ISOM/L-Bibliothek für Serviceautoren:

ISOM/L-Bibliothek
für Serviceautoren

Version 9.10.1.0, IFS Informationstechnik GmbH

  • Hauptseite
  • Zusätzliche Informationen
  • Namensräume

Serviceplattform Taurus®: ISOM/L-Bibliothek für Serviceautoren

Version 9.10.1.0, IFS Informationstechnik GmbH

Autor:

IFS Informationstechnik München, www.ifs-it.de

Einführung

Die Serviceplattform Taurus® ist ein Produkt der IFS Informationstechnik München zur Lösung von Serviceaufgaben im Steuergeräteumfeld. Das primäre Einsatzgebiet ist die Steuergerätetherapie an Fahrzeugen. Durch die Integration kundenspezifischer Komponenten entsteht ein Gesamtprodukt, das den konkreten Bedürfnissen des Kunden entspricht.

Eine zentrale Komponente von Taurus® ist das Integrierte Serviceobjektmodell ISOM, das den Therapiekern von Taurus® bildet. Es stellt ein Ablaufsystem zur Verfügung, das die Steuergerätetherapie durchführt. Teil des Ablaufsystems ist eine Laufzeitumgebung mit einem Interpreter für die Servicesprache ISOM/L.

In ISOM/L werden die genauen Abläufe einer Therapiesitzung definiert. Die Sprache ist auf Serviceautoren zugeschnitten, die das notwendige fachliche Wissen besitzen, um Therapieabläufe beschreiben zu können. Mit ISOM/L können die Therapieabläufe flexibel gestaltet und angepasst werden, ohne dass das Ablaufsystem selbst angepasst werden muss.

Die vorliegende Dokumentation beschreibt die ISOM/L-Bibliothek für Serviceautoren.

Siehe auch:
Seite ISOM-Phasenmodell

Stand: 25 November 2013
IFS Informationstechnik München


für Serviceautoren

  • Hauptseite
  • Zusätzliche Informationen
  • Namensräume

ISOM-Phasenmodell

Die Therapie mit ISOM folgt einem vordefinierten Zustandsmodell.

Jede Phase des Zustandsmodells lässt sich gezielt beeinflussen (inklusive funktional leerlassen).

Die folgende Abbildung zeigt das für Autoren relevante ISOM-Phasenmodell (Stand 07.04.2010):


für Serviceautoren

Zeichenkettenkonstanten

Auflistung und Erläuterung der Zeichenkettenkonstanten für Steuergeräteeigenschaften, die der Fachautor in den ISOM/L-Abläufen verwenden kann.

OEM-übergreifende Eigenschaften

Eigenschaft | Bedeutung | ISOM/L-Bibliothek
"DiagName" | Varianten- bzw. Diagnosename (SGBD-Name) der Steuergerätevariante | GetDiagName ()
"GroupName" | Diagnosegruppendateiname des Steuergeräts; entspricht dem Namen der Gruppen-SGBD. | GetGroupName ()

Regeln

Für künftige Erweiterungen der Eigenschaftsnamen (engl: properties) von Fachobjekten gelten folgende Regeln:

  • Es werden englische Bezeichner verwendet. Ausnahmen sind feststehende Bezeichnungen von Marken oder Programmkomponenten.
  • Eigenschaftsnamen sind "case sensitive", d.h. Groß- und Kleinschreibung wird unterschieden.
  • Eigenschaftsnamen beginnen mit einem Großbuchstaben, jedes weitere Wort der Bezeichnung beginnt ebenfalls mit einem Großbuchstaben (Pascal-Schreibweise).
  • Abkürzungen, die nicht als Wortbestandteile verwendet werden, sondern gewissermaßen freistehend (u.U. zwischen Doppelpunkten) sind, sind in Ihrer üblichen Groß-/Kleinschreibung zu notieren und im Zweifelsfall ganz groß zu schreiben.
  • Durchgängige Großschreibung ist ansonsten nicht zulässig.
  • Die Verwendung von Sonderzeichen außer ":" ist nicht zulässig.

Details

Es folgen einige grundlegende Informationen.

Propertys und semantische Gleichheit von Steuergeräte-Objekten

Property-Namen, die einen ":" enthalten, werden beim semantischen Vergleich von Steuergeräte-Objekten (IsSame-Semantik) nicht berücksichtigt. Daher sollten beim Design neuer Propertys alle Property-Namen, die lediglich erläuternden Charakter haben, der Syntax "<PropertyName>:<Suffix>" folgen. Umgekehr sollten Propertys, die Steuergeräte semantisch unterscheiden, keinen Doppelpunkt enthalten.

Ungesetzte Werte und Leerwerte

Ein Leerstring als Property-Wert wird vom ISOM-Kern grundsätzlich wie ein ungesetzter Wert behandelt.

Aufzählungswerte

Property-Werte, die Kommas enthalten, werden als Aufzählungswerte behandelt. Bei der Prüfung auf semantische Gleichheit kommt eine Teilmengenprüfung zur Anwendung

Schutz von Steuergeräteeigenschaften der Ist-SG-Liste

Der Ist-Kontext soll stets den aus dem Fahrzeug ausgelesenen Zustand repräsentieren. Nur in seltenen Fällen (z.B. Handeingabe) ist hier eine Änderung durch den Autor sinnvoll. Aus Gründen der Prozesssicherheit schützt der ISOM-Kern diese Steuergeräte daher vor direkten Änderungen.

Schemata für Zeichenkettenkonstanten

Für die Bildung von Zeichenkettenkonstanten werden ISOM-intern durchgehend verschiedene syntaktische Formen verwendet, die im Folgenden aufgezählt werden.

  1. Komma-getrennte Werte bezeichnen Aufzählungen, deren Elementereihenfolge i.d.R. keine Rolle spielt.
    • Beispiele: Kanalbezeichner, Diagnoseadressen, ...
  2. Semikolon-getrennte Werte bezeichnen Aufzählungen, deren Elementereihenfolge i.d.R. eine fachliche Rolle spielt.
    • Beispiele: ...
  3. Doppelpunkt-getrennte Werte bezeichnen Schmata. Das jeweils weiter links stehende Element beeinflusst dabei potentiell, wie weiter rechts stehende Werte syntaktisch analysiert und interpretiert werden.
    • Beispiele: ManuallyPlanned:Flash, EcuProp:A:5
  4. Bezeichner mit Hashmark (#) beinhalten i.d.R. eine von ISOM/vom Autor hochgezälten Wert
    • Beispiele: Berichtsabschnitte und -elemente
  5. Darüber hinaus gibt es logische Kontextterm-Ausdrücke, die die folgenden Operatoren unterstützen:
    1. AND
    2. OR
    3. EITHER-OR
    4. Klammerung mit ( und )


für Serviceautoren

Veraltete oder entfernte Elemente

Folgende Elemente sind veraltet und sollten nicht mehr verwendet werden oder wurden entfernt:

Element Isom.Context.Ecu.CreateNewByGroupName(Isom.Base.String groupName)
Ist spezifisch für das Laufzeitsystem EDIABAS und wird seit Version 15 von Argonaut nur noch aus Kompatibilitätsgründen unterstützt; Aufruf sollte ersetzt werden durch Aufrufe von Isom.Context.Ecu.CreateNewByAddress() mit anschließendem Isom.Context.Ecu.SetProp("GroupName").
Element Isom.Context.Ecu.GetGroupName()
Ist spezifisch für das Laufzeitsystem EDIABAS und wird seit Version 15 von Argonaut nur noch aus Kompatibilitätsgründen unterstützt; Aufruf sollte ersetzt werden durch Aufruf von Isom.Context.Ecu.GetProp("GroupName").
Element Isom.Context.Ecu.SetGroupName(Isom.Base.String newGroupName)
Ist spezifisch für das Laufzeitsystem EDIABAS und wird seit Version 15 von Argonaut nur noch aus Kompatibilitätsgründen unterstützt; Aufruf sollte ersetzt werden durch Aufruf von Isom.Context.Ecu.SetProp("GroupName").
Element Isom.Context.Ecu.GetAllPropertyNames()
Wird seit Version 6.5.0.0 nur noch aus Kompatibilitätsgründen unterstützt. Der Abruf der Eigenschaftsnamen wird seitdem durch die Funktionen Isom.Context.Ecu.GetPropNames() und Isom.Context.Ecu.GetDisplayPropNames() bereitgestellt.
Element Isom.Context.Ecu.GetGateway()
Entfernt seit Argonaut Version 1.10. Diese Funktion ist nicht mehr Bestandteil der Fachklasse "Ecu".
Element Isom.Plan.TherapyPlanAction.Purge()
Veraltet seit Argonaut 1.10. TherapyPlanAction.Purge() soll in künftigen Versionen durch Mechanismen ersetzt werden, die auf TherapyPlanAction.RemoveFromPlan() basieren.
Element Isom.Plan.ActionPlan.GetAllPropertyNames()
Wird seit Version 6.5.0.0 nur noch aus Kompatibilitätsgründen unterstützt. Der Abruf der Eigenschaftsnamen wird seitdem durch die Funktion Isom.Context.Ecu.GetPropertyNames() bereitgestellt.
Element Isom.Request.UserRequest.UpdateRequest(Isom.Request.MessageElement message)
Veraltet seit Argonaut 1.9. Stattdessen UpdateMessage() verwenden.
Element Isom.Global.Processes.CompleteTherapyPlan()
Veraltet seit Argonaut 1.5. Dieser Einsprungspunkt wird nur aus Gründen der Rückwärtskompatibilität unterstützt. Die Planvervollständigung sollte stattdessen in CalculateFinalPlan() erfolgen.
Element Isom.Exchange.DataDescription.IsRequired()
Veraltet seit Argonaut 1.17.
Element Isom.Exchange.DataDescription.SetRequired(Isom.Base.Boolean required)
Veraltet seit Argonaut 1.17.
Element Isom.Context.ContextConfiguration.GetDataIntegrationLevel()
Veraltet seit Argonaut 1.17
Element Isom.Context.ContextConfiguration.SetDataIntegrationLevel(Isom.Base.String newDataIntegrationLevel)
Veraltet seit Argonaut 1.17


für Serviceautoren

  • Liste der Namensräume
  • Liste der Funktionen
  • Liste der Annotationen

Liste der Namensräume

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom |
Isom.Base |
Isom.Base.Boolean | Aussagenlogische Wahrheitswerte
Isom.Base.Data | strukturierte Daten
Isom.Base.DataList | Listen aus Datenobjekten des Typs Isom.Base.Data
Isom.Base.Date | Datums- und Zeitangaben
Isom.Base.Number | Zahlen
Isom.Base.NumberList | Listen von Zahlen des Typs Isom.Base.Number
Isom.Base.RegEx | reguläre Ausdrücke
Isom.Base.String | Zeichenketten
Isom.Base.StringDictionary | Wörterbücher mit Zeichenketteneinträgen vom Typ Isom.Base.String
Isom.Base.StringList | Listen von Zeichenketten des Typs Isom.Base.String
Isom.Base.Uri | URIs (Uniform Resource Identifiers)
Isom.Base.UriDictionary | Wörterbücher mit URI-Einträgen vom Typ Isom.Base.Uri
Isom.Base.Version | Repräsentiert einer Versionsnummer
Isom.Checkpoint |
Isom.Checkpoint.CheckpointProcesses | Funktionen zum Erstellen und Wiederherstellen von Checkpoints
Isom.Checkpoint.VehicleCheckpoint | Erstellen eines Checkpoints
Isom.Checkpoint.VehicleRestore | Wiederherstellen eines Fahrzeugzustandes anhand eines Checkpoints
Isom.Context |
Isom.Context.ContextConfiguration | Fachklasse für Grundmerkmale des Fahrzeugs
Isom.Context.CurrentVehicleContext | Fachklasse für den Istkontext
Isom.Context.Dtc | Fachobjekt für einen Fehlerspeichereintrag
Isom.Context.DtcList | Liste von Fehlerspeichereintragobjekten des Typs Isom.Context.Dtc.
Isom.Context.Ecu | Fachobjekt für ein Steuergerät
Isom.Context.EcuList | Listen von Steuergeräteobjekten des Typs Isom.Context.Ecu.
Isom.Context.Environment | Zugriff auf Kommunikation mit dem Fahrzeugzugang und für Spannungsprüfungen
Isom.Context.FutureVehicleContext | Fachobjekt für den Soll-Kontext
Isom.Context.LogicalUnit | Repräsentiert eine logische Einheit
Isom.Context.LogicalUnitList | Listen logischer Einheiten des Typs Isom.Context.LogicalUnit
Isom.Context.LogicalVehicle | Fachobjekt für ein logisches Fahrzeug
Isom.Context.LogicalVehicleList | Listen von Fachobjekten des Typs Isom.Context.LogicalVehicle.
Isom.Context.MockupFactory | Erzeugung von Fachobjektattrappen aus Beschreibungsdateien
Isom.Context.UserProfile | Fachobjekt für das Benutzerprofil
Isom.Context.UserProfileOption | Benutzerprofil-Optionen
Isom.Context.UserProfileOptionList | Listen von Benutzerprofil-Optionen des Typs Isom.Context.UserProfileOption
Isom.Context.UserProfileSetting | Benutzerprofil-Einstellungen
Isom.Context.UserProfileSettingList | Listen von Benutzerprofil-Einstellungen des Typs Isom.Context.UserProfileSetting
Isom.Context.VehicleOrder | Fachobjekt für einen Fahrzeugauftrag
Isom.Diagnostics |
Isom.Diagnostics.MeasuredValue | Messwerte
Isom.Diagnostics.Measurement | Fachfunktionen für Liste von Messwerten des Typs Isom.Diagnostics.MeasuredValue
Isom.Diagnostics.MeasurementList | Listen von Messwerten des Typs Isom.Diagnostics.Measurement
Isom.Exchange |
Isom.Exchange.DataDescription | Datenbeschreibungen, durch die Daten gesichert und geladen werden können
Isom.Exchange.DataDescriptionList | Listen von Datenbeschreibungen der Fachklasse Isom.Exchange.DataDescription
Isom.Exchange.DataExchange | Interaktion mit der Datenaustauschschnittstelle zur Verwaltung abgelegter Datensätze.
Isom.Exchange.DataHandle | Identifikator für Daten, die über die Datenaustauschschnittstelle von ISOM gelesen und geschrieben werden können
Isom.Global |
Isom.Global.Config | Zugriff auf allgemeine Konfigurationsparameter von ISOM.
Isom.Global.Controller | Zugriff auf die steuernde Schnittstelle von ISOM.
Isom.Global.Processes | Einsprungspunkte und Rückruffunktionen
Isom.Plan |
Isom.Plan.ActionPlan | Fachobjekt für den Aktionsplan
Isom.Plan.ActionPlanPhase | Aktionsplanphasen
Isom.Plan.ActivationCode | Freischaltcodes (Software-Freischaltung, Airbag etc.)
Isom.Plan.ActivationCodeList | Listen von Freischaltcodes
Isom.Plan.OrderingInfo | Bestellinformationen
Isom.Plan.OrderingInfoList | Listen von Bestellinformationen
Isom.Plan.TherapyPlan | Fachobjekt des Therapieplans
Isom.Plan.TherapyPlanAction | Fachobjekt für eine Therapieplanaktion
Isom.Plan.TherapyPlanActionList | Liste von Therapieplanaktionen.
Isom.Reporting |
Isom.Reporting.Report | Berichtsdaten für ein formatiert druckbares Dokument.
Isom.Reporting.ReportSection | Berichts-Absatz (logisches Gliederungs-Element/Struktureller Abschnitt von Berichtsdaten).
Isom.Reporting.ReportSectionList | Liste von Report-Abschnitten des Typs Isom.Reporting.ReportSection
Isom.Request |
Isom.Request.Button | Schaltflächenelemente bei Eingabeaufforderungen
Isom.Request.ButtonList | Listen von BO-Schaltflächen des Typs Isom.Request.Button
Isom.Request.MeasuredValue | Messwerte
Isom.Request.Measurement | Fachfunktionen für Liste von Messwerten des Typs Isom.Request.MeasuredValue
Isom.Request.MeasurementList | Listen von Messwerten des Typs Isom.Request.Measurement
Isom.Request.MediaElement | Medienobjekt
Isom.Request.MediaList | Listen von Medienobjekten des Typs Isom.Request.MediaElement
Isom.Request.MessageElement | Dialogelement bei Eingabeaufforderungen
Isom.Request.MessageList | Listen von Dialogelementen des Typs Isom.Request.MessageElement
Isom.Request.Option | Auswahldialoge in Benutzerinteraktionen
Isom.Request.RadioButton | Fachobjekt für Radiobuttons in Assistenten
Isom.Request.SelectionGroup | Auswahlgruppenelemente in Benutzerinteraktionen
Isom.Request.SelectionGroupList | Listen von Auswahlgruppen in Benutzerinteraktionen des Typs Isom.Request.SelectionGroup
Isom.Request.UserRequest | Dialogfenster in Benutzerinteraktionen
Isom.Request.Wizard | Fachobjekt für Assistenten
Isom.Security |
Isom.Security.SecurityProvider | Sicherheitsaufgaben wie zum Beispiel Freischaltung bzw.
Isom.Services |
Isom.Services.Asam | ASAM-Job-Aufrufe
Isom.Services.AsamParameter | Parameter eines ASAM-Jobs oder -Diensts.
Isom.Services.AsamParameterList | Liste von ASAM-Parametern.
Isom.Services.AsamResponseList | Liste von ASAM-Antworten.
Isom.Services.DataProcurement | Zugriff auf allgemeine Informationen der Datenbeschaffung
Isom.Services.Ediabas | EDIABAS-Job-Aufrufe
Isom.Services.EdiabasResultSet | Ergebnisse bei EDIABAS-Job-Aufrufen als Tabelle
Isom.Services.EdiabasResultSetList | Listen von EDIABAS-Ergebnismengen des Typs Isom.Services.EdiabasResultSet
Isom.Services.ServiceManager | Fachobjekt für Informationen zum Fachdienstzugriff
Isom.Sys |
Isom.Sys.CallProfile | Zugriff auf gemessene Zeiten ausgeführter Funktionen
Isom.Sys.ClientData | Informationen über einen beobachtenden oder steuernden Client.
Isom.Sys.ClientDataList | Listen aus Client-Informationen des Typs Isom.Sys.ClientData
Isom.Sys.Contract | Zugriff auf Vertragsinformationen innerhalb abgefragter Händlerdaten
Isom.Sys.ContractList | Liste von Vertragsinformationen des Typs Isom.Sys.Contract
Isom.Sys.Dealer | Zugriff auf Händlerinformationen
Isom.Sys.Error | Fehlerbeschreibungen
Isom.Sys.ErrorHistory | Zugriff auf die Fehlergeschichte.
Isom.Sys.ErrorList | Listen von Fehlerbeschreibungen des Typs Isom.Sys.Error
Isom.Sys.Events |
Isom.Sys.Events.Event | Auslösen von Ereignissen durch den Autor
Isom.Sys.Events.EventInfo | Beschreibung eines Ereignisses
Isom.Sys.Events.EventListener | Fachobjekt für Beobachter von Events
Isom.Sys.Events.Guard | Zugriff auf Wächterfunktionen
Isom.Sys.Events.GuardInfo | Stellt eine Beschreibung eines Wächter-Rückrufs bereit
Isom.Sys.Events.PeriodicTimer | Fachobjekt für periodisch auslösende Zeitgeber
Isom.Sys.Events.Timer | Fachobjekt für einmal auslösende Zeitgeber ("Wecker")
Isom.Sys.Events.TimerInfo | Stellt eine Beschreibung eines Zeitgeber-Rückrufs bereit
Isom.Sys.FunctionInfo | Zugriff auf die gemessene Zeiten aller Ausführungen einer Funktion
Isom.Sys.Log | Zugriff auf die Ereignisaufzeichung
Isom.Sys.Protocol | Erzeugung eines Sitzungsprotokoll der Therapiesitzung und Zugriff auf Protokollarchive.
Isom.Sys.RuntimeInfo | Zugriff auf gemessene Zeiten ausgeführter Funktionen
Isom.Sys.SessionContext | Fachobjekt für den Sitzungskontext
Isom.Sys.System | Zugriff auf allgemeine Systemressourcen
Isom.Sys.SystemInfo | Zugriff auf allgemeine Informationen über den Rechner und die Systemumgebung
Isom.Sys.VersionInfo | Informationen über die Versionskennung der Programmierapplikation


für Serviceautoren

Namensraum Isom

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Base
Isom.Checkpoint
Isom.Context
Isom.Diagnostics
Isom.Exchange
Isom.Global
Isom.Plan
Isom.Reporting
Isom.Request
Isom.Security
Isom.Services
Isom.Sys


für Serviceautoren

Isom.Base

Namensraum Isom.Base

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Base.Boolean | Aussagenlogische Wahrheitswerte
Isom.Base.Data | strukturierte Daten
Isom.Base.DataList | Listen aus Datenobjekten des Typs Isom.Base.Data
Isom.Base.Date | Datums- und Zeitangaben
Isom.Base.Number | Zahlen
Isom.Base.NumberList | Listen von Zahlen des Typs Isom.Base.Number
Isom.Base.RegEx | reguläre Ausdrücke
Isom.Base.String | Zeichenketten
Isom.Base.StringDictionary | Wörterbücher mit Zeichenketteneinträgen vom Typ Isom.Base.String
Isom.Base.StringList | Listen von Zeichenketten des Typs Isom.Base.String
Isom.Base.Uri | URIs (Uniform Resource Identifiers)
Isom.Base.UriDictionary | Wörterbücher mit URI-Einträgen vom Typ Isom.Base.Uri
Isom.Base.Version | Repräsentiert einer Versionsnummer


für Serviceautoren

Isom.Base.Boolean

Namensraum Isom.Base.Boolean

Aussagenlogische Wahrheitswerte Mehr...

Funktionen
Isom.Base.Boolean | And(Isom.Base.Boolean other)

Diese Funktion berechnet das logische UND aus dem aktuellen Element und einem zweiten Wahrheitswert.

Isom.Base.Boolean | Failed()

Prüft, ob das aktuelle Element entweder identisch zu false oder Void ist.

Isom.Base.Boolean | Not()

Diese Funktion liefert den Wahrheitswert, der der Negation des aktuellen Elements entspricht.

Isom.Base.Boolean | Or(Isom.Base.Boolean other)

Berechnet das logische ODER aus dem aktuellen Element und einem zweiten Wahrheitswert.

Isom.Base.Boolean | Xor(Isom.Base.Boolean other)

Berechnet das logische exklusive ODER aus dem aktuellen Element und einem zweiten Wahrheitswert.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | Clone()

Liefert das aktuelle Objekt.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob das aktuelle Element das Void-Objekt ist.

Isom.Base.Boolean | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Der Typ Isom.Base.Boolean enthält die Wahrheitswerte true und false, kann aber zusätzlich auch den Wert Void annehmen.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Base\Boolean.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Base.Boolean.And ( Isom.Base.Boolean other )

Diese Funktion berechnet das logische UND aus dem aktuellen Element und einem zweiten Wahrheitswert.

 Isom.Base.Boolean a = true;
 Isom.Base.Boolean b = false;
 Isom.Base.Boolean c = a.And(b);   // c ist false
Achtung:
Im Gegensatz zu den meisten anderen ISOM/L Funktionen wird hierdurch das aktuelle Element nicht verändert.
Parameter:
other zweiter Wahrheitswert der Operation
Rückgabe:
'true', falls beide Werte 'true' sind, 'false' sonst.
[Isom\Base\Boolean.is: 107]
objectbound Isom.Base.Boolean Isom.Base.Boolean.Clone ( )

Liefert das aktuelle Objekt.

Da ISOM-Objekte des Typs Isom.Base.Boolean nur als zwei statische Instanzen für die Werte 'true' und 'false' existieren, wird keine Kopie zu erzeugt.

Rückgabe:
das aktuelle Objekt
[Isom\Base\Boolean.is: 211]
objectbound Isom.Base.Boolean Isom.Base.Boolean.Failed ( )

Prüft, ob das aktuelle Element entweder identisch zu false oder Void ist.

Diese fachlich motivierte Hilfsoperation dient primär dazu, den Rückgabewert typischer Fachfunktionen zu prüfen. Diese geben normalerweise false im Falle eines "erwartbaren" Fehlschlagens (z.B. SG antwortet nicht) und Void im Falle unerwarteter Zustände (z.B. kein Fahrzeug verbunden) zurück. Eine Auswertung der Form

 if (currentContext.ReadIntegrationLevel().Not())
 {
    // Fehlerbehandlung
 }

wird die Fehlerbehandlung nicht ausführen, wenn ReadIntegrationLevel() Void liefert, da auf Void (="unerwartet") keine Operation (auch nicht .Not()) aufgerufen wird. Stattdessen führt

 if (currentContext.ReadIntegrationLevel().Failed())
 {
       // Fehlerbehandlung
 }

auch bei Void als Ergebnis zur Ausführung der Fehlerbehandlung.

Rückgabe:
'true', falls das aktuelle Element der Wahrheitswert false oder Void ist, 'false' sonst.
[Isom\Base\Boolean.is: 182]
objectbound Isom.Base.Boolean Isom.Base.Boolean.IsVoid ( )

Bestimmt, ob das aktuelle Element das Void-Objekt ist.

Rückgabe:
'true', falls das aktuelle Element das Void-Objekt ist, 'false' sonst.
[Isom\Base\Boolean.is: 200]
objectbound Isom.Base.Boolean Isom.Base.Boolean.Not ( )

Diese Funktion liefert den Wahrheitswert, der der Negation des aktuellen Elements entspricht.

 Isom.Base.Boolean a = true;
 Isom.Base.Boolean b = a.Not();   // b ist false
Achtung:
Im Gegensatz zu den meisten anderen ISOM/L Funktionen wird hierdurch das aktuelle Element nicht verändert.
Rückgabe:
Wahrheitswert, welcher der Negation dieses Wahrheitswertes entspricht.
[Isom\Base\Boolean.is: 87]
objectbound Isom.Base.Boolean Isom.Base.Boolean.Or ( Isom.Base.Boolean other )

Berechnet das logische ODER aus dem aktuellen Element und einem zweiten Wahrheitswert.

 Isom.Base.Boolean a = true;
 Isom.Base.Boolean b = false;
 Isom.Base.Boolean c = a.Or(b);   // c ist true
Achtung:
Im Gegensatz zu den meisten anderen ISOM/L Funktionen wird hierdurch das aktuelle Element nicht verändert.
Parameter:
other zweiter Wahrheitswert der Operation
Rückgabe:
'true', falls einer der beiden Werte 'true' ist, 'false' sonst.
[Isom\Base\Boolean.is: 127]
Isom.Base.Boolean Isom.Base.Boolean.Void ( )

Erzeugt ein Void-Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

Rückgabe:
Void-Objekt
[Isom\Base\Boolean.is: 221]
objectbound Isom.Base.Boolean Isom.Base.Boolean.Xor ( Isom.Base.Boolean other )

Berechnet das logische exklusive ODER aus dem aktuellen Element und einem zweiten Wahrheitswert.

 Isom.Base.Boolean a = true;
 Isom.Base.Boolean b = false;
 Isom.Base.Boolean c = a.Xor(b);   // c ist true
Achtung:
Im Gegensatz zu den meisten anderen ISOM/L Funktionen wird hierdurch das aktuelle Element nicht verändert.
Parameter:
other zweiter Wahrheitswert der Operation
Rückgabe:
'true', falls das aktuelle Element und der übergebene Parameter nicht identische Wahrheitswerte sind, 'false' sonst
[Isom\Base\Boolean.is: 147]


für Serviceautoren

Isom.Base.Data

Namensraum Isom.Base.Data

strukturierte Daten Mehr...

Funktionen
Isom.Base.Boolean | AddAttribute(Isom.Base.String name, Isom.Base.String attr)

Fügt dem Datenobjekt ein Attribut hinzu.

Isom.Base.Boolean | AddElement(Isom.Base.Data value)

Fügt dem Datenobjekt ein unmittelbares Kindelement hinzu.

Isom.Base.DataList | FindElements(Isom.Base.String path)

Sucht mit einem XPath-Ausdruck nach untergeordneten Datenobjekten.

Isom.Base.String | GetAttribute(Isom.Base.String name)

Ruft ein Attribut ab.

Isom.Base.StringDictionary | GetAttributes()

Ruft alle Attribute ab.

Isom.Exchange.DataHandle | GetDataHandle()

Gibt ein DataHandle für das Data-Objekt zurück.

Isom.Base.DataList | GetElements(Isom.Base.String name)

Ruft bestimmte Kindelemente ab.

Isom.Base.String | GetText()

Ruft das Textelement des Datenobjekts ab.

Isom.Base.Boolean | IsValid(Isom.Base.Uri schema)

Validiert das Datenobjekt gegen ein XML-Schema.

Isom.Base.StringList | Query(Isom.Base.StringList paths)

Sucht in den Daten nach bestimmten Einträgen.

Isom.Base.Boolean | RemoveAttribute(Isom.Base.String name)

Entfernt ein Attribut.

Isom.Base.Boolean | RemoveElements(Isom.Base.String path)

Sucht mit einem XPath-Ausdruck nach Datenobjekten und entfernt sie.

Isom.Base.Boolean | RemoveText()

Entfernt das Textelement.

Isom.Base.Boolean | SetNamespaces(Isom.Base.StringDictionary mapping)

Registriert Präfixe für XML-Namesräume, die in XPath-Ausdrücken verwendet werden können

Isom.Base.Boolean | SetNewLineOnXmlAttribute(Isom.Base.Boolean newLine)

Ändert das Format der XML-Attribute.

Isom.Base.Boolean | SetText(Isom.Base.String text)

Setzt das Textelement des Datenobjekts.

Isom.Base.String | ToXml()

Gibt den Inhalt des Datenobjekt als XML-Zeichenkette wieder.

Isom.Base.Boolean | WriteXml(Isom.Base.Uri path)

Schreibt die Daten als XML.

Namensraumfunktionen für die Erzeugung

Funktionen, mit denen Datenobjekte erzeugt werden können

Isom.Base.Data | Create(Isom.Base.String name)

Erzeugt ein neues, leeres Datenobjekt.

Isom.Base.Data | CreateFromXml(Isom.Base.String content)

Erzeugt ein neues Datenobjekt aus einer Zeichenketten.

Isom.Base.Data | CreateWithNamespace(Isom.Base.String name, Isom.Base.String ns)

Erzeugt ein neues, leeres Datenobjekt in einem Namensraum.

Isom.Base.Data | LoadText(Isom.Base.Uri path)

Erzeugt ein neues Datenobjekt aus einer Textdatei ohne hierarchische Struktur.

Isom.Base.Data | LoadXml(Isom.Base.Uri path)

Erzeugt ein neues Datenobjekt aus einer XML-Datei.

Funktionen für globale Objekte

Funktionen, mit denen die globale Ablage von Objekten ermöglicht wird.

Isom.Base.Boolean | AddGlobal(Isom.Base.String key, Isom.Base.Data value)

Speichert eine Kopie dieses Datenobjekts als globale Variable.

Isom.Base.StringList | GetExistingGlobals()

Ruft die Liste der Schlüssel der globalen Datenobjekte ab.

Isom.Base.Data | GetGlobal(Isom.Base.String key)

Ruft ein globales Datenobjekt ab.

Isom.Base.Boolean | RemoveGlobal(Isom.Base.String key)

Entfernt ein globales Datenobjekt.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Data | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Base.Data | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Mit dem Typ Isom.Base.Data lassen sich in ISOM/L Datenstrukturen erzeugen. Die Strukturen können als XML-Dateien gespeichert und aus den Dateien wieder geladen werden.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Base\Data.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Base.Data.AddAttribute | ( | Isom.Base.String | name,
 |  | Isom.Base.String | attr
 | ) |  |

Fügt dem Datenobjekt ein Attribut hinzu.

Falls ein Attribut mit diesem Namen bereits existiert, wird es ersetzt.

Zu beachten:
Wenn ein Attribut ein Präfix verwendet (z.B. xsi:noNamespaceSchemaLocation), dann muss zuvor der Namensraum für das Präfix deklariert worden sein. Ausnahmen davon sind die Standard-Präfixe 'xml' und 'xmlns'.
 Data data = Data.Create("A");
 // Namensraum für Präfix 'xsi' deklarieren (mit Standard-Präfix 'xmlns')
 data.AddAttribute ("xmlns:xsi", "http://www.w3.org/2001/XMLSchema-instance");
 // Präfix 'xsi' verwendet
 data.AddAttribute ("xsi:noNamespaceSchemaLocation", "Beispiel.xsd");

 // <A xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
 //    xsi:noNamespaceSchemaLocation="Beispiel.xsd" />
Parameter:
name | Name des Attributs.
attr | Wert des Attributs.
Rückgabe:
'true', falls das Attribut hinzugefügt werden konnte, 'false', falls der Name oder der Wert das Void-Objekt ist oder falls ein Präfix für einen nicht deklarierten Namensraum verwendet wird.
[Isom\Base\Data.is: 380]
objectbound Isom.Base.Boolean Isom.Base.Data.AddElement ( Isom.Base.Data value )

Fügt dem Datenobjekt ein unmittelbares Kindelement hinzu.

Das übergebene Datenobjekt wird als letztes Kindelement in die Liste der Kinder des Zielelements eingefügt.

 Data data = Data.Create("A");
 Data childElement = Data.Create("B");
 data.AddElement(childElement); // "B" ist jetzt Kindelement von "A"
 Data childChildElement = Data.Create("C");
 childElement.AddElement(childChildElement); // "C" ist jetzt Kindelement von "B"
Parameter:
value Datenobjekt des Elements.
Rückgabe:
'true', falls das Element hinzugefügt werden konnte, 'false', falls das Datenobjekt das Void-Objekt ist.
[Isom\Base\Data.is: 348]
Isom.Base.Boolean Isom.Base.Data.AddGlobal | ( | Isom.Base.String | key,
 |  | Isom.Base.Data | value
 | ) |  |

Speichert eine Kopie dieses Datenobjekts als globale Variable.

Die übergebene Zeichenkette ist der Schlüssel, mit dem die gespeicherte Variable danach mit .GetGlobal() abgerufen werden kann. Existiert bereits eine globale Variable mit dem Schlüssel, wird der vorher gesicherte Wert ersetzt.

 Data data = Data.Create("A");
 Data.AddGlobal("A", data);
Parameter:
key | Schlüssel, mit dem das Objekt als globale Variable gespeichert wird.
value | Datenobjekts, das gespeichert wird.
Rückgabe:
'true', falls das Datenobjekts als globale Variable gespeichert werden konnte, 'false' sonst (z.B. bei einem ungültigen Objekt für Schlüssel oder Wert).
[Isom\Base\Data.is: 254]
objectbound Isom.Base.Data Isom.Base.Data.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Rückgabe:
Kopie dieses Objekts.
[Isom\Base\Data.is: 796]
Isom.Base.Data Isom.Base.Data.Create ( Isom.Base.String name )

Erzeugt ein neues, leeres Datenobjekt.

Das neu erzeugte Datenobjekt eintspricht einem XML-Knoten mit dem übergebenen Namen.

 Data data = Data.Create("A");
Parameter:
name Name des Datenobjekts.
Rückgabe:
Leeres Datenobjekt.
[Isom\Base\Data.is: 118]
Isom.Base.Data Isom.Base.Data.CreateFromXml ( Isom.Base.String content )

Erzeugt ein neues Datenobjekt aus einer Zeichenketten.

Die Zeichenkette muss gültiges XML sein. Sie kann mit einer XML-Deklaration beginnen (vollständige XML-Datei) oder nur ein Fragment enthalten (einzelner XML-Knoten). Eine ggf. vorhandene XML-Deklaration wird nicht in das Datenobjekt übernommen.

 String xml = "<Root><Entry>Inhalt</Entry></Root>";
 Data data = Data.CreateFromXml(xml);
Parameter:
content XML als Zeichenkette
Rückgabe:
Das aus der Zeichenkette erzeugte Datenobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Zeichenkette nicht konvertiert werden konnte.
[Isom\Base\Data.is: 223]
Isom.Base.Data Isom.Base.Data.CreateWithNamespace | ( | Isom.Base.String | name,
 |  | Isom.Base.String | ns
 | ) |  |

Erzeugt ein neues, leeres Datenobjekt in einem Namensraum.

Das neu erzeugte Datenobjekt eintspricht einem XML-Knoten mit dem übergebenen Namen, der dem angegebenen Namensraum zugeordnet ist.

 Data data = Data.CreateWithNamespace("A", "http://www.ifs.it/irgendwo");

 data.WriteXml(...);
 // <A xmlns="http://www.ifs.it/irgendwo" />

Wenn für einen Namensraum bereits ein Alias definiert ist, kann man dieses Alias als Präfix für den Namen verwenden. Der Namensraum wird dann im XML-Dokuemnt nicht noch einmal ausgegeben.

 Data root = Data.CreateWithNamespace("A");
 // Präfix 'ifs' definieren
 root.AddAttribute("xmlns:ifs", "http://www.ifs.it/irgendwo");
 // Präfix 'ifs' verwenden (Namensraum muss auch angegeben werden!)
 Data data = Data.CreateWithNamespace("ifs:B", "http://www.ifs.it/irgendwo");
 root.AddElement(data);

 root.WriteXml(...);
 // <A xmlns:ifs="http://www.ifs.it/irgendwo">
 //     <!-- Namensraum wird im XML-Dokument nur einmal ausgegeben -->
 //     <ifs:B />
 // </A>
Parameter:
name | Name des Datenobjekts.
name | Namensraum des Datenobjekts.
Rückgabe:
Leeres Datenobjekt.
[Isom\Base\Data.is: 159]
objectbound Isom.Base.DataList Isom.Base.Data.FindElements ( Isom.Base.String path )

Sucht mit einem XPath-Ausdruck nach untergeordneten Datenobjekten.

Es werden alle untergeordneten Datenobjekte zurückgegeben, die zu dem XPath-Ausdruck passen.

 Data data = Data.Create("A");
 Data childElement = Data.Create("B");
 Data childElement2 = Data.Create("C");
 childElement.AddElement(childElement2);
 data.AddElement(childElement);
 DataList elements = data.FindElements("A/C");    // elements enthält nur das Datenobjekt childElement2
Parameter:
path XPath-Ausdruck Der XPath-Ausdruck muss bei der Auswertung eine Knotenliste ergeben. Alle gefundenen Element-Knoten werden in das Ergebnis übernommen. Andere Knoten (z.B. Attribute) werden ignoriert.
Rückgabe:
Liste der Elemente, die dem übergebenen XPath-Ausdruck entsprechen.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der XPath-Ausdruck das Void-Objekt oder leer ist.
Es wird das Void-Objekt zurückgegeben, falls der XPath-Ausdruck ungültig ist oder nicht in einer Knotenliste resultiert.
[Isom\Base\Data.is: 511]
objectbound Isom.Base.String Isom.Base.Data.GetAttribute ( Isom.Base.String name )

Ruft ein Attribut ab.

Ruft das benannte Attribut des Datenelements ab.

 Data data = Data.Create("A");
 data.AddAttribute("X", "1");
 String val = data.GetAttribute("X");    // val ist "1"
 String val = data.GetAttribute("Y");    // val ist Void
Parameter:
name Name des Attributs.
Rückgabe:
Wert des Attributs.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der übergebene Name das Void-Objekt ist oder das Datenobjekt kein Attribut mit dem Namen besitzt.
[Isom\Base\Data.is: 439]
objectbound Isom.Base.StringDictionary Isom.Base.Data.GetAttributes ( )

Ruft alle Attribute ab.

Ruft alle Attribute des Datenobjekts als Wörterbuch ab.

 Data data = Data.Create("DataWithAttribute");
 data.AddAttribute("A", "1");
 data.AddAttribute("B", "2");
 StringDictionary attributes = data.GetAttributes();    // attributes enthält die Einträge ("A", "1") und ("B", "2")
Rückgabe:
Zuordnung der Namen aller Attribute des Datenobjekts zu ihren Werten.
[Isom\Base\Data.is: 457]
objectbound Isom.Exchange.DataHandle Isom.Base.Data.GetDataHandle ( )

Gibt ein DataHandle für das Data-Objekt zurück.

Der Inhalt, den das DataHandle referenziert, entspricht dem aktuellen Stand des Data-Objekts. Spätere Änderungen werden nicht in den Inhalt des DataHandle-Objekts übernommen.

Rückgabe:
'Isom.Exchange.DataHandle'
[Isom\Base\Data.is: 770]
objectbound Isom.Base.DataList Isom.Base.Data.GetElements ( Isom.Base.String name )

Ruft bestimmte Kindelemente ab.

Ruft für ein Datenobjekt dessen unmittelbare Kindelemente mit dem übergebenen Namen ab.

 Data data = Data.Create("A");
 Data childElement = Data.Create("B");
 data.AddElement(childElement);
 Data childChildElement = Data.Create("C");
 childElement.AddElement(childChildElement);   // "C" ist jetzt Kindelement von "B"
 DataList elementsB = data.GetElements("B");    // elementsB enthält nur das Datenobjekt childElement
 DataList elementsC = data.GetElements("C");    // elementsC ist eine leere Liste
Parameter:
name Name der abgerufenen unmittelbaren Kind-Datenobjekte.
Rückgabe:
Unmittelbare Kind-Datenobjekte mit dem übergebenen Namen.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der übergebene Name das Void-Objekt ist.
[Isom\Base\Data.is: 482]
Isom.Base.StringList Isom.Base.Data.GetExistingGlobals ( )

Ruft die Liste der Schlüssel der globalen Datenobjekte ab.

Ruft eine Liste der Schlüssel aller globalen Variablen des Typs 'Data' ab

   Data data = Data.Create("A");
   Data.AddGlobal("A", data);
   data = Data.Create("B");
   Data.AddGlobal("B", data);
   StringList keys = Data.GetExistingGlobals(); // enthält "A" und "B"
Rückgabe:
Liste der Schlüssel aller globalen Variablen des Typs 'Data'
[Isom\Base\Data.is: 320]
Isom.Base.Data Isom.Base.Data.GetGlobal ( Isom.Base.String key )

Ruft ein globales Datenobjekt ab.

Ruft das Datenobjekt ab, das unter dem übergebenen Schlüssel als globale Variable gesichert wurde.

 Data value = Data.GetGlobal("A");
Parameter:
key Schlüssel der gesuchten globalen Variable.
Rückgabe:
Kopie des gefundenen Variablenwerts. Änderungen an diesem Rückgabewert ändern den Wert der gesicherten globalen Variable nicht. Um Änderungen in die globale Variable zu übernehmen, muss der geänderte Wert mit .AddGlobal() wieder gesichert werden.
Ausnahmebehandlung:
Die Funktion liefert ein Void-Objekt, falls innerhalb dieser Sitzung noch keine Variable unter dem Schlüssel abgespeichert wurde oder der Schlüssel ein ungültiges Objekt ist.
[Isom\Base\Data.is: 299]
objectbound Isom.Base.String Isom.Base.Data.GetText ( )

Ruft das Textelement des Datenobjekts ab.

Ruft das Textelement des Datenobjekts ab.

 Data data = Data.Create("A");
 data.SetText("abc");
 String text = data.GetText();    // text ist "abc"
Rückgabe:
Das Textelement des Datenobjekts.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls dieses Datenobjekt keinen Textwert besitzt.
[Isom\Base\Data.is: 399]
objectbound Isom.Base.Boolean Isom.Base.Data.IsValid ( Isom.Base.Uri schema )

Validiert das Datenobjekt gegen ein XML-Schema.

Validiert das Datenobjekt gegen ein XML-Schema.

 Data data = Data.LoadXml(uriFile);
 Boolean valid = data.IsValid(uriSchema);
Parameter:
schema XML-Schemadatei
Rückgabe:
'true', falls das Datenobjekt dem XML-Schema entspricht, sonst 'false'
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Parameter 'schema' kein güliges XML-Schema referenziert.
[Isom\Base\Data.is: 659]
objectbound Isom.Base.Boolean Isom.Base.Data.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Base\Data.is: 788]
Isom.Base.Data Isom.Base.Data.LoadText ( Isom.Base.Uri path )

Erzeugt ein neues Datenobjekt aus einer Textdatei ohne hierarchische Struktur.

Der Inhalt der Textdatei wird in einem neu angelegten Datenobjekt mit dem Namen @i Text abgelegt.

 Uri uri = Isom.Base.Uri.DefineUri( "http://localhost/pathA/pathB/file.txt" );
 Data data = Data.LoadText(uri);
 String filecontent = data.GetText();
Parameter:
path URI-Pfadangabe zu der Textdatei.
Rückgabe:
Das aus der Textdatei erzeugte Datenobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Datei nicht geladen werden konnte.
[Isom\Base\Data.is: 201]
Isom.Base.Data Isom.Base.Data.LoadXml ( Isom.Base.Uri path )

Erzeugt ein neues Datenobjekt aus einer XML-Datei.

Der Inhalt des XML-Dokumentknotens der Datei wird dem neu erzeugten Datenobjekt zugewiesen. Die XML-Deklaration wird nicht übernommen.

 Uri uri = Isom.Base.Uri.DefineUri( "http://localhost/pathA/pathB/file.xml" );
 Data data = Data.LoadXml(uri);
Parameter:
path URI-Pfadangabe zu der XML-Datei.
Rückgabe:
Das aus der XML-Datei erzeugte Datenobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Datei nicht geladen werden konnte.
[Isom\Base\Data.is: 180]
objectbound Isom.Base.StringList Isom.Base.Data.Query ( Isom.Base.StringList paths )

Sucht in den Daten nach bestimmten Einträgen.

Der Funktion wird eine Liste von relativen XPath-Ausdrücken übergeben, die für das Datenelement ausgewertet werden. Das Suchergebnis besteht aus einer Liste von Zeichenketten, in der die Ergebnisse der einzelnen XPath-Auswertungen enthalten sind. Die Ergebnisse haben die gleiche Reihenfolge wie die XPath-Ausdrücke.

Wenn ein relativer XPath-Ausdruck ungültig ist oder wenn ein XPath-Ausdruck kein relativer Ausdruck ist, wird im Suchergebnis an der betreffenden Stelle ein Void-Objekt eingetragen.

Wenn die Auswertung eines relativen XPath-Ausdrucks für einen der XML-Knoten in mehreren XML-Knoten resultiert, wird nur der Wert des ersten XML-Knotens in die Suchergebnisse übernommen.

   Uri uri = Isom.Base.Uri.DefineUri( "file:.../ISOM/model/Base_ISOM.xml" );

   StringList search = StringList.CreateStringList();
   search.Insert( "attribute::IsDefault" );   // oder "@IsDefault"
   search.Insert( "child::PChannel" );        // oder "PChannel"

   DataList list = xml.FindElements("//NChannel[@Name='DIAGBUS']");
   result = list.Next().Query(search);
   result.Reset();
   while(result.HasNext())
   {
       String found = result.Next();
       System.Stdout (found);
   }
Parameter:
paths relative XPath-Ausdrücke.
Rückgabe:
Die Suchergebnisse; die Liste kann auch leer sein oder leere Einträge und Void-Objekte enthalten
[Isom\Base\Data.is: 641]
objectbound Isom.Base.Boolean Isom.Base.Data.RemoveAttribute ( Isom.Base.String name )

Entfernt ein Attribut.

Entfernt das genannte Attribut eines Datenobjekts.

 Data data = Data.Create("A");
 data.AddAttribute("X", "true");
 Boolean a = data.RemoveAttribute("X");     // a ist true
 Boolean b = data.RemoveAttribute("X");     // b ist false
Parameter:
name Name des zu entfernenden Attributs.
Rückgabe:
Angabe, ob das Attribut erfolgreich entfernt wurde. Wird das Void-Objekt als Name übergeben, liefert die Funktion "false".
[Isom\Base\Data.is: 558]
objectbound Isom.Base.Boolean Isom.Base.Data.RemoveElements ( Isom.Base.String path )

Sucht mit einem XPath-Ausdruck nach Datenobjekten und entfernt sie.

Alle Datenobjekte, die zu dem übergebenen XPath-Ausdruck passen, werden entfernt.

 Data data = Data.Create("A");
 Data childElement = Data.Create("B");
 Data childElement2 = CData.reate("C");
 childElement.AddElement(childElement2);
 data.AddElement(childElement);
 Boolean success = data.RemoveElements("B/C");
Parameter:
path XPath-Ausdruck Der XPath-Ausdruck muss bei der Auswertung eine Knotenliste ergeben. Alle gefundenen Element-Knoten werden in das Ergebnis übernommen. Andere Knoten (z.B. Attribute) werden ignoriert.
Rückgabe:
true wenn alle Elemente entfernt werden konnten, sonst false.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der XPath-Ausdruck das Void-Objekt oder leer ist.
[Isom\Base\Data.is: 601]
Isom.Base.Boolean Isom.Base.Data.RemoveGlobal ( Isom.Base.String key )

Entfernt ein globales Datenobjekt.

Entfernt ein globales Datenobjekt, das unter dem übergebenen Schlüssel gespeichert wurde.

 Data.RemoveGlobal("A");
Parameter:
key Schlüssel, unter dem die globale Variable abgelegt wurde
Rückgabe:
'true', falls die globale Variable mit dem Schlüssel gelöscht wurde 'false, falls unter dem Schlüssel keine globale Variable abgelegt war.
[Isom\Base\Data.is: 273]
objectbound Isom.Base.Boolean Isom.Base.Data.RemoveText ( )

Entfernt das Textelement.

Entfernt das Textelement eines Datenobjekts.

 Data data = Data.Create("A");
 data.SetText("abc");
 Boolean a = data.RemoveText();
Rückgabe:
Angabe, ob der Text erfolgreich entfernt wurde.
[Isom\Base\Data.is: 575]
objectbound Isom.Base.Boolean Isom.Base.Data.SetNamespaces ( Isom.Base.StringDictionary mapping )

Registriert Präfixe für XML-Namesräume, die in XPath-Ausdrücken verwendet werden können

In XML-Dokumenten können Namensräume angegeben werden. Um mit den Funktionen Isom.Base.Data.FindElements und Isom.Base.Data.Query in einem solchen Dokument suchen zu können, muss der betreffende XPath-Ausdruck Präfixe verwenden. Diese Präfixe wiederum müssen zuvor registriert werden, damit sie dem entsprechenden Namensraum zugeordnet werden können.

Ein Präfix kann mehrfach registriert werden. In diesem Fall ist die letzte Zuordnung gültig.

Die Präfixe 'xml' und 'xmlns' sind reserviert und dürfen nicht verwendet werden.

Dieses Beispiel zeigt ein XML-Dokument mit Namensraum.

 <wurzel xmlns="http://www.ifs-it.de/dieses-Dokument-gibt-es-nicht">
     <eintrag>
         <daten />
     </eintrag>
 </wurzel>
Zu beachten:
XML-Namensräume sind üblicherweise URLs. Sie müssen jedoch auf kein reales Dokument verweisen. Insbesondere wird auch keine Verbindung aufgebaut, um von einer solchen URL Daten zu laden.
Verwendungsbeispiel:
Das folgende ISOM/L-Programm zeigt, wie in dem oben angeführten XML-Dokument mit einem XPath-Ausdruck gesucht werden kann.
 Isom.Base.Uri  uri = Isom.Base.Uri.DefineUri( "daten.xml" );
 Isom.Base.Data input = Isom.Base.Data.LoadXml(uri);

 // Das Präfix 'ifs' soll für den angegebenen XML-Namensraum verwendet werden.
 Isom.Base.StringDictionary namespaces = Isom.Base.StringDictionary.CreateStringDictionary();
 namespaces.Add("ifs", "http://www.ifs-it.de/dieses-Dokument-gibt-es-nicht");

 // Hier wird der NamespaceManager kofiguriert
 Isom.Base.Boolean result = input.SetNamespaces(namespaces);

 // XPath-Ausdruck mit Präfix für die Suche im Dokument
 Isom.Base.DataList matches = input.FindElements("//ifs:eintrag");
Bemerkungen:
Die Information über registrierte Namensräume wird an Data-Objekte in den Suchergebnissen weitergegeben. Im oben angeführten ISOM/-L- Beispielprogramm ist in den Suchergebnissen (in der Liste 'matches') das Präfix 'ifs' für den Namensraum bereits registriert.
Parameter:
mapping Zuordnungen von Präfixen zu Namensräumen
Rückgabe:
'true', falls das Datenobjekt dem XML-Schema entspricht, sonst 'false'
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Parameter 'mapping' Void ist.
[Isom\Base\Data.is: 718]
objectbound Isom.Base.Boolean Isom.Base.Data.SetNewLineOnXmlAttribute ( Isom.Base.Boolean newLine )

Ändert das Format der XML-Attribute.

Bestimmt ob die XML-Attributen in einer neuen Zeile geschrieben werden

 Data a = ...
 a.SetNewLineOnXmlAttribute(true);
 Uri uri = Isom.Base.Uri.DefineUri( "pathX/file.xml" );
 a.WriteXml(uri);

 @param newLine Format der Attribute
 @return immer 'true'
[Isom\Base\Data.is: 757]
objectbound Isom.Base.Boolean Isom.Base.Data.SetText ( Isom.Base.String text )

Setzt das Textelement des Datenobjekts.

Setzt das Textelement des Datenobjekts.

 Data data = Data.Create("A");
 data.SetText("abc");
Parameter:
text das neue Textelement.
Rückgabe:
'true', falls der Text gesetzt werden konnte, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der zu setzende Text das Void-Objekt ist.
[Isom\Base\Data.is: 418]
objectbound Isom.Base.String Isom.Base.Data.ToXml ( )

Gibt den Inhalt des Datenobjekt als XML-Zeichenkette wieder.

Der Inhalt des Datenobjekts wird in einer Zeichenkatte als XML-Darstellung abgelegt.

Zu beachten:
Anders als beim Schreiben in ein XML-Dokument (mit Isom.Base.Data.WriteXml) ergänzt diese Funktion keine XML-Deklaration.
 Data data = Data.LoadXml(uriFile);
 String xml = data.ToXml(); // Inhalt der XML-Datei
Rückgabe:
Isom.Base.String
Der Inhalt des Datenobjekts als XML-Zeichenkette
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Datenobjekt Void ist.
[Isom\Base\Data.is: 741]
Isom.Base.Data Isom.Base.Data.Void ( )

Erzeugt ein Void-Objekt.

Erzeugt ein Void-Objekt. Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

Rückgabe:
Void-Objekt
[Isom\Base\Data.is: 809]
objectbound Isom.Base.Boolean Isom.Base.Data.WriteXml ( Isom.Base.Uri path )

Schreibt die Daten als XML.

Schreibt das Datenobjekt als XML in die angegebene Datei. Eine XML-Deklaration wird automatisch ergänzt.

 Data data = Data.Create("A");
 Data childElement = Data.Create("B");
 Data childElement2 = Data.Create("C");
 childElement.AddElement(childElement2);
 data.AddElement(childElement);
 Uri uri = Isom.Base.Uri.DefineUri( "http://localhost/pathA/pathB/file.xml" );
 Boolean result = data.WriteXml(uri);
Parameter:
path Zielpfad der Schreiboperation.
Rückgabe:
Angabe, ob das Schreiben erfolgreich war.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der übergebene Pfad das Void-Objekt ist oder ein Fehler beim Schreibvorgang auftritt.
[Isom\Base\Data.is: 537]


für Serviceautoren

Isom.Base.DataList

Namensraum Isom.Base.DataList

Listen aus Datenobjekten des Typs Isom.Base.Data Mehr...

Funktionen
Isom.Base.DataList | CreateDataList()

Erzeugt eine neue, leere Liste.

Listenfunktionen

Isom.Base.Data | At(Isom.Base.Number index)

Ruft ein durch einen Index gekennzeichnetes Datenobjekt aus der Liste ab.

Isom.Base.Boolean | Contains(Isom.Base.Data element)

Abfrage, ob ein Element in der Liste vorhanden ist.

Isom.Base.Data | Current()

Liefert während Durchlaufens der Liste das aktuelle Datenobjekt.

Isom.Base.Boolean | HasNext()

Prüft, ob es beim Durchlaufen der Liste mit .Next() Datenobjekte gibt, die noch nicht abgerufen wurden.

Isom.Base.Number | Insert(Isom.Base.Data element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Prüft, ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente der Liste.

Isom.Base.Data | Next()

Liefert beim Durchlaufen der Liste das nächste Datenobjekt.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt ein durch einen Index gekennzeichnetes Element aus der Liste.

Isom.Base.Boolean | Reset()

Setzt den Durchlauf-Iterator vor das erste Element der Liste, so ein neuer Durchlauf der Liste begonnen werden kann.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.DataList | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Base.DataList | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Isom.Base.DataList repräsentiert Listen von Datenobjekten (Isom.Base.Data).

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte Reset() aufgerufen werden.
Autor:
IFS Informationstechnik Mümchen

Quelldateien:

  • Isom\Base\DataList.is

Dokumentation der Funktionen

objectbound Isom.Base.Data Isom.Base.DataList.At ( Isom.Base.Number index )

Ruft ein durch einen Index gekennzeichnetes Datenobjekt aus der Liste ab.

 DataList list = DataList.CreateDataList();
 Data data = Create("A");
 list.Insert(data);
 Data a = list.At(0);               //a ist das vorher hinzugefügte Datenobjekt
 Data b = list.At(1);               //b ist das Void-Objekt
Parameter:
index Index des abgerufenen Elements in der Liste, beginnend bei 0 für das erste Element.
Rückgabe:
Datenobjekt mit dem übergebenen Index.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 ist oder größer gleich der Anzahl der Listenelemente minus Eins.
[Isom\Base\DataList.is: 237]
objectbound Isom.Base.DataList Isom.Base.DataList.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Dabei werden für alle enthaltenen Datenobjekte ebenso Kopien erzeugt.

Rückgabe:
Kopie dieses Objekts.
[Isom\Base\DataList.is: 337]
objectbound Isom.Base.Boolean Isom.Base.DataList.Contains ( Isom.Base.Data element )

Abfrage, ob ein Element in der Liste vorhanden ist.

 DataList list = DataList.CreateDataList();
 Data data1 = Create("A");
 Data data2= Create("B");
 list.Insert(data1);                            //Füge data1 der Liste hinzu
 Boolean result = list.Contains(data1);         //result ist true
 result = list.Contains(data2);                 //result ist false
Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Base\DataList.is: 309]
Isom.Base.DataList Isom.Base.DataList.CreateDataList ( )

Erzeugt eine neue, leere Liste.

 DataList list = DataList.CreateDataList();
Rückgabe:
Leere Liste.
[Isom\Base\DataList.is: 92]
objectbound Isom.Base.Data Isom.Base.DataList.Current ( )

Liefert während Durchlaufens der Liste das aktuelle Datenobjekt.

 DataList list = ...
 list.Reset();                        //Listendurchlauf vorbereiten
 while (list.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    list.Next();                        //Durchlauf weiterführen
    Data currentData = list.Current();  //Element abrufen
    ...
 }
Rückgabe:
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Durchlauf-Iterator vor das erste Element der Liste zeigt.
[Isom\Base\DataList.is: 196]
objectbound Isom.Base.Boolean Isom.Base.DataList.HasNext ( )

Prüft, ob es beim Durchlaufen der Liste mit .Next() Datenobjekte gibt, die noch nicht abgerufen wurden.

 DataList list = ...
 list.Reset();                        //Listendurchlauf vorbereiten
 while (list.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    Data currentData = list.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
'true', falls noch Werte in der Liste mit .Next() abgerufen werden können, 'false' sonst.
[Isom\Base\DataList.is: 174]
objectbound Isom.Base.Number Isom.Base.DataList.Insert ( Isom.Base.Data element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Durchlauf-Iterator wird durch diese Operation zurückgesetzt.

 DataList list = DataList.CreateDataList();
 Data data = Create("A");
 list.Insert(data);
Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügendes Datenobjekt.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
[Isom\Base\DataList.is: 266]
objectbound Isom.Base.Boolean Isom.Base.DataList.IsEmpty ( )

Prüft, ob diese Liste leer ist oder nicht.

 DataList list = DataList.CreateDataList();
 Boolean isEmpty = list.IsEmpty();    // isEmpty ist true
 Data data = Create("A");
 list.Insert(data);
 isEmpty = list.IsEmpty();             // isEmpty ist false
Rückgabe:
'true', falls die Liste leer ist, 'false' sonst.
[Isom\Base\DataList.is: 132]
objectbound Isom.Base.Boolean Isom.Base.DataList.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Base\DataList.is: 328]
objectbound Isom.Base.Number Isom.Base.DataList.Length ( )

Liefert die Anzahl der Elemente der Liste.

 DataList list = DataList.CreateDataList();
 Data data = Create("A");
 list.Insert(data);
 Number length = list.Length();    // length ist 1
Rückgabe:
Anzahl der Elemente.
[Isom\Base\DataList.is: 116]
objectbound Isom.Base.Data Isom.Base.DataList.Next ( )

Liefert beim Durchlaufen der Liste das nächste Datenobjekt.

Ein Listendurchlauf wird mit .Reset() zurückgesetzt, um die Liste mit .Next() vom Listenanfang an durchlaufen zu können.

 DataList list = ...
 list.Reset();                    //Listendurchlauf vorbereiten
 while (list.HasNext ())          //Prüfen, ob es ein nächstes Element gibt
 {
    Data currentData = list.Next(); //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Nächstes Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Base\DataList.is: 154]
objectbound Isom.Base.Boolean Isom.Base.DataList.Remove ( Isom.Base.Number index )

Entfernt ein durch einen Index gekennzeichnetes Element aus der Liste.

Ein eventuell aktiver Durchlauf-Iterator, wird durch diese Operation zurückgesetzt.

 DataList list = DataList.CreateDataList();
 Boolean result = list.Remove(0);       //result ist false
 Data data = Create("A");
 list.Insert(data);
 result = list.Remove(0);               //result ist true
Parameter:
index Index des zu entfernenden Elements in der Liste, beginnend bei 0 für das erste Element.
Rückgabe:
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt).
[Isom\Base\DataList.is: 289]
objectbound Isom.Base.Boolean Isom.Base.DataList.Reset ( )

Setzt den Durchlauf-Iterator vor das erste Element der Liste, so ein neuer Durchlauf der Liste begonnen werden kann.

 DataList list = ...
 list.Reset();                        //Listendurchlauf vorbereiten
 while (list.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    Data currentData = list.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Immer 'true'.
[Isom\Base\DataList.is: 215]
Isom.Base.DataList Isom.Base.DataList.Void ( )

Erzeugt ein Void-Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

Rückgabe:
Void-Objekt
[Isom\Base\DataList.is: 347]


für Serviceautoren

Isom.Base.Date

Namensraum Isom.Base.Date

Datums- und Zeitangaben Mehr...

Funktionen
Isom.Base.Number | ElapsedTime(Isom.Base.Date past)

Liefert die Zeitdifferenz in Sekunden zwischen diesem Zeitstempel und dem Vergleichswert.

Isom.Base.Date | Now()

Abfrage eines Zeitstempelobjekts mit aktuellem Datum und Uhrzeit.

Isom.Base.Date | Parse(Isom.Base.String string)

Erzeugt ein Zeitstempelobjekt für einen Zeitpunkt, der als Zeichenkette übergeben wird.

Isom.Base.Date | ParseFormatted(Isom.Base.String string, Isom.Base.String format, Isom.Base.Boolean local)

Erzeugt ein Zeitstempelobjekt auf Basis einer Formatierung, die als Parameter übergeben wird.

Isom.Base.Date | ParseLocalTime(Isom.Base.String string)

Erzeugt ein Zeitstempelobjekt für einen Zeitpunkt, der als Zeichenkette übergeben wird.

Isom.Base.String | ToLocalTime()

Liefert eine lesbare Zeichenkette für diesen Zeitstempel, die der lokalen Systemzeit entspricht.

Isom.Base.String | ToLocalTimeFormatted(Isom.Base.String format)

Liefert eine lesbare Zeichenkette für diesen Zeitstempel als Datum und Uhrzeit in der lokalen Systemzeit.

Isom.Base.String | ToUniversalTime()

Liefert eine lesbare Zeichenkette für diesen Zeitstempel, die dem Datum und der Uhrzeit in UTC entspricht.

Isom.Base.String | ToUniversalTimeFormatted(Isom.Base.String format)

Liefert eine lesbare Zeichenkette des Zeitstempels als Datum und Uhrzeit in UTC.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Date | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Base.Date | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Base.Date stellt Funktionen für den Umgang mit Datums- und Zeitangaben bereit.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Base\Date.is

Dokumentation der Funktionen

objectbound Isom.Base.Date Isom.Base.Date.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Base\Date.is: 326]
objectbound Isom.Base.Number Isom.Base.Date.ElapsedTime ( Isom.Base.Date past )

Liefert die Zeitdifferenz in Sekunden zwischen diesem Zeitstempel und dem Vergleichswert.

Die Zeitdifferenz ist positiv, falls der Vergleichswert in der Vergangenheit liegt, negativ sonst.

 Date timestamp = Date.Now();
 Date otherTimeStamp = ...
 Number diff = timestamp.ElapsedTime(otherTimeStamp);
Parameter:
past Vergleichswert.
Rückgabe:
Zeitdifferenz in Sekunden zwischen diesem Zeitstempelobjekt und dem Vergleichswert.
[Isom\Base\Date.is: 221]
objectbound Isom.Base.Boolean Isom.Base.Date.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Base\Date.is: 318]
Isom.Base.Date Isom.Base.Date.Now ( )

Abfrage eines Zeitstempelobjekts mit aktuellem Datum und Uhrzeit.

 Date timestamp = Date.Now();
Rückgabe:
Zeitstempelobjekt mit aktuellem Datum und Uhrzeit.
[Isom\Base\Date.is: 86]
Isom.Base.Date Isom.Base.Date.Parse ( Isom.Base.String string )

Erzeugt ein Zeitstempelobjekt für einen Zeitpunkt, der als Zeichenkette übergeben wird.

Die übergebene Zeichenkette wird nach ISO 8601:1988 interpretiert. Die Zeitangaben werden als Angaben in der koordinierten Weltzeit UTC (Universal Time Coordinated) ausgewertet.

Verwendungsbeispiel:
Mögliche Zeitangaben sind:

  • "13.02.2007"
  • "13.02.2007 15:00"
  • "15:00:00 13.02.2007"
  • "15:00"

Parameter:
string Zeichenkette, die den Zeitpunkt angibt.
Rückgabe:
Zeitstempelobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebene Zeichenkette nicht interpretiert werden kann.
[Isom\Base\Date.is: 115]
Isom.Base.Date Isom.Base.Date.ParseFormatted | ( | Isom.Base.String | string,
 |  | Isom.Base.String | format,
 |  | Isom.Base.Boolean | local
 | ) |  |

Erzeugt ein Zeitstempelobjekt auf Basis einer Formatierung, die als Parameter übergeben wird.

Die Funktion unterstützt die Auswertung von Zeichenketten, die nicht in der Formatierung ISO 8601:1988 vorliegen. Die Angabe des Formats erfolgt wie bei der Funktion Isom.Base.Date.ToLocalTimeFormatted dokumentiert.

Parameter:
string | Zeichenkette, die den Zeitpunkt angibt.
format | Zeichenkette, das Format gemäß den Richtlinien von ISO 8601 vorgibt.
local | 'true', wenn für die Datumsangabe lokale Zeit angenommen werden soll, 'false' bei UTC
Rückgabe:
Zeitstempelobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebene Zeichenkette nicht interpretiert werden kann.
[Isom\Base\Date.is: 167]
Isom.Base.Date Isom.Base.Date.ParseLocalTime ( Isom.Base.String string )

Erzeugt ein Zeitstempelobjekt für einen Zeitpunkt, der als Zeichenkette übergeben wird.

Die Zeichenkette wird nach ISO 8601:1988 interpretiert. Die Zeitangaben werden als Angaben in der lokalen Zeit ausgewertet.

Verwendungsbeispiel:
Mögliche Zeitangaben sind:

  • "13.02.2007"
  • "13.02.2007 15:00"
  • "15:00:00 13.02.2007"
  • "15:00"

Parameter:
string Zeichenkette, die den Zeitpunkt angibt.
Rückgabe:
Zeitstempelobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebene Zeichenkette nicht interpretiert werden kann.
[Isom\Base\Date.is: 142]
objectbound Isom.Base.String Isom.Base.Date.ToLocalTime ( )

Liefert eine lesbare Zeichenkette für diesen Zeitstempel, die der lokalen Systemzeit entspricht.

Die Zeichenkette wird als "DD.MM.YYYY hh:mm:ss" formatiert. Ein Beispiel einer solchen Zeichenkette ist "13.02.2007 15:00:00".

 Date timestamp = Date.Now();
 String localTime = timestamp.ToLocalTime();
Rückgabe:
Zeitstempelobjekt.
[Isom\Base\Date.is: 187]
objectbound Isom.Base.String Isom.Base.Date.ToLocalTimeFormatted ( Isom.Base.String format )

Liefert eine lesbare Zeichenkette für diesen Zeitstempel als Datum und Uhrzeit in der lokalen Systemzeit.

Für das Format werden die gleichen Zeichenketten verwendet, die der .NET Typ 'DateTime' akzeptiert. Die wichtigsten Standardformate sind:

Standardformat | Beispiel
d | 08/17/2000
g | 08/17/2000 16:32
r | Thu, 17 Aug 2000 23:32:32 GMT
s | 2000-08-17T16:32:32
u | 2000-08-17 23:32:32Z
U | Thursday, August 17, 2000 23:32:32
Zusätzlich können eigene Formate aus den folgenden Zeichenketten zusammengestellt werden. Diese können mit anderen Zeichen kombiniert werden, wie am Ende der Tabelle gezeigt wird.
Benutzerformat | Beschreibung / Beispiel
d | der Tag des Monats (1-31)
dd | der Tag des Monats (zweistellig: 01-31)
M | der Monat (1-12)
MM | der Monat (zweistellig: 01-12)
y | das Jahr (0-99)
yy | das Jahr (zweistellig: 0-99)
yyyy | das Jahr (vierstellig)
h | Stunde (1-12)
hh | Stunde (zweistellig: 01-12)
tt | AM/PM
H | Stunde (0-23)
HH | Stunde (zweistellig: 00-23)
m | Minuten (0-59)
mm | Minuten (zweistellig: 00-59)
s | Sekunden (0-59)
ss | Sekunden (zweistellig: 00-59)
z | Zeitzonen-Offset in Stunden
zz | Zeitzonen-Offset in Stunden (zweistellig)
zzz | Zeitzonen-Offset in Stunden und Minuten
f | Sekundenbruchteil (1. Stelle)
ff | Sekundenbruchteil (zweistellig)
fff | Sekundenbruchteil (dreistellig)
dd.MM.yyyy | 23.03.2008
: | Standardtrennzeichen für Uhrzeiten (meist ":")
\c | c für beliebige c
HH\:mm\:ss | 15:42:20
hh\:mm\:ss tt | 03:42:20 p.m.
HH\:mm\:ss.fff | 09:42:20.254
HH\:mm\:ss UTC Z | 15:42:20 UTC +1

      Date timestamp = Date.Now();
      String utcTime = timestamp.ToLocalTimeFormatted("HH:mm:ss");
Parameter:
format Das Format der Zeichenkette.
Rückgabe:
Zeitstempelobjekt.
[Isom\Base\Date.is: 283]
objectbound Isom.Base.String Isom.Base.Date.ToUniversalTime ( )

Liefert eine lesbare Zeichenkette für diesen Zeitstempel, die dem Datum und der Uhrzeit in UTC entspricht.

Die Zeichenkette wird als "DD.MM.YYYY hh:mm:ss" formatiert. Ein Beispiel einer solchen Zeichenkette ist "13.02.2007 15:00:00".

 Date timestamp = Date.Now();
 String utcTime = timestamp.ToUniversalTime();
Rückgabe:
Zeitstempelobjekt.
[Isom\Base\Date.is: 203]
objectbound Isom.Base.String Isom.Base.Date.ToUniversalTimeFormatted ( Isom.Base.String format )

Liefert eine lesbare Zeichenkette des Zeitstempels als Datum und Uhrzeit in UTC.

Beispiele für die Formatangabe finden sich in der Dokumentation zu ToLocalTimeFormatted(Isom.Base.String).

 Date timestamp = Date.Now();
 String utcTime = timestamp.ToUniversalTimeFormatted("HH:mm:ss");
Parameter:
format Das Format der Zeichenkette.
Rückgabe:
Zeitstempelobjekt.
[Isom\Base\Date.is: 300]
Isom.Base.Date Isom.Base.Date.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Base\Date.is: 337]


für Serviceautoren

Isom.Base.Number

Namensraum Isom.Base.Number

Zahlen Mehr...

Funktionen
Funktionen für globale Objekte

Funktionen, mit denen die globale Ablage von Objekten ermöglicht wird.

Isom.Base.Boolean | AddGlobal(Isom.Base.String key, Isom.Base.Number value)

Speichert eine Kopie dieses Zahlenobjekts als globale Variable.

Isom.Base.StringList | GetExistingGlobals()

Ruft eine Liste der Schlüssel aller globalen Variablen des Typs 'Number' ab

Isom.Base.Number | GetGlobal(Isom.Base.String key)

Ruft das Zahlenobjekt ab, das unter dem übergebenen Schlüssel als globale Variable gesichert wurde.

Isom.Base.Boolean | RemoveGlobal(Isom.Base.String key)

Entfernt eine globale Zahlenvariable, die unter dem übergebenen Schlüssel gespeichert wurde.

Arithmetische Elementoperationen

Funktionen für elementare, arithmetische Rechenoperationen.

Isom.Base.Number | Add(Isom.Base.Number other)

Addiert eine zweite Zahl zu dieser Zahl.

Isom.Base.Number | Div(Isom.Base.Number other)

Dividiert diese Zahl durch einen andere Zahl.

Isom.Base.Number | Floor()

Rundet die Zahl auf einen ganzzahligen Wert ab.

Isom.Base.Number | Mod(Isom.Base.Number other)

Bestimmt den Rest aus der Division dieser Zahl durch eine andere Zahl.

Isom.Base.Number | Mul(Isom.Base.Number other)

Multipliziert diese Zahl mit einem anderen Zahl.

Isom.Base.Number | Sub(Isom.Base.Number other)

Subtrahiert eine zweite Zahl von dieser Zahl.

Binäre Elementoperationen

Funktionen für elementare Logikoperationen.

Isom.Base.Number | And(Isom.Base.Number other)

Führt ein bitweises logisches UND mit dem Operanden aus.

Isom.Base.Number | Compl()

Konvertiert dieses Objekt in das Einerkomplement.

Isom.Base.Number | Or(Isom.Base.Number other)

Führt ein bitweises logisches ODER mit dem Operanden aus.

Isom.Base.Number | Xor(Isom.Base.Number other)

Führt ein bitweises logisches exklusives ODER mit dem Operanden aus.

Vergleichsoperationen

Funktionen für Vergleiche.

Isom.Base.Boolean | Eq(Isom.Base.Number other)

Prüft diese und die übergebene Zahl auf Gleichheit.

Isom.Base.Boolean | Ge(Isom.Base.Number other)

Es wird geprüft, ob diese Zahl größer gleich einer übergebenen Zahl ist.

Isom.Base.Boolean | Gt(Isom.Base.Number other)

Es wird geprüft, ob diese Zahl größer als eine übergebene Zahl ist.

Isom.Base.Boolean | Le(Isom.Base.Number other)

Es wird geprüft, ob diese Zahl kleiner gleich einer übergebenen Zahl ist.

Isom.Base.Boolean | Lt(Isom.Base.Number other)

Es wird geprüft, ob diese Zahl kleiner als eine übergebene Zahl ist.

Isom.Base.Boolean | Ne(Isom.Base.Number other)

Prüft diese und die übergebene Zahl auf Ungleichheit.

Konvertierungen in Zeichenketten

Funktionen um Zahlen in Zeichenketten umzuwandeln.

Isom.Base.String | ToFloatString()

Gibt eine Zeichenkette mit der Gleitkommadarstellung dieser Zahl zurück.

Isom.Base.String | ToHexString()

Konvertiert die Zahl in eine Ganzzahl und gibt eine Zeichenkette mit der hexadezimalen Repräsentation zurück.

Isom.Base.String | ToIntString()

Konvertiert die Zahl in eine Ganzzahl und gibt eine Zeichenkette mit der dezimalen Repräsentation zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Number | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Base.Number | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Base.Number speichert Zahlen als 64-bittige Gleitkommawerte (doppelte Genauigkeit), entsprechend der Norm IEC 60559:1989 (IEEE 754). Dies entspricht dem Typ System.Double der .NET-Laufzeitumgebung.

Der mögliche Wertebereich ist ±1.0E±308 mit 15 Stellen Genauigkeit.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Base\Number.is

Dokumentation der Funktionen

objectbound Isom.Base.Number Isom.Base.Number.Add ( Isom.Base.Number other )

Addiert eine zweite Zahl zu dieser Zahl.

Das aktuelle Zahlenobjekt übernimmt das Ergebnis als neuen Wert, außer es ist ungültig

 Number a = 1;
 a.Add(1);                    // a ist 2
Parameter:
other Summand, der addiert werden soll.
Rückgabe:
Das aktuelle Zahlenobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Summand das Void-Objekt ist.
[Isom\Base\Number.is: 205]
Isom.Base.Boolean Isom.Base.Number.AddGlobal | ( | Isom.Base.String | key,
 |  | Isom.Base.Number | value
 | ) |  |

Speichert eine Kopie dieses Zahlenobjekts als globale Variable.

Die übergebene Zeichenkette ist der Schlüssel, mit dem die gespeicherte Variable danach mit .GetGlobal() abgerufen werden kann. Existiert bereits eine globale Variable mit dem Schlüssel, wird der vorher gesicherte Wert ersetzt.

 Number.AddGlobal("A", 1);
Parameter:
key | Schlüssel, mit dem die Zahl als globale Variable gespeichert wird.
value | Zahl, die gespeichert wird.
Rückgabe:
'true', falls die Zahl als globale Variable gespeichert werden konnte, 'false' sonst (z.B. bei einem ungültigen Objekt für Schlüssel oder Wert).
[Isom\Base\Number.is: 126]
objectbound Isom.Base.Number Isom.Base.Number.And ( Isom.Base.Number other )

Führt ein bitweises logisches UND mit dem Operanden aus.

Für diese Operation werden beide Operanden in eine Ganzzahl konvertiert. Dadurch kann es zu einem Präzisionsverlust kommen. Das aktuelle Zahlenobjekt übernimmt das Ergebnis als neuen Wert.

 Number a = 1;
 a.And(2);
Parameter:
other Operand des bitweisen logischen UND.
Rückgabe:
Das aktuelle Zahlenobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Operand das Void-Objekt ist.
[Isom\Base\Number.is: 329]
objectbound Isom.Base.Number Isom.Base.Number.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Rückgabe:
Kopie dieses Objekts.
[Isom\Base\Number.is: 598]
objectbound Isom.Base.Number Isom.Base.Number.Compl ( )

Konvertiert dieses Objekt in das Einerkomplement.

Für diese Operation wird die Zahl in eine Ganzzahl konvertiert. Dadurch kann es zu einem Präzisionsverlust kommen. Das aktuelle Zahlenobjekt übernimmt das Ergebnis als neuen Wert.

 Number a = 1;
 a.Compl();
Rückgabe:
Das aktuelle Zahlenobjekt.
[Isom\Base\Number.is: 385]
objectbound Isom.Base.Number Isom.Base.Number.Div ( Isom.Base.Number other )

Dividiert diese Zahl durch einen andere Zahl.

Das aktuelle Zahlenobjekt übernimmt das Ergebnis als neuen Wert, außer es ist ungültig

 Number a = 4;
 a.Div(2);                    // a ist 2
Parameter:
other Divisor, durch den dividiert werden soll.
Rückgabe:
Das aktuelle Zahlenobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Divisor das Void-Objekt ist.
Es wird das Void-Objekt zurückgegeben, falls der Divisor den Wert 0 hat.
[Isom\Base\Number.is: 264]
objectbound Isom.Base.Boolean Isom.Base.Number.Eq ( Isom.Base.Number other )

Prüft diese und die übergebene Zahl auf Gleichheit.

 Number a = 4.5;
 Boolean b = a.Eq(4);                   // b ist false
 Boolean c = a.Eq(4.5);                 // c ist true
Parameter:
other Zahl, mit der diese Zahl verglichen wird.
Rückgabe:
'true', falls beide Zahlen identisch sind, 'false' sonst. Wird das Void-Objekt übergeben, so liefert die Funktion 'false'.
[Isom\Base\Number.is: 412]
objectbound Isom.Base.Number Isom.Base.Number.Floor ( )

Rundet die Zahl auf einen ganzzahligen Wert ab.

Das aktuelle Zahlenobjekt übernimmt das Ergebnis als neuen Wert.

 Number a = 4.5;
 a.Floor();                   // a ist 4
Rückgabe:
Das aktuelle Zahlenobjekt.
[Isom\Base\Number.is: 300]
objectbound Isom.Base.Boolean Isom.Base.Number.Ge ( Isom.Base.Number other )

Es wird geprüft, ob diese Zahl größer gleich einer übergebenen Zahl ist.

 Number a = 4.5;
 Boolean b = a.Ge(4);                 // b ist true
 Boolean c = a.Ge(4.5);               // c ist true
 Boolean d = a.Ge(5);                 // d ist false
Parameter:
other Zahl, mit der diese Zahl verglichen wird.
Rückgabe:
'true', falls diese Zahl größer gleich der übergebenen Zahl ist, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Parameter das Void-Objekt ist.
[Isom\Base\Number.is: 512]
Isom.Base.StringList Isom.Base.Number.GetExistingGlobals ( )

Ruft eine Liste der Schlüssel aller globalen Variablen des Typs 'Number' ab

   Number.AddGlobal("A", 1);
   Number.AddGlobal("B", 2);
   StringList keys = Number.GetExistingGlobals(); // enthält "A" und "B"
Rückgabe:
Liste der Schlüssel aller globalen Variablen des Typs 'Number'
[Isom\Base\Number.is: 177]
Isom.Base.Number Isom.Base.Number.GetGlobal ( Isom.Base.String key )

Ruft das Zahlenobjekt ab, das unter dem übergebenen Schlüssel als globale Variable gesichert wurde.

 Number value = Number.GetGlobal("A");
Parameter:
key Schlüssel der gesuchten globalen Variable.
Rückgabe:
Kopie des gefundenen Variablenwerts. Änderungen an diesem Rückgabewert ändern den Wert der gesicherten globalen Variable nicht. Um Änderungen in die globale Variable zu übernehmen, muss der geänderte Wert mit .AddGlobal() wieder gesichert werden.
Ausnahmebehandlung:
Die Funktion liefert ein Void-Objekt, falls innerhalb dieser Sitzung noch keine Variable unter dem Schlüssel abgespeichert wurde oder der Schlüssel ein ungültiges Objekt ist.
[Isom\Base\Number.is: 148]
objectbound Isom.Base.Boolean Isom.Base.Number.Gt ( Isom.Base.Number other )

Es wird geprüft, ob diese Zahl größer als eine übergebene Zahl ist.

 Number a = 4.5;
 Boolean b = a.Gt(4);                 // b ist true
 Boolean c = a.Gt(4.5);               // c ist false
 Boolean d = a.Gt(5);                 // d ist false
Parameter:
other Zahl, mit der diese Zahl verglichen wird.
Rückgabe:
'true', falls diese Zahl größer als die übergebene Zahl ist, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Parameter das Void-Objekt ist.
[Isom\Base\Number.is: 491]
objectbound Isom.Base.Boolean Isom.Base.Number.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Base\Number.is: 590]
objectbound Isom.Base.Boolean Isom.Base.Number.Le ( Isom.Base.Number other )

Es wird geprüft, ob diese Zahl kleiner gleich einer übergebenen Zahl ist.

 Number a = 4.5;
 Boolean b = a.Le(4);                 // b ist false
 Boolean c = a.Le(4.5);               // c ist true
 Boolean d = a.Le(5);                 // d ist true
Parameter:
other Zahl, mit der diese Zahl verglichen wird.
Rückgabe:
'true', falls diese Zahl kleiner gleich der übergebenen Zahl ist, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Parameter das Void-Objekt ist.
[Isom\Base\Number.is: 471]
objectbound Isom.Base.Boolean Isom.Base.Number.Lt ( Isom.Base.Number other )

Es wird geprüft, ob diese Zahl kleiner als eine übergebene Zahl ist.

 Number a = 4.5;
 Boolean b = a.Lt(4);                 // b ist false
 Boolean c = a.Lt(4.5);               // c ist false
 Boolean d = a.Lt(5);                 // d ist true
Parameter:
other Zahl, mit der diese Zahl verglichen wird.
Rückgabe:
'true', falls diese Zahl kleiner als die übergebene Zahl ist, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Parameter das Void-Objekt ist.
[Isom\Base\Number.is: 450]
objectbound Isom.Base.Number Isom.Base.Number.Mod ( Isom.Base.Number other )

Bestimmt den Rest aus der Division dieser Zahl durch eine andere Zahl.

Das aktuelle Zahlenobjekt übernimmt das Ergebnis als neuen Wert, außer es ist ungültig

 Number a = 4;
 a.Mod(2);                    // a ist 0
Parameter:
other Divisor für die Modulodivision.
Rückgabe:
Das aktuelle Zahlenobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Divisor das Void-Objekt ist.
Es wird das Void-Objekt zurückgegeben, falls der Divisor den Wert 0 hat.
[Isom\Base\Number.is: 286]
objectbound Isom.Base.Number Isom.Base.Number.Mul ( Isom.Base.Number other )

Multipliziert diese Zahl mit einem anderen Zahl.

Das aktuelle Zahlenobjekt übernimmt das Ergebnis als neuen Wert, außer es ist ungültig

 Number a = 2;
 a.Mul(3);                    // a ist 6
Parameter:
other Faktor, mit dem multipliziert werden soll.
Rückgabe:
Das aktuelle Zahlenobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Faktor das Void-Objekt ist.
[Isom\Base\Number.is: 243]
objectbound Isom.Base.Boolean Isom.Base.Number.Ne ( Isom.Base.Number other )

Prüft diese und die übergebene Zahl auf Ungleichheit.

 Number a = 4.5;
 Boolean b = a.Ne(4);                   // b ist true
 Boolean c = a.Ne(4.5);                 // c ist false
Parameter:
other Zahl, mit der diese Zahl verglichen wird.
Rückgabe:
'true', falls beide Zahlen unterschiedlich sind, 'false' sonst. Wird das Void-Objekt übergeben, so liefert die Funktion 'true'.
[Isom\Base\Number.is: 430]
objectbound Isom.Base.Number Isom.Base.Number.Or ( Isom.Base.Number other )

Führt ein bitweises logisches ODER mit dem Operanden aus.

Für diese Operation werden beide Operanden in eine Ganzzahl konvertiert. Dadurch kann es zu einem Präzisionsverlust kommen. Das aktuelle Zahlenobjekt übernimmt das Ergebnis als neuen Wert.

 Number a = 1;
 a.Or(2);
Parameter:
other Operand des bitweisen logischen ODER.
Rückgabe:
Das aktuelle Zahlenobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Operand das Void-Objekt ist.
[Isom\Base\Number.is: 349]
Isom.Base.Boolean Isom.Base.Number.RemoveGlobal ( Isom.Base.String key )

Entfernt eine globale Zahlenvariable, die unter dem übergebenen Schlüssel gespeichert wurde.

 Number.RemoveGlobal("A");
Parameter:
key Schlüssel, unter dem die globale Variable abgelegt wurde
Rückgabe:
'true', falls die globale Variable mit dem Schlüssel gelöscht wurde 'false, falls unter dem Schlüssel keine globale Variable abgelegt war.
[Isom\Base\Number.is: 163]
objectbound Isom.Base.Number Isom.Base.Number.Sub ( Isom.Base.Number other )

Subtrahiert eine zweite Zahl von dieser Zahl.

Das aktuelle Zahlenobjekt übernimmt das Ergebnis als neuen Wert, außer es ist ungültig

 Number a = 1;
 a.Sub(1);                    // a ist 0
Parameter:
other Subtrahend der Operation.
Rückgabe:
Das aktuelle Zahlenobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Subtrahend das Void-Objekt ist.
[Isom\Base\Number.is: 224]
objectbound Isom.Base.String Isom.Base.Number.ToFloatString ( )

Gibt eine Zeichenkette mit der Gleitkommadarstellung dieser Zahl zurück.

 Number a = 4.4;
 System.Stdout(a.ToFloatString());        // gibt 4.4 aus
Rückgabe:
Zeichenkette mit der Gleitkommadarstellung dieser Zahl.
[Isom\Base\Number.is: 571]
objectbound Isom.Base.String Isom.Base.Number.ToHexString ( )

Konvertiert die Zahl in eine Ganzzahl und gibt eine Zeichenkette mit der hexadezimalen Repräsentation zurück.

Diese umfasst kein einleitendes '0x'. Die Funktion liefert nur richtige Ergebnisse für Ganzzahlen im Bereich -2.147.483.648 bis 2.147.483.647. Für Werte außerhalb dieses Bereichs ist der Inhalt der zurückgelieferten Zeichenkette undefiniert.

 Number a = 14;
 System.Stdout(a.ToHexString());        // gibt E aus
Rückgabe:
Zeichenkette mit der hexadezimalen Repräsentation dieser Zahl.
[Isom\Base\Number.is: 557]
objectbound Isom.Base.String Isom.Base.Number.ToIntString ( )

Konvertiert die Zahl in eine Ganzzahl und gibt eine Zeichenkette mit der dezimalen Repräsentation zurück.

Ist der Wert der Zahl größer als 9.223.372.036.854.775.807 oder kleiner als -9.223.372.036.854.775.808 so wird die Zahl als Gleitkommazahl mit Exponenten in der Zeichenkette zurückgegeben.

 Number a = 4.5;
 System.Stdout(a.ToIntString());        // gibt 4 aus
Rückgabe:
Zeichenkette mit der dezimalen Repräsentation dieser Zahl.
[Isom\Base\Number.is: 538]
Isom.Base.Number Isom.Base.Number.Void ( )

Erzeugt ein ungültiges Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

Rückgabe:
Void-Objekt
[Isom\Base\Number.is: 608]
objectbound Isom.Base.Number Isom.Base.Number.Xor ( Isom.Base.Number other )

Führt ein bitweises logisches exklusives ODER mit dem Operanden aus.

Für diese Operation werden beide Operanden in eine Ganzzahl konvertiert. Dadurch kann es zu einem Präzisionsverlust kommen. Das aktuelle Zahlenobjekt übernimmt das Ergebnis als neuen Wert.

 Number a = 1;
 a.Xor(2);
Parameter:
other Operand des bitweisen logischen XODER.
Rückgabe:
Das aktuelle Zahlenobjekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Operand das Void-Objekt ist.
[Isom\Base\Number.is: 369]


für Serviceautoren

Isom.Base.NumberList

Namensraum Isom.Base.NumberList

Listen von Zahlen des Typs Isom.Base.Number Mehr...

Funktionen
Isom.Base.NumberList | CreateNumberList()

Erzeugt eine neue, leere Zahlenliste.

Listenfunktionen

Isom.Base.Number | At(Isom.Base.Number index)

Ruft eine durch einen Index gekennzeichnete Zahl aus der Liste ab.

Isom.Base.Boolean | Contains(Isom.Base.Number element)

Abfrage, ob ein Element in der Liste vorhanden ist.

Isom.Base.Number | Current()

Liefert während dem Durchlaufen der Liste die aktuelle Zahl.

Isom.Base.Boolean | HasNext()

Prüft, ob es beim Durchlaufen der Liste mit .Next() Zahlen gibt, die noch nicht abgerufen wurden.

Isom.Base.Number | Insert(Isom.Base.Number element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Prüft, ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Base.Number | Next()

Liefert beim Durchlaufen der Liste die nächste Zahl.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt ein durch einen Index gekennzeichnetes Element aus der Liste.

Isom.Base.Boolean | Reset()

Setzt den Durchlauf-Iterator vor das erste Element der Liste, so ein neuer Durchlauf der Liste begonnen werden kann.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.NumberList | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Base.NumberList | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Isom.Base.NumberList repräsentiert Listen von Zahlen (Isom.Base.Number).

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.
Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Base\NumberList.is

Dokumentation der Funktionen

objectbound Isom.Base.Number Isom.Base.NumberList.At ( Isom.Base.Number index )

Ruft eine durch einen Index gekennzeichnete Zahl aus der Liste ab.

 NumberList list = NumberList.CreateNumberList();
 list.Insert(1111);
 Number a = list.At(0);               //a ist 1111
 Number b = list.At(1);               //b ist das Void-Objekt
Parameter:
index Index des abgerufenen Elements in der Liste, beginnend bei 0 für das erste Element.
Rückgabe:
Zahl mit dem übergebenen Index.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 ist oder größer gleich der Anzahl der Listenelemente minus Eins.
[Isom\Base\NumberList.is: 239]
objectbound Isom.Base.NumberList Isom.Base.NumberList.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Dabei werden für alle enthaltenen Zahlenobjekte ebenso Kopien erzeugt.

Rückgabe:
Kopie dieses Objekts.
[Isom\Base\NumberList.is: 337]
objectbound Isom.Base.Boolean Isom.Base.NumberList.Contains ( Isom.Base.Number element )

Abfrage, ob ein Element in der Liste vorhanden ist.

 NumberList list = NumberList.CreateNumberList();
 list.Insert(2);                                  //Füge 2 der Liste hinzu
 Boolean result = list.Contains(2);               //result ist true
 result = list.Contains(1);                       //result ist false
Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Base\NumberList.is: 307]
Isom.Base.NumberList Isom.Base.NumberList.CreateNumberList ( )

Erzeugt eine neue, leere Zahlenliste.

 NumberList list = NumberList.CreateNumberList();
Rückgabe:
Leere Liste.
[Isom\Base\NumberList.is: 93]
objectbound Isom.Base.Number Isom.Base.NumberList.Current ( )

Liefert während dem Durchlaufen der Liste die aktuelle Zahl.

 NumberList list = ...
 list.Reset();                        //Listendurchlauf vorbereiten
 while (list.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    list.Next();                        //Durchlauf weiterführen
    Number current = list.Current();    //Element abrufen
    ...
 }
Rückgabe:
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Durchlauf-Iterator vor das erste Element der Liste zeigt.
[Isom\Base\NumberList.is: 199]
objectbound Isom.Base.Boolean Isom.Base.NumberList.HasNext ( )

Prüft, ob es beim Durchlaufen der Liste mit .Next() Zahlen gibt, die noch nicht abgerufen wurden.

 NumberList list = ...
 list.Reset();                        //Listendurchlauf vorbereiten
 while (list.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    Number current = list.Next();       //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
'true', falls noch Zahlen in der Liste mit .Next() abgerufen werden können, 'false' sonst.
[Isom\Base\NumberList.is: 155]
objectbound Isom.Base.Number Isom.Base.NumberList.Insert ( Isom.Base.Number element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Durchlauf-Iterator wird durch diese Operation zurückgesetzt.

 NumberList list = NumberList.CreateNumberList();
 list.Insert(9);
Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügendes Zahl.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
[Isom\Base\NumberList.is: 267]
objectbound Isom.Base.Boolean Isom.Base.NumberList.IsEmpty ( )

Prüft, ob diese Liste leer ist oder nicht.

 NumberList list = NumberList.CreateNumberList();
 Boolean isEmpty = list.IsEmpty();    // isEmpty ist true
 list.Insert(1);
 isEmpty = list.IsEmpty();             // isEmpty ist false
Rückgabe:
'true', falls die Liste leer ist, 'false' sonst.
[Isom\Base\NumberList.is: 135]
objectbound Isom.Base.Boolean Isom.Base.NumberList.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Base\NumberList.is: 328]
objectbound Isom.Base.Number Isom.Base.NumberList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

 NumberList list = NumberList.CreateNumberList();
 list.Insert(1);
 list.Insert(2);
 list.Insert(3);
 list.Insert(4);
 Number length = list.Length();       //length ist 4
Rückgabe:
Anzahl der Elemente.
[Isom\Base\NumberList.is: 120]
objectbound Isom.Base.Number Isom.Base.NumberList.Next ( )

Liefert beim Durchlaufen der Liste die nächste Zahl.

Ein Listendurchlauf wird mit .Reset() zurückgesetzt, um die Liste mit .Next() vom Listenanfang an durchlaufen zu können.

 NumberList list = ...
 list.Reset();                        //Listendurchlauf vorbereiten
 while (list.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    Number current = list.Next();       //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Nächstes Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Base\NumberList.is: 177]
objectbound Isom.Base.Boolean Isom.Base.NumberList.Remove ( Isom.Base.Number index )

Entfernt ein durch einen Index gekennzeichnetes Element aus der Liste.

Ein eventuell aktiver Durchlauf-Iterator, wird durch diese Operation zurückgesetzt.

 NumberList list = NumberList.CreateNumberList();
 Boolean result = list.Remove(0);       //result ist false
 list.Insert(1);
 result = list.Remove(0);               //result ist true
Parameter:
index Index des zu entfernenden Elements in der Liste, beginnend bei 0 für das erste Element.
Rückgabe:
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt).
[Isom\Base\NumberList.is: 289]
objectbound Isom.Base.Boolean Isom.Base.NumberList.Reset ( )

Setzt den Durchlauf-Iterator vor das erste Element der Liste, so ein neuer Durchlauf der Liste begonnen werden kann.

 NumberList list = ...
 list.Reset();                        //Listendurchlauf vorbereiten
 while (list.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    Number current = list.Next();       //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Immer 'true'.
[Isom\Base\NumberList.is: 218]
Isom.Base.NumberList Isom.Base.NumberList.Void ( )

Erzeugt ein Void-Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

Rückgabe:
Void-Objekt
[Isom\Base\NumberList.is: 347]


für Serviceautoren

Isom.Base.RegEx

Namensraum Isom.Base.RegEx

reguläre Ausdrücke Mehr...

Funktionen
Isom.Base.RegEx | DefineRegEx(Isom.Base.String pattern)

Definiert einen regulären Ausdruck.

Isom.Base.Boolean | IsMatch(Isom.Base.String text)

Prüft, ob der reguläre Ausdruck eine Übereinstimmung in der übergebenen Zeichenkette findet.

Isom.Base.StringList | Matches(Isom.Base.String text)

Liefert alle Übereinstimmungen dieses regulären Ausdrucks in der übergebenen Zeichenkette.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.RegEx | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Base.RegEx | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Die von ISOM/L unterstütze Ausdruckssprache entspricht der in der .NET-Laufzeitumgebung 2.0 unterstützten Syntax.
Eine Beschreibung der Elemente der Ausdruckssprache findet sich in der MSDN Dokumentation .

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Base\RegEx.is

Dokumentation der Funktionen

objectbound Isom.Base.RegEx Isom.Base.RegEx.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Rückgabe:
Kopie dieses Objekts.
[Isom\Base\RegEx.is: 174]
Isom.Base.RegEx Isom.Base.RegEx.DefineRegEx ( Isom.Base.String pattern )

Definiert einen regulären Ausdruck.

 RegEx regular = RegEx.DefineRegEx("\b([01][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]\b" );
Parameter:
pattern Zeichenkette, aus der der reguläre Ausdruck erzeugt wird.
Rückgabe:
Definierter regulärer Ausdruck (neues Objekt).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls aus der übergebenen Zeichenkette kein regulärer Ausdruck erzeugt werden konnte.
[Isom\Base\RegEx.is: 90]
objectbound Isom.Base.Boolean Isom.Base.RegEx.IsMatch ( Isom.Base.String text )

Prüft, ob der reguläre Ausdruck eine Übereinstimmung in der übergebenen Zeichenkette findet.

 using Isom.Base.*
 ...
 // Regulärer Ausdruck zum Erkennen von gültigen
 // Zeitangaben der Form HH:MM:SS
 RegEx regular = RegEx.DefineRegEx("\b([01][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]\b" );
 Boolean res = regular.IsMatch( "Die Uhrzeit ist 12:33:57" );
 if( res )
 {
   ...
Parameter:
text Nach Übereinstimmungen zu durchsuchende Zeichenkette.
Rückgabe:
'true', falls eine Übereinstimmung gefunden wurde, 'false' sonst (auch bei Übergabe des Void-Objekts als Eingabezeichenfolge).
[Isom\Base\RegEx.is: 119]
objectbound Isom.Base.Boolean Isom.Base.RegEx.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Base\RegEx.is: 166]
objectbound Isom.Base.StringList Isom.Base.RegEx.Matches ( Isom.Base.String text )

Liefert alle Übereinstimmungen dieses regulären Ausdrucks in der übergebenen Zeichenkette.

 using Isom.Base.*
 ...
 // Regulärer Ausdruck zum Erkennen von gültigen
 // Zeitangaben der Form HH:MM:SS
 RegEx regular = RegEx.DefineRegEx("\b([01][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]\b" );
 StringList list = regular.Matches( "Die Uhrzeit ist 12:33:57" );
 while( list.HasNext() )
 {
    String match = list.Next();
    ...
 }
Parameter:
text Nach Übereinstimmungen zu durchsuchende Zeichenkette.
Rückgabe:
Liste aller gefundenen Übereinstimmungen des regulären Ausdrucks. Wurden keine Übereinstimmungen gefunden, so wird eine leere Liste zurückgegeben.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebene Zeichenkette das Void-Objekt ist.
[Isom\Base\RegEx.is: 148]
Isom.Base.RegEx Isom.Base.RegEx.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Base\RegEx.is: 185]


für Serviceautoren

Isom.Base.String

Namensraum Isom.Base.String

Zeichenketten Mehr...

Funktionen
Isom.Base.String | Append(Isom.Base.String part)

Hängt die übergebene Zeichenkette an diese Zeichenkette an.

Isom.Base.Boolean | Equals(Isom.Base.String other)

Prüft diese und die übergebene Zeichenkette auf Gleichheit.

Isom.Base.Boolean | EqualsIgnoreCase(Isom.Base.String other)

Vergleicht diese Zeichenkette mit einer weiteren Zeichenkette.

Isom.Base.Number | FindFirst(Isom.Base.String searchstring)

Sucht nach ersten Auftreten der Suchzeichenkette innerhalb dieser Zeichenkette.

Isom.Base.String | FromBytes(Isom.Base.String data, Isom.Base.String format, Isom.Base.String encoding, Isom.Base.String separators)

Generiert aus einer Zeichenkette, die eine Folge von Byte-Werten enthält, eine menschenlesbare Zeichenkette.

Isom.Base.Number | Length()

Liefert die Anzahl der einzelnen Zeichen in der Zeichenkette.

Isom.Base.Number | ParseHexNumber()

Interpretiert diese Zeichenkette als Hexadezimalzahl.

Isom.Base.Number | ParseNumber()

Interpretiert diese Zeichenkette als Dezimalzahl.

Isom.Base.String | Replace(Isom.Base.String searchstring, Isom.Base.String replacement)

Ersetzt innerhalb dieser Zeichenkette alle Vorkommen der Suchzeichenkette durch den Ersetzungstext.

Isom.Base.String | ReplaceFirst(Isom.Base.String searchstring, Isom.Base.String replacement)

Ersetzt innerhalb dieser Zeichenkette das erste Vorkommen der Suchzeichenkette durch den Ersetzungstext.

Isom.Base.Boolean | Search(Isom.Base.String searchstring)

Sucht nach der Suchzeichenkette innerhalb dieser Zeichenkette.

Isom.Base.StringList | Split(Isom.Base.String separators)

Teilt eine Zeichenkette anhand übergebener Separatoren und liefert eine Liste von Teilzeichenketten, die durch die Separatoren getrennt werden.

Isom.Base.String | Substring(Isom.Base.Number startIndex, Isom.Base.Number length)

Liefert einen Ausschnitt aus dieser Zeichenkette.

Isom.Base.String | ToBytes(Isom.Base.String data, Isom.Base.String format, Isom.Base.String encoding, Isom.Base.String separator)

Generiert aus einer (menschenlesbaren) Zeichenkette eine Darstellung als Byte-Folge.

Isom.Base.String | ToLower()

Wandelt alle Zeichen der Zeichenkette in Kleinschreibung um.

Isom.Base.String | ToUpper()

Wandelt alle Zeichen der Zeichenkette in Großschreibung um.

Funktionen für globale Objekte

Funktionen, mit denen die globale Ablage von Objekten ermöglicht wird.

Isom.Base.Boolean | AddGlobal(Isom.Base.String key, Isom.Base.String value)

Speichert eine Kopie dieses Zeichenkettenobjekts als globale Variable.

Isom.Base.StringList | GetExistingGlobals()

Ruft eine Liste der Schlüssel aller globalen Variablen des Typs 'String' ab

Isom.Base.String | GetGlobal(Isom.Base.String key)

Ruft die Zeichenkette ab, die unter dem übergebenen Schlüssel als globale Variable gesichert wurde.

Isom.Base.Boolean | RemoveGlobal(Isom.Base.String key)

Entfernt eine globale Zeichenkettenvariable, die unter dem übergebenen Schlüssel gespeichert wurde.

Funktionen zum Erhalten und Setzen von Zeichenketten

Funktionen für die Arbeit mit Textdefinitionen (deftext).

Isom.Base.String | GetTextCategory()

Ermittelt die Text-Kategorie des Strings

Isom.Base.String | GetTextId()

Ermittelt die Text-Id des Strings

Isom.Base.Boolean | SetTextCategory(Isom.Base.String category)

Setzt die Text-Kategorie des Strings.

Isom.Base.Boolean | SetTextId(Isom.Base.String textId)

Setzt die Text-Id des Strings.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.String | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Base.String | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Der Typ Isom.Base.String speichert Zeichenketten, die aus Unicode-Zeichen aufgebaut sind. Die maximale Länge wird in der Regel durch den verfügbare Arbeitsspeicher limitiert. Das theoretische Maximum für die Länge sind 2.147.483.647 Unicode-Zeichen.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Base\String.is

Dokumentation der Funktionen

Isom.Base.Boolean Isom.Base.String.AddGlobal | ( | Isom.Base.String | key,
 |  | Isom.Base.String | value
 | ) |  |

Speichert eine Kopie dieses Zeichenkettenobjekts als globale Variable.

Die übergebene Zeichenkette ist der Schlüssel, mit dem die gespeicherte Variable danach mit .GetGlobal() abgerufen werden kann. Existiert bereits eine globale Variable mit dem Schlüssel, wird der vorher gesicherte Wert ersetzt.

 String.AddGlobal("A", "1");
Parameter:
key | Schlüssel, mit dem die Zeichenkette als globale Variable gespeichert wird.
value | Zeichenkette, die gespeichert wird.
Rückgabe:
'true', falls die Zeichenkette als globale Variable gespeichert werden konnte, 'false' sonst (z.B. bei einem ungültigen Objekt für Schlüssel oder Wert).
[Isom\Base\String.is: 123]
objectbound Isom.Base.String Isom.Base.String.Append ( Isom.Base.String part )

Hängt die übergebene Zeichenkette an diese Zeichenkette an.

Das aktuelle Zeichenkettenobjekt übernimmt das Ergebnis als neuen Wert, außer es ist ungültig

 String s = "ab";
 s.Append("c");                   // s ist "abc"
Parameter:
part Zeichenkette, die angehängt werden soll.
Rückgabe:
Die aktuelle Zeichenkette
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die zweite Zeichenkette das Void-Objekt ist.
[Isom\Base\String.is: 199]
objectbound Isom.Base.String Isom.Base.String.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Rückgabe:
Kopie dieses Objekts.
[Isom\Base\String.is: 700]
objectbound Isom.Base.Boolean Isom.Base.String.Equals ( Isom.Base.String other )

Prüft diese und die übergebene Zeichenkette auf Gleichheit.

Bei diesem Vergleich wird auf Groß-/Kleinschreibung geachtet.

 String s = "abc";
 Boolean a = s.Equals("ABC");                   // a ist false
 Boolean a = s.Equals("abc");                   // a ist true
Parameter:
other Vergleichszeichenkette.
Rückgabe:
'true', falls diese Zeichenkette mit der Suchzeichenkette übereinstimmt 'false' sonst (auch wenn die Vergleichszeichenkette das Void-Objekt ist).
[Isom\Base\String.is: 268]
objectbound Isom.Base.Boolean Isom.Base.String.EqualsIgnoreCase ( Isom.Base.String other )

Vergleicht diese Zeichenkette mit einer weiteren Zeichenkette.

Bei diesem Vergleich wird nicht auf Groß-/Kleinschreibung geachtet.

 String s = "abc";
 Boolean a = s.EqualsIgnoreCase("ABC");                   // a ist true
 Boolean a = s.EqualsIgnoreCase("abc");                   // a ist true
 Boolean a = s.EqualsIgnoreCase("cba");                   // a ist false
Parameter:
other Vergleichszeichenkette.
Rückgabe:
'true', falls diese Zeichenkette mit der Suchzeichenkette übereinstimmt, 'false' sonst (auch wenn die Suchzeichenkette das Void-Objekt ist).
[Isom\Base\String.is: 432]
objectbound Isom.Base.Number Isom.Base.String.FindFirst ( Isom.Base.String searchstring )

Sucht nach ersten Auftreten der Suchzeichenkette innerhalb dieser Zeichenkette.

Bei dem Vergleich wird auf Groß-/Kleinschreibung (case) geachtet.

 String s = "abcb";
 Number pos = s.FindFirst("b");                   // pos ist 1
Parameter:
searchstring Suchzeichenkette.
Rückgabe:
0-basierter Index, an dem die Zeichenkette gefunden wurde.
[Isom\Base\String.is: 309]
Isom.Base.String Isom.Base.String.FromBytes | ( | Isom.Base.String | data,
 |  | Isom.Base.String | format,
 |  | Isom.Base.String | encoding,
 |  | Isom.Base.String | separators
 | ) |  |

Generiert aus einer Zeichenkette, die eine Folge von Byte-Werten enthält, eine menschenlesbare Zeichenkette.

Parameter:
data | Byte-Folge, die gemäß den anderen Parametern formatiert ist
format Gibt an, ob die einzelnen Byte-Werte dezimal oder hexadezimal dargestellt sind. Bei hexadezimaler Darstellung darf das Präfix "0x" oder "0X" vorangestellt sein, wenn Trennzeichen zwischen den einzelnen Byte-Werten vorhanden sind. Wird das Void-Objekt übergeben, wird als Vorgabewert hexadezimale Darstellung angenommen. Groß- und Kleinschreibung wird bei diesem Parameter nicht unterschieden. Mögliche Werte sind:
  • HEX
  • DEC
  • String.Void()
encoding Gibt die Byte- und Zeichenkodierung an, die zur Dekodierung verwendet werden soll. Es gibt 2 Gruppen von Parametern, von denen jeweils höchstens einer angegeben wird. Die beiden Bestandteile werden durch einen Doppelpunkt getrennt. Die erste Gruppe enthält mögliche Kodierungen einzelner Bytes (BCD-P, BCD, Base64, Base32, unverändert), die zweite Gruppe enthält unterstützte Zeichensätze (ASCII, ISO-8859-x, UTF-8). Ist kein Wert aus Gruppe 1 angegeben, wird "unverändert" angenommen. Ist kein Wert aus Gruppe 2 angegeben, wird "ASCII" angenommen. Wird das Void-Objekt übergeben, werden die Vorgabewerte aus beiden Gruppen verwendet. Groß- und Kleinschreibung wird bei diesem Parameter nicht unterschieden. Mögliche Werte sind z.B.:
  • ASCII
  • BCD-P
  • Base64:UTF-8
  • String.Void()
separators | Zeichenkette, die alle Zeichen enthält, die als Trennzeichen erkannt werden sollen. Wird das Void-Objekt oder die leere Zeichenkette angegeben, wird kein Trennzeichen verwendet. Stattdessen wird erwartet, dass data genau 2 hexadezimale Ziffern zur Darstellung eines Bytes enthält.

Das folgende Beispiel zeigt die Dekodierung, wobei für alle Parameter außer data mit Vorgabewerten gearbeitet wird.

   String input = "414243";
   String output = String.FromBytes(input, String.Void(), String.Void(), String.Void());
   // Ergebnis: "ABC"

Das folgende Beispiel zeigt die Dekodierung mit Verwendung des Leerzeichens als Trennzeichen:

   String input = "41 42 43"; // Alternativ: "0x41 0x42 0x43"
   String output = String.FromBytes(input, String.Void(), String.Void(), " ");
   // Ergebnis: "ABC"

Das folgende Beispiel zeigt die Dekodierung einer Byte-Folge, die BCD-P-kodiert ist, d.h. die oberen und die unteren 4 Bits jedes Bytes enthalten eine Dezimalziffer:

   String input = "0x41 0x42 0x43";
   String output = String.FromBytes(input, String.Void(), "BCD-P", " ");
   // Ergebnis: "414243"

Das folgende Beispiel zeigt die Dekodierung einer Byte-Folge, die BCD-P-kodiert ist, wobei die Eingabewerte dezimal dargestellt sind:

   String input = "65 66 67";
   String output = String.FromBytes(input, "DEC", "BCD-P", " ");
   // Ergebnis: "414243"
Ausnahmebehandlung:
Wenn data das Void-Objekt ist
Wenn data nicht mit den angegebenen Parametern dekodiert werden kann, z.B.
  • data enthält Zeichen, die im angegebenen Format nicht zulässig sind, z.B. Hexadezimalziffern a-f, wenn dezimale Kodierung angegeben wird
  • Es wird BCD- oder BCD-P-Kodierung angegeben, aber data enthält nicht nur Ziffern
  • Es wird UTF-8-Kodierung angegeben, aber data stellt keine gültige UTF-8-Bytefolge dar
Wenn sich angegebene Parameter gegenseitig ausschließen: Wird angegeben, dass kein Trennzeichen verwendet wird, dann muss die Darstellung einzelner Bytes hexadezimal erfolgen.
Rückgabe:
Die aus data generierte, menschenlesbare Zeichenkette
[Isom\Base\String.is: 557]
Isom.Base.StringList Isom.Base.String.GetExistingGlobals ( )

Ruft eine Liste der Schlüssel aller globalen Variablen des Typs 'String' ab

   String.AddGlobal("A", "1");
   String.AddGlobal("B", "2");
   StringList keys = String.GetExistingGlobals(); // enthält "A" und "B"
Rückgabe:
Liste der Schlüssel aller globalen Variablen des Typs 'String'
[Isom\Base\String.is: 175]
Isom.Base.String Isom.Base.String.GetGlobal ( Isom.Base.String key )

Ruft die Zeichenkette ab, die unter dem übergebenen Schlüssel als globale Variable gesichert wurde.

 String value = String.GetGlobal("A");
Parameter:
key Schlüssel der gesuchten globalen Variable.
Rückgabe:
Kopie des gefundenen Variablenwerts. Änderungen an diesem Rückgabewert ändern den Wert der gesicherten globalen Variable nicht. Um Änderungen in die globale Variable zu übernehmen, muss der geänderte Wert mit .AddGlobal() wieder gesichert werden.
Ausnahmebehandlung:
Die Funktion liefert ein Void-Objekt, falls innerhalb dieser Sitzung noch keine Variable unter dem Schlüssel abgespeichert wurde oder der Schlüssel ein ungültiges Objekt ist.
[Isom\Base\String.is: 145]
objectbound Isom.Base.String Isom.Base.String.GetTextCategory ( )

Ermittelt die Text-Kategorie des Strings

 String a = ...
 String textId = a.GetTextCategory();
Rückgabe:
Text-Kategorie des Strings, falls diese gesetzt ist. Ansonsten wird das Void-Objekt zurückgegeben.
[Isom\Base\String.is: 639]
objectbound Isom.Base.String Isom.Base.String.GetTextId ( )

Ermittelt die Text-Id des Strings

 String a = "Test";
 //...
 String textId = a.GetTextId();
Rückgabe:
Text-Id des Strings, falls diese gesetzt ist. Ansonsten wird das Void-Objekt zurückgegeben.
[Isom\Base\String.is: 624]
objectbound Isom.Base.Boolean Isom.Base.String.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Base\String.is: 692]
objectbound Isom.Base.Number Isom.Base.String.Length ( )

Liefert die Anzahl der einzelnen Zeichen in der Zeichenkette.

 String s = "ab";
 Number n = s.Length();                   // n ist 2
Rückgabe:
Länge der Zeichenkette.
[Isom\Base\String.is: 323]
objectbound Isom.Base.Number Isom.Base.String.ParseHexNumber ( )

Interpretiert diese Zeichenkette als Hexadezimalzahl.

Die Zeichenkette darf nicht mit '0x' beginnen.

 String s = "FF";
 Number n = s.ParseNumber();                    // n ist 255 (in dezimaler Schreibweise)
Rückgabe:
Zahl, die der Zeichenkette entspricht.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Zeichenkette nicht in eine gültige Zahl konvertiert werden kann.
[Isom\Base\String.is: 411]
objectbound Isom.Base.Number Isom.Base.String.ParseNumber ( )

Interpretiert diese Zeichenkette als Dezimalzahl.

 String s = "5.1";
 Number n = s.ParseNumber();                    // n ist 5.1
Rückgabe:
Zahl, die der Zeichenkette entspricht.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Zeichenkette nicht in eine Dezimalzahl konvertiert werden kann.
[Isom\Base\String.is: 394]
Isom.Base.Boolean Isom.Base.String.RemoveGlobal ( Isom.Base.String key )

Entfernt eine globale Zeichenkettenvariable, die unter dem übergebenen Schlüssel gespeichert wurde.

 Number.RemoveGlobal("A");
Parameter:
key Schlüssel, unter dem die globale Variable abgelegt wurde
Rückgabe:
'true', falls die globale Variable mit dem Schlüssel gelöscht wurde 'false, falls unter dem Schlüssel keine globale Variable abgelegt war.
[Isom\Base\String.is: 160]
objectbound Isom.Base.String Isom.Base.String.Replace | ( | Isom.Base.String | searchstring,
 |  | Isom.Base.String | replacement
 | ) |  |

Ersetzt innerhalb dieser Zeichenkette alle Vorkommen der Suchzeichenkette durch den Ersetzungstext.

Das aktuelle Zeichenkettenobjekt übernimmt das Ergebnis als neuen Wert, außer es ist ungültig

 String s = "ab";
 s.Replace("b", "bc");                    // s ist "abc"
Parameter:
searchstring | Suchzeichenkette.
replacement | Ersetzungstext.
Rückgabe:
Die aktuelle Zeichenkette
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben falls die Suchzeichenkette oder der Ersetzungstext das Void-Objekt ist.
Siehe auch:
Isom.Base.String.ReplaceFirst() um nur ein Vorkommen zu ersetzen.
[Isom\Base\String.is: 223]
objectbound Isom.Base.String Isom.Base.String.ReplaceFirst | ( | Isom.Base.String | searchstring,
 |  | Isom.Base.String | replacement
 | ) |  |

Ersetzt innerhalb dieser Zeichenkette das erste Vorkommen der Suchzeichenkette durch den Ersetzungstext.

Das aktuelle Zeichenkettenobjekt übernimmt das Ergebnis als neuen Wert, außer es ist ungültig.

 String s = "abcb";
 s.ReplaceFirst("b", dd");                    // s ist "addcb"
Parameter:
searchstring | Suchzeichenkette.
replacement | Ersetzungstext.
Rückgabe:
Die aktuelle Zeichenkette
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben falls die Suchzeichenkette oder der Ersetzungstext das Void-Objekt oder der Leerstring ist.
Siehe auch:
Isom.Base.String.Replace() um alle Vorkommen zu ersetzen.
[Isom\Base\String.is: 248]
objectbound Isom.Base.Boolean Isom.Base.String.Search ( Isom.Base.String searchstring )

Sucht nach der Suchzeichenkette innerhalb dieser Zeichenkette.

Bei dem Vergleich wird auf Groß-/Kleinschreibung geachtet.

 String s = "ab";
 Boolean a = s.Search("ba");                  // a ist false
 Boolean a = s.Search("a");                   // a ist true
Parameter:
searchstring Suchzeichenkette.
Rückgabe:
'true', falls die Suchzeichenkette Teil dieser Zeichenkette ist, 'false' sonst (auch wenn die Suchzeichenkette das Void-Objekt ist).
Siehe auch:
Isom.Base.String.FindFirst() für die Positionsbestimmung.
[Isom\Base\String.is: 291]
objectbound Isom.Base.Boolean Isom.Base.String.SetTextCategory ( Isom.Base.String category )

Setzt die Text-Kategorie des Strings.

Das Setzen einer leeren Text-Kategor führt zum Zurücksetzen der Text-Kategorie.

 String a = "Beispieltext für einen Fehler";
 a.SetTextCategory("MESSAGE");
Rückgabe:
'true', falls das Setzen erfolgreich war
[Isom\Base\String.is: 673]
objectbound Isom.Base.Boolean Isom.Base.String.SetTextId ( Isom.Base.String textId )

Setzt die Text-Id des Strings.

Anhand der Text-Id kann ein Klient die Übersetzung des Texts in eine andere Sprache suchen.

Das Setzen einer leeren Text-Id führt zum Zurücksetzen der Text-Id.

 String a = "Beispielfür einen übersetzbaren Text";
 a.SetTextId("IFS.Taurus.ErrorText.Error1000");
Rückgabe:
'true', falls das Setzen erfolgreich war
[Isom\Base\String.is: 657]
objectbound Isom.Base.StringList Isom.Base.String.Split ( Isom.Base.String separators )

Teilt eine Zeichenkette anhand übergebener Separatoren und liefert eine Liste von Teilzeichenketten, die durch die Separatoren getrennt werden.

Die Separatorzeichen werden als Zeichenkette übergeben. Jedes Zeichen dieser Zeichenkette wird als mögliches Separatorzeichen verwendet.

 String s = "a,b,c,d";
 StringList list = s.Split(",");              // list besteht aus "a", "b", "c" und "d"
 while( list.HasNext() )
 {
    String part = list.Next();
    ...
 }
Parameter:
separators Separatorzeichen.
Rückgabe:
Liste der Teilzeichenketten. Die Liste enthält mindestens ein Element.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Separatorzeichenkette das Void-Objekt ist.
[Isom\Base\String.is: 352]
objectbound Isom.Base.String Isom.Base.String.Substring | ( | Isom.Base.Number | startIndex,
 |  | Isom.Base.Number | length
 | ) |  |

Liefert einen Ausschnitt aus dieser Zeichenkette.

 String s = "abc";
 String subString = s.Substring(0, 1);                    // subString ist "a"
 String subString = s.Substring(1, 1);                    // subString ist "b"
 String subString = s.Substring(1, 2);                    // subString ist "bc"
Parameter:
startIndex | Index, ab dem die Teilzeichenkette bestimmt werden soll. Die Zählung beginnt bei 0 für das erste Zeichen.
length | Länge der Teilzeichenkette ab der Anfangsposition. Wenn der Parameter '-1' ist, wird die Teilzeichen- kette ab der Anfangsposition bis zum Ende geliefert.
Rückgabe:
Ausschnitt aus dieser Zeichenkette
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls ein Parameter das Void-Objekt ist oder die Parameter außerhalb des zulässigen Bereichs liegen (negativ oder größer/gleich der Länge der Zeichenkette). Die Ausnahme ist die Länge '-1'.
[Isom\Base\String.is: 378]
Isom.Base.String Isom.Base.String.ToBytes | ( | Isom.Base.String | data,
 |  | Isom.Base.String | format,
 |  | Isom.Base.String | encoding,
 |  | Isom.Base.String | separator
 | ) |  |

Generiert aus einer (menschenlesbaren) Zeichenkette eine Darstellung als Byte-Folge.

Wird hexadezimale Darstellung verwendet, erfolgt die Ausgabe mit genau 2 Ziffern pro Byte ohne Präfix "0x".

Diese Funktion ist die Umkehrfunktion von FromBytes().

Parameter:
data | Zeichenkette, aus der eine Darstellung als Byte-Folge erzeugt werden soll
format | Gibt an, ob die einzelnen Byte-Werte dezimal oder hexadezimal dargestellt werden. Die möglichen Werte sind die gleichen wie in FromBytes().
encoding | Gibt die Byte- und Zeichenkodierung an, die zur Kodierung verwendet werden soll. Die möglichen Werte sind die gleichen wie in FromBytes().
separator | Zeichen oder Zeichenkette, mit der zwei aufeinanderfolgende Byte-Werte getrennt werden

Das folgende Beispiel zeigt die Kodierung einer Byte-Folge mit BCD-P-Kodierung, wobei die Ausgabewerte dezimal dargestellt werden:

   String input = "414243";
   String output = String.ToBytes(input, "DEC", "BCD-P", " ");
   // Ergebnis: "65 66 67"
Ausnahmebehandlung:
Wenn data das Void-Objekt ist
Wenn die in data angegebene Zeichenkette in der angegebenen Zeichen- oder Byte-Kodierung nicht darstellbar ist, z.B.:
  • BCD- oder BCD-P-Kodierung für eine Zeichenkette, die nicht nur Ziffern enthält
  • ISO-8859-1-Kodierung für eine Zeichenkette mit nichtwesteuropäischen Schriftzeichen
Rückgabe:
Darstellung von data als Byte-Folge
[Isom\Base\String.is: 600]
objectbound Isom.Base.String Isom.Base.String.ToLower ( )

Wandelt alle Zeichen der Zeichenkette in Kleinschreibung um.

Das aktuelle Zeichenkettenobjekt übernimmt das Ergebnis als neuen Wert, außer es ist ungültig.

 String s = "aB";
 s.ToLower();                     // s ist danach "ab"
Rückgabe:
Die aktuelle Zeichenkette in Kleinschreibung.
[Isom\Base\String.is: 462]
objectbound Isom.Base.String Isom.Base.String.ToUpper ( )

Wandelt alle Zeichen der Zeichenkette in Großschreibung um.

Das aktuelle Zeichenkettenobjekt übernimmt das Ergebnis als neuen Wert, außer es ist ungültig.

 String s = "aB";
 s.ToUpper();                     // s ist danach "AB"
Rückgabe:
Die aktuelle Zeichenkette in Großschreibung.
[Isom\Base\String.is: 447]
Isom.Base.String Isom.Base.String.Void ( )

Erzeugt ein Void-Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

Rückgabe:
Void-Objekt
[Isom\Base\String.is: 710]


für Serviceautoren

Isom.Base.StringDictionary

Namensraum Isom.Base.StringDictionary

Wörterbücher mit Zeichenketteneinträgen vom Typ Isom.Base.String Mehr...

Funktionen
Isom.Base.StringDictionary | CreateStringDictionary()

Erzeugt ein neues, leeres Wörterbuch für Zeichenketten.

Wörterbuchfunktionen

Isom.Base.Boolean | Add(Isom.Base.String key, Isom.Base.String value)

Setzt einen Eintrag im Wörterbuch.

Isom.Base.Number | Count()

Ermittelt die Anzahl der gesetzten Einträge (Schlüssel).

Isom.Base.String | Get(Isom.Base.String key)

Sucht einen Eintrag für einen vorgegebenen Schlüssel.

Isom.Base.StringList | GetKeys()

Ermittelt die Liste aller gesetzten Schlüssel.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.StringDictionary | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Base.StringDictionary | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Isom.Base.StringDictionary repräsentiert Wörterbücher mit Zeichenketten (Isom.Base.String).

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Base\StringDictionary.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Base.StringDictionary.Add | ( | Isom.Base.String | key,
 |  | Isom.Base.String | value
 | ) |  |

Setzt einen Eintrag im Wörterbuch.

Ein vorher mit dem Schlüssel geschriebener Eintrag wird dabei überschrieben.

 StringDictionary dict = StringDictionary.CreateStringDictionary();
 dict.Add("A", "1");
Parameter:
key | Schlüssel des Eintrags
value | Wert des Eintrags
Rückgabe:
true
[Isom\Base\StringDictionary.is: 132]
objectbound Isom.Base.StringDictionary Isom.Base.StringDictionary.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Dabei werden für alle eingetragenen Werte Kopien erzeugt.

Rückgabe:
Kopie dieses Objekts.
[Isom\Base\StringDictionary.is: 185]
objectbound Isom.Base.Number Isom.Base.StringDictionary.Count ( )

Ermittelt die Anzahl der gesetzten Einträge (Schlüssel).

 StringDictionary dict = StringDictionary.CreateStringDictionary();
 Number n = dict.Count();   //n ist 0
Rückgabe:
Größe des Wörterbuchs.
[Isom\Base\StringDictionary.is: 96]
Isom.Base.StringDictionary Isom.Base.StringDictionary.CreateStringDictionary ( )

Erzeugt ein neues, leeres Wörterbuch für Zeichenketten.

 StringDictionary dict = StringDictionary.CreateStringDictionary();
Rückgabe:
Leeres Wörterbuch für Zeichenketten.
[Isom\Base\StringDictionary.is: 77]
objectbound Isom.Base.String Isom.Base.StringDictionary.Get ( Isom.Base.String key )

Sucht einen Eintrag für einen vorgegebenen Schlüssel.

 StringDictionary dict = StringDictionary.CreateStringDictionary();
 dict.Add("A", "1");
 String s = dict.Get("A");  //s ist "1"
 String t = dict.Get("B");    //t ist das Void-Objekt
Parameter:
key Schlüssel des gesuchten Eintrags
Rückgabe:
Wert des Eintrags zum vorgegebenen Schlüssel.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls für den Schlüssel kein Wert gesetzt ist.
[Isom\Base\StringDictionary.is: 115]
objectbound Isom.Base.StringList Isom.Base.StringDictionary.GetKeys ( )

Ermittelt die Liste aller gesetzten Schlüssel.

Durch Durchlaufen der Liste lassen sich alle Einträge des Wörterbücher abrufen.

 StringDictionary dict = ..
 StringList keys = dict.GetKeys();
 keys.Reset();
 while( keys.HasNext() )
 {
    String key = keys.Next();
    String value = dict.Get(key);
    ...
 }
Rückgabe:
Liste aller im Wörterbuch enthaltenen Schlüssel
[Isom\Base\StringDictionary.is: 154]
objectbound Isom.Base.Boolean Isom.Base.StringDictionary.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Base\StringDictionary.is: 175]
Isom.Base.StringDictionary Isom.Base.StringDictionary.Void ( )

Erzeugt ein Void-Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

Rückgabe:
Void-Objekt
[Isom\Base\StringDictionary.is: 196]


für Serviceautoren

Isom.Base.StringList

Namensraum Isom.Base.StringList

Listen von Zeichenketten des Typs Isom.Base.String Mehr...

Funktionen
Isom.Base.String | Concat(Isom.Base.String separator)

Liefert eine Zeichenkette, die alle Elemente der Liste enthält.

Isom.Base.Boolean | ContainsIgnoreCase(Isom.Base.String element)

Abfrage, ob ein Element unter Vernachlässigung der Groß-/Kleinschreibung (case) in der Liste vorhanden ist.

Isom.Base.StringList | CreateStringList()

Erzeugt eine neue, leere Zeichenkettenliste.

Isom.Base.Boolean | RemoveAll(Isom.Base.String value)

Entfernt alle Vorkommen der vorgegebenen Zeichenkette in der Liste.

Isom.Base.StringList | Sort()

Sortiert alle Listenelementen aphabetisch aufsteigend

Funktionen für globale Objekte

Funktionen, mit denen die globale Ablage von Objekten ermöglicht wird.

Isom.Base.Boolean | AddGlobal(Isom.Base.String key, Isom.Base.StringList value)

Speichert eine Kopie dieser Liste als globale Variable.

Isom.Base.Boolean | AddStringToGlobalList(Isom.Base.String key, Isom.Base.String value, Isom.Base.Boolean insertUnique)

Fügt eine Zeichenkette zu einer in einer globalen Variablen gesicherten Zeichenkettenliste hinzu.

Isom.Base.StringList | GetExistingGlobals()

Ruft eine Liste der Schlüssel aller globalen Variablen des Typs 'StringList' ab

Isom.Base.StringList | GetGlobal(Isom.Base.String key)

Ruft die Liste ab, welche als globale Variable unter dem Schlüssel für Zeichenkettenlisten gespeichert wurde.

Isom.Base.Boolean | RemoveGlobal(Isom.Base.String key)

Entfernt eine Liste, die als globale Variable unter dem übergebenen Schlüssel gespeichert wurde.

Listenfunktionen

Isom.Base.String | At(Isom.Base.Number index)

Ruft eine durch einen Index gekennzeichnete Zeichenkette aus der Liste ab.

Isom.Base.Boolean | Contains(Isom.Base.String element)

Abfrage, ob ein Element in der Liste vorhanden ist.

Isom.Base.String | Current()

Liefert während des Durchlaufens der Liste die aktuelle Zeichenkette.

Isom.Base.Boolean | HasNext()

Prüft, ob es beim Durchlaufen der Liste mit .Next() Zeichenketten gibt, die noch nicht abgerufen wurden.

Isom.Base.Number | Insert(Isom.Base.String element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Prüft, ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Base.String | Next()

Liefert beim Durchlaufen der Liste die nächste Zeichenkette.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt ein durch einen Index gekennzeichnetes Element aus der Liste.

Isom.Base.Boolean | Reset()

Setzt den Durchlauf-Iterator vor das erste Element der Liste, so ein neuer Durchlauf der Liste begonnen werden kann.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.StringList | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Base.StringList | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Isom.Base.StringList repräsentiert Listen von Zeichenketten (Isom.Base.String).

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte Reset() aufgerufen werden.
Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Base\StringList.is

Dokumentation der Funktionen

Isom.Base.Boolean Isom.Base.StringList.AddGlobal | ( | Isom.Base.String | key,
 |  | Isom.Base.StringList | value
 | ) |  |

Speichert eine Kopie dieser Liste als globale Variable.

Die übergebene Zeichenkette ist der Schlüssel, mit dem die gespeicherte Variable danach mit .GetGlobal() abgerufen werden kann. Existiert bereits eine globale Variable mit dem Schlüssel, wird der vorher gesicherte Wert ersetzt.

 StringList list = StringList.CreateStringList();
 StringList.AddGlobal("A", list);
Parameter:
key | Schlüssel, mit dem die Zeichenkette als globale Variable gespeichert wird.
value | Zeichenkette, die gespeichert wird.
Rückgabe:
'true', falls die Zeichenkette als globale Variable gespeichert werden konnte, 'false' sonst (z.B. bei einem ungültigen Objekt für Schlüssel oder Wert).
[Isom\Base\StringList.is: 213]
Isom.Base.Boolean Isom.Base.StringList.AddStringToGlobalList | ( | Isom.Base.String | key,
 |  | Isom.Base.String | value,
 |  | Isom.Base.Boolean | insertUnique
 | ) |  |

Fügt eine Zeichenkette zu einer in einer globalen Variablen gesicherten Zeichenkettenliste hinzu.

Als Schlüssel dient die übergebene Zeichenkette key. Existiert unter diesem Schlüssel keine Zeichenkettenliste, so wird sie erzeugt.

 StringList.AddStringToGlobalList("A", "X", true);
Parameter:
key | Schlüssel der als globale Variable abgelegten Zeichenkettenliste, zu der die Zeichenkette hinzugefügt wird.
value | Zeichenkette, die hinzugefügt werden soll.
insertUnique | Wahrheitswert, der angibt, ob die Zeichenkette auch eingefügt werden soll, wenn sie bereits in der globalen Zeichenkettenliste enthalten ist. Ist Wert 'true', so wird die Zeichenkette nicht der Liste hinzugefügt, falls sie bereits enthalten ist.
Rückgabe:
'true', falls die Zeichenkette zu der globalen Zeichenkettenliste hinzugefügt werden konnte, 'false' sonst (z.B. weil der Schlüssel oder der Wert das Void-Objekt waren).
[Isom\Base\StringList.is: 240]
objectbound Isom.Base.String Isom.Base.StringList.At ( Isom.Base.Number index )

Ruft eine durch einen Index gekennzeichnete Zeichenkette aus der Liste ab.

 StringList list = StringList.CreateStringList();
 list.Insert("A");
 String a = list.At(0);               //a ist "A"
 String b = list.At(1);               //b ist das Void-Objekt
Parameter:
index Index des abgerufenen Elements in der Liste, beginnend bei 0 für das erste Element.
Rückgabe:
Zeichenkette mit dem übergebenen Index.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 ist oder größer gleich der Anzahl der Listenelemente.
[Isom\Base\StringList.is: 444]
objectbound Isom.Base.StringList Isom.Base.StringList.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Dabei werden für alle enthaltenen Zeichenkettenobjekte ebenso Kopien erzeugt.

Rückgabe:
Kopie dieses Objekts.
[Isom\Base\StringList.is: 542]
objectbound Isom.Base.String Isom.Base.StringList.Concat ( Isom.Base.String separator )

Liefert eine Zeichenkette, die alle Elemente der Liste enthält.

Zwischen den einzelnen Elementen wird die Separator- zeichenkette eingefügt. Diese Separatorzeichenkette kann auch die leere Zeichenkette "" sein. In diesem Falle, werden nur alle Zeichenketten dieser Liste aneinandergehängt.

 StringList list = StringList.CreateStringList();
 list.Insert("A");
 list.Insert("B");
 list.Insert("C");
 list.Insert("D");
 String s = list.Concat(",");   // s ist "A,B,C,D"
Parameter:
separator Separatorzeichenkette, die zwischen den einzelnen Elementen der Liste eingefügt wird.
Rückgabe:
Aus den Elementen konstruierte Zeichenkette.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Separatorzeichenkette das Void-Objekt ist.
[Isom\Base\StringList.is: 182]
objectbound Isom.Base.Boolean Isom.Base.StringList.Contains ( Isom.Base.String element )

Abfrage, ob ein Element in der Liste vorhanden ist.

 StringList list = StringList.CreateStringList();
 list.Insert("A");
 Boolean contains = list.Contains("B");   // contains ist false
 Boolean contains = list.Contains("A");   // contains ist true
Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
Siehe auch:
Isom.Base.StringList.ContainsIgnoreCase() für Variante ohne Berücksichtigung der Groß-/Kleinschreibung.
[Isom\Base\StringList.is: 514]
objectbound Isom.Base.Boolean Isom.Base.StringList.ContainsIgnoreCase ( Isom.Base.String element )

Abfrage, ob ein Element unter Vernachlässigung der Groß-/Kleinschreibung (case) in der Liste vorhanden ist.

 StringList list = StringList.CreateStringList();
 list.Insert("A");
 Boolean contains = list.ContainsIgnoreCase("b");   // contains ist false
 Boolean contains = list.ContainsIgnoreCase("a");   // contains ist true
Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
Siehe auch:
Isom.Base.StringList.Contains() für Variante mit Berücksichtigung der Groß-/Kleinschreibung.
[Isom\Base\StringList.is: 148]
Isom.Base.StringList Isom.Base.StringList.CreateStringList ( )

Erzeugt eine neue, leere Zeichenkettenliste.

 StringList list = StringList.CreateStringList();
Rückgabe:
Leere Liste.
[Isom\Base\StringList.is: 105]
objectbound Isom.Base.String Isom.Base.StringList.Current ( )

Liefert während des Durchlaufens der Liste die aktuelle Zeichenkette.

 StringList list = ...
 list.Reset();                        //Listendurchlauf vorbereiten
 while (list.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    list.Next();                      //Durchlauf weiterführen
    Number current = list.Current();  //Element abrufen
    ...
 }
Rückgabe:
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Durchlauf-Iterator vor das erste Element der Liste zeigt.
[Isom\Base\StringList.is: 404]
Isom.Base.StringList Isom.Base.StringList.GetExistingGlobals ( )

Ruft eine Liste der Schlüssel aller globalen Variablen des Typs 'StringList' ab

   StringList list1 = StringList.CreateStringList();
   list1.Insert("A1");
   list1.Insert("A2");
   StringList.AddGlobal("A", list1);

   StringList list2 = StringList.CreateStringList();
   list2.Insert("B1");
   String.AddGlobal("B", list2);

   StringList keys = StringList.GetExistingGlobals(); // enthält "A" und "B"
Rückgabe:
Liste der Schlüssel aller globalen Variablen des Typs 'StringList'
[Isom\Base\StringList.is: 298]
Isom.Base.StringList Isom.Base.StringList.GetGlobal ( Isom.Base.String key )

Ruft die Liste ab, welche als globale Variable unter dem Schlüssel für Zeichenkettenlisten gespeichert wurde.

 StringList.GetGlobal("A");
Parameter:
key Schlüssel, unter dem die Liste im globalen Variablenfeld gesucht wird.
Rückgabe:
Kopie des im globalen Variablenfeld gespeicherten Wertes. Änderungen an diesem Rückgabewert ändern nicht den im globalen Variablenfeld gespeicherten Wert.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls innerhalb dieser Sitzung noch keine Variable unter diesem Schlüssel abgespeichert wurde oder der Schlüssel das Void-Objekt ist.
[Isom\Base\StringList.is: 261]
objectbound Isom.Base.Boolean Isom.Base.StringList.HasNext ( )

Prüft, ob es beim Durchlaufen der Liste mit .Next() Zeichenketten gibt, die noch nicht abgerufen wurden.

 StringList list = ...
 list.Reset();                        //Listendurchlauf vorbereiten
 while (list.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    Number current = list.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
'true', falls noch Zeichenketten in der Liste mit .Next() abgerufen werden können, 'false' sonst.
[Isom\Base\StringList.is: 360]
objectbound Isom.Base.Number Isom.Base.StringList.Insert ( Isom.Base.String element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Durchlauf-Iterator wird durch diese Operation zurückgesetzt.

 StringList list = StringList.CreateStringList();
 list.Insert("A");
Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügendes Zeichenkette.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
[Isom\Base\StringList.is: 472]
objectbound Isom.Base.Boolean Isom.Base.StringList.IsEmpty ( )

Prüft, ob diese Liste leer ist oder nicht.

 StringList list = StringList.CreateStringList();
 Boolean isEmpty = list.IsEmpty();    // isEmpty ist true
 list.Insert("A");
 isEmpty = list.IsEmpty();            // isEmpty ist false
Rückgabe:
'true', falls die Liste leer ist, 'false' sonst.
[Isom\Base\StringList.is: 340]
objectbound Isom.Base.Boolean Isom.Base.StringList.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Base\StringList.is: 533]
objectbound Isom.Base.Number Isom.Base.StringList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

 StringList list = StringList.CreateStringList();
 list.Insert("A");
 list.Insert("B");
 list.Insert("C");
 list.Insert("D");
 Number length = list.Length();       //length ist 4
Rückgabe:
Anzahl der Elemente.
[Isom\Base\StringList.is: 325]
objectbound Isom.Base.String Isom.Base.StringList.Next ( )

Liefert beim Durchlaufen der Liste die nächste Zeichenkette.

Ein Listendurchlauf wird mit .Reset() zurückgesetzt, um sie mit .Next() vom Listenanfang an durchlaufen zu können.

 StringList list = ...
 list.Reset();                        //Listendurchlauf vorbereiten
 while (list.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    Number current = list.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Nächstes Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Base\StringList.is: 382]
objectbound Isom.Base.Boolean Isom.Base.StringList.Remove ( Isom.Base.Number index )

Entfernt ein durch einen Index gekennzeichnetes Element aus der Liste.

Ein eventuell aktiver Durchlauf-Iterator, wird durch diese Operation zurückgesetzt.

Parameter:
index Index des zu entfernenden Elements in der Liste, beginnend bei 0 für das erste Element.
 StringList list = StringList.CreateStringList();
 Boolean result = list.Remove(0);       //result ist false
 list.Insert("A");
 result = list.Remove(0);               //result ist true
Rückgabe:
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt).
[Isom\Base\StringList.is: 494]
objectbound Isom.Base.Boolean Isom.Base.StringList.RemoveAll ( Isom.Base.String value )

Entfernt alle Vorkommen der vorgegebenen Zeichenkette in der Liste.

 StringList list = StringList.CreateStringList();
 list.Insert("A");
 list.Insert("A");
 list.Insert("A");
 result = list.RemoveAll("B");            // result ist false
 Boolean isEmpty = list.isEmpty();          // isEmpty ist false
 result = list.RemoveAll("A");            // result ist true
 Boolean isEmpty = list.isEmpty();          // isEmpty ist true
Parameter:
value Zu entfernender String-Wert.
Rückgabe:
'true', falls mindestens ein Element entfernt werden konnte, 'false' sonst.
[Isom\Base\StringList.is: 127]
Isom.Base.Boolean Isom.Base.StringList.RemoveGlobal ( Isom.Base.String key )

Entfernt eine Liste, die als globale Variable unter dem übergebenen Schlüssel gespeichert wurde.

 Number.RemoveGlobal("A");
Parameter:
key Schlüssel, unter dem die globale Variable abgelegt wurde
Rückgabe:
'true', falls die globale Variable mit dem Schlüssel gelöscht wurde 'false, falls unter dem Schlüssel keine globale Variable abgelegt war.
[Isom\Base\StringList.is: 276]
objectbound Isom.Base.Boolean Isom.Base.StringList.Reset ( )

Setzt den Durchlauf-Iterator vor das erste Element der Liste, so ein neuer Durchlauf der Liste begonnen werden kann.

 StringList list = ...
 list.Reset();                        //Listendurchlauf vorbereiten
 while (list.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    Number current = list.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Immer 'true'.
[Isom\Base\StringList.is: 423]
objectbound Isom.Base.StringList Isom.Base.StringList.Sort ( )

Sortiert alle Listenelementen aphabetisch aufsteigend

Rückgabe:
alphabetische Sortierung der Listenelementen aufsteigend
[Isom\Base\StringList.is: 157]
Isom.Base.StringList Isom.Base.StringList.Void ( )

Erzeugt ein Void-Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

Rückgabe:
Void-Objekt
[Isom\Base\StringList.is: 552]


für Serviceautoren

Isom.Base.Uri

Namensraum Isom.Base.Uri

URIs (Uniform Resource Identifiers) Mehr...

Funktionen
Isom.Base.Uri | DefineUri(Isom.Base.String uri)

Erzeugt ein neues URI-Objekt.

Isom.Base.String | GetChecksum()

Liefert die Prüfsumme des Inhalts einer an dem URI vorliegenden Datei.

Isom.Base.String | GetFragment()

Liefert den Dokumentfragment-Anteil des URI (oder leer).

Isom.Base.String | GetHost()

Liefert den Host-Anteil des URI (oder leer).

Isom.Base.String | GetPath()

Liefert den Pfad-Anteil des URI (oder leer).

Isom.Base.String | GetPort()

Liefert die Anschlussnummer des URI (oder leer).

Isom.Base.String | GetQuery()

Liefert den CGI-Query-Anteil des URI (oder leer).

Isom.Base.String | GetScheme()

Liefert den Schema-Anteil des URI.

Isom.Base.String | GetUserInfo()

Liefert den Basis-Authentifizierungs-Anteil des URI (oder leer).

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Uri | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Base.Uri | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Isom.Base.Uri repräsentiert einen URI (Uniform Resource Identifier). Momentan werden die folgenden URI-Schemata unterstützt:

Schema | Beispiel
file | file:///C:/path/file.xml
http | http://localhost/path/file.xml
https | https://localhost/path/file.xml
ftp | ftp://localhost:21
tcp | tcp://localhost:52410

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Base\Uri.is

Dokumentation der Funktionen

objectbound Isom.Base.Uri Isom.Base.Uri.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Rückgabe:
Kopie dieses Objekts.
[Isom\Base\Uri.is: 240]
Isom.Base.Uri Isom.Base.Uri.DefineUri ( Isom.Base.String uri )

Erzeugt ein neues URI-Objekt.

 Uri uri = Uri.DefineUri( "https://localhost/pathA/pathB/file.xml" );
Rückgabe:
Neues URI-Objekt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Parameter uri nicht als URI interpretiert werden kann.
Es wird das Void-Objekt zurückgegeben, falls der Parameter uri nicht einem der Schematypen File/Http/Https/Ftp/Tcp entspricht.
[Isom\Base\Uri.is: 100]
objectbound Isom.Base.String Isom.Base.Uri.GetChecksum ( )

Liefert die Prüfsumme des Inhalts einer an dem URI vorliegenden Datei.

 Uri uri = Uri.DefineUri( "https://user:password@localhost/pathA/pathB/file.cgi?a=1&b=2#frag" );
 System.Stdout( uri.GetChecksum() ); // liefert die Prüfsumme des Dateiinhalts
Rückgabe:
Prüfsumme, der an dem URI vorliegenden Datei.
[Isom\Base\Uri.is: 210]
objectbound Isom.Base.String Isom.Base.Uri.GetFragment ( )

Liefert den Dokumentfragment-Anteil des URI (oder leer).

 Uri uri = Uri.DefineUri( "https://user:password@localhost/pathA/pathB/file.cgi?a=1&b=2#frag" );
 System.Stdout( uri.GetFragment() ); // liefert "#frag"
Rückgabe:
Dokumentfragment-Anteil des URI.
[Isom\Base\Uri.is: 197]
objectbound Isom.Base.String Isom.Base.Uri.GetHost ( )

Liefert den Host-Anteil des URI (oder leer).

 Uri uri = Uri.DefineUri( "https://user:password@localhost/pathA/pathB/file.cgi?a=1&b=2#frag" );
 System.Stdout( uri.GetHost() );     // liefert "localhost"
Rückgabe:
Host-Anteil des URI.
[Isom\Base\Uri.is: 128]
objectbound Isom.Base.String Isom.Base.Uri.GetPath ( )

Liefert den Pfad-Anteil des URI (oder leer).

 Uri uri = Uri.DefineUri( "https://user:password@localhost/pathA/pathB/file.cgi?a=1&b=2#frag" );
 System.Stdout( uri.GetPath() );     // liefert "/pathA/pathB/file.cgi"
Rückgabe:
Pfad-Anteil des URI.
[Isom\Base\Uri.is: 171]
objectbound Isom.Base.String Isom.Base.Uri.GetPort ( )

Liefert die Anschlussnummer des URI (oder leer).

 Uri uri = Uri.DefineUri( "tcp://localhost:52410" );
 System.Stdout( uri.GetPort() );     // liefert "52410"
Rückgabe:
Anschlussnummer des URI.
Wenn kein Netzwerkanschluss als Teil des URI angegeben wurde, wird der Standardwert für das Protokoll zurückgeliefert (z.B. '80' für Http).
Wenn kein Standardnetzwerkanschluss vorhanden ist, wird eine leere Zeichenkette zurückgeliefert.
[Isom\Base\Uri.is: 145]
objectbound Isom.Base.String Isom.Base.Uri.GetQuery ( )

Liefert den CGI-Query-Anteil des URI (oder leer).

 Uri uri = Uri.DefineUri( "https://user:password@localhost/pathA/pathB/file.cgi?a=1&b=2#frag" );
 System.Stdout( uri.GetQuery() );    // liefert "?a=1&b=2"
Rückgabe:
CGI-Query-Anteil des URI.
[Isom\Base\Uri.is: 184]
objectbound Isom.Base.String Isom.Base.Uri.GetScheme ( )

Liefert den Schema-Anteil des URI.

 Uri uri = Uri.DefineUri( "https://user:password@localhost/pathA/pathB/file.cgi?a=1&b=2#frag" );
 System.Stdout( uri.GetScheme() );   // liefert "https"
Rückgabe:
Schema-Anteil des URI
[Isom\Base\Uri.is: 115]
objectbound Isom.Base.String Isom.Base.Uri.GetUserInfo ( )

Liefert den Basis-Authentifizierungs-Anteil des URI (oder leer).

 Uri uri = Uri.DefineUri( "https://user:password@localhost/pathA/pathB/file.cgi?a=1&b=2#frag" );
 System.Stdout( uri.GetUserInfo() ); // liefert "user:password"
Rückgabe:
Basis-Authentifizierungs-Anteil des URI.
[Isom\Base\Uri.is: 158]
objectbound Isom.Base.Boolean Isom.Base.Uri.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Base\Uri.is: 230]
Isom.Base.Uri Isom.Base.Uri.Void ( )

Erzeugt ein Void-Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

Rückgabe:
Void-Objekt
[Isom\Base\Uri.is: 252]


für Serviceautoren

Isom.Base.UriDictionary

Namensraum Isom.Base.UriDictionary

Wörterbücher mit URI-Einträgen vom Typ Isom.Base.Uri Mehr...

Funktionen
Isom.Base.UriDictionary | CreateUriDictionary()

Erzeugt ein neues, leeres Wörterbuch für URIs.

Wörterbuchfunktionen

Isom.Base.Boolean | Add(Isom.Base.String key, Isom.Base.Uri value)

Setzt einen Eintrag im Wörterbuch.

Isom.Base.Number | Count()

Ermittelt die Anzahl der gesetzten Einträge (Schlüssel).

Isom.Base.Uri | Get(Isom.Base.String key)

Sucht einen Eintrag für einen vorgegebenen Schlüssel.

Isom.Base.StringList | GetKeys()

Ermittelt die Liste aller gesetzten Schlüssel.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.UriDictionary | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Base.UriDictionary | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Isom.Base.UriDictionary repräsentiert Wörterbücher mit URI-Einträgen (Isom.Base.Uri).

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Base\UriDictionary.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Base.UriDictionary.Add | ( | Isom.Base.String | key,
 |  | Isom.Base.Uri | value
 | ) |  |

Setzt einen Eintrag im Wörterbuch.

Ein vorher mit dem Schlüssel geschriebener Eintrag wird dabei überschrieben.

 UriDictionary dict = UriDictionary.CreateUriDictionary();
 Uri uri = Uri.DefineUri( "https://user:password@localhost/pathA/pathB/file.cgi?a=1&b=2#frag" );
 dict.Add("A", uri);
Parameter:
key | Schlüssel des Eintrags
value | Wert des Eintrags
Rückgabe:
true
[Isom\Base\UriDictionary.is: 137]
objectbound Isom.Base.UriDictionary Isom.Base.UriDictionary.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Dabei werden für alle eingetragenen Werte Kopien erzeugt.

Rückgabe:
Kopie dieses Objekts.
[Isom\Base\UriDictionary.is: 189]
objectbound Isom.Base.Number Isom.Base.UriDictionary.Count ( )

Ermittelt die Anzahl der gesetzten Einträge (Schlüssel).

 UriDictionary dict = UriDictionary.CreateUriDictionary();
 Number n = dict.Count();   //n ist 0
Rückgabe:
Größe des Wörterbuchs.
[Isom\Base\UriDictionary.is: 99]
Isom.Base.UriDictionary Isom.Base.UriDictionary.CreateUriDictionary ( )

Erzeugt ein neues, leeres Wörterbuch für URIs.

 UriDictionary dict = UriDictionary.CreateUriDictionary();
Rückgabe:
Leeres Wörterbuch für URIs
[Isom\Base\UriDictionary.is: 81]
objectbound Isom.Base.Uri Isom.Base.UriDictionary.Get ( Isom.Base.String key )

Sucht einen Eintrag für einen vorgegebenen Schlüssel.

 UriDictionary dict = UriDictionary.CreateUriDictionary();
 Uri uri = Uri.DefineUri( "https://user:password@localhost/pathA/pathB/file.cgi?a=1&b=2#frag" );
 dict.Add("A", uri);
 Uri s = dict.Get("A");   //s ist die eingetragene URI
 Uri t = dict.Get("B");   //t ist das Void-Objekt
Parameter:
key Schlüssel des gesuchten Eintrags
Rückgabe:
Wert des Eintrags zum vorgegebenen Schlüssel.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls für den Schlüssel kein Wert gesetzt ist.
[Isom\Base\UriDictionary.is: 119]
objectbound Isom.Base.StringList Isom.Base.UriDictionary.GetKeys ( )

Ermittelt die Liste aller gesetzten Schlüssel.

Durch Durchlaufen der Liste lassen sich alle Einträge des Wörterbücher abrufen.

 UriDictionary dict = ...
 StringList keys = dict.GetKeys();
 while( keys.HasNext() )
 {
    String key = list.Next();
    Uri value = dict.Get(key);
    ...
 }
Rückgabe:
Liste aller im Wörterbuch enthaltenen Schlüssel
[Isom\Base\UriDictionary.is: 158]
objectbound Isom.Base.Boolean Isom.Base.UriDictionary.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Base\UriDictionary.is: 179]
Isom.Base.UriDictionary Isom.Base.UriDictionary.Void ( )

Erzeugt ein Void-Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

Rückgabe:
Void-Objekt
[Isom\Base\UriDictionary.is: 200]


für Serviceautoren

Isom.Base.Version

Namensraum Isom.Base.Version

Repräsentiert einer Versionsnummer Mehr...

Funktionen
Isom.Base.Version | CreateNew()

Erzeugt eine Instanz von Version, deren Bestandteile alle auf 0 gesetzt sind.

Isom.Base.Version | Parse(Isom.Base.String version, Isom.Base.String separator)

Wertet eine Zeichenkette aus, die eine Versionsnummer enthält, und erzeugt daraus eine Instanz von Version

Elementoperationen der Versionskomponenten

Funktionen, mit denen man die Versionskomponenten setzen und lesen kann.

Isom.Base.Number | GetBuild()

Ruft die dritte Komponente der Versionsnummer ab

Isom.Base.Number | GetMajor()

Ruft die erste Komponente der Versionsnummer ab

Isom.Base.Number | GetMinor()

Ruft die zweite Komponente der Versionsnummer ab

Isom.Base.Number | GetRevision()

Ruft die vierte Komponente der Versionsnummer ab

Isom.Base.Boolean | SetBuild(Isom.Base.Number buildVersion)

Legt die dritte Komponente der Versionsnummer fest

Isom.Base.Boolean | SetMajor(Isom.Base.Number majorVersion)

Legt die erste Komponente der Versionsnummer fest

Isom.Base.Boolean | SetMinor(Isom.Base.Number minorVersion)

Legt die zweite Komponente der Versionsnummer fest

Isom.Base.Boolean | SetRevision(Isom.Base.Number revisionVersion)

Legt die vierte Komponente der Versionsnummer fest

Vergleichsoperationen

Funktionen um zwei Versionsnummern zu vergleichen.

Isom.Base.Boolean | Eq(Isom.Base.Version other)

Prüft diese und die übergebene Version auf Gleichheit.

Isom.Base.Boolean | Gt(Isom.Base.Version other)

Es wird geprüft, ob diese Version größer als eine andere.

Isom.Base.Boolean | Lt(Isom.Base.Version other)

Es wird geprüft, ob diese Version kleiner als eine übergebene Version ist.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Version | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Base.Version | Void()

Liefert das ungültige Objekt des Namensraums Isom.Base.Version

Ausführliche Beschreibung

Die Fachklasse Isom.Base.Version beschreibt eine Versionsnummer, die 4 Bestandteile enthält. Für jeden Bestandteil wird als Wertebereich der Wertebereich von Isom.Base.Number zugelassen, wobei nur natürliche Zahlen einschließlich der Null verwendet werden dürfen. Die einzelnen Bestandteile werden bezeichnet als Major, Minor, Build und Revision.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Base\Version.is

Dokumentation der Funktionen

objectbound Isom.Base.Version Isom.Base.Version.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Rückgabe:
Kopie dieses Objekts.
[Isom\Base\Version.is: 357]
Isom.Base.Version Isom.Base.Version.CreateNew ( )

Erzeugt eine Instanz von Version, deren Bestandteile alle auf 0 gesetzt sind.

 Version version = Version.CreateNew();
Rückgabe:
Leere Versionsangabe
Ausnahmebehandlung:
Es wird ein Void-Objekt geliefert, wenn die Zeichenkette nicht ausgewertet werden konnte
[Isom\Base\Version.is: 117]
objectbound Isom.Base.Boolean Isom.Base.Version.Eq ( Isom.Base.Version other )

Prüft diese und die übergebene Version auf Gleichheit.

 Version ver1 = Version.Parse("1.19.1.0", ".");
 Version ver2 = Version.Parse("1.19.0.0", ".");
 Version ver3 = Version.Parse("1.19.1.0", ".");
 Boolean b = ver1.Eq(ver2);               // b ist false
 Boolean c = ver1.Eq(ver3);               // c ist true
Parameter:
other Instanz von Isom.Base.Version, mit der die aufgerufene Instanz verglichen wird.
Rückgabe:
'true', wenn die aufgerufene Instanz gleich other ist
[Isom\Base\Version.is: 289]
objectbound Isom.Base.Number Isom.Base.Version.GetBuild ( )

Ruft die dritte Komponente der Versionsnummer ab

 Version version = Version.Parse("5.4.2.3", ".");
 Number build = version.GetBuild();    // 3. Komponente der Versionsnummer ist "2"
Rückgabe:
Die dritte Komponente der Versionsnummer
[Isom\Base\Version.is: 170]
objectbound Isom.Base.Number Isom.Base.Version.GetMajor ( )

Ruft die erste Komponente der Versionsnummer ab

 Version version = Version.Parse("5.4.2.3", ".");
 Number maj = version.GetMajor();    // 1. Komponente der Versionsnummer ist "5"
Rückgabe:
Die erste Komponente der Versionsnummer
[Isom\Base\Version.is: 140]
objectbound Isom.Base.Number Isom.Base.Version.GetMinor ( )

Ruft die zweite Komponente der Versionsnummer ab

 Version version = Version.Parse("5.4.2.3", ".");
 Number min = version.GetMinor();    // 2. Komponente der Versionsnummer ist "4"
Rückgabe:
Die 2. Komponente der Versionsnummer
[Isom\Base\Version.is: 155]
objectbound Isom.Base.Number Isom.Base.Version.GetRevision ( )

Ruft die vierte Komponente der Versionsnummer ab

 Version version = Version.Parse("5.4.2.3", ".");
 Number rev = version.GetRevision();    // 4. Komponente der Versionsnummer ist "3"
Rückgabe:
Die vierte Komponente der Versionsnummer
[Isom\Base\Version.is: 185]
objectbound Isom.Base.Boolean Isom.Base.Version.Gt ( Isom.Base.Version other )

Es wird geprüft, ob diese Version größer als eine andere.

 Version ver1 = Version.Parse("1.19.1.0", ".");
 Version ver2 = Version.Parse("1.19.0.0", ".");
 Version ver3 = Version.Parse("1.19.2.0", ".");
 Boolean a = ver1.Gt(ver2);               // a ist true
 Boolean b = ver1.Gt(ver3);               // b ist false
 Boolean c = ver3.Gt(ver1);               // c ist true
Parameter:
other Instanz von Isom.Base.Version, mit der die aufgerufene Instanz verglichen wird
Rückgabe:
'true', wenn die aufgerufene Instanz größer ist als other
[Isom\Base\Version.is: 329]
objectbound Isom.Base.Boolean Isom.Base.Version.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', wenn die aktuelle Instanz das ungültige Objekt ist
[Isom\Base\Version.is: 348]
objectbound Isom.Base.Boolean Isom.Base.Version.Lt ( Isom.Base.Version other )

Es wird geprüft, ob diese Version kleiner als eine übergebene Version ist.

 Version ver1 = Version.Parse("1.19.1.0", ".");
 Version ver2 = Version.Parse("1.19.0.0", ".");
 Version ver3 = Version.Parse("1.19.2.0", ".");
 Boolean a = ver1.Lt(ver2);               // a ist false
 Boolean b = ver1.Lt(ver3);               // b ist true
 Boolean c = ver2.Lt(ver1);               // c ist true
Parameter:
other Instanz von Isom.Base.Version, mit der die aufgerufene Instanz verglichen wird
Rückgabe:
'true', wenn die aufgerufene Instanz kleiner ist als other
[Isom\Base\Version.is: 309]
Isom.Base.Version Isom.Base.Version.Parse | ( | Isom.Base.String | version,
 |  | Isom.Base.String | separator
 | ) |  |

Wertet eine Zeichenkette aus, die eine Versionsnummer enthält, und erzeugt daraus eine Instanz von Version

 Version.Parse("19.0.0.1", ".");
Parameter:
version | Auszuwertende Zeichenkette
separator | Trennzeichenkette zwischen 2 Bestandteilen der Versionsnummer oder String.Void(), um den Vorgabewert zu verwenden.
Rückgabe:
Repräsentiert die interpretierte Versionsnummer
Ausnahmebehandlung:
Wird ein Void-Objekt geliefert, wenn die Zeichenkette nicht ausgewertet werden konnte, separator die leere Zeichenkette war
[Isom\Base\Version.is: 101]
objectbound Isom.Base.Boolean Isom.Base.Version.SetBuild ( Isom.Base.Number buildVersion )

Legt die dritte Komponente der Versionsnummer fest

 Version ver = Version.CreateNew();
 ver.SetBuild(3);
Parameter:
buildVersion dritte Komponente der Versionsnummer
Rückgabe:
immer 'true'
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, wenn buildVersion keine natürliche Zahl ist.
[Isom\Base\Version.is: 242]
objectbound Isom.Base.Boolean Isom.Base.Version.SetMajor ( Isom.Base.Number majorVersion )

Legt die erste Komponente der Versionsnummer fest

 Version ver = Version.CreateNew();
 ver.SetMajor(1);
Parameter:
majorVersion erste Komponente der Versionsnummer
Rückgabe:
immer 'true'
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, wenn minorVersion keine natürliche Zahl ist
[Isom\Base\Version.is: 204]
objectbound Isom.Base.Boolean Isom.Base.Version.SetMinor ( Isom.Base.Number minorVersion )

Legt die zweite Komponente der Versionsnummer fest

 Version ver = Version.CreateNew();
 ver.SetMinor(2);
Parameter:
minorVersion zweite Komponente der Versionsnummer
Rückgabe:
immer 'true'
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, wenn minorVersion keine natürliche Zahl ist
[Isom\Base\Version.is: 223]
objectbound Isom.Base.Boolean Isom.Base.Version.SetRevision ( Isom.Base.Number revisionVersion )

Legt die vierte Komponente der Versionsnummer fest

 Version ver = Version.CreateNew();
 ver.SetRevision(4);
Parameter:
revisionVersion vierte Komponente der Versionsnummer
Rückgabe:
immer 'true'
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, wenn revisionVersion keine natürliche Zahl ist.
[Isom\Base\Version.is: 261]
Isom.Base.Version Isom.Base.Version.Void ( )

Liefert das ungültige Objekt des Namensraums Isom.Base.Version

Ausnahmebehandlung:
Es wird immer das Void-Objekt geliefert
[Isom\Base\Version.is: 367]


für Serviceautoren

Isom.Checkpoint

Namensraum Isom.Checkpoint

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Checkpoint.CheckpointProcesses | Funktionen zum Erstellen und Wiederherstellen von Checkpoints
Isom.Checkpoint.VehicleCheckpoint | Erstellen eines Checkpoints
Isom.Checkpoint.VehicleRestore | Wiederherstellen eines Fahrzeugzustandes anhand eines Checkpoints


für Serviceautoren

Isom.Checkpoint.CheckpointProcesses

Namensraum Isom.Checkpoint.CheckpointProcesses

Funktionen zum Erstellen und Wiederherstellen von Checkpoints Mehr...

Funktionen
Hauptfunktionalität

Erzeugen und Wiederherstellen eines Checkpoints.

Isom.Base.Boolean | CreateCheckpoint()

Erzeugen eines Checkpoints.

Isom.Base.Boolean | RestoreCheckpoint()

Wiederherstellen eines Checkpoints

Hilfsfunktionen

Funktionen, die beim Erzeugen oder Wiederherstellen eines Checkpoints von nutzen sind.

Isom.Base.Boolean | CheckCheckpointCompatibilityToCurrentVehicle()

Überprüft, ob der angegebene Checkpoint für das tatsächlich ermittelte Fahrzeug gültig ist.

Isom.Base.Boolean | CheckFutureContext(Isom.Base.Boolean forceFutureContext)

Diese Funktion ermittelt die Soll-Konfiguration und stellt fest, ob zunächst Aktionen durchgeführt werden müssen, um das Fahrzeug in diese Soll-Konfiguration zu überführen.

Isom.Base.Boolean | IsTherapyPlanEmpty(Isom.Plan.TherapyPlan tp)

Prüft, ob der Therapieplan logisch leer ist, d.h.

Isom.Base.Boolean | PrintRet(Isom.Base.String text, Isom.Base.Boolean ret)

Hilfsfunktion, die ausgibt, ob eine Funktion erfolgreich war.

Ausführliche Beschreibung

Zu beachten:
  • Technische Konstante für Globalschlüssel FLASHMODE.
 INTERNAL GLOBALKEY_FLASHMODE         "GLOBALKEY_FLASHMODE"
  • Technische Konstante für Globalschlüssel FLASHMODE_COMFORT.
 INTERNAL GLOBALVAL_FLASHMODE_COMFORT "GLOBALVAL_FLASHMODE_COMFORT"
  • Technische Konstante für Globalschlüssel FLASHMODE_EXPERT.
 INTERNAL GLOBALVAL_FLASHMODE_EXPERT  "GLOBALVAL_FLASHMODE_EXPERT"
Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Checkpoint\CheckpointProcesses.is

Dokumentation der Funktionen

Isom.Base.Boolean Isom.Checkpoint.CheckpointProcesses.CheckCheckpointCompatibilityToCurrentVehicle ( )

Überprüft, ob der angegebene Checkpoint für das tatsächlich ermittelte Fahrzeug gültig ist.

Dafür müssen folgende Bedingungen gelten:

  • Fahrgestellnummern müssen identisch sein
  • Fahrzeugaufträge müssen übereinstimmen
  • Es müssen die gleichen Steuergeräte verbaut sein

[Isom\Checkpoint\CheckpointProcesses.is: 635 - 734]
Isom.Base.Boolean Isom.Checkpoint.CheckpointProcesses.CheckFutureContext ( Isom.Base.Boolean forceFutureContext )

Diese Funktion ermittelt die Soll-Konfiguration und stellt fest, ob zunächst Aktionen durchgeführt werden müssen, um das Fahrzeug in diese Soll-Konfiguration zu überführen.

Dem Benutzer wird angeboten diese Aktionen durchzuführen oder abzubrechen.

Parameter:
forceFutureContext Gibt an, ob die Soll-Konfiguration erzeugt werden muss. Dies ist beim Abspeichern der Fall. Beim Wiederherstellen wird zwar auch dazu geraten, dass sich das Fahrzeug in einer gültigen Soll-Konfiguration befindet, jedoch ist es dort nicht zwingend notwendig.
[Isom\Checkpoint\CheckpointProcesses.is: 475 - 619]
Isom.Base.Boolean Isom.Checkpoint.CheckpointProcesses.CreateCheckpoint ( )

Erzeugen eines Checkpoints.

Die Funktion überprüft zunächst, ob sich das Fahrzeug in einer gültigen Soll-Konfiguration befindet. Sollte das nicht der Fall sein, so wird dem Benutzer die Möglichkeit angeboten, einen Therapieplan durchzuführen, der das Fahrzeug in eine gültige Soll- Konfiguration überführt. Der Benutzer kann dies auch ablehnen, jedoch kann dann kein Checkpoint erstellt werden und das Skript wird beendet. Nachdem das Fahrzeug in eine gültige Soll-Konfiguration gebracht wurde, wird der Checkpoint erzeugt. (Individualdaten und Individualisierungseinstellungen werden aktuell noch nicht behandelt!)

   using Isom.Base.*;
   ...
   if (selectedKey.Equals ("1"))
      {
          if (ret)
          ret = PrintRet ("CreateCheckpoint",
                          CheckpointProcesses.CreateCheckpoint ());
          return ret;
      }
[Isom\Checkpoint\CheckpointProcesses.is: 145 - 190]
Isom.Base.Boolean Isom.Checkpoint.CheckpointProcesses.IsTherapyPlanEmpty ( Isom.Plan.TherapyPlan tp )

Prüft, ob der Therapieplan logisch leer ist, d.h.

keine konkreten Aktionen enthält.

Rückgabe:
'true' wenn TP leer, 'false' wenn TP nicht leer oder im Fehlerfall.
[Isom\Checkpoint\CheckpointProcesses.is: 747 - 772]
Isom.Base.Boolean Isom.Checkpoint.CheckpointProcesses.PrintRet | ( | Isom.Base.String | text,
 |  | Isom.Base.Boolean | ret
 | ) |  |

Hilfsfunktion, die ausgibt, ob eine Funktion erfolgreich war.

Rückgabe:
'true' wenn die Funktion erfolgreich war, 'false' sonst
[Isom\Checkpoint\CheckpointProcesses.is: 784 - 796]
Isom.Base.Boolean Isom.Checkpoint.CheckpointProcesses.RestoreCheckpoint ( )

Wiederherstellen eines Checkpoints

Zunächst wird überprüft, ob der angegebene Checkpoint korrekt ist und für das tatsächlich angeschlossene Fahrzeug gültig ist. Anschließend wird versucht, das Fahrzeug auf eine gültige Soll- Konfiguration zu bringen, außer der Benutzer wünscht dies ausdrücklich nicht. Danach werden die Werte des CurrentContext auf die Werte des Checkpoints gesetzt. Anschließend wird der Aktionsplan berechnet und umgekehrt. Es folgt die Ausführung des Aktionsplanes und die Wiederherstellung von Individualdaten und Individualisierungseinstellungen. (Individualdaten und Individualisierungseinstellungen werden aktuell noch nicht behandelt!)

   using Isom.Base.*;
   ...
   if (selectedKey.Equals ("2"))
      {
          if (ret)
          ret = PrintRet ("RestoreCheckpoint",
                          CheckpointProcesses.RestoreCheckpoint ());
          return ret;
      }
[Isom\Checkpoint\CheckpointProcesses.is: 224 - 442]


für Serviceautoren

Isom.Checkpoint.VehicleCheckpoint

Namensraum Isom.Checkpoint.VehicleCheckpoint

Erstellen eines Checkpoints Mehr...

Funktionen
Isom.Checkpoint.VehicleCheckpoint | GetInstance()

Ermittelt die für diese ISOM-Sitzung einmalige Checkpoint-Instanz zum Erstellen eines Checkpoints.

Speichern von Fahrzeuginformationen

Isom.Base.Boolean | ExportTherapyData()

Die Funktion exportiert Daten, die für die Wiederherstellung von Softwareständen benötigt werden.

Isom.Base.Boolean | SaveIndividualData()

Diese Funktion speichert die Individualdaten in das Verzeichnis des Checkpoints.

Isom.Base.Boolean | SaveVehicleInformation()

Diese Funktion speichert Informationen über das Fahrzeug ab.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Checkpoint.VehicleCheckpoint | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Checkpoint.VehicleCheckpoint | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Er stellt Funktionen zur Verfügung, um einen Checkpoint zu erstellen. Dabei ist es möglich, die Informationen über den Zustand des Fahrzeuges abzuspeichern. Des Weiteren können auch die zur Wiederherstellung notwendigen Daten des Programmierdatenpaketes in den Checkpoint hinzugefügt werden. Mit Hilfe des Checkpoints ist es möglich, den aktuellen Zustand des Fahrzeuges abzuspeichern, um diesen zu einem späteren Zeitpunkt wiederherstellen zu können.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Checkpoint\VehicleCheckpoint.is

Dokumentation der Funktionen

objectbound Isom.Checkpoint.VehicleCheckpoint Isom.Checkpoint.VehicleCheckpoint.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Checkpoint\VehicleCheckpoint.is: 168]
objectbound Isom.Base.Boolean Isom.Checkpoint.VehicleCheckpoint.ExportTherapyData ( )

Die Funktion exportiert Daten, die für die Wiederherstellung von Softwareständen benötigt werden.

Die relevanten Verzeichnisse und Dateien aus dem zur Baureihe passenden Programmierdatenpaket werden in ein Unterverzeichnis "SP" des Checkpoints kopiert.

Rückgabe:
'true' falls erfolgreich, 'false' sonst.
[Isom\Checkpoint\VehicleCheckpoint.is: 136]
Isom.Checkpoint.VehicleCheckpoint Isom.Checkpoint.VehicleCheckpoint.GetInstance ( )

Ermittelt die für diese ISOM-Sitzung einmalige Checkpoint-Instanz zum Erstellen eines Checkpoints.

Rückgabe:
Die für diese ISOM-Sitzung singuläre VehicleCheckpoint-Instanz.
[Isom\Checkpoint\VehicleCheckpoint.is: 83]
objectbound Isom.Base.Boolean Isom.Checkpoint.VehicleCheckpoint.SaveIndividualData ( )

Diese Funktion speichert die Individualdaten in das Verzeichnis des Checkpoints.

Rückgabe:
'true' falls erfolgreich, 'false' sonst.
[Isom\Checkpoint\VehicleCheckpoint.is: 123]
objectbound Isom.Base.Boolean Isom.Checkpoint.VehicleCheckpoint.SaveVehicleInformation ( )

Diese Funktion speichert Informationen über das Fahrzeug ab.

Die Funktion speichert folgende Informationen ab:

  • Fahrzeugauftrag
  • Fahrgestellnummer
  • Integrationsstufe
  • Liste der Steuergeräte
  • Individualisierungseinstellungen

Diese Informationen werden in der XML-Datei "vehicleInformation.xml" in dem Verzeichnis des Checkpoints gespeichert. Die Informationen müssen vor dem Abspeichern ermittelt werden, was nicht automatisch passiert.

Rückgabe:
'true' falls erfolgreich, 'false' sonst.
[Isom\Checkpoint\VehicleCheckpoint.is: 112]
Isom.Checkpoint.VehicleCheckpoint Isom.Checkpoint.VehicleCheckpoint.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Checkpoint\VehicleCheckpoint.is: 180]


für Serviceautoren

Isom.Checkpoint.VehicleRestore

Namensraum Isom.Checkpoint.VehicleRestore

Wiederherstellen eines Fahrzeugzustandes anhand eines Checkpoints Mehr...

Funktionen
Isom.Checkpoint.VehicleRestore | GetInstance()

Ermittelt die für diese ISOM-Sitzung einmalige Checkpoint-Instanz zum Wiederherstellen eines Checkpoints.

Checkpoint laden

Funktion zum Laden eines Checkpoints.

Isom.Base.Boolean | LoadCheckpoint()

Listet dem Benutzer alle für das aktuelle Fahrzeug gültigen Checkpoints auf.

Checkpoint Überprüfung

Funktionen zur Überprüfung von Checkpoints.

Isom.Base.Boolean | CompareCheckpointEcusToCurrentContextEcus()

Vergleicht die Liste der Steuergeräte, die im Checkpoint abgespeichert wurden, mit der Liste der Steuergeräten, die für den CurrentContext ermittelt wurden.

Isom.Base.String | GetVehicleIdentificationNumber()

Liefert die Fahrgestellnummer aus dem abgespeicherten Checkpoint.

Isom.Context.VehicleOrder | GetVehicleOrder()

Liefert den Fahrzeugauftrag aus dem abgespeicherten Checkpoint.

Therapieplan Manipulation

Funktionen zur Manipulation von Therapieplänen.

Isom.Base.Boolean | CalculateReversedActionPlan()

Diese Funktion dreht die Reihenfolge der Flash- und Codieraktionen im Aktionsplan um.

Isom.Base.Boolean | ChangeTherapyDataPath()

Ändert den Pfad zu den Therapiedaten für Fachdienste zur Fahrzeugkommunikation.

Isom.Base.Boolean | ChangeTherapyPlanTargets()

Diese Funktion ändert die Teilenummern der Steuergeräte im Therapieplan.

Isom.Base.Boolean | SetCurrentContextToSavedContext()

Setzt den ermittelten Fahrzeugkontext auf die Werte des abgespeicherten Kontextes.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Checkpoint.VehicleRestore | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Checkpoint.VehicleRestore | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Er stellt Funktionen bereit, die es ermöglichen den Fahrzeugzustand aus einem Checkpoint wiederherzustellen.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Checkpoint\VehicleRestore.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Checkpoint.VehicleRestore.CalculateReversedActionPlan ( )

Diese Funktion dreht die Reihenfolge der Flash- und Codieraktionen im Aktionsplan um.

Dazu werden die Sortierkriterien für die Flashphasen und für die Flashsequenz negiert. Ebenso werden die Sortierkriterien für die Codiersequenz negiert. Dadurch wird die Reihenfolge der einzelnen Flashphasen und die Reihenfolge der einzelnen Codierphasen zeitlich umgedreht. Die Flashphasen sind jedoch noch vor den Codierphasen. Innerhalb der Phasen wird die Reihenfolge der Aktionen ebenfalls umgedreht.

   using Isom.Base.*
   using Isom.Checkpoint.*;
   ...
      VehicleRestore restoreCP = VehicleRestore.GetInstance();
      if( restoreCP.CalculateReversedActionPlan() )
      { ... }
Rückgabe:
'true' falls erfolgreich, 'false' sonst.
[Isom\Checkpoint\VehicleRestore.is: 272]
objectbound Isom.Base.Boolean Isom.Checkpoint.VehicleRestore.ChangeTherapyDataPath ( )

Ändert den Pfad zu den Therapiedaten für Fachdienste zur Fahrzeugkommunikation.

Der Pfad wird auf den Wert gesetzt, den der ausgewählte Checkpoint hat. Ist dieser nicht gesetzt, so wird der Pfad nicht verändert und die Funktion liefert 'false' zurück. Der neue Pfad wird auch für zukünftig erzeugte Fachdienste für die Fahrzeugkommunikation geändert.

   using Isom.Base.*
   using Isom.Checkpoint.*;
   ...
      VehicleRestore restoreCP = VehicleRestore.GetInstance();
      if( restoreCP.ChangeTherapyDataPath() )
      { ... }
Rückgabe:
'true' falls erfolgreich, 'false' sonst.
[Isom\Checkpoint\VehicleRestore.is: 294]
objectbound Isom.Base.Boolean Isom.Checkpoint.VehicleRestore.ChangeTherapyPlanTargets ( )

Diese Funktion ändert die Teilenummern der Steuergeräte im Therapieplan.

Im Normalfall stehen dort die neueren Teilenummern, auf die die Steuergeräte geflashed werden sollen. Diese werden daher auf die alten, im Checkpoint abgespeicherten Werte gesetzt, damit die Steuergeräte auf die alten Teilenummern geflashed werden. Auch die Integrationsstufe wird auf den alten Wert aus dem Checkpoint gesetzt.

   using Isom.Base.*
   using Isom.Checkpoint.*;
   ...
      VehicleRestore restoreCP = VehicleRestore.GetInstance();
      if( restoreCP.ChangeTherapyPlanTargets() )
      { ... }
Rückgabe:
'true' falls erfolgreich 'false' sonst.
[Isom\Checkpoint\VehicleRestore.is: 247]
objectbound Isom.Checkpoint.VehicleRestore Isom.Checkpoint.VehicleRestore.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Checkpoint\VehicleRestore.is: 322]
objectbound Isom.Base.Boolean Isom.Checkpoint.VehicleRestore.CompareCheckpointEcusToCurrentContextEcus ( )

Vergleicht die Liste der Steuergeräte, die im Checkpoint abgespeichert wurden, mit der Liste der Steuergeräten, die für den CurrentContext ermittelt wurden.

Die Steuergeräte werden anhand der Diagnoseadresse verglichen.

   using Isom.Base.*
   using Isom.Checkpoint.*;
   ...
      VehicleRestore restoreCP = VehicleRestore.GetInstance();
      if( restoreCP.CompareCheckpointEcusToCurrentContextEcus() )
      { ... }
Rückgabe:
'true' wenn die beiden Listen gleich sind, 'false' sonst.
[Isom\Checkpoint\VehicleRestore.is: 194]
Isom.Checkpoint.VehicleRestore Isom.Checkpoint.VehicleRestore.GetInstance ( )

Ermittelt die für diese ISOM-Sitzung einmalige Checkpoint-Instanz zum Wiederherstellen eines Checkpoints.

   using Isom.Base.*
   using Isom.Checkpoint.*;
   ...
      VehicleRestore restoreCP = VehicleRestore.GetInstance();
Rückgabe:
Die für diese ISOM-Sitzung singuläre VehicleRestore-Instanz.
[Isom\Checkpoint\VehicleRestore.is: 92]
objectbound Isom.Base.String Isom.Checkpoint.VehicleRestore.GetVehicleIdentificationNumber ( )

Liefert die Fahrgestellnummer aus dem abgespeicherten Checkpoint.

Mit deren Hilfe kann man überprüfen, ob der abgespeicherte Checkpoint zum tatsächlich angeschlossenen Fahrzeug gehört.

   using Isom.Base.*
   using Isom.Checkpoint.*;
   ...
      VehicleRestore restoreCP = VehicleRestore.GetInstance();
      String savedVin = restoreCP.GetVehicleIdentificationNumber();
Rückgabe:
Fahrgestellnummer als String, sofern der Checkpoint geladen und erfolgreich deserialisiert wurde.
[Isom\Checkpoint\VehicleRestore.is: 155]
objectbound Isom.Context.VehicleOrder Isom.Checkpoint.VehicleRestore.GetVehicleOrder ( )

Liefert den Fahrzeugauftrag aus dem abgespeicherten Checkpoint.

   using Isom.Base.*
   using Isom.Checkpoint.*;
   ...
      VehicleRestore restoreCP = VehicleRestore.GetInstance();
      VehicleOrder savedVO = restoreCP.GetVehicleOrder();
Rückgabe:
Fahrzeugauftrag, sofern der Checkpoint geladen und erfolgreich deserialisiert wurde.
[Isom\Checkpoint\VehicleRestore.is: 173]
objectbound Isom.Base.Boolean Isom.Checkpoint.VehicleRestore.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Checkpoint\VehicleRestore.is: 313]
objectbound Isom.Base.Boolean Isom.Checkpoint.VehicleRestore.LoadCheckpoint ( )

Listet dem Benutzer alle für das aktuelle Fahrzeug gültigen Checkpoints auf.

Diese müssen sich in einem festgelegten Verzeichnis befinden. Dieses wird über die Anwendungseinstellung "DataExchangePath" festgelegt. Unterhalb von diesem Verzeichnis wird in dem Verzeichnis mit der passenden Vin7 gesucht und im dortigen Unterverzeichnis "Checkpoints" alle Verzeichnisse aufgelistet. Der Benutzer bekommt dann automatisch eine Benutzeranfrage mit allen möglichen Checkpoints, von denen einer ausgewählt werden muss.

   using Isom.Base.*
   using Isom.Checkpoint.*;
   ...
      VehicleRestore restoreCP = VehicleRestore.GetInstance();
      String myPath = "C:\.";
      restoreCP.LoadCheckpointFile( myPath );
Rückgabe:
'true' falls erfolgreich 'false' sonst.
[Isom\Checkpoint\VehicleRestore.is: 126]
objectbound Isom.Base.Boolean Isom.Checkpoint.VehicleRestore.SetCurrentContextToSavedContext ( )

Setzt den ermittelten Fahrzeugkontext auf die Werte des abgespeicherten Kontextes.

Dabei werden die Integrationsstufe, die Teilenummern und Steuergeräte-Identifikatoren der verbauten Steuergeräte auf die Werte gesetzt, die im Checkpoint abgespeichert wurden.

   using Isom.Base.*
   using Isom.Checkpoint.*;
   ...
      VehicleRestore restoreCP = VehicleRestore.GetInstance();
      if( restoreCP.SetCurrentContextToSavedContext() )
      { ... }
Rückgabe:
'true' falls erfolgreich, 'false' sonst.
[Isom\Checkpoint\VehicleRestore.is: 224]
Isom.Checkpoint.VehicleRestore Isom.Checkpoint.VehicleRestore.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Checkpoint\VehicleRestore.is: 334]


für Serviceautoren

Isom.Context

Namensraum Isom.Context

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Context.ContextConfiguration | Fachklasse für Grundmerkmale des Fahrzeugs
Isom.Context.CurrentVehicleContext | Fachklasse für den Istkontext
Isom.Context.Dtc | Fachobjekt für einen Fehlerspeichereintrag
Isom.Context.DtcList | Liste von Fehlerspeichereintragobjekten des Typs Isom.Context.Dtc.
Isom.Context.Ecu | Fachobjekt für ein Steuergerät
Isom.Context.EcuList | Listen von Steuergeräteobjekten des Typs Isom.Context.Ecu.
Isom.Context.Environment | Zugriff auf Kommunikation mit dem Fahrzeugzugang und für Spannungsprüfungen
Isom.Context.FutureVehicleContext | Fachobjekt für den Soll-Kontext
Isom.Context.LogicalUnit | Repräsentiert eine logische Einheit
Isom.Context.LogicalUnitList | Listen logischer Einheiten des Typs Isom.Context.LogicalUnit
Isom.Context.LogicalVehicle | Fachobjekt für ein logisches Fahrzeug
Isom.Context.LogicalVehicleList | Listen von Fachobjekten des Typs Isom.Context.LogicalVehicle.
Isom.Context.MockupFactory | Erzeugung von Fachobjektattrappen aus Beschreibungsdateien
Isom.Context.UserProfile | Fachobjekt für das Benutzerprofil
Isom.Context.UserProfileOption | Benutzerprofil-Optionen
Isom.Context.UserProfileOptionList | Listen von Benutzerprofil-Optionen des Typs Isom.Context.UserProfileOption
Isom.Context.UserProfileSetting | Benutzerprofil-Einstellungen
Isom.Context.UserProfileSettingList | Listen von Benutzerprofil-Einstellungen des Typs Isom.Context.UserProfileSetting
Isom.Context.VehicleOrder | Fachobjekt für einen Fahrzeugauftrag


für Serviceautoren

Isom.Context.ContextConfiguration

Namensraum Isom.Context.ContextConfiguration

Fachklasse für Grundmerkmale des Fahrzeugs Mehr...

Funktionen
Isom.Context.ContextConfiguration | GetInstance()

Liefert die Objektinstanz für den Zugriff auf die bereitgestellten Funktionen.

Eigenschaften zu Mandant und Baureihe

Isom.Base.String | GetModelSeries()

Fragt die eingestellte Baureihe ab.

Isom.Base.String | GetModelSeriesGroup()

Fragt den Namen der eingestellten Baureihengruppe ab.

Isom.Base.String | GetOem()

Fragt den Namen des eingestellten Mandanten ab.

Isom.Context.EcuList | GetSoftwareVersionEcus()

Liefert eine Liste der Steuergeräte, von denen der Softwarezustand des Fahrzeugs ermittelt werden kann.

Isom.Context.EcuList | GetVehicleConfigurationEcus()

Liefert eine Liste der Steuergeräte, von denen die Fahrzeugmerkmale ermittelt werden können.

Isom.Context.EcuList | GetVinEcus()

Liefert eine Liste der Steuergeräte, von denen die Fahrgestellnummer ermittelt werden kann.

Isom.Base.Boolean | SetModelSeries(Isom.Base.String modelSeries)

Setzt die vorgegebene Baureihe

Isom.Base.Boolean | SetModelSeriesGroup(Isom.Base.String modelSeriesGroup)

Setzt die vorgegebene Baureihengruppe

Isom.Base.Boolean | SetOem(Isom.Base.String oem)

Setzt den Namen des Mandanten.

Eigenschaften des Fahrzeugs

Isom.Base.String | GetDataIntegrationLevel()

Fragt den Identifikator des eingestellten Softwarestands ab.

Isom.Base.String | GetVin17()

Fragt die 17-stellige Fahrgestellnummer ab.

Isom.Base.Boolean | SetDataIntegrationLevel(Isom.Base.String newDataIntegrationLevel)

Setzt den Identifikator des eingestellten Softwarestands.

Isom.Base.Boolean | SetVin17(Isom.Base.String vin)

Setzt die 17-stellige Fahrgestellnummer.

Fachfunktionen zur automatischen Baureihenerkennung

Isom.Base.String | FindModelSeries()

Ermittelt die Baureihe anhand der eingestellten 17-stelligen Fahrgestellnummer.

Fachfunktionen zum Kanalmodell des Fahrzeugs

Isom.Base.StringList | GetDefaultLChannels()

Liefert die Liste der verfügbaren L-Kanäle

Isom.Base.StringList | GetPossibleInterfaces()

Liefert die Liste der möglichen Fahrzeugzugänge.

Isom.Base.StringList | GetPossibleNChannels()

Ermittelt die Liste der verfügbaren N-Kanäle des Fahrzeugs

Isom.Base.String | GetVehicleInterface()

Ermittelt den Namen des angeschlossenen Fahrzeugzugangs.

Isom.Base.Boolean | SetDefaultLChannels(Isom.Base.StringList newDefaultLChannels)

Setzt die Liste der verfügbaren L-Kanäle

Isom.Base.Boolean | SetNChannelEnforcedSequential(Isom.Base.String nchannelList)

Legt N-Kanäle fest, die in der Planausführung nicht parallel verwendet werden dürfen

Logische Fahrzeuge und Überarbeitungsstände

Informationen zu logischen Fahrzeugen als Teile des Fahrzeugkontexts, über die Teilbordnetze des Fahreugs separat angesprochen werden können sowie zu Überarbeitungsstände, die den Verbau des Fahrzeugs charakterisieren.
(Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).)

Isom.Context.LogicalVehicleList | GetLogicalVehicles()

Ermittelt die Liste verwendbarer logischer Fahrzeuge.

Isom.Base.String | GetModelSeriesRevision()

Fragt den Überarbeitungsstand des Fahrzeugs ab.

Isom.Base.Boolean | SetModelSeriesRevision(Isom.Base.String newModelSeriesRevision)

Setzt den Überarbeitungsstand des Fahrzeugs.

Fachfunktionen mit Sitzungsbezug

Isom.Base.Boolean | FinalizeSession()

Beendet die aktuelle Therapiesitzung.

Isom.Base.String | GetSessionName()

Fragt den Namen der aktuellen Sitzung ab.

Isom.Base.String | GetSessionRemark()

Fragt den Sitzungshinweis ab.

Sichtbarkeits- / Editierbarkeitssteuerung / Menüs

Isom.Base.Boolean | ComputeEcuActionVisibility()

Aktualisiert, welche Steuergeräteaktionen manuell angewiesen werden dürfen

Isom.Base.Boolean | ComputeMenuItemVisibility()

Wertet Menüstrukturen aus, die mit den Annotationen MenuItem und MenuText festgelegt wurden.

Isom.Base.Boolean | ComputeVehicleActionVisibility()

Aktualisiert, welche Fahrzeugaktionen manuell angewiesen werden dürfen

Eigenschaften

Typischerweise herstellerabhängige Datenwerte, die das Fahrzeug charakterisieren. Für baureihenspezifische Eigenschaftsnamen siehe herstellerspezifisches Begleitdokument.

Isom.Base.String | GetDisplayProp(Isom.Base.String propName)

Abfrage einer Anzeigeeigenschaft

Isom.Base.StringList | GetDisplayPropNames()

Liefert die Namen aller Anzeigeeigenschaften.

Isom.Base.String | GetProp(Isom.Base.String propName)

Abfrage einer technischen Eigenschaft

Isom.Base.StringList | GetPropNames()

Liefert die Namen aller technischen Eigenschaften für das Fahrzeug.

Isom.Base.Boolean | SetDisplayProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt eine Anzeigeeigenschaft

Isom.Base.Boolean | SetProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt eine technische Eigenschaft

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Context.ContextConfiguration | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Isom.Context.ContextConfiguration | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Diese Fachklasse erlaubt den Zugriff auf Merkmale des angeschlossenen Fahrzeugs, die extern konfiguriert werden (durch die ISOM-Konfigurationsdatei oder als Kommandozeilenparameter) und die ISOM vor Identifikation der Steuergeräte ermittelt.

Verwendungsbeispiel:
Der folgende Quelltext zeigt eine einfache Implementierung des Einsprungspunkts ContextIdent:
   Isom.Base.Boolean ContextIdent() // Einsprungspunkt zur Baureihenerkennung (Phase 1)
   {
      // Abfrage der Zugriffsinstanz
      Isom.Context.ContextConfiguration ccfg = Isom.Context.ContextConfiguration.GetInstance();

      // Abfrage der aktuell eingestellten Baureihengruppe
      Isom.Base.String modelSeriesGroup = ccfg.GetModelSeriesGroup();

      // Prüfung, ob die Baureihengruppe des Fahrzeugs bereits gesetzt wurde
      if (modelSeriesGroup.IsVoid())
      {
        // Baureihe setzen
        ccfg.SetModelSeries("DURANGO01");

        // ISOM ermittelt die Baureihengruppe beim Setzen der Baureihe auf Basis der
        // zugehörigen Fahrzeugbeschreibung automatisch, daher sollte die Baureihengruppe
        // bereits eingestellt sein
        if (ccfg.GetModelSeriesGroup().IsVoid())
        {
          // Fehlerbehandlung
          // ..
          return false;
        }
        return true;
      }
      else
      {
        //Baureihengruppe des Fahrzeugs wurde bereits gesetzt
        return false;
      }
   }

Quelldateien:

  • Isom\Context\ContextConfiguration.is

Dokumentation der Funktionen

objectbound Isom.Context.ContextConfiguration Isom.Context.ContextConfiguration.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Isom.Context.ContextConfiguration
Das geklonte Objekt.
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 1260]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.ComputeEcuActionVisibility ( )

Aktualisiert, welche Steuergeräteaktionen manuell angewiesen werden dürfen

ISOM führt diese Neubewertung der Sichtbarkeit in den meisten Fällen selbstständig durch. Details dazu befinden sich in der Dokumentation von ISOM. Diese Funktion erlaubt es zusätzlich, die Aktualisierung in ISOM/L auszulösen.

Zu beachten:
Isom.Context.ContextConfiguration.ComputeVehicleActionVisibility() führt die Ak'true'erung für Fahrzeugaktionen durch
Rückgabe:
Isom.Base.Boolean
Immer true.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Aktualisierung nicht durchgeführt werden konnte
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 1002]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.ComputeMenuItemVisibility ( )

Wertet Menüstrukturen aus, die mit den Annotationen MenuItem und MenuText festgelegt wurden.

Mit den Funktionsannotationen MenuItem und MenuText können auf der Serviceplattform Taurus® Funktionen festgelegt werden, die an der Bedienoberfläche in einer Menüstruktur angeboten werden. Diese Funktion veranlasst nach der Auswertung die Darstellung im Taurus® Client.

Rückgabe:
Isom.Base.Boolean
Immer true.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Auswertung nicht durchgeführt werden konnte
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 1026]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.ComputeVehicleActionVisibility ( )

Aktualisiert, welche Fahrzeugaktionen manuell angewiesen werden dürfen

ISOM führt diese Neubewertung der Sichtbarkeit in den meisten Fällen selbstständig durch. Details dazu befinden sich in der Dokumentation von ISOM. Diese Funktion erlaubt es zusätzlich, die Aktualisierung in ISOM/L auszulösen.

Zu beachten:
Isom.Context.ContextConfiguration.ComputeEcuActionVisibility() führt die Aktualisierung für Steuergeräteaktionen durch
Verwendungsbeispiel:
Der folgende Quelltext zeigt eine Implementierung des Einsprungspunkts OnRestartTherapySession, die eine Neubewertung der Sichtbarbarkeit der Aktionen erzwingt:
   Isom.Base.Boolean OnRestartTherapySession() // Einsprungspunkt bei Wiedereinstieg in eine Sitzung
   {
     // Abfrage der Zugriffsinstanz
     Isom.Context.ContextConfiguration ccfg = Isom.Context.ContextConfiguration.GetInstance();

     // Neubewertung der Steuergeräteaktionen
     ccfg.ComputeEcuActionVisibility();

     // Neubewertung der Fahrzeugaktionen
     ccfg.ComputeVehicleActionVisibility();

     // Weitere Behandlung des Wiedereinstiegs
     // ..
     'true'true;
   }
Rückgabe:
Isom.Base.Boolean
Immer true.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Aktualisierung nicht durchgeführt werden konnte
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 977]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.FinalizeSession ( )

Beendet die aktuelle Therapiesitzung.

Diese Funktion bewirkt, dass die aktuelle Therapiesitzung vorzeitig beendet wird. Nach Aufruf der Funktion geht ISOM in einen Zustand über, in dem sich die Sitzung nur noch beenden lässt. Der Aufruf kehrt daher nicht zurück.

Rückgabe:
Isom.Base.Boolean
Der Aufruf dieser Funktion kehrt nicht zurück.
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 924]
objectbound Isom.Base.String Isom.Context.ContextConfiguration.FindModelSeries ( )

Ermittelt die Baureihe anhand der eingestellten 17-stelligen Fahrgestellnummer.

Vorraussetzung für diese Art der Erkennung der Baureihe ist ein angebundener Fachdienst für Logistikinformationen, der der Fahrgestellnummer die Baureihe zuordnen kann.

Vorbedingung:
Die 17-stellige Fahrgestellnummer wurde bereits ermittelt.
Rückgabe:
Isom.Base.String
Ermittelte Baureihe.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Baureihe nicht ermittelt werden konnte.
Verwendungsbeispiel:
Der folgende Quelltext zeigt eine Implementierung des Einsprungspunkts ContextIdent, der Baureihe und Baureihengruppe des Fahrzeugs anhand der eingestellten 17-stelligen Fahrgestellnummer erkennt:
   Isom.Base.Boolean ContextIdent() // Einsprungspunkt zur Baureihenerkennung (Phase 1)
   {
      // Abfrage der Zugriffsinstanz
      Isom.Context.ContextConfiguration ccfg = Isom.Context.ContextConfiguration.GetInstance();

      // Abfrage der aktuell eingestellten Fahrgestellnummer
      Isom.Base.String vin17 = ccfg.GetVin17();

      // Prüfung, ob die Fahrgestellnummer bekannt ist
      if (vin17.IsVoid())
      {
        // Fahrgestellnummer nicht eingestellt
        return false;
      }

      // Ermittlung der Baureihe durch den Fachdienst für Logistikinformationen
      Isom.Base.String modelSeries = ccfg.FindModelSeries();

      if (modelSeriesGroup.IsVoid())
      {
        // Baureihengruppe konnte nicht ermittelt werden
        return false;
      }

      // Setzen der ermittelten Baureihe (setzt Baureihengruppe automatisch)
      return ccfg.SetModelSeries(modelSeries);
   }
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 555]
objectbound Isom.Base.String Isom.Context.ContextConfiguration.GetDataIntegrationLevel ( )

Fragt den Identifikator des eingestellten Softwarestands ab.

Der Wert wird Fachdiensten, die die Vorgabe eines Softwarestands benötigen, bei der Initialisierung übergeben.

Rückgabe:
Isom.Base.String
Identifikator des Softwarestands.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls noch kein Softwarestand gesetzt wurde.
Veraltet:
Veraltet seit Argonaut 1.17
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 27.06.2011
[Isom\Context\ContextConfiguration.is: 423]
objectbound Isom.Base.StringList Isom.Context.ContextConfiguration.GetDefaultLChannels ( )

Liefert die Liste der verfügbaren L-Kanäle

Die Liste wird initialisiert mit den L-Kanälen, die aus der ISOM-Fahrzeugbeschreibung des eingestellten Baureihenverbunds ermittelt werden (ohne Berücksichtigung des Verbindungszustands der entsprechenden P-Kanäle). Diese Liste kann mit der Fachfunktion Isom.Context.ContextConfiguration.SetDefaultLChannels geändert werden.

Vorbedingung:
Ermittelte Baureihengruppe und geladenene ISOM-Fahrzeugbeschreibung
Rückgabe:
Isom.Base.StringList
'Die Liste der verfügbaren L-Kanäle.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die verfügbaren L-Kanäle nicht ermittelt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 735]
objectbound Isom.Base.String Isom.Context.ContextConfiguration.GetDisplayProp ( Isom.Base.String propName )

Abfrage einer Anzeigeeigenschaft

Anzeigeeigenschaften erlauben es, den in dieser Fachklasse angebotenen Satz an Eigenschaften durch herstellerspezifische Eigenschaften zu erweitern. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Zu beachten:
Zur Anzeige auf der Serviceplattform Taurus® stehen die Anzeigeeigenschaften innerhalb der BOAM-Daten durch den Bezeichner ISOM:Vehicle.Context.DisplayPropertiesConfiguration.<Name> zur Verfügung.
Parameter:
propName Eigenschaftsname
Rückgabe:
Isom.Base.String
Wert der Anzeigeeigenschaft
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die abgefragte Eigenschaft nicht bekannt ist oder kein Wert gesetzt ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 1123]
objectbound Isom.Base.StringList Isom.Context.ContextConfiguration.GetDisplayPropNames ( )

Liefert die Namen aller Anzeigeeigenschaften.

Es werden die Eigenschaftsnamen für die Anzeigeeigenschaften zurückgeliefert, die mit Isom.Context.ContextConfiguration.GetDisplayProp() abgefragt werden können. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Rückgabe:
Isom.Base.StringList
Liste der Namen aller Anzeigeeigenschaften
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 1224]
Isom.Context.ContextConfiguration Isom.Context.ContextConfiguration.GetInstance ( )

Liefert die Objektinstanz für den Zugriff auf die bereitgestellten Funktionen.

Rückgabe:
Isom.Context.ContextConfiguration
Objektinstanz für den Zugriff auf die bereitgestellten Funktionen.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 27.06.2011
[Isom\Context\ContextConfiguration.is: 168]
objectbound Isom.Context.LogicalVehicleList Isom.Context.ContextConfiguration.GetLogicalVehicles ( )

Ermittelt die Liste verwendbarer logischer Fahrzeuge.

   Isom.Context.CurrentVehicleContext cvc = Isom.Context.CurrentVehicleContext.GetInstance();
   Isom.Context.LogicalVehicleList vl = cvc.GetLogicalVehicles();
Siehe auch:
Isom.Context.ContextConfiguration.GetLogicalVehicles
Isom.Context.FutureVehicleContext.GetLogicalVehicles
Isom.Context.Ecu.GetLogicalVehicle
Isom.Plan.TherapyPlanAction.GetLogicalVehicles
Seit:
Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).
Rückgabe:
Isom.Context.LogicalVehicleList
Liste verwendbarer Logischer Fahrzeuge
Datum:
letzte Änderung am 29.06.2011
[Isom\Context\ContextConfiguration.is: 850]
objectbound Isom.Base.String Isom.Context.ContextConfiguration.GetModelSeries ( )

Fragt die eingestellte Baureihe ab.

Die Baureihe kann mit Isom.Context.ContextConfiguration.SetModelSeries eingestellt werden.

Zu beachten:
Zur Anzeige auf der Serviceplattform Taurus® steht der Wert innerhalb der BOAM-Daten durch den Bezeichner ISOM:Vehicle.Context.ModelSeries zur Verfügung.
Rückgabe:
Isom.Base.String
Name der Baureihe.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls noch keine Baureihe gesetzt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 27.06.2011
[Isom\Context\ContextConfiguration.is: 285]
objectbound Isom.Base.String Isom.Context.ContextConfiguration.GetModelSeriesGroup ( )

Fragt den Namen der eingestellten Baureihengruppe ab.

Die Baureihengruppe kann mit Isom.Context.ContextConfiguration.SetModelSeriesGroup eingestellt werden.

Zu beachten:
Zur Anzeige auf der Serviceplattform Taurus® steht der Wert innerhalb der Servicedaten BOAM durch den Bezeichner ISOM:Vehicle.Context.ModelSeriesGroup zur Verfügung.
Rückgabe:
Isom.Base.String
Name der Baureihengruppe.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls noch keine Baureihengruppe gesetzt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 27.06.2011
[Isom\Context\ContextConfiguration.is: 237]
objectbound Isom.Base.String Isom.Context.ContextConfiguration.GetModelSeriesRevision ( )

Fragt den Überarbeitungsstand des Fahrzeugs ab.

Rückgabe:
Isom.Base.String
Überarbeitungsstand des Fahrzeugs
oder Isom.Base.String.Void() wenn keiner gesetzt.
Siehe auch:
Isom.Context.ContextConfiguration.SetModelSeriesRevision
Seit:
Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 23. 08 .2011
[Isom\Context\ContextConfiguration.is: 797]
objectbound Isom.Base.String Isom.Context.ContextConfiguration.GetOem ( )

Fragt den Namen des eingestellten Mandanten ab.

Der Mandant legt unter Anderem fest, welche Servicedaten und welche Fachdienstanbindungen verwendet werden.

Rückgabe:
Isom.Base.String
Name des Mandanten.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 27.06.2011
[Isom\Context\ContextConfiguration.is: 190]
objectbound Isom.Base.StringList Isom.Context.ContextConfiguration.GetPossibleInterfaces ( )

Liefert die Liste der möglichen Fahrzeugzugänge.

Die Liste der möglichen Fahrzeugzugänge wird aus der ISOM-Fahrzeugbeschreibung des eingestellten Baureihenverbunds ermittelt.

Vorbedingung:
Ermittelte Baureihengruppe und geladenene ISOM-Fahrzeugbeschreibung
Rückgabe:
Isom.Base.StringList
Liste der möglichen Fahrzeugzugänge.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die möglichen Fahrzeugzugänge nicht ermittelt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 608]
objectbound Isom.Base.StringList Isom.Context.ContextConfiguration.GetPossibleNChannels ( )

Ermittelt die Liste der verfügbaren N-Kanäle des Fahrzeugs

Diese Funktion liefert die Liste der N-Kanäle, deren P-Kanal verbunden und für die mindestens ein L-Kanal verfügbar ist. Die Liste der N-Kanäle und ihrer P-Kanäle und L-Kanäle werden in der ISOM-Fahrzeugbeschreibung des gesetzen Baureihenverbunds konfiguriert. Die verfügbaren L-Kanäle können vom Serviceautor mit Isom.Context.ContextConfiguration.SetDefaultLChannels eingeschränkt werden. Diese Funktion berücksichtigt diese Einschränkung.

Vorbedingung:
Ermittelte Baureihengruppe und geladenene ISOM-Fahrzeugbeschreibung
Rückgabe:
Isom.Base.StringList
Liste der verfügbaren N-Kanäle.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die N-Kanäle nicht ermittelt werden konnten.
Verwendungsbeispiel:
Der folgende Quelltext zeigt eine Implementierung des Einsprungspunkts CheckAccess, der die Liste der verfügbaren N-Kanäle durchläuft:
   Isom.Base.Boolean CheckAccess() // Einsprungspunkt zur Prüfung des Fahrzeugzugangs (Phase 2)
   {
     // Abfrage der Zugriffsinstanz
     Isom.Context.ContextConfiguration ccfg = Isom.Context.ContextConfiguration.GetInstance();

     // Abfrage der verfügbaren N-Kanäle
     Isom.Base.StringList possibleNChannels = ccfg.GetPossibleNChannels();

     // Iteration über die Liste
     possibleNChannels.Reset();
     while(possibleNChannels.HasNext())
     {
       // Abfrage des nächsten N-Kanals
       Isom.Base.String nChannel = possibleNChannels.Next();

       // Prüfung und Protokollierung
       // ..
     }
   }
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 661]
objectbound Isom.Base.String Isom.Context.ContextConfiguration.GetProp ( Isom.Base.String propName )

Abfrage einer technischen Eigenschaft

Eigenschaften erlauben es, den in dieser Fachklasse angebotenen Satz an Eigenschaften durch herstellerspezifische Eigenschaften zu erweitern. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Parameter:
propName Eigenschaftsname
Rückgabe:
Isom.Base.String
Wert der Eigenschaft
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die abgefragte Eigenschaft nicht bekannt ist oder kein Wert gesetzt ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 1062]
objectbound Isom.Base.StringList Isom.Context.ContextConfiguration.GetPropNames ( )

Liefert die Namen aller technischen Eigenschaften für das Fahrzeug.

Es werden die Eigenschaftsnamen für die technischen Eigenschaften zurückgeliefert, die mit Isom.Context.ContextConfiguration.GetProp() abgefragt werden können. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Verwendungsbeispiel:
Der folgende Quelltext zeigt eine Implementierung des Einsprungspunkts OnRestartTherapySession, die die Eigenschaften, die bei der vorherigen Sitzungsdurchführung gesetzt wurden untersucht und für den Wiedereinstieg ggf. verändert:
   Isom.Base.Boolean OnRestartTherapySession() // Einsprungspunkt bei Wiedereinstieg in eine Sitzung
   {
     // Abfrage der Zugriffsinstanz
     Isom.Context.ContextConfiguration ccfg = Isom.Context.ContextConfiguration.GetInstance();

     // Abfrage der Namen der gesetzten Eigenschaften
     Isom.Base.StringList propNames = ccfg.GetPropNames();

     // Iteration über die Liste
     propNames.Reset();
     while(propNames.HasNext())
     {
       // Abfrage des nächsten Eigenschaftsnamens
       Isom.Base.String propName = propNames.Next();

       // Behandlung der Eigenschaft beim Wiedereinstieg
       // ..
     }

     // Weitere Behandlung des Wiedereinstiegs
     // ..
     return true;
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller technischen Eigenschaften
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 1203]
objectbound Isom.Base.String Isom.Context.ContextConfiguration.GetSessionName ( )

Fragt den Namen der aktuellen Sitzung ab.

Der Sitzungsname ist ein Bezeichner, der durch den Serviceautor mit Isom.Context.ContextConfiguration.SetSessionName() festgelegt wird.

Zu beachten:
Zur Anzeige des Werts auf der Serviceplattform Taurus® wird auf ihn innerhalb der BOAM-Daten mit ISOM:Context.ContextConfiguration.SessionName zugegriffen.
Rückgabe:
Isom.Base.String
Name, der für die aktuelle Sitzung festgelegt wurde.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls kein Name für die aktuelle Sitzung festgelegt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 27.06.2011
[Isom\Context\ContextConfiguration.is: 882]
objectbound Isom.Base.String Isom.Context.ContextConfiguration.GetSessionRemark ( )

Fragt den Sitzungshinweis ab.

Der Sitzungshinweis wird durch den Serviceautor mit Isom.Context.ContextConfiguration.SetSessionName() festgelegt.

Zu beachten:
Zur Anzeige des Werts auf der Serviceplattform Taurus® wird auf ihn innerhalb der BOAM-Daten mit ISOM:Context.ContextConfiguration.SessionData zugegriffen.
Rückgabe:
Isom.Base.String
Sitzungshinweis, der für die aktuelle Sitzung festgelegt wurde.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls kein Hinweis für die aktuelle Sitzung festgelegt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 27.06.2011
[Isom\Context\ContextConfiguration.is: 907]
objectbound Isom.Context.EcuList Isom.Context.ContextConfiguration.GetSoftwareVersionEcus ( )

Liefert eine Liste der Steuergeräte, von denen der Softwarezustand des Fahrzeugs ermittelt werden kann.

Die Funktion liefert eine ungefilterte Liste aller Steuergeräte, die in der ISOM-Fahrzeugbeschreibung der eingestellten Baureihengruppe im Element „SoftwareVersionEcus“ angegeben wurden.

Vorbedingung:
Ermittelte Baureihengruppe und geladenene ISOM-Fahrzeugbeschreibung
Zu beachten:
Die Funktionen Isom.Context.CurrentVehicleContext.GetSoftwareVersionEcus und Isom.Context.FutureVehicleContext.GetSoftwareVersionEcus liefern jeweils eine Liste, die auf Basis der in dem jeweiligen Kontext vorhandenen Steuergeräte gefiltert wurde.
Rückgabe:
Isom.Context.EcuList
Steuergeräte, von denen der Softwarezustand des Fahrzeugs ermittelt werden kann.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die ISOM-Fahrzeugbeschreibung nicht ausgewertet werden konnte
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 394]
objectbound Isom.Context.EcuList Isom.Context.ContextConfiguration.GetVehicleConfigurationEcus ( )

Liefert eine Liste der Steuergeräte, von denen die Fahrzeugmerkmale ermittelt werden können.

Die Funktion liefert eine ungefilterte Liste aller Steuergeräte, die in der ISOM-Fahrzeugbeschreibung der eingestellten Baureihengruppe im Element „VehicleConfigurationEcus“ angegeben wurden.

Vorbedingung:
Ermittelte Baureihengruppe und geladenene ISOM-Fahrzeugbeschreibung
Zu beachten:
Die Funktionen Isom.Context.CurrentVehicleContext.GetVehicleConfigurationEcus und Isom.Context.FutureVehicleContext.GetVehicleConfigurationEcus liefern jeweils eine Liste, die auf Basis der in dem jeweiligen Kontext vorhandenen Steuergeräte gefiltert wurde.
Rückgabe:
Isom.Context.EcuList
Steuergeräte, von denen die Fahrzeugmerkmale ermittelt werden können.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die ISOM-Fahrzeugbeschreibung nicht ausgewertet werden konnte
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 365]
objectbound Isom.Base.String Isom.Context.ContextConfiguration.GetVehicleInterface ( )

Ermittelt den Namen des angeschlossenen Fahrzeugzugangs.

Die Funktion ermittelt den Namen vom Fachdienst, der für den Fahrzeugzugang zuständig ist

Vorbedingung:
Fachdienst zur Abfrage von Informationen zum Fahrzeugzugang
Rückgabe:
Isom.Base.String
Name des angeschlossenen Fahrzeugzugangs.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Fahrzeugzugang nicht ermittelt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 584]
objectbound Isom.Base.String Isom.Context.ContextConfiguration.GetVin17 ( )

Fragt die 17-stellige Fahrgestellnummer ab.

Die 17-stellige Fahrgestellnummer erhält ISOM vom Fachdienst für den Fahrzeugzugang, falls dieser sie liefert. Alternativ kann sie mit der Fachfunktion Isom.Context.ContextConfiguration.SetVin17 eingestellt werden.

Zu beachten:
Zur Anzeige auf der Serviceplattform Taurus® steht der Wert innerhalb der BOAM-Daten durch den Bezeichner ISOM:Vehicle.Context.Vin17 zur Verfügung.
Rückgabe:
Isom.Base.String
17-stellige Fahrgestellnummer.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Fahrgestellnummer noch nicht gesetzt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 27.06.2011
[Isom\Context\ContextConfiguration.is: 471]
objectbound Isom.Context.EcuList Isom.Context.ContextConfiguration.GetVinEcus ( )

Liefert eine Liste der Steuergeräte, von denen die Fahrgestellnummer ermittelt werden kann.

Die Funktion liefert eine ungefilterte Liste aller Steuergeräte, die in der ISOM-Fahrzeugbeschreibung der eingestellten Baureihengruppe im Element „VinEcus“ angegeben wurden.

Vorbedingung:
Ermittelte Baureihengruppe und geladenene ISOM-Fahrzeugbeschreibung
Zu beachten:
Die Funktionen Isom.Context.CurrentVehicleContext.GetVinEcus und Isom.Context.FutureVehicleContext.GetVinEcus liefern jeweils eine Liste, die auf Basis der in dem jeweiligen Kontext vorhandenen Steuergeräte gefiltert wurde.
Rückgabe:
Isom.Context.EcuList
Steuergeräte, von denen die Fahrgestellnummer ermittelt werden kann.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die ISOM-Fahrzeugbeschreibung nicht ausgewertet werden konnte
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 336]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.IsVoid ( )

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Das Void-Objekt kann z. B. bei Funktionsaufrufen geliefert werden, um einen Fehler anzuzeigen.

Rückgabe:
Isom.Base.Boolean
true, falls dies das Void-Objekt ist, false sonst
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\ContextConfiguration.is: 1248]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.SetDataIntegrationLevel ( Isom.Base.String newDataIntegrationLevel )

Setzt den Identifikator des eingestellten Softwarestands.

Der Wert wird Fachdiensten, die die Vorgabe eines Softwarestands benötigen, bei der Initialisierung übergeben.

Parameter:
newDataIntegrationLevel Identifikator des zu setzenden Softwarestands.
Rückgabe:
Isom.Base.Boolean
'true' gdw. der Softwarestand erfolgreich gesetzt wurde.
Veraltet:
Veraltet seit Argonaut 1.17
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 445]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.SetDefaultLChannels ( Isom.Base.StringList newDefaultLChannels )

Setzt die Liste der verfügbaren L-Kanäle

Die gesetzten L-Kanäle beeinflussen Fachfunktionen wie z. B. Isom.Context.ContextConfiguration.GetPossibleNChannels() oder die Ermittlung des Aktionsplans mit Isom.Plan.ActionPlan.DoTp2Ap().

Parameter:
newDefaultLChannels neue Liste von Default-L-Kanälen.
Rückgabe:
Isom.Base.Boolean
'true' gdw. die Liste der verfügbaren L-Kanäle erfolgreich gesetzt wurde.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls newDefaultLChannels Void ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 759]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.SetDisplayProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt eine Anzeigeeigenschaft

Anzeigeeigenschaften erlauben es, den in dieser Fachklasse angebotenen Satz an Eigenschaften durch herstellerspezifische Eigenschaften zu erweitern. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Zu beachten:
Im Vergleich zu Isom.Context.ContextConfiguration.SetProp() eignet sich diese Funktion für Eigenschaftswerte, die lokalisiert werden.
Parameter:
propName | Eigenschaftsname
propValue | Neuer Wert der Eigenschaft
Rückgabe:
Isom.Base.Boolean
Immer true.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 1151]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.SetModelSeries ( Isom.Base.String modelSeries )

Setzt die vorgegebene Baureihe

ISOM ermittelt die Baureihengruppe bei Setzen der Baureihe auf Basis der zugehörigen Fahrzeugbeschreibung automatisch und setzt sie mit Isom.Context.ContextConfiguration.SetModelSeriesGroup.

Parameter:
modelSeries Name der zu setzenden Baureihe.
Rückgabe:
Isom.Base.Boolean
'true' gdw. die Baureihe erfolgreich gesetzt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 306]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.SetModelSeriesGroup ( Isom.Base.String modelSeriesGroup )

Setzt die vorgegebene Baureihengruppe

Diese Funktion löst das Laden der ISOM-Fahrzeugbeschreibung der gesetzten Baureihengruppe aus. Dadurch wird z. B. die Fahrzeuggeneration, die mit Isom.Context.CurrentVehicleContext.GetVehicleGeneration() abgefragt werden kann, gesetzt und das Kanalmodell der Baureihengruppe initialisiert.

Parameter:
modelSeriesGroup Name der zu setzenden Baureihengruppe.
Rückgabe:
Isom.Base.Boolean
'true' gdw. die Baureihengruppe erfolgreich gesetzt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 260]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.SetModelSeriesRevision ( Isom.Base.String newModelSeriesRevision )

Setzt den Überarbeitungsstand des Fahrzeugs.

Parameter:
oem Name des zu setzenden Überarbeitungsstand.
Rückgabe:
Isom.Base.Boolean
true, falls Setzen erfolgreich
false nie.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Parameter Void oder eine leere Zeichenkette ist.
Es wird das Void-Objekt zurückgegeben, falls der Überarbeitungsstand in der geladenen ISOM-Fahrzeugbeschreibung nicht modelliert ist.
Siehe auch:
Isom.Context.ContextConfiguration.GetModelSeriesRevision
Seit:
Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 23. 08 .2011
[Isom\Context\ContextConfiguration.is: 824]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.SetNChannelEnforcedSequential ( Isom.Base.String nchannelList )

Legt N-Kanäle fest, die in der Planausführung nicht parallel verwendet werden dürfen

Aktionen, deren N-Kanäle in der Liste angegeben werden, werden bei der Ermittlung des Aktionsplans mit Isom.Plan.ActionPlan.DoTp2Ap() sequentialisiert.

Vorbedingung:
Ermittelte Baureihengruppe und geladenene ISOM-Fahrzeugbeschreibung
Parameter:
nchannelList Komma-separierte Liste der Kanäle, die zwangssequentialisiert werden.
Rückgabe:
Isom.Base.Boolean
'true' gdw. die nicht-parallelen N-Kanäle erfolgreich festgelegt wurden.
Verwendungsbeispiel:
Der folgende Quelltext zeigt eine Implementierung des Einsprungspunkts DoTp2Ap, die festlegt, dass der Aktionsplan keine parallel ausgeführten Aktionen enthalten darf:
   Isom.Base.Boolean DoTp2Ap() // Einsprungspunkt zur Berechnung des Aktionsplans (Phase 9)
   {
     // Abfrage der Zugriffsinstanz
     Isom.Context.ContextConfiguration ccfg = Isom.Context.ContextConfiguration.GetInstance();

     // Abfrage der verfügbaren N-Kanäle
     Isom.Base.StringList possibleNChannels = ccfg.GetPossibleNChannels();

     // Erzwingen sequentieller Aktionsausführung auf diesen N-Kanälen
     ccfg.SetNChannelEnforcedSequential(possibleNChannels);

     // Berechnung des Aktionsplans
     // ..
     return true;
   }
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 708]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.SetOem ( Isom.Base.String oem )

Setzt den Namen des Mandanten.

Diese Funktion erlaubt es, den beim Start von ISOM festgelegten Mandanten (durch die ISOM-Konfigurationsdatei oder als Kommandozeilenparameter) zu wechseln. Durch Setzen eines Mandanten werden u. A. dessen Servicedaten und Fachdienstanbindungen geladen.

Parameter:
oem Name des zu setzenden Mandanten.
Rückgabe:
Isom.Base.Boolean
'true' gdw. der Mandant erfolgreich gesetzt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 212]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.SetProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt eine technische Eigenschaft

Eigenschaften erlauben es, den in dieser Fachklasse angebotenen Satz an Eigenschaften durch herstellerspezifische Eigenschaften zu erweitern. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Zu beachten:
Im Vergleich zu Isom.Context.ContextConfiguration.SetDisplayProp() eignet sich diese Funktion nur für Eigenschaftswerte, die nicht lokalisiert werden.
Parameter:
propName | Eigenschaftsname
propValue | Eigenschaftswert
Rückgabe:
Isom.Base.Bool'true'> Immer true.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 1091]
objectbound Isom.Base.Boolean Isom.Context.ContextConfiguration.SetVin17 ( Isom.Base.String vin )

Setzt die 17-stellige Fahrgestellnummer.

Die übergebene Fahrgestellnummer muss 17 Stellen haben. Ansonsten wird sie nicht gesetzt.

Parameter:
vin Zu setzende Fahrgestellnummer.
Rückgabe:
Isom.Base.Boolean
'true' gdw. die Fahrgestellnummer erfolgreich gesetzt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 491]
Isom.Context.ContextConfiguration Isom.Context.ContextConfiguration.Void ( )

Erzeugt ein Void-Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Isom.Context.ContextConfiguration
Die Funktion liefert immer ein Void-Objekt.
Ausnahmebehandlung:
Void wird von dieser Funktion immer geliefert.
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\ContextConfiguration.is: 1277]


für Serviceautoren

Isom.Context.CurrentVehicleContext

Namensraum Isom.Context.CurrentVehicleContext

Fachklasse für den Istkontext Mehr...

Funktionen
Isom.Context.CurrentVehicleContext | GetInstance()

Liefert die Objektinstanz zum Zugriff auf die bereitgestellten Funktionen.

Eigenschaften des Fahrzeugs

Isom.Base.String | GetBuildVersion()

Liefert den Integrationsstand bei Bau des Fahrzeugs.

Isom.Base.String | GetCurrentVersion()

Liefert den aktuellen Integrationsstand des Fahrzeugs.

Isom.Context.EcuList | GetEcus()

Fragt die Steuergeräteliste ab.

Isom.Base.String | GetHistoricalVersion()

Liefert den Integrationsstand vor der letzten Aktualisierung.

Isom.Base.String | GetOdometerUnit()

Liefert die physikalische Maßeinheit des Wegstreckenzählers.

Isom.Base.String | GetOdometerValue()

Liefert den Wert des Stands des Wegstreckenzählers.

Isom.Base.String | GetPreviousOemVersion()

Ermittelt die Versionskennung der Programmierapplikation, die im Rahmen der letzten Fahrzeugbehandlung verwendet wurde.

Isom.Context.UserProfile | GetUserProfileClone()

Liefert das Benutzerprofil.

Isom.Base.String | GetVehicleGeneration()

Liefert die Fahrzeuggeneration.

Isom.Base.String | GetVehicleIdentificationNumber()

Liefert die 17-stellige Fahrgestellnummer des Fahrzeugs.

Isom.Context.VehicleOrder | GetVehicleOrderClone()

Liefert die Repräsentation der Fahrzeugmerkmale.

Isom.Base.Boolean | SetBuildVersion(Isom.Base.String version)

Setzt den Integrationsstand bei Bau des Fahrzeugs.

Isom.Base.Boolean | SetCurrentVersion(Isom.Base.String version)

Setzt den aktuellen Integrationsstand des Fahrzeugs.

Isom.Base.Boolean | SetEcus(Isom.Context.EcuList newList)

Setzt die Steuergeräteliste.

Isom.Base.Boolean | SetHistoricalVersion(Isom.Base.String version)

Setzt den Integrationsstand vor der letzten Aktualisierung.

Isom.Base.Boolean | SetOdometer(Isom.Base.String newOdoValue, Isom.Base.String newOdoUnit)

Setzt Wert und Maßeinheit des Wegstreckenzählers im Datenmodell.

Isom.Base.Boolean | SetVehicleGeneration(Isom.Base.String vehicleGeneration)

Setzt die Fahrzeuggeneration im Datenmodell.

Isom.Base.Boolean | SetVehicleOrder(Isom.Context.VehicleOrder vo)

Setzt die Fahrzeugmerkmale.

Isom.Base.Boolean | SetVin17(Isom.Base.String vin17)

Setzt die Fahrgestellnummer im Datenmodell.

Steuergerätebezogene Hilfsfunktionen

Isom.Context.EcuList | GetEcusByBus(Isom.Base.String busName)

Liefert die Steuergeräte an einem Fahrzeugbus.

Isom.Context.EcuList | GetExpectedEcus()

Ermittelt die Steuergeräte, die im Fahrzeug verbaut sein sollten.

Isom.Context.Ecu | GetGatewayByBus(Isom.Base.String busName)

Liefert das Gateway-Steuergerät eines Fahrzeugbusses.

Isom.Context.EcuList | GetSoftwareVersionEcus()

Liefert eine Liste der Steuergeräte, von denen die Integrationsstände des Fahrzeugs ermittelt werden können.

Isom.Context.EcuList | GetSpecialFunctionEcus(Isom.Base.String functionName)

Liefert eine Liste der Steuergeräte mit besonderen Funktionsmerkmalen.

Isom.Context.EcuList | GetVehicleConfigurationEcus()

Liefert eine Liste der Steuergeräte, von denen die Fahrzeugmerkmale ermittelt werden können.

Isom.Context.EcuList | GetVinEcus()

Liefert eine Liste der Steuergeräte, von denen die Fahrgestellnummer ermittelt werden kann.

Isom.Base.StringDictionary | RunProcess(Isom.Base.String processName, Isom.Base.StringDictionary arguments)

Führt eine benannte OEM-Funktion aus.

Ermittlung von Eigenschaften aus dem Fahrzeug

Isom.Base.Number | GetBatteryVoltage()

Ermittlung der aktuellen Batteriespannung.

Isom.Base.Number | GetIgnitionVoltage()

Ermittlung der aktuellen Zündspannung.

Isom.Context.EcuList | IdentifyAllEcus()

Identifiziert alle Steuergeräte des Fahrzeugs.

Isom.Base.Boolean | ReadDtcFromAllEcus()

Ermittelt die Fehlerspeichereinträge.

Isom.Base.Boolean | ReadOdometerFromEcus(Isom.Context.EcuList odometerEcus)

Ermittelt den Wert und Maßeinheit des gezeigten Wegstreckenzählers

Isom.Base.Boolean | ReadUserProfile()

Ermittelt das Benutzerprofil des Fahrzeugs.

Isom.Base.Boolean | ReadVehicleOrder()

Ermittelt die vollständigen Fahrzeugmerkmale.

Isom.Base.Boolean | ReadVehicleOrderAdditionals()

Vervollständigt vom Fahrzeug gelesene Fahrzeugmerkmale mit Zusatzinformationen

Isom.Base.Boolean | ReadVehicleOrderPure()

Ermittelt die Fahrzeugmerkmale, wie sie vom Fahrzeug geliefert werden.

Isom.Base.Boolean | ReadVersions()

Ermittlung der Integrationsstände des Fahrzeugs.

Isom.Base.Boolean | ReadVin()

Ermittelt die Fahrgestellnummer

Schreiben in das Fahrzeug

Isom.Base.Boolean | ClearDtcInAllEcus()

Löscht die Fehlerspeichereinträge.

Isom.Base.Boolean | DeployAllVersions()

Schreibt alle Softwarestände aus dem Datenmodell in das Fahrzeug.

Isom.Context.UserProfile | DeployUserProfile()

Schreibt das Benutzerprofil aus dem Sollkonntext in das Fahrzeug.

Isom.Base.Boolean | UserProfileChanged()

Prüft, ob das Benutzerprofil im Sollkontext Änderungen gegenüber dem Istkontext enthält.

Datenimport

Isom.Base.Boolean | ImportVehicleOrder()

Importiert Fahrzeugmale aus einer externen Datenquelle.

Eigenschaften

Typischerweise herstellerabhängige Datenwerte, die das Fahrzeug charakterisieren. Für baureihenspezifische Eigenschaftsnamen siehe herstellerspezifisches Begleitdokument.

Isom.Base.String | GetDisplayProp(Isom.Base.String propName)

Abfrage einer Anzeigeeigenschaft

Isom.Base.StringList | GetDisplayPropNames()

Liefert die Namen aller Anzeigeeigenschaften.

Isom.Base.String | GetProp(Isom.Base.String propName)

Abfrage einer technischen Eigenschaft

Isom.Base.StringList | GetPropNames()

Liefert die Namen aller technischen Eigenschaften für das Fahrzeug.

Isom.Base.Boolean | SetDisplayProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt eine Anzeigeeigenschaft

Isom.Base.Boolean | SetProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt eine technische Eigenschaft

Logische Fahrzeuge und Überarbeitungsstände

Informationen zu logischen Fahrzeugen als Teile des Fahrzeugkontexts, über die Teilbordnetze des Fahreugs separat angesprochen werden können sowie zu Überarbeitungsstände, die den Verbau des Fahrzeugs charakterisieren.
(Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).)

Isom.Context.LogicalVehicleList | GetLogicalVehicles()

Ermittelt die Liste verwendbarer logischer Fahrzeuge.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Context.CurrentVehicleContext | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Isom.Context.CurrentVehicleContext | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Diese Fachklasse enthält Funktionen zur Ermittlung des aktuellen Fahrzeugzustands und zum Zugriff auf die ermittelten Werte. Die bereitgestellten Eigenschaften werden üblicherweise mit Fachfunktionen, die mit „Read“ beginnen, aus dem Fahrzeug ermittelt. Die Eigenschaften können mit Fachfunktionen, die mit „Set“ beginnen, gesetzt werden, um so eine Ermittlung zu überpringen oder ermittelte Werte zu überschreiben. Fachfunktionen, die mit „Get“ beginnen, liefern üblicherweise die Eigenschaften aus dem Modell des Fahrzeugs. Fachfunktionen, die Eigenschaften des Modells in das physikalische Fahrzeug übertragen, beginnen mit „Deploy“.

Achtung:
Wenn Daten aus dem Fahrzeug gelesen werden, dann überschreiben diese in der Regel Werte im ISOM-Objektmodell, die zuvor vom Serviceautor gesetzt wurden. Auf Ausnahmen von dieser Regel wird in der Beschreibung der jeweiligen Fachfunktion ausdrücklich hingewiesen.
Verwendungsbeispiel:
Der folgende Quelltext zeigt eine einfache Implementierung des Einsprungspunkts UpdateCurrentContextVehicleData:
   Isom.Base.Boolean UpdateCurrentContextVehicleData() // Einsprungspunkt zur Ermittlung von Fahrzeuginformationen (Phase 3)
   {
      // Abfrage der Zugriffsinstanz
      Isom.Context.CurrentVehicleContext cctx = Isom.Context.CurrentVehicleContext.GetInstance();

      // Ermittlung der Fahrzeugmerkmale durch den Fachdienst zur Fahrzeugkommunikation
      if (cctx.ReadVehicleOrder().Failed())
      {
        // Fahrzeugmerkmale konnten nicht ausgelesen werden
        return false;
      }

      // Ermittlung der Integrationsstände durch den Fachdienst zur Fahrzeugkommunikation
      if (cctx.ReadVersions().Failed())
      {
        // Integrationsstände konnten nicht ausgelesen werden
        return false;
      }

      // Ermittlung des Benutzerprofils durch den Fachdienst zur Fahrzeugkommunikation
      if (cctx.ReadUserProfile().Failed())
      {
        // Benutzerprofil konnte nicht ausgelesen werden
        return false;
      }

      // Abfrage einer Kopie der ermittelten Fahrzeugmerkmale
      Isom.Context.VehicleOrder vo = cctx.GetVehicleOrderClone();

      // Auswertung der ermittelten Fahrzeugmerkmale
      // ..

      return true;
   }

Quelldateien:

  • Isom\Context\CurrentVehicleContext.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.ClearDtcInAllEcus ( )

Löscht die Fehlerspeichereinträge.

Die Funktion erlaubt es, Fahrzeugmale einzubringen, die z. B. als externe Datei vorliegen

Bemerkungen:
Auf der Serviceplattform Taurus® wird zur Datenablage der Dienst Hermes verwendet. Die unterstützten Datenarten werden in der Konfiguration von Hermes festgelegt. Instanzen der Fachklasse Isom.Exchange.DataDescription beschreiben die Daten, auf die zugegriffen wird. Sie legen die Indizes fest, mit denen die Daten gegenüber Hermes identifiziert werden. Ist wie z. B. wie bei ISOM Didact kein Dienst zur Datenablage vorhanden, muss ein gültiges Datenaustauschverzeichnis für ISOM konfiguriert sein.
Rückgabe:
Isom.Base.Boolean
true nach erfolgreichem Löschen, false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der zur Fahrzeugkommunikation angebundene Fachdienst das Löschen von Fehlerspeichereinträgen nicht unterstützt.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1496]
objectbound Isom.Context.CurrentVehicleContext Isom.Context.CurrentVehicleContext.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Isom.Context.CurrentVehicleContext
Das geklonte Objekt.
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\CurrentVehicleContext.is: 1808]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.DeployAllVersions ( )

Schreibt alle Softwarestände aus dem Datenmodell in das Fahrzeug.

Ein Integrationsstand versioniert alle im Fahrzeug verbauten Steuergeräte eindeutig. Dabei handelt es sich üblicherweise um eine Versionsinformation, die einen festgelegten Stand von Hard- und Softwareeinheiten für Steuergeräte benennt. Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um die im Datenmodell gesetzten Werte für den aktuellen Softwarestand, den Softwarestand beim Bau des Fahrzeugs und den Softwarestand vor der letzten Aktualisierung des Fahrzeugs in das Fahrzeug zu schreiben.

Achtung:
Nach fehlgeschlagenem Fachdienstaufruf (Rückgabewert Void) können alle Integrationsstände zurückgesetzt (Void) sein.
Rückgabe:
Isom.Base.Boolean
true, falls die Integrationsstände erfolgreich geschrieben wurden false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls ein technischer Fehler aufgetreten ist (z.B. Aufruf der Fachfunktion für Fahrzeuge, die keine Integrationsstände unterstützen)
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1419]
objectbound Isom.Context.UserProfile Isom.Context.CurrentVehicleContext.DeployUserProfile ( )

Schreibt das Benutzerprofil aus dem Sollkonntext in das Fahrzeug.

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um das im Isom.Context.FutureVehicleContext geführte Benutzerprofil in das Fahrzeug zu schreiben. Ist in Isom.Context.FutureVehicleContext kein Benutzerprofil gesetzt, wird das Benutzerprofil des Istkontexts Isom.Context.CurrentVehicleContext geschrieben.

Rückgabe:
Isom.Context.UserProfile
Das Benutzerprofil, das geschrieben wurde.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Benutzerprofil nicht geschrieben werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1444]
objectbound Isom.Base.Number Isom.Context.CurrentVehicleContext.GetBatteryVoltage ( )

Ermittlung der aktuellen Batteriespannung.

Die Funktion verwendet den zum Fahrzeugzugang angebundenen Fachdienst, um den aktuellen Wert der Batteriespannung zu ermitteln.

Rückgabe:
Isom.Base.Number
Aktueller Wert der Batteriespannung in Volt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1308]
objectbound Isom.Base.String Isom.Context.CurrentVehicleContext.GetBuildVersion ( )

Liefert den Integrationsstand bei Bau des Fahrzeugs.

Der gelieferte Wert muss vorher mit der Funktion Isom.Context.CurrentVehicleContext.ReadVersions aus dem Fahrzeug ermittelt oder mit Isom.Context.CurrentVehicleContext.SetBuildVersion gesetzt werden.

Zu beachten:
Zur Anzeige des Werts auf der Serviceplattform Taurus® wird auf ihn innerhalb der BOAM-Daten mit ISOM:Vehicle.Context.BuildLevel zugegriffen.
Rückgabe:
Isom.Base.String
Identifikator des Integrationsstands bei Bau des Fahrzeugs.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Integrationsstand noch nicht ermittelt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 431]
objectbound Isom.Base.String Isom.Context.CurrentVehicleContext.GetCurrentVersion ( )

Liefert den aktuellen Integrationsstand des Fahrzeugs.

Der gelieferte Wert muss vorher mit der Funktion Isom.Context.CurrentVehicleContext.ReadVersions aus dem Fahrzeug ermittelt oder mit Isom.Context.CurrentVehicleContext.SetCurrentVersion gesetzt werden.

Zu beachten:
Zur Anzeige des Werts auf der Serviceplattform Taurus® wird auf ihn innerhalb der BOAM-Daten mit ISOM:Vehicle.Context.CurrentLevel zugegriffen.
Verwendungsbeispiel:
Der folgende Quelltext zeigt eine einfache Implementierung des Einsprungspunkts UpdateCurrentContextVehicleData, der die Integrationsstände vom Fahrzeug ermittelt:
   Isom.Base.Boolean UpdateCurrentContextVehicleData() // Einsprungspunkt zur Ermittlung von Fahrzeuginformationen (Phase 3)
   {
      // Abfrage der Zugriffsinstanz
      Isom.Context.CurrentVehicleContext cctx = Isom.Context.CurrentVehicleContext.GetInstance();

      // Ermittlung der Integrationsstände durch den Fachdienst zur Fahrzeugkommunikation
      if (cctx.ReadVersions().Failed())
      {
        // Integrationsstände konnten nicht ausgelesen werden
        return false;
      }

      // Abfrage des aktuellen Integrationsstands
      Isom.Base.String currentVersion = cctx.GetCurrentVersion();
      if (currentVersion.IsVoid())
      {
        // Aktueller Integrationsstand ungültig
        return false;
      }

      // Abfrage des Integrationsstands vor der letzten Aktualisierung
      Isom.Base.String historicalVersion = cctx.GetHistoricalVersion();
      if (historicalVersion.IsVoid())
      {
        // Integrationsstand vor der letzten Aktualisierung ungültig
        return false;
      }

      // Abfrage des Integrationsstands bei Bau des Fahrzeugs
      Isom.Base.String buildVersion = cctx.GetBuildVersion();
      if (buildVersion.IsVoid())
      {
        // Integrationsstand bei Bau des Fahrzeugs ungültig
        return false;
      }

      // Protokollierung und Auswertung der ermittelten Integrationsstände
      // ..

      return true;
   }
Rückgabe:
Isom.Base.String
Identifikator des aktuellen Integrationsstands.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Integrationsstand noch nicht ermittelt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 381]
objectbound Isom.Base.String Isom.Context.CurrentVehicleContext.GetDisplayProp ( Isom.Base.String propName )

Abfrage einer Anzeigeeigenschaft

Anzeigeeigenschaften erlauben es, den in dieser Fachklasse angebotenen Satz an Eigenschaften durch herstellerspezifische Eigenschaften zu erweitern. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Zu beachten:
Zur Anzeige auf der Serviceplattform Taurus® stehen die Anzeigeeigenschaften innerhalb der BOAM-Daten durch den Bezeichner ISOM:Vehicle.Context.DisplayPropertiesCurrent.<Name> zur Verfügung.
Parameter:
propName Eigenschaftsname
Rückgabe:
Isom.Base.String
Wert der Anzeigeeigenschaft
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die abgefragte Eigenschaft nicht bekannt ist oder kein Wert gesetzt ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\CurrentVehicleContext.is: 1627]
objectbound Isom.Base.StringList Isom.Context.CurrentVehicleContext.GetDisplayPropNames ( )

Liefert die Namen aller Anzeigeeigenschaften.

Es werden die Eigenschaftsnamen für die Anzeigeeigenschaften zurückgeliefert, die mit Isom.Context.CurrentVehicleContext.GetDisplayProp() abgefragt werden können. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Rückgabe:
Isom.Base.StringList
Liste der Namen aller Anzeigeeigenschaften
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\CurrentVehicleContext.is: 1728]
objectbound Isom.Context.EcuList Isom.Context.CurrentVehicleContext.GetEcus ( )

Fragt die Steuergeräteliste ab.

Die abgefragte Steuergeräteliste enthält die Steuergeräte, die im Fahrzeug verbaut sind. Sie wird befüllt durch Aufruf von Isom.Context.CurrentVehicleContext.IdentifyAllEcus oder durch Setzen der Liste mit Isom.Context.CurrentVehicleContext.SetEcus

Achtung:
Es wird eine Kopie der Steuergeräteliste des Istkontexts zurückgegeben. Eine Änderung derselben wirkt sich nicht auf die im Istkontext geführte Liste aus.
Zu beachten:
Zur Anzeige des Werts auf der Serviceplattform Taurus® wird auf ihn innerhalb der BOAM-Daten mit ISOM:EcuList zugegriffen.
Verwendungsbeispiel:
Der folgende Quelltext zeigt eine einfache Implementierung des Einsprungspunkts UpdateCurrentContextEcus, die die Steuergeräte im Fahrzeug identifiziert:
   Isom.Base.Boolean UpdateCurrentContextEcus() // Einsprungspunkt zur Ermittlung der verbauten Steuergeräte (Phase 4)
   {
     // Abfrage der Zugriffsinstanz
     Isom.Context.CurrentVehicleContext cctx = Isom.Context.CurrentVehicleContext.GetInstance();

     // Identifikation der Steuergeräte durch den Fachdienst zur Fahrzeugkommunikation
     Isom.Context.EcuList ecus = cctx.IdentifyAllEcus();
     if (ecus.IsVoid())
     {
       // Steuergeräte konnten nicht identifiziert werden
       return false;
     }

     // Iteration über die Liste
     ecus.Reset();
     while(ecus.HasNext())
     {
       // Abfrage des nächsten N-Kanals
       Isom.Context.Ecu ecu = ecus.Next();

       // Prüfung und Protokollierung
       // ..
     }

     return true;
   }
Rückgabe:
Isom.Context.EcuList
Kopie der Steuergeräteliste des Istkontexts.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 263]
objectbound Isom.Context.EcuList Isom.Context.CurrentVehicleContext.GetEcusByBus ( Isom.Base.String busName )

Liefert die Steuergeräte an einem Fahrzeugbus.

Die Funktion liefert die Steuergeräte, die sich im vorgegebenen Fahrzeugbus befinden. Die Buszuordnung wird in der Fahrzeugbeschreibung festgelegt.

Rückgabe:
Isom.Context.EcuList
Steuergeräte an einem Fahrzeugbus.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Parameter busName das Void-Objekt ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1022]
objectbound Isom.Context.EcuList Isom.Context.CurrentVehicleContext.GetExpectedEcus ( )

Ermittelt die Steuergeräte, die im Fahrzeug verbaut sein sollten.

Die Ermittlung benötigt einen angebundenen Fachdienst für Logistikinformationen, der die erwarteten Steuergeräte aus den ermittelten Fahrzeugmerkmalen herleitet.

Rückgabe:
Isom.Context.EcuList
Im Fahrzeug auf Basis der Fahrzeugmerkmale erwartete Steuergeräte.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Steuergeräte nicht ermittelt werden konnten.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 847]
objectbound Isom.Context.Ecu Isom.Context.CurrentVehicleContext.GetGatewayByBus ( Isom.Base.String busName )

Liefert das Gateway-Steuergerät eines Fahrzeugbusses.

Die Funktion liefert das Steuergerät, das das Gateway des vorgegebenen Fahrzeugbusses ist. Die Gateway-Zuordnung wird in der Fahrzeugbeschreibung festgelegt.

Rückgabe:
Isom.Context.Ecu
Gateway-Steuergerät.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Gateway-Steuergerät nicht ermittelt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1044]
objectbound Isom.Base.String Isom.Context.CurrentVehicleContext.GetHistoricalVersion ( )

Liefert den Integrationsstand vor der letzten Aktualisierung.

Der gelieferte Wert muss vorher mit der Funktion Isom.Context.CurrentVehicleContext.ReadVersions aus dem Fahrzeug ermittelt oder mit Isom.Context.CurrentVehicleContext.SetHistoricalVersion gesetzt werden.

Zu beachten:
Zur Anzeige des Werts auf der Serviceplattform Taurus® wird auf ihn innerhalb der BOAM-Daten mit ISOM:Vehicle.Context.HistoricalLevel zugegriffen.
Rückgabe:
Isom.Base.String
Identifikator des Integrationsstands vor der letzten Aktualisierung.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Integrationsstand noch nicht ermittelt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 480]
objectbound Isom.Base.Number Isom.Context.CurrentVehicleContext.GetIgnitionVoltage ( )

Ermittlung der aktuellen Zündspannung.

Die Funktion verwendet den zum Fahrzeugzugang angebundenen Fachdienst, um den aktuellen Wert der Zündspannung zu ermitteln.

Rückgabe:
Isom.Base.Number
Aktueller Wert der Zündspannung in Volt.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1287]
Isom.Context.CurrentVehicleContext Isom.Context.CurrentVehicleContext.GetInstance ( )

Liefert die Objektinstanz zum Zugriff auf die bereitgestellten Funktionen.

Rückgabe:
Isom.Context.CurrentVehicleContext
Objektinstanz zum Zugriff auf die bereitgestellten Funktionen.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 198]
objectbound Isom.Context.LogicalVehicleList Isom.Context.CurrentVehicleContext.GetLogicalVehicles ( )

Ermittelt die Liste verwendbarer logischer Fahrzeuge.

   Isom.Context.CurrentVehicleContext cvc = Isom.Context.CurrentVehicleContext.GetInstance();
   Isom.Context.LogicalVehicleList vl = cvc.GetLogicalVehicles();
Siehe auch:
Isom.Context.ContextConfiguration.GetLogicalVehicles
Isom.Context.FutureVehicleContext.GetLogicalVehicles
Isom.Context.Ecu.GetLogicalVehicle
Isom.Plan.TherapyPlanAction.GetLogicalVehicles
Seit:
Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).
Rückgabe:
Isom.Context.LogicalVehicleList
Liste verwendbarer Logischer Fahrzeuge
Datum:
letzte Änderung am 29.06.2011
[Isom\Context\CurrentVehicleContext.is: 1767]
objectbound Isom.Base.String Isom.Context.CurrentVehicleContext.GetOdometerUnit ( )

Liefert die physikalische Maßeinheit des Wegstreckenzählers.

Der gelieferte Wert muss vorher mit der Funktion Isom.Context.CurrentVehicleContext.ReadOdometerFromEcus aus dem Fahrzeug ermittelt oder mit Isom.Context.CurrentVehicleContext.SetOdometer gesetzt werden.

Zu beachten:
Zur Anzeige des Werts auf der Serviceplattform Taurus® wird auf ihn innerhalb der BOAM-Daten mit ISOM:Vehicle.Context.OdometerUnit zugegriffen.
Rückgabe:
Isom.Base.String
Einheit des Wegstreckenzählers.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Einheit des Wegstreckenzählers noch nicht ermittelt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 651]
objectbound Isom.Base.String Isom.Context.CurrentVehicleContext.GetOdometerValue ( )

Liefert den Wert des Stands des Wegstreckenzählers.

Der gelieferte Wert muss vorher mit der Funktion Isom.Context.CurrentVehicleContext.ReadOdometerFromEcus aus dem Fahrzeug ermittelt oder mit Isom.Context.CurrentVehicleContext.SetOdometer gesetzt werden. Die Funktion Isom.Context.CurrentVehicleContext.GetOdometerUnit liefert die physikalische Maßeinheit, in der der Wegstreckenzähler geführt wird.

Zu beachten:
Zur Anzeige des Werts auf der Serviceplattform Taurus® wird auf ihn innerhalb der BOAM-Daten mit ISOM:Vehicle.Context.OdometerCount zugegriffen.
Verwendungsbeispiel:
Der folgende Quelltext zeigt eine einfache Implementierung des Einsprungspunkts UpdateCurrentContextVehicleData, der den Stand des Wegstreckenzählers vom Fahrzeug ermittelt:
   Isom.Base.Boolean UpdateCurrentContextVehicleData() // Einsprungspunkt zur Ermittlung von Fahrzeuginformationen (Phase 3)
   {
      // Abfrage der Zugriffsinstanz
      Isom.Context.CurrentVehicleContext cctx = Isom.Context.CurrentVehicleContext.GetInstance();

      // Ermittlung von Wert und Maßeinheit des Wegstreckenzählers durch den Fachdienst zur Fahrzeugkommunikation
      if (cctx.ReadOdometerFromEcus().Failed())
      {
        // Wegstreckenzähler konnte nicht ausgelesen werden
        return false;
      }

      // Abfrage des Werts
      Isom.Base.String odomValue = cctx.GetOdometerValue();
      if (odomValue.IsVoid())
      {
        // Wert des Wegstreckenzählers ungültig
        return false;
      }

      // Abfrage der Maßeinheit
      Isom.Base.String odomUnit = cctx.GetOdometerUnit();
      if (odomUnit.IsVoid())
      {
        // Einheit des Wegstreckenzählers ungültig
        return false;
      }

      // Protokollierung und Auswertung der ermittelten Werte
      // ..

      return true;
   }
Rückgabe:
Isom.Base.String
Wert des Wegstreckenzählers.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Wert des Wegstreckenzählers noch nicht ermittelt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 625]
objectbound Isom.Base.String Isom.Context.CurrentVehicleContext.GetPreviousOemVersion ( )

Ermittelt die Versionskennung der Programmierapplikation, die im Rahmen der letzten Fahrzeugbehandlung verwendet wurde.

Falls die Versionskennung nicht bereits aus dem Fahrzeug gelesen wurde, ermittelt die Fachfunktion die Kennung über einen angebundenen Fachdienst für Logistik durch den aktuellen Integrationsstand des Fahrzeugs.

Zu beachten:
Zur Anzeige des Werts auf der Serviceplattform Taurus® wird auf ihn innerhalb der BOAM-Daten mit ISOM:Vehicle.Context.PreviousApplicationVersion zugegriffen.
Rückgabe:
Isom.Base.String
Versionskennung.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Versionskennung nicht ermittelt oder nicht von ISOM ausgewertet werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 703]
objectbound Isom.Base.String Isom.Context.CurrentVehicleContext.GetProp ( Isom.Base.String propName )

Abfrage einer technischen Eigenschaft

Eigenschaften erlauben es, den in dieser Fachklasse angebotenen Satz an Eigenschaften durch herstellerspezifische Eigenschaften zu erweitern. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Parameter:
propName Eigenschaftsname
Rückgabe:
Isom.Base.String
Wert der Eigenschaft
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die abgefragte Eigenschaft nicht bekannt ist oder kein Wert gesetzt ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\CurrentVehicleContext.is: 1566]
objectbound Isom.Base.StringList Isom.Context.CurrentVehicleContext.GetPropNames ( )

Liefert die Namen aller technischen Eigenschaften für das Fahrzeug.

Es werden die Eigenschaftsnamen für die technischen Eigenschaften zurückgeliefert, die mit Isom.Context.CurrentVehicleContext.GetProp() abgefragt werden können. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Verwendungsbeispiel:
Der folgende Quelltext zeigt eine Implementierung des Einsprungspunkts OnRestartTherapySession, die die Eigenschaften, die bei der vorherigen Sitzungsdurchführung gesetzt wurden untersucht und für den Wiedereinstieg ggf. verändert:
   Isom.Base.Boolean OnRestartTherapySession() // Einsprungspunkt bei Wiedereinstieg in eine Sitzung
   {
     // Abfrage der Zugriffsinstanz
     Isom.Context.CurrentVehicleContext cctx = Isom.Context.CurrentVehicleContext.GetInstance();

     // Abfrage der Namen der gesetzten Eigenschaften
     Isom.Base.StringList propNames = cctx.GetPropNames();

     // Iteration über die Liste
     propNames.Reset();
     while(propNames.HasNext())
     {
       // Abfrage des nächsten Eigenschaftsnamens
       Isom.Base.String propName = propNames.Next();

       // Behandlung der Eigenschaft beim Wiedereinstieg
       // ..
     }

     // Weitere Behandlung des Wiedereinstiegs
     // ..
     return true;
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller technischen Eigenschaften
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\CurrentVehicleContext.is: 1707]
objectbound Isom.Context.EcuList Isom.Context.CurrentVehicleContext.GetSoftwareVersionEcus ( )

Liefert eine Liste der Steuergeräte, von denen die Integrationsstände des Fahrzeugs ermittelt werden können.

Die Funktion liefert eine Liste aller Steuergeräte, die folgende zwei Bedingungen erfüllen:

  1. Sie sind Elemente der Steuergeräte-Liste dieses Kontexts, die mit Isom.Context.CurrentVehicleContext.GetEcus abgefragt wird.
  2. Sie sind in der Fahrzeugbeschreibung im Element „SoftwareVersionEcus“ für die aktuell eingestellte Baureihengruppe angegeben.

Rückgabe:
Isom.Context.EcuList
Steuergeräte, von denen die Integrationsstände des Fahrzeugs ermittelt werden können.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1000]
objectbound Isom.Context.EcuList Isom.Context.CurrentVehicleContext.GetSpecialFunctionEcus ( Isom.Base.String functionName )

Liefert eine Liste der Steuergeräte mit besonderen Funktionsmerkmalen.

Steuergeräte mit besonderen Funktionsmerkmalen werden in der Fahrzeugbeschreibung mit 'SpecialFunction' modelliert. Die Elemente in der gelieferten Liste sind dem Wert der 'Priority' nach aufsteigend angeordnet.

Verwendungsbeispiel:
Der folgende Quelltext zeigt eine einfache Implementierung des Einsprungspunkts DisplayVo, in der das Auslesen der Steuergeräte mit besonderen Funktionsmerkmalen erfolgt:
Der folgende Quelltext zeigt die Modellierung der besonderen Funktionsmerkmale im XML-Knoten 'SpecialFunctions' innerhalb einer Fahrzeugbeschreibung:
   Isom.Base.String DisplayVo()
  {
  // Abfrage der Zugriffsinstanz
     Isom.Context.CurrentVehicleContext cvc = Isom.Context.CurrentVehicleContext.GetInstance();
     //..

    // Ermittelt alle FA-tragenden SG
    Isom.Context.EcuList voEcus = cvc.GetSpecialFunctionEcus("VehicleOrderSequence");

    //...

   <Ecus>
  <!-- Gateways haben Adressen 1-10 -->
  <BaseVariant Name="PLCGW">
   <Address>1</Address>
    <GroupName>G_ZGW</GroupName>
    <SpecialFunctions>
      <Function Name="VehicleOrderSequence" Priority="1" />
      <Function Name="VinSequence" Priority="1" />
    </SpecialFunctions>
 //...
Parameter:
functionName Name des Funktionsmerkmals.
Rückgabe:
Isom.Context.EcuList
Steuergeräte mit dem Funktionsmerkmal.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 901]
objectbound Isom.Context.UserProfile Isom.Context.CurrentVehicleContext.GetUserProfileClone ( )

Liefert das Benutzerprofil.

Der gelieferte Wert wurde mit der Funktion Isom.Context.CurrentVehicleContext.ReadUserProfile aus dem Fahrzeug ermittelt.

Achtung:
Es wird eine Kopie des Benutzerprofils zurückgegeben.
Rückgabe:
Isom.Context.UserProfile
Fahrzeugmerkmale.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Benutzerprofil noch nicht ermittelt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 770]
objectbound Isom.Context.EcuList Isom.Context.CurrentVehicleContext.GetVehicleConfigurationEcus ( )

Liefert eine Liste der Steuergeräte, von denen die Fahrzeugmerkmale ermittelt werden können.

Die Funktion liefert eine Liste aller Steuergeräte, die folgende zwei Bedingungen erfüllen:

  1. Sie sind Elemente der Steuergeräte-Liste dieses Kontexts, die mit Isom.Context.CurrentVehicleContext.GetEcus abgefragt wird.
  2. Sie sind in der Fahrzeugbeschreibung im Element „VehicleConfigurationEcus“ für die aktuell eingestellte Baureihengruppe angegeben.

Rückgabe:
Isom.Context.EcuList
Steuergeräte, von denen die Fahrzeugmerkmale ermittelt werden können.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 976]
objectbound Isom.Base.String Isom.Context.CurrentVehicleContext.GetVehicleGeneration ( )

Liefert die Fahrzeuggeneration.

Der gelieferte Wert muss vorher beim Festlegen der Baureihe oder der Baureihengruppe mit Isom.Context.ContextConfiguration.SetModelSeries bzw. Isom.Context.ContextConfiguration.SetModelSeriesGroup automatisch ermittelt oder mit Isom.Context.CurrentVehicleContext.SetVehicleGeneration gesetzt werden.

Rückgabe:
Isom.Base.String
Fahrzeuggeneration.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Fahrzeuggeneration noch nicht ermittelt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 793]
objectbound Isom.Base.String Isom.Context.CurrentVehicleContext.GetVehicleIdentificationNumber ( )

Liefert die 17-stellige Fahrgestellnummer des Fahrzeugs.

Der gelieferte Wert muss vorher mit der Funktion Isom.Context.CurrentVehicleContext.ReadVin aus dem Fahrzeug ermittelt oder mit Isom.Context.ContextConfiguration.SetVin17 gesetzt werden.

Zu beachten:
Zur Anzeige des Werts auf der Serviceplattform Taurus® wird auf ihn innerhalb der BOAM-Daten mit ISOM:Vehicle.Context.Vin17 zugegriffen.
Rückgabe:
Isom.Base.String
Fahrgestellnummer.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Fahrgestellnummer noch nicht ermittelt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 558]
objectbound Isom.Context.VehicleOrder Isom.Context.CurrentVehicleContext.GetVehicleOrderClone ( )

Liefert die Repräsentation der Fahrzeugmerkmale.

Der gelieferte Wert muss vorher mit der Funktion Isom.Context.CurrentVehicleContext.ReadVehicleOrder aus dem Fahrzeug ermittelt oder mit Isom.Context.CurrentVehicleContext.SetVehicleOrder gesetzt werden.

Achtung:
Es wird eine Kopie der Repräsentation der Fahrzeugmerkmale zurückgegeben. Eine Änderung derselben wirkt sich nicht auf die im Istkontext geführten Fahrzeugmerkmale aus.
Zu beachten:
Zur Anzeige einer Zeichenkettenrepräsentation der Fahrzeugmerkmale auf der Serviceplattform Taurus® wird innerhalb der BOAM-Daten mit ISOM:Vehicle.Context.VehicleOrderOriginal zugegriffen.
Rückgabe:
Isom.Context.VehicleOrder
Fahrzeugmerkmale.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Fahrzeugmerkmale noch nicht ermittelt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 533]
objectbound Isom.Context.EcuList Isom.Context.CurrentVehicleContext.GetVinEcus ( )

Liefert eine Liste der Steuergeräte, von denen die Fahrgestellnummer ermittelt werden kann.

Die Funktion liefert eine Liste aller Steuergeräte, die folgende zwei Bedingungen erfüllen:

  1. Sie sind Elemente der Steuergeräte-Liste dieses Kontexts, die mit Isom.Context.CurrentVehicleContext.GetEcus() abgefragt wird.
  2. Sie sind in der Fahrzeugbeschreibung der eingestellten Baureihengruppe im Element „VinEcus“ angegeben.

Rückgabe:
Isom.Context.EcuList
Steuergeräte, von denen die Fahrgestellnummer ermittelt werden kann.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 952]
objectbound Isom.Context.EcuList Isom.Context.CurrentVehicleContext.IdentifyAllEcus ( )

Identifiziert alle Steuergeräte des Fahrzeugs.

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um die Steuergeräte zu identifizieren. Wenn funktionale Identifikation möglich ist, wird diese genutzt. Andernfalls dient die Steuergeräteliste, die Isom.Context.CurrentVehicleContext.GetEcus() liefert, als Liste der zu identifizierenden Steuergeräte.

Rückgabe:
Isom.Context.EcuList
Alle Steuergeräte, die identifiziert wurden oder deren Identifikation versucht wurde.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1358]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.ImportVehicleOrder ( )

Importiert Fahrzeugmale aus einer externen Datenquelle.

Die Funktion erlaubt es, Fahrzeugmale einzubringen, die z. B. als externe Datei vorliegen

Bemerkungen:
Auf der Serviceplattform Taurus® wird zur Datenablage der Dienst Hermes verwendet. Die unterstützten Datenarten werden in der Konfiguration von Hermes festgelegt. Instanzen der Fachklasse Isom.Exchange.DataDescription beschreiben die Daten, auf die zugegriffen wird. Sie legen die Indizes fest, mit denen die Daten gegenüber Hermes identifiziert werden. Ist wie z. B. wie bei ISOM Didact kein Dienst zur Datenablage vorhanden, muss ein gültiges Datenaustauschverzeichnis für ISOM konfiguriert sein.
Rückgabe:
Isom.Base.Boolean
true, wenn die Fahrzeugmale erfolgreich importiert werden konnte, false, sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1530]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.IsVoid ( )

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Das Void-Objekt kann z. B. bei Funktionsaufrufen geliefert werden, um einen Fehler anzuzeigen.

Rückgabe:
Isom.Base.Boolean
true, falls dies das Void-Objekt ist, false sonst
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1796]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.ReadDtcFromAllEcus ( )

Ermittelt die Fehlerspeichereinträge.

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um die Fehlerspeichereinträge zu ermitteln. Die Einstellungen des Benutzerprofils müssen in der Fahrzeugbeschreibung der eingestellten Baureihengruppe angegeben werden.

Rückgabe:
Isom.Base.Boolean
true, falls die Fehlerspeichereinträge erfolgreich ermittelt wurden false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1382]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.ReadOdometerFromEcus ( Isom.Context.EcuList odometerEcus )

Ermittelt den Wert und Maßeinheit des gezeigten Wegstreckenzählers

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um Wert und Maßeinheit des gezeigten Wegstreckenzählers aus dem Fahrzeug zu ermitteln. Die Liste der Steuergeräte, die dazu gefragt werden, wird als Parameter übergeben. Die Reihenfolge der SG in der Liste gibt die Reihenfolge bei der Abfrage und die Priorisierung bei der Übernahme des Werts vor. Die ermittelten Werte werden bei erfolgreicher Ausführung in das Datenmodell übernommen.

Parameter:
odometerEcus Liste der Steuergeräte, von denen der gezeigte Wegstreckenzähler abgefragt werden kann.
Rückgabe:
Isom.Base.Boolean
true, falls der gezeigte Wegstreckenzähler erfolgreich ermittelt werden konnte,
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1240]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.ReadUserProfile ( )

Ermittelt das Benutzerprofil des Fahrzeugs.

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um das Benutzerprofil zu ermitteln. Die Einstellungen des Benutzerprofils müssen in der Fahrzeugbeschreibung der eingestellten Baureihengruppe angegeben werden.

Rückgabe:
Isom.Base.Boolean
true, falls das Benutzerprofil erfolgreich ermittelt wurde false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1332]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.ReadVehicleOrder ( )

Ermittelt die vollständigen Fahrzeugmerkmale.

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um die Fahrzeugmerkmale zu ermitteln. Es werden nacheinander alle Steuergeräte, die Isom.Context.ContextConfiguration.GetVehicleOrderEcus() liefert, nach den Fahrzeugmerkmalen befragt. Das erste erfolgreich abgefragte Ergebnis wird in das Datenmodell übernommen.

Zu beachten:
Ein Aufruf dieser Funktion entspricht einem Aufruf von Isom.Context.CurrentVehicleContext.ReadVehicleOrderPure, gefolgt von einem Aufruf von Isom.Context.CurrentVehicleContext.ReadVehicleOrderAdditionals
Rückgabe:
Isom.Base.Boolean
true, falls die Fahrzeugmerkmale erfolgreich ermittelt wurden false sonst.
Achtung:
Mit der Hauptversion 1.21 wurde eingeführt, dass vom Serviceautor mittels Isom.Context.CurrentVehicleContext.SetVehicleOrder vorgegebene Fahrzeugmerkmale im ISOM-Objektmodell nicht mehr überschrieben werden, wenn mit Isom.Context.CurrentVehicleContext.ReadVehicleOrder die Fahrzeugmerkmale aus dem Fahrzeug gelesenen werden. Um die Daten aus dem Fahrzeug zu übernehmen, muss der Serviceautor seine Vorgabe zuvor mit Isom.Context.CurrentVehicleContext.SetVehicleOrder(VehicleOrder.Void()) ausdrücklich zurücknehmen.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Sonderprozess nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 23.10.2012
[Isom\Context\CurrentVehicleContext.is: 1092]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.ReadVehicleOrderAdditionals ( )

Vervollständigt vom Fahrzeug gelesene Fahrzeugmerkmale mit Zusatzinformationen

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um Zusatzinformationen zu den Fahrzeugmerkmalen zu ermitteln. Bei erfolgreicher Ausführung wird das Ergebnis in das Datenmodell übernommen.

Zu beachten:
Die Fahrzeugmerkmale können mit einem Aufruf von Isom.Context.CurrentVehicleContext.ReadVehicleOrderPure vom Fahrzeug ausgelesen werden.
Achtung:
Mit der Hauptversion 1.21 wurde eingeführt, dass vom Serviceautor mittels Isom.Context.CurrentVehicleContext.SetVehicleOrder vorgegebene Fahrzeugmerkmale im ISOM-Objektmodell nicht mehr überschrieben werden, wenn mit Isom.Context.CurrentVehicleContext.ReadVehicleOrderAdditionals die Fahrzeugmerkmale aus dem Fahrzeug gelesenen werden. Um die Daten aus dem Fahrzeug zu übernehmen, muss der Serviceautor seine Vorgabe zuvor mit Isom.Context.CurrentVehicleContext.SetVehicleOrder(VehicleOrder.Void()) ausdrücklich zurücknehmen.
Rückgabe:
Isom.Base.Boolean
true, falls die Fahrzeugmerkmale erfolgreich vervollständigt wurden false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 23.10.2012
[Isom\Context\CurrentVehicleContext.is: 1171]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.ReadVehicleOrderPure ( )

Ermittelt die Fahrzeugmerkmale, wie sie vom Fahrzeug geliefert werden.

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um die Fahrzeugmerkmale zu ermitteln. Es werden nacheinander alle Steuergeräte, die Isom.Context.ContextConfiguration.GetVehicleOrderEcus() liefert, nach den Fahrzeugmerkmalen befragt. Das erste erfolgreich abgefragte Ergebnis wird in das Datenmodell übernommen.

Zu beachten:
Die ermittelten Fahrzeugmerkmale können mit einem Aufruf von Isom.Context.CurrentVehicleContext.ReadVehicleOrderAdditionals mit zusätzlichen Informationen vervollständigt werden.
Achtung:
Mit der Hauptversion 1.21 wurde eingeführt, dass vom Serviceautor mittels Isom.Context.CurrentVehicleContext.SetVehicleOrder vorgegebene Fahrzeugmerkmale im ISOM-Objektmodell nicht mehr überschrieben werden, wenn mit Isom.Context.CurrentVehicleContext.ReadVehicleOrderPure die Fahrzeugmerkmale aus dem Fahrzeug gelesenen werden. Um die Daten aus dem Fahrzeug zu übernehmen, muss der Serviceautor seine Vorgabe zuvor mit Isom.Context.CurrentVehicleContext.SetVehicleOrder(VehicleOrder.Void()) ausdrücklich zurücknehmen.
Rückgabe:
Isom.Base.Boolean
true, falls die Fahrzeugmerkmale erfolgreich ermittelt wurden false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 23.10.2012
[Isom\Context\CurrentVehicleContext.is: 1133]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.ReadVersions ( )

Ermittlung der Integrationsstände des Fahrzeugs.

Ein Integrationsstand versioniert alle im Fahrzeug verbauten Steuergeräte eindeutig. Dabei handelt es sich üblicherweise um eine Versionsinformation, die einen festgelegten Stand von Hard- und Softwareeinheiten für Steuergeräte benennt. Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um den aktuellen Softwarestand, den Softwarestand beim Bau des Fahrzeugs und den Softwarestand vor der letzten Aktualisierung des Fahrzeugs zu ermitteln. Die ermittelten Werte werden bei erfolgreicher Ausführung in das Datenmodell übernommen.

Achtung:
Mit der Hauptversion 1.21 wurde eingeführt, dass vom Serviceautor mittels Isom.Context.CurrentVehicleContext.SetCurrentVersion, Isom.Context.CurrentVehicleContext.SetBuildVersion oder Isom.Context.CurrentVehicleContext.SetHistoricalVersion vorgegebene Versionsinformationen im ISOM-Objektmodell nicht mehr überschrieben werden, wenn mit Isom.Context.CurrentVehicleContext.ReadVersions die Versionsinformationen aus dem Fahrzeug gelesenen werden. Um die Daten aus dem Fahrzeug zu übernehmen, muss der Serviceautor seine Vorgabe zuvor mit ausdrücklich zurücknehmen, indem er die entsprechende Set-Funktion mit String.Void als Parameter aufruft.
Rückgabe:
Isom.Base.Boolean
true wenn die Integrationsstände erfolgreich ermittelt wurden
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 23.10.2012
[Isom\Context\CurrentVehicleContext.is: 1210]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.ReadVin ( )

Ermittelt die Fahrgestellnummer

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um die Fahrgestellnummer aus dem Fahrzeug zu ermitteln. Es werden nacheinander alle Steuergeräte, die Isom.Context.ContextConfiguration.GetVinEcus() liefert, nach der Fahrgestellnummer befragt. Das erste erfolgreich abgefragte Ergebnis wird in das Datenmodell übernommen.

Rückgabe:
Isom.Base.Boolean
true, falls der gezeigte Wegstreckenzähler erfolgreich ermittelt werden konnte,
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1266]
objectbound Isom.Base.StringDictionary Isom.Context.CurrentVehicleContext.RunProcess | ( | Isom.Base.String | processName,
 |  | Isom.Base.StringDictionary | arguments
 | ) |  |

Führt eine benannte OEM-Funktion aus.

Steuergeräte mit besonderen Funktionsmerkmalen werden in der Fahrzeugbeschreibung mit 'SpecialFunction' modelliert. Die unterstützten OEM-Funktionen werden in diesen Elementen als 'Function' aufgeführt. Die Ausführung der OEM-Funktion erfolgt über den angebundenen Fachdienst zur Fahrzeugkommunikation.

Parameter:
processName | Name der OEM-Funktion.
arguments | Ausführungsparameter.
Rückgabe:
Isom.Base.StringDictionary
Ein prozessspezifisches Wörterbuch der Ausführungsergebnisse.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die OEM-Funktion nicht implementiert ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011 (23.10.2012)
[Isom\Context\CurrentVehicleContext.is: 929]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.SetBuildVersion ( Isom.Base.String version )

Setzt den Integrationsstand bei Bau des Fahrzeugs.

Ein Integrationsstand versioniert alle im Fahrzeug verbauten Steuergeräte eindeutig. Dabei handelt es sich üblicherweise um eine Versionsinformation, die einen festgelegten Stand von Hard- und Softwareeinheiten für Steuergeräte benennt.

Parameter:
version Zu setzender Integrationsstand.
Rückgabe:
Isom.Base.Boolean
true, falls der Integrationstand erfolgreich gesetzt wurde false sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 454]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.SetCurrentVersion ( Isom.Base.String version )

Setzt den aktuellen Integrationsstand des Fahrzeugs.

Ein Integrationsstand versioniert alle im Fahrzeug verbauten Steuergeräte eindeutig. Dabei handelt es sich üblicherweise um eine Versionsinformation, die einen festgelegten Stand von Hard- und Softwareeinheiten für Steuergeräte benennt.

Parameter:
version Zu setzender Integrationsstand.
Rückgabe:
Isom.Base.Boolean
true, falls der Integrationstand erfolgreich gesetzt wurde false sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 404]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.SetDisplayProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt eine Anzeigeeigenschaft

Anzeigeeigenschaften erlauben es, den in dieser Fachklasse angebotenen Satz an Eigenschaften durch herstellerspezifische Eigenschaften zu erweitern. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Zu beachten:
Im Vergleich zu Isom.Context.CurrentVehicleContext.SetProp() eignet sich diese Funktion für Eigenschaftswerte, die lokalisiert werden.
Parameter:
propName | Eigenschaftsname
propValue | Neuer Wert der Eigenschaft
Rückgabe:
Isom.Base.Boolean
Immer true.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\CurrentVehicleContext.is: 1655]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.SetEcus ( Isom.Context.EcuList newList )

Setzt die Steuergeräteliste.

Die Funktion setzt die Liste der Steuergeräte, die im Fahrzeug verbaut sind.

Verwendungsbeispiel:
Der folgende Quelltext zeigt eine einfache Implementierung des Einsprungspunkts UpdateCurrentContextEcus, die die Steuergeräteliste so setzt, wie sie von der Fachfunktion Isom.Context.CurrentVehicleContext.GetExpectedEcus geliefert wird:
   Isom.Base.Boolean UpdateCurrentContextEcus() // Einsprungspunkt zur Ermittlung der verbauten Steuergeräte (Phase 4)
   {
     // Abfrage der Zugriffsinstanz
     Isom.Context.CurrentVehicleContext cctx = Isom.Context.CurrentVehicleContext.GetInstance();

     // Ermittlung der Steuergeräte durch den Fachdienst für Logistikinformationen
     Isom.Context.EcuList expected = cctx.GetExpectedEcus();
     if (expected.IsVoid())
     {
       // Erwartete Steuergeräte konnten nicht ermitteln werden
       return false;
     }

     // Übernahme der erwarteten Steuergeräte in den Istkontext
     cctx.SetEcus(expected);

     return true;
   }
Parameter:
newList Liste der Steuergeräte.
Rückgabe:
Isom.Base.Boolean
Immer true.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 308]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.SetHistoricalVersion ( Isom.Base.String version )

Setzt den Integrationsstand vor der letzten Aktualisierung.

Ein Integrationsstand versioniert alle im Fahrzeug verbauten Steuergeräte eindeutig. Dabei handelt es sich üblicherweise um eine Versionsinformation, die einen festgelegten Stand von Hard- und Softwareeinheiten für Steuergeräte benennt.

Parameter:
version Zu setzender Integrationsstand.
Rückgabe:
Isom.Base.Boolean
true, falls der Integrationstand erfolgreich gesetzt wurde false sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 503]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.SetOdometer | ( | Isom.Base.String | newOdoValue,
 |  | Isom.Base.String | newOdoUnit
 | ) |  |

Setzt Wert und Maßeinheit des Wegstreckenzählers im Datenmodell.

Achtung:
Der Wert kann nicht ins Fahrzeug geschrieben werden.
Parameter:
newOdoValue | neuer Wert des Wegstreckenzählers
newOdoUnit | neue Maßeinheit des Wegstreckenzählers
Rückgabe:
Isom.Base.Boolean
true, falls Wert und Maßeinheit erfolgreich gesetzt wurde false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebenen Werte nicht gesetzt werden konnten.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 676]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.SetProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt eine technische Eigenschaft

Eigenschaften erlauben es, den in dieser Fachklasse angebotenen Satz an Eigenschaften durch herstellerspezifische Eigenschaften zu erweitern. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Zu beachten:
Im Vergleich zu Isom.Context.CurrentVehicleContext.SetDisplayProp() eignet sich diese Funktion nur für Eigenschaftswerte, die nicht lokalisiert werden.
Parameter:
propName | Eigenschaftsname
propValue | Eigenschaftswert
Rückgabe:
Isom.Base.Bool'true'> Immer true.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\CurrentVehicleContext.is: 1595]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.SetVehicleGeneration ( Isom.Base.String vehicleGeneration )

Setzt die Fahrzeuggeneration im Datenmodell.

Die Fahrzeuggeneration wird üblicherweise bereits beim Festlegen der Baureihe oder der Baureihengruppe mit Isom.Context.ContextConfiguration.SetModelSeries bzw. Isom.Context.ContextConfiguration.SetModelSeriesGroup anhand der Fahrzeugbeschreibung automatisch festgelegt.

Parameter:
vehicleGeneration Zu setzende Fahrzeuggeneration.
Rückgabe:
Isom.Base.Boolean
true, falls die Fahrzeuggeneration erfolgreich gesetzt wurde false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebene Fahrzeuggeneration gesetzt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 819]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.SetVehicleOrder ( Isom.Context.VehicleOrder vo )

Setzt die Fahrzeugmerkmale.

Diese Funktion setzt die Fahrzeugmerkmale im Modell, aber nimmt keinen Abgleich mit dem Fahrzeug vor.

Parameter:
vo Repräsentation der Fahrzeugmerkmale
Rückgabe:
Isom.Base.Boolean
true nach erfolgreicher Übernahme in das Datenmodell, false sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 724]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.SetVin17 ( Isom.Base.String vin17 )

Setzt die Fahrgestellnummer im Datenmodell.

Achtung:
Der Wert kann nicht ins Fahrzeug geschrieben werden.
Parameter:
vin17 Zu setzende Fahrgestellnummer.
Rückgabe:
Isom.Base.Boolean
true, falls die Fahrgestellnummer erfolgreich gesetzt wurde false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebene Fahrgestellnummer gesetzt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 747]
objectbound Isom.Base.Boolean Isom.Context.CurrentVehicleContext.UserProfileChanged ( )

Prüft, ob das Benutzerprofil im Sollkontext Änderungen gegenüber dem Istkontext enthält.

Die Funktion vergleicht das im Isom.Context.FutureVehicleContext geführte Benutzerprofil mit Benutzerprofil aus dem Istkontext Isom.Context.CurrentVehicleContext.

Rückgabe:
Isom.Base.Boolean
true, falls das Benutzerprofil geändert wurde false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Benutzerprofil nicht geschrieben werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 07.07.2011
[Isom\Context\CurrentVehicleContext.is: 1466]
Isom.Context.CurrentVehicleContext Isom.Context.CurrentVehicleContext.Void ( )

Erzeugt ein Void-Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Isom.Context.CurrentVehicleContext
Die Funktion liefert immer ein Void-Objekt.
Ausnahmebehandlung:
Void wird von dieser Funktion immer geliefert.
Datum:
letzte Änderung am 04.07.2011
[Isom\Context\CurrentVehicleContext.is: 1825]


für Serviceautoren

Isom.Context.Dtc

Namensraum Isom.Context.Dtc

Fachobjekt für einen Fehlerspeichereintrag Mehr...

Funktionen
Erzeugung von / Zugriff auf Objektinstanzen

Namensraum-gebundene Funktionen zum Zugriff auf Objektinstanzen

Isom.Context.Dtc | CreateByDtcNumber(Isom.Context.Ecu ecu, Isom.Base.String number)

Erzeugt ein Fachobjekt für einen Fehlerspeichereintrag mit dem vorgegebenen, eindeutigen Schlüsselwert.

Isom.Context.DtcList | GetPossibleDtc()

Liefert eine Liste von Fachobjekten, die alle in den Diagnoseservicedaten modellierten, potentell möglichen Fehlerspeichereinträge enthält.

Fachfunktionen mit Fahrzeugzugriff

Fachfunktionen mit Fahrzeugzugriff

Isom.Base.Boolean | Clear()

Löscht den vorgegebenen, einzelnen Fehlerspeichereintrag aus dem Fahrzeug.

Isom.Base.Boolean | ReadDetails()

Liest Details zu dem vorgegebenen, einzelnen Fehlerspeichereintrag aus dem Fahrzeug.

Zugriff auf identifizierende Attribute für Fehlercodes

Liefert oder setzt die identifizierende Zeichenkettenrepräsentationen für Fehlercodes.

Isom.Base.String | GetDtcNumber()

Liefert die 5-stellige Repräsentation eines Fehlercodes im standardisierten Format entsprechend ISO 15031-6 (beispielsweise "P2628") oder einen OEM-spezifischen, eindeutigen Identifikator (beispielsweise "0x000001")

Isom.Base.Boolean | SetDtcNumber(Isom.Base.String newVal)

Setzt die 5-stellige Repräsentation eines Fehlercodes im standardisierten Format entsprechend ISO 15031-6 (beispielsweise "P2628") oder einen OEM-spezifischen, eindeutigen Identifikator (beispielsweise "0x000001")

Low-Level API für standardiserte Fehlercodes

Zugriff auf Bestandteile eines standardiserten Fehlercodes
(auch verwendbar, wenn Diagnoseservicedaten nicht verfügbar sind)

Isom.Base.String | GetAreaOfVehicleSystemForDtcNumber()

Liefert den Systembereich eines Fehlercodes im standardisierten Format als englische Wortfolge entsprechend ISO 15031-6, soweit dem Fehlercode in der Norm ein solcher zugeodnet ist (typischerweise bei Systemkategorie "POWERTRAIN")

Isom.Base.String | GetStandardisationForDtcNumber()

Liefert die Standardisierungskategorie eines Fehlercodes im standardisierten Format als englische Wortfolge entsprechend ISO 15031-6.

Isom.Base.String | GetSystemCategoryForDtcNumber()

Liefert die Systemkategorie (auch: Bereich) eines Fehlercodes im standardisierten Format als englisches Wort entsprechend ISO 15031-6.

Assoziationen zu anderen Fachobjekten

Zugriff auf andere Fachobjekte, die mit dem Fehlerspeichereintrag in Zusammenhang stehen

Isom.Context.EcuList | GetEcus()

Liefert die Steuergeräte-Fachobjekte, auf die sich der Fehlerocde bezieht.

Zugriff auf Eigenschaftswerte

Auf Eigenschaftswerte (properties) von Fehlerspeichereinträgen kann in gleicher Weise wie bei Verwendung von Isom.Base.StringDictionary zugegriffen werden.

Isom.Base.Boolean | Add(Isom.Base.String key, Isom.Base.String value)

Setzt einen DTC-Eigenschaftswert.

Isom.Base.Number | Count()

Ermittlelt die Anzahl der gesetzten Eigenschaftswerte (Schlüssel).

Isom.Base.String | Get(Isom.Base.String key)

Sucht einen im ISOM-Objektmodell gesetzten Dtc-Eigenschaftswert für einen vorgegebenen Schlüssel.

Isom.Base.StringList | GetKeys()

Ermittlelt die Liste der Schlüssel aller gesetzten DTC-Eigenschaftswerte.

Strukturierter Zugriff auf ausgewählte Fehlerspeicherinformationen

(beispielsweise Umgebungsbedingungen als Messwerte, Zeitbezüge)

Isom.Diagnostics.MeasurementList | GetFreezeFrameConditions()

Liefert Umweltbedingungen, die zum Zeitpunkt des Auttretens des Fehlers vorgelegen haben.

Voraussetzung ist ein vorherigen Detail-Lesen des Fehlerspeichereintrags.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Context.Dtc | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Ermittelt, ob es sich um das Void-Objekt handelt.

Isom.Context.Dtc | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Ein Fachobjekt vom Typ Isom.context.Dtc beschreibt einen einzelnen Fehlerspeichereintrag im Fahrzeug. Ein Fehlerspeichereintrag protokolliert ein diagnoserelevantes Symptom, welches vom Steuergerät während der Betriebsphase des Fahrzeugs erkannt und im nichtflüchtigen Fehlerspeicher eines oder mehrerer Steuergeräte gespeichert wurde. Die Symptome können erkannte Fehlerzustände im engeren Sinne sein, aber auch Beobachtungen umfassen, die lediglich auf mögliche Fehlerursachen hindeuten und die Diagnose unterstützen.

ISOM-Objektmodell für Fehlercodes

Ein Fehlerspeichereintrag wird in ISOM durch einen eindeutigen Schlüsselwert identifiziert. Auf den Wert kann den über den Fachfunktionsaufruf Isom.Context.Dtc.Get("DtcCode") zugegriffen werden kann. Der Ergebniswert ist entweder ein 5-stelliger standardkonformer Fehlercode (s.u.) oder eine Zeichenkette in einem anderen, OEM-spezifischen Format.

Darüber hinaus werden im ISOM-Objektmodell Informationen darüber gespeichert, wann und unter welchen Bedingungen das Symptom aufgetreten ist und wie der Fehler klassifiziert wird. Umfang und Systematik dieser Informationen sind vom jeweiligen Fahrzeug-Fachdienst und den Diagnoseservicedaten abhängig.
Hinweis: Der Fachdienst ist im ISOM-Fahrzeugmodell der aktuellen Baureihe konfiguriert.

Low-Level API für standardkonforme Fehlercodes

Für OEM-übergreifend standardisierte, 5-stellige Fehlercodes nach dem Standard ISO 15031-6 liefert ISOM über die sogenannte Low-Level API eine einheitliche Interpretation.

Fachfunktionen und Inhalte der Low-Level-API

Folgende Informationen werden für standardisierte, 5-stellige Fehlercodes über Fachfunktionen verfügbar gemacht:

  • Die Fachfunktionen GetDtcNumber() bzw. SetDtcNumber()
    greifen auf den 5-stelligen Standard-Fehlercode zu.
  • Die Fachfunktion GetSystemCategoryForDtcNumber()
    liefert die Systemkategorie (auch: Bereich),
    z.B. "CHASSIS" für Fahrwerk-bezogene Fehlercodes.
  • Die Fachfunktion GetStandardisationForDtcNumber()
    klassifiziert die Standardisierungskategorie,
    d.h. sie beschreibt, wer den Fehlercode definiert hat.
  • Die Fachfunktion GetAreaOfVehicleSystemForDtcNumber()
    liefert für den Systembereich von Antriebsstrang-bezogenen Fehlercodes,
    z.B. "FUEL" für Fehlercodes im Zusammenhang mit dem Einspritzsystem/Kraftstoffsystem.
  • Das allgemeine Namensschema für die Fachfunktionen der Low-Level API ist Get...ForDtcNumber().

ISOM implementiert die folgende Interpretation eines 16-Bit-Fehlercodes gemäß ISO-15031-6:

Diagnoseservicedaten

Inhalt der Diagnoseservicedaten

Mithilfe der Diagnoseservicedaten und der Technologiekomponente ASTERION werden Fehlerspeichereinträge automatisch mit weiteren, diagnoserelevanten Zusatzinformationen angereichert. Zu diesen Zusatzinformationen zählen:

  • Anzeigetexte für Fehlerspeichereinträge
  • Klassifizierungen des Fehlers nach betroffener Systemkomponente
    (z.B. Fahrwerk, Elektrik)
  • Klassifizierungen des Fehlers nach Fehlerart
    (z.B. Spannung zu niedrig, Wert ausserhalb Bereich, ...)
  • Thesauren für die Begriffsbeziehungen der Hierarchischen Suche

Ablage der Diagnoseservicedaten

Diagnoseservicedaten sind unter dem folgenden Pfad im Integrationsprodukt Argonaut abzulegen:

     <Argonaut>/<OEM>/Services/data/Diagnostics</code>

Referenzdokumentation

Eigenschaftsnamen

Von ISOM werden folgende Eigenschaften aus dem Fahrzeug ausgelesen und sind von Serviceautor abfragbar:

Eigenschaftsname | Beschreibung
DtcCode | eindeutiger Schlüsselwert für den Fehlerspeichereintrag
Memory | Speicher im Steuergerät, aus dem der Fehlerspeichereintrag gelesen wurde
IsStored | Gibt an, ob der Fehlercode bereits permanent im Steuergerät gespeichert ist
IsPresent | Gibt an, ob der Fehlercode aktuell im Steuergerät vorhanden ist (d.h. erkannt wurde)
FailureMode | Klassifiziert den Typ des Fehlers
TestHistory | Beschreibt die Vorgeschichte der Fehlererkennung bzw. der Vorbedingungen (z.B. letzter Fahrzyklus, aktueller Fahrzyklus, ...)
MalfunctionIndicatorLamp | Gibt an, ob für den Fehlerspeichereintrag aktuell eine Warnlampe (MIL) leuchten sollte
DiagnosticProtocols | Benennt Diagnoseprotokolle, über welche der Fehlerspeichereintrag aus dem Steuergerät gelesen wurde
DtcStatus.Hex | Fachdienst-abhängiger Statuswert des Fehlerspeichereintrags. Wird nur intern verwendet, um Emulationen zu erstellen.

Folgende Eigenschaften werden üblicherweise in den Diagnoseservicedaten gepflegt und stehen dem Serviceautor dadurch zur Verfügung:

Eigenschaftsname | Beschreibung
SystemsOrComponents | vom Fehler betroffene Systemkomponente(n), z.B. entprechend Thesaurus zu ISO-15031-6

Folgende Eigenschaftsnamen können in den Diagnoseservicedaten verwendet werden, um die Gültigkeit eines Fehlerspeichereintrags auf ein einzelnes Steuergerät einzuschränken:

Eigenschaftsname | Beschreibung
EcuAddress | Dezimale Diagnoseadresse des Steuergeräts
EcuVariant | Variante des Steuergeräts
Diese Eigenschaften werden nach erfolgter Suche in den Diagnoseservicedaten aus dem Datenmodell des Fehlerspeichereintrags entfernt und stehen dem Autor danach nicht zur Verfügung.

Typische Formate für die gelieferten Zeichenketten werden unten beschrieben.

Die vom Fehlerspeichereintrag betroffenen Steuergeräte können mittels der Fachfunktion Isom.Context.Dtc.GetEcus() abgefragt werden.

Weitere Eigenschaftsnamen können frei vom Serviceautor, dem Fahrzeug-Fachdienst oder in den Diagnoseservicedaten definiert werden. Die Namen der in Abhangigkeit von Fachdienst und von den Diagnoseservicedaten abfragbaren Eigenschaftswerte sind in der herstellerspezifischen Begleitdokumentation dokumentiert.

Werte und Formate von Dtc-Eigenschaften

Die folgenden Werte bzw. Formate können in den Eigenschaftswerten OEM-übergreifend auftreten:

Eigenschaftsname | Format | Beispiel | Beschreibung
DtcCode | Regex([PCBUpcbu][0-3][0-F][0-F]{2}) | "P2628" | 5-stelliger standardkonformer Fehlercode
 | alle anderen Zeichenketten-Formate | "0x0023" | OEM-abhängige Fehlerspeichereinträge
Memory | Primary |  | 5-stelliger standardkonformer Fehlercode
 | alle anderen Zeichenketten-Formate | "Shadow" | OEM-abhängige Fehlerspeichereinträge
DiagnosticProtocols | "KWP-2000" |  | Fehlerspeichereintrag wurde über KWP-2000-Diagnoseprotokoll ausgelesen
 | "UDS" |  | Fehlerspeichereintrag wurde über UDS-Diagnoseprotokoll ausgelesen
MalfunctionIndicatorLamp | "true" |  | Warnanzeige (MIL) wird angesteuert und müsste leuchten
 | "false" |  | Mit dem Fehlercode ist eine Warnanzeige (MIL) assoziiert, diese wird jedoch nicht angesteuert und darf nicht leuchten, weil der Fehler aktuell nicht vorliegt (vgl. IsPresent)
 | Void/ungesetzt |  | Mit dem Fehlercode ist keine Warnanzeige (MIL) assoziiert, oder es liegt keine Information über eine solche Assoziation vor.
IsStored | "true" |  | Fehlerspeichereintrag permanent im Steuergerät gespeichert
 | "false" |  | Fehlerspeichereintrag noch nicht permanent im Steuergerät gespeichert
IsPresent | "true" |  | Fehler liegt aktuell vor
 | "false" |  | Fehler liegt aktuell nicht vor
FailureMode | Text entsprechend Thesaurus | "Kurzschluss" | ausführliche Beschreibung ggf. im Thesaurus
 | Void/ungesetzt |  | Klassifikation konnte nicht ermittelt werden

Querverweise und Referenzen

Siehe auch:
Isom.Context.DtcList für den zugehörigen Listentyp.

Literatur

  • ISO 15031-6:2010 "Road vehicles -- Communication between vehicle and external equipment for emissions-related diagnostics -- Part 6: Diagnostic trouble code definitions"

Dokumenteninformation

Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 21.12.2010

Quelldateien:

  • Isom\Context\Dtc.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Context.Dtc.Add | ( | Isom.Base.String | key,
 |  | Isom.Base.String | value
 | ) |  |

Setzt einen DTC-Eigenschaftswert.

Zu beachten:
Ein vorher mit dem Schlüssel geschriebener Eintrag wird dabei überschrieben.
Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit vorgegebenem Fehlercode
  // (hier: ein standardkonformer Fehlercode "P2628" )
 Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber(Isom.Context.Ecu.Void(), "P2628");

 // Setzen/Überschreiben von Dtc-Eigenschaften
 dtc.Add( "A", "1");
Parameter:
key | Schlüssel des Eigenschaftswerts
value | Wert des Eigenschaftswerts
Rückgabe:
Isom.Base.Boolean
immer true
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 900]
objectbound Isom.Base.Boolean Isom.Context.Dtc.Clear ( )

Löscht den vorgegebenen, einzelnen Fehlerspeichereintrag aus dem Fahrzeug.

Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit den Vorgabeinformationen für das Löschen
  Isom.Context.Ecu ecu = Isom.Context.Ecu.Void(); // keinen SG-Bezug vorgeben
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber( ecu, "P2628" );

  // verwenden des Fachobjekts, um einen Fehlerspeichereintrag
  //  unter Verwendung logischer Adressierung zu löschen
  //  (nicht von allen Fachdiensten unterstützt)
  dtc.Clear();
  // zurücklesen nichtlöschbarer Fehlerspeichereinträge
  dtc.ReadDetails();
  // Auswertung nichtlöschbarer Fehlerspeichereinträge
  if( dtc.Get( "IsStored" ).Equals( "true" ) )
  {
      // Fehlerocde "P2628" konnte nicht gelöscht werden.
  }
Rückgabe:
Isom.Base.Boolean
true nach erfolgreichem Löschen, false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Operation vom konfigurierten Fahrzeug-Fachdienst nicht unterstützt wird.
Zu beachten:
Das Löschen einzelner Fehlerspeichereinträge wird u.U. nicht von allen Fahrzeug-Fachdiensten unterstützt. In diesem Falle wird Void zurückgegeben.
Siehe auch:
Isom.Context.Ecu.ClearDtc() für physikalisch adressiertes Löschen von Fehlerspeichereinträgen.
Isom.Context.CurrentVehicleContext.ClearDtcInAllEcus() für funktional adressiertes/sequentielles Löschen von Fehlerspeichereinträgen.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 506]
objectbound Isom.Context.Dtc Isom.Context.Dtc.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit vorgegebenem Fehlercode
  // (hier: ein standardkonformer Fehlercode "P2628" )
  Isom.Context.Dtc dtc1 = Isom.Context.Dtc.CreateByDtcNumber(Isom.Context.Ecu.Void(), "P2628");

  // Clonen
  Isom.Context.Dtc dtc2 = dtc1.Clone();

  // Setzen/Überschreiben von Dtc-Eigenschaften in erster Instanz
  dtc1.Add( "A", "1" );

  // Leseversuch in zweiter Instanz
  Isom.Base.String t = dtc2.Get( "A" );
  //  t ist das Void-Objekt
Rückgabe:
Isom.Context.Dtc
Das geklonte Objekt.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 1076]
objectbound Isom.Base.Number Isom.Context.Dtc.Count ( )

Ermittlelt die Anzahl der gesetzten Eigenschaftswerte (Schlüssel).

Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit vorgegebenem Fehlercode
  // (hier: ein standardkonformer Fehlercode "P2628" )
  Isom.Context.Ecu ecu = Isom.Context.Ecu.Void(); // keinen SG-Bezug vorgeben
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber(ecu, "P2628");

  //Zugriff auf den Zähler der Dtc-Eigenschaften
  Isom.Base.Number n = dtc.Count();
  //  n ist z.B. 1
Rückgabe:
Isom.Base.Number
Größe des Wörterbuchs.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 828]
Isom.Context.Dtc Isom.Context.Dtc.CreateByDtcNumber | ( | Isom.Context.Ecu | ecu,
 |  | Isom.Base.String | number
 | ) |  |

Erzeugt ein Fachobjekt für einen Fehlerspeichereintrag mit dem vorgegebenen, eindeutigen Schlüsselwert.

Verwendungsbeispiel:
  // Fachobjekt erzeugen
  Isom.Context.Ecu ecu = Isom.Context.Ecu.Void(); // keinen SG-Bezug vorgeben
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber( ecu, "P2628" );

  // Fachobjekt verwenden (hier: Zugriff auf Diagnoseservicedaten)
  Isom.Base.String soc = dtc.Get( "SystemsOrComponents" );
  //  soc ist z.B. "2O2 Sensor Pumping Current Trim"
  Isom.Base.String fmd = dtc.Get( "FailureMode" );
  //  fmd ist z.B. "Circuit High"
Rückgabe:
Isom.Context.Dtc
Fachobjekt für einen Fehlerspeichereintrag.
Nachbedingung:
Das gelieferte Fachobjekt ist mithilfe der ASTERION-Diagnoseservicedaten und bei standardkonformen Fehlercodes zusätzlich anhand der Low-Level API vervollständigt.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 363]
objectbound Isom.Base.String Isom.Context.Dtc.Get ( Isom.Base.String key )

Sucht einen im ISOM-Objektmodell gesetzten Dtc-Eigenschaftswert für einen vorgegebenen Schlüssel.

Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit vorgegebenem Fehlercode
  // (hier: ein standardkonformer Fehlercode "P2628" )
 Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber(Isom.Context.Ecu.Void(), "P2628");

 // Setzen/Überschreiben von Dtc-Eigenschaften
 dtc.Add( "A", "1" );

 // Lesen gesetzter bzw. ungesetzter Eigenschaften
 Isom.Base.String s = dtc.Get( "A" );
 //  s ist "1"
 Isom.Base.String t = dtc.Get( "B" );
 //  t ist das Void-Objekt
Parameter:
key Schlüssel des gesuchten Eintrags
Rückgabe:
Isom.Base.String
Wert des Eintrags zum vorgegebenen Schlüssel.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls für den Schlüssel kein Wert gesetzt ist.
Siehe auch:
Referenzdokumentation Referenzdokumentation für Schlüsslnamen, und mögliche Ergebnisformate.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 867]
objectbound Isom.Base.String Isom.Context.Dtc.GetAreaOfVehicleSystemForDtcNumber ( )

Liefert den Systembereich eines Fehlercodes im standardisierten Format als englische Wortfolge entsprechend ISO 15031-6, soweit dem Fehlercode in der Norm ein solcher zugeodnet ist (typischerweise bei Systemkategorie "POWERTRAIN")

Zu beachten:
Diese Fachfunktion ist Teil der Low-Level API für Fehlerspeichereinträge in ISOM und funktioniert nur für standardkonforme, 5-stellige Fehlercodes.
(Quelle: ISO 15031-6: Anzeigezeichen 2)
Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit vorgegebenem Fehlercode
  // (Voraussetzung: ein standardkonformer Fehlercode)
  Isom.Context.Ecu ecu = Isom.Context.Ecu.Void(); // keinen SG-Bezug vorgeben
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber( ecu, "P2628" );

  // Zugriff auf Interpretationsergebnisse über Low-Level-API
  Isom.Base.String dtcAVS = dtc.GetAreaOfVehicleSystemForDtcNumber();
  //  dtcAVS ist z.B. "ECU"
Rückgabe:
Isom.Base.String
"AIR" = Einspritzsystem/Sekundärluft/Gemischaufbereitung
"FUEL" = Einspritzsystem/Kraftstoffsystem
"IGNITION" = Zündung
"EMISSION_RELATED" = Abgasrückführung und andere Hilfskomponenten zur Emissionsüberwachung
"VELOCITY" = Fahrgeschwindigkeits-und Leerlaufregelung
"ECU" = steuergeräteinterne Fehler
"GEAR" = Getriebe
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 731]
objectbound Isom.Base.String Isom.Context.Dtc.GetDtcNumber ( )

Liefert die 5-stellige Repräsentation eines Fehlercodes im standardisierten Format entsprechend ISO 15031-6 (beispielsweise "P2628") oder einen OEM-spezifischen, eindeutigen Identifikator (beispielsweise "0x000001")

Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit vorgegebenem Fehlercode
  // (hier: ein standardkonformer Fehlercode "P2628" )
  Isom.Context.Ecu ecu = Isom.Context.Ecu.Void(); // keinen SG-Bezug vorgeben
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber( ecu, "P2628" );

  // zurücklesen des bei Erzeugung vorgegebenen Fehlercodes
  Isom.Base.String dtcNumber = dtc.GetDtcNumber();
  //  dtcNumber ist "P2628"
Rückgabe:
Isom.Base.String
5-stellige Repräsentation eines Fehlercodes oder OEM-spezifischer, eindeutiger Identifikator
Siehe auch:
Isom.Context.Dtc.SetDtcNumber()
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 552]
objectbound Isom.Context.EcuList Isom.Context.Dtc.GetEcus ( )

Liefert die Steuergeräte-Fachobjekte, auf die sich der Fehlerocde bezieht.

Die Ergebnisliste beinhaltet alle Steuergeräte, bei denen diese Fehlercodes aufgetreten sind bzw. die für diesen Fehlercode in der Diagnosebedatung modelliert ist.

Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit vorgegebenem Fehlercode
  // (hier: ein standardkonformer Fehlercode "P2628" )
  Isom.Context.Ecu ecu = Isom.Context.Ecu.Void(); // keinen SG-Bezug vorgeben
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber( ecu, "P2628" );

  // Ermitteln der Steuergeräte, die in den Diagnoseservicedaten
  //  mit diesem Fehlerspeichereintrag assoziiert sind
  Isom.Context.Dtc dtcEcus = dtc.GetEcus();

  // Iteration über die Ergebnisliste
  dtcEcus.Reset();
  while( dtcEcus.HasNext() )
  {
      Isom.Context.Ecu dtcEcu = dtcEcus.Next();
      // Fehlerocde betrifft das Steuergerät dtcEcu
  }
Rückgabe:
Isom.Context.EcuList
Liste assoziierter Steuergeräte-Fachobjekte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 786]
objectbound Isom.Diagnostics.MeasurementList Isom.Context.Dtc.GetFreezeFrameConditions ( )

Liefert Umweltbedingungen, die zum Zeitpunkt des Auttretens des Fehlers vorgelegen haben.

Voraussetzung ist ein vorherigen Detail-Lesen des Fehlerspeichereintrags.

Verwendungsbeispiel:
  ...
  // Erzeugen eines DTC-Fachobjekts mit den Vorgabeinformationen für das Lesen
  Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("18");
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber( ecu, "P2628" );

  // Detail-Auslesen und Zugriff auf die Umweltbedingungen des FSE
  dtc.ReadDetails();
  Isom.Diagnostics.MeasurementList ml = dtc.GetFreezeFrameConditions();
  ml.Reset();
  while( ml.HasNext() )
  {
    Isom.Diagnostics.Measurement m = ml.Next (  );
    Isom.Base.String  mk = m.GetKey();          // z.B. "FreezeFrameConditions"
    m.Reset();
    while( ml.HasNext() )
    {
      Isom.Diagnostics.MeasuredValue mv = m.Next();

      Isom.Base.String mvKey = mv.GetKey();   // Ruft den Identifikator der aktuellen "MeasuredValue" ab.
      Isom.Base.String mvMax = mv.GetMax();   // Ruft den größtmöglichen Wert ab.
      Isom.Base.String mvMin = mv.GetMin();   // Ruft den kleinstmöglichen Wert ab.
      Isom.Base.String mvVal = mv.GetValue(); // Ruft den Anzeigetext der aktuellen "MeasuredValue" ab.
      Isom.Base.String mvUnt = mv.GetUnit();  // Ruft die Einheit der aktuellen "MeasuredValue" ab.
    }
  }
Rückgabe:
Isom.Base.StringList
Liste aller im Wörterbuch enthaltenen Schlüssel
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 02.02.2011
[Isom\Context\Dtc.is: 1000]
objectbound Isom.Base.StringList Isom.Context.Dtc.GetKeys ( )

Ermittlelt die Liste der Schlüssel aller gesetzten DTC-Eigenschaftswerte.

Durch Durchlaufen der Liste lassen sich alle Einträge des Wörterbücher abrufen.

Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit vorgegebenem Fehlercode
  // (hier: ein standardkonformer Fehlercode "P2628" )
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber(Isom.Context.Ecu.Void(), "P2628");

  // Ermitteln der Namen aller Dtc-Eigenschaften in diesem Fachobjekt
  Isom.Base.StringList keys = dtc.GetKeys();

  // Iteration über die Ergebnisliste
  keys.Reset();
  while( keys.HasNext() )
  {
    Isom.Base.String key = keys.Next();
    Isom.Base.String value = dtc.Get(key);
    ...
  }
Rückgabe:
Isom.Base.StringList
Liste aller im Wörterbuch enthaltenen Schlüssel
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 940]
Isom.Context.DtcList Isom.Context.Dtc.GetPossibleDtc ( )

Liefert eine Liste von Fachobjekten, die alle in den Diagnoseservicedaten modellierten, potentell möglichen Fehlerspeichereinträge enthält.

Bemerkungen:
Diese Liste kann als Basis für die systematische Suche nach Fehlern oder diagnoserelevanten Smyptomen dienen.
Verwendungsbeispiel:
  // alle in den Diagnoseservicedaten modellierten Fehlerspeichereinträge ermitteln
  Isom.Context.DtcList all = Dtc.GetPossibleDtc();

  // einschränken auf alle möglichen fahrwerksbezogenen Spannungsunterschreitungen
  Isom.Context.DtcList lowVoltageChassis
   = all.FilterByProp( "SystemsOrComponents", "chassis" )
         .FilterByProp( "FailureMode", "voltage low" );

  // davon nur die wirklich aufgetretenen, im SG permanent gespeicherten Einträge
  Isom.Context.DtcList storedLowVoltageChassis
   = lowVoltageChassis.FilterByProp( "IsStored", "true" );
Rückgabe:
Isom.Context.DtcList
Liste mögleicher Fehlerspeichereinträge.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 402]
objectbound Isom.Base.String Isom.Context.Dtc.GetStandardisationForDtcNumber ( )

Liefert die Standardisierungskategorie eines Fehlercodes im standardisierten Format als englische Wortfolge entsprechend ISO 15031-6.

Zu beachten:
Diese Fachfunktion ist Teil der Low-Level API für Fehlerspeichereinträge in ISOM und funktioniert nur für standardkonforme, 5-stellige Fehlercodes.
(Quelle: ISO 15031-6: Anzeigezeichen 2)
Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit vorgegebenem Fehlercode
  // (Voraussetzung: ein standardkonformer Fehlercode)
  Isom.Context.Ecu ecu = Isom.Context.Ecu.Void(); // keinen SG-Bezug vorgeben
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber( ecu, "P2628" );

  // Zugriff auf Interpretationsergebnisse über Low-Level-API
  Isom.Base.String dtcSTD = dtc.GetStandardisationForDtcNumber();
  //  dtcSTD ist "ISO_SAE_CONTROLLED"
Rückgabe:
Isom.Base.String
"ISO_SAE_CONTROLLED" = ISO-15031-6/SAE J2012
"OEM_CONTROLLED" = OEM-spezifisch
"SAE_RESERVED" = reserviert
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 687]
objectbound Isom.Base.String Isom.Context.Dtc.GetSystemCategoryForDtcNumber ( )

Liefert die Systemkategorie (auch: Bereich) eines Fehlercodes im standardisierten Format als englisches Wort entsprechend ISO 15031-6.

Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit vorgegebenem Fehlercode
  // (Voraussetzung: ein standardkonformer Fehlercode)
  Isom.Context.Ecu ecu = Isom.Context.Ecu.Void(); // keinen SG-Bezug vorgeben
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber( ecu, "P2628" );

  // Zugriff auf Interpretationsergebnisse über Low-Level-API
  Isom.Base.String dtcSC = dtc.GetSystemCategoryForDtcNumber();
  //  dtcSC ist "POWERTRAIN"
Zu beachten:
Diese Fachfunktion ist Teil der Low-Level API für Fehlerspeichereinträge in ISOM und funktioniert nur für standardkonforme, 5-stellige Fehlercodes.
(Quelle: ISO 15031-6: Anzeigezeichen 1)
Rückgabe:
Isom.Base.String
"POWERTRAIN" = Antriebsstrang
"CHASSIS" = Fahrwerk
"BODY" = Karosseriebereich
"NETWORK" = Datennetz/Bussystem
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 649]
objectbound Isom.Base.Boolean Isom.Context.Dtc.IsVoid ( )

Ermittelt, ob es sich um das Void-Objekt handelt.

Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit vorgegebenem Fehlercode
  // (hier: ein standardkonformer Fehlercode "P2628" )
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber(Isom.Context.Ecu.Void(), "P2628");

  // Prüfen auf Erfolg
  Isom.Base.Boolean created = dtc.IsVoid().Not();
Rückgabe:
Isom.Base.Boolean
'true', falls dies das Void-Objekt ist, 'false' sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 1041]
objectbound Isom.Base.Boolean Isom.Context.Dtc.ReadDetails ( )

Liest Details zu dem vorgegebenen, einzelnen Fehlerspeichereintrag aus dem Fahrzeug.

Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit den Vorgabeinformationen für das Lesen
  Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("18");
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber( ecu, "P2628" );

  // verwenden des Fachobjekts, um den Fehlerspeichereintrag
  //  unter Verwendung logischer Adressierung zu lesen
  //  (nicht von allen Fachdiensten unterstützt)
  dtc.ReadDetails();

  // prüfen, ob Fehlerspeichereintrag im Steuergerät gespeichert ist
  if( dtc.Get( "IsStored" ).Equals( "true" ) )
  {
      // Fehlerocde "P2628" ist im Fahrzeug permanent gespeichert.
  }
Rückgabe:
Isom.Base.Boolean
true nach erfolgreichem Lesen, false sonst.
Zu beachten:
Das selektive Lesen einzelner Fehlerspeichereinträge wird u.U. nicht von allen Fahrzeug-Fachdiensten unterstützt. In diesem Falle wird Void zurückgegeben.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Operation vom konfigurierten Fahrzeug-Fachdienst nicht unterstützt wird.
Siehe auch:
Isom.Context.Ecu.ReadDtc() für physikalisch adressiertes Lesen von Fehlerspeichereinträgen.
Isom.Context.CurrentVehicleContext.ReadDtcFromAllEcus() für funktional adressiertes/sequentielles Lesen von Fehlerspeichereinträgen.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 461]
objectbound Isom.Base.Boolean Isom.Context.Dtc.SetDtcNumber ( Isom.Base.String newVal )

Setzt die 5-stellige Repräsentation eines Fehlercodes im standardisierten Format entsprechend ISO 15031-6 (beispielsweise "P2628") oder einen OEM-spezifischen, eindeutigen Identifikator (beispielsweise "0x000001")

Verwendungsbeispiel:
  // Erzeugen eines DTC-Fachobjekts mit vorgegebenem Fehlercode
  // (hier: ein standardkonformer Fehlercode "P2628" )
  Isom.Context.Ecu ecu = Isom.Context.Ecu.Void(); // keinen SG-Bezug vorgeben
  Isom.Context.Dtc dtc = Isom.Context.Dtc.CreateByDtcNumber( ecu, "P2628" );

  // zurücklesen des bei Erzeugung vorgegebenen Fehlercodes
  Isom.Base.String dtcNumber = dtc.GetDtcNumber();
  //  dtcNumber ist "P2628"
  Isom.Base.String soc = dtc.Get( "SystemsOrComponents" );
  //  soc ist z.B. "2O2 Sensor Pumping Current Trim"

  // Ändern des Fehlercodes
  dtc.SetDtcNumber( "P2640" );
  dtcNumber = dtc.GetDtcNumber();
  //  dtcNumber ist nun "P2640"
  soc = dtc.Get( "SystemsOrComponents" );
  //  soc ist nun z.B. "Torque Management Feedback Signal A"
Parameter:
newVal die zu setzende, 5-stellige Repräsentation eines Fehlercodes
Rückgabe:
Isom.Base.Boolean
true nach erfolgreichem Setzen, false sonst.
Siehe auch:
Isom.Context.Dtc.GetDtcNumber()
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 598]
Isom.Context.Dtc Isom.Context.Dtc.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um beispielsweise einen ungültigen Funktionsrückgabewert zu erzeugen.

Verwendungsbeispiel:
  // Erzeugen eines Void-Fachobjekts vom Typ Dtc
  Isom.Context.Dtc dtc = Isom.Context.Dtc.Void();

  // Prüfen auf Void
  Isom.Base.Boolean invalid = dtc.IsVoid();
  //  invalid ist true
Rückgabe:
Isom.Context.Dtc
Ungültiges Objekt.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\Dtc.is: 1106]


für Serviceautoren

Isom.Context.DtcList

Namensraum Isom.Context.DtcList

Liste von Fehlerspeichereintragobjekten des Typs Isom.Context.Dtc. Mehr...

Funktionen
Isom.Context.DtcList | CreateNew()

Erzeugt eine neue, leere Fehlerspeichereintragsliste zur temporären Speicherung

Isom.Context.DtcList | FilterByProp(Isom.Base.String propName, Isom.Base.String propValue)

Liefert eine Teilliste

Assoziationen zu anderen Fachobjekten

Zugriff auf andere Fachobjekte, die mit dem Fehlerspeichereintrag in Zusammenhang stehen.

Isom.Context.EcuList | GetEcus()

Liefert die Steuergeräte-Fachobjekte, auf die sich einer der Fehlerocdes bezieht.

Listenfunktionen

Isom.Context.Dtc | At(Isom.Base.Number index)

Ruft den Fehlerspeichereintrag innerhalb der Liste ab, welcher durch den Index ausgewählt wurde.

Isom.Base.Boolean | Contains(Isom.Context.Dtc element)

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Isom.Context.Dtc | Current()

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Isom.Base.Boolean | HasNext()

Liefert einen Wahrheitswert, der angibt, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Isom.Base.Number | Insert(Isom.Context.Dtc element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Liefert einen Wahrheitswert, der angibt, ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Context.Dtc | Next()

Liefert das nächste Steuergerät in der Liste.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt das durch den Index gekennzeichnete Element aus der Liste.

Isom.Base.Boolean | Reset()

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Context.DtcList | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Context.DtcList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Es wird eine Liste von Fehlerspeichereintragsobjekten des Typs Isom.Context.Dtc bereitgestellt.

Das Fachobjekt Isom.Context.DtcList bietet folgende Leistungsmerkmale:

  • die für ISOM-Listentypen üblichen Möglichkeiten zur Iteration mit HasNext() und Next()
  • fachliche Suchfunktionen für die sogenannte Hierarchischen Suche

Zu beachten:
Im Allgemeinen kann nicht von einer fachlichen Reihenfolge der Fehlerspeichereinträge in der Liste ausgegangen werden.
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion At()
  • durch Durchlaufen der Liste mit den Funktionen HasNext() und Next(). Vor einem Durchlaufen sollte Reset() aufgerufen werden.

Querverweise und Referenzen

Siehe auch:
Isom.Context.Dtc für den zugehörigen Elementetyp.

Literatur

  • ISO 15031-6:2010 "Road vehicles -- Communication between vehicle and external equipment for emissions-related diagnostics -- Part 6: Diagnostic trouble code definitions"

Dokumenteninformation

Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 21.12.2010

Quelldateien:

  • Isom\Context\DtcList.is

Dokumentation der Funktionen

objectbound Isom.Context.Dtc Isom.Context.DtcList.At ( Isom.Base.Number index )

Ruft den Fehlerspeichereintrag innerhalb der Liste ab, welcher durch den Index ausgewählt wurde.

Parameter:
index Index.
Rückgabe:
Isom.Context.Dtc
Ausgewählter Fehlerspeichereintrag.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 ist oder größer gleich der Anzahl der Listenelemente.
[Isom\Context\DtcList.is: 284]
objectbound Isom.Context.DtcList Isom.Context.DtcList.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Isom.Context.DtcList
Das geklonte Objekt vom Typ Isom.Context.DtcList.
[Isom\Context\DtcList.is: 369]
objectbound Isom.Base.Boolean Isom.Context.DtcList.Contains ( Isom.Context.Dtc element )

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element.
Rückgabe:
Isom.Base.Boolean
'true', falls das Element gefunden werden konnte,
'false' sonst.
[Isom\Context\DtcList.is: 337]
Isom.Context.DtcList Isom.Context.DtcList.CreateNew ( )

Erzeugt eine neue, leere Fehlerspeichereintragsliste zur temporären Speicherung

Verwendungsbeispiel:
  Isom.Context.DtcList dtcList = DtcList.CreateNew();
Rückgabe:
Isom.Context.DtcList
Das neu erzeugte Fehlerspeichereintragslisten-Objekt.
[Isom\Context\DtcList.is: 118]
objectbound Isom.Context.Dtc Isom.Context.DtcList.Current ( )

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Rückgabe:
Isom.Context.Dtc
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Iterator zurückgesetzt wurde.
[Isom\Context\DtcList.is: 256]
objectbound Isom.Context.DtcList Isom.Context.DtcList.FilterByProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Liefert eine Teilliste

Liefert eine Teilliste, in der sämtliche enthaltenen Fehlerspeichereinträge für die vorgegebene Eigenschaft propName mit dem vorgegebenen Wert propValue übereinstimmen, wobei semantische Begriffsbeziehungen (Unterbegriffe, Spezialisierungen) nicht berücksichtigt weden (keine Hierarchiesuche).

Verwendungsbeispiel:
  Isom.Context.DtcList all = Dtc.GetPossibleDtc();

  Isom.Context.DtcList stored =  all.FilterByProp( "IsStored", "true" );

  while( stored.HasNext() )
  {
      Isom.Context.Dtc dtc = stored.Next();
      // dtc ist im SG permanent gespeichert
  }
Parameter:
propName | Name der zu vergleichenden Eigenschaft.
propValue | gesuchter Wert der zu vergleichenden Eigenschaft.
Rückgabe:
Isom.Context.DtcList
Neue Fehlerspeichereintragsliste entsprechend o.g. Filterkriterien.
[Isom\Context\DtcList.is: 158]
objectbound Isom.Context.EcuList Isom.Context.DtcList.GetEcus ( )

Liefert die Steuergeräte-Fachobjekte, auf die sich einer der Fehlerocdes bezieht.

Die Ergebnisliste beinhaltet alle Steuergeräte, bei denen ein Fehlercode aus der Liste aufgetreten sind bzw. die für diesen Fehlercode in den Diagnoseservicedaten modelliert sind.

Rückgabe:
Isom.Context.EcuList
Liste assoziierter Steuergeräte-Fachobjekte.
[Isom\Context\DtcList.is: 182]
objectbound Isom.Base.Boolean Isom.Context.DtcList.HasNext ( )

Liefert einen Wahrheitswert, der angibt, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Rückgabe:
Isom.Base.Boolean
'true', falls noch Werte in der Liste zur Verfügung stehen,
'false' sonst.
[Isom\Context\DtcList.is: 227]
objectbound Isom.Base.Number Isom.Context.DtcList.Insert ( Isom.Context.Dtc element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Iterator, wird durch diese Operation zurückgesetzt.

Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügendes Steuergerät.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
[Isom\Context\DtcList.is: 309]
objectbound Isom.Base.Boolean Isom.Context.DtcList.IsEmpty ( )

Liefert einen Wahrheitswert, der angibt, ob diese Liste leer ist oder nicht.

Rückgabe:
Isom.Base.Boolean
'true', falls die Liste leer ist,
'false' sonst.
[Isom\Context\DtcList.is: 215]
objectbound Isom.Base.Boolean Isom.Context.DtcList.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
Isom.Base.Boolean
'true', falls dies das Void-Objekt ist,
'false' sonst.
[Isom\Context\DtcList.is: 359]
objectbound Isom.Base.Number Isom.Context.DtcList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

Rückgabe:
Isom.Base.Number
Anzahl der Elemente.
[Isom\Context\DtcList.is: 204]
objectbound Isom.Context.Dtc Isom.Context.DtcList.Next ( )

Liefert das nächste Steuergerät in der Liste.

Diese Funktion sollte zum Iterieren über die Liste verwendet werden.

Rückgabe:
Isom.Context.Dtc
Nächstes Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Context\DtcList.is: 242]
objectbound Isom.Base.Boolean Isom.Context.DtcList.Remove ( Isom.Base.Number index )

Entfernt das durch den Index gekennzeichnete Element aus der Liste.

Ein eventuell aktiver Iterator, wird durch diese Operation zurückgesetzt.

Parameter:
index Index.
Rückgabe:
Isom.Base.Boolean
'true', falls das Element entfernt werden konnte,
'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt).
[Isom\Context\DtcList.is: 325]
objectbound Isom.Base.Boolean Isom.Context.DtcList.Reset ( )

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Rückgabe:
Isom.Base.Boolean
Immer 'true'.
[Isom\Context\DtcList.is: 267]
Isom.Context.DtcList Isom.Context.DtcList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Isom.Context.DtcList
Ungültiges Objekt vom Typ Isom.Context.DtcList.
[Isom\Context\DtcList.is: 382]


für Serviceautoren

Isom.Context.Ecu

Namensraum Isom.Context.Ecu

Fachobjekt für ein Steuergerät Mehr...

Funktionen
Funktionen zur Erzeugung eines Fachobjekts

Erzeugung "freistehender" Instanzen vom Fachobjekt-Typ "Ecu"

Isom.Context.Ecu | CreateNewByAddress(Isom.Base.String ecuAddress)

Erzeugt ein neues Steuergeräte-Fachobjekt mit der übergebenen Adresse.

Isom.Context.Ecu | CreateNewByGroupName(Isom.Base.String groupName)

Erzeugt ein neues Steuergeräte-Fachobjekt mit dem übergebenen Gruppennamen.

Identifizierung und (Re)Initialisierung

Ermitteln von Steuergeräte-Detailinformationen mittels Fahrzeug-Kommunikation und Rücksetzen der Steuergeräte-Zustände über Fahrzeug-Kommunikation

Isom.Base.Boolean | Identify()

Identifiziert ein Steuergerät durch Kommunikation mit dem Fahrzeug.

Isom.Base.Boolean | UpdateContext()

Synchronisiert Steuergeräte-Informationen zwischen ISOM-Modell und Fachdiensteanbindung.

Therapieoperationen auf Steuergeräten

Steuergeräte-Operationen, die vorwiegend in der Ausführung des Therapieplans Verwendung finden.

Isom.Base.Boolean | CodeWithDefaults()

Führt die Steuergerätedefaultcodierung des Steuergeräts im Komfortmodus aus.

Isom.Base.Boolean | ErasePartial(Isom.Context.LogicalUnitList parts)

Führt das Löschen von bestimmten Teilen des Steuergeräts im Expertenmodus aus.

Isom.Base.Boolean | FlashComfort()

Führt die Flashprogrammierung des Steuergeräts im Komfortmodus aus.

Isom.Base.Boolean | FlashForced()

Führt die Flashprogrammierung des Steuergeräts im Expertenmodus aus.

Isom.Base.Boolean | FlashPartial(Isom.Base.StringList parts)

Führt die Flashprogrammierung des Steuergeräts im Expertenmodus aus.

Sonderfunktionen auf Steuergeräten

Spezielle, benannte Operationen.

Isom.Base.Boolean | DeployAllVersions()

Schreibt alle Identifikatoren der Softwarestände (Build-, Historical-,Current-) in das informationstragende Steuergerät im Fahrzeug.

Isom.Context.VehicleOrder | ReadVehicleOrder()

Liest eine Repräsentation der Fahrzeugkonfiguration aus dem Steuergerät.

Isom.Base.Boolean | ReadVersions()

Ermittlung der Identifikatoren der Softwarestände (Build-, Historical-,Current-) für das Fahrzeug aus dem informationstragenden Steuergerät.

Isom.Base.StringDictionary | RunProcess(Isom.Base.String processName, Isom.Base.StringDictionary arguments)

Ruft einen benannten Sonderprozess auf.

Isom.Base.Boolean | StoreVehicleOrder(Isom.Context.VehicleOrder vo)

Schreibt eine Repräsentation der Fahrzeugkonfiguration in das Steuergerät.

Fehlerspeicheroperationen auf Steuergeräten

Umgang mit Fehlerspeichereinträgen in Steuergeräten

Isom.Base.Boolean | ClearDtc()

Löscht alle löschbaren Fehlerspeichereinträge im Steuergerät und aktualisiert die Liste der verbleibenden Fehlerspeichereinträge

Isom.Base.Boolean | DeleteAllDtc()

Löscht sämtliche Information über Fehlerspeicher aus dem Datenobjekt.

Isom.Base.Boolean | DeleteDtc(Isom.Base.String errorID)

Löscht einen Fehlerspeichereintrag mit der übergebenen Fehler-ID aus dem Datenobjekt.

Isom.Base.StringDictionary | GetDtc(Isom.Base.String errorID)

Liefert das Wörterbuch zu einem Fehlerspeichereintrag mit der übergebenen Fehler-ID.

Isom.Base.StringList | GetDtcIdentifiers()

Liefert alle Fehler-IDs (Fehlernummern) des Steuergeräts.

Isom.Base.Boolean | ReadDtc()

Liest alle Fehlerspeichereinträge im Steuergerät.

Isom.Base.Boolean | SetDtc(Isom.Base.String errorID, Isom.Base.StringDictionary errorInfo)

Setzt für das Steuergerät einen Fehlerspeichereintrag.

Freischaltung von Funktionen von Steuergeräten mit Freischaltcodes

Aktivieren/Deaktivieren/Abfragen von Funktionen von Steuergeräten und Freischaltcodes

Isom.Base.Boolean | DisableActivationCode(Isom.Plan.ActivationCode fsc)

Deaktiviert eine Funktion, die über den FSC identifiziert wird.

Isom.Base.Boolean | EnableActivationCode(Isom.Plan.ActivationCode fsc)

Schaltet eine Funktion mittels Freischaltcode (wenn notwendig) frei.

Isom.Base.Boolean | StoreActivationCode(Isom.Plan.ActivationCode fsc)

Verbringt einen Freischaltcode in das Fahrzeug.

Isom.Base.Boolean | StoreAndEnableActivationCode(Isom.Plan.ActivationCode fsc)

Überträgt einen Freischaltcode an ein Steuergerät und schaltet die entsprechende Funktion frei.

Technische Benennung von Steuergeräten

Namen und Adressen, die das Ansprechen des SG und die Assoziierung der zugehörigen Servicedaten erlauben.

Isom.Base.String | GetBaseVariant()

Fragt den Basisvarianten-Namen des Steuergeräts ab.

Isom.Base.StringList | GetCodingNames()

Ermittelt die Liste der Codiernamen.

Isom.Base.Number | GetCodingSequence()

Fragt die Codierreihenfolge für dieses Steuergerät ab

Isom.Base.String | GetDiagName()

Fragt den Diagnose-Namen des Steuergeräts ab.

Isom.Base.String | GetEcuAddress()

Fragt die Steuergeräteadresse des Steuergeräts ab, auch als Verbauadresse bezeichnet.

Isom.Base.String | GetGroupName()

Fragt den Namen der Diagnosegruppendatei des Steuergeräts ab.

Isom.Base.String | GetOrderType()

Fragt den Bestelltyp dieses Steuergerätes ab.

Isom.Base.Number | GetPostCodingDelay(Isom.Base.String codeName)

Fragt die Codierabklingzeit für eine Codiereinheit dieses Steuergerätes ab.

Isom.Base.String | GetProtocol()

Liefert das Protokoll zur Kommunikation mit dem Steuergerät.

Isom.Base.Boolean | SetBaseVariant(Isom.Base.String newBaseVariant)

Setzt den Basisvarianten-Namen des Steuergeräts.

Isom.Base.Boolean | SetCodingSequence(Isom.Base.Number value)

Setzt die Codierreihenfolge für dieses Steuergerät.

Isom.Base.Boolean | SetDiagName(Isom.Base.String newDiagName)

Setzt den Diagnose-Namen des Steuergeräts.

Isom.Base.Boolean | SetGroupName(Isom.Base.String newGroupName)

Setzt den Namen der Diagnosegruppendatei des Steuergeräts.

Isom.Base.Boolean | SetPostCodingDelay(Isom.Base.String codeName, Isom.Base.Number value)

Setzt die Codierabklingzeit für eine Codiereinheit dieses Steuergerätes.

Eigenschaften

Typischerweise herstellerabhängige Datenwerte, die das SG charakterisieren. Für baureihenspezifische Property-Namen siehe herstellerspezifisches Begleitdokument.

Isom.Base.StringList | GetAllPropertyNames()

Liefert die Namen aller Eigenschaften dieses Steuergeräts.

Isom.Base.String | GetDisplayProp(Isom.Base.String propName)

Ermittelt den Wert der vorgegebenen Anzeigeeigenschaft für das Steuergerät.

Isom.Base.StringList | GetDisplayPropNames()

Liefert die Namen aller Anzeige-Eigenschaften des Steuergeräts.

Isom.Base.String | GetProp(Isom.Base.String propName)

Ermittelt den Wert der vorgegebenen Eigenschaft (Property) für das Steuergerät.

Isom.Base.StringList | GetPropNames()

Liefert die Namen aller technischen Eigenschaften des Steuergeräts.

Isom.Base.Boolean | InvalidateProp(Isom.Base.String propName)

Löscht die vorgegebene Eigenschaft (Property) für das Steuergerät unter Umgehung des Überschreibschutzes für Steuergeräte der Ist-Sg-Liste

Isom.Base.Boolean | SetDisplayProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt den Wert der vorgegebenen Anzeigeeigenschaft für das Steuergerät.

Isom.Base.Boolean | SetProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt den Wert der vorgegebenen Eigenschaft (Property) für das Steuergerät.

Steuergeräte-Zustand

ISOM-übergreifende oder herstellerabhängige Zustände, die Teil eines diskreten Zustandsautomaten sind. Für ISOM-übergreifend Zustands-Namen siehe Fach-IV-Konzept ISOM. Für baureihenspezifische Zustands-Namen siehe herstellerspezifisches Begleitdokument.

Isom.Base.StringList | GetStates(Isom.Base.Boolean includeUnknown)

Fragt die Steuergeräte-Zustände in allen State-Kategorien (Zustandsautomaten) ab.

Isom.Base.Boolean | IsInState(Isom.Base.String testState)

Prüft, ob sich der vorgegebene Zustandsautomat im angegebenen Zustand befindet.

Isom.Base.Boolean | SetState(Isom.Base.String newState)

Setzt den Steuergeräte-Zustand im passenden Zustandsautomaten.

Aktionsbezogene Eigenschaften

Eigenschaften, die bestimmen, ob bestimmte Fach-Operationen auf dem Steuergerät sinnvoll sind.

Isom.Base.Boolean | IsCodeable()

Ermittelt, ob das Steuergerät codierbar ist.

Isom.Base.Boolean | IsFlashable()

Ermittelt, ob das Steuergerät programmierbar ist.

Aggregatmodellierungs-bezogene Eigenschaften

Eigenschaften aus der generischen Aggregatmodellierung.

Isom.Context.EcuList | GetAssemblingChildren()

Ermittelt die Assoziation zu den im Steuergerät enthaltenen Teil-Steuergeräten.

Isom.Context.Ecu | GetAssemblingParent()

Fragt das Steuergerät (oder den Steuergeräteteil) ab, welches das Steuergerät laut ISOM-Aggregatmodellierung unmittelbar enthält.

Isom.Context.EcuList | GetPossibleAssemblingChildren()

Fragt alle möglichen Teil-Steuergeräte ab, die das Steuergerät laut ISOM-Fahrzeugbeschreibung enthalten kann.

Isom.Context.EcuList | GetPossibleAssemblingParents()

Fragt alle möglichen zusammengesetzten SG ab, die das aktuelle SG laut ISOM-Fahrzeugbeschreibung enthalten können (direkte Parent-Beziehung).

Isom.Base.Boolean | SetAssemblingChildren(Isom.Context.EcuList children)

Setzt die Assoziation zu den im Steuergerät enthaltenen Teil-Steuergeräten.

Isom.Base.Boolean | SetAssemblingParent(Isom.Context.Ecu ecu)

Setzt die Assoziation zum enthaltenden Aggregat-Steuergerät (direkte Parent-Beziehung).

Varianteninformation

Informationen zu Verbauvarianten des Steuergeräts (bei unvollständiger Identifikation)

Isom.Context.EcuList | GetPossibleVariants()

Fragt ab, welche Varianten für das Steuergerät laut ISOM-Fahrzeugbeschreibung möglich sind.

Bustopologie-/Kanalinformationen

Informationen zu Bus/Gateway und Kanalinformationen, über die das SG angesprochen werden kann.

Isom.Base.StringList | GetConnectedBuses()

Liefert die durch die ISOM-Fahrzeugbeschreibung zugeordnete Liste der Namen aller Busse, an die das Steuergerät angeschlossen ist unter Beachtung der zum Zeitpunkt des Aufrufs gültigen Bustopologie.

Isom.Base.StringList | GetPossibleLChannels()

Liefert die durch die ISOM-Fahrzeugbeschreibung zugeordnete Liste möglicher L-Kanäle für das Steuergerät.

Isom.Base.String | GetPrimaryBus()

Ermittelt den primären Bus des Steuergeräts

Isom.Base.Boolean | IsRouter()

Bestimmt, ob es sich um ein Routing-Steuergerät handelt.

Logische Fahrzeuge und Überarbeitungsstände

Informationen zu logischen Fahrzeugen als Aufteilung des Fahrzeugkontexts, über die Teilbordnetze des Fahreugs separat angesprochen werden können sowie zu Überarbeitungsständen, die den Verbau des Fahrzeugs charakterisieren.
(Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).)

Isom.Context.LogicalVehicle | GetLogicalVehicle()

Gibt das logische Fahrzeug zurück, in dem das Steuergerät enthalten ist.

Freischaltungs-Informationen

Informationen zu Freischaltcodes des SG.

Isom.Plan.ActivationCodeList | GetActivationCodes()

Liefert alle Freischaltcodes des Steuergeräts.

Anzeige im Client

Eigenschaften, die die Anzeige des Steuergerätes im Client bestimmen.

Isom.Base.String | GetDisplayName()

Fragt den optional in der ISOM-Fahrzeugbeschreibung gesetzten Anzeigenamen des Steuergerätes ab.

Isom.Base.String | GetEcuText()

Fragt den mit der Annotation [EcuText(..)] gesetzten Anzeigenamen des Steuergeräts ab.

Editierbare Aktionen im Client

Eigenschaften, die die manuell hinzufügbaren Aktionen im Client betreffen.

Isom.Plan.TherapyPlanActionList | GetEditableActions()

Ermittelt die Liste aller mit der Annotation [EditableEcuAction(..)] markierten Steuergeräte-bezogenen Aktionen.

Zugriff auf Logistikinformationen

Zugriff auf / Vorausbestimmung von Informationen, die über die jeweils konfigurierten Logistik-Fachdienste bereitgestellt werden.

Isom.Base.Boolean | QueryLogistics()

Bestimmt Logistikdaten für typische Aktionen auf diesem Steuergerät.

Zugriff auf Logistikinformationen

Zugriff auf die Liste der logischen Einheiten eines Steuergeräts

Isom.Context.LogicalUnitList | GetLogicalUnits()

Liefert die Liste der logischen Einheiten eines Steuergeräts

Es wird eine flache Kopie geliefert, d.h. Änderungen der Liste wirken nicht auf die Liste logischer Einheiten des Steuergeräts. Änderungen an logischen Einheiten in der Liste wirken dagegen auf die logischen Einheiten des Steuergeräts.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   //Prüfung auf vorhandenen logische Einheiten
   Isom.Context.LogicalUnitList logicalUnitsFromEcu = ecu.GetLogicalUnits();
Isom.Base.Boolean | SetLogicalUnits(Isom.Context.LogicalUnitList logicalUnits)

Legt die Liste der logischen Einheiten eines Steuergeräts fest.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   //Liste von logischen Einheiten erzeugen
   Isom.Context.LogicalUnitList logicalUnitList = Isom.Context.LogicalUnitList.CreateNew();
   //EdmIds als Zeichenkette
   Isom.Base.String edmids = "btld_00000894-004_000_000,swfl_00000895-006_000_006,cafd_00000896-006_006_001,hwel_000008b0-002_005_001";
   Isom.Base.StringList edmIdsList = edmids.Split(",");
   edmIdsList.Reset();
   while(edmIdsList.HasNext())
   {
       Isom.Context.LogicalUnit logicalUnit = Isom.Context.LogicalUnit.ParseSgbmId(edmIdsList.Next());
       logicalUnitList.Insert(logicalUnit);
   }
   //logische Einheiten im Steuergerät setzen
   if(ecu.SetLogicalUnits(logicalUnitList).Failed())
   {
       //Fehlerbehandlung
   }
Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Context.Ecu | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Isom.Context.Ecu | Void()

Erzeugt ein Void-Objekt.

Entfernte Funktionen der Fachklasse "Ecu"

Funktionen, die nicht mehr Bestandteil der Fachklasse "Ecu" sind:

Isom.Context.Ecu | GetGateway()

Ermittelt das Gateway eines Steuergeräts.

Veraltet:
Entfernt seit Argonaut Version 1.10. Diese Funktion ist nicht mehr Bestandteil der Fachklasse "Ecu".

Ausführliche Beschreibung

Ein Steuergeräte-Fachobjekt repräsentiert sämtliche Identifikations- und Zustandsinformationen eines Steuergerätes.

Konstanten

Konstanten Das Steuergeräte-Fachobjekt ist mit bestimmten Steuergeräteeigenschaften verknüpft, die durch Zeichenkettenkonstanten beschrieben werden können. Diese Konstanten werden hier näher erläutert.

Quelldateien:

  • Isom\Context\Ecu.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Context.Ecu.ClearDtc ( )

Löscht alle löschbaren Fehlerspeichereinträge im Steuergerät und aktualisiert die Liste der verbleibenden Fehlerspeichereinträge

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.ClearDtc().Failed())
   {
     //Fehlerbehandlung
   }
Rückgabe:
Isom.Base.Boolean
'true' nach erfolgreichem Löschen, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, wenn die Fehlerspeicher nicht gelöscht werden konnten.
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Siehe auch:
Isom.Context.CurrentVehicleContext.ClearDtcInAllEcus() für funktional adressiertes/sequentielles Löschen von Fehlerspeichereinträgen.
Isom.Context.Dtc.Clear() für logisch adressiertes Löschen von Fehlerspeichereinträgen.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 866]
objectbound Isom.Context.Ecu Isom.Context.Ecu.Clone ( )

Erzeugt eine identische Kopie des Objekts.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Context.Ecu clone = ecu.Clone();
Rückgabe:
Isom.Context.Ecu
Das geklonte Objekt.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\Ecu.is: 2830]
objectbound Isom.Base.Boolean Isom.Context.Ecu.CodeWithDefaults ( )

Führt die Steuergerätedefaultcodierung des Steuergeräts im Komfortmodus aus.

Der Aufruf ist derzeit nur innerhalb einer Aktionsausführung "Code" zulässig.

   Isom.Base.Boolean DoCode(Isom.Plan.TherapyPlanAction action)
   {
     Isom.Context.Ecu ecu = action.GetEcu();
     Isom.Base.StringList parts = Isom.Base.StringList.CreateStringList();

     //Angabe der zu codierenden Teile

     if(ecu.CodeWithDefaults().Failed())
     {
       //Fehlerbehandlung
     }
     //..
     return true;
   }
Rückgabe:
Isom.Base.Boolean
'true', falls die Codierung vollständig erfolgreich war, 'false' sonst.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 565]
Isom.Context.Ecu Isom.Context.Ecu.CreateNewByAddress ( Isom.Base.String ecuAddress )

Erzeugt ein neues Steuergeräte-Fachobjekt mit der übergebenen Adresse.

Die daraus eindeutig ermittelbaren Datenfelder werden aus der ISOM-Fahrzeugbeschreibung gelesen; es findet keine Fahrzeugkommunikation statt. Das Fachobjekt wird nicht automatisch zur Ist- oder Soll-SG-Liste hinzugefügt, sondern es ist gewissermaßen "freistehend".

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
Rückgabe:
Isom.Context.Ecu
Das neu erzeugte Steuergeräte-Objekt mit der übergebenen Adresse.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine ISOM-Fahrzeugbeschreibung geladen ist
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 233]
Isom.Context.Ecu Isom.Context.Ecu.CreateNewByGroupName ( Isom.Base.String groupName )

Erzeugt ein neues Steuergeräte-Fachobjekt mit dem übergebenen Gruppennamen.

Die daraus eindeutig ermittelbaren Datenfelder werden aus der ISOM-Fahrzeugbeschreibung gelesen; es findet keine Fahrzeugkommunikation statt. Das Fachobjekt wird nicht automatisch zur Ist- oder Soll-SG-Liste hinzugefügt, sondern es ist gewissermaßen "freistehend".

Veraltet:
Ist spezifisch für das Laufzeitsystem EDIABAS und wird seit Version 15 von Argonaut nur noch aus Kompatibilitätsgründen unterstützt; Aufruf sollte ersetzt werden durch Aufrufe von Isom.Context.Ecu.CreateNewByAddress() mit anschließendem Isom.Context.Ecu.SetProp("GroupName").
   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByGroupName( "MOTOR" );
Rückgabe:
Isom.Context.Ecu
Das neu erzeugte Steuergeräte-Objekt mit dem übergebenen Gruppennamen.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine ISOM-Fahrzeugbeschreibung geladen ist
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 269]
objectbound Isom.Base.Boolean Isom.Context.Ecu.DeleteAllDtc ( )

Löscht sämtliche Information über Fehlerspeicher aus dem Datenobjekt.

Achtung:
Die Fehlerspeicher werden nicht im realen Steuergerät gelöscht. Dafür ist die Funktion Isom.Context.Ecu.ClearDtc() zu verwenden.
   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.DeleteAllDtc().Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
errorID Gibt den Identifikator des Fehlers an. Dies kann z.B. die Fehlernummer sein.
Rückgabe:
Isom.Base.Boolean
'true' nach erfolgreichem Löschen, 'false' sonst.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 986]
objectbound Isom.Base.Boolean Isom.Context.Ecu.DeleteDtc ( Isom.Base.String errorID )

Löscht einen Fehlerspeichereintrag mit der übergebenen Fehler-ID aus dem Datenobjekt.

Achtung:
Der Fehlerspeichereintrag wird nicht im realen Steuergerät entfernt. Dafür ist die Funktion Isom.Context.Ecu.ClearDtc() zu verwenden.
   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.DeleteAllDtc().Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
errorID Gibt den Identifikator des Fehlers an. Dies kann z.B. die Fehlernummer sein.
Rückgabe:
Isom.Base.Boolean
'true' nach erfolgreichem Löschen, 'false' sonst.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1019]
objectbound Isom.Base.Boolean Isom.Context.Ecu.DeployAllVersions ( )

Schreibt alle Identifikatoren der Softwarestände (Build-, Historical-,Current-) in das informationstragende Steuergerät im Fahrzeug.

Verbringt alle im ISOM-Objektmodell hinterlegten Integrationsstände in das vorgegebene Steuergerät.
Geschrieben werden:

  1. die Ist-Version aus dem Ist-Kontext als aktuelle Version,
  2. die Bau-Version aus dem Ist-Kontext als Bau-Version,
  3. die Backup-Version aus dem Ist-Kontext als Backup-Version

Zu beachten:
Sollte nur für Steuergeräte aufgerufen werden, die im ISOM-Fahrzeugmodell als versionstragend modelliert sind und dadurch von der Fachfunktion Isom.Context.CurrentVehicleContext.GetSoftwareVersionEcus zurückgeliefert werden.
Diese Funktion ist nur dann erfolgreich ausführbar wenn die für das Fahrzeug konfigurierten Fachdienste eine Möglichkeit anbieten, Versionen SG-bezogen zu schreiben.
Achtung:
Nach fehlgeschlagenem Fachdienstaufruf (Rückgabewert Void) können alle Integrationsstände im ISOM-Phasenmodell (Fachobjekt Isom.Context.CurrentVehicleContext) zurückgesetzt (Void) sein.
  Isom.Context.CurrentVehicleContext currentContext = Isom.Context.CurrentVehicleContext.GetInstance();
  Isom.Context.EcuList versionEcus = currentContext.GetSoftwareVersionEcus();
  Isom.Context.Ecu master = versionEcus.At(0); // SoftwareVersionEcu mit höchster Priorität
  currentContext.SetCurrentVersion("E060-06-09-520");
  master.DeployAllVersions();
Rückgabe:
Isom.Base.Boolean
'true' nach fachlich und technisch erfolgreichem Schreiben,
'false'bei fachlichem Fehlschlag des Schreibens (z.B. den Aufruf der Fachfunktion bevor Werte für die I-Stufen im ISOM-Objektmodell vorliegen)
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls ein technischer Fehler aufgetreten ist (z.B. Aufruf der Fachfunktion für Fahrzeuge, die keine Integrationsstände unterstützen)
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 30.03.2011 (Neueinführung mit BZ-11492)
[Isom\Context\Ecu.is: 752]
objectbound Isom.Base.Boolean Isom.Context.Ecu.DisableActivationCode ( Isom.Plan.ActivationCode fsc )

Deaktiviert eine Funktion, die über den FSC identifiziert wird.

   Isom.Base.Boolean DoDeactivate(Isom.Plan.TherapyPlanAction action)
   {
     Isom.Context.Ecu ecu = action.GetEcu();
     Isom.Plan.ActivationCode fsc = action.GetActivationCode();
     if(ecu.DisableActivationCode(fsc).Failed())
     {
       //Fehlerbehandlung
     }
     //..
     return true;
   }
Parameter:
fsc Freischaltcode
Rückgabe:
Isom.Base.Boolean
'true' nach erfolgreichem Deaktivieren, 'false' sonst.
Ausnahmebehandlung:
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Siehe auch:
Isom.Context.Ecu.StoreActivationCode()
Isom.Context.Ecu.EnableActivationCode()
Isom.Context.Ecu.StoreAndEnableActivationCode()
Datum:
letzte Änderung am 05.01.2012
[Isom\Context\Ecu.is: 1175]
objectbound Isom.Base.Boolean Isom.Context.Ecu.EnableActivationCode ( Isom.Plan.ActivationCode fsc )

Schaltet eine Funktion mittels Freischaltcode (wenn notwendig) frei.

   Isom.Base.Boolean DoActivate(Isom.Plan.TherapyPlanAction action)
   {
     Isom.Context.Ecu ecu = action.GetEcu();
     Isom.Plan.ActivationCode fsc = action.GetActivationCode();
     if(ecu.StoreActivationCode(fsc).Failed())
     {
       //Fehlerbehandlung
     }
     if(ecu.EnableActivationCode(fsc).Failed())
     {
       //Fehlerbehandlung
     }
     //..
     return true;
   }
Parameter:
fsc Freischaltcode
Rückgabe:
Isom.Base.Boolean
'true' nach erfolgreichem Aktivieren, 'false' sonst.
Ausnahmebehandlung:
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Siehe auch:
Isom.Context.Ecu.StoreActivationCode()
Isom.Context.Ecu.StoreAndEnableActivationCode()
Isom.Context.Ecu.DisableActivationCode()
Datum:
letzte Änderung am 05.01.2012
[Isom\Context\Ecu.is: 1106]
objectbound Isom.Base.Boolean Isom.Context.Ecu.ErasePartial ( Isom.Context.LogicalUnitList parts )

Führt das Löschen von bestimmten Teilen des Steuergeräts im Expertenmodus aus.

Mit dieser Funktion ist es möglich, nur bestimmte Teile des Steuergerätes zu löschen. Die zu löschenden Teile können über den Parameter 'parts' als Isom.Context.LogicalUnitList mitgegeben werden. Der Fachdienst muss diese Funktionalität geeignet unterstützen. Der Aufruf ist derzeit nur innerhalb einer Aktionsausführung "EraseSoftwarePackage" zulässig, für die die Logistik die notwendigen Löschinformationen liefert.

Parameter:
parts Beschreibung der zu löschenden Teile; darf nicht leer sein, sonst liefert die Funktion 'false' zurück.
Rückgabe:
Isom.Base.Boolean
'true', falls das Löschen erfolgreich war, 'false' sonst.
Ausnahmebehandlung:
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Datum:
letzte Änderung am 08.08.2012
[Isom\Context\Ecu.is: 526]
objectbound Isom.Base.Boolean Isom.Context.Ecu.FlashComfort ( )

Führt die Flashprogrammierung des Steuergeräts im Komfortmodus aus.

Der Aufruf ist derzeit nur innerhalb einer Aktionsausführung "Flash" zulässig, für die die Logistik die notwendigen Flashinformationen liefert.

   Isom.Base.Boolean DoFlash(Isom.Plan.TherapyPlanAction action)
   {
     Isom.Context.Ecu ecu = action.GetEcu();
     if(ecu.FlashComfort().Failed())
     {
       //Fehlerbehandlung
     }
     //..
     return true;
   }
Rückgabe:
Isom.Base.Boolean
'true', falls die Programmierung vollständig erfolgreich war, 'false' sonst.
Ausnahmebehandlung:
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 410]
objectbound Isom.Base.Boolean Isom.Context.Ecu.FlashForced ( )

Führt die Flashprogrammierung des Steuergeräts im Expertenmodus aus.

Damit ist es insbesondere auch möglich, ein Steuergerät auf einen alten Softwarezustand zu flashen. Der Aufruf ist derzeit nur innerhalb einer Aktionsausführung "Flash" zulässig, für die die Logistik die notwendigen Flashinformationen liefert.

   Isom.Base.Boolean DoFlash(Isom.Plan.TherapyPlanAction action)
   {
     Isom.Context.Ecu ecu = action.GetEcu();
     if(ecu.FlashForced().Failed())
     {
       //Fehlerbehandlung
     }
     //..
     return true;
   }
Rückgabe:
Isom.Base.Boolean
'true', falls die Programmierung vollständig erfolgreich war, 'false' sonst.
Ausnahmebehandlung:
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 449]
objectbound Isom.Base.Boolean Isom.Context.Ecu.FlashPartial ( Isom.Base.StringList parts )

Führt die Flashprogrammierung des Steuergeräts im Expertenmodus aus.

Mit dieser Funktion ist es möglich, nur bestimmte Teile des Steuergerätes zu programmieren. Die zu flashenden Teile können über den Parameter 'parts' als Isom.Base.StringList mitgegeben werden. Der Fachdienst muss diese Funktionalität geeignet unterstützen. Der Aufruf ist derzeit nur innerhalb einer Aktionsausführung "Flash" zulässig, für die die Logistik die notwendigen Flashinformationen liefert.

   Isom.Base.Boolean DoFlash(Isom.Plan.TherapyPlanAction action)
   {
     Isom.Context.Ecu ecu = action.GetEcu();
     Isom.Base.StringList parts = Isom.Base.StringList.CreateStringList();

     //Angabe der zu programmierenden Teile

     if(ecu.FlashPartial(parts).Failed())
     {
       //Fehlerbehandlung
     }
     //..
     return true;
   }
Parameter:
parts Beschreibung der zu flashenden Teile; darf nicht leer sein, sonst liefert die Funktion 'false' zurück.
Rückgabe:
Isom.Base.Boolean
'true', falls die Programmierung erfolgreich war, 'false' sonst.
Ausnahmebehandlung:
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 495]
objectbound Isom.Plan.ActivationCodeList Isom.Context.Ecu.GetActivationCodes ( )

Liefert alle Freischaltcodes des Steuergeräts.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Plan.ActivationCodeList activationCodes = ecu.GetActivationCodes();
Rückgabe:
Isom.Plan.ActivationCodeList
Freischaltcodes des Steuergerätes.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2529]
objectbound Isom.Base.StringList Isom.Context.Ecu.GetAllPropertyNames ( )

Liefert die Namen aller Eigenschaften dieses Steuergeräts.

Es werden die Eigenschaftsnamen sowohl für die technischen Eigenschaften (siehe Isom.Context.Ecu.GetProp()) als auch die Anzeigeeigenschaften (siehe Isom.Context.Ecu.GetDisplayProp()) zurückgeliefert.

Veraltet:
Wird seit Version 6.5.0.0 nur noch aus Kompatibilitätsgründen unterstützt. Der Abruf der Eigenschaftsnamen wird seitdem durch die Funktionen Isom.Context.Ecu.GetPropNames() und Isom.Context.Ecu.GetDisplayPropNames() bereitgestellt.
   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.StringList allPropNames = ecu.GetAllPropertyNames();
Rückgabe:
Isom.Base.StringList
Namen aller Eigenschaften dieses Steuergeräts
Siehe auch:
Isom.Context.Ecu.GetProp()
Isom.Context.Ecu.SetProp()
Isom.Context.Ecu.InvalidateProp()
Isom.Context.Ecu.GetPropNames()
Isom.Context.Ecu.GetDisplayPropNames()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1696]
objectbound Isom.Context.EcuList Isom.Context.Ecu.GetAssemblingChildren ( )

Ermittelt die Assoziation zu den im Steuergerät enthaltenen Teil-Steuergeräten.

(direkte Children-Beziehung).

  Isom.Context.Ecu parent = Isom.Context.Ecu.CreateNewByAddress("222");
  Isom.Context.EcuList children = parent.GetAssemblingChildren();
Rückgabe:
Isom.Context.EcuList
Liste der Teil-Steuergeräte.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2312]
objectbound Isom.Context.Ecu Isom.Context.Ecu.GetAssemblingParent ( )

Fragt das Steuergerät (oder den Steuergeräteteil) ab, welches das Steuergerät laut ISOM-Aggregatmodellierung unmittelbar enthält.

Dieses wird typischerweise bei der Contextermittlung bestimmt. Die Aggregatmodellierung der Logistikdienste kann ggf. abweichen. Die ISOM-Aggregatmodellierung repräsentiert die Werkstattsicht.

  Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
  Isom.Context.Ecu parent = ecu.GetAssemblingParent();
Rückgabe:
Isom.Context.Ecu
Das Aggregat-Steuergerät, welches das aktuelle Steuergerät enthält.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Steuergerät nicht Teil eines Aggregat-Steuergeräts ist.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2217]
objectbound Isom.Base.String Isom.Context.Ecu.GetBaseVariant ( )

Fragt den Basisvarianten-Namen des Steuergeräts ab.

Die Basisvariante benennt typischerweise die Funktion eines Steuergeräts an einer Verbauadresse. Die bei der Identifizierung systemtechnisch gesetzte Basisvariante entstammt typischerweise der ISOM-Fahrzeugbeschreibung.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.String baseVariant = ecu.GetBaseVariant();
Rückgabe:
Isom.Base.String
Basisvarianten-Name (in Großschreibung).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Basisvarianten-Name noch nicht ermittelt oder leer ist.
Siehe auch:
Isom.Context.Ecu.SetBaseVariant()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1315]
objectbound Isom.Base.StringList Isom.Context.Ecu.GetCodingNames ( )

Ermittelt die Liste der Codiernamen.

Die Codiernamen eines Steuergeräts sind Teil der ISOM-Fahrzeugbeschreibung.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.StringList codingNames = ecu.GetCodingNames();
Rückgabe:
Isom.Base.StringList
Liste der Codiernamen; leere Liste bei nicht codierbaren Steuergeräten.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1449]
objectbound Isom.Base.Number Isom.Context.Ecu.GetCodingSequence ( )

Fragt die Codierreihenfolge für dieses Steuergerät ab

Die Codierreihenfolge eines Steuergeräts ist Teil der ISOM-Fahrzeugbeschreibung.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.Number codingSequence = ecu.GetCodingSequence();
Rückgabe:
Isom.Base.Number
Codierreihenfolge.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Codierreihenfolge nicht ermittelt werden konnte.
Siehe auch:
Isom.Context.Ecu.SetCodingSequence()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1479]
objectbound Isom.Base.StringList Isom.Context.Ecu.GetConnectedBuses ( )

Liefert die durch die ISOM-Fahrzeugbeschreibung zugeordnete Liste der Namen aller Busse, an die das Steuergerät angeschlossen ist unter Beachtung der zum Zeitpunkt des Aufrufs gültigen Bustopologie.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.StringList busNames = ecu.GetConnectedBuses();
   while(busNames.HasNext())
   {
     //..
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller Busse, an die das Steuergerät angeschlossen ist
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls diese Information nicht ermittelt werden konnte.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2412]
objectbound Isom.Base.String Isom.Context.Ecu.GetDiagName ( )

Fragt den Diagnose-Namen des Steuergeräts ab.

Der Diagnose-Name wird auch als Variantenname des Steuergerätes bezeichnet.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.String dn = ecu.GetDiagName();
Rückgabe:
Isom.Base.String
"Diagnose-Name" des Steuergeräts (in Großschreibung).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Diagnose-Name noch nicht ermittelt oder leer ist.
Siehe auch:
Isom.Context.Ecu.SetDiagName()
Isom.Context.Ecu.GetPossibleVariants() liefert mögliche Variantennamen eines Steuergeräts.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1245]
objectbound Isom.Base.String Isom.Context.Ecu.GetDisplayName ( )

Fragt den optional in der ISOM-Fahrzeugbeschreibung gesetzten Anzeigenamen des Steuergerätes ab.

Wenn für eine Variante kein Anzeigename definiert ist, wird der Anzeigename der Basisvariante zurückgegeben. Wenn für eine Basisvariante kein Anzeigename definiert ist, wird der Name der Basisvariante zurückgegeben.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.String displayName = ecu.GetDisplayName();
Rückgabe:
Isom.Base.String
Anzeigename des Steuergeräts laut ISOM-Fahrzeugbeschreibung.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls kein Anzeigename ermittelt werden konnte
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2597]
objectbound Isom.Base.String Isom.Context.Ecu.GetDisplayProp ( Isom.Base.String propName )

Ermittelt den Wert der vorgegebenen Anzeigeeigenschaft für das Steuergerät.

Die unterstützen Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.String val = ecu.GetDisplayProp("DisplayProp1");
Parameter:
propName Name der Anzeigeeigenschaft
Rückgabe:
Isom.Base.String
Wert der Anzeigeeigenschaft.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Wert ungesetzt oder gleich "" ist.
Siehe auch:
Isom.Context.Ecu.SetDisplayProp()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1845]
objectbound Isom.Base.StringList Isom.Context.Ecu.GetDisplayPropNames ( )

Liefert die Namen aller Anzeige-Eigenschaften des Steuergeräts.

Es werden die Eigenschaftsnamen für die Anzeige-Eigenschaften (siehe Isom.Context.Ecu.GetDisplayProp()) zurückgeliefert. Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

   Boolean DoFlash ( TherapyPlanAction action )
   {
     Isom.Context.Ecu ecu = action.GetEcu();
     Isom.Base.StringList displayPropertyNames = ecu.GetDisplayPropNames();
     displayPropertyNames.Reset();
     while(displayPropertyNames.HasNext())
     {
       //Abfrage des Werts für den gelieferten Eigenschaftsnamen und z. B. Aufzeichnung ins Protokoll
     }

     //Aktionsausführung

     return true;
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller Anzeige-Eigenschaften des Steuergeräts.
Siehe auch:
Isom.Context.Ecu.GetDisplayProp()
Datum:
letzte Änderung am 09.09.2010
[Isom\Context\Ecu.is: 1963]
objectbound Isom.Base.StringDictionary Isom.Context.Ecu.GetDtc ( Isom.Base.String errorID )

Liefert das Wörterbuch zu einem Fehlerspeichereintrag mit der übergebenen Fehler-ID.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.StringDictionary entry = ecu.GetDtc("1");
Parameter:
errorID Gibt den Identifikator des Fehlers an. Dies kann z.B. die Fehlernummer sein.
Rückgabe:
Isom.Base.StringDictionary
Wörterbuch des Fehlerspeichereintrags.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 953]
objectbound Isom.Base.StringList Isom.Context.Ecu.GetDtcIdentifiers ( )

Liefert alle Fehler-IDs (Fehlernummern) des Steuergeräts.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.StringList errIdentifiers = ecu.GetDtcIdentifiers();
Rückgabe:
Isom.Base.StringList
Liste der Fehlerspeichereinträge in Dezimaldarstellung.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 927]
objectbound Isom.Base.String Isom.Context.Ecu.GetEcuAddress ( )

Fragt die Steuergeräteadresse des Steuergeräts ab, auch als Verbauadresse bezeichnet.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.String addr = ecu.GetEcuAddress(); //liefert "64"
Rückgabe:
Isom.Base.String
Steuergeräteadresse.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1214]
objectbound Isom.Base.String Isom.Context.Ecu.GetEcuText ( )

Fragt den mit der Annotation [EcuText(..)] gesetzten Anzeigenamen des Steuergeräts ab.

Als Schlüssel wird der Gruppenname des Steuergerätes verwendet.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.String txt = ecu.GetEcuText();
Rückgabe:
Isom.Base.String
Mit Annotation [EcuText(..)] gesetzter Anzeigename des Steuergeräts.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls kein Anzeigename ermittelt werden konnte
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2570]
objectbound Isom.Plan.TherapyPlanActionList Isom.Context.Ecu.GetEditableActions ( )

Ermittelt die Liste aller mit der Annotation [EditableEcuAction(..)] markierten Steuergeräte-bezogenen Aktionen.

Die nicht Steuergeräte-bezogenen Aktionen lassen sich über Isom.Plan.TherapyPlan.GetEditableActions() ermitteln.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Plan.TherapyPlanActionList list = ecu.GetEditableActions();
   while(list.HasNext())
   {
     //..
   }
Rückgabe:
Isom.Plan.TherapyPlanActionList
Liste aller Steuergeräte-bezogenen hinzufügbaren Aktionen.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2634]
Isom.Context.Ecu Isom.Context.Ecu.GetGateway ( )

Ermittelt das Gateway eines Steuergeräts.

Veraltet:
Entfernt seit Argonaut Version 1.10. Diese Funktion ist nicht mehr Bestandteil der Fachklasse "Ecu".

Mit der Einführung von mehrfach erreichbaren Steuergeräten, die gleichzeitig an mehrere Busse angeschlossen sind, ist die Zuordnung eines Steuergeräts zu einem Gateway nicht mehr eindeutig. Eine eindeutige Zuordnung besteht nur noch zwischen einem Bus und seinem Gateway. Die Funktion 'GetGateway()' wurde daher aus der Fachklasse 'Ecu' entfernt. Stattdessen kann der Fachautor Aufrufe von 'Ecu.GetConnectedBuses()' und 'CurrentVehicleContext.GetGatewayByBus()' bzw. 'FutureVehicleContext.GetGatewayByBus()' kombinieren, um an die entsprechenden Informationen zu gelangen, wie das nachfolgende Beispiel zeigt.

Verwendungsbeispiel:
   // *** ohne Verwendung von 'GetGateway()' die Liste aller Gateways
   //     eines Steuergeräts bestimmen ***

   // Steuergerät, dessen Gateways bestimmt werden sollen
   Ecu checkEcu = // ...
   // Ist-Kontext holen
   CurrentVehicleContext currentContext = CurrentVehicleContext.GetInstance();
   // Liste aller verbundenen Busse bestimmen
   StringList connectedBuses = checkEcu.GetConnectedBuses();
   EcuList gatewayList = EcuList.CreateNew(); // Liste der Gateways anlegen
   connectedBuses.Reset();
   while(connectedBuses.HasNext())
   {
      String busName = connectedBuses.Next();
      Ecu gateway = currentContext.GetGatewayByBus(busName);
      if(gateway.IsVoid())
      {
          // Steuergerät "checkEcu" ist direkt an den Fahrzeugzugang
          // angeschlossen
          // ...
      }
      else
      {
          // Steuergerät des betrachteten Busses zu Liste hinzufügen
          gatewayList.Insert(gateway);
      }
   }
   // "gatewayList" enthält jetzt die Gateway-Steuergeräte der Busse,
   // an denen "checkEcu" direkt angeschlossen ist
[MainPage.dox: 159]
objectbound Isom.Base.String Isom.Context.Ecu.GetGroupName ( )

Fragt den Namen der Diagnosegruppendatei des Steuergeräts ab.

Er wird typischerweise zur Adressierung von Steuergeräte-Basisvarianten in EDIABAS-Aufrufen verwendet.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.String dg = ecu.GetGroupName();
Veraltet:
Ist spezifisch für das Laufzeitsystem EDIABAS und wird seit Version 15 von Argonaut nur noch aus Kompatibilitätsgründen unterstützt; Aufruf sollte ersetzt werden durch Aufruf von Isom.Context.Ecu.GetProp("GroupName").
Rückgabe:
Isom.Base.String
Name der Diagnosegruppendatei (in Großschreibung).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Diagnose-Gruppendatei noch nicht ermittelt oder leer ist.
Siehe auch:
Isom.Context.Ecu.SetGroupName()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1385]
objectbound Isom.Context.LogicalUnitList Isom.Context.Ecu.GetLogicalUnits ( )

Liefert die Liste der logischen Einheiten eines Steuergeräts

Es wird eine flache Kopie geliefert, d.h. Änderungen der Liste wirken nicht auf die Liste logischer Einheiten des Steuergeräts. Änderungen an logischen Einheiten in der Liste wirken dagegen auf die logischen Einheiten des Steuergeräts.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   //Prüfung auf vorhandenen logische Einheiten
   Isom.Context.LogicalUnitList logicalUnitsFromEcu = ecu.GetLogicalUnits();
Rückgabe:
Liste der logischen Einheiten des Steuergeräts Die Liste kann leer sein, aber nicht das Void-Objekt
[Isom\Context\Ecu.is: 2737]
objectbound Isom.Context.LogicalVehicle Isom.Context.Ecu.GetLogicalVehicle ( )

Gibt das logische Fahrzeug zurück, in dem das Steuergerät enthalten ist.

Rückgabe:
Isom.Context.LogicalVehicle
logische Fahrzeug des Steuergeräts entsprechend ISOM-Fahrzeugbeschreibung.
Seit:
Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 23. 08 .2011
[Isom\Context\Ecu.is: 2497]
objectbound Isom.Base.String Isom.Context.Ecu.GetOrderType ( )

Fragt den Bestelltyp dieses Steuergerätes ab.

Der Bestelltyp wird in der ISOM-Fahrzeugbeschreibung für die Variante des Steuergeräts angegeben. Dementsprechend liegt diese Information erst vor, wenn die Variante bestimmt wurde.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.String orderType = ecu.GetOrderType();
   if(orderType.IsVoid().Not())
   {
     //Fehlerbehandlung
   }
Rückgabe:
Isom.Base.String
Bestelltyp als Zeichenkette.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Wert nicht ermittelbar ist.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1615]
objectbound Isom.Context.EcuList Isom.Context.Ecu.GetPossibleAssemblingChildren ( )

Fragt alle möglichen Teil-Steuergeräte ab, die das Steuergerät laut ISOM-Fahrzeugbeschreibung enthalten kann.

(direkte Children-Beziehung).

  Isom.Context.Ecu parent = Isom.Context.Ecu.CreateNewByAddress("222");
  Isom.Context.EcuList children = parent.GetPossibleAssemblingChildren();
Rückgabe:
Isom.Context.EcuList
Mögliche Teil-Steuergeräte dieses Steuergeräts; eine leere Liste, wenn dieses Steuergerät kein Aggregat ist.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2264]
objectbound Isom.Context.EcuList Isom.Context.Ecu.GetPossibleAssemblingParents ( )

Fragt alle möglichen zusammengesetzten SG ab, die das aktuelle SG laut ISOM-Fahrzeugbeschreibung enthalten können (direkte Parent-Beziehung).

  Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
  Isom.Context.EcuList parents = ecu.GetPossibleAssemblingParents();
Rückgabe:
Isom.Context.EcuList
Liste von Aggregat-Steuergeräten, die die das aktuelle SG laut ISOM-Fahrzeugbeschreibung enthalten können.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2189]
objectbound Isom.Base.StringList Isom.Context.Ecu.GetPossibleLChannels ( )

Liefert die durch die ISOM-Fahrzeugbeschreibung zugeordnete Liste möglicher L-Kanäle für das Steuergerät.

Eventuelle, per Isom.Context.ContextConfiguration.SetDefaultLChannels() gesetzte Globalvorgaben werden filternd berücksichtigt.

   Isom.Base.Boolean FilterFlash( TherapyPlanAction action )
   {
     Isom.Base.StringList channels = action.GetEcu().GetPossibleLChannels();
     action.SetPossibleLChannels( channels );
     //..
     return true;
    }
Rückgabe:
Isom.Base.StringList
Liste möglicher L-Kanäle laut ISOM-Fahrzeugbeschreibung.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2384]
objectbound Isom.Context.EcuList Isom.Context.Ecu.GetPossibleVariants ( )

Fragt ab, welche Varianten für das Steuergerät laut ISOM-Fahrzeugbeschreibung möglich sind.

  Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
  Isom.Context.EcuList variantList = ecu.GetPossibleVariants();
Rückgabe:
Isom.Context.EcuList
Liste aller möglichen Varianten.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2345]
objectbound Isom.Base.Number Isom.Context.Ecu.GetPostCodingDelay ( Isom.Base.String codeName )

Fragt die Codierabklingzeit für eine Codiereinheit dieses Steuergerätes ab.

Die Codierabklingzeiten eines Steuergeräts sind Teil der ISOM-Fahrzeugbeschreibung.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.Number postCodingDelay = ecu.GetPostCodingDelay("MOTOR_CODE_1");
Parameter:
codeName value Name der Codiereinheit
Rückgabe:
Isom.Base.Number
Codierabklingzeit.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Codierabklingzeit nicht ermittelt werden konnte.
Siehe auch:
Isom.Context.Ecu.SetPostCodingDelay()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1545]
objectbound Isom.Base.String Isom.Context.Ecu.GetPrimaryBus ( )

Ermittelt den primären Bus des Steuergeräts

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.String primaryBus = ecu.GetPrimaryBus();
   if(primaryBus.IsVoid().Not())
   {
     // Bearbeitung mit dem primären Bus
   }
Rückgabe:
Isom.Base.String
Name des primären Buses
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der primäre Bus des Steuergeräts nicht definiert ist.
Datum:
letzte Änderung am 14.03.2012
[Isom\Context\Ecu.is: 2466]
objectbound Isom.Base.String Isom.Context.Ecu.GetProp ( Isom.Base.String propName )

Ermittelt den Wert der vorgegebenen Eigenschaft (Property) für das Steuergerät.

Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden. Wenn der Wert für <propName> ungesetzt ist und <propName> kein : enthält, wird zusätzlich noch nach einem Wert <propName>:ByIsom gesucht und dieser im Erfolgsfall zurückgeliefert. Dies dient einem transparenten Rückfall auf von ISOM vorausberechnete Werte, wenn ein qualifizierter Wert für <propName> nicht ermittelbar ist. Dieses Verhalten kann unterdrückt werden, indem an <propName> ein : als letztes Zeichen angehängt wird.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.String val = ecu.GetProp("PartNumber");
Parameter:
propName Name der Eigenschaft
Rückgabe:
Isom.Base.String
Wert der Eigenschaft.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Wert ungesetzt oder gleich "" ist.
Siehe auch:
Isom.Context.Ecu.SetProp()
Isom.Context.Ecu.GetAllPropertyNames()
Isom.Context.Ecu.InvalidateProp()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1737]
objectbound Isom.Base.StringList Isom.Context.Ecu.GetPropNames ( )

Liefert die Namen aller technischen Eigenschaften des Steuergeräts.

Es werden die Eigenschaftsnamen für die technischen Eigenschaften (siehe Isom.Context.Ecu.GetProp()) zurückgeliefert. Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

   Isom.Base.Boolean DoFlash (Isom.Plan.TherapyPlanAction action)
   {
     Isom.Context.Ecu ecu = action.GetEcu();
     Isom.Base.StringList propertyNames = ecu.GetPropNames();
     propertyNames.Reset();
     while(propertyNames.HasNext())
     {
       //Abfrage des Werts für den gelieferten Eigenschaftsnamen und z. B. Aufzeichnung ins Protokoll
     }

     //Aktionsausführung

     return true;
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller technischen Eigenschaften des Steuergeräts.
Siehe auch:
Isom.Context.Ecu.GetProp()
Datum:
letzte Änderung am 09.09.2010
[Isom\Context\Ecu.is: 1921]
objectbound Isom.Base.String Isom.Context.Ecu.GetProtocol ( )

Liefert das Protokoll zur Kommunikation mit dem Steuergerät.

Die Funktion liefert das in der Fahrzeugbeschreibung der eingestellten Baureihengruppe angegebene Protokoll zur Kommunikation mit dem Steuergerät.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("42");
   Isom.Base.String protocol = ecu.GetProtocol();
   if(protocol.IsVoid().Not())
   {
       //...
   }
Rückgabe:
Isom.Base.String
Protokoll als Zeichenkette
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Protokoll nicht ermittelt werden kann.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 11.06.2010
[Isom\Context\Ecu.is: 1650]
objectbound Isom.Base.StringList Isom.Context.Ecu.GetStates ( Isom.Base.Boolean includeUnknown )

Fragt die Steuergeräte-Zustände in allen State-Kategorien (Zustandsautomaten) ab.

Es werden die vollqualifizierten Namen aller Zustände geliefert.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.GetStates(false).Contains( "Isom.Flash.BaseEcu"))  // Grundsteuergerät
   {
     //..
   }
Parameter:
includeUnknown '... .UNKNOWN'-Zustände werden unterdrückt, falls 'false'
Rückgabe:
Isom.Base.StringList
Die vollqualifizierten Zustände in allen State-Kategorien.
Siehe auch:
Isom.Context.Ecu.SetState()
Isom.Context.Ecu.IsInState()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2009]
objectbound Isom.Base.Boolean Isom.Context.Ecu.Identify ( )

Identifiziert ein Steuergerät durch Kommunikation mit dem Fahrzeug.

Danach werden die Informationen zum identifizierten Steuergerät aus der der ISOM-Fahrzeugbeschreibung gelesen und in das Fachobjekt übertragen. Typischerweise sind danach alle Diagnoseinformationen des Ist-Zustandes gesetzt.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress( "18" );
   if (ecu.Identify().Failed())
   {
     //Fehlerbehandlung
   }
Rückgabe:
Isom.Base.Boolean
'true', wenn mindestens eine Basisidentifikation erfolgreich war, 'false' sonst.
Ausnahmebehandlung:
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Nachbedingung:
Zustand 'Isom.Identify.FullyIdentified' oder 'Isom.Identify.PartiallyIdentified' oder 'Isom.Identify.Failed'.
Zustand 'Isom.Communication.Responding' oder Isom.Communication.NotResponding.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 325]
objectbound Isom.Base.Boolean Isom.Context.Ecu.InvalidateProp ( Isom.Base.String propName )

Löscht die vorgegebene Eigenschaft (Property) für das Steuergerät unter Umgehung des Überschreibschutzes für Steuergeräte der Ist-Sg-Liste

Ein Aufruf für nicht im Istkontext vorhandene Steuergeräte ist zulässig und gleichwertig zu Isom.Context.Ecu.SetProp(). Das Rücksetzen einer Steuergeräte-Eigenschaft (property) wirkt sich konventionsmäßig immer auf alle im System bekannten Fahrzeug-Kontexte aus (transparentes Autoren-Property-Modell), d.h. autorengesetzte Eigenschaften haben globalen Charakter und unterliegen keiner Einfügehistorie. Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   ecu.InvalidateProp("PartNumber");
Parameter:
propName Name der Eigenschaft
Rückgabe:
Isom.Base.Boolean
Immer 'true'
Siehe auch:
Isom.Context.Ecu.GetProp()
Isom.Context.Ecu.SetProp()
Isom.Context.Ecu.GetAllPropertyNames()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1813]
objectbound Isom.Base.Boolean Isom.Context.Ecu.IsCodeable ( )

Ermittelt, ob das Steuergerät codierbar ist.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.IsCodeable())
   {
     //..
   }
Rückgabe:
Isom.Base.Boolean
'true', falls das Steuergerät codierbar ist, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Identifikationsdaten nicht ausreichen, um die Codierbarkeit zu ermitteln
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2122]
objectbound Isom.Base.Boolean Isom.Context.Ecu.IsFlashable ( )

Ermittelt, ob das Steuergerät programmierbar ist.

Dafür wird geprüft, ob in der ISOM-Fahrzeugbeschreibung eine FlashInfo angegeben ist. Eventuell im SG hinterlegte Zähler/Beschränkungen für Programmiervorgänge werden nicht ausgewertet. Wenn die Diagnoseinformationen noch nicht genügen, um die Variante zu identifizieren, wird 'true' zurückgegeben, 'false' wenn alle Varianten flashbar sind bzw. falls alle Varianten nicht flashbar sind. Ansonsten wird 'Void' zurückgegeben.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.IsFlashable())
   {
     //..
   }
Rückgabe:
Isom.Base.Boolean
'true', falls das Steuergerät eindeutig programmierbar ist, 'false' falls das Steuergerät eindeutig nicht programmierbar ist
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Identifikationsdaten nicht ausreichen, um die Programmierbarkeit zu ermitteln
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2156]
objectbound Isom.Base.Boolean Isom.Context.Ecu.IsInState ( Isom.Base.String testState )

Prüft, ob sich der vorgegebene Zustandsautomat im angegebenen Zustand befindet.

Dies ist eine Bequemlichkeitsfunktion für

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.GetStates(true).Contains("Isom.Flash.BaseEcu")) // Grundsteuergerät
   {
     //..
   }

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.IsInState("Isom.Flash.BaseEcu")) // Grundsteuergerät
   {
     //..
   }
Parameter:
newState vollqualifizierter Zustandsname.
Rückgabe:
Isom.Base.Boolean
'true', wenn sich der vorgegebene Zustandsautomat im angegebenen Zustand befindet.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Zustandsautomat nicht existiert.
Siehe auch:
Isom.Context.Ecu.GetStates()
Isom.Context.Ecu.SetState()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2083]
objectbound Isom.Base.Boolean Isom.Context.Ecu.IsRouter ( )

Bestimmt, ob es sich um ein Routing-Steuergerät handelt.

Ein Steuergerät ist ein Router-Steuergerät, wenn es:

  • laut aktueller Bustopologie an mehr als einen Bus angeschlossen ist
  • laut ISOM-Fahrzeugbeschreibung Routing-Fähigkeiten aufweist

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.Boolean isRouter = ecu.IsRouter();
   if(isRouter)
   {
     // Sonderbehandlung für Routing-SG ...
   }
Rückgabe:
Isom.Base.Boolean
'true', wenn es sich um ein Routing-Steuergerät handelt
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Routing-Fähigkeiten des Steuergeräts nicht ermittelt werden konnte.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2443]
objectbound Isom.Base.Boolean Isom.Context.Ecu.IsVoid ( )

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Das Void-Objekt kann z. B. bei Funktionsaufrufen geliefert werden, um einen Fehler anzuzeigen.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   //Prüfung auf Void
   if (ecu.IsVoid())
   {
     //Fehlerbehandlung
   }
Rückgabe:
Isom.Base.Boolean
'true', falls dies das Void-Objekt ist, 'false' sonst
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\Ecu.is: 2809]
objectbound Isom.Base.Boolean Isom.Context.Ecu.QueryLogistics ( )

Bestimmt Logistikdaten für typische Aktionen auf diesem Steuergerät.

Typischerweise wird für das Steuergeräte-Objekt über die konfigurierten Logistik-Fachdienste ein Logistikplan berechnet, welcher Tausch- und Programmierinformationen für das Steuergerät beinhaltet. Die Ergebnisse werden als logische Einheiten mit dem Zustand "Isom.Source.Logistics" in die vorgegebenen Steuergeräte-Datenobjekte eingetragen. Eigenschaftsnamen und Spezifika der jeweiligen Fachdienste sind im herstellerspezifischen Begleitdokument beschrieben.

Die Funktion ist primär für Anwendungsfälle gedacht, in denen die Ist-Verbauinformation durch Fahrzeugkommunikation nicht hinreichend ermittelt werden kann, z.B. aufgrund eines nicht antwortenden Gateway-Steuergeräts.

Konventionsmäßig erfolgt der Aufruf mit

  • dem Ist-Fahrzeugauftrag und
  • dem vom Autor gesetzten Soll-I-Level (wenn gesetzt) beziehungsweise dem über Logistik automatisch ermittelten Soll-I-Level (sonst)

Zu beachten:
Durch die Logistikberechnung kann ein mehrfacher Aufruf (beispielsweise für zahlreiche Steuergeräte) zeitaufwändig sein.
Im Codebeispiel werden die Steuergeräte des Soll-Kontext (Isom.Context.FutureVehicleContext) verwendet. Dieses Vorgehen ist deswegen zu bevorzugen, weil Aktionen als assoziiertes Steuergerät (Isom.Plan.TherapyPlanAction.GetEcu()) immer ein Steuergerät des Soll-Kontext verwenden. Werden stattdessen Steuergeräte des Ist-Kontext befüllt und dann Aktionen für diese Steuergeräte eingeplant, stehen die von Isom.Context.Ecu.QueryLogistics() berechneten Properties in dem durch Isom.Plan.TherapyPlanAction.GetEcu() gelieferten Steuergerät unter Umständen nicht zur Verfügung.
   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.QueryLogistics().Failed())
   {
     // Fehlerbehandlung
   }
Rückgabe:
Isom.Base.Boolean
'true' nach erfolgreicher Ermittlung aller Logistikinformation, 'false' sonst.
Datum:
letzte Änderung am 29.03.2012
[Isom\Context\Ecu.is: 2703]
objectbound Isom.Base.Boolean Isom.Context.Ecu.ReadDtc ( )

Liest alle Fehlerspeichereinträge im Steuergerät.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.ReadDtc().Failed())
   {
     //Fehlerbehandlung
   }
Rückgabe:
Isom.Base.Boolean
'true' nach erfolgreichem Lesen
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, wenn die Fehlerspeicher nicht ausgelesen werden konnten
Siehe auch:
Isom.Context.CurrentVehicleContext.ReadDtcFromAllEcus() für funktional adressiertes/sequentielles Lesen von Fehlerspeichereinträgen.
Isom.Context.Dtc.ReadDetails() für logisch adressiertes Lesen von Fehlerspeichereinträgen.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 830]
objectbound Isom.Context.VehicleOrder Isom.Context.Ecu.ReadVehicleOrder ( )

Liest eine Repräsentation der Fahrzeugkonfiguration aus dem Steuergerät.

   Isom.Context.CurrentVehicleContext cvc = Isom.Context.CurrentVehicleContext.GetInstance();
   Isom.Context.EcuList vcEcus = cvc.GetVehicleConfigurationEcus();
   while (vcEcus.HasNext())
   {
     Isom.Context.Ecu vcEcu = vcEcus.Next();
     Isom.Context.VehicleOrder vo = vcEcu.ReadVehicleOrder();
     //..
   }
Rückgabe:
Isom.Context.VehicleOrder
Gelesene Fahrzeugkonfiguration als Instanz der Fachklasse Isom.Context.VehicleOrder.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die notwendigen Fahrzeug-Metadaten nicht ermittelbar sind.
Es wird das Void-Objekt zurückgegeben, falls das Steuergerät keine Fahrzeugkonfiguration trägt.
Es wird das Void-Objekt zurückgegeben, falls die Fahrzeugkonfiguration nicht gelesen werden konnte.
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 645]
objectbound Isom.Base.Boolean Isom.Context.Ecu.ReadVersions ( )

Ermittlung der Identifikatoren der Softwarestände (Build-, Historical-,Current-) für das Fahrzeug aus dem informationstragenden Steuergerät.

Ermittelt den aktuellen Identifikator des Softwarestands, den Identifikator beim Bau des Fahrzeugs und den Identifikator des Softwarestands vor der letzten Aktualisierung. Aktualisiert im Erfolgsfall den CurrentVehicleContext.

Zu beachten:
Sollte nur für Steuergeräte aufgerufen werden, die im ISOM-Fahrzeugmodell als versionstragend modelliert sind und infolgedessen von der Fachfunktion Isom.Context.CurrentVehicleContext.GetSoftwareVersionEcus() zurückgeliefert werden.
Diese Funktion ist nur dann erfolgreich ausführbar wenn die für das Fahrzeug konfigurierten Fachdienste eine Möglichkeit anbieten, Versionen SG-bezogen zu lesen.
  Isom.Context.CurrentVehicleContext currentContext = Isom.Context.CurrentVehicleContext.GetInstance();
  Isom.Context.EcuList versionEcus = currentContext.GetSoftwareVersionEcus();
  Isom.Context.Ecu master = versionEcus.At(0); // SoftwareVersionEcu mit höchster Priorität
  master.ReadVersions();
  Isom.Base.String currentVersion = currentContext.GetCurrentVersion(); // z.B. "E060-06-09-520"
Rückgabe:
Isom.Base.Boolean
'true' wenn das Lesen der Identifikatoren erfolgreich war;
'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die notwendigen Fahrzeug-Metadaten nicht ermittelbar sind.
Es wird das Void-Objekt zurückgegeben, falls das Steuergerät keine Fahrzeugkonfiguration trägt.
Es wird das Void-Objekt zurückgegeben, falls die Fahrzeugkonfiguration nicht gelesen werden konnte.
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Siehe auch:
Isom.Context.CurrentVehicleContext.GetCurrentVersion für Zugriff auf den aktuellen Integrationsstand
Isom.Context.CurrentVehicleContext.GetBuildVersion für Zugriff auf den Bau-Integrationsstand
Isom.Context.CurrentVehicleContext.GetHistoricalVersion für Zugriff auf den Backup-Integrationsstand
Isom.Context.CurrentVehicleContext.ReadVersions für Fahrzeug-bezogenes Lesen
Datum:
letzte Änderung am 30.03.2011 (Neueinführung mit BZ-11492)
[Isom\Context\Ecu.is: 700]
objectbound Isom.Base.StringDictionary Isom.Context.Ecu.RunProcess | ( | Isom.Base.String | processName,
 |  | Isom.Base.StringDictionary | arguments
 | ) |  |

Ruft einen benannten Sonderprozess auf.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress( "64" );
   Isom.Base.String processName = "ExampleProcess";
   Isom.Base.StringDictionary args = Isom.Base.StringDictionary.CreateStringDictionary();

   //Angabe der vom Sonderprozess benötigten Argumente

   Isom.Base.StringDictionary result = ecu.RunProcess(processName, args);
Parameter:
processName | Name des aufgerufenen Sonderprozesses
arguments | Argumente des Aufrufs
Rückgabe:
Isom.Base.StringDictionary
Ein prozessspezifisches Wörterbuch der Aufrufergebnisse.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, wenn der aufgerufene Sonderprozess nicht implementiert ist.
Es wird das Void-Objekt zurückgegeben, wenn der aufgerufene Sonderprozess fehlgeschlagen ist.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 786]
objectbound Isom.Base.Boolean Isom.Context.Ecu.SetAssemblingChildren ( Isom.Context.EcuList children )

Setzt die Assoziation zu den im Steuergerät enthaltenen Teil-Steuergeräten.

(direkte Children-Beziehung).

  Isom.Context.Ecu parent = Isom.Context.Ecu.CreateNewByAddress("222");
  Isom.Context.EcuList children = EcuList.CreateNew();

  //Befüllen der Liste 'children' mit den Teil-Steuergeräten

  parent.SetAssemblingChildren(children);
Rückgabe:
Isom.Base.Boolean
'true' im Erfolgsfall, 'false' sonst
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2290]
objectbound Isom.Base.Boolean Isom.Context.Ecu.SetAssemblingParent ( Isom.Context.Ecu ecu )

Setzt die Assoziation zum enthaltenden Aggregat-Steuergerät (direkte Parent-Beziehung).

  Isom.Context.Ecu  = Isom.Context.Ecu.CreateNewByAddress("222");
  Isom.Context.Ecu child = Isom.Context.Ecu.CreateNewByAddress("11");
  child.SetAssemblingParent(parent);
Parameter:
ecu Zu setzendes Aggregat-Steuergerät
Rückgabe:
Isom.Base.Boolean
'true' im Erfolgsfall, 'false' sonst.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2241]
objectbound Isom.Base.Boolean Isom.Context.Ecu.SetBaseVariant ( Isom.Base.String newBaseVariant )

Setzt den Basisvarianten-Namen des Steuergeräts.

Bisher ungesetzte Steuergeräte-Eigenschaften werden anhand der Informationen aus der ISOM-Fahrzeugbeschreibung aktualisiert.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.SetBaseVariant("MOTOR").Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
newBaseVariant Neuer Basisvarianten-Name oder String.Void(), um diesen zurückzusetzen.
Rückgabe:
Isom.Base.Boolean
immer 'true'
Siehe auch:
Isom.Context.Ecu.GetBaseVariant()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1348]
objectbound Isom.Base.Boolean Isom.Context.Ecu.SetCodingSequence ( Isom.Base.Number value )

Setzt die Codierreihenfolge für dieses Steuergerät.

Mit der Funktion lassen sich aus der ISOM-Fahrzeugbeschreibung ausgelesene Werte überschreiben.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.SetCodingSequence(1).Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
value value Codierreihenfolge
Rückgabe:
Isom.Base.Boolean
'true', falls die Codierreihenfolge erfolgreich gesetzt wurde, 'false' sonst
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Codierreihenfolge nicht gesetzt werden konnte.
Siehe auch:
Isom.Context.Ecu.GetCodingSequence()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1514]
objectbound Isom.Base.Boolean Isom.Context.Ecu.SetDiagName ( Isom.Base.String newDiagName )

Setzt den Diagnose-Namen des Steuergeräts.

Bisher ungesetzte Steuergeräte-Eigenschaften werden anhand der Informationen aus der ISOM-Fahrzeugbeschreibung aktualisiert. Der Diagnosename wird auch als Varianten-Name des Steuergeräts bezeichnet.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.SetDiagName("MOTOR_VARIANT_1").Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
newDiagName Neuer Variantenname oder String.Void(), um den Variantennamen zurückzusetzen.
Rückgabe:
Isom.Base.Boolean
immer 'true'
Siehe auch:
Isom.Context.Ecu.GetDiagName()
Isom.Context.Ecu.GetPossibleVariants() liefert mögliche Variantennamen eines Steuergeräts.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1282]
objectbound Isom.Base.Boolean Isom.Context.Ecu.SetDisplayProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt den Wert der vorgegebenen Anzeigeeigenschaft für das Steuergerät.

Setzt den Wert der vorgegebenen Anzeigeeigenschaft für das Steuergerät. Die unterstützen Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden. Das Setzen einer Steuergeräte-Anzeigeigenschaft (DisplayProperty) wirkt sich konventionsmäßig immer auf alle im System bekannten Fahrzeug-Kontexte aus (transparentes Autoren-Property-Modell), d.h. autorengesetzte Eigenschaften haben globalen Charakter und unterliegen keiner Einfügehistorie.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   ecu.SetDisplayProp("EcuType", "Test");
Parameter:
propName | Name der Eigenschaft
propName | Neuer Wert der Eigenschaft
Rückgabe:
Isom.Base.Boolean
Immer 'true'
Siehe auch:
Isom.Context.Ecu.GetDisplayProp()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1879]
objectbound Isom.Base.Boolean Isom.Context.Ecu.SetDtc | ( | Isom.Base.String | errorID,
 |  | Isom.Base.StringDictionary | errorInfo
 | ) |  |

Setzt für das Steuergerät einen Fehlerspeichereintrag.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.StringDictionary errorInfo = Isom.Base.StringDictionary.CreateStringDictionary();

   //Befüllen von 'errorInfo'

   if(ecu.SetDtc("1", errorInfo).Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
errorID | Gibt den Identifikator des Fehlers an. Dies kann z.B. die Fehlernummer sein.
errorInfo | Enthält weitere Informationen, die den Fehler genauer beschreiben.
Rückgabe:
Isom.Base.Boolean
'true', falls der Fehlerspeichereintrag erfolgreich gesetzt wurde.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Fehlerspeichereinträge nicht gesetzt werden konnten.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 903]
objectbound Isom.Base.Boolean Isom.Context.Ecu.SetGroupName ( Isom.Base.String newGroupName )

Setzt den Namen der Diagnosegruppendatei des Steuergeräts.

Er wird typischerweise zur Adressierung von Steuergeräte-Basisvarianten in EDIABAS-Aufrufen verwendet.

Veraltet:
Ist spezifisch für das Laufzeitsystem EDIABAS und wird seit Version 15 von Argonaut nur noch aus Kompatibilitätsgründen unterstützt; Aufruf sollte ersetzt werden durch Aufruf von Isom.Context.Ecu.SetProp("GroupName").
   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.SetGroupName("D_MOTOR").Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
newGroupName Neuer Namen der Diagnosegruppendatei oder Void, um diesen zurückzusetzen.
Rückgabe:
Isom.Base.Boolean
immer 'true'
Siehe auch:
Isom.Context.Ecu.GetGroupName()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1423]
objectbound Isom.Base.Boolean Isom.Context.Ecu.SetLogicalUnits ( Isom.Context.LogicalUnitList logicalUnits )

Legt die Liste der logischen Einheiten eines Steuergeräts fest.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   //Liste von logischen Einheiten erzeugen
   Isom.Context.LogicalUnitList logicalUnitList = Isom.Context.LogicalUnitList.CreateNew();
   //EdmIds als Zeichenkette
   Isom.Base.String edmids = "btld_00000894-004_000_000,swfl_00000895-006_000_006,cafd_00000896-006_006_001,hwel_000008b0-002_005_001";
   Isom.Base.StringList edmIdsList = edmids.Split(",");
   edmIdsList.Reset();
   while(edmIdsList.HasNext())
   {
       Isom.Context.LogicalUnit logicalUnit = Isom.Context.LogicalUnit.ParseSgbmId(edmIdsList.Next());
       logicalUnitList.Insert(logicalUnit);
   }
   //logische Einheiten im Steuergerät setzen
   if(ecu.SetLogicalUnits(logicalUnitList).Failed())
   {
       //Fehlerbehandlung
   }
Parameter:
logicalUnits Liste logischer Einheiten des Steuergeräts
Rückgabe:
true, wenn die Liste logischer Einheiten festgelegt wurde
[Isom\Context\Ecu.is: 2771]
objectbound Isom.Base.Boolean Isom.Context.Ecu.SetPostCodingDelay | ( | Isom.Base.String | codeName,
 |  | Isom.Base.Number | value
 | ) |  |

Setzt die Codierabklingzeit für eine Codiereinheit dieses Steuergerätes.

Mit der Funktion lassen sich aus der ISOM-Fahrzeugbeschreibung ausgelesene Werte überschreiben.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   if(ecu.SetPostCodingDelay("MOTOR_CODE_1", 100).Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
codeName | Name der Codiereinheit
value | Codierreihenfolge
Rückgabe:
Isom.Base.Boolean
'true', falls die Codierabklingzeit erfolgreich gesetzt wurde, 'false' sonst
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Codierabklingzeit nicht gesetzt werden konnte.
Siehe auch:
Isom.Context.Ecu.GetPostCodingDelay()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1581]
objectbound Isom.Base.Boolean Isom.Context.Ecu.SetProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt den Wert der vorgegebenen Eigenschaft (Property) für das Steuergerät.

Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden. Das Setzen einer Steuergeräte-Eigenschaft (property) wirkt sich konventionsmäßig immer auf alle im System bekannten Fahrzeug-Kontexte aus (transparentes Autoren-Property-Modell), d.h. autorengesetzte Eigenschaften haben globalen Charakter und unterliegen keiner Einfügehistorie.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   Isom.Base.String propName = "PartNumber";
   if(ecu.GetProp(propName).IsVoid())
     ecu.SetProp(propName, "5444442");
Parameter:
propName | Name der Eigenschaft
propValue | Neuer Wert der Eigenschaft
Rückgabe:
Isom.Base.Boolean
Immer 'true'
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Steuergeräteobjekt Teil der Ist-Sg-Liste ist und die Eigenschaft bereits nicht leer gesetzt ist.
Siehe auch:
Isom.Context.Ecu.GetProp()
Isom.Context.Ecu.GetAllPropertyNames()
Isom.Context.Ecu.InvalidateProp()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 1777]
objectbound Isom.Base.Boolean Isom.Context.Ecu.SetState ( Isom.Base.String newState )

Setzt den Steuergeräte-Zustand im passenden Zustandsautomaten.

Dazu wird der Name des zu setzenden Zustands vollqualifiziert als Parameter übergeben.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress("64");
   ecu.SetState("Isom.Identify.Unknown");
Parameter:
newState vollqualifizierter Zustandsname.
Rückgabe:
Isom.Base.Boolean
Immer 'true'.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der neue Zustand nicht vollqualifiziert ist.
Siehe auch:
Isom.Context.Ecu.GetStates()
Isom.Context.Ecu.IsInState()
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 2040]
objectbound Isom.Base.Boolean Isom.Context.Ecu.StoreActivationCode ( Isom.Plan.ActivationCode fsc )

Verbringt einen Freischaltcode in das Fahrzeug.

   Isom.Base.Boolean DoActivate(Isom.Plan.TherapyPlanAction action)
   {
     Isom.Context.Ecu ecu = action.GetEcu();
     Isom.Plan.ActivationCode fsc = action.GetActivationCode();
     if(ecu.StoreActivationCode(fsc).Failed())
     {
       //Fehlerbehandlung
     }
     if(ecu.EnableActivationCode(fsc).Failed())
     {
       //Fehlerbehandlung
     }
     //..
     return true;
   }
Parameter:
fsc Freischaltcode
Rückgabe:
Isom.Base.Boolean
'true' nach erfolgreichem Schreiben, 'false' sonst.
Ausnahmebehandlung:
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Siehe auch:
Isom.Context.Ecu.EnableActivationCode()
Isom.Context.Ecu.StoreAndEnableActivationCode()
Isom.Context.Ecu.DisableActivationCode()
Datum:
letzte Änderung am 05.01.2012
[Isom\Context\Ecu.is: 1068]
objectbound Isom.Base.Boolean Isom.Context.Ecu.StoreAndEnableActivationCode ( Isom.Plan.ActivationCode fsc )

Überträgt einen Freischaltcode an ein Steuergerät und schaltet die entsprechende Funktion frei.

   Isom.Base.Boolean DoActivate(Isom.Plan.TherapyPlanAction action)
   {
     Isom.Context.Ecu ecu = action.GetEcu();
     Isom.Plan.ActivationCode fsc = action.GetActivationCode();
     if(ecu.StoreAndEnableActivationCode(fsc).Failed())
     {
       //Fehlerbehandlung
     }
     //..
     return true;
   }
Parameter:
fsc Freischaltcode
Rückgabe:
Isom.Base.Boolean
'true' nach erfolgreichem Aktivieren, 'false' sonst.
Ausnahmebehandlung:
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Siehe auch:
Isom.Context.Ecu.StoreActivationCode()
Isom.Context.Ecu.EnableActivationCode()
Isom.Context.Ecu.DisableActivationCode()
Datum:
letzte Änderung am 05.01.2012
[Isom\Context\Ecu.is: 1141]
objectbound Isom.Base.Boolean Isom.Context.Ecu.StoreVehicleOrder ( Isom.Context.VehicleOrder vo )

Schreibt eine Repräsentation der Fahrzeugkonfiguration in das Steuergerät.

   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress( "64" );
   Isom.Context.FutureVehicleContext fvc = Isom.Context.FutureVehicleContext.GetInstance();
   Isom.Context.VehicleOrder vo = fvc.GetVehicleOrderClone();
   if(ecu.StoreVehicleOrder(vo).Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
vo Zu schreibende Repräsentation der Fahrzeugkonfiguration.
Rückgabe:
Isom.Base.Boolean
'true', nach erfolgreichem Schreiben, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die notwendigen Fahrzeug-Metadaten nicht ermittelbar sind.
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 610]
objectbound Isom.Base.Boolean Isom.Context.Ecu.UpdateContext ( )

Synchronisiert Steuergeräte-Informationen zwischen ISOM-Modell und Fachdiensteanbindung.

Achtung:
Dieser Aufruf ist nur für Spezialanwendungen vorgesehen, in denen ein spezieller Abgleich zwischen einem Fachdienst und ISOM stattfinden muss, welcher über die vorimplementierte Datenhaltung einer "normalen" ISOM-Sitzung hinausgeht.
Zu beachten:
Für Notwendigkeit und Umfang des Abgleichs siehe das herstellerspezifische Begleitdokument.
   Isom.Context.Ecu ecu = Isom.Context.Ecu.CreateNewByAddress( "18" );
   if (ecu.UpdateContext().Failed())
   {
     //Fehlerbehandlung
   }
Rückgabe:
Isom.Base.Boolean
'true', wenn keine Fehler aufgetreten sind, 'false' sonst.
Ausnahmebehandlung:
Void wird bei baureihenspezifischen Fehlern zurückgegeben, siehe herstellerspezifisches Begleitdokument.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\Ecu.is: 361]
Isom.Context.Ecu Isom.Context.Ecu.Void ( )

Erzeugt ein Void-Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

   //Erzeuge Void-Objekt
   Isom.Context.Ecu ecu = Isom.Context.Ecu.Void();
Rückgabe:
Isom.Context.Ecu
Die Funktion liefert immer ein Void-Objekt.
Ausnahmebehandlung:
Void wird von dieser Funktion immer geliefert.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\Ecu.is: 2854]


für Serviceautoren

Isom.Context.EcuList

Namensraum Isom.Context.EcuList

Listen von Steuergeräteobjekten des Typs Isom.Context.Ecu. Mehr...

Funktionen
Isom.Context.EcuList | CreateNew()

Erzeugt eine neue, leere Steuergeräteliste.

Listenfunktionen

Isom.Context.Ecu | At(Isom.Base.Number index)

Gibt ein Listenelement zurück.

Isom.Base.Boolean | Contains(Isom.Context.Ecu element)

Prüft, ob ein Element in der Liste vorhanden ist.

Isom.Context.Ecu | Current()

Liefert das Listenelement an der aktuellen Position des Iterators.

Isom.Base.Boolean | HasNext()

Gibt an, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Isom.Base.Number | Insert(Isom.Context.Ecu element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Gibt an, ob diese Liste leer ist.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Context.Ecu | Next()

Liefert das nächste Steuergerät in der Liste.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt ein Element aus der Liste.

Isom.Base.Boolean | Reset()

Setzt den Iterator zurück.

Komfortfunktionen zum Finden und Filtern

Finden und filtern von Steuergeräten

Isom.Context.EcuList | Filter(Isom.Context.EcuList otherList)

Filtert die aktuelle Liste mit der als Parameter übergebenen Liste.

Isom.Context.EcuList | FilterByBaseVariant(Isom.Base.String baseVariantName)

Sucht alle Steuergeräte mit dem angegebenen Basisvariantennamen in der Liste.

Isom.Context.EcuList | FilterByEcuAddress(Isom.Base.String ecuAddress)

Sucht alle Steuergeräte mit der angegebenen Diagnoseadresse in der Liste.

Isom.Context.EcuList | FilterByGroupName(Isom.Base.String diagGroup)

Sucht alle Steuergeräte mit dem angegebenen Diagnosegruppendateinamen in der Liste.

Isom.Context.EcuList | FilterByState(Isom.Base.String testState)

Sucht alle Steuergeräte, die sich im angegebenen Zustand befinden.

Isom.Context.Ecu | FindByBaseVariant(Isom.Base.String baseVariantName)

Sucht das eindeutige Steuergerät mit dem angegebenen Basisvariantennamen in der Liste.

Isom.Context.Ecu | FindByEcuAddress(Isom.Base.String ecuAddress)

Sucht das eindeutige Steuergerät mit der angegebenen Diagnoseadresse in der Liste und gibt es zurück.

Isom.Context.Ecu | FindByGroupName(Isom.Base.String diagGroup)

Sucht das eindeutige Steuergerät mit der angegebenen Diagnosegruppendatei in der Liste.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Context.EcuList | Clone()

Erzeugt eine neue Liste, die die Elemente dieser Liste enthält.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Isom.Context.EcuList | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:

  • der indizierte Zugriff mit der Funktion At()
  • das Durchlaufen der Liste mit den Funktionen HasNext() und Next(). Vor dem Durchlaufen sollte Reset() aufgerufen werden.

  // Liste erstellen
  Isom.Context.EcuList ecus = Isom.Context.EcuList.CreateNew();

  Isom.Base.Boolean empty = ecus.IsEmpty();    // gibt 'true' zurück

  // Liste befüllen (mit drei Steuergeräte-Fachobjekten)
  Isom.Context.Ecu ecu1 = Isom.Context.Ecu.CreateNewByAddress("64");
  ecus.Insert(ecu1);
  Isom.Context.Ecu ecu2 = Isom.Context.Ecu.CreateNewByAddress("112");
  ecus.Insert(ecu2);
  Isom.Context.Ecu ecu3 = Isom.Context.Ecu.CreateNewByAddress("58");
  ecus.Insert(ecu3);

  empty = ecus.IsEmpty();                      // gibt 'false' zurück
  Isom.Base.Number size = ecus.Length();       // gibt '3' zurück

  // indizierter Zugriff
  Isom.Context.Ecu ecu = ecus.At(1);        // gibt das Steuergerät mit Adresse "112" zurück
  ecu = ecus.At(3);                         // gibt 'Void' zurück, da der Index zu groß ist

  // Durchlaufen der Liste
  ecus.Reset();                // Iterator zurücksetzen
  while(ecus.HasNext())
  {
      ecu = ecus.Next();    // Zugriff auf das nächste Listenelement
      Isom.Sys.System.Stdout(ecu.GetEcuAddress());              // Adresse des aktuellen Listenelements (über lokale Variable) ausgeben
      Isom.Sys.System.Stdout(ecu.Current().GetEcuAddress());    // Adresse des aktuellen Listenelements (über aktuellen Index) ausgeben
  }

  if( ecus.Contains(Isom.Context.Ecu.CreateNewByAddress("11"))) // 'false'
  {
      // ...
  }

  ecus.Remove(0);             // entfernt erstes Element
  size = ecus.Length();       // gibt '2' zurück
Datum:
letzte Änderung am 20.07.2010

Quelldateien:

  • Isom\Context\EcuList.is

Dokumentation der Funktionen

objectbound Isom.Context.Ecu Isom.Context.EcuList.At ( Isom.Base.Number index )

Gibt ein Listenelement zurück.

Ruft das Element aus der Liste ab, das durch den (Null-basierten) Index ausgewählt wird.

Parameter:
index Index.
Rückgabe:
Isom.Context.Ecu
Ausgewähltes Steuergerät.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 oder größer gleich der Anzahl der Listenelemente ist.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 266]
objectbound Isom.Context.EcuList Isom.Context.EcuList.Clone ( )

Erzeugt eine neue Liste, die die Elemente dieser Liste enthält.

Rückgabe:
Isom.Context.EcuList
Neue Liste, die die Elemente dieser Liste enthält.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 670]
objectbound Isom.Base.Boolean Isom.Context.EcuList.Contains ( Isom.Context.Ecu element )

Prüft, ob ein Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element.
Rückgabe:
Isom.Base.Boolean
'true', falls das Element gefunden werden konnte, 'false' sonst.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 328]
Isom.Context.EcuList Isom.Context.EcuList.CreateNew ( )

Erzeugt eine neue, leere Steuergeräteliste.

Rückgabe:
Isom.Context.EcuList
neue, leere Liste.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 136]
objectbound Isom.Context.Ecu Isom.Context.EcuList.Current ( )

Liefert das Listenelement an der aktuellen Position des Iterators.

Zu beachten:
Diese Funktion sollte nur beim Iterieren über die Liste verwendet werden.
Rückgabe:
Isom.Context.Ecu
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Iterator zurückgesetzt wurde.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 229]
objectbound Isom.Context.EcuList Isom.Context.EcuList.Filter ( Isom.Context.EcuList otherList )

Filtert die aktuelle Liste mit der als Parameter übergebenen Liste.

Die Reihenfolge der aktuellen Liste bleibt erhalten. Die zurückgegebene Liste enthält alle Steuergeräte der aktuellen Liste außer denjenigen, die in der als Parameter übergebenen Liste nicht enthalten sind. Dabei gilt als Kriterium, dass alle fachlichen Eigenschaften, die in dem Steuergerät aus der aktuellen Liste gesetzt sind, in dem Steuergerät aus der als Parameter übergebenen Liste entweder die gleichen Werte haben oder nicht gesetzt sind. In dem Steuergerät aus der als Parameter übergebenen Liste dürfen zudem keine fachlichen Eigenschaften gesetzt sein, die in dem Steuergerät aus der aktuellen Liste nicht gesetzt sind.

   Isom.Context.CurrentVehicleContext currentContext = Isom.Context.CurrentVehicleContext.GetInstance();
   Isom.Context.EcuList ccEcuList = currentContext.GetEcus();
   Isom.Context.EcuList voEcuList = ccEcuList.Filter(currentContext.GetVehicleConfigurationEcus());
   // Erstellen der Filterliste
   EcuList otherList = EcuList.CreateNew();

   // Erstellen und einfügen der Steuergeräte
   Ecu pattern1 = Ecu.CreateNewByAddress("33");
   pattern1.SetProp("BaseVariant", "EMOTORHR");

   Ecu pattern2 = Ecu.CreateNewByAddress("150");
   pattern2.SetProp("BaseVariant", "EMOTORHL");

   Ecu pattern3 = Ecu.CreateNewByAddress("278");
   pattern3.SetProp("BaseVariant", "EMOTORVR");

   Ecu pattern4 = Ecu.CreateNewByAddress("389");
   pattern4.SetProp("BaseVariant", "EMOTORVL");

   otherList.Insert(pattern1);
   otherList.Insert(pattern2);
   otherList.Insert(pattern3);
   otherList.Insert(pattern4);

   //Filtern der Liste 'ccEcuList' mit der Liste 'otherList'
   ccEcuList.Filter(otherList);
Parameter:
otherList Liste, mit der die aktuelle Liste gefiltert werden soll.
Rückgabe:
Isom.Context.EcuList
Gefilterte Liste.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 622]
objectbound Isom.Context.EcuList Isom.Context.EcuList.FilterByBaseVariant ( Isom.Base.String baseVariantName )

Sucht alle Steuergeräte mit dem angegebenen Basisvariantennamen in der Liste.

Die durchsuchte Liste selbst bleibt unverändert.

   Isom.Context.EcuList ecuList = Isom.Context.EcuList.CreateNew();

   //Befüllen der Liste 'ecuList'

   Isom.Context.EcuList baseVariants = ecuList.FilterByBaseVariant("MOTOR");
Parameter:
baseVariantName Basisvariantenname
Rückgabe:
Isom.Context.EcuList
Liste aller gefundenen Elemente.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der übergebene 'baseVariantName' Void ist.
Siehe auch:
Isom.Context.Ecu.GetBaseVariant().
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 473]
objectbound Isom.Context.EcuList Isom.Context.EcuList.FilterByEcuAddress ( Isom.Base.String ecuAddress )

Sucht alle Steuergeräte mit der angegebenen Diagnoseadresse in der Liste.

Die durchsuchte Liste selbst bleibt unverändert.

   Isom.Context.EcuList ecuList = Isom.Context.EcuList.CreateNew();

   //Befüllen der Liste 'ecuList'

   Isom.Context.EcuList filtered = ecuList.FilterByEcuAddress("64");
Parameter:
ecuAddress Diagnoseadresse
Rückgabe:
Isom.Context.EcuList
Liste aller gefundenen Elemente.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebene 'ecuAddress' Void ist.
Siehe auch:
Isom.Context.Ecu.GetEcuAddress().
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 405]
objectbound Isom.Context.EcuList Isom.Context.EcuList.FilterByGroupName ( Isom.Base.String diagGroup )

Sucht alle Steuergeräte mit dem angegebenen Diagnosegruppendateinamen in der Liste.

Die durchsuchte Liste selbst bleibt unverändert.

   Isom.Context.EcuList ecuList = Isom.Context.EcuList.CreateNew();

   //Befüllen der Liste 'ecuList'

   Isom.Context.EcuList filteredList = ecuList.FilterByGroupName("MOTOR");
Parameter:
diagGroup Diagnosegruppendateiname
Rückgabe:
Isom.Context.EcuList
Liste aller gefundenen Elemente.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebene 'diagGroup' Void ist.
Siehe auch:
Isom.Context.Ecu.GetGroupName().
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 536]
objectbound Isom.Context.EcuList Isom.Context.EcuList.FilterByState ( Isom.Base.String testState )

Sucht alle Steuergeräte, die sich im angegebenen Zustand befinden.

Die durchsuchte Liste selbst bleibt unverändert.

   Isom.Context.EcuList ecuList = Isom.Context.EcuList.CreateNew();

   //Befüllen der Liste 'ecuList'

   Isom.Context.EcuList filteredList = ecuList.FilterByState("Isom.Logistics.NotAccepted");
Parameter:
testState vollqualifizierter Zustandsname.
Rückgabe:
Isom.Context.EcuList
Liste aller gefundenen Elemente.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das übergebene 'testState' Void ist.
Siehe auch:
Isom.Context.Ecu.IsInState().
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 567]
objectbound Isom.Context.Ecu Isom.Context.EcuList.FindByBaseVariant ( Isom.Base.String baseVariantName )

Sucht das eindeutige Steuergerät mit dem angegebenen Basisvariantennamen in der Liste.

Die durchsuchte Liste selbst bleibt unverändert.

   Isom.Context.EcuList ecuList = Isom.Context.EcuList.CreateNew();

   //Befüllen der Liste 'ecuList'

   Isom.Context.Ecu ecu = ecuList.FindByBaseVariant("MOTOR");
Parameter:
baseVariantName Basisvariantenname
Rückgabe:
Isom.Context.Ecu
Gefundenes Steuergerät.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebene 'baseVariantName' Void ist.
Es wird das Void-Objekt zurückgegeben, falls mehr als ein oder weniger als ein Element gefunden wurde.
Siehe auch:
Isom.Context.Ecu.GetBaseVariant().
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 442]
objectbound Isom.Context.Ecu Isom.Context.EcuList.FindByEcuAddress ( Isom.Base.String ecuAddress )

Sucht das eindeutige Steuergerät mit der angegebenen Diagnoseadresse in der Liste und gibt es zurück.

   Isom.Context.EcuList ecuList = Isom.Context.EcuList.CreateNew();

   //Befüllen der Liste 'ecuList'

   Isom.Context.Ecu ecu = ecuList.FindByEcuAddress("64");
Parameter:
ecuAddress Diagnoseadresse
Rückgabe:
Isom.Context.Ecu
Gefundenes Steuergerät.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebene 'ecuAddress' Void ist.
Es wird das Void-Objekt zurückgegeben, falls mehr als ein oder weniger als ein Element gefunden wurde.
Siehe auch:
Isom.Context.Ecu.GetEcuAddress().
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 374]
objectbound Isom.Context.Ecu Isom.Context.EcuList.FindByGroupName ( Isom.Base.String diagGroup )

Sucht das eindeutige Steuergerät mit der angegebenen Diagnosegruppendatei in der Liste.

Die durchsuchte Liste selbst bleibt unverändert.

   Isom.Context.EcuList ecuList = Isom.Context.EcuList.CreateNew();

   //Befüllen der Liste 'ecuList'

   Isom.Context.Ecu ecu = ecuList.FindByGroupName("MOTOR");
Parameter:
diagGroup Diagnosegruppendateiname
Rückgabe:
Isom.Context.Ecu
Gefundenes Steuergerät.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebene 'diagGroup' Void ist.
Es wird das Void-Objekt zurückgegeben, falls mehr als ein oder weniger als ein Element gefunden wurde.
Siehe auch:
Isom.Context.Ecu.GetGroupName().
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 505]
objectbound Isom.Base.Boolean Isom.Context.EcuList.HasNext ( )

Gibt an, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Rückgabe:
Isom.Base.Boolean
'true', falls noch Werte in der Liste zur Verfügung stehen, 'false' sonst.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 186]
objectbound Isom.Base.Number Isom.Context.EcuList.Insert ( Isom.Context.Ecu element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Iterator, wird durch diese Operation zurückgesetzt.

Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügendes Steuergerät.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 292]
objectbound Isom.Base.Boolean Isom.Context.EcuList.IsEmpty ( )

Gibt an, ob diese Liste leer ist.

Rückgabe:
Isom.Base.Boolean
'true', falls die Liste leer ist, 'false' sonst.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 172]
objectbound Isom.Base.Boolean Isom.Context.EcuList.IsVoid ( )

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Das Void-Objekt kann z. B. bei Funktionsaufrufen geliefert werden, um einen Fehler anzuzeigen.

Rückgabe:
Isom.Base.Boolean
'true', falls dies das Void-Objekt ist, 'false' sonst.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 658]
objectbound Isom.Base.Number Isom.Context.EcuList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

Rückgabe:
Isom.Base.Number
Anzahl der Elemente.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 160]
objectbound Isom.Context.Ecu Isom.Context.EcuList.Next ( )

Liefert das nächste Steuergerät in der Liste.

Diese Funktion setzt den Iterator der Liste auf das nächste Element und gibt dieses Element zurück.

Zu beachten:
Diese Funktion sollte zum Iterieren über die Liste verwendet werden.
Vor dem Iterieren sollte der Iterator mit Reset() zurückgesetzt werden.
Rückgabe:
Isom.Context.Ecu
Nächstes Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 211]
objectbound Isom.Base.Boolean Isom.Context.EcuList.Remove ( Isom.Base.Number index )

Entfernt ein Element aus der Liste.

Entfernt das durch den Index gekennzeichnete Element aus der Liste. Ein eventuell aktiver Iterator wird durch diese Operation zurückgesetzt.

Parameter:
index Index.
Rückgabe:
Isom.Base.Boolean
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt).
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 313]
objectbound Isom.Base.Boolean Isom.Context.EcuList.Reset ( )

Setzt den Iterator zurück.

Setzt den Iterator auf die Position vor dem ersten Element der Liste.

Rückgabe:
Isom.Base.Boolean
Immer 'true'.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\EcuList.is: 245]
Isom.Context.EcuList Isom.Context.EcuList.Void ( )

Erzeugt ein Void-Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Isom.Context.EcuList
Die Funktion liefert immer ein Void-Objekt.
Ausnahmebehandlung:
Void wird von dieser Funktion immer geliefert.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\EcuList.is: 686]


für Serviceautoren

Isom.Context.Environment

Namensraum Isom.Context.Environment

Zugriff auf Kommunikation mit dem Fahrzeugzugang und für Spannungsprüfungen Mehr...

Funktionen
Isom.Context.Environment | GetInstance()

Liefert die statische Instanz des Umgebungs-Objektes.

Elementoperationen

Funktionen zum Abfragen von Fahrzeugzugangseigenschaften.

Isom.Base.StringDictionary | GetAllEnvironmentVars()

Abfrage von Umgebungsparameter.

Isom.Base.Number | GetBatteryVoltage()

Liefert die aktuelle Batteriespannung.

Isom.Base.String | GetCurrentVciFirmwareVersion()

Ermittelt die Firmwareversion des Fahrzeugzugangs.

Isom.Base.String | GetEnvironmentVar(Isom.Base.String name)

Abfrage eines Umgebungsparameters.

Isom.Base.Number | GetIgnitionVoltage()

Liefert die aktuelle Zündungsspannung.

Isom.Base.String | GetLatestVciFirmwareVersion()

Ermittelt die neueste Firmwareversion, die für den Fahrzeugzugang zur Verfügung steht.

Isom.Base.String | GetOperationMode()

Ermittelt den Betriebsmodus, in dem sich die Anwendung befindet.

Isom.Base.Number | GetVciChannelCount()

Ermittelt die Anzahl der Kanäle des Fahrzeugzugangs.

Isom.Base.StringDictionary | GetVciChannelData(Isom.Base.Number index)

Ermittelt die Daten eines Kanals des Fahrzeugzugangs.

Isom.Base.String | GetVciConnectionQuality()

Ermittelt die Qualität der Verbindung zum Fahrzeugzugang.

Isom.Base.String | GetVciConnectionType()

Ermittelt Art der Verbindung zum Fahrzeugzugang (zum Beispiel Ethernet oder WLAN).

Isom.Base.String | GetVciGateway()

Ermittelt das Gateway der Netzwerkverbindung des Fahrzeugzugangs.

Isom.Base.String | GetVciIp()

Ermittelt die IP-Adresse des Fahrzeugzugangs.

Isom.Base.String | GetVciMac()

Ermittelt die MAC-Adresse des Fahrzeugzugangs.

Isom.Base.String | GetVciName()

Ermittelt den Namen des Fahrzeugzugangs.

Isom.Base.String | GetVciNetmask()

Ermittelt die Maske der Netzwerkverbindung des Fahrzeugzugangs.

Isom.Base.Number | GetVciState()

Ermittelt den Zustand des Fahrzeugzugangs.

Isom.Base.String | GetVehiclePreparationState()

Abfrage der Fortschritts-Phase der Fachdienste.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Context.Environment | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Dieses Fachobjekt ermöglicht Zugriff auf die Umgebung. Dazu gehört der Fahrzeugzugang, dessen Eigenschaften abgefragt werden können, ebenso wie Umgebungsvariablen und der aktuelle Betriebsmodus der Anwendung.

Hinweis: Dieses Fachobjekt funktioniert nicht mit ISOM Didact. Die meisten Funktionsaufrufe kehren mit dem Ergebnis 'Void' zurück.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Context\Environment.is

Dokumentation der Funktionen

objectbound Isom.Base.StringDictionary Isom.Context.Environment.GetAllEnvironmentVars ( )

Abfrage von Umgebungsparameter.

Rückgabe:
Die Umgebungsparameter als Wörterbuch
[Isom\Context\Environment.is: 244]
objectbound Isom.Base.Number Isom.Context.Environment.GetBatteryVoltage ( )

Liefert die aktuelle Batteriespannung.

Rückgabe:
Die aktuelle Batteriespannung in Volt.
Ausnahmebehandlung:
Bei fehlgeschlagener Ermittlung der Batteriespannung.
[Isom\Context\Environment.is: 116]
objectbound Isom.Base.String Isom.Context.Environment.GetCurrentVciFirmwareVersion ( )

Ermittelt die Firmwareversion des Fahrzeugzugangs.

Rückgabe:
Die Firmwareversion des Fahrzeugzugangs.
Ausnahmebehandlung:
Bei fehlgeschlagener Ermittlung der Firmwareversion des Fahrzeugzugangs.
[Isom\Context\Environment.is: 136]
objectbound Isom.Base.String Isom.Context.Environment.GetEnvironmentVar ( Isom.Base.String name )

Abfrage eines Umgebungsparameters.

Parameter:
name Name des Umgebaungsparameters
Rückgabe:
Wert des Umgebungsparameters
[Isom\Context\Environment.is: 253]
objectbound Isom.Base.Number Isom.Context.Environment.GetIgnitionVoltage ( )

Liefert die aktuelle Zündungsspannung.

Rückgabe:
Die zuletzt gemessene Zündungsspannung in Volt.
Ausnahmebehandlung:
Bei fehlgeschlagener Ermittlung der Zündungsspannung.
[Isom\Context\Environment.is: 126]
Isom.Context.Environment Isom.Context.Environment.GetInstance ( )

Liefert die statische Instanz des Umgebungs-Objektes.

Rückgabe:
Objekt zum Zugriff auf den Fahrzeugzugang
[Isom\Context\Environment.is: 100]
objectbound Isom.Base.String Isom.Context.Environment.GetLatestVciFirmwareVersion ( )

Ermittelt die neueste Firmwareversion, die für den Fahrzeugzugang zur Verfügung steht.

Rückgabe:
Die neueste zur Verfügung stehende Firmwareversion für den Fahrzeugzugang.
[Isom\Context\Environment.is: 144]
objectbound Isom.Base.String Isom.Context.Environment.GetOperationMode ( )

Ermittelt den Betriebsmodus, in dem sich die Anwendung befindet.

Rückgabe:
Betriebsmodus der Anwendung.
[Isom\Context\Environment.is: 236]
objectbound Isom.Base.Number Isom.Context.Environment.GetVciChannelCount ( )

Ermittelt die Anzahl der Kanäle des Fahrzeugzugangs.

Rückgabe:
Die Anzahl der Kanäle des Fahrzeugzugangs.
[Isom\Context\Environment.is: 219]
objectbound Isom.Base.StringDictionary Isom.Context.Environment.GetVciChannelData ( Isom.Base.Number index )

Ermittelt die Daten eines Kanals des Fahrzeugzugangs.

Parameter:
index der Index [ 0 ... (GetVciChannelCount()-1) ]
Rückgabe:
Die Daten eines Kanals des Fahrzeugzugangs.
[Isom\Context\Environment.is: 228]
objectbound Isom.Base.String Isom.Context.Environment.GetVciConnectionQuality ( )

Ermittelt die Qualität der Verbindung zum Fahrzeugzugang.

Rückgabe:
Die Qualität der Verbindung.
[Isom\Context\Environment.is: 211]
objectbound Isom.Base.String Isom.Context.Environment.GetVciConnectionType ( )

Ermittelt Art der Verbindung zum Fahrzeugzugang (zum Beispiel Ethernet oder WLAN).

Rückgabe:
Die Art der Verbindung.
[Isom\Context\Environment.is: 203]
objectbound Isom.Base.String Isom.Context.Environment.GetVciGateway ( )

Ermittelt das Gateway der Netzwerkverbindung des Fahrzeugzugangs.

Rückgabe:
Das Gateway.
[Isom\Context\Environment.is: 195]
objectbound Isom.Base.String Isom.Context.Environment.GetVciIp ( )

Ermittelt die IP-Adresse des Fahrzeugzugangs.

Rückgabe:
Die IP-Adresse des Fahrzeugzugangs.
[Isom\Context\Environment.is: 152]
objectbound Isom.Base.String Isom.Context.Environment.GetVciMac ( )

Ermittelt die MAC-Adresse des Fahrzeugzugangs.

Rückgabe:
Die MAC-Adresse des Fahrzeugzugangs.
[Isom\Context\Environment.is: 160]
objectbound Isom.Base.String Isom.Context.Environment.GetVciName ( )

Ermittelt den Namen des Fahrzeugzugangs.

Rückgabe:
Der Name des Fahrzeugzugangs.
[Isom\Context\Environment.is: 179]
objectbound Isom.Base.String Isom.Context.Environment.GetVciNetmask ( )

Ermittelt die Maske der Netzwerkverbindung des Fahrzeugzugangs.

Rückgabe:
Die Netzmaske.
[Isom\Context\Environment.is: 187]
objectbound Isom.Base.Number Isom.Context.Environment.GetVciState ( )

Ermittelt den Zustand des Fahrzeugzugangs.

Rückgabe:
1, wenn das VCI erreichbar ist, 0, wenn das VCI nicht erreichbar ist.
[Isom\Context\Environment.is: 171]
objectbound Isom.Base.String Isom.Context.Environment.GetVehiclePreparationState ( )

Abfrage der Fortschritts-Phase der Fachdienste.

Die Ergebniswerte sind fachdienstabhängig und sind in den herstellerspezifischen Begleitdokumenten unter dem Schlagwort 'Fortschritts-Phasen' zu finden.

Fachdienstübergreifend bedeutet eine leere Zeichenkette als Ergebniswert, dass die Fortschrittsinformationen zwar ermittelt werden, jedoch keiner Phase zugeordnet werden konnten.

     Boolean OnEnvironmentUpdate()
     {
         // ...

         Environment env = Environment.GetInstance();

         String prepState = env.GetVehiclePreparationState ();
         // anzuzeigenden, übersetzbaren Text bestimmen
         String prepStateText = prepState.Clone ();
         switch (prepState)
         {
             case "GetEcuInfo":
                 prepStateText = Texts.PROGRESS_GET_ECU_INFO;
             case "PrepareVehicleForFlash":
                 prepStateText = Texts.PROGRESS_PREPARE_VEHICLE_FOR_FLASH;
             // ...
             default:
                 ;
         }

         // abgelegte ID der Meldung holen
         Number progressId = Number.GetGlobal (Consts.GLOBALKEY_PREPSTATEID);

         // Es wird bereits eine Meldung angezeigt
         if (progressId.IsVoid ().Not ())
         {
             Helpers.UpdateProgressText (progressId, prepStateText);
         }

         // ...
     }
Rückgabe:
Name der Fortschritts-Phase, in der sich die Vehicleproxy-Fachdienste befinden.
[Isom\Context\Environment.is: 304]
objectbound Isom.Base.Boolean Isom.Context.Environment.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Context\Environment.is: 323]
Isom.Context.Environment Isom.Context.Environment.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Context\Environment.is: 334]


für Serviceautoren

Isom.Context.FutureVehicleContext

Namensraum Isom.Context.FutureVehicleContext

Fachobjekt für den Soll-Kontext Mehr...

Funktionen
Isom.Context.FutureVehicleContext | GetInstance()

Ermittelt den für diese ISOM-Sitzung gültigen Soll-Fahrzeugkontext.

Getters/Setters

Zugriff auf Objektbestandteile des Soll-Kontexts.

Isom.Context.EcuList | GetEcus()

Ermittelt die Soll-Steuergeräteliste.

Isom.Context.EcuList | GetEcusByBus(Isom.Base.String busName)

Liefert die Liste aller Steuergeräte, die an den Bus mit dem übergebenen Namen angeschlossen sind.

Isom.Context.Ecu | GetGatewayByBus(Isom.Base.String busName)

Liefert das Gateway-Steuergerät des Busses mit dem übergebenen Namen.

Isom.Base.StringList | GetPossibleTargetVersions()

Ermittelt über die Logistik die möglichen Ziel-Integrationsstände.

Isom.Base.String | GetTargetVersion()

Ermittelt den aktuell eingestellten Soll-Integrationsstand für Logistikpläne.

Isom.Context.UserProfile | GetUserProfile()

Ermittelt das Benutzerprofil.

Isom.Context.VehicleOrder | GetVehicleOrderClone()

Ermittelt eine Kopie des Soll-Fahrzeugauftrags.

Isom.Base.Boolean | SetCurrentOemVersion(Isom.Base.String currentVersion)

Setzt den Wert der aktuellen Versionskennung für den Soll-Kontext.

Isom.Base.Boolean | SetEcus(Isom.Context.EcuList newList)

Setzt die Soll-Steuergeräteliste.

Isom.Base.Boolean | SetTargetVersion(Isom.Base.String newGoalVersion)

Setzt den für Logistikpläne zu verwendenden Soll-Integrationsstand.

Fahrzeugzugriff

Zugriff auf das Fahrzeug.

Isom.Base.StringDictionary | RunProcess(Isom.Base.String processName, Isom.Base.StringDictionary arguments)

Ruft einen benannten Sonderprozess auf.

Planung, FA-Änderungen (Umrüstungen)

Verwendung des ISOM Planungs-Subsystems und der Logistikfunktionalität der Fachdiensteanbindung.

Isom.Base.Boolean | CalcFinalFutureContext()

Berechnet einen neuen Soll-Kontext unter Berücksichtigung von Aktionen, die schon im Plan sind.

Isom.Base.Boolean | CalcNewFutureContext()

Berechnet einen neuen Soll-Kontext, der die bisherige Planung berücksichtigt.

Isom.Base.Boolean | ChangeVehicleOrder(Isom.Context.VehicleOrder newVo)

Plant die Änderungen, um das Fahrzeug vom aktuellen Soll-Fahrzeugauftrag in den vorgegebenen neuen Soll- Fahrzeugauftrag zu überführen.

Isom.Base.Boolean | GeneratePlan()

Erzeugt einen nativen Therapieplan, welcher den Ist-Kontext in diesen Soll-Kontext überführt.

Isom.Base.Boolean | RecalcPlanAfterReassembly(Isom.Base.String vin7)

Berechnet alle Logistik-(Teil-)Pläne im Therapieplan neu und führt vorige, ggf.

Isom.Base.Boolean | ResetFutureContext()

Initialisiert den Soll-Kontext neu und leert den Therapieplan

Eigenschaften

Typischerweise herstellerabhängige Datenwerte, die das Fahrzeug charakterisieren. Für baureihenspezifische Property-Namen siehe herstellerspezifisches Begleitdokument.

Isom.Base.String | GetDisplayProp(Isom.Base.String propName)

Setzt den Wert der vorgegebenen Anzeigeeigenschaft für das Fahrzeug.

Isom.Base.StringList | GetDisplayPropNames()

Liefert die Namen aller Anzeige-Eigenschaften für den Soll-Kontext des Fahrzeugs.

Isom.Base.String | GetProp(Isom.Base.String propName)

Ermittelt den Wert der vorgegebenen Eigenschaft (property) für das Fahrzeug.

Isom.Base.StringList | GetPropNames()

Liefert die Namen aller technischen Eigenschaften für den Soll-Kontext des Fahrzeugs.

Isom.Context.EcuList | GetSoftwareVersionEcus()

Liefert eine Liste der Steuergeräte, von denen der Softwarezustand des Fahrzeugs ermittelt werden kann.

Isom.Context.EcuList | GetVehicleConfigurationEcus()

Liefert eine Liste der Steuergeräte, von denen die Fahrzeugmerkmale ermittelt werden können.

Isom.Context.EcuList | GetVinEcus()

Liefert eine Liste der Steuergeräte, von denen die Fahrgestellnummer ermittelt werden kann.

Isom.Base.Boolean | SetDisplayProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt den Wert der vorgegebenen Anzeigeeigenschaft für das Fahrzeug.

Isom.Base.Boolean | SetProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt den Wert der vorgegebenen Eigenschaft (property) für das Fahrzeug.

Logische Fahrzeuge und Überarbeitungsstände

Informationen zu logischen Fahrzeugen als Teile des Fahrzeugkontexts, über die Teilbordnetze des Fahreugs separat angesprochen werden können sowie zu Überarbeitungsstände, die den Verbau des Fahrzeugs charakterisieren.
(Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).)

Isom.Context.LogicalVehicleList | GetLogicalVehicles()

Ermittelt die Liste verwendbarer logischer Fahrzeuge.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Context.FutureVehicleContext | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Context.FutureVehicleContext | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Hauptaufgabe des Fachobjekts FutureVehicleContext ist es, die Ziel-Informationen für die Logistikplanung bereitzustellen.

Weiterhin bestimmen die Steuergeräte in Isom.Context.FutureVehicleContext.GetEcus() die SG-Anzeige im Client.

Quelldateien:

  • Isom\Context\FutureVehicleContext.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Context.FutureVehicleContext.CalcFinalFutureContext ( )

Berechnet einen neuen Soll-Kontext unter Berücksichtigung von Aktionen, die schon im Plan sind.

Zu beachten:
Verwendet für die Logistikabfrage den realen, zuletzt aus dem Fahrzeug gelesenen Ist-Kontext und den endgültigen Soll-Kontext der bisherigen Planung.
  1. Es wird ein nativer Logistikplan berechnet, wobei folgende Parameter einfließen:
    • Fahrzeugauftrag entsprechend CurrentVehicleContext als Ist-FA,
    • Fahrzeugauftrag inklusive eventueller geplanter Umrüstungen als Soll-FA,
    • Ist-SG-Liste entsprechend des während der identifizierung ermittelten CurrentVehicleContext,
    • Ist-Integrationsstände entsprechend des während der identifizierung ermittelten CurrentVehicleContext,
    • Soll-Integrationsstände entsprechend SetTargetVersion() bzw. neuester über die Logistik ermittelter Soll-Integrationsstand, wenn kein Integrationsstand per SetTargetVersion() explizit gesetzt,
    • Liste aller im Therapieplan manuell geplanten Aktionen als in die Logistik einzusteuernde Aktionen.
Der Logistikplan kann nachfolgend durch Aufruf von GeneratePlan() in den Therapieplan übertragen werden.
Verwendungshinweis:
Folgende Richtlinie gilt für die Auswahl der Planberechnungsfunktion:
  • CalcNewFutureContext() ist einzig dafür vorgesehen, um am Sitzungsanfang oder nach vollständiger Planabarbeitung einen neuen nativen Therapieplan zu generieren, der die bisherige Planung ersetzt.
  • CalcFinalFutureContext() ist einzig dafür vorgesehen, um vor Planabarbeitung einen Gesamt-Therapieplan inklusive aller manueller Aktionen und FA-Änderungen (Umrüstungen) zu generieren, der die vorherigen Therapiepläne ersetzt.
Verwendungsbeispiel:
   using Isom.Base.*
   ...
     Boolean CalculateFinalPlan()
     {
         ...

         // Soll-Kontext holen
         FutureVehicleContext futureContext = FutureVehicleContext.GetInstance ();

         if( futureContext.CalcFinalFutureContext().Failed() )
         {
            // Funktion fehlschlagen lassen
            return false;
         }

         ...
     }
Rückgabe:
'true', falls keine Fehler aufgetreten sind, 'false' sonst.
Siehe auch:
Isom.Context.FutureVehicleContext.CalcNewFutureContext() für einen anderen Modus der Logistikplanung
Isom.Context.FutureVehicleContext.GeneratePlan() für die Berücksichtigung des berechneten Kontexts im Therapieplan
[Isom\Context\FutureVehicleContext.is: 783]
objectbound Isom.Base.Boolean Isom.Context.FutureVehicleContext.CalcNewFutureContext ( )

Berechnet einen neuen Soll-Kontext, der die bisherige Planung berücksichtigt.

Zu beachten:
Der Logistikplan kann nachfolgend durch Aufruf von GeneratePlan() in den Therapieplan übertragen werden.
Verwendungshinweis:
Folgende Richtlinie gilt für die Auswahl der Planberechnungsfunktion:
  • CalcNewFutureContext() ist zusammen mit ResetFutureContext() einzig dafür vorgesehen, um am Sitzungsanfang oder nach vollständiger Planabarbeitung einen neuen nativen Therapieplan zu generieren, der die bisherige Planung ersetzt.
  • CalcFinalFutureContext() ist einzig dafür vorgesehen, um vor Planabarbeitung einen Gesamt-Therapieplan inklusive aller manueller Aktionen und FA-Änderungen (Umrüstungen) zu generieren, der die vorherigen Therapiepläne ersetzt.
Verwendungsbeispiel:
   using Isom.Base.*
   ...
     Boolean GetFutureContext()
     {
         ...

         // Soll-Kontext holen
         FutureVehicleContext futureContext = FutureVehicleContext.GetInstance ();

         if( futureContext.CalcNewFutureContext().Failed() )
         {
             // ggf. weitere Aufrufe nach Vervollständigung des Ist-Kontexts
         }

         ...
     }

     Boolean FinishPlan()
     {
         ...

        // Soll-Kontext holen
        FutureVehicleContext futureContext = FutureVehicleContext.GetInstance ();

        // Soll-Kontext neu initialisieren und Therapiepaln leeren
        if( futureContext.ResetFutureContext().Failed() )
         {
             ...
         }

        // abschließende Kontextprüfung nach Planausführung
        if (futureContext.CalcNewFutureContext ().Failed ())
        {
            // Funktion fehlgeschlagen lassen
            return false;
        }

        ...
     }
Rückgabe:
'true', falls keine Fehler aufgetreten sind, 'false' sonst.
Siehe auch:
Isom.Context.FutureVehicleContext.CalcFinalFutureContext() für einen anderen Modus der Logistikplanung
Isom.Context.FutureVehicleContext.ResetFutureContext() für die Neuinitialisierung des Soll-Kontexts
Isom.Context.FutureVehicleContext.GeneratePlan() für die Berücksichtigung des berechneten Kontexts im Therapieplan
Isom.Context.FutureVehicleContext.SetTargetVersion() für die (optionale) gezielte Beeinflussung des Ziel-Integrationsstands
[Isom\Context\FutureVehicleContext.is: 661]
objectbound Isom.Base.Boolean Isom.Context.FutureVehicleContext.ChangeVehicleOrder ( Isom.Context.VehicleOrder newVo )

Plant die Änderungen, um das Fahrzeug vom aktuellen Soll-Fahrzeugauftrag in den vorgegebenen neuen Soll- Fahrzeugauftrag zu überführen.

Dafür wird

  • der aktuelle Soll-Fahrzeugauftrag im ISOM-Fachmodell geändert,
  • über die Logisik ein Updateplan berechnet und
  • dieser dem aktuellen Therapieplan hinzugefügt.

Das Schreiben des neuen FAs in das Fahrzeug (FA-Abgleich) ist nicht Bestandteil dieses Plans. Bei Fehlschlagen bleibt der Soll-Fahrzeugauftrag ungeändert.

Verwendungsbeispiel:
   using Isom.Base.*
   ...
  FutureVehicleContext futureContext = FutureVehicleContext.GetInstance();
  VehicleOrder voCopy = futureContext.GetVehicleOrderClone().Clone();
  voCopy.Add( ... );
  futureContext.ChangeVehicleOrder( voCopy );
Rückgabe:
'true' gdw. erfolgreich, 'false' sonst.
[Isom\Context\FutureVehicleContext.is: 519]
objectbound Isom.Context.FutureVehicleContext Isom.Context.FutureVehicleContext.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Context\FutureVehicleContext.is: 1201]
objectbound Isom.Base.Boolean Isom.Context.FutureVehicleContext.GeneratePlan ( )

Erzeugt einen nativen Therapieplan, welcher den Ist-Kontext in diesen Soll-Kontext überführt.

Achtung:
Setzt einen vorherigen Aufruf von CalcNewFutureContext() oder CalcFinalFutureContext() voraus.
Zu beachten:
Für Top-Level-Aufrufe sollte stattdessen die verschattete Funktion Isom.Global.Processes.GeneratePlan() verwendet werden.
Rückgabe:
'true', falls keine Fehler aufgetreten sind, 'false' sonst.
[Isom\Context\FutureVehicleContext.is: 590]
objectbound Isom.Base.String Isom.Context.FutureVehicleContext.GetDisplayProp ( Isom.Base.String propName )

Setzt den Wert der vorgegebenen Anzeigeeigenschaft für das Fahrzeug.

Zu beachten:
Die unterstützten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.
Es gilt die Initialisierungsreihenfolge: ContextConfiguration -> CurrentVehicleContext -> FutureVehicleContext
Verwendungsbeispiel:
   // Consts.is:
   deftext INTERNAL CCPROP_VO_TYPE "VehicleOrderType"

   // *.is:
   using Isom.Base.*
   ...
      FutureVehicleContext fvc = FutureVehicleContext.GetInstance();
      String val = fvc.GetDisplayProp( Consts.CCPROP_VO_TYPE );
Rückgabe:
Wert der Eigenschaft.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Wert ungesetzt oder gleich "" ist.
Siehe auch:
Isom.Context.FutureVehicleContext.SetDisplayProp()
Isom.Context.FutureVehicleContext.GetProp()
[Isom\Context\FutureVehicleContext.is: 895]
objectbound Isom.Base.StringList Isom.Context.FutureVehicleContext.GetDisplayPropNames ( )

Liefert die Namen aller Anzeige-Eigenschaften für den Soll-Kontext des Fahrzeugs.

Es werden die Eigenschaftsnamen für die Anzeige-Eigenschaften (siehe Isom.Context.FutureVehicleContext.GetDisplayProp()) zurückgeliefert. Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

   Isom.Context.FutureVehicleContext fvc = Isom.Context.FutureVehicleContext.GetInstance();
   Isom.Base.StringList displayPropertyNames = fvc.GetDisplayPropNames();
   displayPropertyNames.Reset();
   while(displayPropertyNames.HasNext())
   {
     //Abfrage des Werts für den gelieferten Eigenschaftsnamen und z. B. Aufzeichnung ins Protokoll
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller Anzeige-Eigenschaften für den Soll-Kontext des Fahrzeugs.
Siehe auch:
Isom.Context.FutureVehicleContext.GetDisplayProp()
Datum:
letzte Änderung am 09.09.2010
[Isom\Context\FutureVehicleContext.is: 1002]
objectbound Isom.Context.EcuList Isom.Context.FutureVehicleContext.GetEcus ( )

Ermittelt die Soll-Steuergeräteliste.

Rückgabe:
Liste der identifizierten Steuergeräte.
[Isom\Context\FutureVehicleContext.is: 149]
objectbound Isom.Context.EcuList Isom.Context.FutureVehicleContext.GetEcusByBus ( Isom.Base.String busName )

Liefert die Liste aller Steuergeräte, die an den Bus mit dem übergebenen Namen angeschlossen sind.

Die Liste umfasst auch das Gateway-Steuergerät des Busses (falls definiert).

   using Isom.Base.*

   FutureVehicleContext futureContext = FutureVehicleContext.GetInstance();
   EcuList ecusInBus = futureContext.GetEcusByBus("BUS-NAME");
Rückgabe:
Liste der an den Bus angeschlossenen Steuergeräte oder Void, falls der Bus oder seine Steuergeräte nicht ermittelt werden konnten.
[Isom\Context\FutureVehicleContext.is: 369]
objectbound Isom.Context.Ecu Isom.Context.FutureVehicleContext.GetGatewayByBus ( Isom.Base.String busName )

Liefert das Gateway-Steuergerät des Busses mit dem übergebenen Namen.

Das Gateway eines Busses wird in der ISOM-Fahrzeugbeschreibung festgelegt.

   using Isom.Base.*

   FutureVehicleContext futureContext = FutureVehicleContext.GetInstance();
   Ecu gateway = futureContext.GetGatewayByBus("BUS-NAME");
Rückgabe:
Benutzerprofil oder Void.
[Isom\Context\FutureVehicleContext.is: 388]
Isom.Context.FutureVehicleContext Isom.Context.FutureVehicleContext.GetInstance ( )

Ermittelt den für diese ISOM-Sitzung gültigen Soll-Fahrzeugkontext.

Verwendungsbeispiel:
   using Isom.Base.*
   using Isom.Context.FutureVehicleContext;
   ...
      FutureVehicleContext ftx = FutureVehicleContext.GetInstance();
Rückgabe:
Die für diese ISOM-Sitzung singuläre Kontext-Konfiguration.
[Isom\Context\FutureVehicleContext.is: 133]
objectbound Isom.Context.LogicalVehicleList Isom.Context.FutureVehicleContext.GetLogicalVehicles ( )

Ermittelt die Liste verwendbarer logischer Fahrzeuge.

   Isom.Context.FutureVehicleContext fvc = Isom.Context.FutureVehicleContext.GetInstance();
   Isom.Context.LogicalVehicleList fvl = fvc.GetLogicalVehicles();
Siehe auch:
Isom.Context.ContextConfiguration.GetLogicalVehicles
Isom.Context.CurrentVehicleContext.GetLogicalVehicles
Isom.Context.Ecu.GetLogicalVehicle
Isom.Plan.TherapyPlanAction.GetLogicalVehicles
Seit:
Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).
Rückgabe:
Isom.Context.LogicalVehicleList
Liste verwendbarer Logischer Fahrzeuge
Datum:
letzte Änderung am 29.06.2011
[Isom\Context\FutureVehicleContext.is: 1172]
Isom.Base.StringList Isom.Context.FutureVehicleContext.GetPossibleTargetVersions ( )

Ermittelt über die Logistik die möglichen Ziel-Integrationsstände.

Zu beachten:
Statische Funktion, damit frühzeitiger Aufruf ohne FutureVehicleContext-Instanzerzeugung möglich ist.
Verwendungsbeispiel:
    Boolean GetFutureContext()
    {
        FutureVehicleContext futureContext = FutureVehicleContext.GetInstance ();
        // ...

        // mögliche Ziel-Integrationsstände ermitteln
        StringList possibleVersions = FutureVehicleContext.TargetVersions();

        // semantisch größten Ziel-Integrationsstand bestimmen;
        possibleVersions.Reset();
        String futureVersion = possibleVersions.Next(); // ersten Wert als Vergleichsbasis
        while( possibleVersions.HasNext() )
        {
            String iLevelLoop = possibleVersions.Next();

            // Integrationsstände semantisch vergleichen
            Boolean isMax = Helpers.IsILevelGreaterOrEqual (iLevelLoop, futureVersion);
            if( isMax.IsVoid() ) // nicht vergleichbar
            {
                futureVersion = String.Void();
                break;
            }
            else if( isMax )
            {
                futureVersion = iLevelLoop;
            }
        }

        // max. Ziel-Integrationsstand setzen, wenn eindeutig ermittelt; sonst warnen und fortfahren
        if( futureVersion.IsVoid() )
        {
            // ... log warning ...
        }
        else
        {
            if( futureContext.SetTargetVersion( futureVersion ). Failed() )
            {
                // ... log warning ...
            }
            else
            {
                // ... log success ...
            }
        }

        // ...

   }
Rückgabe:
mögliche Ziel-Integrationsstände.
Siehe auch:
Isom.Context.FutureVehicleContext.SetTargetVersion()
[Isom\Context\FutureVehicleContext.is: 249]
objectbound Isom.Base.String Isom.Context.FutureVehicleContext.GetProp ( Isom.Base.String propName )

Ermittelt den Wert der vorgegebenen Eigenschaft (property) für das Fahrzeug.

Zu beachten:
Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.
Es gilt die Initialisierungsreihenfolge: ContextConfiguration -> CurrentVehicleContext -> FutureVehicleContext
Verwendungsbeispiel:
   // Consts.is:
   deftext INTERNAL CCPROP_VO_TYPE "VehicleOrderType"

   // *.is:
   using Isom.Base.*
   ...
      FutureVehicleContext fvc = ...;
      String val = fvc.GetProp( Consts.CCPROP_VO_TYPE );
Rückgabe:
Wert der Eigenschaft.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Wert ungesetzt oder gleich "" ist.
Siehe auch:
Isom.Context.Ecu.GetProp()
[Isom\Context\FutureVehicleContext.is: 826]
objectbound Isom.Base.StringList Isom.Context.FutureVehicleContext.GetPropNames ( )

Liefert die Namen aller technischen Eigenschaften für den Soll-Kontext des Fahrzeugs.

Es werden die Eigenschaftsnamen für die technischen Eigenschaften (siehe Isom.Context.FutureVehicleContext.GetProp()) zurückgeliefert. Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

   Isom.Context.FutureVehicleContext fvc = Isom.Context.FutureVehicleContext.GetInstance();
   Isom.Base.StringList propertyNames = fvc.GetPropNames();
   propertyNames.Reset();
   while(propertyNames.HasNext())
   {
     //Abfrage des Werts für den gelieferten Eigenschaftsnamen und z. B. Aufzeichnung ins Protokoll
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller technischen Eigenschaften für den Soll-Kontext des Fahrzeugs.
Siehe auch:
Isom.Context.FutureVehicleContext.GetProp()
Datum:
letzte Änderung am 09.09.2010
[Isom\Context\FutureVehicleContext.is: 968]
objectbound Isom.Context.EcuList Isom.Context.FutureVehicleContext.GetSoftwareVersionEcus ( )

Liefert eine Liste der Steuergeräte, von denen der Softwarezustand des Fahrzeugs ermittelt werden kann.

Die Funktion liefert eine Liste aller Steuergeräte, die folgende zwei Bedingungen erfüllen:

  1. Sie sind Elemente der Steuergeräte-Liste dieses Kontexts, die mit Isom.Context.FutureVehicleContext.GetEcus abgefragt wird.
  2. Sie sind in der Fahrzeugbeschreibung im Element "SoftwareVersionEcus" für die aktuell eingestellte Baureihengruppe angegeben.

      Isom.Context.FutureVehicleContext ftx = Isom.Context.FutureVehicleContext.GetInstance();
      Isom.Context.EcuList softwareVersionEcus = ftx.GetSoftwareVersionEcus();
      while(softwareVersionEcus.HasNext())
      {
        //...
      }
Rückgabe:
Isom.Context.EcuList
Steuergeräte, von denen der Softwarezustand des Fahrzeugs ermittelt werden kann.
Siehe auch:
Isom.Context.ContextConfiguration.GetSoftwareVersionEcus()
Isom.Context.CurrentVehicleContext.GetSoftwareVersionEcus()
Seit:
Eingeführt zu Version 6.1.2.0
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 11.06.2010
[Isom\Context\FutureVehicleContext.is: 1132]
objectbound Isom.Base.String Isom.Context.FutureVehicleContext.GetTargetVersion ( )

Ermittelt den aktuell eingestellten Soll-Integrationsstand für Logistikpläne.

Zu beachten:
Die Zielversion wird spätestens durch einen der folgenden Funktionsaufrufe festgelegt: * SetTargetVersion ODER * CalcNewFutureContext ODER * CalcFinalFutureContext
Verwendungsbeispiel:
   using Isom.Base.*
   ...
  FutureVehicleContext futureContext = FutureVehicleContext.GetInstance();
  String ilevel = futureContext.GetTargetVersion();
Rückgabe:
Soll-Integrationsstand.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Integrationsstand noch nicht ermittelt ist.
Siehe auch:
Isom.Context.FutureVehicleContext.SetTargetVersion()
[Isom\Context\FutureVehicleContext.is: 279]
objectbound Isom.Context.UserProfile Isom.Context.FutureVehicleContext.GetUserProfile ( )

Ermittelt das Benutzerprofil.

Rückgabe:
Benutzerprofil
[Isom\Context\FutureVehicleContext.is: 421]
objectbound Isom.Context.EcuList Isom.Context.FutureVehicleContext.GetVehicleConfigurationEcus ( )

Liefert eine Liste der Steuergeräte, von denen die Fahrzeugmerkmale ermittelt werden können.

Die Funktion liefert eine Liste aller Steuergeräte, die folgende zwei Bedingungen erfüllen:

  1. Sie sind Elemente der Steuergeräte-Liste dieses Kontexts, die mit Isom.Context.FutureVehicleContext.GetEcus abgefragt wird.
  2. Sie sind in der Fahrzeugbeschreibung im Element "VehicleConfigurationEcus" für die aktuell eingestellte Baureihengruppe angegeben.

      Isom.Context.FutureVehicleContext ftx = Isom.Context.FutureVehicleContext.GetInstance();
      Isom.Context.EcuList vcEcus = ftx.GetVehicleConfigurationEcus();
      while(vcEcus.HasNext())
      {
        //...
      }
Rückgabe:
Isom.Context.EcuList
Steuergeräte, von denen die Fahrzeugmerkmale ermittelt werden können.
Siehe auch:
Isom.Context.ContextConfiguration.GetVehicleConfigurationEcus()
Isom.Context.CurrentVehicleContext.GetVehicleConfigurationEcus()
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 11.06.2010
[Isom\Context\FutureVehicleContext.is: 1088]
objectbound Isom.Context.VehicleOrder Isom.Context.FutureVehicleContext.GetVehicleOrderClone ( )

Ermittelt eine Kopie des Soll-Fahrzeugauftrags.

Zu beachten:
Der echte Fahrzeugauftrag kann nicht direkt manipuliert werden, sondern nur über ChangeVehicleOrder() inklusive Logistikberechnung.
Verwendungsbeispiel:
   using Isom.Base.*
   ...
  FutureVehicleContext futureContext = futureContext.GetInstance();
  VehicleOrder voCopy = futureContext.GetVehicleOrderClone().Clone();
  voCopy.Add( ... );
  futureContext.ChangeVehicleOrder( voCopy );
Rückgabe:
Soll-Fahrzeugauftrag (Clone).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Fahrzeugauftrag noch nicht ermittelt ist.
[Isom\Context\FutureVehicleContext.is: 412]
objectbound Isom.Context.EcuList Isom.Context.FutureVehicleContext.GetVinEcus ( )

Liefert eine Liste der Steuergeräte, von denen die Fahrgestellnummer ermittelt werden kann.

Die Funktion liefert eine Liste aller Steuergeräte, die folgende zwei Bedingungen erfüllen:

  1. Sie sind Elemente der Steuergeräte-Liste dieses Kontexts, die mit Isom.Context.FutureVehicleContext.GetEcus abgefragt wird.
  2. Sie sind in der Fahrzeugbeschreibung im Element "VinEcus" für die aktuell eingestellte Baureihengruppe angegeben.

      Isom.Context.FutureVehicleContext ftx = Isom.Context.FutureVehicleContext.GetInstance();
      Isom.Context.EcuList vinEcus = ftx.GetVinEcus();
      while(vinEcus.HasNext())
      {
        //...
      }
Rückgabe:
Isom.Context.EcuList
Steuergeräte, von denen die Fahrgestellnummer ermittelt werden kann.
Siehe auch:
Isom.Context.ContextConfiguration.GetVinEcus()
Isom.Context.CurrentVehicleContext.GetVinEcus()
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 11.06.2010
[Isom\Context\FutureVehicleContext.is: 1046]
objectbound Isom.Base.Boolean Isom.Context.FutureVehicleContext.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Context\FutureVehicleContext.is: 1193]
objectbound Isom.Base.Boolean Isom.Context.FutureVehicleContext.RecalcPlanAfterReassembly ( Isom.Base.String vin7 )

Berechnet alle Logistik-(Teil-)Pläne im Therapieplan neu und führt vorige, ggf.

bereits teilweise ausgeführte Logistikpläne mit diesen zusammen. Der Aktionsplan wird aktualisiert und neu gestartet. Bereits abgearbeitete Aktionen verbleiben im Plan, werden jedoch nicht neu gestartet.

Die Funktion prüft außerdem das tatsächliche Vorhandensein von ein-/auszubauenden Steuergeräten.

Verwendung: Geführter Tausch, nach der Durchführung von Umbauten am Fahrzeug.

Verwendungsbeispiel:
   using Isom.Base.*
   ...
     Boolean DoRecalcPlanAfterReassembly (TherapyPlanAction action)
     {
         // Fahrgestellnummer ermitteln
         String vin = IdentVin ();
         String vin7;

         if( vin.Length().Gt( 7 ) )
         {
             Number index = vin.Length().Sub( 7 );
             vin7 = vin.Substring( index, -1 );
         }

         // Soll-Kontext holen
         FutureVehicleContext futureContext = FutureVehicleContext.GetInstance ();
         // Plan neu berechnen nach Umbau
         if (futureContext.RecalcPlanAfterReassembly (vin7).Failed ())
         {
             ...
             return false;
         }
         return true;
     }
Parameter:
vin7 7-stellige FgNr des neu identifizierten Fahrzeugs.
Rückgabe:
'true' gdw. erfolgreich, 'false' sonst.
[Isom\Context\FutureVehicleContext.is: 567]
objectbound Isom.Base.Boolean Isom.Context.FutureVehicleContext.ResetFutureContext ( )

Initialisiert den Soll-Kontext neu und leert den Therapieplan

Der Aufruf bewirkt folgende Änderungen an Kontexten und Plänen:

  1. der bisherige Aktionsplan wird verworfen,
  2. der Therapieplan wird geleert,
  3. der Sollkontext wird neu initialisiert
  4. der Soll-Fahrzeugauftrag sowie die Soll-SG-Liste werden auf den letzten aus dem Fahrzeug gelesenen / importierten / vom Autor gesetzten Zustand entsprechend CurrentVehicleContext gebracht.

Achtung:
Alle vor Aufruf eventuell vorgenommenen Änderungen am Fahrzeugauftrag, am Therapie- und am Aktionsplan gehen durch den Aufruf verloren, d.h. die Kontextfortschreibung beginnt mit CurrentVehicleContext als Ausgangspunkt von vorn.
Verwendungshinweis:
Diese Funktion soll vor dem Aufruf von CalcNewFutureContext() aufgerufen werden.
Verwendungsbeispiel:
    // Entfernen aller Aktionen aus dem Maßnahmenplan wird
     // rückgängig gemacht
     Boolean RestoreNativePlan(Isom.Plan.TherapyPlanAction action)
     {
         // ...

         // Soll-Kontext holen
         Isom.Context.FutureVehicleContext futureContext =
             Isom.Context.FutureVehicleContext.GetInstance ();

     // Soll-Kontext und Pläne leeren
         if( futureContext.ResetFutureContext().Failed() )
         {
       // Fehler protokollieren
             Isom.Sys.Log.Error("", "...");

       // ggf. weitere Maßnahmen zur Fehlerbehandlung
         }

     // Soll-Kontext neu berechnen
         if( futureContext.CalcNewFutureContext().Failed() )
         {
       // Fehler protokollieren
             Isom.Sys.Log.Error("", "...");

       // ggf. weitere Maßnahmen zur Fehlerbehandlung
         }

         // ...
     }
Siehe auch:
Isom.Context.FutureVehicleContext.CalcNewFutureContext() für einen Modus einer neuen Logistikplanung
[Isom\Context\FutureVehicleContext.is: 722]
objectbound Isom.Base.StringDictionary Isom.Context.FutureVehicleContext.RunProcess | ( | Isom.Base.String | processName,
 |  | Isom.Base.StringDictionary | arguments
 | ) |  |

Ruft einen benannten Sonderprozess auf.

Verwendungsbeispiel:
   using Isom.Base.*
   using Isom.Context.*;
   ...
      FutureVehicleContext fvc = FutureVehicleContext.GetInstance();
      StringDictionary args = StringDictionary.CreateStringDictionary();
      String processName = ...;
      ...
      StringDictionary result = fvc.RunProcess(processName, args);
Rückgabe:
'true' Ein prozessspezifisches Wörterbuch der Aufrufergebnisse.
Ausnahmebehandlung:
Wenn der aufgerufene Sonderprozess nicht implementiert ist.
Wenn der aufgerufene Sonderprozess fehlgeschlagen ist.
[Isom\Context\FutureVehicleContext.is: 476]
objectbound Isom.Base.Boolean Isom.Context.FutureVehicleContext.SetCurrentOemVersion ( Isom.Base.String currentVersion )

Setzt den Wert der aktuellen Versionskennung für den Soll-Kontext.

Parameter:
currentVersion Die aktuelle Versionskennung der verwendeten Werkstattapplikation.
Verwendungsbeispiel:
   using Isom.Base.*;
   using Isom.Sys.*;
   ...
   FutureVehicleContext futureContext = FutureVehicleContext.GetInstance();
   String currentOemVersion = VersionInfo.GetOemVersion();
   futureContext.SetCurrentOemVersion(currentOemVersion);
Rückgabe:
'true', falls die Versionskennung darüber hinaus ins Fahrzeug geschrieben werden konnte, 'false' sonst. Gibt daher aktuell immer 'false' zurück, da ein Speichern im Fahrzeug zur Zeit nicht implementiert ist.
[Isom\Context\FutureVehicleContext.is: 443]
objectbound Isom.Base.Boolean Isom.Context.FutureVehicleContext.SetDisplayProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt den Wert der vorgegebenen Anzeigeeigenschaft für das Fahrzeug.

Zu beachten:
Die unterstützten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.
Es gilt die Initialisierungsreihenfolge: ContextConfiguration -> CurrentVehicleContext -> FutureVehicleContext
Das Setzen einer Anzeigeeigenschaft (display property) im Soll-Fahrzeugkontext wirkt sich konventionsmäßig immer auf alle im System bekannten Fahrzeug-Kontexte aus (transparentes Autoren-Property-Modell), d.h. autorengesetzte Eigenschaften haben globalen Charakter und unterliegen keiner Einfügehistorie.
Verwendungsbeispiel:
   // Consts.is:
   deftext INTERNAL CCPROP_VO_TYPE "VehicleOrderType"
   deftext MESSAGE VO_MSG "Fahrzeugauftrag"

   // *.is:
   using Isom.Base.*
   ...
      FutureVehicleContext fvc = FutureVehicleContext.GetInstance();
      if( fvc.GetDisplayProp( Consts.CCPROP_VO_TYPE ).IsVoid() )
        fvc.SetDisplayProp( Consts.CCPROP_VO_TYPE, VO_MSG );
Rückgabe:
'true' nach erfolgreichem Setzen. 'false' niemals.
Siehe auch:
Isom.Context.FutureVehicleContext.GetDisplayProp()
[Isom\Context\FutureVehicleContext.is: 934]
objectbound Isom.Base.Boolean Isom.Context.FutureVehicleContext.SetEcus ( Isom.Context.EcuList newList )

Setzt die Soll-Steuergeräteliste.

Zu beachten:
Die Soll-Steuergeräteliste wird vom ISOM-Kern bei Erstzugriff auf den FutureVehicleContext.GetInstance() anhand der Ist-SG-Liste initialisiert, so dass eine Nutzung von FutureVehicleContext.SetEcus() nur in Ausnahmefällen notwendig ist.
Verwendungsbeispiel:
   using Isom.Base.*
   using Isom.Context.EcuList;
   ...
    Boolean CompleteFurturEcuList()
    { ...
      EcuList ecuList = currentContext.GetEcus();
      Ecu newAggregate = Ecu.CreateNewByAddress( -123 );
      ecuList.Add( newAggregate );
      futureContect.SetEcus( ecuList );
    }
Rückgabe:
Immer true, solange keine Exceptions aufgetreten.
[Isom\Context\FutureVehicleContext.is: 178]
objectbound Isom.Base.Boolean Isom.Context.FutureVehicleContext.SetProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt den Wert der vorgegebenen Eigenschaft (property) für das Fahrzeug.

Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Zu beachten:
Es gilt die Initialisierungsreihenfolge: ContextConfiguration -> CurrentVehicleContext -> FutureVehicleContext
Das Setzen einer Eigenschaft (property) im Soll-Fahrzeugkontext wirkt sich konventionsmäßig immer auf alle im System bekannten Fahrzeug-Kontexte aus (transparentes Autoren-Property-Modell), d.h. autorengesetzte Eigenschaften haben globalen Charakter und unterliegen keiner Einfügehistorie.
Verwendungsbeispiel:
   // Consts.is:
   deftext INTERNAL CCPROP_VO_TYPE "VehicleOrderType"

   // *.is:
   using Isom.Base.*
   ...
      FutureVehicleContext fvc = ...;
      if( fvc.GetProp( Consts.CCPROP_VO_TYPE ).IsVoid() )
        fvc.SetProp( Consts.CCPROP_VO_TYPE, "FA" );
Rückgabe:
liefert immer 'true'.
Siehe auch:
Isom.Context.Ecu.GetProp()
[Isom\Context\FutureVehicleContext.is: 863]
objectbound Isom.Base.Boolean Isom.Context.FutureVehicleContext.SetTargetVersion ( Isom.Base.String newGoalVersion )

Setzt den für Logistikpläne zu verwendenden Soll-Integrationsstand.

Verwendungsbeispiel:
    Boolean GetFutureContext()
    {
        FutureVehicleContext futureContext = FutureVehicleContext.GetInstance ();
        // ...

        StringList possibleVersions = FutureVehicleContext.GetPossibleTargetVersions();
        // mögliche Ziel-Integrationsstände ermitteln

        // semantisch größten Ziel-Integrationsstand bestimmen;
        possibleVersions.Reset();
        String futureVersion = possibleVersions.Next(); // ersten Wert als Vergleichsbasis
        while( possibleVersions.HasNext() )
        {
            String iLevelLoop = possibleVersions.Next();

            // Integrationsstände semantisch vergleichen
            Boolean isMax = Helpers.IsILevelGreaterOrEqual (iLevelLoop, futureVersion);
            if( isMax.IsVoid() ) // nicht vergleichbar
            {
                futureVersion = String.Void();
                break;
            }
            else if( isMax )
            {
                futureVersion = iLevelLoop;
            }
        }

        // max. Ziel-Integrationsstände setzen, wenn eindeutig ermittelt; sonst warnen und fortfahren
        if( futureVersion.IsVoid() )
        {
            // ... log warning ...
        }
        else
        {
            if( futureContext.SetTargetVersion( futureVersion ). Failed() )
            {
                // ... log warning ...
            }
            else
            {
                // ... log success ...
            }
        }

        // ...

   }
Rückgabe:
Immer true, solange keine Exceptions aufgetreten.
Siehe auch:
Isom.Context.FutureVehicleContext.GetTargetVersion()
Isom.Context.FutureVehicleContext.GetPossibleTargetVersions()
Isom.Context.FutureVehicleContext.SetCurrentOemVersion()
[Isom\Context\FutureVehicleContext.is: 348]
Isom.Context.FutureVehicleContext Isom.Context.FutureVehicleContext.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Context\FutureVehicleContext.is: 1212]


für Serviceautoren

Isom.Context.LogicalUnit

Namensraum Isom.Context.LogicalUnit

Repräsentiert eine logische Einheit Mehr...

Funktionen
Isom.Context.LogicalUnit | CreateNew()

Erzeugt eine Instanz von LogicalUnit

Elementoperationen

Funktionen, die für das Setzen und Auslesen von Informationen einer logischen Einheit verantwortlich sind.

Isom.Base.String | GetCategory()

Fragt die Kategorie ab, zu der diese logische Einheit gehört

Isom.Base.String | GetKey()

Fragt den Schlüssel einer logischen Einheit ab

Isom.Plan.OrderingInfoList | GetOrderingInfo()

Fragt die Bestellinformationen dieser logischen Einheit ab

Isom.Base.String | GetProp(Isom.Base.String propName)

Fragt eine autorendefinierte Eigenschaft der logischen Einheit ab

Isom.Base.StringList | GetPropNames()

Diese Funktion ruft eine Liste der Bezeichnungen aller autorendefinierten Eigenschaften des Objekts ab.

Isom.Base.StringList | GetStates()

Ruft eine Liste aller Zustände ab, in denen sich die logische Einheit befindet

Isom.Base.Version | GetVersion()

Fragt die Versionsnummer der logischen Einheit ab

Isom.Base.Boolean | InvalidateProp(Isom.Base.String propName)

Löscht eine autorendefinierte Eigenschaft der logischen Einheit

Isom.Base.Boolean | IsInState(Isom.Base.String state)

Prüft, ob sich die logische Einheit in einem angegebenen Zustand befindet

Isom.Base.Boolean | SetCategory(Isom.Base.String category)

Legt die Kategorie fest, zu der diese logische Einheit gehört

Isom.Base.Boolean | SetKey(Isom.Base.String key)

Legt den Schlüssel einer logischen Einheit fest

Isom.Base.Boolean | SetOrderingInfo(Isom.Plan.OrderingInfoList orderingInfo)

Legt die Bestellinformationen dieser logischen Einheit fest

Isom.Base.Boolean | SetProp(Isom.Base.String propName, Isom.Base.String propValue)

Legt eine autorendefinierte Eigenschaft der logischen Einheit fest.

Isom.Base.Boolean | SetState(Isom.Base.String state)

Setzt den Zustand der logischen Einheit im passenden Zustandsautomaten

Isom.Base.Boolean | SetVersion(Isom.Base.Version version)

Legt die Versionsnummer dieser logischen Einheit fest

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Context.LogicalUnit | Clone()

Liefert eine tiefe Kopie des Objekts

Isom.Base.Boolean | IsVoid()

Prüft, ob die aktuelle Instanz das ungültige Objekt ist

Isom.Context.LogicalUnit | Void()

Liefert das ungültige Objekt des Namensraums Isom.Context.LogicalUnit

Ausführliche Beschreibung

Isom.Context.LogicalUnit repräsentiert eine logische Einheit, die im ISOM-Objektmodell eine Hardware- oder Softwarekomponente eines Steuergeräts modelliert.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Context\LogicalUnit.is

Dokumentation der Funktionen

objectbound Isom.Context.LogicalUnit Isom.Context.LogicalUnit.Clone ( )

Liefert eine tiefe Kopie des Objekts

Rückgabe:
Tiefe Kopie des aufgerufenen Objekts
[Isom\Context\LogicalUnit.is: 547]
Isom.Context.LogicalUnit Isom.Context.LogicalUnit.CreateNew ( )

Erzeugt eine Instanz von LogicalUnit

 //Instanz einer logischen Einheit erzeugen
 LogicalUnit logicalUnit = logicalUnit.CreateNew();
Rückgabe:
Eine Instanz der logischen Einheit
Category = Void-Objekt
Key = Void-Objekt
Version = 0.0.0.0
Ausnahmebehandlung:
keine
[Isom\Context\LogicalUnit.is: 103]
objectbound Isom.Base.String Isom.Context.LogicalUnit.GetCategory ( )

Fragt die Kategorie ab, zu der diese logische Einheit gehört

 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Kategorie der logischen Einheit setzen
 logicalUnit.SetCategory("SWFL");

 //Abfrage der Kategorie der logischen Einheit
 String category = logicalUnit.GetCategory();
Rückgabe:
Kategorie der logischen Einheit
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, wenn keine Kategorie festgelegt wurde.
[Isom\Context\LogicalUnit.is: 178]
objectbound Isom.Base.String Isom.Context.LogicalUnit.GetKey ( )

Fragt den Schlüssel einer logischen Einheit ab

 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Schlüssel für die logische Einheit setzen
 logicalUnit.SetKey("00000895");

 //Abfrage des Schlüssels der logischen Einheit
 String rev = logicalUnit.GetKey();
Rückgabe:
Schlüssel der logischen Einheit
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, wenn kein Schlüssel festgelegt wurde.
[Isom\Context\LogicalUnit.is: 134]
objectbound Isom.Plan.OrderingInfoList Isom.Context.LogicalUnit.GetOrderingInfo ( )

Fragt die Bestellinformationen dieser logischen Einheit ab

 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Erzeugt ein neues, leeres Objekt für eine Bestellalternative
 OrderingInfo orderInfo = OrderingInfo.CreateNew();

 //Typ des Liefermediums setzen
 orderInfo.SetMedium("CDROM");
 // Bestellinformationen befüllen
 ...

 //Liste von Bestellalternativen erzeugen
 OrderingInfoList orderingInfoList = OrderingInfoList.CreateOrderingInfoList();
 //Bestellinfo in die Liste hinzufügen
 orderingInfoList.Insert(orderInfo);

 //Bestellinformationen der logischen Einheit setzen
 logicalUnit.SetOrderingInfo(orderingInfoList);

 //Bestellinformationen der logischen Einheit abfragen
 OrderingInfoList logOrderingInfoList = logicalUnit.GetOrderingInfo();
Rückgabe:
Bestellinformationen der logischen Einheit
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, wenn keine Bestellinformationen festgelegt wurden.
[Isom\Context\LogicalUnit.is: 282]
objectbound Isom.Base.String Isom.Context.LogicalUnit.GetProp ( Isom.Base.String propName )

Fragt eine autorendefinierte Eigenschaft der logischen Einheit ab

 //Es wird mit diesem Beispiel BTLD_0000121F-006_010_000 gearbeitet
 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Eigenschaft 'DisplayText' setzen
 logicalUnit.SetProp("DisplayText", "BTLD_0000121F-006_010_000");

 // Eigenschaft abfragen
 String displayText = logicalUnit.GetProp("DisplayText");
Parameter:
propName Bezeichnung der autorendefinierten Eigenschaft
Rückgabe:
Wert der autorendefinierten Eigenschaft mit dem Namen propName
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, wenn keine autorendefinierte Eigenschaft propName festgelegt wurde
[Isom\Context\LogicalUnit.is: 343]
objectbound Isom.Base.StringList Isom.Context.LogicalUnit.GetPropNames ( )

Diese Funktion ruft eine Liste der Bezeichnungen aller autorendefinierten Eigenschaften des Objekts ab.

 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Eigenschaft 'DisplayText' setzen
 logicalUnit.SetProp("DisplayText", "BTLD_0000121F-006_010_000");
 //weitere Eigenschaften setzen
 ...

 //Liste der Bezeichnungen abfragen
 StringList propNames = logicalUnit.GetPropNames();
Rückgabe:
Liste der Bezeichnung aller autorendefinierten Eigenschaften
[Isom\Context\LogicalUnit.is: 421]
objectbound Isom.Base.StringList Isom.Context.LogicalUnit.GetStates ( )

Ruft eine Liste aller Zustände ab, in denen sich die logische Einheit befindet

 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Zustände setzen
 logicalUnit.SetState("Isom.Source.Logistics");
 logicalUnit.SetState("Isom.Execution.Failed");

 StringList states = logicalUnit.GetStates();
Rückgabe:
Liste aller Zustände, in denen sich die logische Einheit befindet
[Isom\Context\LogicalUnit.is: 517]
objectbound Isom.Base.Version Isom.Context.LogicalUnit.GetVersion ( )

Fragt die Versionsnummer der logischen Einheit ab

 LogicalUnit logicalUnit = LogicalUnit.CreateNew();
 //die Versionsnummer ist per Definition mit Nuller befüllt: 0.0.0.0

 //Abfrage der Versionsnummer der logischen Einheit
 Version logicalUnitVersion = logicalUnit.GetVersion();
Rückgabe:
Versionsnummer der logischen Einheit
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, wenn wenn zuvor das Void-Objekt als Version gesetzt wurde.
[Isom\Context\LogicalUnit.is: 220]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnit.InvalidateProp ( Isom.Base.String propName )

Löscht eine autorendefinierte Eigenschaft der logischen Einheit

 //Es wird mit diesem Beispiel BTLD_0000121F-006_010_000 gearbeitet
 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Eigenschaft 'DisplayText' setzen
 logicalUnit.SetProp("DisplayText", "BTLD_0000121F-006_010_000");

 //Eigenschaft löschen
 Boolean result = logicalUnit.InvalidateProp("DisplayText");
Parameter:
propName Bezeichnung der autorendefinierten Eigenschaft
Rückgabe:
true, wenn der Wert der autorendefinierten Eigenschaft gelöscht wurde oder nicht gesetzt war
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, wenn propName den Wert String.Void() hatte.
[Isom\Context\LogicalUnit.is: 398]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnit.IsInState ( Isom.Base.String state )

Prüft, ob sich die logische Einheit in einem angegebenen Zustand befindet

 //Es wird mit diesem Beispiel BTLD_0000121F-006_010_000 gearbeitet
 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Schlüssel setzen
 logicalUnit.SetKey("0000121F");

 //Kategorie setzen
 logicalUnit.SetCategory("BTLD");

 //Version erzeugen
 Version v = Version.Parse("006_010_000", "_");

 //Version hinzufügen
 logicalUnit.SetVersion(v);

 //Zustand setzen
 logicalUnit.SetState("Isom.Source.Ecu");

 Boolean result = logicalUnit.IsInState("Isom.Source.Ecu");
Parameter:
state Bezeichnung des Zustands
Rückgabe:
true, wenn sich die logische Einheit im angegebenen Zustand befindet; false, wenn sich die logische Einheit in einem anderen Zustand befindet
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der angegebene Zustand nicht gefunden wurde.
[Isom\Context\LogicalUnit.is: 496]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnit.IsVoid ( )

Prüft, ob die aktuelle Instanz das ungültige Objekt ist

Rückgabe:
true, wenn die aktuelle Instanz das ungültige Objekt ist
[Isom\Context\LogicalUnit.is: 537]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnit.SetCategory ( Isom.Base.String category )

Legt die Kategorie fest, zu der diese logische Einheit gehört

 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Kategorie der logischen Einheit setzen
 Boolean result = logicalUnit.SetCategory("SWFL");
Parameter:
category Kategorie der logischen Einheit
Rückgabe:
true, wenn die Kategorie erfolgreich gesetzt wurde
[Isom\Context\LogicalUnit.is: 200]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnit.SetKey ( Isom.Base.String key )

Legt den Schlüssel einer logischen Einheit fest

 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Schlüssel für die logische Einheit setzen
 Boolean result = logicalUnit.SetKey("00000895");
Parameter:
key Schlüssel der logischen Einheit
Rückgabe:
true, wenn der Schlüssel erfolgreich gesetzt wurde
[Isom\Context\LogicalUnit.is: 155]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnit.SetOrderingInfo ( Isom.Plan.OrderingInfoList orderingInfo )

Legt die Bestellinformationen dieser logischen Einheit fest

 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Erzeugt ein neues, leeres Objekt für eine Bestellalternative
 OrderingInfo orderInfo = OrderingInfo.CreateNew();

 //Typ des Liefermediums setzen
 orderInfo.SetMedium("CDROM");
 // Bestellinformationen befüllen
 ...

 //Liste von Bestellalternativen erzeugen
 OrderingInfoList orderingInfoList = OrderingInfoList.CreateOrderingInfoList();
 //Bestellinfo in die Liste hinzufügen
 orderingInfoList.Insert(orderInfo);

 //Bestellinformationen der logischen Einheit setzen
 logicalUnit.SetOrderingInfo(orderingInfoList);
Parameter:
orderingInfo Liste der möglichen Bestellalternativen.
Rückgabe:
true, wenn die möglichen Bestellalternativen erfolgreich festgelegt wurden.
[Isom\Context\LogicalUnit.is: 316]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnit.SetProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Legt eine autorendefinierte Eigenschaft der logischen Einheit fest.

Wurde der Wert zuvor bereits festgelegt, wird der vorherige Wert überschrieben.

 //Es wird mit diesem Beispiel BTLD_0000121F-006_010_000 gearbeitet
 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Eigenschaft 'DisplayText' setzen
 logicalUnit.SetProp("DisplayText", "BTLD_0000121F-006_010_000");
Parameter:
propName | Bezeichnung der autorendefinierten Eigenschaft
propValue | Wert der autorendefinierten Eigenschaft
Rückgabe:
true, wenn der Wert der autorendefinierten Eigenschaft übernommen wurde
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, wenn versucht wird, den Wert String.Void() für propValue zu übergeben. Zum Löschen einer autorendefinierten Eigenschaft wird LogicalUnit.InvalidateProp verwendet.
[Isom\Context\LogicalUnit.is: 371]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnit.SetState ( Isom.Base.String state )

Setzt den Zustand der logischen Einheit im passenden Zustandsautomaten

 //Es wird mit diesem Beispiel BTLD_0000121F-006_010_000 gearbeitet
 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Schlüssel setzen
 logicalUnit.SetKey("0000121F");

 //Kategorie setzen
 logicalUnit.SetCategory("BTLD");

 //Version erzeugen
 Version v = Version.Parse("006_010_000", "_");

 //Version hinzufügen
 logicalUnit.SetVersion(v);

 //Zustand setzen
 logicalUnit.SetState("Isom.Source.Ecu");
Parameter:
state vollqualifizierte Bezeichnung des Zustands
Rückgabe:
true, wenn der Zustand gesetzt wurde
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Angabe des Zustands nicht vollqualifiziert war.
[Isom\Context\LogicalUnit.is: 457]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnit.SetVersion ( Isom.Base.Version version )

Legt die Versionsnummer dieser logischen Einheit fest

 LogicalUnit logicalUnit = LogicalUnit.CreateNew();

 //Version erzeugen
 //Verwendung der Funktion Parse: sie wertet eine Zeichenkette aus,
 //die eine Versionsnummer enthält, und erzeugt daraus eine Instanz von Isom.Base.Version
 Version ver = Version.Parse( "2.10.13.5", "." );

 //Version in die logische Einheit hinzufügen
 Boolean result = logicalUnit.SetVersion(ver);
Parameter:
version Versionsnummer der logischen Einheit.
Rückgabe:
true, wenn die Versionsnummer erfolgreich gesetzt wurde.
[Isom\Context\LogicalUnit.is: 246]
Isom.Context.LogicalUnit Isom.Context.LogicalUnit.Void ( )

Liefert das ungültige Objekt des Namensraums Isom.Context.LogicalUnit

Rückgabe:
Ungültige Objekt des Namensraums Isom.Context.LogicalUnit
[Isom\Context\LogicalUnit.is: 557]


für Serviceautoren

Isom.Context.LogicalUnitList

Namensraum Isom.Context.LogicalUnitList

Listen logischer Einheiten des Typs Isom.Context.LogicalUnit Mehr...

Funktionen
Isom.Context.LogicalUnitList | CreateNew()

Erzeugt eine leere Liste logischer Einheiten

Spezielle Funktionen für Listen aus logischen Einheiten

Funktionen, die nur für Listen aus logischen Einheiten sind.

Isom.Base.Boolean | RemoveAll(Isom.Context.LogicalUnit pattern)

Entfernt alle Elemente aus der Liste, die ein Muster analog zur Funktion Select erfüllen

Isom.Context.LogicalUnitList | Select(Isom.Context.LogicalUnit pattern)

Liefert eine Liste aller logischen Einheiten in der aktuellen Instanz, die das angegebene Muster erfüllen.

Listenfunktionen

Isom.Context.LogicalUnit | At(Isom.Base.Number index)

Ruft das Element am angegebenen Index ab

Isom.Base.Boolean | Contains(Isom.Context.LogicalUnit pattern)

Prüft, ob die Liste ein Element mit dem angegebenen Muster analog zur Funktion Select enthält

Isom.Context.LogicalUnit | Current()

Ruft während einer Iteration das aktuelle Element ab

Isom.Base.Boolean | HasNext()

Prüft während einer Iteration, ob es ein weiteres Element in der Liste gibt, das noch nicht abgerufen wurde.

Isom.Base.Number | Insert(Isom.Context.LogicalUnit element)

Ruft das Element an einem angegebenen Index ab

Isom.Base.Boolean | IsEmpty()

Ruft ab, ob die Liste leer ist

Isom.Base.Number | Length()

Ruft die Anzahl der Elemente in der Liste ab

Isom.Context.LogicalUnit | Next()

Ruft das Element hinter der aktuellen Position des Iterators während einer Iteration ab und setzt die aktuelle Position des Iterators auf dieses Element

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt das Element am angegebenen Index aus der Liste

Isom.Base.Boolean | Reset()

Setzt die Position des Iterators vor das erste Element

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Context.LogicalUnitList | Clone()

Liefert eine tiefe Kopie der Liste

Isom.Base.Boolean | IsVoid()

Prüft, ob die aktuelle Instanz das ungültige Objekt ist

Isom.Context.LogicalUnitList | Void()

Liefert das ungültige Objekt des Namensraums Isom.Context.LogicalUnitList

Ausführliche Beschreibung

Isom.Context.LogicalUnitList repräsentiert Listen von logischen Einheiten (Isom.Context.LogicalUnit).

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Context\LogicalUnitList.is

Dokumentation der Funktionen

objectbound Isom.Context.LogicalUnit Isom.Context.LogicalUnitList.At ( Isom.Base.Number index )

Ruft das Element am angegebenen Index ab

Parameter:
index Nullbasierter Index des abzurufenden Elements
Rückgabe:
Element an Index index
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, falls index einen Index angibt, für den kein Element existiert
[Isom\Context\LogicalUnitList.is: 246]
objectbound Isom.Context.LogicalUnitList Isom.Context.LogicalUnitList.Clone ( )

Liefert eine tiefe Kopie der Liste

Rückgabe:
Tiefe Kopie des aufgerufenen Objekts
Ausnahmebehandlung:
Es wird immer das Void-Objekt geliefert
[Isom\Context\LogicalUnitList.is: 317]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnitList.Contains ( Isom.Context.LogicalUnit pattern )

Prüft, ob die Liste ein Element mit dem angegebenen Muster analog zur Funktion Select enthält

Parameter:
pattern Muster, für das ermittelt wird, ob ein passendes Element enthalten ist
Rückgabe:
true, wenn ein passendes Element in der Liste enthalten ist
[Isom\Context\LogicalUnitList.is: 272]
Isom.Context.LogicalUnitList Isom.Context.LogicalUnitList.CreateNew ( )

Erzeugt eine leere Liste logischer Einheiten

Rückgabe:
leere Liste logischer Einheiten
[Isom\Context\LogicalUnitList.is: 90]
objectbound Isom.Context.LogicalUnit Isom.Context.LogicalUnitList.Current ( )

Ruft während einer Iteration das aktuelle Element ab

Rückgabe:
Element, das während einer Iteration aktuell ist
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, falls der Iterator nicht auf ein Element zeigt. Ein Iterator zeigt nach einem Aufruf von Reset vor dem ersten Aufruf von Next nicht auf ein Element.
[Isom\Context\LogicalUnitList.is: 185]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnitList.HasNext ( )

Prüft während einer Iteration, ob es ein weiteres Element in der Liste gibt, das noch nicht abgerufen wurde.

Rückgabe:
true, falls es ein weiteres Element in der Liste gibt, das noch nicht abgerufen wurde
[Isom\Context\LogicalUnitList.is: 195]
objectbound Isom.Base.Number Isom.Context.LogicalUnitList.Insert ( Isom.Context.LogicalUnit element )

Ruft das Element an einem angegebenen Index ab

Parameter:
element das in die Liste einzufügende Element
Rückgabe:
Index, an dem das Element element eingefügt wurde
[Isom\Context\LogicalUnitList.is: 259]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnitList.IsEmpty ( )

Ruft ab, ob die Liste leer ist

Rückgabe:
true, wenn die Liste leer ist
[Isom\Context\LogicalUnitList.is: 229]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnitList.IsVoid ( )

Prüft, ob die aktuelle Instanz das ungültige Objekt ist

Rückgabe:
true, wenn die aktuelle Instanz das ungültige Objekt ist
[Isom\Context\LogicalUnitList.is: 305]
objectbound Isom.Base.Number Isom.Context.LogicalUnitList.Length ( )

Ruft die Anzahl der Elemente in der Liste ab

Rückgabe:
Anzahl der Elemente in der Liste
[Isom\Context\LogicalUnitList.is: 219]
objectbound Isom.Context.LogicalUnit Isom.Context.LogicalUnitList.Next ( )

Ruft das Element hinter der aktuellen Position des Iterators während einer Iteration ab und setzt die aktuelle Position des Iterators auf dieses Element

Rückgabe:
das nächste Element während der Iteration
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, falls die aktuelle Position des Iterators bereits das letzte Element der Liste ist.
[Isom\Context\LogicalUnitList.is: 209]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnitList.Remove ( Isom.Base.Number index )

Entfernt das Element am angegebenen Index aus der Liste

Parameter:
index Index des Elements, das aus der Liste entfernt werden soll
Rückgabe:
true, wenn das Element am Index index aus der Liste entfernt wurde
[Isom\Context\LogicalUnitList.is: 285]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnitList.RemoveAll ( Isom.Context.LogicalUnit pattern )

Entfernt alle Elemente aus der Liste, die ein Muster analog zur Funktion Select erfüllen

Parameter:
pattern Muster aller zu entfernenden Elemente
Rückgabe:
true, falls mindestens ein Element entfernt wurde
[Isom\Context\LogicalUnitList.is: 153]
objectbound Isom.Base.Boolean Isom.Context.LogicalUnitList.Reset ( )

Setzt die Position des Iterators vor das erste Element

Rückgabe:
true, wenn die Position des Iterators gesetzt wurde
[Isom\Context\LogicalUnitList.is: 172]
objectbound Isom.Context.LogicalUnitList Isom.Context.LogicalUnitList.Select ( Isom.Context.LogicalUnit pattern )

Liefert eine Liste aller logischen Einheiten in der aktuellen Instanz, die das angegebene Muster erfüllen.

 //  BTLD_00000660-003_159_001
 LogicalUnit logicalUnit = LogicalUnit.CreateNew();
 logicalUnit.SetCategory("BTLD");
 logicalUnit.SetKey("00000660");

 //Version erzeugen: 003_159_001
 Version version = Version.CreateNew();
 version.SetMajor(3);
 version.SetMinor(159);
 version.SetBuild(1);
 logicalUnit.SetVersion(version);

 //Liste der logischen Einheiten erzeugen
 LogicalUnitList list = LogicalUnitList.CreateNew();
 list.Insert(logicalUnit);

 //Suchmuster erzeugen
 LogicalUnit pattern = LogicalUnit.CreateNew();
 pattern.SetCategory("BTLD");

 //Suchmuster in der Liste der logischen Einheiten suchen
 LogicalUnitList result = list.Select(pattern);
Parameter:
pattern Logische Einheit, die das Suchmuster repräsentiert
Rückgabe:
Liste der logischen Einheiten, die das Suchmuster erfüllen
Ausnahmebehandlung:
Es wird das Void-Objekt geliefert, falls pattern das Void-Objekt war
[Isom\Context\LogicalUnitList.is: 140]
Isom.Context.LogicalUnitList Isom.Context.LogicalUnitList.Void ( )

Liefert das ungültige Objekt des Namensraums Isom.Context.LogicalUnitList

Rückgabe:
Ungültige Objekt des Namensraums Isom.Context.LogicalUnitList
Ausnahmebehandlung:
Es wird immer das Void-Objekt geliefert
[Isom\Context\LogicalUnitList.is: 329]


für Serviceautoren

Isom.Context.LogicalVehicle

Namensraum Isom.Context.LogicalVehicle

Fachobjekt für ein logisches Fahrzeug Mehr...

Funktionen
Zugriff auf Objektinstanzen

Namensraum-gebundene Funktionen zum Zugriff auf Objektinstanzen

Isom.Context.LogicalVehicleList | GetPossibleLogicalVehicles()

Liefert eine Liste aller in der ISOM-Fahrzeugbeschreibung für den aktuellen Baureihenverbund modellierten logischen Fahrzeuge.

Fachfunktionen für den Zugriff auf Objektattribute logischer Fahrzeuge

Zugriff auf Objektattribute, die auf Ebene logischer Fahrzeuge modelliert sind sowie auf Assoziationen logischer Fahrzeuge zu anderen Fachobjekten.

Isom.Base.String | GetName()

Liefert den Namen des logischen Fahrzeugs entsprechend ISOM-Fahrzeugbeschreibung.

Isom.Base.String | GetVehicleGeneration()

Liefert die Bordnetzgeneration des logischen Fahrzeugs entsprechend ISOM-Fahrzeugbeschreibung.

Isom.Base.Boolean | SetVehicleGeneration(Isom.Base.String vehicleGeneration)

Setzt die Bordnetzgeneration des logischen Fahrzeugs im Datenmodell.

Steuerung der Parallelausführung

Steuert (zusammen mit LogicalVehicleList.SetSequence), ob auf logische Fahrzeuge sequentiell oder parallel zugegriffen wird.

Isom.Base.Boolean | EnforceExclusive()

Verhindert den Wechsel des logischen Fahrzeugs durch ISOM.

Isom.Base.Boolean | ReleaseExclusive()

Erlaubt den Wechsel des logischen Fahrzeugs durch ISOM.

Fachfunktionen für alle Fahrzeugkontexte/Logischen Fahrzeuge

Fachfunktionen, die in gleicher Weise in allen Fahrzeugkontexten (CurrentVehicleContext, FutureVehicleContext) sowie in logischen Fahrzeugen (LogicalVehicle) zur Verfügung stehen.

Isom.Context.EcuList | GetEcus()

Fragt die Steuergeräteliste ab.

Isom.Base.StringDictionary | RunProcess(Isom.Base.String processName, Isom.Base.StringDictionary arguments)

Führt eine benannte OEM-Funktion aus.

Isom.Base.Boolean | SetEcus(Isom.Context.EcuList newList)

Setzt die Steuergeräteliste.

Fachfunktionen analog CurrentVehicleContext

Fachfunktionen, die auch in Isom.Context.CurrentVehicleContext (Gesamtfahrzeugsicht) zur Verfügung stehen.

Lesen aus dem Fahrzeug

Isom.Context.EcuList | IdentifyAllEcus()

Identifiziert alle Steuergeräte des logischen Fahrzeugs.

Isom.Base.Boolean | ReadDtcFromAllEcus()

Ermittelt die Fehlerspeichereinträge.

Isom.Base.Boolean | ReadUserProfile()

Ermittelt das Benutzerprofil des Fahrzeugs.

Isom.Base.Boolean | ReadVehicleOrder()

Ermittelt die vollständigen Fahrzeugmerkmale.

Isom.Base.Boolean | ReadVehicleOrderAdditionals()

Vervollständigt vom Fahrzeug gelesene Fahrzeugmerkmale mit Zusatzinformationen

Isom.Base.Boolean | ReadVehicleOrderPure()

Ermittelt die Fahrzeugmerkmale, wie sie vom Fahrzeug geliefert werden.

Isom.Base.Boolean | ReadVersions()

Ermittlung der Integrationsstände des Fahrzeugs.

Isom.Base.Boolean | ReadVin()

Ermittelt die Fahrgestellnummer

Schreiben in das Fahrzeug

Isom.Base.Boolean | ClearDtcInAllEcus()

Löscht die Fehlerspeichereinträge.

Isom.Base.Boolean | DeployAllVersions()

Schreibt alle Integrationsstände aus dem Datenmodell in das Fahrzeug.

Isom.Context.UserProfile | DeployUserProfile()

Schreibt das Benutzerprofil aus dem Sollkonntext in das Fahrzeug.

Isom.Base.Boolean | UserProfileChanged()

Prüft, ob das Benutzerprofil im Sollkontext Änderungen gegenüber dem Istkontext enthält.

Abfragen aus dem Datenmodell

Isom.Context.UserProfile | GetCurrentUserProfileClone()

Liefert das Benutzerprofil.

Fachfunktionen mit Logistikzugriff

Isom.Context.EcuList | GetExpectedEcus()

Ermittelt die Steuergeräte, die im logischen Fahrzeug verbaut sein sollten.

Eigenschaften

Typischerweise herstellerabhängige Datenwerte, die das Fahrzeug charakterisieren. Für baureihenspezifische Eigenschaftsnamen siehe herstellerspezifisches Begleitdokument.

Isom.Base.String | GetDisplayProp(Isom.Base.String propName)

Abfrage einer Anzeigeeigenschaft

Isom.Base.StringList | GetDisplayPropNames()

Liefert die Namen aller Anzeigeeigenschaften.

Isom.Base.String | GetProp(Isom.Base.String propName)

Abfrage einer technischen Eigenschaft

Isom.Base.StringList | GetPropNames()

Liefert die Namen aller technischen Eigenschaften für das logische Fahrzeug.

Isom.Base.Boolean | SetDisplayProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt eine Anzeigeeigenschaft

Isom.Base.Boolean | SetProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt eine technische Eigenschaft

Fachfunktionen analog FutureVehicleContext

Fachfunktionen, die auch in Isom.Context.FutureVehicleContext (Gesamtfahrzeugsicht) zur Verfügung stehen.

Isom.Context.UserProfile | GetFutureUserProfile()

Ermittelt das Benutzerprofil.

Isom.Base.StringList | GetPossibleTargetVersions()

Ermittelt über die Logistik die möglichen Ziel-Integrationsstände.

Isom.Base.String | GetTargetVersion()

Ermittelt den aktuell eingestellten Soll-Integrationsstand für Logistikpläne.

Isom.Base.Boolean | SetTargetVersion(Isom.Base.String newGoalVersion)

Setzt den für Logistikpläne zu verwendenden Soll-Integrationsstand.

Abfrage von Steuergerätefunktionen und -rollen

Abfrage von Steuergeräten, die im logischen Fahrzeug Sonderfunktionen tragen oder bestimmte Rollen (Master/Slave) tragen.

Isom.Context.EcuList | GetSoftwareVersionEcus()

Liefert eine Liste der Steuergeräte, von denen die Integrationsstände des Fahrzeugs ermittelt werden können.

Isom.Context.EcuList | GetSpecialFunctionEcus(Isom.Base.String functionName)

Liefert eine Liste der Steuergeräte mit besonderen Funktionsmerkmalen.

Isom.Context.EcuList | GetVehicleConfigurationEcus()

Liefert eine Liste der Steuergeräte, von denen die Fahrzeugmerkmale ermittelt werden können.

Isom.Context.EcuList | GetVinEcus()

Liefert eine Liste der Steuergeräte, von denen die Fahrgestellnummer ermittelt werden kann.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Context.LogicalVehicle | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Ermittelt, ob es sich um das Void-Objekt handelt.

Isom.Context.LogicalVehicle | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Ein Fachobjekt vom Typ Isom.Context.LogicalVehicle beschreibt einen aus Servicesicht zusammengehörigen Teil aus dem Gesamtbordnetz des angeschlossenen Fahrzeugs.

Anwendung für Mischbordnetze

Mischbordnetze ist der Oberbegriff für Bordnetze, die aus mehreren separaten Teilbordnetzen bestehen. Bei Mischbordnetzen wird jedes Teilbordnetz als separates logisches Fahrzeug abgebildet, so dass physikalische Aufteilung und logische Aufteilung korrespondieren.

Querverweise und Referenzen

Siehe auch:
Isom.Context.LogicalVehicleList für den zugehörigen Listentyp.
Isom.Context.CurrentVehicleContext für die Gesamtfahrzeugsicht.
Isom.Context.FutureVehicleContext für die Gesamtfahrzeugsicht.

Literatur

  • SPEC BZ-12385/WA-588-5637

Dokumenteninformation

Seit:
Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 21.12.2010

Quelldateien:

  • Isom\Context\LogicalVehicle.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.ClearDtcInAllEcus ( )

Löscht die Fehlerspeichereinträge.

Die Funktion löscht alle Fehlerspeichereinträge in allen Steuergeräten des logischen Fahrzeugs. Falls vom angebundenen Fachdienst unterstützt, werden die Fehlerspeicher funktional gelöscht.

Rückgabe:
Isom.Base.Boolean
true nach erfolgreichem Löschen,
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der zur Fahrzeugkommunikation angebundene Fachdienst das Löschen von Fehlerspeichereinträgen nicht unterstützt.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 836]
objectbound Isom.Context.LogicalVehicle Isom.Context.LogicalVehicle.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Isom.Context.LogicalVehicle
Das geklonte Objekt.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\LogicalVehicle.is: 1482]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.DeployAllVersions ( )

Schreibt alle Integrationsstände aus dem Datenmodell in das Fahrzeug.

Ein Integrationsstand versioniert alle im Fahrzeug verbauten Steuergeräte eindeutig. Dabei handelt es sich üblicherweise um eine Versionsinformation, die einen festgelegten Stand von Hard- und Softwareeinheiten für Steuergeräte benennt. Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um die im Datenmodell gesetzten Werte für den aktuellen Softwarestand, den Softwarestand beim Bau des Fahrzeugs und den Softwarestand vor der letzten Aktualisierung des Fahrzeugs in das Fahrzeug zu schreiben.

Achtung:
Nach fehlgeschlagenem Fachdienstaufruf (Rückgabewert Void) können alle Integrationsstände zurückgesetzt (Void) sein.
Rückgabe:
Isom.Base.Boolean
true, falls die Integrationsstände erfolgreich geschrieben wurden
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls ein technischer Fehler aufgetreten ist (z.B. Aufruf der Fachfunktion für Fahrzeuge, die keine Integrationsstände unterstützen)
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 766]
objectbound Isom.Context.UserProfile Isom.Context.LogicalVehicle.DeployUserProfile ( )

Schreibt das Benutzerprofil aus dem Sollkonntext in das Fahrzeug.

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um das im logischen Fahrzeug geführte Benutzerprofil in das Fahrzeug zu schreiben.

Rückgabe:
Isom.Context.UserProfile
Das Benutzerprofil, das geschrieben wurde.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Benutzerprofil nicht geschrieben werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 788]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.EnforceExclusive ( )

Verhindert den Wechsel des logischen Fahrzeugs durch ISOM.

Rückgabe:
Isom.Base.Boolean
true, falls Fachfunktionsaufruf erfolgreich
false sonst.
Zu beachten:
Auch über Funktionsannotation [ExclusiveLogicalVehicle(…)] realisierbar.
Siehe auch:
Isom.Context.LogicalVehicle.ReleaseExclusive
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 307]
objectbound Isom.Context.UserProfile Isom.Context.LogicalVehicle.GetCurrentUserProfileClone ( )

Liefert das Benutzerprofil.

Der gelieferte Wert wurde mit der Funktion @Isom.Context.LogicalVehicle.ReadUserProfile aus dem Fahrzeug ermittelt.

Achtung:
Es wird eine Kopie des Benutzerprofils zurückgegeben.
Rückgabe:
Isom.Context.UserProfile
Fahrzeugmerkmale.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Benutzerprofil noch nicht ermittelt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 867]
objectbound Isom.Base.String Isom.Context.LogicalVehicle.GetDisplayProp ( Isom.Base.String propName )

Abfrage einer Anzeigeeigenschaft

Anzeigeeigenschaften erlauben es, den in dieser Fachklasse angebotenen Satz an Eigenschaften durch herstellerspezifische Eigenschaften zu erweitern. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Zu beachten:
Zur Anzeige auf der Serviceplattform Taurus® stehen die Anzeigeeigenschaften innerhalb der BOAM-Daten durch den Bezeichner ISOM:Vehicle.Context.DisplayPropertiesCurrent.<Name> zur Verfügung.
Parameter:
propName Eigenschaftsname
Rückgabe:
Isom.Base.String
Wert der Anzeigeeigenschaft
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die abgefragte Eigenschaft nicht bekannt ist oder kein Wert gesetzt ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 998]
objectbound Isom.Base.StringList Isom.Context.LogicalVehicle.GetDisplayPropNames ( )

Liefert die Namen aller Anzeigeeigenschaften.

Es werden die Eigenschaftsnamen für die Anzeigeeigenschaften zurückgeliefert, die mit Isom.Context.LogicalVehicle.GetDisplayProp() abgefragt werden können. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Rückgabe:
Isom.Base.StringList
Liste der Namen aller Anzeigeeigenschaften
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 1100]
objectbound Isom.Context.EcuList Isom.Context.LogicalVehicle.GetEcus ( )

Fragt die Steuergeräteliste ab.

Die abgefragte Steuergeräteliste enthält die Steuergeräte, die im logischen Fahrzeug vorhanden sind. Es kann sich dabei sowohl um ein logisches Fahrzeug des Ist-Kontextes als auch um ein logisches Fahrzeug des Soll-Kontextes handeln. Sie wird befüllt durch Aufruf von Isom.Context.CurrentVehicleContext.IdentifyAllEcus oder durch Setzen der Liste mit SetEcus, Isom.Context.CurrentVehicleContext.SetEcus oder Isom.Context.FutureVehicleContext.SetEcus.

Achtung:
Es wird eine Kopie der Steuergeräteliste zurückgegeben. Eine Änderung derselben wirkt sich nicht auf die logische im Fahrzeug geführte Liste aus.
Zu beachten:
Zur Anzeige des Werts auf der Serviceplattform Taurus® wird auf ihn innerhalb der BOAM-Daten mit ISOM:EcuList zugegriffen.
Verwendungsbeispiel:
Der folgende Quelltext zeigt eine einfache Implementierung des Einsprungspunkts UpdateCurrentContextEcus, die die Steuergeräte im Fahrzeug identifiziert:
   Isom.Base.Boolean UpdateCurrentContextEcus() // Einsprungspunkt zur Ermittlung der verbauten Steuergeräte (Phase 4)
   {
     // Abfrage der Zugriffsinstanz
     Isom.Context.CurrentVehicleContext cctx = Isom.Context.CurrentVehicleContext.GetInstance();

     // Identifikation der Steuergeräte durch den Fachdienst zur Fahrzeugkommunikation
     Isom.Context.EcuList ecus = cctx.IdentifyAllEcus();
     if (ecus.IsVoid())
     {
       // Steuergeräte konnten nicht identifiziert werden
       return false;
     }

     // Iteration über die Liste
     ecus.Reset();
     while(ecus.HasNext())
     {
       // Abfrage des nächsten N-Kanals
       Isom.Context.Ecu ecu = ecus.Next();

       // Prüfung und Protokollierung
       // ..
     }

     return true;
   }
Rückgabe:
Isom.Context.EcuList
Kopie der Steuergeräteliste des logischen Fahrzeugs.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 414]
objectbound Isom.Context.EcuList Isom.Context.LogicalVehicle.GetExpectedEcus ( )

Ermittelt die Steuergeräte, die im logischen Fahrzeug verbaut sein sollten.

Die Ermittlung benötigt einen angebundenen Fachdienst für Logistikinformationen, der die erwarteten Steuergeräte aus den ermittelten Fahrzeugmerkmalen herleitet.

Rückgabe:
Isom.Context.EcuList
Im Fahrzeug auf Basis der Fahrzeugmerkmale erwartete Steuergeräte.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Steuergeräte nicht ermittelt werden konnten.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 897]
objectbound Isom.Context.UserProfile Isom.Context.LogicalVehicle.GetFutureUserProfile ( )

Ermittelt das Benutzerprofil.

Rückgabe:
Benutzerprofil
[Isom\Context\LogicalVehicle.is: 1288]
objectbound Isom.Base.String Isom.Context.LogicalVehicle.GetName ( )

Liefert den Namen des logischen Fahrzeugs entsprechend ISOM-Fahrzeugbeschreibung.

Rückgabe:
Isom.Base.String
Name des logischen Fahrzeugs.
Zu beachten:
Wenn in der ISOM-Fahrzeugbeschreibung keine explizite Aufteilung in logische Fahrzeuge vorgenommen ist (z. B. bei Baureihen mit homogenem Bordnetz), wird von ISOM implizit ein logisches Fahrzeug namens fallback erzeugt, um eine einheitliche Datenmodellierung zu gewährleisten.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 209]
Isom.Context.LogicalVehicleList Isom.Context.LogicalVehicle.GetPossibleLogicalVehicles ( )

Liefert eine Liste aller in der ISOM-Fahrzeugbeschreibung für den aktuellen Baureihenverbund modellierten logischen Fahrzeuge.

Zu beachten:
Der Überarbeitungsstand des Fahrzeugs wird dabei nicht als Einschränkung berücksichtigt.
Rückgabe:
Isom.Context.LogicalVehicleList
Liste aller logischen Fahrzeuge für diesen Baureihenverbund.
Siehe auch:
Isom.Context.CurrentVehicleContext.GetLogicalVehicles für Fachfunktion mit Berücksichtigung des gesetzten Überarbeitungsstands.
Isom.Context.FutureVehicleContext.GetLogicalVehicles für Fachfunktion mit Berücksichtigung des gesetzten Überarbeitungsstands.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 171]
objectbound Isom.Base.StringList Isom.Context.LogicalVehicle.GetPossibleTargetVersions ( )

Ermittelt über die Logistik die möglichen Ziel-Integrationsstände.

Zu beachten:
Statische Funktion, damit frühzeitiger Aufruf ohne FutureVehicleContext-Instanzerzeugung möglich ist.
Verwendungsbeispiel:
    Boolean GetFutureContext()
    {
        FutureVehicleContext futureContext = FutureVehicleContext.GetInstance ();
        // ...

        // mögliche Ziel-Integrationsstände ermitteln
        StringList possibleVersions = FutureVehicleContext.TargetVersions();

        // semantisch größten Ziel-Integrationsstand bestimmen;
        possibleVersions.Reset();
        String futureVersion = possibleVersions.Next(); // ersten Wert als Vergleichsbasis
        while( possibleVersions.HasNext() )
        {
            String iLevelLoop = possibleVersions.Next();

            // Integrationsstände semantisch vergleichen
            Boolean isMax = Helpers.IsILevelGreaterOrEqual (iLevelLoop, futureVersion);
            if( isMax.IsVoid() ) // nicht vergleichbar
            {
                futureVersion = String.Void();
                break;
            }
            else if( isMax )
            {
                futureVersion = iLevelLoop;
            }
        }

        // max. Ziel-Integrationsstand setzen, wenn eindeutig ermittelt; sonst warnen und fortfahren
        if( futureVersion.IsVoid() )
        {
            // ... log warning ...
        }
        else
        {
            if( futureContext.SetTargetVersion( futureVersion ). Failed() )
            {
                // ... log warning ...
            }
            else
            {
                // ... log success ...
            }
        }

        // ...

   }
Rückgabe:
mögliche Ziel-Integrationsstände.
Siehe auch:
Isom.Context.LogicalVehicle.SetTargetVersion()
[Isom\Context\LogicalVehicle.is: 1180]
objectbound Isom.Base.String Isom.Context.LogicalVehicle.GetProp ( Isom.Base.String propName )

Abfrage einer technischen Eigenschaft

Eigenschaften erlauben es, den in dieser Fachklasse angebotenen Satz an Eigenschaften durch herstellerspezifische Eigenschaften zu erweitern. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Parameter:
propName Eigenschaftsname
Rückgabe:
Isom.Base.String
Wert der Eigenschaft
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die abgefragte Eigenschaft nicht bekannt ist oder kein Wert gesetzt ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 937]
objectbound Isom.Base.StringList Isom.Context.LogicalVehicle.GetPropNames ( )

Liefert die Namen aller technischen Eigenschaften für das logische Fahrzeug.

Es werden die Eigenschaftsnamen für die technischen Eigenschaften zurückgeliefert, die mit Isom.Context.LogicalVehicle.GetProp() abgefragt werden können. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Verwendungsbeispiel:
Der folgende Quelltext zeigt eine Implementierung des Einsprungspunkts OnRestartTherapySession, die die Eigenschaften, die bei der vorherigen Sitzungsdurchführung gesetzt wurden untersucht und für den Wiedereinstieg ggf. verändert:
   Isom.Base.Boolean OnRestartTherapySession() // Einsprungspunkt bei Wiedereinstieg in eine Sitzung
   {
     // Abfrage der Zugriffsinstanz
     Isom.Context.CurrentVehicleContext cctx = Isom.Context.CurrentVehicleContext.GetInstance();

     // Abfrage der Namen der gesetzten Eigenschaften
     Isom.Base.StringList propNames = cctx.GetPropNames();

     // Iteration über die Liste
     propNames.Reset();
     while(propNames.HasNext())
     {
       // Abfrage des nächsten Eigenschaftsnamens
       Isom.Base.String propName = propNames.Next();

       // Behandlung der Eigenschaft beim Wiedereinstieg
       // ..
     }

     // Weitere Behandlung des Wiedereinstiegs
     // ..
     return true;
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller technischen Eigenschaften
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 1079]
objectbound Isom.Context.EcuList Isom.Context.LogicalVehicle.GetSoftwareVersionEcus ( )

Liefert eine Liste der Steuergeräte, von denen die Integrationsstände des Fahrzeugs ermittelt werden können.

Die Funktion liefert eine Liste aller Steuergeräte, die folgende zwei Bedingungen erfüllen:

  1. Sie sind Elemente der Steuergeräte-Liste dieses Kontexts, die mit Isom.Context.LogicalVehicle.GetEcus abgefragt wird.
  2. Sie sind in der Fahrzeugbeschreibung im Element „SoftwareVersionEcus“ für die aktuell eingestellte Baureihengruppe angegeben.

Rückgabe:
Isom.Context.EcuList
Steuergeräte, von denen die Integrationsstände des Fahrzeugs ermittelt werden können.
Siehe auch:
Isom.Context.LogicalVehicle.ReadVehicleOrder als Komfortfunktion für Isom.Context.LogicalVehicle.ReadVehicleOrderPure und Isom.Context.LogicalVehicle.ReadVehicleOrderAdditionals.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 1433]
objectbound Isom.Context.EcuList Isom.Context.LogicalVehicle.GetSpecialFunctionEcus ( Isom.Base.String functionName )

Liefert eine Liste der Steuergeräte mit besonderen Funktionsmerkmalen.

Steuergeräte mit besonderen Funktionsmerkmalen werden in der Fahrzeugbeschreibung mit 'SpecialFunction' modelliert. Die Elemente in der gelieferten Liste sind dem Wert der 'Priority' nach aufsteigend angeordnet.

Verwendungsbeispiel:
Der folgende Quelltext zeigt eine einfache Implementierung des Einsprungspunkts DisplayVo, in der das Auslesen der Steuergeräte mit besonderen Funktionsmerkmalen erfolgt:
Der folgende Quelltext zeigt die Modellierung der besonderen Funktionsmerkmale im XML-Knoten 'SpecialFunctions' innerhalb einer Fahrzeugbeschreibung:
   Isom.Base.String DisplayVo()
  {
  // Abfrage der Zugriffsinstanz
     Isom.Context.CurrentVehicleContext cvc = Isom.Context.CurrentVehicleContext.GetInstance();
     //..

    // Ermittelt alle FA-tragenden SG
    Isom.Context.EcuList voEcus = cvc.GetSpecialFunctionEcus("VehicleOrderSequence");

    //...

   <Ecus>
  <!-- Gateways haben Adressen 1-10 -->
  <BaseVariant Name="PLCGW">
   <Address>1</Address>
    <GroupName>G_ZGW</GroupName>
    <SpecialFunctions>
      <Function Name="VehicleOrderSequence" Priority="1" />
      <Function Name="VinSequence" Priority="1" />
    </SpecialFunctions>
 //...
Parameter:
functionName Name des Funktionsmerkmals.
Rückgabe:
Isom.Context.EcuList
Steuergeräte mit dem Funktionsmerkmal.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 1352]
objectbound Isom.Base.String Isom.Context.LogicalVehicle.GetTargetVersion ( )

Ermittelt den aktuell eingestellten Soll-Integrationsstand für Logistikpläne.

Zu beachten:
Die Zielversion wird spätestens durch einen der folgenden Funktionsaufrufe festgelegt: * SetTargetVersion ODER * CalcNewFutureContext ODER * CalcFinalFutureContext
Verwendungsbeispiel:
   using Isom.Base.*
   ...
  FutureVehicleContext futureContext = FutureVehicleContext.GetInstance();
  String ilevel = futureContext.GetTargetVersion();
Rückgabe:
Soll-Integrationsstand.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Integrationsstand noch nicht ermittelt ist.
Siehe auch:
Isom.Context.LogicalVehicle.SetTargetVersion()
[Isom\Context\LogicalVehicle.is: 1210]
objectbound Isom.Context.EcuList Isom.Context.LogicalVehicle.GetVehicleConfigurationEcus ( )

Liefert eine Liste der Steuergeräte, von denen die Fahrzeugmerkmale ermittelt werden können.

Die Funktion liefert eine Liste aller Steuergeräte, die folgende zwei Bedingungen erfüllen:

  1. Sie sind Elemente der Steuergeräte-Liste dieses Kontexts, die mit Isom.Context.LogicalVehicle.GetEcus abgefragt wird.
  2. Sie sind in der Fahrzeugbeschreibung im Element „VehicleConfigurationEcus“ für die aktuell eingestellte Baureihengruppe angegeben.

Rückgabe:
Isom.Context.EcuList
Steuergeräte, von denen die Fahrzeugmerkmale ermittelt werden können.
Siehe auch:
Isom.Context.LogicalVehicle.ReadVehicleOrder als Komfortfunktion für Isom.Context.LogicalVehicle.ReadVehicleOrderPure und Isom.Context.LogicalVehicle.ReadVehicleOrderAdditionals.

Ermittelt+setzt derzeit parallel auch die VIN17.

Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 1405]
objectbound Isom.Base.String Isom.Context.LogicalVehicle.GetVehicleGeneration ( )

Liefert die Bordnetzgeneration des logischen Fahrzeugs entsprechend ISOM-Fahrzeugbeschreibung.

Rückgabe:
Isom.Base.String
Bordnetzgeneration des logischen Fahrzeugs.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Fahrzeuggeneration noch nicht ermittelt wurde.
Zu beachten:
Die Bordnetzgeneration eines logischen Fahrzeugs wird anhand der ISOM-Fahrzeugbeschreibung initialisiert, kann aber vom Serviceautor mit der Fachfunktion SetVehicleGeneration überschrieben werden.
Siehe auch:
Isom.Context.LogicalVehicle.SetVehicleGeneration
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 236]
objectbound Isom.Context.EcuList Isom.Context.LogicalVehicle.GetVinEcus ( )

Liefert eine Liste der Steuergeräte, von denen die Fahrgestellnummer ermittelt werden kann.

Die Funktion liefert eine Liste aller Steuergeräte, die folgende zwei Bedingungen erfüllen:

  1. Sie sind Elemente der Steuergeräte-Liste dieses Kontexts, die mit Isom.Context.LogicalVehicle.GetEcus() abgefragt wird.
  2. Sie sind in der Fahrzeugbeschreibung der eingestellten Baureihengruppe im Element „VinEcus“ angegeben.

Rückgabe:
Isom.Context.EcuList
Steuergeräte, von denen die Fahrgestellnummer ermittelt werden kann.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 1375]
objectbound Isom.Context.EcuList Isom.Context.LogicalVehicle.IdentifyAllEcus ( )

Identifiziert alle Steuergeräte des logischen Fahrzeugs.

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um die Steuergeräte zu identifizieren. Wenn funktionale Identifikation möglich ist, wird diese genutzt. Andernfalls dient die Steuergeräteliste, die Isom.Context.LogicalVehicle.GetEcus() liefert, als Liste der zu identifizierenden Steuergeräte.

Rückgabe:
Isom.Context.EcuList
Alle Steuergeräte, die identifiziert wurden oder deren Identifikation versucht wurde.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 705]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.IsVoid ( )

Ermittelt, ob es sich um das Void-Objekt handelt.

Rückgabe:
Isom.Base.Boolean
'true', falls dies das Void-Objekt ist, 'false' sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 1464]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.ReadDtcFromAllEcus ( )

Ermittelt die Fehlerspeichereinträge.

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um die Fehlerspeichereinträge zu ermitteln. Die Einstellungen des Benutzerprofils müssen in der Fahrzeugbeschreibung der eingestellten Baureihengruppe angegeben werden.

Rückgabe:
Isom.Base.Boolean
true, falls die Fehlerspeichereinträge erfolgreich ermittelt wurden
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 729]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.ReadUserProfile ( )

Ermittelt das Benutzerprofil des Fahrzeugs.

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um das Benutzerprofil zu ermitteln. Die Einstellungen des Benutzerprofils müssen in der Fahrzeugbeschreibung der eingestellten Baureihengruppe angegeben werden.

Rückgabe:
Isom.Base.Boolean
true, falls das Benutzerprofil erfolgreich ermittelt wurde
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 679]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.ReadVehicleOrder ( )

Ermittelt die vollständigen Fahrzeugmerkmale.

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um die Fahrzeugmerkmale zu ermitteln. Es werden nacheinander alle Steuergeräte, die Isom.Context.LogicalVehicle.GetVehicleConfigurationEcus() liefert, nach den Fahrzeugmalen befragt. Das erste erfolgreich abgefragte Ergebnis wird in das Datenmodell übernommen.

Zu beachten:
Ein Aufruf dieser Funktion entspricht einem Aufruf von Isom.Context.LogicalVehicle.ReadVehicleOrderPure, gefolgt von einem Aufruf von Isom.Context.LogicalVehicle.ReadVehicleOrderAdditionals
Rückgabe:
Isom.Base.Boolean
true, falls die Fahrzeugmerkmale erfolgreich ermittelt wurden
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die OEM-Funktion nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 537]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.ReadVehicleOrderAdditionals ( )

Vervollständigt vom Fahrzeug gelesene Fahrzeugmerkmale mit Zusatzinformationen

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um Zusatzinformationen zu den Fahrzeugmerkmalen zu ermitteln. Bei erfolgreicher Ausführung wird das Ergebnis in das Datenmodell übernommen.

Zu beachten:
Die Fahrzeugmerkmale können mit einem Aufruf von Isom.Context.LogicalVehicle.ReadVehicleOrderPure vom Fahrzeug ausgelesen werden.
Rückgabe:
Isom.Base.Boolean
true, falls die Fahrzeugmerkmale erfolgreich vervollständigt wurden
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 594]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.ReadVehicleOrderPure ( )

Ermittelt die Fahrzeugmerkmale, wie sie vom Fahrzeug geliefert werden.

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um die Fahrzeugmerkmale zu ermitteln. Es werden nacheinander alle Steuergeräte, die Isom.Context.ContextConfiguration.GetVehicleOrderEcus() liefert, nach den Fahrzeugmalen befragt. Das erste erfolgreich abgefragte Ergebnis wird in das Datenmodell übernommen.

Zu beachten:
Die ermittelten Fahrzeugmerkmale können mit einem Aufruf von Isom.Context.LogicalVehicle.ReadVehicleOrderAdditionals mit zusätzlichen Informationen vervollständigt werden.
Rückgabe:
Isom.Base.Boolean
true, falls die Fahrzeugmerkmale erfolgreich ermittelt wurden
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 567]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.ReadVersions ( )

Ermittlung der Integrationsstände des Fahrzeugs.

Ein Integrationsstand versioniert alle im Fahrzeug verbauten Steuergeräte eindeutig. Dabei handelt es sich üblicherweise um eine Versionsinformation, die einen festgelegten Stand von Hard- und Softwareeinheiten für Steuergeräte benennt. Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um den aktuellen Softwarestand, den Softwarestand beim Bau des Fahrzeugs und den Softwarestand vor der letzten Aktualisierung des Fahrzeugs zu ermitteln. Die ermittelten Werte werden bei erfolgreicher Ausführung in das Datenmodell übernommen.

Rückgabe:
Isom.Base.Boolean
true wenn die Integrationsstände erfolgreich ermittelt wurden
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 622]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.ReadVin ( )

Ermittelt die Fahrgestellnummer

Die Funktion verwendet den zur Fahrzeugkommunikation angebundenen Fachdienst, um die Fahrgestellnummer aus dem Fahrzeug zu ermitteln. Es werden nacheinander alle Steuergeräte, die Isom.Context.LogicalVehicle.GetVinEcus() liefert, nach der Fahrgestellnummer befragt. Das erste erfolgreich abgefragte Ergebnis wird in das Datenmodell übernommen.

Rückgabe:
Isom.Base.Boolean
true, falls der gezeigte Wegstreckenzähler erfolgreich ermittelt werden konnte,
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Ermittlung nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 650]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.ReleaseExclusive ( )

Erlaubt den Wechsel des logischen Fahrzeugs durch ISOM.

Hebt die Wirkung von eines vorherigen Aufrufs von Isom.Context.LogicalVehicle.EnforceExclusive wieder auf

Rückgabe:
Isom.Base.Boolean
true, falls Fachfunktionsaufruf erfolgreich
false sonst.
Zu beachten:
Auch als Funktionsannotation [ExclusiveLogicalVehicle(…)].
Siehe auch:
Isom.Context.LogicalVehicle.EnforceExclusive
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 335]
objectbound Isom.Base.StringDictionary Isom.Context.LogicalVehicle.RunProcess | ( | Isom.Base.String | processName,
 |  | Isom.Base.StringDictionary | arguments
 | ) |  |

Führt eine benannte OEM-Funktion aus.

Steuergeräte mit besonderen Funktionsmerkmalen werden in der Fahrzeugbeschreibung mit 'SpecialFunction' modelliert. Die unterstützten OEM-Funktionen werden in diesen Elementen als 'Function' aufgeführt. Die Ausführung der OEM-Funktion erfolgt über den angebundenen Fachdienst zur Fahrzeugkommunikation.

Parameter:
processName | Name der OEM-Funktion.
arguments | Ausführungsparameter.
Rückgabe:
Isom.Base.StringDictionary
Ein prozessspezifisches Wörterbuch der Ausführungsergebnisse.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die OEM-Funktion nicht ausgeführt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 487]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.SetDisplayProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt eine Anzeigeeigenschaft

Anzeigeeigenschaften erlauben es, den in dieser Fachklasse angebotenen Satz an Eigenschaften durch herstellerspezifische Eigenschaften zu erweitern. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Zu beachten:
Im Vergleich zu Isom.Context.LogicalVehicle.SetProp() eignet sich diese Funktion für Eigenschaftswerte, die lokalisiert werden.
Parameter:
propName | Eigenschaftsname
propValue | Eigenschaftswert
Rückgabe:
Isom.Base.Boolean
Immer true.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 1027]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.SetEcus ( Isom.Context.EcuList newList )

Setzt die Steuergeräteliste.

Die Funktion setzt die Liste der Steuergeräte, die im logischen Fahrzeug vorhanden sind.

Verwendungsbeispiel:
Der folgende Quelltext zeigt eine einfache Implementierung des Einsprungspunkts UpdateCurrentContextEcus, die die Steuergeräteliste so setzt, wie sie von der Fachfunktion Isom.Context.CurrentVehicleContext.GetExpectedEcus geliefert wird:
   Isom.Base.Boolean UpdateCurrentContextEcus() // Einsprungspunkt zur Ermittlung der verbauten Steuergeräte (Phase 4)
   {
     // Abfrage der Zugriffsinstanz
     Isom.Context.CurrentVehicleContext cctx = Isom.Context.CurrentVehicleContext.GetInstance();

     // Ermittlung der Steuergeräte durch den Fachdienst für Logistikinformationen
     Isom.Context.EcuList expected = cctx.GetExpectedEcus();
     if (expected.IsVoid())
     {
       // Erwartete Steuergeräte konnten nicht ermitteln werden
       return false;
     }

     // Übernahme der erwarteten Steuergeräte in den Istkontext
     cctx.SetEcus(expected);

     return true;
   }
Parameter:
newList Liste der Steuergeräte.
Rückgabe:
Isom.Base.Boolean
Immer true.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 459]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.SetProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt eine technische Eigenschaft

Eigenschaften erlauben es, den in dieser Fachklasse angebotenen Satz an Eigenschaften durch herstellerspezifische Eigenschaften zu erweitern. Systemseitig ermittelte Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Zu beachten:
Im Vergleich zu Isom.Context.LogicalVehicle.SetDisplayProp() eignet sich diese Funktion nur für Eigenschaftswerte, die nicht lokalisiert werden.
Parameter:
propName | Eigenschaftsname
propValue | Eigenschaftswert
Rückgabe:
Isom.Base.Boolean
Immer true.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 966]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.SetTargetVersion ( Isom.Base.String newGoalVersion )

Setzt den für Logistikpläne zu verwendenden Soll-Integrationsstand.

Verwendungsbeispiel:
    Boolean GetFutureContext()
    {
        FutureVehicleContext futureContext = FutureVehicleContext.GetInstance ();
        // ...

        StringList possibleVersions = FutureVehicleContext.GetPossibleTargetVersions();
        // mögliche Ziel-Integrationsstände ermitteln

        // semantisch größten Ziel-Integrationsstand bestimmen;
        possibleVersions.Reset();
        String futureVersion = possibleVersions.Next(); // ersten Wert als Vergleichsbasis
        while( possibleVersions.HasNext() )
        {
            String iLevelLoop = possibleVersions.Next();

            // Integrationsstände semantisch vergleichen
            Boolean isMax = Helpers.IsILevelGreaterOrEqual (iLevelLoop, futureVersion);
            if( isMax.IsVoid() ) // nicht vergleichbar
            {
                futureVersion = String.Void();
                break;
            }
            else if( isMax )
            {
                futureVersion = iLevelLoop;
            }
        }

        // max. Ziel-Integrationsstände setzen, wenn eindeutig ermittelt; sonst warnen und fortfahren
        if( futureVersion.IsVoid() )
        {
            // ... log warning ...
        }
        else
        {
            if( futureContext.SetTargetVersion( futureVersion ). Failed() )
            {
                // ... log warning ...
            }
            else
            {
                // ... log success ...
            }
        }

        // ...

   }
Rückgabe:
Immer true, solange keine Exceptions aufgetreten.
Siehe auch:
Isom.Context.LogicalVehicle.GetTargetVersion()
Isom.Context.LogicalVehicle.GetPossibleTargetVersions()
Isom.Context.FutureVehicleContext.SetCurrentOemVersion()
[Isom\Context\LogicalVehicle.is: 1279]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.SetVehicleGeneration ( Isom.Base.String vehicleGeneration )

Setzt die Bordnetzgeneration des logischen Fahrzeugs im Datenmodell.

Parameter:
vehicleGeneration (Isom.Base.String)
Bordnetzgeneration des logischen Fahrzeugs.
Rückgabe:
Isom.Base.Boolean
true, falls die Fahrzeuggeneration erfolgreich gesetzt wurde
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls Isom.Base.String.Void() oder eine leere Zeichenkette übergeben wurde.
Es wird das Void-Objekt zurückgegeben, falls die übergebene Fahrzeuggeneration gesetzt werden konnte.
Zu beachten:
Die Bordnetzgeneration eines logischen Fahrzeugs wird anhand der ISOM-Fahrzeugbeschreibung initialisiert. Die Funktion SetVehicleGeneration wird verwendet, um diesen Wert zu überschreiben.
Siehe auch:
Isom.Context.LogicalVehicle.GetVehicleGeneration
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 271]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicle.UserProfileChanged ( )

Prüft, ob das Benutzerprofil im Sollkontext Änderungen gegenüber dem Istkontext enthält.

Die Funktion vergleicht das im Isom.Context.FutureVehicleContext geführte Benutzerprofil mit dem Benutzerprofil aus dem Istkontext Isom.Context.CurrentVehicleContext für die jeweiligen logischen Fahrzeuge mit dem gleichen Namen wie das aufrufende logische Fahrzeug in Ist- und Sollkontext.

Rückgabe:
Isom.Base.Boolean
true, falls das Benutzerprofil geändert wurde
false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Benutzerprofil nicht geschrieben werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 17.10.2011
[Isom\Context\LogicalVehicle.is: 813]
Isom.Context.LogicalVehicle Isom.Context.LogicalVehicle.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um beispielsweise einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Isom.Context.LogicalVehicle
Ungültiges Objekt.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 06.07.2010
[Isom\Context\LogicalVehicle.is: 1502]


für Serviceautoren

Isom.Context.LogicalVehicleList

Namensraum Isom.Context.LogicalVehicleList

Listen von Fachobjekten des Typs Isom.Context.LogicalVehicle. Mehr...

Funktionen
Isom.Context.LogicalVehicleList | CreateNew()

Erzeugt eine neue, leere Liste logischer Fahrzeuge.

Spezielle Such- und Filterfunktionen

Fachfunktionen für bequeme Suche und Filterung von Listen von Fachobjekten des Typs Isom.Context.LogicalVehicle.

Isom.Context.LogicalVehicle | FindByName(Isom.Base.String lvName)

Sucht das erste Auftreten des vorgegebenen logischen Fahrzeugs in der Liste.

Zugriffsreihenfolge auf Fachdienste

Festlegen der Zugriffsreihenfolge auf Fachdienste

Isom.Base.Boolean | ResetSequence()

Sortiert die Listenelemente entsprechend der Prioritätenfolge in der Fahrzeugbeschreibung

Isom.Base.Boolean | SetSequence(Isom.Base.StringList names)

Sortiert die Listenelemente entsprechend der vorgegebenen Reihenfolge.

Bequemlichkeitsfunktionen

Fachfunktionen die typische Anwendungsfälle vereinfachen oder beschleunigen

Isom.Base.Boolean | RemoveAll(Isom.Context.LogicalVehicle lv)

Entfernt alle Instanzen des vorgegebenen logischen Fahrzeugs aus der Liste.

Listenfunktionen

Isom.Context.LogicalVehicle | At(Isom.Base.Number index)

Gibt ein Listenelement zurück.

Isom.Base.Boolean | Contains(Isom.Context.LogicalVehicle element)

Filtert die aktuelle Liste mit der als Parameter übergebenen Liste.

Isom.Base.Boolean | Contains(Isom.Context.LogicalVehicle element)

Prüft, ob ein Element in der Liste vorhanden ist.

Isom.Context.LogicalVehicle | Current()

Liefert das Listenelement an der aktuellen Position des Iterators.

Isom.Base.Boolean | HasNext()

Gibt an, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Isom.Base.Number | Insert(Isom.Context.LogicalVehicle element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Gibt an, ob diese Liste leer ist.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Context.LogicalVehicle | Next()

Liefert das nächste logische Fahrzeug in der Liste.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt ein Element aus der Liste.

Isom.Base.Boolean | Reset()

Setzt den Iterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Context.LogicalVehicleList | Clone()

Erzeugt eine neue Liste, die die Elemente dieser Liste enthält.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Isom.Context.LogicalVehicleList | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Isom.Context.LogicalVehicleList sind Listen von Fachobjekten des Typs Isom.Context.LogicalVehicle.

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.
Datum:
letzte Änderung am 20.07.2010

Quelldateien:

  • Isom\Context\LogicalVehicleList.is

Dokumentation der Funktionen

objectbound Isom.Context.LogicalVehicle Isom.Context.LogicalVehicleList.At ( Isom.Base.Number index )

Gibt ein Listenelement zurück.

Ruft das Element aus der Liste ab, das durch den (Null-basierten) Index ausgewählt wird.

Parameter:
index Index.
Rückgabe:
Isom.Context.LogicalVehicle
Ausgewähltes Steuergerät.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 oder größer gleich der Anzahl der Listenelemente ist.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 351]
objectbound Isom.Context.LogicalVehicleList Isom.Context.LogicalVehicleList.Clone ( )

Erzeugt eine neue Liste, die die Elemente dieser Liste enthält.

Rückgabe:
Isom.Context.LogicalVehicleList
Neue Liste, die die Elemente dieser Liste enthält.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 483]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicleList.Contains ( Isom.Context.LogicalVehicle element )

Prüft, ob ein Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element.
Rückgabe:
Isom.Base.Boolean
'true', falls das Element gefunden werden konnte, 'false' sonst.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 445]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicleList.Contains ( Isom.Context.LogicalVehicle element )

Filtert die aktuelle Liste mit der als Parameter übergebenen Liste.

Die Reihenfolge der aktuellen Liste bleibt erhalten. Die zurückgegebene Liste enthält alle logischen Fahrzeuge der aktuellen Liste außer denjenigen, die in der als Parameter übergebenen Liste nicht enthalten sind. Dabei gilt als Kriterium, dass alle fachlichen Eigenschaften, die in dem logischen Fahrzeug aus der aktuellen Liste gesetzt sind, in dem logischen Fahrzeug aus der als Parameter übergebenen Liste entweder die gleichen Werte haben oder nicht gesetzt sind. In dem logischen Fahrzeug aus der als Parameter übergebenen Liste dürfen zudem keine fachlichen Eigenschaften gesetzt sein, die in dem logischen Fahrzeug aus der aktuellen Liste nicht gesetzt sind.

   Isom.Context.CurrentVehicleContext currentContext = Isom.Context.CurrentVehicleContext.GetInstance();
   Isom.Context.LogicalVehicleList ccEcuList = currentContext.GetEcus();
   Isom.Context.LogicalVehicleList voEcuList = ccEcuList.Filter(currentContext.GetVehicleConfigurationEcus());
Parameter:
otherList Liste, mit der die aktuelle Liste gefiltert werden soll.
Rückgabe:
Isom.Context.LogicalVehicleList
Gefilterte Liste.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 445]
Isom.Context.LogicalVehicleList Isom.Context.LogicalVehicleList.CreateNew ( )

Erzeugt eine neue, leere Liste logischer Fahrzeuge.

Rückgabe:
Isom.Context.LogicalVehicleList
neue, leere Liste.
Datum:
letzte Änderung am 23.08.2011
[Isom\Context\LogicalVehicleList.is: 91]
objectbound Isom.Context.LogicalVehicle Isom.Context.LogicalVehicleList.Current ( )

Liefert das Listenelement an der aktuellen Position des Iterators.

Zu beachten:
Diese Funktion sollte nur beim Iterieren über die Liste verwendet werden.
Rückgabe:
Isom.Context.LogicalVehicle
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Iterator zurückgesetzt wurde.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 314]
objectbound Isom.Context.LogicalVehicle Isom.Context.LogicalVehicleList.FindByName ( Isom.Base.String lvName )

Sucht das erste Auftreten des vorgegebenen logischen Fahrzeugs in der Liste.

Rückgabe:
Isom.Context.LogicalVehicle
Gefundenes Listenelement oder Isom.Context.LogicalVehicle.Void() wenn nicht gefunden.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 23.08.2011
[Isom\Context\LogicalVehicleList.is: 121]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicleList.HasNext ( )

Gibt an, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Rückgabe:
Isom.Base.Boolean
'true', falls noch Werte in der Liste zur Verfügung stehen, 'false' sonst.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 271]
objectbound Isom.Base.Number Isom.Context.LogicalVehicleList.Insert ( Isom.Context.LogicalVehicle element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Iterator wird durch diese Operation zurückgesetzt.

Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügendes logisches Fahrzeug.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 377]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicleList.IsEmpty ( )

Gibt an, ob diese Liste leer ist.

Rückgabe:
Isom.Base.Boolean
'true', falls die Liste leer ist, 'false' sonst.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 257]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicleList.IsVoid ( )

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Das Void-Objekt kann z. B. bei Funktionsaufrufen geliefert werden, um einen Fehler anzuzeigen.

Rückgabe:
Isom.Base.Boolean
'true', falls dies das Void-Objekt ist, 'false' sonst.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 471]
objectbound Isom.Base.Number Isom.Context.LogicalVehicleList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

Rückgabe:
Isom.Base.Number
Anzahl der Elemente.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 245]
objectbound Isom.Context.LogicalVehicle Isom.Context.LogicalVehicleList.Next ( )

Liefert das nächste logische Fahrzeug in der Liste.

Diese Funktion setzt den Iterator der Liste auf das nächste Element und gibt dieses Element zurück.

Zu beachten:
Diese Funktion sollte zum Iterieren über die Liste verwendet werden.
Vor dem Iterieren sollte der Iterator mit Reset() zurückgesetzt werden.
Rückgabe:
Isom.Context.LogicalVehicle
Nächstes Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 296]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicleList.Remove ( Isom.Base.Number index )

Entfernt ein Element aus der Liste.

Entfernt das durch den Index gekennzeichnete Element aus der Liste. Ein eventuell aktiver Iterator wird durch diese Operation zurückgesetzt.

Parameter:
index Index.
Rückgabe:
Isom.Base.Boolean
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt).
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 398]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicleList.RemoveAll ( Isom.Context.LogicalVehicle lv )

Entfernt alle Instanzen des vorgegebenen logischen Fahrzeugs aus der Liste.

Zu beachten:
Diese Funktion wird verwendet, um ein einzelnes logisches Fahrzeug von der Verarbeitung auszuschließen.
Parameter:
lv zu entfernendes logisches Fahrzeug.
Rückgabe:
Isom.Base.Boolean
true, falls Fachfunktionsaufruf erfolgreich
false sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 23. 08 .2011
[Isom\Context\LogicalVehicleList.is: 222]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicleList.Reset ( )

Setzt den Iterator zurück.

Setzt den Iterator auf die Position vor dem ersten Element der Liste.

Rückgabe:
Isom.Base.Boolean
Immer 'true'.
Datum:
letzte Änderung am 20.07.2010
[Isom\Context\LogicalVehicleList.is: 330]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicleList.ResetSequence ( )

Sortiert die Listenelemente entsprechend der Prioritätenfolge in der Fahrzeugbeschreibung

Zu beachten:
Diese Funktion wird verwendet, eine zuvor mit SetSequence vorgenommene Umsortierung rückgängig zu machen.
Rückgabe:
Isom.Base.Boolean
true, falls Fachfunktionsaufruf erfolgreich
false sonst.
Siehe auch:
Isom.Context.LogicalVehicleList.SetSequence zum gezielten Verändern der Sortierung.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 23.08.2011
[Isom\Context\LogicalVehicleList.is: 186]
objectbound Isom.Base.Boolean Isom.Context.LogicalVehicleList.SetSequence ( Isom.Base.StringList names )

Sortiert die Listenelemente entsprechend der vorgegebenen Reihenfolge.

Zu beachten:
Diese Funktion wird verwendet, um die Zugriffsreihenfolge auf die logischen Fahrzeuge zu beeinflussen.
Parameter:
names Liste von Namen logischer Fahrzeuge, anhand derer die aktuelle Liste umsortiert wird.
Rückgabe:
Isom.Base.Boolean
true, falls Fachfunktionsaufruf erfolgreich
false sonst.
Siehe auch:
Isom.Context.LogicalVehicleList.ResetSequence zum Rücksetzen der Sortierung.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 23.08.2011
[Isom\Context\LogicalVehicleList.is: 160]
Isom.Context.LogicalVehicleList Isom.Context.LogicalVehicleList.Void ( )

Erzeugt ein Void-Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Isom.Context.LogicalVehicleList
Die Funktion liefert immer ein Void-Objekt.
Ausnahmebehandlung:
Void wird von dieser Funktion immer geliefert.
Datum:
letzte Änderung am 19.07.2010
[Isom\Context\LogicalVehicleList.is: 499]


für Serviceautoren

Isom.Context.MockupFactory

Namensraum Isom.Context.MockupFactory

Erzeugung von Fachobjektattrappen aus Beschreibungsdateien Mehr...

Funktionen
Isom.Services.AsamParameter | CreateAsamParameter(Isom.Base.UriDictionary uris)

Erzeugt eine AsamParameter-Attrappe aus einer Beschreibungsdatei.

Isom.Services.AsamParameterList | CreateAsamParameterList(Isom.Base.UriDictionary uris)

Erzeugt eine AsamParameterList-Attrappe aus einer Beschreibungsdatei.

Isom.Services.AsamResponseList | CreateAsamResponseList(Isom.Base.UriDictionary uris)

Erzeugt eine AsamResponseList-Attrappe aus einer Beschreibungsdatei.

Isom.Context.Ecu | CreateEcu(Isom.Base.UriDictionary uris)

Erzeugt eine Ecu-Attrappe aus Beschreibungsdateien.

Isom.Context.EcuList | CreateEcuList(Isom.Base.UriDictionary uris)

Erzeugt eine EcuList-Attrappe aus Beschreibungsdateien.

Isom.Services.EdiabasResultSetList | CreateEdiabasResultSetList(Isom.Base.UriDictionary uris)

Erzeugt eine EdiabasResultSetList-Attrappe aus einer Beschreibungsdatei.

Isom.Context.VehicleOrder | CreateVehicleOrder(Isom.Base.UriDictionary uris)

Erzeugt eine VehicleOrder-Attrappe aus Beschreibungsdateien.

Isom.Base.UriDictionary | GetUrisFromAsamParameter(Isom.Services.AsamParameter parameter)

Abfrage der URI der Beschreibungsdatei, aus der eine AsamParameter-Attrappe erzeugt wurde.

Isom.Base.UriDictionary | GetUrisFromAsamParameterList(Isom.Services.AsamParameterList parameterList)

Abfrage der URI der Beschreibungsdatei, aus der eine AsamParameterList-Attrappe erzeugt wurde.

Isom.Base.UriDictionary | GetUrisFromAsamResponseList(Isom.Services.AsamResponseList responseList)

Abfrage der URI der Beschreibungsdatei, aus der eine AsamResponseList-Attrappe erzeugt wurde.

Isom.Base.UriDictionary | GetUrisFromEcu(Isom.Context.Ecu ecu)

Abfrage der URIs der Beschreibungsdateien, aus der eine Ecu-Attrappe erzeugt wurde.

Isom.Base.UriDictionary | GetUrisFromEcuList(Isom.Context.EcuList ecus)

Abfrage der URIs der Beschreibungsdateien, aus der eine EcuList-Attrappe erzeugt wurde.

Isom.Base.UriDictionary | GetUrisFromEdiabasResultSetList(Isom.Services.EdiabasResultSetList ediabasResultSetList)

Abfrage der URI der Beschreibungsdatei, aus der eine EdiabasResultSetList-Attrappe erzeugt wurde.

Isom.Base.UriDictionary | GetUrisFromVehicleOrder(Isom.Context.VehicleOrder vo)

Abfrage der URIs der Beschreibungsdateien, aus der eine VehicleOrder-Attrappe erzeugt wurde.

Isom.Base.Boolean | IsMockAsamParameterListOf(Isom.Services.AsamParameterList mock, Isom.Services.AsamParameterList real)

Vergleich einer AsamParameterList-Attrappe mit einem 'echten' AsamParameterList-Objekt

Isom.Base.Boolean | IsMockAsamParameterOf(Isom.Services.AsamParameter mock, Isom.Services.AsamParameter real)

Vergleich einer AsamParameter-Attrappe mit einem 'echten' AsamParameter-Objekt

Isom.Base.Boolean | IsMockAsamResponseListOf(Isom.Services.AsamResponseList mock, Isom.Services.AsamResponseList real)

Vergleich einer AsamResponseList-Attrappe mit einem 'echten' AsamResponseList-Objekt

Isom.Base.Boolean | IsMockEcuListOf(Isom.Context.EcuList mock, Isom.Context.EcuList real)

Vergleich einer EcuList-Attrappe mit einem 'echten' EcuList-Objekt

Isom.Base.Boolean | IsMockEcuOf(Isom.Context.Ecu mock, Isom.Context.Ecu real)

Vergleich einer Ecu-Attrappe mit einem 'echten' Ecu-Objekt

Isom.Base.Boolean | IsMockEdiabasResultSetListOf(Isom.Services.EdiabasResultSetList mock, Isom.Services.EdiabasResultSetList real)

Vergleich einer EdiabasResultSetList-Attrappe mit einem 'echten' EdiabasResultSetList-Objekt

Isom.Base.Boolean | IsMockVehicleOrderOf(Isom.Context.VehicleOrder mock, Isom.Context.VehicleOrder real)

Vergleich einer VehicleOrder-Attrappe mit einem 'echten' VehicleOrder-Objekt

Ausführliche Beschreibung

Eine Attrappe kann das Verhalten eines realen Objekts vortäuschen. Attrappen bilden hierzu die externe Schnittstelle der Klassendefinition nach, die unter Umständen noch nicht implementiert ist und ermöglichen damit frühzeitige und unabhängige Komponententests. Der Namensraum Isom.Context.MockupFactory der IBS ermöglicht die Erzeugung von Attrappen für Fachobjekte aus XML-Beschreibungen.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Context\MockupFactory.is

Dokumentation der Funktionen

Isom.Services.AsamParameter Isom.Context.MockupFactory.CreateAsamParameter ( Isom.Base.UriDictionary uris )

Erzeugt eine AsamParameter-Attrappe aus einer Beschreibungsdatei.

Die URI der Beschreibungsdatei muss als Wert des Eintrags 'AsamParameter' im übergebenen Wörterbuch 'uris' angegeben werden.

Parameter:
uris Wörterbuch der Beschreibungsdateien
Rückgabe:
Erzeugte AsamParameter-Attrappe
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht erzeugt werden konnte.
[Isom\Context\MockupFactory.is: 96]
Isom.Services.AsamParameterList Isom.Context.MockupFactory.CreateAsamParameterList ( Isom.Base.UriDictionary uris )

Erzeugt eine AsamParameterList-Attrappe aus einer Beschreibungsdatei.

Die URI der Beschreibungsdatei muss als Wert des Eintrags 'AsamParameterList' im übergebenen Wörterbuch 'uris' angegeben werden.

Parameter:
uris Wörterbuch der Beschreibungsdateien
Rückgabe:
Erzeugte AsamParameterList-Attrappe
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht erzeugt werden konnte.
[Isom\Context\MockupFactory.is: 138]
Isom.Services.AsamResponseList Isom.Context.MockupFactory.CreateAsamResponseList ( Isom.Base.UriDictionary uris )

Erzeugt eine AsamResponseList-Attrappe aus einer Beschreibungsdatei.

Die URI der Beschreibungsdatei muss als Wert des Eintrags 'AsamResponseList' im übergebenen Wörterbuch 'uris' angegeben werden.

Parameter:
uris Wörterbuch der Beschreibungsdateien
Rückgabe:
Erzeugte AsamResponseList-Attrappe
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht erzeugt werden konnte.
[Isom\Context\MockupFactory.is: 180]
Isom.Context.Ecu Isom.Context.MockupFactory.CreateEcu ( Isom.Base.UriDictionary uris )

Erzeugt eine Ecu-Attrappe aus Beschreibungsdateien.

Die URI der Beschreibungsdatei muss als Wert des Eintrags 'Ecu' im übergebenen Wörterbuch 'uris' angegeben werden. Optional lässt sich eine weitere Datei-URI für ergänzende Informationen als Eintrag 'EcuExtension' angeben

Parameter:
uris Wörterbuch der Beschreibungsdateien
Rückgabe:
Erzeugte Ecu-Attrappe
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht erzeugt werden konnte.
[Isom\Context\MockupFactory.is: 267]
Isom.Context.EcuList Isom.Context.MockupFactory.CreateEcuList ( Isom.Base.UriDictionary uris )

Erzeugt eine EcuList-Attrappe aus Beschreibungsdateien.

Die URI der Beschreibungsdatei muss als Wert des Eintrags 'EcuList' im übergebenen Wörterbuch 'uris' angegeben werden. Optional lässt sich eine weitere Datei-URI für ergänzende Informationen als Eintrag 'EcuListExtension' angeben

Parameter:
uris Wörterbuch der Beschreibungsdateien
Rückgabe:
Erzeugte EcuList-Attrappe
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht erzeugt werden konnte.
[Isom\Context\MockupFactory.is: 311]
Isom.Services.EdiabasResultSetList Isom.Context.MockupFactory.CreateEdiabasResultSetList ( Isom.Base.UriDictionary uris )

Erzeugt eine EdiabasResultSetList-Attrappe aus einer Beschreibungsdatei.

Die URI der Beschreibungsdatei muss als Wert des Eintrags 'EdiabasResultSetList' im übergebenen Wörterbuch 'uris' angegeben werden.

Parameter:
uris Wörterbuch der Beschreibungsdateien
Rückgabe:
Erzeugte EdiabasResultSetList-Attrappe
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht erzeugt werden konnte.
[Isom\Context\MockupFactory.is: 222]
Isom.Context.VehicleOrder Isom.Context.MockupFactory.CreateVehicleOrder ( Isom.Base.UriDictionary uris )

Erzeugt eine VehicleOrder-Attrappe aus Beschreibungsdateien.

Die URI der Beschreibungsdatei muss als Wert des Eintrags 'VehicleOrder' im übergebenen Wörterbuch 'uris' angegeben werden. Optional lässt sich eine weitere Datei-URI für ergänzende Informationen als Eintrag 'VehicleProfile' angeben

Parameter:
uris Wörterbuch der Beschreibungsdateien
Rückgabe:
Erzeugte VehicleOrder-Attrappe
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht erzeugt werden konnte.
[Isom\Context\MockupFactory.is: 355]
Isom.Base.UriDictionary Isom.Context.MockupFactory.GetUrisFromAsamParameter ( Isom.Services.AsamParameter parameter )

Abfrage der URI der Beschreibungsdatei, aus der eine AsamParameter-Attrappe erzeugt wurde.

Die URI der Beschreibungsdatei ist als Wert des Eintrags 'AsamParameter' im zurückgelieferten Wörterbuch angegeben.

Parameter:
parameter AsamParameter-Attrappe
Rückgabe:
Wörterbuch der Beschreibungsdateien
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht aus einer Beschreibungsdatei erzeugt wurde.
[Isom\Context\MockupFactory.is: 111]
Isom.Base.UriDictionary Isom.Context.MockupFactory.GetUrisFromAsamParameterList ( Isom.Services.AsamParameterList parameterList )

Abfrage der URI der Beschreibungsdatei, aus der eine AsamParameterList-Attrappe erzeugt wurde.

Die URI der Beschreibungsdatei ist als Wert des Eintrags 'AsamParameterList' im zurückgelieferten Wörterbuch angegeben.

Parameter:
parameterList AsamParameterList-Attrappe
Rückgabe:
Wörterbuch der Beschreibungsdateien
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht aus einer Beschreibungsdatei erzeugt wurde.
[Isom\Context\MockupFactory.is: 153]
Isom.Base.UriDictionary Isom.Context.MockupFactory.GetUrisFromAsamResponseList ( Isom.Services.AsamResponseList responseList )

Abfrage der URI der Beschreibungsdatei, aus der eine AsamResponseList-Attrappe erzeugt wurde.

Die URI der Beschreibungsdatei ist als Wert des Eintrags 'AsamResponseList' im zurückgelieferten Wörterbuch angegeben.

Parameter:
responseList AsamResponseList-Attrappe
Rückgabe:
Wörterbuch der Beschreibungsdateien
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht aus einer Beschreibungsdatei erzeugt wurde.
[Isom\Context\MockupFactory.is: 195]
Isom.Base.UriDictionary Isom.Context.MockupFactory.GetUrisFromEcu ( Isom.Context.Ecu ecu )

Abfrage der URIs der Beschreibungsdateien, aus der eine Ecu-Attrappe erzeugt wurde.

Die URIs der Beschreibungsdateien sind als Werte der Einträge 'Ecu' und 'EcuExtension' (optional) im zurückgelieferten Wörterbuch angegeben.

Parameter:
ecu Ecu-Attrappe
Rückgabe:
Wörterbuch der Beschreibungsdateien
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht aus einer Beschreibungsdatei erzeugt wurde.
[Isom\Context\MockupFactory.is: 282]
Isom.Base.UriDictionary Isom.Context.MockupFactory.GetUrisFromEcuList ( Isom.Context.EcuList ecus )

Abfrage der URIs der Beschreibungsdateien, aus der eine EcuList-Attrappe erzeugt wurde.

Die URIs der Beschreibungsdateien sind als Werte der Einträge 'EcuList' und 'EcuListExtension' (optional) im zurückgelieferten Wörterbuch angegeben.

Parameter:
ecus EcuList-Attrappe
Rückgabe:
Wörterbuch der Beschreibungsdateien
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht aus einer Beschreibungsdatei erzeugt wurde.
[Isom\Context\MockupFactory.is: 326]
Isom.Base.UriDictionary Isom.Context.MockupFactory.GetUrisFromEdiabasResultSetList ( Isom.Services.EdiabasResultSetList ediabasResultSetList )

Abfrage der URI der Beschreibungsdatei, aus der eine EdiabasResultSetList-Attrappe erzeugt wurde.

Die URI der Beschreibungsdatei ist als Wert des Eintrags 'EdiabasResultSetList' im zurückgelieferten Wörterbuch angegeben.

Parameter:
ediabasResultSetList EdiabasResultSetList-Attrappe
Rückgabe:
Wörterbuch der Beschreibungsdateien
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht aus einer Beschreibungsdatei erzeugt wurde.
[Isom\Context\MockupFactory.is: 237]
Isom.Base.UriDictionary Isom.Context.MockupFactory.GetUrisFromVehicleOrder ( Isom.Context.VehicleOrder vo )

Abfrage der URIs der Beschreibungsdateien, aus der eine VehicleOrder-Attrappe erzeugt wurde.

Die URIs der Beschreibungsdateien sind als Werte der Einträge 'VehicleOrder' und 'VehicleProfile' (optional) im zurückgelieferten Wörterbuch angegeben.

Parameter:
vo VehicleOrder-Attrappe
Rückgabe:
Wörterbuch der Beschreibungsdateien
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Objekt nicht aus einer Beschreibungsdatei erzeugt wurde.
[Isom\Context\MockupFactory.is: 370]
Isom.Base.Boolean Isom.Context.MockupFactory.IsMockAsamParameterListOf | ( | Isom.Services.AsamParameterList | mock,
 |  | Isom.Services.AsamParameterList | real
 | ) |  |

Vergleich einer AsamParameterList-Attrappe mit einem 'echten' AsamParameterList-Objekt

Parameter:
mock | AsamParameterList-Attrappe
real | 'echtes' AsamParameterList-Objekt
Rückgabe:
Ergebnis des Vergleichs. 'true', falls die Parameter gleich sind, 'false' sonst
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Vergleich nicht durchgeführt werden konnte
[Isom\Context\MockupFactory.is: 166]
Isom.Base.Boolean Isom.Context.MockupFactory.IsMockAsamParameterOf | ( | Isom.Services.AsamParameter | mock,
 |  | Isom.Services.AsamParameter | real
 | ) |  |

Vergleich einer AsamParameter-Attrappe mit einem 'echten' AsamParameter-Objekt

Parameter:
mock | AsamParameter-Attrappe
real | 'echtes' AsamParameter-Objekt
Rückgabe:
Ergebnis des Vergleichs. 'true', falls die Parameter gleich sind, 'false' sonst
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Vergleich nicht durchgeführt werden konnte
[Isom\Context\MockupFactory.is: 124]
Isom.Base.Boolean Isom.Context.MockupFactory.IsMockAsamResponseListOf | ( | Isom.Services.AsamResponseList | mock,
 |  | Isom.Services.AsamResponseList | real
 | ) |  |

Vergleich einer AsamResponseList-Attrappe mit einem 'echten' AsamResponseList-Objekt

Parameter:
mock | AsamResponseList-Attrappe
real | 'echtes' AsamResponseList-Objekt
Rückgabe:
Ergebnis des Vergleichs. 'true', falls die Parameter gleich sind, 'false' sonst
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Vergleich nicht durchgeführt werden konnte
[Isom\Context\MockupFactory.is: 208]
Isom.Base.Boolean Isom.Context.MockupFactory.IsMockEcuListOf | ( | Isom.Context.EcuList | mock,
 |  | Isom.Context.EcuList | real
 | ) |  |

Vergleich einer EcuList-Attrappe mit einem 'echten' EcuList-Objekt

Parameter:
mock | EcuList-Attrappe
real | 'echtes' EcuList-Objekt
Rückgabe:
Ergebnis des Vergleichs. 'true', falls die Parameter gleich sind, 'false' sonst
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Vergleich nicht durchgeführt werden konnte
[Isom\Context\MockupFactory.is: 339]
Isom.Base.Boolean Isom.Context.MockupFactory.IsMockEcuOf | ( | Isom.Context.Ecu | mock,
 |  | Isom.Context.Ecu | real
 | ) |  |

Vergleich einer Ecu-Attrappe mit einem 'echten' Ecu-Objekt

Parameter:
mock | Ecu-Attrappe
real | 'echtes' Ecu-Objekt
Rückgabe:
Ergebnis des Vergleichs. 'true', falls die Parameter gleich sind, 'false' sonst
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Vergleich nicht durchgeführt werden konnte
[Isom\Context\MockupFactory.is: 295]
Isom.Base.Boolean Isom.Context.MockupFactory.IsMockEdiabasResultSetListOf | ( | Isom.Services.EdiabasResultSetList | mock,
 |  | Isom.Services.EdiabasResultSetList | real
 | ) |  |

Vergleich einer EdiabasResultSetList-Attrappe mit einem 'echten' EdiabasResultSetList-Objekt

Parameter:
mock | EdiabasResultSetList-Attrappe
real | 'echtes' EdiabasResultSetList-Objekt
Rückgabe:
Ergebnis des Vergleichs. 'true', falls die Parameter gleich sind, 'false' sonst
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Vergleich nicht durchgeführt werden konnte
[Isom\Context\MockupFactory.is: 251]
Isom.Base.Boolean Isom.Context.MockupFactory.IsMockVehicleOrderOf | ( | Isom.Context.VehicleOrder | mock,
 |  | Isom.Context.VehicleOrder | real
 | ) |  |

Vergleich einer VehicleOrder-Attrappe mit einem 'echten' VehicleOrder-Objekt

Parameter:
mock | VehicleOrder-Attrappe
real | 'echtes' VehicleOrder-Objekt
Rückgabe:
Ergebnis des Vergleichs. 'true', falls die Parameter gleich sind, 'false' sonst
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Vergleich nicht durchgeführt werden konnte
[Isom\Context\MockupFactory.is: 383]


für Serviceautoren

Isom.Context.UserProfile

Namensraum Isom.Context.UserProfile

Fachobjekt für das Benutzerprofil Mehr...

Funktionen
Funktionen zum Auslesen von Einstellungen

Funktionen, die das Auslesen von Einstellungen ermöglichen.

Isom.Context.UserProfileSettingList | GetAllSettings()

Ermittelt eine Liste von allen Einstellungen und liefert diese als Ergebnis zurück.

Isom.Context.UserProfileSettingList | GetSettingsByAssignment(Isom.Base.String assignment)

Ermittelt eine Liste von allen Einstellungen, die die übergebene Zugehörigkeit erfüllen und liefert diese als Ergebnis zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Context.UserProfile | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Context.UserProfile repräsentiert die Instanz für das Benutzerprofil.

Quelldateien:

  • Isom\Context\UserProfile.is

Dokumentation der Funktionen

objectbound Isom.Context.UserProfileSettingList Isom.Context.UserProfile.GetAllSettings ( )

Ermittelt eine Liste von allen Einstellungen und liefert diese als Ergebnis zurück.

   using Isom.Base.*
   using Isom.Context.UserProfile;
   using Isom.Context.UserProfileSettingList;
   ...
   UserProfile up = CurrentVehicleContext.GetInstance().GetUserProfileClone();
   UserProfileSettingList upsList = up.GetAllSettings( "KEY1" );
Rückgabe:
Eine Liste mit allen Einstellungen.
[Isom\Context\UserProfile.is: 85]
objectbound Isom.Context.UserProfileSettingList Isom.Context.UserProfile.GetSettingsByAssignment ( Isom.Base.String assignment )

Ermittelt eine Liste von allen Einstellungen, die die übergebene Zugehörigkeit erfüllen und liefert diese als Ergebnis zurück.

   using Isom.Base.*
   using Isom.Context.UserProfile;
   using Isom.Context.UserProfileSettingList;
   ...
   UserProfile up = CurrentVehicleContext.GetInstance().GetUserProfileClone();
   UserProfileSettingList upsList = up.GetSettingsByAssignment( "KEY1" );
Parameter:
assignment Zugehörigkeit der Einstellung.
Rückgabe:
Eine Liste mit allen Einstellungen.
[Isom\Context\UserProfile.is: 105]
objectbound Isom.Base.Boolean Isom.Context.UserProfile.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Context\UserProfile.is: 125]
Isom.Context.UserProfile Isom.Context.UserProfile.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Context\UserProfile.is: 137]


für Serviceautoren

Isom.Context.UserProfileOption

Namensraum Isom.Context.UserProfileOption

Benutzerprofil-Optionen Mehr...

Funktionen
Funktionen zum Auslesen bestimmter Einstellungen der Benutzerprofil-Optionen

Funktionen, die das Auslesen bestimmter Werte von Einstellungen ermöglichen.

Isom.Base.String | GetName()

Ermittelt den Namen einer Benutzerprofil-Option.

Isom.Base.Boolean | IsCurrent()

Gibt an, ob diese Benutzerprofil-Option aktuell gesetzt ist.

Isom.Base.Boolean | IsDefault()

Gibt an, ob diese Benutzerprofil-Option voreingestellt ist.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Context.UserProfileOption | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Context.UserProfileOption ermöglicht es Einstellungen der Benutzerprofil-Optionen auszuwerten.

Quelldateien:

  • Isom\Context\UserProfileOption.is

Dokumentation der Funktionen

objectbound Isom.Base.String Isom.Context.UserProfileOption.GetName ( )

Ermittelt den Namen einer Benutzerprofil-Option.

Rückgabe:
Name der Option.
[Isom\Context\UserProfileOption.is: 76]
objectbound Isom.Base.Boolean Isom.Context.UserProfileOption.IsCurrent ( )

Gibt an, ob diese Benutzerprofil-Option aktuell gesetzt ist.

Rückgabe:
'true', falls die Benutzerprofil-Option aktuell gesetzt ist, 'false' sonst.
[Isom\Context\UserProfileOption.is: 87]
objectbound Isom.Base.Boolean Isom.Context.UserProfileOption.IsDefault ( )

Gibt an, ob diese Benutzerprofil-Option voreingestellt ist.

Rückgabe:
'true', falls die Benutzerprofil-Option voreingestellt gesetzt ist, 'false' sonst.
[Isom\Context\UserProfileOption.is: 99]
objectbound Isom.Base.Boolean Isom.Context.UserProfileOption.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Context\UserProfileOption.is: 119]
Isom.Context.UserProfileOption Isom.Context.UserProfileOption.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Context\UserProfileOption.is: 131]


für Serviceautoren

Isom.Context.UserProfileOptionList

Namensraum Isom.Context.UserProfileOptionList

Listen von Benutzerprofil-Optionen des Typs Isom.Context.UserProfileOption Mehr...

Funktionen
Funktion zum Setzen einer bestimmten Benutzerprofil-Option

Funktion, die eine Benutzerprofil-Option auswählt. Alle anderen Optionen werden dadurch abgewählt.

Isom.Base.Boolean | SetUserProfileOptionAsCurrent(Isom.Context.UserProfileOption newUPO)

Wählt eine Benutzerprofil-Option aus.

Listenfunktionen

Isom.Context.UserProfileOption | At(Isom.Base.Number index)

Ruft die Benutzerprofil-Option innerhalb der Liste ab, welches durch den Index ausgewählt wurde.

Isom.Context.UserProfileOption | Current()

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Isom.Base.Boolean | HasNext()

Liefert einen Wahrheitswert, der angibt ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Isom.Base.Boolean | IsEmpty()

Liefert einen Wahrheitswert, der angibt ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Context.UserProfileOption | Next()

Liefert das nächste Element in der Liste.

Isom.Base.Boolean | Reset()

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Context.UserProfileOptionList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Context.UserProfileOptionList sind Listen von Benutzerprofil-Optionen des Typs Isom.Context.UserProfileOption

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Context\UserProfileOptionList.is

Dokumentation der Funktionen

objectbound Isom.Context.UserProfileOption Isom.Context.UserProfileOptionList.At ( Isom.Base.Number index )

Ruft die Benutzerprofil-Option innerhalb der Liste ab, welches durch den Index ausgewählt wurde.

Parameter:
index Index.
Rückgabe:
Ausgewählte Benutzerprofil-Option.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 ist oder größer gleich der Anzahl der Listenelemente.
[Isom\Context\UserProfileOptionList.is: 183]
objectbound Isom.Context.UserProfileOption Isom.Context.UserProfileOptionList.Current ( )

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Rückgabe:
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Iterator zurückgesetzt wurde.
[Isom\Context\UserProfileOptionList.is: 158]
objectbound Isom.Base.Boolean Isom.Context.UserProfileOptionList.HasNext ( )

Liefert einen Wahrheitswert, der angibt ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Rückgabe:
'true', falls noch Werte in der Liste zur Verfügung stehen, 'false' sonst.
[Isom\Context\UserProfileOptionList.is: 133]
objectbound Isom.Base.Boolean Isom.Context.UserProfileOptionList.IsEmpty ( )

Liefert einen Wahrheitswert, der angibt ob diese Liste leer ist oder nicht.

Rückgabe:
'true', falls die Liste leer ist, 'false' sonst.
[Isom\Context\UserProfileOptionList.is: 121]
objectbound Isom.Base.Boolean Isom.Context.UserProfileOptionList.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Context\UserProfileOptionList.is: 203]
objectbound Isom.Base.Number Isom.Context.UserProfileOptionList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

Rückgabe:
Anzahl der Elemente.
[Isom\Context\UserProfileOptionList.is: 110]
objectbound Isom.Context.UserProfileOption Isom.Context.UserProfileOptionList.Next ( )

Liefert das nächste Element in der Liste.

Diese Funktion sollte zum Iterieren über die Liste verwendet werden.

Rückgabe:
Nächstes Element der Liste..
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Context\UserProfileOptionList.is: 146]
objectbound Isom.Base.Boolean Isom.Context.UserProfileOptionList.Reset ( )

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Rückgabe:
Immer 'true'.
[Isom\Context\UserProfileOptionList.is: 168]
objectbound Isom.Base.Boolean Isom.Context.UserProfileOptionList.SetUserProfileOptionAsCurrent ( Isom.Context.UserProfileOption newUPO )

Wählt eine Benutzerprofil-Option aus.

Alle anderen Optionen werden dadurch abgewählt.

Rückgabe:
'true' im Erfolgsfall.
[Isom\Context\UserProfileOptionList.is: 91]
Isom.Context.UserProfileOptionList Isom.Context.UserProfileOptionList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Context\UserProfileOptionList.is: 215]


für Serviceautoren

Isom.Context.UserProfileSetting

Namensraum Isom.Context.UserProfileSetting

Benutzerprofil-Einstellungen Mehr...

Funktionen
Funktionen zum Auslesen der Benutzerprofil-Einstellungen

Funktionen, die es ermöglichen bestimmte Werte der Benutzerprofil-Einstellungen auszulesen.

Isom.Base.String | GetAssignment()

Ermittelt die Zugehörigkeit einer Benutzerprofil-Einstellung.

Isom.Base.String | GetName()

Ermittelt den Namen einer Benutzerprofil-Einstellung.

Isom.Context.UserProfileOptionList | GetOptions()

Ermittelt eine Liste der Benutzerprofil-Optionen für diese Einstellung.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Context.UserProfileSetting | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Context.UserProfileSetting ermöglicht es Werte von Benutzerprofil-Einstellungen zu ermitteln.

Quelldateien:

  • Isom\Context\UserProfileSetting.is

Dokumentation der Funktionen

objectbound Isom.Base.String Isom.Context.UserProfileSetting.GetAssignment ( )

Ermittelt die Zugehörigkeit einer Benutzerprofil-Einstellung.

Rückgabe:
Zugehörigkeit der Benutzerprofil-Einstellung.
[Isom\Context\UserProfileSetting.is: 86]
objectbound Isom.Base.String Isom.Context.UserProfileSetting.GetName ( )

Ermittelt den Namen einer Benutzerprofil-Einstellung.

Rückgabe:
Name der Benutzerprofil-Einstellung.
[Isom\Context\UserProfileSetting.is: 77]
objectbound Isom.Context.UserProfileOptionList Isom.Context.UserProfileSetting.GetOptions ( )

Ermittelt eine Liste der Benutzerprofil-Optionen für diese Einstellung.

Rückgabe:
Liste der Benutzerprofil-Optionen
[Isom\Context\UserProfileSetting.is: 96]
objectbound Isom.Base.Boolean Isom.Context.UserProfileSetting.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Context\UserProfileSetting.is: 116]
Isom.Context.UserProfileSetting Isom.Context.UserProfileSetting.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Context\UserProfileSetting.is: 128]


für Serviceautoren

Isom.Context.UserProfileSettingList

Namensraum Isom.Context.UserProfileSettingList

Listen von Benutzerprofil-Einstellungen des Typs Isom.Context.UserProfileSetting Mehr...

Funktionen
Listenfunktionen

Isom.Context.UserProfileSetting | At(Isom.Base.Number index)

Ruft die Benutzerprofil-Einstellung innerhalb der Liste ab, welches durch den Index ausgewählt wurde.

Isom.Context.UserProfileSetting | Current()

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Isom.Base.Boolean | HasNext()

Liefert einen Wahrheitswert, der angibt, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Isom.Base.Boolean | IsEmpty()

Liefert einen Wahrheitswert, der angibt, ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Context.UserProfileSetting | Next()

Liefert das nächste Element in der Liste.

Isom.Base.Boolean | Reset()

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Context.UserProfileSettingList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Context.UserProfileSettingList sind Listen von Benutzerprofil-Einstellungen des Typs Isom.Context.UserProfileSetting.

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Context\UserProfileSettingList.is

Dokumentation der Funktionen

objectbound Isom.Context.UserProfileSetting Isom.Context.UserProfileSettingList.At ( Isom.Base.Number index )

Ruft die Benutzerprofil-Einstellung innerhalb der Liste ab, welches durch den Index ausgewählt wurde.

Parameter:
index Index.
Rückgabe:
Ausgewählte Benutzerprofil-Einstellung.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 ist oder größer gleich der Anzahl der Listenelemente.
[Isom\Context\UserProfileSettingList.is: 159]
objectbound Isom.Context.UserProfileSetting Isom.Context.UserProfileSettingList.Current ( )

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Rückgabe:
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Iterator zurückgesetzt wurde.
[Isom\Context\UserProfileSettingList.is: 134]
objectbound Isom.Base.Boolean Isom.Context.UserProfileSettingList.HasNext ( )

Liefert einen Wahrheitswert, der angibt, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Rückgabe:
'true' ,falls noch Werte in der Liste zur Verfügung stehen, 'false' sonst.
[Isom\Context\UserProfileSettingList.is: 109]
objectbound Isom.Base.Boolean Isom.Context.UserProfileSettingList.IsEmpty ( )

Liefert einen Wahrheitswert, der angibt, ob diese Liste leer ist oder nicht.

Rückgabe:
'true', falls die Liste leer ist, 'false' sonst.
[Isom\Context\UserProfileSettingList.is: 97]
objectbound Isom.Base.Boolean Isom.Context.UserProfileSettingList.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Context\UserProfileSettingList.is: 179]
objectbound Isom.Base.Number Isom.Context.UserProfileSettingList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

Rückgabe:
Anzahl der Elemente.
[Isom\Context\UserProfileSettingList.is: 86]
objectbound Isom.Context.UserProfileSetting Isom.Context.UserProfileSettingList.Next ( )

Liefert das nächste Element in der Liste.

Diese Funktion sollte zum Iterieren über die Liste verwendet werden.

Rückgabe:
Nächstes Element der Liste..
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Context\UserProfileSettingList.is: 122]
objectbound Isom.Base.Boolean Isom.Context.UserProfileSettingList.Reset ( )

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Rückgabe:
Immer 'true'.
[Isom\Context\UserProfileSettingList.is: 144]
Isom.Context.UserProfileSettingList Isom.Context.UserProfileSettingList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Context\UserProfileSettingList.is: 191]


für Serviceautoren

Isom.Context.VehicleOrder

Namensraum Isom.Context.VehicleOrder

Fachobjekt für einen Fahrzeugauftrag Mehr...

Funktionen
Funktionen zum Auslesen und Setzen

Funktionen, die das Auslesen und Setzen bestimmter Werte ermöglichen.

Isom.Base.String | GetImportURI()

Liefert die URI, an der ISOM den zu importierenden Fahrzeugauftrag erwartet.

Isom.Base.String | GetModelSeries()

Ermittelt die [reale] Baureihe aus dem Fahrzeugauftrag.

Isom.Base.StringDictionary | GetOemFormat()

Liefert den Fahrzeugauftrag im OEM-spezifischen Format als Wörterbuch.

Isom.Base.StringList | GetProperties(Isom.Base.String key)

Liefert eine Liste von Fahrzeugauftragselementen für den übergebenen Schlüssel.

Isom.Base.StringList | GetPropertiesKeys()

Liefert eine Liste von allen Schlüsseln, für die es Fahrzeugauftragselemente gibt.

Isom.Base.Boolean | SetModelSeries(Isom.Base.String newModelSeries)

Setzt die [reale] Baureihe im Fahrzeugauftrag.

Isom.Base.Boolean | SetProperties(Isom.Base.String key, Isom.Base.StringList properties)

Setzt eine Liste von Fahrzeugauftragselementen für den übergebenen Schlüssel.

Isom.Base.String | ToString()

Ermittelt die [unnormierte] String-Repräsentation des Fahrzeugauftrags.

Funktionen zur Modifikation des Fahrzeugauftrags

Funktionen, die es ermöglichen Modifikationen am Fahrzeugauftrag vorzunehmen.

Isom.Base.Boolean | Add(Isom.Base.String faElem)

Fügt ein Fahrzeugauftragselement zum FA-Hauptspeicherabbild hinzu.

Isom.Base.Boolean | Normalize()

Normalisiert den Fahrzeugauftrag.

Isom.Base.Boolean | Remove(Isom.Base.String faElem)

Entfernt ein Fahrzeugauftragselement aus dem FA-Hauptspeicherabbild.

Funktionen zum Prüfen von Bedingungen

Funktionen, die es ermöglichen Bedingungen des Fahrzeugauftrags zu prüfen.

Isom.Base.Boolean | Contains(Isom.Base.String faElem)

Prüft, ob der Fahrzeugauftrag das Element enthält.

Isom.Base.Boolean | Equals(Isom.Context.VehicleOrder vo)

Vergleicht zwei Fahrzeugaufträge auf semantische Gleichheit.

Isom.Base.Boolean | EvaluateTerm(Isom.Base.String faTerm)

Prüft, ob der angegebene Term für diesen Fahrzeugauftrag erfüllt ist.

Isom.Base.Boolean | IsValid()

Prüft einen Fahrzeugauftrag auf Gültigkeit.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Context.VehicleOrder | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Context.VehicleOrder | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Ein Fahrzeugauftrag (FA) beschreibt wesentliche funktionelle Aspekte der Fahrzeugkonfiguration eines konkreten Fahrzeugs.

Quelldateien:

  • Isom\Context\VehicleOrder.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Context.VehicleOrder.Add ( Isom.Base.String faElem )

Fügt ein Fahrzeugauftragselement zum FA-Hauptspeicherabbild hinzu.

   using Isom.Base.*
   ...
      Boolean FilterRetrofit...( TherapyPlanAction action )
      {
          FutureVehicleContext fvc = FutureVehicleContext.GetInstance();
          VehicleOrder voCopy = fvc.GetVehicleOrderClone();

          voCopy.Add( "$609" ); // entspr. FaManipulationen ADD $609
          ...
          fvc.ChangeVehicleOrder( voCopy );
          ...
      }
Rückgabe:
'true', falls wirklich das Element hinzugefügt wurde, d.h. die FA-Objektkopie das FA-Element noch nicht enthielt und das Einfügen erfolgreich war, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Funktion auf dem FA im aktuellen Ist-Kontext (CurrentVehiclecontext.GetInstance().GetVehicleOrderClone()) aufgerufen wird (ISOM verwaltet dieses Datenobjekt).
Es wird das Void-Objekt zurückgegeben, falls die Funktion auf dem FA im aktuellen Soll-Kontext (FutureVehicleContext.GetInstance().GetVehicleOrderClone()) aufgerufen wird (VehicleOrder.Clone() und FutureVehicleContext.ChangeVehicleOrder() ist zu benutzen).
[Isom\Context\VehicleOrder.is: 310]
objectbound Isom.Context.VehicleOrder Isom.Context.VehicleOrder.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Context\VehicleOrder.is: 506]
objectbound Isom.Base.Boolean Isom.Context.VehicleOrder.Contains ( Isom.Base.String faElem )

Prüft, ob der Fahrzeugauftrag das Element enthält.

Das übergebene FA-Element muss ein gültiges FA-Element inklusive vorangestellten FA-Typkennzeichen sein.

Rückgabe:
'true', falls das Element im FA gefunden wurde, 'false' sonst.
[Isom\Context\VehicleOrder.is: 393]
objectbound Isom.Base.Boolean Isom.Context.VehicleOrder.Equals ( Isom.Context.VehicleOrder vo )

Vergleicht zwei Fahrzeugaufträge auf semantische Gleichheit.

Die Funktion vergleicht, ob zwei Fahrzeugaufträge semantisch gleich sind. Dabei wird berücksichtigt, dass sich die Reihenfolge der Fahrzeugauftragselemente in den beiden Fahrzeugaufträgen unterscheiden kann, die beiden jedoch dieselbe Information darstellen, falls sie die gleichen Elemente besitzen. Die Funktion erzeugt von den beiden zu vergleichenden Fahrzeugaufträgen zunächst Kopien. Auf diesen Kopien wird dann die Normalisierungsfunktion Normalize() durchgeführt. Der Vergleich erfolgt dann über die Zeichenkettenrepräsentationen der normalisierten Fahrzeugaufträge. Die beiden zu vergleichenden Fahrzeugaufträgen werden somit nicht verändert, die Reihenfolge der Elemente bleibt erhalten.

      VehicleOrder vo1 = CurrentVehicleContext.GetInstance ().GetVehicleOrderClone ();
      VehicleOrder vo2 = CurrentVehicleContext.GetInstance ().GetVehicleOrderClone ();
      vo2.Normalize();
      Boolean isEqual = false;
      isEqual = vo1.Equals ( vo2 );
      if ( isEqual )
      {
          System.Stdout( "Die Fahrzeugaufträge sind gleich." );
      }
      else
      {
          System.Stdout( "Die Fahrzeugaufträge sind nicht gleich." );
      }
Rückgabe:
'true', falls die Fahrzeugaufträge gleich sind.
[Isom\Context\VehicleOrder.is: 467]
objectbound Isom.Base.Boolean Isom.Context.VehicleOrder.EvaluateTerm ( Isom.Base.String faTerm )

Prüft, ob der angegebene Term für diesen Fahrzeugauftrag erfüllt ist.

Der übergebene FA-Term darf nur AND, OR, (, ) und FA-Elemente enthalten. Anstelle eines FA-Elements sind auch folgende spezielle Schlüsselworte erlaubt: TRUE (immer "wahr") FALSE (immer "falsch") FLASHABLE ("wahr", wenn das aktuelle Steuergerät programmierbar ist) CODEABLE ("wahr", wenn das aktuelle Steuergerät codierbar ist) Zusätzlich werden folgende spezielle Syntaxformen unterstützt: Planned:<ActionName> (wahr, wenn die vorgegebene Aktion im Therapieplan enthalten ist. Ein Steuergerätebezug wird dabei unterstützt. Beispiel: [EditableEcuAction ("Flash", Texts.ACTION_ECU_FLASH, "FLASHABLE AND NOT Planned:Replace")] ) ManuallyPlanned:<ActionName> (wahr, wenn die vorgegebene Aktion manuell dem Therapieplan hinzugefügt wurde. Ein Steuergerätebezug wird dabei unterstützt. Beispiel: [EditableEcuAction ("Flash", Texts.ACTION_ECU_FLASH, "FLASHABLE AND NOT ManuallyPlanned:Replace")] )

   using Isom.Base.*
   ...
  CurrentVehicleContext currentContext = CurrentVehicleContext.GetInstance();
  VehicleOrder vo = futureContext.GetVehicleOrderClone();
  if( vo.EvaluateTerm( "§PU05 AND ($609 OR $610)" )
      ...
Rückgabe:
'true', falls das Element im FA gefunden wurde, 'false' sonst.
[Isom\Context\VehicleOrder.is: 431]
Isom.Base.String Isom.Context.VehicleOrder.GetImportURI ( )

Liefert die URI, an der ISOM den zu importierenden Fahrzeugauftrag erwartet.

Zur Benutzung der Funktion bitte Code-Beispiel beachten.

   using Isom.Base.*
   ...
      String uriVO;
      uriVO = VehicleOrder.GetImportURI();
      if( uriVO.IsVoid() )
      {
          // Fehlerbehandlung
      }
Rückgabe:
URI, falls erfolgreich.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls ein Fehler aufgetreten ist.
[Isom\Context\VehicleOrder.is: 144]
objectbound Isom.Base.String Isom.Context.VehicleOrder.GetModelSeries ( )

Ermittelt die [reale] Baureihe aus dem Fahrzeugauftrag.

Rückgabe:
[reale] Baureihe
[Isom\Context\VehicleOrder.is: 108]
objectbound Isom.Base.StringDictionary Isom.Context.VehicleOrder.GetOemFormat ( )

Liefert den Fahrzeugauftrag im OEM-spezifischen Format als Wörterbuch.

Das Wörterbuch wird im OEM-Fachdienstproxy befüllt.

Der Oem kann im Wörterbuch ein oder mehrere Schlüssel-Werte-Paare eintragen. So kann es z.B. einen Eintrag geben der den Fahrzeugauftrag exakt so enthält wie er aus dem Fahrzeug gelesen wurde. Denkbar ist auch, dass der Fahrzeugauftrag in mehrere logische Teile gegliedert wird und über das Wörterbuch mit verschiedenen Schlüsseln abfragbar ist.

   using Isom.Base.*
   ...
   StringDictionary faOEM = CurrentVehicleContext.GetInstance().GetVehicleOrderClone().GetOemFormat();
   StringList keys = faOEM.GetKeys();
   keys.Reset();
   while( keys.HasNext() )
   {
     String faKey = keys.Next();
     String faValue = faOEM.Get(faKey);
     String originalFA = "FA-OemFormat: Schlüssel(";
     originalFA.Append( faKey );
     originalFA.Append( ") Wert(" );
     originalFA.Append( faValue );
     originalFA.Append( ")" );
     // Wert ausgeben, in der Ereignisaufzeichnung eintragen, ...
   }
Rückgabe:
Wörterbuch mit dem Fahrzeugauftrag im Oem-Format
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls ein Fehler aufgetreten ist.
[Isom\Context\VehicleOrder.is: 264]
objectbound Isom.Base.StringList Isom.Context.VehicleOrder.GetProperties ( Isom.Base.String key )

Liefert eine Liste von Fahrzeugauftragselementen für den übergebenen Schlüssel.

   using Isom.Base.*
   ...
   CurrentVehicleContext cvc = CurrentVehicleContext.GetInstance();
   VehicleOrder vo = cvc.GetVehicleOrderClone();
   StringList elements = vo.GetProperties( "Extras" );
   while( elements.HasNext() )
   {
       String key = elements.Next();
       System.Stdout( key );
   }
Rückgabe:
Liste von Fahrzeugauftragselementen, falls erfolgreich.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls ein Fehler aufgetreten ist.
[Isom\Context\VehicleOrder.is: 196]
objectbound Isom.Base.StringList Isom.Context.VehicleOrder.GetPropertiesKeys ( )

Liefert eine Liste von allen Schlüsseln, für die es Fahrzeugauftragselemente gibt.

   using Isom.Base.*
   ...
   CurrentVehicleContext cvc = CurrentVehicleContext.GetInstance();
   VehicleOrder vo = cvc.GetVehicleOrderClone();
   StringList allKeys = vo.GetPropertiesKeys();
   allKeys.Reset();
   while( allKeys.HasNext() )
   {
       String key = allKeys.Next();
       System.Stdout( key );
   }
Rückgabe:
Liste von Schlüsseln, falls erfolgreich.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls ein Fehler aufgetreten ist.
[Isom\Context\VehicleOrder.is: 171]
objectbound Isom.Base.Boolean Isom.Context.VehicleOrder.IsValid ( )

Prüft einen Fahrzeugauftrag auf Gültigkeit.

Rückgabe:
'true', falls der Fahrzeugauftrag keine unzulässigen Elemente enthält, 'false' sonst
[Isom\Context\VehicleOrder.is: 477]
objectbound Isom.Base.Boolean Isom.Context.VehicleOrder.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Context\VehicleOrder.is: 497]
objectbound Isom.Base.Boolean Isom.Context.VehicleOrder.Normalize ( )

Normalisiert den Fahrzeugauftrag.

Die Funktion sortiert die Elemente des Fahrzeugauftrages. Es werden keine Elemente entfernt oder hinzugefügt.

      VehicleOrder voUnsorted = CurrentVehicleContext.GetInstance ().GetVehicleOrderClone ();
      System.Stdout ( voUnsorted.ToString( ) );
      voUnsorted.Normalize ( );
      System.Stdout ( voUnsorted.ToString( ) );
Rückgabe:
'true' falls erfolgreich.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Funktion auf dem FA im aktuellen Ist-Kontext (CurrentVehiclecontext.GetInstance().GetVehicleOrderClone()) aufgerufen wird (ISOM verwaltet dieses Datenobjekt).
[Isom\Context\VehicleOrder.is: 371]
objectbound Isom.Base.Boolean Isom.Context.VehicleOrder.Remove ( Isom.Base.String faElem )

Entfernt ein Fahrzeugauftragselement aus dem FA-Hauptspeicherabbild.

   using Isom.Base.*
   ...
      Boolean FilterRetrofit...( TherapyPlanAction action )
      {
          FutureVehicleContext fvc = FutureVehicleContext.GetInstance();
          VehicleOrder voCopy = fvc.GetVehicleOrderClone();

          voCopy.Remove( "$609" ); // entspr. FaManipulationen REMOVE $609
          ...
          fvc.ChangeVehicleOrder( voCopy );
          ...
      }
Rückgabe:
'true', falls wirklich das Element entfernt wurde, d.h. die FA-Objektkopie das FA-Element bereits enthielt und das Entfernen erfolgreich war, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Funktion auf dem FA im aktuellen Ist-Kontext (CurrentVehiclecontext.GetInstance().GetVehicleOrderClone()) aufgerufen wird (ISOM verwaltet dieses Datenobjekt).
Es wird das Void-Objekt zurückgegeben, falls die Funktion auf dem FA im aktuellen Soll-Kontext (FutureVehicleContext.GetInstance().GetVehicleOrderClone()) aufgerufen wird (VehicleOrder.Clone() und FutureVehicleContext.ChangeVehicleOrder() ist zu benutzen).
[Isom\Context\VehicleOrder.is: 347]
objectbound Isom.Base.Boolean Isom.Context.VehicleOrder.SetModelSeries ( Isom.Base.String newModelSeries )

Setzt die [reale] Baureihe im Fahrzeugauftrag.

Rückgabe:
true bei Erfolg.
Zu beachten:
Diese Funktion ist ausschließlich zur Verwendung innerhalb von Umschlüsselungen vorgesehen.
[Isom\Context\VehicleOrder.is: 119]
objectbound Isom.Base.Boolean Isom.Context.VehicleOrder.SetProperties | ( | Isom.Base.String | key,
 |  | Isom.Base.StringList | properties
 | ) |  |

Setzt eine Liste von Fahrzeugauftragselementen für den übergebenen Schlüssel.

   using Isom.Base.*
   ...
   CurrentVehicleContext cvc = CurrentVehicleContext.GetInstance();
   VehicleOrder vo = cvc.GetVehicleOrderClone();
   StringList modelType = StringList.CreateStringList();
   modelType.Insert( "NA71" );
   Boolean ret;
   ret = vo.SetProperties( "TypeCode", modelType );
   // Fehlerbehandlung falls ret!=true
   // ...
Rückgabe:
'true' falls erfolgreich. 'false' falls der übergebene Schlüssel eine leere Zeichenkette ist.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls ein Fehler aufgetreten ist.
[Isom\Context\VehicleOrder.is: 223]
objectbound Isom.Base.String Isom.Context.VehicleOrder.ToString ( )

Ermittelt die [unnormierte] String-Repräsentation des Fahrzeugauftrags.

Rückgabe:
[nicht normierte] String-Repräsentation des Fahrzeugauftrags.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls im Objekt noch kein FA-String verfügbar ist.
[Isom\Context\VehicleOrder.is: 99]
Isom.Context.VehicleOrder Isom.Context.VehicleOrder.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Context\VehicleOrder.is: 518]


für Serviceautoren

Isom.Diagnostics

Namensraum Isom.Diagnostics

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Diagnostics.MeasuredValue | Messwerte
Isom.Diagnostics.Measurement | Fachfunktionen für Liste von Messwerten des Typs Isom.Diagnostics.MeasuredValue
Isom.Diagnostics.MeasurementList | Listen von Messwerten des Typs Isom.Diagnostics.Measurement


für Serviceautoren

Isom.Diagnostics.MeasuredValue

Namensraum Isom.Diagnostics.MeasuredValue

Messwerte Mehr...

Funktionen
Isom.Diagnostics.MeasuredValue | CreateMeasuredValue(Isom.Base.String key, Isom.Base.String value, Isom.Base.String unit, Isom.Base.String min, Isom.Base.String max)

Erzeugt eine neue "MeasuredValue".

Funktionen zum Auslesen und Setzen von Werten

Funktionen, die das Auslesen und Setzen bestimmter Werte ermöglicht.

Isom.Base.String | GetKey()

Ruft den Identifikator der aktuellen "MeasuredValue" ab.

Isom.Base.String | GetMax()

Ruft den größtmöglichen Wert ab.

Isom.Base.String | GetMin()

Ruft den kleinstmöglichen Wert ab.

Isom.Base.String | GetUnit()

Ruft die Einheit der aktuellen "MeasuredValue" ab.

Isom.Base.String | GetValue()

Ruft den Anzeigetext der aktuellen "MeasuredValue" ab.

Isom.Base.Boolean | SetMax(Isom.Base.String max)

Legt den größtmöglichen Wert fest.

Isom.Base.Boolean | SetMin(Isom.Base.String min)

Legt den kleinstmöglichen Wert fest.

Isom.Base.Boolean | SetUnit(Isom.Base.String unit)

Legt die Einheit der aktuellen MeasuredValue fest.

Isom.Base.Boolean | SetValue(Isom.Base.String value)

Legt den Anzeigetext der aktuellen "MeasuredValue" fest.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Diagnostics.MeasuredValue | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Diagnostics.MeasuredValue | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Diagnostics.MeasuredValue sind Messwerte, die eingestellt und ausgelesen werden können.

Quelldateien:

  • Isom\Diagnostics\MeasuredValue.is

Dokumentation der Funktionen

objectbound Isom.Diagnostics.MeasuredValue Isom.Diagnostics.MeasuredValue.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
neue "MeasuredValue" mit demselben Inhalt.
[Isom\Diagnostics\MeasuredValue.is: 183]
Isom.Diagnostics.MeasuredValue Isom.Diagnostics.MeasuredValue.CreateMeasuredValue | ( | Isom.Base.String | key,
 |  | Isom.Base.String | value,
 |  | Isom.Base.String | unit,
 |  | Isom.Base.String | min,
 |  | Isom.Base.String | max
 | ) |  |

Erzeugt eine neue "MeasuredValue".

Parameter:
key | eindeutiger Identifikator der "MeasuredValue"
value | Initialer Wert der "MeasuredValue"
unit | Einheit der "MeasuredValue"
min | Minimaler Wert der "MeasuredValue"
max | Maximaler Wert der "MeasuredValue"
Rückgabe:
Neue Instanz von "MeasuredValue".
[Isom\Diagnostics\MeasuredValue.is: 83]
objectbound Isom.Base.String Isom.Diagnostics.MeasuredValue.GetKey ( )

Ruft den Identifikator der aktuellen "MeasuredValue" ab.

Rückgabe:
Identifikator dieser "MeasuredValue".
[Isom\Diagnostics\MeasuredValue.is: 96]
objectbound Isom.Base.String Isom.Diagnostics.MeasuredValue.GetMax ( )

Ruft den größtmöglichen Wert ab.

Rückgabe:
Der größtmögliche Wert.
[Isom\Diagnostics\MeasuredValue.is: 152]
objectbound Isom.Base.String Isom.Diagnostics.MeasuredValue.GetMin ( )

Ruft den kleinstmöglichen Wert ab.

Rückgabe:
Der kleinstmögliche Wert.
[Isom\Diagnostics\MeasuredValue.is: 136]
objectbound Isom.Base.String Isom.Diagnostics.MeasuredValue.GetUnit ( )

Ruft die Einheit der aktuellen "MeasuredValue" ab.

Rückgabe:
Einheit dieser "MeasuredValue".
[Isom\Diagnostics\MeasuredValue.is: 120]
objectbound Isom.Base.String Isom.Diagnostics.MeasuredValue.GetValue ( )

Ruft den Anzeigetext der aktuellen "MeasuredValue" ab.

Rückgabe:
Anzeigetext dieser "MeasuredValue".
[Isom\Diagnostics\MeasuredValue.is: 104]
objectbound Isom.Base.Boolean Isom.Diagnostics.MeasuredValue.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, andernfalls 'false'.
[Isom\Diagnostics\MeasuredValue.is: 175]
objectbound Isom.Base.Boolean Isom.Diagnostics.MeasuredValue.SetMax ( Isom.Base.String max )

Legt den größtmöglichen Wert fest.

Rückgabe:
Immer 'true'.
[Isom\Diagnostics\MeasuredValue.is: 160]
objectbound Isom.Base.Boolean Isom.Diagnostics.MeasuredValue.SetMin ( Isom.Base.String min )

Legt den kleinstmöglichen Wert fest.

Rückgabe:
Immer 'true'.
[Isom\Diagnostics\MeasuredValue.is: 144]
objectbound Isom.Base.Boolean Isom.Diagnostics.MeasuredValue.SetUnit ( Isom.Base.String unit )

Legt die Einheit der aktuellen MeasuredValue fest.

Rückgabe:
Immer 'true'.
[Isom\Diagnostics\MeasuredValue.is: 128]
objectbound Isom.Base.Boolean Isom.Diagnostics.MeasuredValue.SetValue ( Isom.Base.String value )

Legt den Anzeigetext der aktuellen "MeasuredValue" fest.

Rückgabe:
Immer 'true'.
[Isom\Diagnostics\MeasuredValue.is: 112]
Isom.Diagnostics.MeasuredValue Isom.Diagnostics.MeasuredValue.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
ungültiges Objekt
[Isom\Diagnostics\MeasuredValue.is: 195]


für Serviceautoren

Isom.Diagnostics.Measurement

Namensraum Isom.Diagnostics.Measurement

Fachfunktionen für Liste von Messwerten des Typs Isom.Diagnostics.MeasuredValue Mehr...

Funktionen
Isom.Diagnostics.Measurement | CreateMeasurement(Isom.Base.String key)

Erzeugt eine neue Liste.

Funktionen zum Bearbeiten und Verwenden von Messwerten

Funktionen, die es ermöglichen Messwerte zu Bearbeiten und Verwenden.

Isom.Base.Boolean | AddMeasuredValue(Isom.Diagnostics.MeasuredValue measure)

Fügt einen Messwert der Liste hinzu.

Isom.Diagnostics.MeasuredValue | FindByKey(Isom.Base.String key)

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Isom.Base.String | GetDisplayType()

Liefert die aktuell gewünschte Darstellungsart.

Isom.Base.String | GetHeading()

Gibt die optionale Überschrift für die Messwerte zurück.

Isom.Base.String | GetKey()

Ruft den Identifikator der aktuellen Messwertgruppe ab.

Isom.Base.Boolean | SetDisplayType(Isom.Base.String displayType)

Legt die gewünschte Darstellungsart fest.

Isom.Base.Boolean | SetHeading(Isom.Base.String heading)

Setzt die optionale Überschrift für die Messwerte.

Listenfunktionen

Isom.Base.Boolean | Contains(Isom.Diagnostics.MeasuredValue element)

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Isom.Diagnostics.MeasuredValue | Current()

Liefert den aktuelle Messwert.

Isom.Base.Boolean | HasNext()

Bestimmt, ob noch weitere Messwerte in der Liste vorhanden sind.

Isom.Base.Boolean | IsEmpty()

Prüft, ob die Liste Elemente enthält.

Isom.Base.Number | Length()

Liefert die Anzahl der Messwerte in der Liste.

Isom.Diagnostics.MeasuredValue | Next()

Liefert den nächsten Messwerte.

Isom.Base.Boolean | Reset()

Setzt den Listeniterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Diagnostics.Measurement | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Diagnostics.Measurement | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Das folgende Quelltext-Beispiel zeigt die Verwendung am Beispiel einer Messwertanzeige in einem Assistentenschritt.

 Isom.Base.Boolean UpdatedMeasurementStep(Isom.Request.Wizard wizard)
 {
    wizard.AddMessage("Message", "   ");

    Isom.Base.String msg2 = "UpdateFunktion: ";
    msg2.Append(wizard.GetUpdateFunction());

    wizard.AddMessage("MessageNeuLine", "   ");

    // Messgröße erzeugen
    Isom.Diagnostics.Measurement measureXAngle = Isom.Diagnostics.Measurement.CreateMeasurement("XAngle");
    Isom.Diagnostics.Measurement measureYAngle = Isom.Diagnostics.Measurement.CreateMeasurement("YAngle");
    // Anzeigetyp festlegen (muss dem Client bekannt sein)
    measureXAngle.SetDisplayType("BARITEM horizontal filled");
    measureYAngle.SetDisplayType("VOLTAGE");

    measureXAngle.SetHeading("X");
    measureYAngle.SetHeading("Y");

    // Messwert "XAngleValue" und "YAngleValue" erzeugen
    // (Identifikator, Startwert, Einheit, untere und obere Grenze des Wertebereichs)
    Isom.Diagnostics.MeasuredValue xAngle =
        Isom.Diagnostics.MeasuredValue.CreateMeasuredValue("XAngleValue", "0.0", "°", "-15.0", "15.0");
    Isom.Diagnostics.MeasuredValue yAngle =
        Isom.Diagnostics.MeasuredValue.CreateMeasuredValue("YAngleValue", "0.0", "°", "-15.0", "15.0");

    // Zu Messgröße "XAngle" bzw. "YAngle" hinzufügen
    measureXAngle.AddMeasuredValue(xAngle);
    measureYAngle.AddMeasuredValue(yAngle);

    // Liste von Messgrößen erzeugen
    wizard.AddMeasurement("MesX", measureXAngle);
    wizard.AddMeasurement("MesY", measureYAngle);

    return true;
 }

Quelldateien:

  • Isom\Diagnostics\Measurement.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Diagnostics.Measurement.AddMeasuredValue ( Isom.Diagnostics.MeasuredValue measure )

Fügt einen Messwert der Liste hinzu.

Rückgabe:
Immer 'true'.
[Isom\Diagnostics\Measurement.is: 138]
objectbound Isom.Diagnostics.Measurement Isom.Diagnostics.Measurement.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
neue "Measurement" mit demselben Inhalt.
[Isom\Diagnostics\Measurement.is: 295]
objectbound Isom.Base.Boolean Isom.Diagnostics.Measurement.Contains ( Isom.Diagnostics.MeasuredValue element )

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Parameter:
element gesuchtes Element
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Diagnostics\Measurement.is: 272]
Isom.Diagnostics.Measurement Isom.Diagnostics.Measurement.CreateMeasurement ( Isom.Base.String key )

Erzeugt eine neue Liste.

Rückgabe:
Neue Listeninstanz.
[Isom\Diagnostics\Measurement.is: 124]
objectbound Isom.Diagnostics.MeasuredValue Isom.Diagnostics.Measurement.Current ( )

Liefert den aktuelle Messwert.

Rückgabe:
Aktueller Messwert oder ein Void-Objekt, falls der Iterator am Anfang der Liste steht.
[Isom\Diagnostics\Measurement.is: 253]
objectbound Isom.Diagnostics.MeasuredValue Isom.Diagnostics.Measurement.FindByKey ( Isom.Base.String key )

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Parameter:
key Identifikator des zu suchenden Objekts.
Rückgabe:
Das Objekt oder das Void-Objekt, falls die Liste kein Messwert mit diesem Identifikator enthält.
[Isom\Diagnostics\Measurement.is: 149]
objectbound Isom.Base.String Isom.Diagnostics.Measurement.GetDisplayType ( )

Liefert die aktuell gewünschte Darstellungsart.

Rückgabe:
Gewünschte Darstellungsart.
[Isom\Diagnostics\Measurement.is: 165]
objectbound Isom.Base.String Isom.Diagnostics.Measurement.GetHeading ( )

Gibt die optionale Überschrift für die Messwerte zurück.

Rückgabe:
Die optionale Überschrift, falls sie gesetzt ist, sonst "Void".
[Isom\Diagnostics\Measurement.is: 202]
objectbound Isom.Base.String Isom.Diagnostics.Measurement.GetKey ( )

Ruft den Identifikator der aktuellen Messwertgruppe ab.

Rückgabe:
Identifikator dieser Messwertgruppe.
[Isom\Diagnostics\Measurement.is: 157]
objectbound Isom.Base.Boolean Isom.Diagnostics.Measurement.HasNext ( )

Bestimmt, ob noch weitere Messwerte in der Liste vorhanden sind.

Rückgabe:
'true', falls weitere Messwerte vorhanden sind, 'false' sonst.
[Isom\Diagnostics\Measurement.is: 244]
objectbound Isom.Base.Boolean Isom.Diagnostics.Measurement.IsEmpty ( )

Prüft, ob die Liste Elemente enthält.

Rückgabe:
'true', falls keine Messwerte vorhanden sind, 'false' sonst.
[Isom\Diagnostics\Measurement.is: 225]
objectbound Isom.Base.Boolean Isom.Diagnostics.Measurement.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true' wenn es das Void-Objekt ist, 'false' sonst.
[Isom\Diagnostics\Measurement.is: 287]
objectbound Isom.Base.Number Isom.Diagnostics.Measurement.Length ( )

Liefert die Anzahl der Messwerte in der Liste.

Rückgabe:
Anzahl der Messwerte.
[Isom\Diagnostics\Measurement.is: 216]
objectbound Isom.Diagnostics.MeasuredValue Isom.Diagnostics.Measurement.Next ( )

Liefert den nächsten Messwerte.

Rückgabe:
Nächster Messwert in der Liste oder ein Void-Objekt, falls der Iterator auf dem letzten Objekt der Liste steht.
[Isom\Diagnostics\Measurement.is: 234]
objectbound Isom.Base.Boolean Isom.Diagnostics.Measurement.Reset ( )

Setzt den Listeniterator zurück.

Rückgabe:
Immer 'true'.
[Isom\Diagnostics\Measurement.is: 261]
objectbound Isom.Base.Boolean Isom.Diagnostics.Measurement.SetDisplayType ( Isom.Base.String displayType )

Legt die gewünschte Darstellungsart fest.

Die Darstellungsart muss dem Client bekannt sein. Momentan sind für den Taurus Client folgende Werte zulässig (ohne Berücksichtung der Groß-/Kleinschreibung):

  • baritem für eine lineare Anzeige
  • voltage für eine Skalenanzeige, ähnlich einem analogen Messgerät

Für den Wert baritem können zusätzliche Parameter angegeben werden:

  • horizontal oder vertical legt die Ausrichtung fest (Vorgabewert ist horizontal)
  • filled gibt an, dass ein ausgefüllter Balken statt einer Markierung angezeigt werden soll Mehrere Parameter werden durch Leerzeichen getrennt angegeben.

Rückgabe:
Immer 'true'.
[Isom\Diagnostics\Measurement.is: 186]
objectbound Isom.Base.Boolean Isom.Diagnostics.Measurement.SetHeading ( Isom.Base.String heading )

Setzt die optionale Überschrift für die Messwerte.

Rückgabe:
Immer 'true'
[Isom\Diagnostics\Measurement.is: 194]
Isom.Diagnostics.Measurement Isom.Diagnostics.Measurement.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
ungültiges Objekt
[Isom\Diagnostics\Measurement.is: 307]


für Serviceautoren

Isom.Diagnostics.MeasurementList

Namensraum Isom.Diagnostics.MeasurementList

Listen von Messwerten des Typs Isom.Diagnostics.Measurement Mehr...

Funktionen
Isom.Diagnostics.MeasurementList | CreateMeasurementList()

Erzeugt eine neue Liste.

Funktionen zum Erzeugen und Verwenden von Messwerten

Funktionen, die es ermöglichen Messwerte zu erzeugen, hinzuzufügen und zu finden.

Isom.Base.Boolean | AddMeasurement(Isom.Diagnostics.Measurement measure)

Fügt der Liste ein Element hinzu.

Isom.Diagnostics.Measurement | FindByKey(Isom.Base.String key)

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Listenfunktionen

Isom.Base.Boolean | Contains(Isom.Diagnostics.Measurement element)

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Isom.Diagnostics.Measurement | Current()

Liefert das aktuelle Elemente.

Isom.Base.Boolean | HasNext()

Bestimmt, ob noch weitere Elemente in der Liste vorhanden sind.

Isom.Base.Boolean | IsEmpty()

Prüft, ob die Liste Elemente enthält.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Diagnostics.Measurement | Next()

Liefert das nächste Element.

Isom.Base.Boolean | Reset()

Setzt den Listeniterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Diagnostics.MeasurementList | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Diagnostics.MeasurementList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Diagnostics.MeasurementList sind Listen von Messwerten des Typs Isom.Diagnostics.Measurement

Quelldateien:

  • Isom\Diagnostics\MeasurementList.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Diagnostics.MeasurementList.AddMeasurement ( Isom.Diagnostics.Measurement measure )

Fügt der Liste ein Element hinzu.

Rückgabe:
Immer 'true'.
[Isom\Diagnostics\MeasurementList.is: 91]
objectbound Isom.Diagnostics.MeasurementList Isom.Diagnostics.MeasurementList.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue "MeasurementList" mit demselben Inhalt.
[Isom\Diagnostics\MeasurementList.is: 196]
objectbound Isom.Base.Boolean Isom.Diagnostics.MeasurementList.Contains ( Isom.Diagnostics.Measurement element )

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Diagnostics\MeasurementList.is: 173]
Isom.Diagnostics.MeasurementList Isom.Diagnostics.MeasurementList.CreateMeasurementList ( )

Erzeugt eine neue Liste.

Rückgabe:
neue Listeninstanz
[Isom\Diagnostics\MeasurementList.is: 77]
objectbound Isom.Diagnostics.Measurement Isom.Diagnostics.MeasurementList.Current ( )

Liefert das aktuelle Elemente.

Rückgabe:
Aktuelles Elemente oder ein Void-Objekt, falls der Iterator am Anfang der Liste steht.
[Isom\Diagnostics\MeasurementList.is: 154]
objectbound Isom.Diagnostics.Measurement Isom.Diagnostics.MeasurementList.FindByKey ( Isom.Base.String key )

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Parameter:
key Identifikator des zu suchenden Objekts.
Rückgabe:
Das Element oder das Void-Objekt, falls die Liste kein Element mit diesem Identifikator enthält.
[Isom\Diagnostics\MeasurementList.is: 102]
objectbound Isom.Base.Boolean Isom.Diagnostics.MeasurementList.HasNext ( )

Bestimmt, ob noch weitere Elemente in der Liste vorhanden sind.

Rückgabe:
'true', falls weitere Elemente vorhanden sind, 'false' sonst.
[Isom\Diagnostics\MeasurementList.is: 145]
objectbound Isom.Base.Boolean Isom.Diagnostics.MeasurementList.IsEmpty ( )

Prüft, ob die Liste Elemente enthält.

Rückgabe:
'true', falls keine Elemente vorhanden sind, 'false' sonst.
[Isom\Diagnostics\MeasurementList.is: 126]
objectbound Isom.Base.Boolean Isom.Diagnostics.MeasurementList.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Diagnostics\MeasurementList.is: 188]
objectbound Isom.Base.Number Isom.Diagnostics.MeasurementList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

Rückgabe:
Anzahl der Elemente.
[Isom\Diagnostics\MeasurementList.is: 117]
objectbound Isom.Diagnostics.Measurement Isom.Diagnostics.MeasurementList.Next ( )

Liefert das nächste Element.

Rückgabe:
Nächstes Element in der Liste oder ein Void-Objekt, falls der Iterator auf dem letzten Objekt der Liste steht.
[Isom\Diagnostics\MeasurementList.is: 135]
objectbound Isom.Base.Boolean Isom.Diagnostics.MeasurementList.Reset ( )

Setzt den Listeniterator zurück.

Rückgabe:
Immer 'true'.
[Isom\Diagnostics\MeasurementList.is: 162]
Isom.Diagnostics.MeasurementList Isom.Diagnostics.MeasurementList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt
[Isom\Diagnostics\MeasurementList.is: 208]


für Serviceautoren

Isom.Exchange

Namensraum Isom.Exchange

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Exchange.DataDescription | Datenbeschreibungen, durch die Daten gesichert und geladen werden können
Isom.Exchange.DataDescriptionList | Listen von Datenbeschreibungen der Fachklasse Isom.Exchange.DataDescription
Isom.Exchange.DataExchange | Interaktion mit der Datenaustauschschnittstelle zur Verwaltung abgelegter Datensätze.
Isom.Exchange.DataHandle | Identifikator für Daten, die über die Datenaustauschschnittstelle von ISOM gelesen und geschrieben werden können


für Serviceautoren

Isom.Exchange.DataDescription

Namensraum Isom.Exchange.DataDescription

Datenbeschreibungen, durch die Daten gesichert und geladen werden können Mehr...

Funktionen
Isom.Exchange.DataDescription | Create()

Liefert eine neue Instanz.

Funktionen zum Bearbeiten und Verwenden von Datenbeschreibungen

Funktionen, die das Bearbeiten und Verwenden von Datenbeschreibungen ermöglichen.

Isom.Base.String | GetDataType()

Gibt den Namen des Typs der beschriebenen Daten zurück.

Isom.Base.StringDictionary | GetIndices()

Gibt die Indizes der beschriebenen Daten zurück.

Isom.Base.Boolean | IsRequired()

Gibt an, ob die beschriebenen Daten notwendig für einen Datenimport sind.

Isom.Base.Boolean | SetDataType(Isom.Base.String dataType)

Legt den Datentyp der beschriebenen Daten fest.

Isom.Base.Boolean | SetIndices(Isom.Base.StringDictionary indices)

Legt die Indizes der beschriebenen Daten fest.

Isom.Base.Boolean | SetRequired(Isom.Base.Boolean required)

Legt fest, ob die beschriebenen Daten notwendig für einen Datenimport sind.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Exchange.DataDescription | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Isom.Exchange.DataDescription | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Isom.Exchange.DataDescription sind Datenbeschreibungen, durch die Daten mit den Funktionen in Isom.Exchange.DataExchange gesichert und geladen werden können

Bemerkungen:
Auf der Serviceplattform Taurus® wird zur Datenablage der Dienst Hermes verwendet. Die unterstützten Datenarten werden in der Konfiguration von Hermes festgelegt. Instanzen der Fachklasse Isom.Exchange.DataDescription beschreiben die Daten, auf die zugegriffen wird. Sie legen die Indizes fest, mit denen die Daten gegenüber Hermes identifiziert werden. Ist z. B. wie bei ISOM Didact kein Dienst zur Datenablage vorhanden, muss ein gültiges Datenaustauschverzeichnis für ISOM konfiguriert sein.
Achtung:
Wenn für einen Datentyp Indizes definiert sind, die mit "Vin" beginnen, können diese Indizes automatisch mit der 7-stelligen Fahrgestellnummer aus dem Isom.Context.CurrentVehicleContext befüllt werden. Das erfolgt immer dann, wenn eine entsprechende Datenbeschreibung bei einem Funktionsaufruf übergeben wird, in der ein solcher Index nicht festgelegt ist. Vom Autor gesetzte Indizes werden nicht überschrieben.
Verwendungsbeispiel:
   //Erzeugen der Instanz
   Isom.Exchange.DataDescription dataDescription = Isom.Exchange.DataDescription.Create();

   //Setzen des Datentyps VehicleOrder
   dataDescription.SetDataType("VehicleOrder");

   //Erzeugen eines Wörterbuchs für die Indizes
   Isom.Base.StringDictionary indices = Isom.Base.StringDictionary.CreateStringDictionary();

   //Eintragen des Index Vin7 in das Wörterbuch
   //Wird vom Autor vorgegeben und daher nicht automatisch mit der Fahrgestellnummer
   //aus dem Isom.Context.CurrentVehicleContext belegt
   indices.Add("Vin7", "1234567");

   //Setzen der Indizes
   dataDescription.SetIndices(indices);

   //Abfrage der Zugriffsinstanz auf die Datenablage
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();

   //Einlesen des Datensatzes
   Isom.Exchange.DataHandle handle = dataExchange.Load(description);

Den dazu passenden Auszug aus einer Hermes-Konfiguration zeigt folgendes Beispiel:

   <DataType Name="VehicleOrder">
     <RequiredKeys>
       <Index Name="Vin7"/>
     </RequiredKeys>
     ..
   </DataType>

Quelldateien:

  • Isom\Exchange\DataDescription.is

Dokumentation der Funktionen

objectbound Isom.Exchange.DataDescription Isom.Exchange.DataDescription.Clone ( )

Erzeugt eine Kopie dieses Objekts.

   //Erzeugen einer Instanz
   Isom.Exchange.DataDescription dataDescription = Isom.Exchange.DataDescription.Create();

   //Erzeugen einer Kopie
   Isom.Exchange.DataDescription clone = dataDescription.Clone();
Rückgabe:
Isom.Exchange.DataDescription
Neue DataDescription mit demselben Inhalt.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescription.is: 355]
Isom.Exchange.DataDescription Isom.Exchange.DataDescription.Create ( )

Liefert eine neue Instanz.

In der neuen Instanz sind weder Datentyp noch Schlüssel eingetragen.

   //Erzeugen der Instanz
   Isom.Exchange.DataDescription dataDescription = Isom.Exchange.DataDescription.Create();
Rückgabe:
Isom.Exchange.DataDescription
Neue, leere Instanz der Fachklasse.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescription.is: 139]
objectbound Isom.Base.String Isom.Exchange.DataDescription.GetDataType ( )

Gibt den Namen des Typs der beschriebenen Daten zurück.

Die unterstützten Datentypen werden von der verwendeten Datenablage festgelegt

   //Erzeugen der Instanz
   Isom.Exchange.DataDescription dataDescription = Isom.Exchange.DataDescription.Create();

   //Setzen des Datentyps VehicleOrder
   dataDescription.SetDataType("VehicleOrder");

   //Abfrage des Datentyps
   Isom.Base.String dataType = dataDescription.GetDataType();
Rückgabe:
Isom.Base.String
Der Name des Datentyps.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescription.is: 170]
objectbound Isom.Base.StringDictionary Isom.Exchange.DataDescription.GetIndices ( )

Gibt die Indizes der beschriebenen Daten zurück.

Die Indizes, mit denen Daten identifiziert werden, werden von der verwendeten Datenablage vorgegeben.

   //Erzeugen der Instanz
   Isom.Exchange.DataDescription dataDescription = Isom.Exchange.DataDescription.Create();

   //Erzeugen eines Wörterbuchs für die Indizes
   Isom.Base.StringDictionary indices = Isom.Base.StringDictionary.CreateStringDictionary();

   //Eintragen des Index Vin7 in das Wörterbuch
   indices.Add("Vin7", "1234567");

   //Setzen des Datentyps VehicleOrder
   dataDescription.SetIndices(indices);

   //Abfrage des Datentyps
   indices = dataDescription.GetIndices();
Rückgabe:
Isom.Base.StringDictionary
Indizes der beschriebenen Daten.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescription.is: 202]
objectbound Isom.Base.Boolean Isom.Exchange.DataDescription.IsRequired ( )

Gibt an, ob die beschriebenen Daten notwendig für einen Datenimport sind.

Veraltet:
Veraltet seit Argonaut 1.17.
   //Erzeugen der Instanz
   Isom.Exchange.DataDescription dataDescription = Isom.Exchange.DataDescription.Create();

   //Abfrage, ob die beschriebene Datei notwendig ist.
   Isom.Base.Boolean req = dataDescription.IsRequired();
Rückgabe:
Isom.Base.Boolean
'true' genau dann, wenn die Datei notwendig für einen Datenimport ist.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescription.is: 224]
objectbound Isom.Base.Boolean Isom.Exchange.DataDescription.IsVoid ( )

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Das Void-Objekt wird z. B. geliefert, um einen Fehlerfall anzuzeigen

   //Erzeugen einer Instanz
   Isom.Exchange.DataDescription dataDescription = Isom.Exchange.DataDescription.Create();

   //Prüfung auf Void
   if (dataDescription.IsVoid())
   {
     //Fehlerbehandlung
   }
Rückgabe:
Isom.Base.Boolean
'true' genau dann, wenn dies das Void-Objekt ist.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescription.is: 335]
objectbound Isom.Base.Boolean Isom.Exchange.DataDescription.SetDataType ( Isom.Base.String dataType )

Legt den Datentyp der beschriebenen Daten fest.

Die unterstützten Datentypen werden von der verwendeten Datenablage festgelegt und können mit Isom.Exchange.DataExchange.GetSupportedDataTypes() abgefragt werden. In dieser Fachfunktion erfolgt keine Prüfung, ob der übergebene Wert unterstützt wird.

   //Erzeugen der Instanz
   Isom.Exchange.DataDescription dataDescription = Isom.Exchange.DataDescription.Create();

   //Setzen des Datentyps VehicleOrder
   dataDescription.SetDataType("VehicleOrder");
Parameter:
dataType Namen des Datentyps.
Rückgabe:
Isom.Base.Boolean
Immer 'true'.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescription.is: 249]
objectbound Isom.Base.Boolean Isom.Exchange.DataDescription.SetIndices ( Isom.Base.StringDictionary indices )

Legt die Indizes der beschriebenen Daten fest.

Die Indizes, mit denen Daten identifiziert werden, werden von der verwendeten Datenablage vorgegeben. In dieser Fachfunktion erfolgt keine Prüfung, ob die übergebenen Werte unterstützt werden.

   //Erzeugen der Instanz
   Isom.Exchange.DataDescription dataDescription = Isom.Exchange.DataDescription.Create();

   //Erzeugen eines Wörterbuchs für die Indizes
   Isom.Base.StringDictionary indices = Isom.Base.StringDictionary.CreateStringDictionary();

   //Eintragen des Index Vin7 in das Wörterbuch
   indices.Add("Vin7", "1234567");

   //Setzen der Indizes
   dataDescription.SetIndices(indices);
Parameter:
dataType Indizes der Daten.
Rückgabe:
Isom.Base.Boolean
Immer 'true'.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescription.is: 280]
objectbound Isom.Base.Boolean Isom.Exchange.DataDescription.SetRequired ( Isom.Base.Boolean required )

Legt fest, ob die beschriebenen Daten notwendig für einen Datenimport sind.

Veraltet:
Veraltet seit Argonaut 1.17.
   //Erzeugen der Instanz
   Isom.Exchange.DataDescription dataDescription = Isom.Exchange.DataDescription.Create();

   //Festlegung, dass die beschriebene Datei notwendig ist.
   dataDescription.SetRequired(true);
Parameter:
dataType 'true' für notwendige Daten, 'false' sonst.
Rückgabe:
Isom.Base.Boolean
immer 'true'.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescription.is: 303]
Isom.Exchange.DataDescription Isom.Exchange.DataDescription.Void ( )

Erzeugt ein Void-Objekt.

Erzeugt ein Void-Objekt. Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

   //Erzeuge Void-Objekt
   Isom.Exchange.DataDescription dataDescription = Isom.Exchange.DataDescription.Void();
Rückgabe:
Isom.Exchange.DataDescription
Ungültiges Objekt.
Ausnahmebehandlung:
Die Funktion liefert immer Void.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescription.is: 377]


für Serviceautoren

Isom.Exchange.DataDescriptionList

Namensraum Isom.Exchange.DataDescriptionList

Listen von Datenbeschreibungen der Fachklasse Isom.Exchange.DataDescription Mehr...

Funktionen
Funktionen zum Erzeugen und Durchsuchen von Listen

Funktionen, die es ermöglichen Datenbeschreibungslisten zu erzeugen und durchsuchen.

Isom.Exchange.DataDescriptionList | Create()

Legt eine neue Liste an.

Isom.Exchange.DataDescription | FindByType(Isom.Base.String name)

Sucht das erste Vorkommen einer Datenbeschreibung eines Typs in der Liste.

Isom.Base.Boolean | IsDefinedType(Isom.Base.String name)

Prüft, ob eine Datenbeschreibung eines Typs in der Liste vorkommt.

Listenfunktionen

Isom.Base.Boolean | Contains(Isom.Exchange.DataDescription element)

Abfrage, ob ein Element in der Liste vorhanden ist.

Isom.Exchange.DataDescription | Current()

Liefert beim Durchlaufen der Liste die aktuelle Datenbeschreibung.

Isom.Base.Boolean | HasNext()

Prüft, ob es beim Durchlaufen der Liste Datenbeschreibungen gibt, die noch nicht abgerufen wurden.

Isom.Base.Boolean | IsEmpty()

Prüft, ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Exchange.DataDescription | Next()

Liefert beim Durchlaufen der Liste die nächste Datenbeschreibung.

Isom.Base.Boolean | Reset()

Setzt den Listeniterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Exchange.DataDescriptionList | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Exchange.DataDescriptionList | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Das Fachobjekt DataExchange ermöglicht den Zugriff auf die Datenaustauschkomponente von ISOM.

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Exchange\DataDescriptionList.is

Dokumentation der Funktionen

objectbound Isom.Exchange.DataDescriptionList Isom.Exchange.DataDescriptionList.Clone ( )

Erzeugt eine Kopie dieses Objekts.

   //Erzeugen einer Instanz
   Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Create();

   //Erzeugen einer Kopie
   Isom.Exchange.DataDescriptionList clone = dataDescrList.Clone();
Rückgabe:
Isom.Exchange.DataDescriptionList
Neue Liste mit demselben Inhalt.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescriptionList.is: 382]
objectbound Isom.Base.Boolean Isom.Exchange.DataDescriptionList.Contains ( Isom.Exchange.DataDescription element )

Abfrage, ob ein Element in der Liste vorhanden ist.

 Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Create();
 Isom.Exchange.DataDescription dataDescr = Isom.Exchange.DataDescription.Create();
 Isom.Base.Boolean contains = dataDescrList.Contains(dataDescr);    // contains ist false
 dataDescrList.Insert(dataDescr);
 Isom.Base.Boolean contains = dataDescrList.Contains(dataDescr);    // contains ist true
Parameter:
element Gesuchtes Element.
Rückgabe:
Isom.Base.Boolean
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Exchange\DataDescriptionList.is: 330]
Isom.Exchange.DataDescriptionList Isom.Exchange.DataDescriptionList.Create ( )

Legt eine neue Liste an.

Die erzeugte Liste enthält keine Elemente.

   //Erzeugen der Instanz
   Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Create();
Rückgabe:
Isom.Exchange.DataDescriptionList
Die neue Liste.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescriptionList.is: 98]
objectbound Isom.Exchange.DataDescription Isom.Exchange.DataDescriptionList.Current ( )

Liefert beim Durchlaufen der Liste die aktuelle Datenbeschreibung.

 Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Create();
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Reset();                        //Listendurchlauf vorbereiten
 while (dataDescrList.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    dataDescrList.Next();                                                //Durchlauf weiterführen
    Isom.Exchange.DataDescription current = dataDescrList.Current();     //Element abrufen
 }
Rückgabe:
Isom.Exchange.DataDescription
Aktuelle Datenbeschreibung.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Listendurchlauf am Anfang der Liste steht.
[Isom\Exchange\DataDescriptionList.is: 289]
objectbound Isom.Exchange.DataDescription Isom.Exchange.DataDescriptionList.FindByType ( Isom.Base.String name )

Sucht das erste Vorkommen einer Datenbeschreibung eines Typs in der Liste.

   //Erzeugen einer Datenbeschreibung
   Isom.Exchange.DataDescription voDescription = Isom.Exchange.DataDescription.Create();

   //Setzen des Datentyps VehicleOrder
   voDescription.SetDataType("VehicleOrder");

   //Erzeugen einer Liste
   Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Create();

   //Einfügen der Datenbeschreibung in die Liste
   dataDescrList.Insert(voDescription);

   //Suche nach Datentyp VehicleOrder
   Isom.Exchange.DataDescription result = dataDescrList.FindByType("VehicleOrder"); //result enthält voDescription

   //Suche nach Datentyp ActivationCode
   result = dataDescrList.FindByType("ActivationCode"); //result enthält Void
Parameter:
name Name des gesuchten Typs.
Rückgabe:
Isom.Exchange.DataDescription
Das erste Vorkommen einer Datenbeschreibung des gesuchten Typs
Ausnahmebehandlung:
Die Funktion liefert Void, falls die Liste keine Datenbeschreibung mit diesem Datentypen enthält.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescriptionList.is: 134]
objectbound Isom.Base.Boolean Isom.Exchange.DataDescriptionList.HasNext ( )

Prüft, ob es beim Durchlaufen der Liste Datenbeschreibungen gibt, die noch nicht abgerufen wurden.

 Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Create();
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Reset();                        //Listendurchlauf vorbereiten
 while (dataDescrList.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    Isom.Exchange.DataDescription current = dataDescrList.Next();     //Element abrufen und Durchlauf weiterführen
 }
Rückgabe:
Isom.Base.Boolean
true', falls noch Zeichenketten in der Liste mit .Next() abgerufen werden können, 'false' sonst.
[Isom\Exchange\DataDescriptionList.is: 263]
objectbound Isom.Base.Boolean Isom.Exchange.DataDescriptionList.IsDefinedType ( Isom.Base.String name )

Prüft, ob eine Datenbeschreibung eines Typs in der Liste vorkommt.

   //Erzeugen einer Datenbeschreibung
   Isom.Exchange.DataDescription voDescription = Isom.Exchange.DataDescription.Create();

   //Setzen des Datentyps VehicleOrder
   voDescription.SetDataType("VehicleOrder");

   //Erzeugen einer Liste
   Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Create();

   //Einfügen der Datenbeschreibung in die Liste
   dataDescrList.Insert(voDescription);

   //Suche nach Datentyp VehicleOrder
   Isom.Base.Boolean result = dataDescrList.IsDefinedType("VehicleOrder"); //result ist 'true'

   //Suche nach Datentyp ActivationCode
   result = dataDescrList.IsDefinedType("ActivationCode"); //result ist 'false'
Parameter:
name Name des gesuchten Typs.
Rückgabe:
Isom.Base.Boolean
'true' genau dann, wenn die Liste eine Datenbeschreibung eines Typs mit diesem Namen enthält.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescriptionList.is: 167]
objectbound Isom.Base.Boolean Isom.Exchange.DataDescriptionList.IsEmpty ( )

Prüft, ob diese Liste leer ist oder nicht.

 Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Create();
 Isom.Base.Boolean isEmpty = dataDescrList.IsEmpty();    // isEmpty ist true
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 isEmpty = dataDescrList.IsEmpty();                      // isEmpty ist false
Rückgabe:
Isom.Base.Boolean
'true', falls die Liste leer ist, 'false' sonst.
[Isom\Exchange\DataDescriptionList.is: 210]
objectbound Isom.Base.Boolean Isom.Exchange.DataDescriptionList.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Das Void-Objekt wird z. B. geliefert, um einen Fehlerfall anzuzeigen

   //Erzeugen einer Instanz
   Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Create();

   //Prüfung auf Void
   if (dataDescrList.IsVoid())
   {
     //Fehlerbehandlung
   }
Rückgabe:
Isom.Base.Boolean
'true', falls das Objekt Void ist, 'false' sonst.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescriptionList.is: 362]
objectbound Isom.Base.Number Isom.Exchange.DataDescriptionList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

 Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Create();
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 Isom.Base.Number length = dataDescrList.Length();  //length ist 3
Rückgabe:
Isom.Base.Number
Anzahl der Elemente.
[Isom\Exchange\DataDescriptionList.is: 193]
objectbound Isom.Exchange.DataDescription Isom.Exchange.DataDescriptionList.Next ( )

Liefert beim Durchlaufen der Liste die nächste Datenbeschreibung.

Ein Listendurchlauf wird mit .Reset() zurückgesetzt, um sie mit .Next() vom Listenanfang an durchlaufen zu können.

 Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Create();
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Reset();                        //Listendurchlauf vorbereiten
 while (dataDescrList.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    Isom.Exchange.DataDescription current = dataDescrList.Next();     //Element abrufen und Durchlauf weiterführen
 }
Rückgabe:
Isom.Exchange.DataDescriptionr
Nächstes Element der Liste.
Nächstes Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Exchange\DataDescriptionList.is: 238]
objectbound Isom.Base.Boolean Isom.Exchange.DataDescriptionList.Reset ( )

Setzt den Listeniterator zurück.

 Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Create();
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Insert(Isom.Exchange.DataDescription.Create());
 dataDescrList.Reset();                        //Listendurchlauf vorbereiten
 while (dataDescrList.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    Isom.Exchange.DataDescription current = dataDescrList.Next();     //Element abrufen und Durchlauf weiterführen
 }
Rückgabe:
Isom.Base.Boolean
Immer 'true'.
[Isom\Exchange\DataDescriptionList.is: 311]
Isom.Exchange.DataDescriptionList Isom.Exchange.DataDescriptionList.Void ( )

Erzeugt ein Void-Objekt.

Erzeugt ein Void-Objekt. Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

   //Erzeuge Void-Objekt
   Isom.Exchange.DataDescriptionList dataDescrList = Isom.Exchange.DataDescriptionList.Void();
Rückgabe:
Isom.Exchange.DataDescriptionList
Ungültiges Objekt.
Ausnahmebehandlung:
Die Funktion liefert immer Void.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataDescriptionList.is: 403]


für Serviceautoren

Isom.Exchange.DataExchange

Namensraum Isom.Exchange.DataExchange

Interaktion mit der Datenaustauschschnittstelle zur Verwaltung abgelegter Datensätze. Mehr...

Funktionen
Isom.Exchange.DataExchange | GetInstance()

Liefert die Singleton-Instanz der Fachklasse.

Funktionen für den Datenaustausch

Funktionen, die den Datenaustausch ermöglichen.

Isom.Base.StringList | GetSupportedDataTypes()

Liefert alle zulässigen Arten von Datensätzen.

Isom.Exchange.DataHandle | Load(Isom.Exchange.DataDescription dataDescription)

Lädt einen Datensatz.

Isom.Base.StringDictionary | LoadDictionary(Isom.Exchange.DataDescription dataDescription)

Lädt ein Wörterbuch.

Isom.Exchange.DataDescriptionList | Lookup(Isom.Exchange.DataDescription dataDescription)

Sucht einen Datensatz.

Isom.Base.Boolean | Remove(Isom.Exchange.DataDescription dataDescription)

Löscht einen Datensatz.

Isom.Base.Boolean | RemoveDataByCurrentVin()

Löscht alle Datensätze für die aktuell eingestellte Fahrgestellnummer

Isom.Base.Boolean | RemoveDictionary(Isom.Exchange.DataDescription dataDescription)

Löscht den Datensatz eines Wörterbuchs.

Isom.Base.Boolean | RemoveFromDictionary(Isom.Exchange.DataDescription dataDescription, Isom.Base.String key)

Entfernt einen Eintrag aus einem als Datensatz abgelegten Wörterbuch.

Isom.Base.Boolean | Store(Isom.Exchange.DataDescription dataDescription, Isom.Exchange.DataHandle input)

Speichert einen Datensatz.

Isom.Base.Boolean | StoreDictionary(Isom.Exchange.DataDescription dataDescription, Isom.Base.StringDictionary dictionary)

Speichert ein Wörterbuch.

Isom.Base.Boolean | UpdateDictionary(Isom.Exchange.DataDescription dataDescription, Isom.Base.StringDictionary dictionary)

Aktualisiert ein Wörterbuch.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Isom.Exchange.DataExchange | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Dieses Fachobjekt ermöglicht eine indexbasierte Verwaltung abgelegter Datensätze. Datensätze können anhand von Beschreibungen als Instanzen der Fachklasse Isom.Exchange.DataDescription gespeichert, gefunden, geladen und gelöscht werden.

Bemerkungen:
Auf der Serviceplattform Taurus® wird zur Datenablage der Dienst Hermes verwendet. Die unterstützten Datenarten werden in der Konfiguration von Hermes festgelegt. Instanzen der Fachklasse Isom.Exchange.DataDescription beschreiben die Daten, auf die zugegriffen wird. Sie legen die Indizes fest, mit denen die Daten gegenüber Hermes identifiziert werden. Ist wie z. B. wie bei ISOM Didact kein Dienst zur Datenablage vorhanden, muss ein gültiges Datenaustauschverzeichnis für ISOM konfiguriert sein.

Quelldateien:

  • Isom\Exchange\DataExchange.is

Dokumentation der Funktionen

Isom.Exchange.DataExchange Isom.Exchange.DataExchange.GetInstance ( )

Liefert die Singleton-Instanz der Fachklasse.

Liefert die Singleton-Instanz der Fachklasse, auf der instanzgebundene Fachfunktionen aufgerufen werden.

   //Abfrage der Zugriffsinstanz
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();
Rückgabe:
Isom.Exchange.DataExchange
Singleton-Instanz der Fachklasse, auf der instanzgebundene Fachfunktionen aufgerufen werden können.
Ausnahmebehandlung:
Void wird zurückgegeben, falls der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar ist.
Datum:
letzte Änderung am 09.07.2010
[Isom\Exchange\DataExchange.is: 107]
objectbound Isom.Base.StringList Isom.Exchange.DataExchange.GetSupportedDataTypes ( )

Liefert alle zulässigen Arten von Datensätzen.

Die Funktion liefert alle Arten von Datensätzen, die in ISOM mit dieser Fachklasse abgespeichert oder geladen werden können.

   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();
   Isom.Base.StringList supportedTypes = dataExchange.GetSupportedDataTypes();
   if(supportedTypes.Length().Eq(0))
   {
       //Falls keine Datentypen unterstützt werden
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller Arten von Datensätzen, die abgespeichert oder geladen werden können. Die Datentypen werden in der verwendeten Datenablage konfiguriert.
Ausnahmebehandlung:
Void wird zurückgegeben, falls die Liste nicht bestimmt werden kann, weil der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar ist.
Datum:
letzte Änderung am 28.06.2010
[Isom\Exchange\DataExchange.is: 497]
objectbound Isom.Base.Boolean Isom.Exchange.DataExchange.IsVoid ( )

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist. Das Void-Objekt wird z. B. von Isom.Exchange.DataExchange.GetInstance() geliefert, falls der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar ist.

   //Abfrage der Zugriffsinstanz
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();

   //Prüfung auf Void
   if (dataExchange.IsVoid())
   {
     //Fehlerbehandlung
   }
Rückgabe:
Isom.Base.Boolean
'true' genau dann, wenn dies das Void-Objekt ist.
Datum:
letzte Änderung am 09.07.2010
[Isom\Exchange\DataExchange.is: 557]
objectbound Isom.Exchange.DataHandle Isom.Exchange.DataExchange.Load ( Isom.Exchange.DataDescription dataDescription )

Lädt einen Datensatz.

Lädt einen Datensatz, der durch den Parameter 'dataDescription' eindeutig identifiziert wird. Geliefert wird eine Instanz der Fachklasse Isom.Exchange.DataHandle als Abstraktion eines Datenstroms, der nicht weiter manipuliert werden kann. Er kann nur als Ein- und Ausgabeparameter der Fachfunktionen in Isom.Exchange.DataExchange verwendet werden. Wird zur Identifizierung des Datensatzes ein Index erwartet, der mit "Vin" beginnt und ist in dem Übergabeparameter für den Index kein Wert vorgegeben, wird von ISOM für diesen Index die 7-stellige Fahrgestellnummer aus dem Istkontext eingetragen. Alle zur Identifizierung des Datensatzes benötigten Indizes, die nicht mit "Vin" beginnen, müssen im Übergabeparameter angegeben sein, so dass sich eine vollständige Beschreibung des zu ladenden Datensatzes ergibt.

   //Abfrage der Zugriffsinstanz
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();

   //Datenbeschreibung erzeugen
   Isom.Exchange.DataDescription description = Isom.Exchange.DataDescription.Create();

   //Setzen der Indizes
   //..

   //Einlesen des Datensatzes
   Isom.Exchange.DataHandle handle = dataExchange.Load(description);
Parameter:
dataDescription Beschreibung des zu ladenden Datensatzes.
Rückgabe:
Isom.Exchange.DataHandle
Abstraktion des geladenen Datenstroms.
Ausnahmebehandlung:
Void wird zurückgegeben, falls der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar oder die Datei nicht vorhanden ist.
Datum:
letzte Änderung am 09.07.2010
[Isom\Exchange\DataExchange.is: 151]
objectbound Isom.Base.StringDictionary Isom.Exchange.DataExchange.LoadDictionary ( Isom.Exchange.DataDescription dataDescription )

Lädt ein Wörterbuch.

Lädt ein Wörterbuch, das als Datensatz abgelegt wurde, der durch den Parameter 'dataDescription' eindeutig identifiziert wird. Alle zur Identifizierung des Datensatzes benötigten Indizes müssen im Übergabeparameter angegeben sein, so dass sich eine vollständige Beschreibung des zu ladenden Datensatzes ergibt.

   //Abfrage der Zugriffsinstanz
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();

   //Datenbeschreibung erzeugen
   Isom.Exchange.DataDescription description = Isom.Exchange.DataDescription.Create();

   //Setzen der Indizes
   //..

   //Einlesen des Wörterbuchs
   Isom.Base.StringDictionary result = dataExchange.LoadDictionary(description);
Parameter:
dataDescription Beschreibung des zu ladenden Datensatzes.
Rückgabe:
Isom.Base.StringDictionary
Eingelesenes Wörterbuch.
Ausnahmebehandlung:
Void wird zurückgegeben, falls der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar ist oder beim Aufruf einen Fehler geliefert hat.
Datum:
letzte Änderung am 09.07.2010
[Isom\Exchange\DataExchange.is: 303]
objectbound Isom.Exchange.DataDescriptionList Isom.Exchange.DataExchange.Lookup ( Isom.Exchange.DataDescription dataDescription )

Sucht einen Datensatz.

Sucht Datensätze, die durch den Parameter 'dataDescription' beschrieben werden. Wird zur Beschreibung des Datensatzes ein Index erwartet, der mit der Zeichenkette "Vin" beginnt und ist in dem Übergabeparameter für den Index kein Wert vorgegeben, wird von ISOM für diesen Index die 7-stellige Fahrgestellnummer aus dem Istkontext eingetragen. Indizes, die in dem Übergabeparameter angegeben wurden werden unverändert weitergegeben, so dass auch Suchmuster, wie z. B. "*", als Wert eines Index erlaubt sind, sofern der angebundene Dienst zur Datenablage dies unterstützt.

   //Abfrage der Zugriffsinstanz
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();

   //Datenbeschreibung erzeugen
   Isom.Exchange.DataDescription description = Isom.Exchange.DataDescription.Create();

   //Setzen der Indizes
   //..

   //Suchen von Datensätzen
   Isom.Exchange.DataDescriptionList results = dataExchange.Lookup(description))
Parameter:
dataDescription Beschreibung der gesuchten Datensätze.
Rückgabe:
Isom.Exchange.DataDescriptionList
Liste mit gefundenen Datensätzen.
Ausnahmebehandlung:
Void wird zurückgegeben, falls der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar ist.
Datum:
letzte Änderung am 09.07.2010
[Isom\Exchange\DataExchange.is: 230]
objectbound Isom.Base.Boolean Isom.Exchange.DataExchange.Remove ( Isom.Exchange.DataDescription dataDescription )

Löscht einen Datensatz.

Löscht einen Datensatz, der durch den Parameter 'dataDescription' eindeutig identifiziert wird. Wird zur Identifizierung des Datensatzes ein Index erwartet, der mit der Zeichenkette "Vin" beginnt und ist in dem Übergabeparameter für den Index kein Wert vorgegeben, wird von ISOM für diesen Index die 7-stellige Fahrgestellnummer aus dem Istkontext eingetragen. Alle zur Identifizierung des Datensatzes benötigten Indizes, die nicht mit "Vin" beginnen, müssen im Übergabeparameter angegeben sein, so dass sich eine vollständige Beschreibung des zu löschenden Datensatzes ergibt.

   //Abfrage der Zugriffsinstanz
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();

   //Datenbeschreibung erzeugen
   Isom.Exchange.DataDescription description = Isom.Exchange.DataDescription.Create();

   //Setzen der Indizes
   //..

   //Löschen des Datensatzes
   if (dataExchange.Remove(description).Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
dataDescription Beschreibung des zu löschenden Datensatzes.
Rückgabe:
Isom.Base.Boolean
'true' genau dann, wenn der Vorgang erfolgreich war.
Ausnahmebehandlung:
Void wird zurückgegeben, falls der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar ist oder beim Aufruf einen Fehler geliefert hat.
Datum:
letzte Änderung am 09.07.2010
[Isom\Exchange\DataExchange.is: 269]
objectbound Isom.Base.Boolean Isom.Exchange.DataExchange.RemoveDataByCurrentVin ( )

Löscht alle Datensätze für die aktuell eingestellte Fahrgestellnummer

Die Funktion löscht alle Datensätze, die für die aktuell eingestellte Fahrgestellnummer abgespeichert wurden. Berücksichtigt werden alle Daten, die einen Schlüssel benötigen, der mit "Vin" beginnt.

   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();
   if(dataExchange.RemoveDataByCurrentVin().Failed())
   {
       //Daten konnten nicht gelöscht werden
   }
Rückgabe:
Isom.Base.Boolean
Liefert 'true', wenn Daten gelöscht wurden, 'false' sonst.
Ausnahmebehandlung:
Void wird zurückgegeben, falls der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar ist.
Datum:
letzte Änderung am 28.06.2010
[Isom\Exchange\DataExchange.is: 523]
objectbound Isom.Base.Boolean Isom.Exchange.DataExchange.RemoveDictionary ( Isom.Exchange.DataDescription dataDescription )

Löscht den Datensatz eines Wörterbuchs.

Löscht ein als Datensatz, der durch den Parameter 'dataDescription' eindeutig identifiziert wird, abgelegtes Wörterbuch. Alle zur Identifizierung des Datensatzes benötigten Indizes müssen im Übergabeparameter 'dataDescription' angegeben sein, so dass sich eine vollständige Beschreibung des zu entfernenden Datensatzes ergibt.

   //Abfrage der Zugriffsinstanz
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();

   //Datenbeschreibung erzeugen
   Isom.Exchange.DataDescription description = Isom.Exchange.DataDescription.Create();

   //Setzen der Indizes
   //..

   //Löschen des Datensatzes des Wörterbuchs
   if (dataExchange.RemoveDictionary(description).Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
dataDescription Beschreibung des zu löschenden Datensatzes.
Rückgabe:
Isom.Base.Boolean
'true' genau dann, wenn der Vorgang erfolgreich war.
Ausnahmebehandlung:
Void wird zurückgegeben, falls der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar ist oder beim Aufruf einen Fehler geliefert hat.
Datum:
letzte Änderung am 09.07.2010
[Isom\Exchange\DataExchange.is: 470]
objectbound Isom.Base.Boolean Isom.Exchange.DataExchange.RemoveFromDictionary | ( | Isom.Exchange.DataDescription | dataDescription,
 |  | Isom.Base.String | key
 | ) |  |

Entfernt einen Eintrag aus einem als Datensatz abgelegten Wörterbuch.

Entfernt einen Eintrag aus einem als Datensatz, der durch den Parameter 'dataDescription' eindeutig identifiziert wird, abgelegten Wörterbuch. Alle zur Identifizierung des Datensatzes benötigten Indizes müssen im Übergabeparameter angegeben sein, so dass sich eine vollständige Beschreibung des zu entfernenden Datensatzes ergibt. Ist für das Wörterbuch kein Datensatz vorhanden, wird ein neuer Datensatz erzeugt und abgelegt.

   //Abfrage der Zugriffsinstanz
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();

   //Datenbeschreibung erzeugen
   Isom.Exchange.DataDescription description = Isom.Exchange.DataDescription.Create();

   //Setzen der Indizes
   //..

   //Entfernt den Schlüssel "Test" aus dem abgelegten Wörterbuch
   if (dataExchange.RemoveFromDictionary(description, "Test").Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
dataDescription | Beschreibung des Datensatzes des Wörterbuchs.
key | Schlüssel, der aus dem als Datensatz abgelegten Wörterbuch entfernt wird
Rückgabe:
Isom.Base.Boolean
'true' genau dann, wenn der Vorgang erfolgreich war.
Ausnahmebehandlung:
Void wird zurückgegeben, falls der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar ist oder beim Aufruf einen Fehler geliefert hat.
Datum:
letzte Änderung am 09.07.2010
[Isom\Exchange\DataExchange.is: 432]
objectbound Isom.Base.Boolean Isom.Exchange.DataExchange.Store | ( | Isom.Exchange.DataDescription | dataDescription,
 |  | Isom.Exchange.DataHandle | input
 | ) |  |

Speichert einen Datensatz.

Speichert einen Datensatz, der durch den Parameter 'dataDescription' eindeutig identifiziert wird. Wird zur Identifizierung des Datensatzes ein Index erwartet, der mit "Vin" beginnt und ist in dem Übergabeparameter für den Index kein Wert vorgegeben, wird von ISOM für diesen Index die 7-stellige Fahrgestellnummer aus dem Istkontext eingetragen. Alle zur Identifizierung des Datensatzes benötigten Indizes, die nicht mit "Vin" beginnen, müssen im Übergabeparameter angegeben sein, so dass sich eine vollständige Beschreibung des zu speichernden Datensatzes ergibt.

   //Abfrage der Zugriffsinstanz
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();

   //Datenbeschreibung erzeugen
   Isom.Exchange.DataDescription description = Isom.Exchange.DataDescription.Create();

   //Setzen der Indizes
   //..

   //Einlesen des Datensatzes
   Isom.Exchange.DataHandle handle = dataExchange.Load(description);

   //Speichern des Datensatzes
   if (dataExchange.Store(description, handle).Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
dataDescription | Beschreibung des zu speichernden Datensatzes.
input | Die zu speichernden Daten
Rückgabe:
Isom.Base.Boolean
'true' genau dann, wenn der Vorgang erfolgreich war.
Ausnahmebehandlung:
Void wird zurückgegeben, falls der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar ist oder beim Aufruf einen Fehler geliefert hat.
Datum:
letzte Änderung am 09.07.2010
[Isom\Exchange\DataExchange.is: 194]
objectbound Isom.Base.Boolean Isom.Exchange.DataExchange.StoreDictionary | ( | Isom.Exchange.DataDescription | dataDescription,
 |  | Isom.Base.StringDictionary | dictionary
 | ) |  |

Speichert ein Wörterbuch.

Speichert ein Wörterbuch 'dictionary' als Datensatz, der durch den Parameter 'dataDescription' eindeutig identifiziert wird. Alle zur Identifizierung des Datensatzes benötigten Indizes müssen im Übergabeparameter angegeben sein, so dass sich eine vollständige Beschreibung des zu speichernden Datensatzes ergibt.

   StringDictionary dict = StringDictionary.CreateStringDictionary();

   //Befüllen des Wörterbuchs
   //..

   //Abfrage der Zugriffsinstanz
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();

   //Datenbeschreibung erzeugen
   Isom.Exchange.DataDescription description = Isom.Exchange.DataDescription.Create();

   //Setzen der Indizes
   //..

   //Speichern des Wörterbuchs als Datensatz
   if (dataExchange.StoreDictionary(description, dict).Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
dataDescription | Beschreibung des zu speichernden Datensatzes.
dictionary | Zu speicherndes Wörterbuch.
Rückgabe:
Isom.Base.Boolean
'true' genau dann, wenn der Vorgang erfolgreich war.
Ausnahmebehandlung:
Void wird zurückgegeben, falls der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar ist oder beim Aufruf einen Fehler geliefert hat.
Datum:
letzte Änderung am 09.07.2010
[Isom\Exchange\DataExchange.is: 347]
objectbound Isom.Base.Boolean Isom.Exchange.DataExchange.UpdateDictionary | ( | Isom.Exchange.DataDescription | dataDescription,
 |  | Isom.Base.StringDictionary | dictionary
 | ) |  |

Aktualisiert ein Wörterbuch.

Aktualisiert ein als Datensatz, der durch den Parameter 'dataDescription' eindeutig identifiziert wird, abgelegtes Wörterbuch. Alle zur Identifizierung des Datensatzes benötigten Indizes müssen im Übergabeparameter angegeben sein, so dass sich eine vollständige Beschreibung des zu aktualisierenden Datensatzes ergibt. Ist für das Wörterbuch kein Datensatz vorhanden, wird ein neuer Datensatz erzeugt und abgelegt.

   StringDictionary dict = StringDictionary.CreateStringDictionary();

   //Befüllen des Wörterbuchs
   //..

   //Abfrage der Zugriffsinstanz
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();

   //Datenbeschreibung erzeugen
   Isom.Exchange.DataDescription description = Isom.Exchange.DataDescription.Create();

   //Setzen der Indizes
   //..

   //Aktualisieren des Datensatzes des Wörterbuchs
   if (dataExchange.UpdateDictionary(description, dict).Failed())
   {
     //Fehlerbehandlung
   }
Parameter:
dataDescription | Beschreibung des zu aktualisierenden Datensatzes.
dictionary | Aktualisierendes Wörterbuch.
Rückgabe:
Isom.Base.Boolean
'true' genau dann, wenn der Vorgang erfolgreich war.
Ausnahmebehandlung:
Void wird zurückgegeben, falls der zur Nutzung dieser Fachklasse benötigte Dienst zur Datenablage nicht erreichbar ist oder beim Aufruf einen Fehler geliefert hat.
Datum:
letzte Änderung am 09.07.2010
[Isom\Exchange\DataExchange.is: 392]
Isom.Exchange.DataExchange Isom.Exchange.DataExchange.Void ( )

Erzeugt ein Void-Objekt.

Erzeugt ein Void-Objekt. Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

   //Erzeuge Void-Objekt
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.Void();
Rückgabe:
Isom.Exchange.DataExchange
Die Funktion liefert immer ein Void-Objekt.
Ausnahmebehandlung:
Die Funktion liefert immer Void.
Datum:
letzte Änderung am 09.07.2010
[Isom\Exchange\DataExchange.is: 579]


für Serviceautoren

Isom.Exchange.DataHandle

Namensraum Isom.Exchange.DataHandle

Identifikator für Daten, die über die Datenaustauschschnittstelle von ISOM gelesen und geschrieben werden können Mehr...

Funktionen
Funktion zur Erzeugung eines neuen Identifikator

Funktion, die es ermöglicht einen neuen Identifikator für Daten zu erzeugen.

Isom.Exchange.DataHandle | CreateNewForFile(Isom.Base.String path)

Erzeugt einen neuen Identifikator für Daten

Isom.Exchange.DataHandle | CreateNewForUri(Isom.Base.Uri uri)

Erzeugt einen neuen Identifikator für Daten

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Isom.Exchange.DataHandle | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Der Autor kann die Daten selbst nicht manipulieren, weshalb das Fachobjekt neben Void, IsVoid und CreateNewForFile keine weiteren Funktionen zur Verfügung stellt. Der Autor kann Daten laden und mit einer anderen Datenbeschreibung wieder abspeichern, wie das folgende Beispiel zeigt:

   //Abfrage einer Zugriffsinstanz auf die Datenablage
   Isom.Exchange.DataExchange dataExchange = Isom.Exchange.DataExchange.GetInstance();

   //Datenbeschreibung erzeugen
   Isom.Exchange.DataDescription sourceDescr = Isom.Exchange.DataDescription.Create();

   //Setzen der Indizes
   //..

   //Einlesen des Datensatzes
   Isom.Exchange.DataHandle handle = dataExchange.Load(sourceDescr);

   //Prüfung auf Void
   if (handle.IsVoid())
   {
     //Fehlerbehandlung
   }

   //Datenbeschreibung erzeugen
   Isom.Exchange.DataDescription targetDescr = Isom.Exchange.DataDescription.Create();

   //Setzen der Indizes
   //..

   //Speichern des Datensatzes mit anderen
   Isom.Base.Boolean result = dataExchange.Store(targetDescr, handle);

Quelldateien:

  • Isom\Exchange\DataHandle.is

Dokumentation der Funktionen

Isom.Exchange.DataHandle Isom.Exchange.DataHandle.CreateNewForFile ( Isom.Base.String path )

Erzeugt einen neuen Identifikator für Daten

Erzeugt einen neuen Identifikator für die Daten, die über den Parameter path referenziert werden

Parameter:
path Vollqualifizierter Pfad der Daten
Rückgabe:
Isom.Exchange.DataHandle
Identifikator für Daten
[Isom\Exchange\DataHandle.is: 111]
Isom.Exchange.DataHandle Isom.Exchange.DataHandle.CreateNewForUri ( Isom.Base.Uri uri )

Erzeugt einen neuen Identifikator für Daten

Erzeugt einen neuen Identifikator für die Daten, die über den Parameter uri referenziert werden

Parameter:
uri URI der Daten
Rückgabe:
Isom.Exchange.DataHandle
Identifikator für Daten
[Isom\Exchange\DataHandle.is: 125]
objectbound Isom.Base.Boolean Isom.Exchange.DataHandle.IsVoid ( )

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Das Void-Objekt wird z. B. geliefert, um einen Fehlerfall anzuzeigen

Rückgabe:
Isom.Base.Boolean
'true' genau dann, wenn dies das Void-Objekt ist.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataHandle.is: 146]
Isom.Exchange.DataHandle Isom.Exchange.DataHandle.Void ( )

Erzeugt ein Void-Objekt.

Erzeugt ein Void-Objekt. Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

   //Erzeuge Void-Objekt
   Isom.Exchange.DataHandle dataHandle = Isom.Exchange.DataHandle.Void();
Rückgabe:
Isom.Exchange.DataHandle
Ungültiges Objekt.
Ausnahmebehandlung:
Die Funktion liefert immer Void.
Datum:
letzte Änderung am 21.06.2011
[Isom\Exchange\DataHandle.is: 167]


für Serviceautoren

Isom.Global

Namensraum Isom.Global

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Global.Config | Zugriff auf allgemeine Konfigurationsparameter von ISOM.
Isom.Global.Controller | Zugriff auf die steuernde Schnittstelle von ISOM.
Isom.Global.Processes | Einsprungspunkte und Rückruffunktionen


für Serviceautoren

Isom.Global.Config

Namensraum Isom.Global.Config

Zugriff auf allgemeine Konfigurationsparameter von ISOM. Mehr...

Funktionen
Isom.Global.Config | GetInstance()

Ermittelt den Satz der für diese ISOM-Sitzung gültigen Konfigurationsparameter.

Funktionen für den Zugriff auf Attribute

Funktionen, die es ermöglichen auf Attribute zuzugreifen.

Isom.Base.String | GetOperationMode()

Ermittelt den für diese ISOM-Sitzung gültigen Betriebsmodus.

Isom.Base.Boolean | IsInOperationMode(Isom.Base.String targetOperationMode)

Prüft, ob sich ISOM lt.

Ausführliche Beschreibung

Isom.Global.Config ermöglicht den Zugriff auf allgemeine Konfigurationsparameter von ISOM.

Quelldateien:

  • Isom\Global\Config.is

Dokumentation der Funktionen

Isom.Global.Config Isom.Global.Config.GetInstance ( )

Ermittelt den Satz der für diese ISOM-Sitzung gültigen Konfigurationsparameter.

   using Isom.Base.*
   using Isom.Context.Config;
   ...
      Config isomglobalCfg = Config.GetInstance();
Rückgabe:
Das für diese ISOM-Sitzung singuläre Konfigurationsparameterobjekt.
[Isom\Global\Config.is: 85]
objectbound Isom.Base.String Isom.Global.Config.GetOperationMode ( )

Ermittelt den für diese ISOM-Sitzung gültigen Betriebsmodus.

Mögliche Werte:

  • "SERVICE" - normaler Werkstattbetrieb (Voreinstellung)
  • "EXPERT" - Expertenmodus mit erw. Therapiemöglichkeiten

   using Isom.Base.*
   using Isom.Context.Config;
   ...
      Config isomglobalCfg = Config.GetInstance();
      Log.Info ("",  isomglobalCfg.GetOperationMode() );
Rückgabe:
Betriebsmodus entspr. Konfigruation (inkl. Groß-Kleinschreibung).
[Isom\Global\Config.is: 113]
objectbound Isom.Base.Boolean Isom.Global.Config.IsInOperationMode ( Isom.Base.String targetOperationMode )

Prüft, ob sich ISOM lt.

Konfiguration im vorgegebenen Betriebsmodus befindet.

Die Prüfung erfolgt case-insensitiv, d.h. ohne Berücksichtigung der Groß-Kleinschreibung.

   using Isom.Base.*
   using Isom.Context.Config;
   ...
      Config isomglobalCfg = Config.GetInstance();
      if( isomglobalCfg.IsInOperationMode("ExPeRt") )
      {
          ...
      }
Rückgabe:
true gdw. sich ISOM lt. Konfiguration im vorgegebenen Betriebsmodus befindet.
[Isom\Global\Config.is: 136]


für Serviceautoren

Isom.Global.Controller

Namensraum Isom.Global.Controller

Zugriff auf die steuernde Schnittstelle von ISOM. Mehr...

Funktionen
Isom.Global.Controller | GetInstance()

Ermittelt ein Objekt, über das auf die steuernde Schnittstelle von Isom zugegriffen werden kann.

Funktionen zur direkten Steuerung von ISOM

Funktionen, die es ermöglichen ISOM direkt zu steuern.

Isom.Base.String | AbortActionPlan()

Bricht eine gestartete Aktionsplanausführung ab.

Isom.Base.String | AddPlanElement(Isom.Plan.TherapyPlanAction planElement)

Fügt eine Top-Level-Aktion hinzu, die über den Aktionsnamen und (optional) das assoziierte Ecu identifiziert wird.

Isom.Base.String | CalculateFinalPlan()

Berechnet den Therapieplan, der ausgeführt werden soll.

Isom.Base.String | CalculatePlan()

Führt die Plan-Berechnung aus.

Isom.Base.String | DeleteFinalPlan()

Verwirft den Therapieplan, der mit CalculateFinalPlan() berechnet wurde.

Isom.Base.String | EvaluateCurrentContextEcus()

Setzt die Ist-Kontext Ermittlung mit der Ermittlung der Ist-SG-Liste fort.

Isom.Base.String | EvaluateFutureContext()

Führt die Soll-Kontext Ermittlung aus.

Isom.Base.String | EvaluateModelSeries()

Führt die Baureihenerkennung aus.

Isom.Base.String | EvaluateVehicleData()

Führt die Ist-Kontextermittlung mit der Ermittlung der Fahrzeugdaten (außer Ist-SG-Liste) aus.

Isom.Base.String | GetProcessState()

Ermittelt den aktuellen Prozesszustand.

Isom.Base.String | PerformActionPlan()

Führt die Aktionsplandurchführung aus.

Isom.Base.String | PrepareActionPlan()

Führt die Aktionsplanberechnung aus.

Isom.Base.String | ReevaluateDataAvailability()

Neubewertung der Datenverfügbarkeit aller Aktionen.

Isom.Base.String | RemovePlanElement(Isom.Plan.TherapyPlanAction planElement)

Entfernt eine Top-Level-Aktion, die über den Aktionsnamen und (optional) das assoziierte ECU identifiziert wird.

Isom.Base.String | RestartTherapySession(Isom.Base.String targetState)

Erlaubt die Fortführung der Sitzung nachdem eine Therapiesitzung komplett durchgelaufen ist.

Isom.Base.String | RunAction(Isom.Plan.TherapyPlanAction planElement)

Führt die Aktion, die über den Aktionsnamen und (optional) das assoziierte Ecu identifiziert wird, sofort aus.

Isom.Base.String | StopIsom(Isom.Base.String message)

Beendet die ISOM Instanz und terminiert alle verwendeten Fachdienste, falls ISOM nicht aktiv ist.

Isom.Base.String | TerminateIsom(Isom.Base.String message)

Beendet die ISOM Instanz und terminiert alle verwendeten Fachdienste, auch falls ISOM aktiv ist.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob das aktuelle Element das Void-Objekt ist.

Isom.Global.Controller | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Diese Fachklasse darf nur verwendet werden, wenn Isom mit dem Kommandozeilen-Parameter 'Program' gestartet wird. Der Aufruf ist nur aus dem steuernden Hauptskript heraus zulässig.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Global\Controller.is

Dokumentation der Funktionen

objectbound Isom.Base.String Isom.Global.Controller.AbortActionPlan ( )

Bricht eine gestartete Aktionsplanausführung ab.

(AKA manueller Abbruch)

Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 368]
objectbound Isom.Base.String Isom.Global.Controller.AddPlanElement ( Isom.Plan.TherapyPlanAction planElement )

Fügt eine Top-Level-Aktion hinzu, die über den Aktionsnamen und (optional) das assoziierte Ecu identifiziert wird.

   using Isom.Base.*
   using Isom.Plan.*
   ...
   state = ctrl.AddPlanElement (action);
Parameter:
planElement zu erzeugendes Element
Zu beachten:
Diese Funktion ist nur erlaubt, falls ISOM im Zustand StateTherapyPlanCreated ist.
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 230]
objectbound Isom.Base.String Isom.Global.Controller.CalculateFinalPlan ( )

Berechnet den Therapieplan, der ausgeführt werden soll.

   using Isom.Base.*
   ...
   state = ctrl.CalculateFinalPlan();
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 404]
objectbound Isom.Base.String Isom.Global.Controller.CalculatePlan ( )

Führt die Plan-Berechnung aus.

   using Isom.Base.*
   ...
   state = ctrl.CalculatePlan();
Zu beachten:
Diese Funktion ist nur erlaubt, falls ISOM im Zustand StateFutureContextKnown ist.
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 209]
objectbound Isom.Base.String Isom.Global.Controller.DeleteFinalPlan ( )

Verwirft den Therapieplan, der mit CalculateFinalPlan() berechnet wurde.

   using Isom.Base.*
   ...
   state = ctrl.DeleteFinalPlan();
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 418]
objectbound Isom.Base.String Isom.Global.Controller.EvaluateCurrentContextEcus ( )

Setzt die Ist-Kontext Ermittlung mit der Ermittlung der Ist-SG-Liste fort.

   using Isom.Base.*
   ...
   state = ctrl.EvaluateCurrentContextEcus();
Zu beachten:
Diese Funktion ist nur erlaubt, falls ISOM im Zustand StateVehicleDataKnown ist.
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 175]
objectbound Isom.Base.String Isom.Global.Controller.EvaluateFutureContext ( )

Führt die Soll-Kontext Ermittlung aus.

   using Isom.Base.*
   ...
   state = ctrl.EvaluateFutureContext();
Zu beachten:
Diese Funktion ist nur erlaubt, falls ISOM im Zustand StateCurrContextKnown ist.
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 192]
objectbound Isom.Base.String Isom.Global.Controller.EvaluateModelSeries ( )

Führt die Baureihenerkennung aus.

   using Isom.Base.*
   ...
   state = ctrl.EvaluateModelSeries();
Zu beachten:
Diese Funktion ist nur erlaubt, falls ISOM im Zustand StateConfigUnknown ist.
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 139]
objectbound Isom.Base.String Isom.Global.Controller.EvaluateVehicleData ( )

Führt die Ist-Kontextermittlung mit der Ermittlung der Fahrzeugdaten (außer Ist-SG-Liste) aus.

   using Isom.Base.*
   ...
   state = ctrl.EvaluateVehicleData();
Zu beachten:
Diese Funktion ist nur erlaubt, falls ISOM im Zustand StateConfigKnown ist.
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 157]
Isom.Global.Controller Isom.Global.Controller.GetInstance ( )

Ermittelt ein Objekt, über das auf die steuernde Schnittstelle von Isom zugegriffen werden kann.

Wurde ISOM nicht mit dem Kommandozeilen-Parameter 'Program' gestartet, gibt diese Funktion immer ein "Void"-Objekt zurück.

   using Isom.Base.*
   using Isom.Context.Controller;
   ...
      Controller ctrl = Controller.GetInstance();
Rückgabe:
Das für diese ISOM-Sitzung singuläre Steuerungsobjekt.
[Isom\Global\Controller.is: 105]
objectbound Isom.Base.String Isom.Global.Controller.GetProcessState ( )

Ermittelt den aktuellen Prozesszustand.

Rückgabe:
der aktuelle ISOM-Prozesszustand
[Isom\Global\Controller.is: 122]
objectbound Isom.Base.Boolean Isom.Global.Controller.IsVoid ( )

Bestimmt, ob das aktuelle Element das Void-Objekt ist.

Rückgabe:
'true', falls das aktuelle Element das Void-Objekt ist, 'false' sonst.
[Isom\Global\Controller.is: 437]
objectbound Isom.Base.String Isom.Global.Controller.PerformActionPlan ( )

Führt die Aktionsplandurchführung aus.

   using Isom.Base.*
   ...
   state = ctrl.PerformActionPlan();
Zu beachten:
Diese Funktion ist nur erlaubt, falls ISOM im Zustand StateActionPlanCreated ist.
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 328]
objectbound Isom.Base.String Isom.Global.Controller.PrepareActionPlan ( )

Führt die Aktionsplanberechnung aus.

   using Isom.Base.*
   ...
   state = ctrl.PrepareActionPlan();
Zu beachten:
Diese Funktion ist nur erlaubt, falls ISOM im Zustand StateTherapyPlanCreated ist.
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 311]
objectbound Isom.Base.String Isom.Global.Controller.ReevaluateDataAvailability ( )

Neubewertung der Datenverfügbarkeit aller Aktionen.

Führt die Neubewertung der Datenverfügbarkeit für alle Aktionen im Therapieplan aus.

   using Isom.Base.*
   ...
   state = ctrl.ReevaluateDataAvailability();
Zu beachten:
Diese Funktion ist nur erlaubt, falls ISOM im Zustand StateTherapyPlanCreated ist.
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 294]
objectbound Isom.Base.String Isom.Global.Controller.RemovePlanElement ( Isom.Plan.TherapyPlanAction planElement )

Entfernt eine Top-Level-Aktion, die über den Aktionsnamen und (optional) das assoziierte ECU identifiziert wird.

   using Isom.Base.*
   using Isom.Plan.*
   ...
   state = ctrl.RemovePlanElement (action);
Parameter:
planElement zu entfernendes Element
Zu beachten:
Diese Funktion ist nur erlaubt, falls ISOM im Zustand StateTherapyPlanCreated ist.
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 251]
objectbound Isom.Base.String Isom.Global.Controller.RestartTherapySession ( Isom.Base.String targetState )

Erlaubt die Fortführung der Sitzung nachdem eine Therapiesitzung komplett durchgelaufen ist.

ISOM geht dazu in einen Zustand im Phasenmodell zurück, der als Parameter übergeben wird. Abgearbeitete Aktionen bleiben erhalten. Die unterstützen Zustände, in die ISOM mit dieser Funktion übergehen kann, sind: -<c>StateConfigKnown</c> -<c>StateFutureContextKnown</c>

Zu beachten:
Diese Funktion ist nur erlaubt, falls ISOM im Zustand StateActionPlanExecuted ist.
   Isom.Base.String state = ctrl.RestartTherapySession("StateConfigKnown");
Parameter:
targetState Zustand, in den ISOM springen soll
Rückgabe:
Isom.Base.String
ISOM-Prozesszustand nach Ausführung
Datum:
letzte Änderung am 01.09.2010
[Isom\Global\Controller.is: 359]
objectbound Isom.Base.String Isom.Global.Controller.RunAction ( Isom.Plan.TherapyPlanAction planElement )

Führt die Aktion, die über den Aktionsnamen und (optional) das assoziierte Ecu identifiziert wird, sofort aus.

   using Isom.Base.*
   using Isom.Plan.*
   ...
   state = ctrl.RunAction (action);
Parameter:
planElement auszuführende Aktion
Zu beachten:
Es dürfen nur solche Aktionen angewiesen werden, die als CanExecuteImmediate markiert sind.
Diese Funktion ist nur erlaubt, falls ISOM im Zustand StateTherapyPlanCreated ist.
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 274]
objectbound Isom.Base.String Isom.Global.Controller.StopIsom ( Isom.Base.String message )

Beendet die ISOM Instanz und terminiert alle verwendeten Fachdienste, falls ISOM nicht aktiv ist.

Parameter:
message Eine Nachricht, um den Grund des Aufrufs zu beschreiben
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 379]
objectbound Isom.Base.String Isom.Global.Controller.TerminateIsom ( Isom.Base.String message )

Beendet die ISOM Instanz und terminiert alle verwendeten Fachdienste, auch falls ISOM aktiv ist.

Parameter:
message Eine Nachricht, um den Grund des Aufrufs zu beschreiben
Rückgabe:
ISOM-Prozesszustand nach Ausführung
[Isom\Global\Controller.is: 390]
Isom.Global.Controller Isom.Global.Controller.Void ( )

Erzeugt ein Void-Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

Rückgabe:
Void-Objekt
[Isom\Global\Controller.is: 447]


für Serviceautoren

Isom.Global.Processes

Namensraum Isom.Global.Processes

Einsprungspunkte und Rückruffunktionen Mehr...

Funktionen
Einsprungspunkte

Einsprungpunkte und fachliche Rückruffunktionen, die während einer Therapiesitzung auftreten (grob sortiert in typischer Aufrufreihenfolge)

Isom.Base.Boolean | AbortActionPlan()

Führt einen manuellen Planabbruch durch.

Isom.Base.Boolean | AddActionManually(Isom.Plan.TherapyPlanAction action)

Fügt eine Aktion zum Therapieplan hinzu.

Isom.Base.Boolean | CalculateFinalPlan()

Berechnet den finalen Therapieplan.

Isom.Base.Boolean | CheckAccess()

Prüfung des Fahrzeugzugangs.

Isom.Base.Boolean | CheckForPreservedSession()

Prüft, ob eine gespeicherte Sitzung vorhanden ist.

Isom.Base.Boolean | CompleteTherapyPlan()

Schließt die Therapieplanermittlung ab.

Isom.Base.Boolean | ContextIdent()

Ermittlung der Baureihe.

Isom.Base.Boolean | DeleteFinalPlan()

Entfernt den finalen Therapieplan.

Isom.Base.Boolean | DoTp2Ap()

Ermittelt den aktuellen Aktionsplan.

Isom.Base.Boolean | EndPlanPhase(Isom.Plan.ActionPlanPhase phase)

Wird nach Abschluss einer Aktionsplanphase aufgerufen.

Isom.Base.Boolean | ExecuteActionPlan()

Startet die Ausführung des Aktionsplans.

Isom.Base.Boolean | FinishPlan()

Wird nach Abschluss des Aktionsplans aufgerufen.

Isom.Base.Boolean | GeneratePlan()

Erzeugt den nativen Therapieplan.

Isom.Base.Boolean | GetFutureContext()

Ermittlung des Soll-Kontexts.

Isom.Base.Boolean | OnLogicalVehicleChanged(Isom.Base.String previousLV, Isom.Base.String nextLV, Isom.Base.String requestedPChannel)

Benachrichtigung über einen Wechsel des aktiven logischen Fahrzeugs

Isom.Base.Boolean | OnRestartTherapySession()

Wird beim Wiedereinstieg in eine Sitzung aufgerufen.

Isom.Base.Boolean | OnUserProfileChanged(Isom.Context.UserProfile userProfileChanges)

Wird aufgerufen, wenn das Benutzerprofil über die Client-Schnittstelle verändert wurde.

Isom.Base.Boolean | PreparePlan()

Wird zu Beginn des Aktionsplans aufgerufen.

Isom.Base.Boolean | ReevaluateDataAvailability()

Neubewertung der Datenverfügbarkeit für alle Aktionen.

Isom.Base.Boolean | RemoveActionManually(Isom.Plan.TherapyPlanAction action)

Enfernt eine Aktion aus dem Therapieplan.

Isom.Base.Boolean | RunAction(Isom.Plan.TherapyPlanAction action)

Sofortausführung einer einzelnen Aktion

Isom.Base.Boolean | SetExecutionOrder()

Festlegung der Ausführungsreihenfolge.

Isom.Base.Boolean | StartPlanPhase(Isom.Plan.ActionPlanPhase phase)

Wird zu Beginn einer Aktionsplanphase aufgerufen.

Isom.Base.Boolean | UpdateCurrentContextEcus()

Ermittlung und Setzen der Ist-Steuergeräteliste im Modell.

Isom.Base.Boolean | UpdateCurrentContextVehicleData()

Ermittlung des Ist-Kontexts außer der Steuergeräteliste.

Rückruffunktionen beim Starten und Beenden

Rückruffunktionen, die beim Starten und Beenden von ISOM aufgerufen werden

Isom.Base.Boolean | OnIsomStarting()

Wird aufgerufen, sobald die statische Prüfung der Skripte abgeschlossen ist.

Isom.Base.Boolean | OnIsomStopping(Isom.Base.Boolean isForced, Isom.Base.String message)

Wird vor dem eigentlichem Beenden von ISOM aufgerufen.

Therapiefunktionen für ISOM bekannte Aktionen

Leere Ausführungsfunktionen für ISOM namentlich bekannte Aktionen.

Isom.Base.Boolean | DoCode(Isom.Plan.TherapyPlanAction action)

Therapiefunktionen für die Codierung.

Isom.Base.Boolean | DoFlash(Isom.Plan.TherapyPlanAction action)

Therapiefunktionen für die Programmierung.

Isom.Base.Boolean | DoMount(Isom.Plan.TherapyPlanAction action)

Therapiefunktionen für den Einbau.

Isom.Base.Boolean | DoReplace(Isom.Plan.TherapyPlanAction action)

Therapiefunktionen für den Tausch.

Isom.Base.Boolean | DoUnmount(Isom.Plan.TherapyPlanAction action)

Therapiefunktionen für den Ausbau.

Rückruffunktionen für asynchrone Aktionen/Phasen

Asynchron von einem externen Ausführungssystem rückgerufene Funktionen zur Therapiedurchführung.

Isom.Base.Boolean | OnAsyncActionFinished(Isom.Plan.TherapyPlanAction action, Isom.Base.Boolean succ)

Wird aufgerufen, wenn der Status der Abarbeitung einer asynchronen Aktion auf den finalen Zustand 'ausgeführt' gesetzt wird.

Isom.Base.Boolean | OnAsyncActionStarting(Isom.Plan.TherapyPlanAction action)

Wird aufgerufen, wenn der Status der Abarbeitung einer asynchronen Aktion auf den Zustand 'in Ausführung' gesetzt wird.

Isom.Base.Boolean | OnAsyncPhaseHalted(Isom.Plan.TherapyPlanActionList actions, Isom.Sys.ErrorList errors)

Wird aufgerufen, wenn bei der Abarbeitung eines asynchronen Plans Fehler aufgetreten sind und eine Maßnahmensteigerung möglich ist.

Rückruffunktionen für Änderungen im Sitzungskontext

Technische Rückruffunktionen bei Änderungen an der Client-Umgebung.

Isom.Base.Boolean | OnClientListChanged(Isom.Sys.ClientDataList added, Isom.Sys.ClientDataList removed)

Wird aufgerufen, wenn sich die Liste der Clients ändert, die mit der Sitzung verbunden sind.

Isom.Base.Boolean | OnSessionListChanged(Isom.Base.StringList started, Isom.Base.StringList stopped)

Wird aufgerufen, wenn sich die Liste der Sitzungen ändert, die momentan aktiv sind.

Ausführliche Beschreibung

In diesem Namensraum werden alle Einsprungspunkte (Rückruffunktionen für Phasen des Phasenmodells)und Rückruffunktionen definiert, die vom Serviceautor spezialisiert werden können.

Die Standard-Implementierungen geben in der Regel true zurück. Nur wenn kein sinnvolles Standard-Verhalten möglich ist (z.B. bei RunAction() wird false zurückgegeben). Außerdem protokollieren die meisten Standard-Implementierungen ein Warnung über die fehlende Spezialisierung.

Achtung:
Alle hier aufgelisteten Funktionen müssen als Rückgabewert Isom.Base.Boolean verwenden.
Siehe auch:
ISOM-Phasenmodell
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010

Quelldateien:

  • Isom\Global\Processes.is

Dokumentation der Funktionen

Isom.Base.Boolean Isom.Global.Processes.AbortActionPlan ( )

Führt einen manuellen Planabbruch durch.

Diese Rückruffunktion wird von ISOM beim manuellen Abbruch einer Sitzung aufgerufen. In der Funktion können vom Serviceautor Arbeiten angewiesen werden, die zum korrekten Abschluss des abgebrochenen Plans nötig sind.

Dieser Einsprungspunkt kann in Phase 10 des Phasenmodells aufgerufen werden.

  Isom.Base.Boolean AbortActionPlan()
  {
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance ();
      Isom.Plan.ActionPlan ap = Isom.Plan.ActionPlan.GetInstance (tp);

      // Beenden signalisieren
      Isom.Base.Boolean success = ap.TryAbort (10000);

      // Falls das Signalisieren erfolgreich war, Planabbruch erzwingen
      if( success )
      {
          success = aPlan.ForceAbort ();
      }

      return success;
  }
Zu beachten:
Die Funktion wird im Prozesszustand "StateActionPlanPerforming" aufgerufen, um eine Planausführung vorzeitig abzubrechen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
Rückgabewert wird nicht ausgewertet.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1382 - 1390]
Isom.Base.Boolean Isom.Global.Processes.AddActionManually ( Isom.Plan.TherapyPlanAction action )

Fügt eine Aktion zum Therapieplan hinzu.

Fügt dem Therapieplan die übergebene Aktion action hinzu.

Dieser Einsprungspunkt wird in Phase 7 des Phasenmodells aufgerufen.

  Isom.Base.Boolean AddActionManually( Isom.Plan.TherapyPlanAction action )
  {
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();

      // Aktion hinzufügen
      Isom.Base.Boolean success = tp.Add( action );
      return success;
  }
Nachbedingung:
Wenn diese Funktion true zurückgibt, enthält der Therapieplan die übergebene Aktion action.
Zu beachten:
Die Funktion wird im Phasenmodell im Zustand "StateTherapyPlanCreated" aufgerufen, um dem Therapieplan eine Aktion hinzuzufügen.
Sinnvolle Spezialisierungsebenen
alle
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 613 - 621]
Isom.Base.Boolean Isom.Global.Processes.CalculateFinalPlan ( )

Berechnet den finalen Therapieplan.

Ziel dieses Einsprungspunkts ist es, von der Logistik einen finalen Therapieplan ermitteln zu lassen, in dem der native Therapieplan mit den manuell hinzugefügten Aktionen zusammengeführt wird.

Dieser Einsprungspunkt wird in Phase 8 des Phasenmodells aufgerufen.

  Isom.Base.Boolean CalculateFinalPlan()
  {
      Isom.Context.FutureVehicleContext futureContext = Isom.Context.FutureVehicleContext.GetInstance ();

      // Neuen Soll-Kontext mit manuellen Erweiterungen an die Logistik übergeben:
      if (futureContext.CalcFinalFutureContext().Failed())
      {
          return false;
      }

      // Füge dem Therapieplan eine Aktion hinzu:
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
      Isom.Plan.TherapyPlanAction action = tp.CreateAction("FinalContext");
      if(tp.Add( action ))
      {
          return false;
      }

      return true;
  }

  Isom.Base.Boolean FilterFinalContext()
  {
      // Therapieplan für den neuen Soll-Kontext von Einsprungspunkt erzeugen lassen:
      return GeneratePlan();
  }
Nachbedingung:
Wenn diese Funktion true zurückgibt, ist ein gültiger Therapieplan vorhanden.
Zu beachten:
Die Funktion wird im Phasenmodell aufgerufen, um ISOM vom Zustand "StateTherapyPlanCreated" in den Zustand "StateTherapyPlanCompleted" zu überführen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 815 - 823]
Isom.Base.Boolean Isom.Global.Processes.CheckAccess ( )

Prüfung des Fahrzeugzugangs.

Dieser Einsprungspunkt wird zu Beginn der Phase 2 des Phasenmodells aufgerufen. Der Serviceautor hat hier die Möglichkeit, notwendige Eigenschaften des Fahrzeugzugangs zu überprüfen.

  Isom.Base.Boolean CheckAccess( )
  {
      return true;
  }
Zu beachten:
Die Funktion wird im Phasenmodell im Zustand "StateConfigKnown" vor der Ermittlung der Steuergeräteliste mit UpdateCurrentContextVehicleData() aufgerufen
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 240 - 248]
Isom.Base.Boolean Isom.Global.Processes.CheckForPreservedSession ( )

Prüft, ob eine gespeicherte Sitzung vorhanden ist.

Es wird geprüft, ob eine gespeicherte Sitzung vorhanden ist, und ggf. wird sie wiederaufgenommen.

Dieser Einsprungspunkt wird in Phase 3 des Phasenmodells aufgerufen. Je nach Rückgabewert erfolgt der Wechsel zu zu Phase 4 (false) oder Phase 10 (true).

  Isom.Base.Boolean CheckForPreservedSession( )
  {
      // Überprüfung, ob es eine gespeicherte Sitzung gibt
      Isom.Base.Boolean result = Isom.Plan.ActionPlan.PreservedSessionExists ();

      if (result)
      {
          // Versuch, gespeicherte Sitzung wiederaufzunehmen
          result = ActionPlan.ResumePreservedSession();
      }

      return result;
  }
Zu beachten:
Die Funktion wird im Phasenmodell im Zustand "StateVehicleDataKnown" aufgerufen.
Sinnvolle Spezialisierungsebenen
OEM
Rückgabe:
Isom.Base.Boolean
true wenn eine Sitzung wiederaufgenommen wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 297 - 305]
Isom.Base.Boolean Isom.Global.Processes.CompleteTherapyPlan ( )

Schließt die Therapieplanermittlung ab.

Veraltet:
Veraltet seit Argonaut 1.5. Dieser Einsprungspunkt wird nur aus Gründen der Rückwärtskompatibilität unterstützt. Die Planvervollständigung sollte stattdessen in CalculateFinalPlan() erfolgen.
Zu beachten:
Die Funktion wird im Prozesszustand "StateTherapyPlanCompleted" aufgerufen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1467 - 1470]
Isom.Base.Boolean Isom.Global.Processes.ContextIdent ( )

Ermittlung der Baureihe.

Dieser Einsprungspunkt wird zu Beginn der Phase 1 des Phasenmodells aufgerufen. Der Serviceautor hat hier die Möglichkeit, die Baureihenerkennung zu beeinflussen.

  Isom.Base.Boolean ContextIdent( )
  {
      // Baureihengruppe aus Konfiguration holen
      Isom.Context.ContextConfiguration config = Isom.Context.ContextConfiguration.GetInstance();
      Isom.Base.String modelSeriesGroup = config.GetModelSeriesGroup();

      if( modelSeriesGroup.Equals( "" ).Not().And( modelSeriesGroup.Equals( "Base" ).Not()) )
      {
          // Baureihengruppe wurde extern vorgegeben - protokollieren
      }
      else
      {
          // Assistenten zur Baureihenauswahl ausführen
      }

      return true;
  }
Nachbedingung:
Wenn diese Funktion true zurückgibt, muss die Baureihe des Fahrzeugs im Ist-Kontext bekannt sein.
Zu beachten:
Die Funktion wird im Phasenmodell aufgerufen, um ISOM vom Zustand "StateConfigUnknown" in den Zustand "StateConfigKnown" zu überführen.
Sinnvolle Spezialisierungsebenen
OEM
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 193 - 201]
Isom.Base.Boolean Isom.Global.Processes.DeleteFinalPlan ( )

Entfernt den finalen Therapieplan.

Entfernt den in CalculateFinalPlan() erstellten finalen Therapieplan wieder.

Dieser Einsprungspunkt kann in Phase 8 des Phasenmodells aufgerufen werden, um wieder in Phase 7 zurückzukehren.

  Isom.Base.Boolean DeleteFinalPlan()
  {
      // Entfernt die Aktion "FinalContext" aus dem Therapieplan:
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance ();
      if (tp.Remove (tp.CreateAction ("FinalContext")).Failed ())
      {
          // ggf. protokollieren, dass kein finaler Therapieplan gefunden wurde
      }

      // immer @c true zurückgeben
      return true;
  }
Zu beachten:
Die Funktion wird im Phasenmodell aufgerufen, um ISOM vom Zustand "StateTherapyPlanCompleted" in den Zustand "StateTherapyPlanCreated" zu überführen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 871 - 879]
Isom.Base.Boolean Isom.Global.Processes.DoCode ( Isom.Plan.TherapyPlanAction action )

Therapiefunktionen für die Codierung.

In dieser Funktion implementiert der Serviceautor die Aktion Code unter Berücksichtigung aller fachlicher Aspekte.

  Isom.Base.Boolean DoCode (Isom.Plan.TherapyPlanAction action)
  {
      Isom.Context.Ecu ecu = action.GetEcu();

      Isom.Base.Boolean success = ecu.CodeWithDefaults();
      return success;
  }
Sinnvolle Spezialisierungsebenen
alle
Parameter:
action Therapieplanaktion.
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1759 - 1767]
Isom.Base.Boolean Isom.Global.Processes.DoFlash ( Isom.Plan.TherapyPlanAction action )

Therapiefunktionen für die Programmierung.

In dieser Funktion implementiert der Serviceautor die Aktion Flash unter Berücksichtigung aller fachlicher Aspekte.

  Isom.Base.Boolean DoFlash (Isom.Plan.TherapyPlanAction action)
  {
      Isom.Context.Ecu ecu = action.GetEcu();

      Isom.Base.Boolean success = ecu.FlashComfort();
      if(success.Failed())
      {
          // Maßnahmensteigerung
          success = ecu.FlashForced();
      }

      return success;
  }
Sinnvolle Spezialisierungsebenen
alle
Parameter:
action Therapieplanaktion.
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1712 - 1720]
Isom.Base.Boolean Isom.Global.Processes.DoMount ( Isom.Plan.TherapyPlanAction action )

Therapiefunktionen für den Einbau.

In dieser Funktion implementiert der Serviceautor die Aktion Mount unter Berücksichtigung aller fachlicher Aspekte.

  Isom.Base.Boolean DoMount (Isom.Plan.TherapyPlanAction action)
  {
      return true;
  }
Sinnvolle Spezialisierungsebenen
alle
Parameter:
action Therapieplanaktion.
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1847 - 1855]
Isom.Base.Boolean Isom.Global.Processes.DoReplace ( Isom.Plan.TherapyPlanAction action )

Therapiefunktionen für den Tausch.

In dieser Funktion implementiert der Serviceautor die Aktion Replace unter Berücksichtigung aller fachlicher Aspekte.

  Isom.Base.Boolean DoReplace (Isom.Plan.TherapyPlanAction action)
  {
      return true;
  }
Sinnvolle Spezialisierungsebenen
alle
Parameter:
action Therapieplanaktion.
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1891 - 1899]
Isom.Base.Boolean Isom.Global.Processes.DoTp2Ap ( )

Ermittelt den aktuellen Aktionsplan.

Ermittelt zum aktuellen Therapieplan den zugehörigen Aktionsplan und setzt diesen als aktuellen Aktionsplan.

Dieser Einsprungspunkt wird in Phase 9 des Phasenmodells aufgerufen, unmittelbar nach SetExecutionOrder().

  Isom.Base.Boolean DoTp2Ap()
  {
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance ();
      Isom.Plan.ActionPlan ap = Isom.Plan.ActionPlan.GetInstance (tp);

      Isom.Base.Boolean success = ap.DoTp2Ap ();
      return success;
  }
Zu beachten:
Die Funktion wird im Phasenmodell aufgerufen, um ISOM vom Zustand "StateTherapyPlanCreated" in den Zustand "StateActionPlanCreated" zu überführen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 991 - 999]
Isom.Base.Boolean Isom.Global.Processes.DoUnmount ( Isom.Plan.TherapyPlanAction action )

Therapiefunktionen für den Ausbau.

In dieser Funktion implementiert der Serviceautor die Aktion Unmount unter Berücksichtigung aller fachlicher Aspekte.

  Isom.Base.Boolean DoUnmount (Isom.Plan.TherapyPlanAction action)
  {
      return true;
  }
Sinnvolle Spezialisierungsebenen
alle
Parameter:
action Therapieplanaktion.
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1803 - 1811]
Isom.Base.Boolean Isom.Global.Processes.EndPlanPhase ( Isom.Plan.ActionPlanPhase phase )

Wird nach Abschluss einer Aktionsplanphase aufgerufen.

Wird nach der Ausführung einer Aktionsplanphase aufgerufen. Hier können vom Serviceautor Arbeiten angewiesen werden, die nach Abschluss einer Aktionsplanphase auszuführen sind - z.B. Reaktivieren des MOST-GW nach paralleler Programmierung.

Dieser Einsprungspunkt wird in Phase 10 des Phasenmodells aufgerufen.

  Isom.Base.Boolean EndPlanPhase(Isom.Plan.ActionPlanPhase phase)
  {
      return true;
  }
Parameter:
phase Aktionsplanphase.
Zu beachten:
Die Funktion wird im Prozesszustand "StateActionPlanPerforming" aufgerufen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1186 - 1194]
Isom.Base.Boolean Isom.Global.Processes.ExecuteActionPlan ( )

Startet die Ausführung des Aktionsplans.

Startet die Ausführung des aktuellen Aktionsplans.

Dieser Einsprungspunkt wird in Phase 10 des Phasenmodells aufgerufen.

  Isom.Base.Boolean ExecuteActionPlan()
  {
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance ();
      Isom.Plan.ActionPlan ap = Isom.Plan.ActionPlan.GetInstance (tp);

      Isom.Base.Boolean success = ap.ExecuteActionPlan ();
      return success;
  }
Zu beachten:
Die Funktion überführt ISOM im Phasenmodell vom Zustand "StateActionPlanCreated" in den Zustand "StateActionPlanPerforming".
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1041 - 1049]
Isom.Base.Boolean Isom.Global.Processes.FinishPlan ( )

Wird nach Abschluss des Aktionsplans aufgerufen.

Wird nach der Ausführung des Aktionsplans aufgerufen. Hier kann der Serviceautor abschließende Arbeiten durchführen - z.B. Fehlerspeicher löschen.

Dieser Einsprungspunkt wird in Phase 10 des Phasenmodells aufgerufen.

  Isom.Base.Boolean FinishPlan()
  {
      return true;
  }
Zu beachten:
Die Funktion wird im Prozesszustand "StateActionPlanPerforming" aufgerufen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1233 - 1241]
Isom.Base.Boolean Isom.Global.Processes.GeneratePlan ( )

Erzeugt den nativen Therapieplan.

Der nativen Therapieplan enthält alle Aktionen, die erforderlich sind um den Ist-Kontext in den Soll-Kontext zu überführen.

Dieser Einsprungspunkt wird zu Beginn der Phase 6 des Phasenmodells aufgerufen.

  Isom.Base.Boolean GeneratePlan( )
  {
      Isom.Context.FutureVehicleContext futureContext = Isom.Context.FutureVehicleContext.GetInstance ();

      // nativen Therapieplan berechnen
      Isom.Base.Boolean success = futureContext.GeneratePlan();
      return success;
  }
Nachbedingung:
Wenn diese Funktion true zurückgibt, ist ein gültiger Therapieplan vorhanden.
Zu beachten:
Die Funktion wird im Phasenmodell im Zustand "StateFutureContextKnown" aufgerufen, um einen Therapieplan zu erzeugen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 558 - 566]
Isom.Base.Boolean Isom.Global.Processes.GetFutureContext ( )

Ermittlung des Soll-Kontexts.

In diesem Einsprungspunkt ermittelt der Serviceautor den Soll-Kontext.

Dieser Einsprungspunkt wird zu Beginn der Phase 5 des Phasenmodells aufgerufen.

  Isom.Base.Boolean GetFutureContext( )
  {
      Isom.Context.FutureVehicleContext futureContext = Isom.Context.FutureVehicleContext.GetInstance ();

      // Soll-Kontext über Logistik ermitteln
      Isom.Base.Boolean success = futureContext.CalcNewFutureContext();
      return success;
  }
Nachbedingung:
Wenn diese Funktion true zurückgibt, muss der Soll-Kontext bekannt sein.
Zu beachten:
Die Funktion wird im Phasenmodell aufgerufen, um ISOM vom Zustand "StateCurrContextKnown" in den Zustand "StateFutureContextKnown" zu überführen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 502 - 510]
Isom.Base.Boolean Isom.Global.Processes.OnAsyncActionFinished | ( | Isom.Plan.TherapyPlanAction | action,
 |  | Isom.Base.Boolean | succ
 | ) |  |

Wird aufgerufen, wenn der Status der Abarbeitung einer asynchronen Aktion auf den finalen Zustand 'ausgeführt' gesetzt wird.

Diese Rückruffunktion wird aufgerufen, wenn die Bearbeitung einer asynchronen Aktion beendet wird, d.h. wenn die Aktion durch ein externes Ausführungssystem gesteuert wurde.

  Isom.Base.Boolean OnAsyncActionFinished (Isom.Plan.TherapyPlanAction action, Isom.Base.Boolean succ)
  {
      return true;
  }
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Basisbaureihe
Parameter:
action | Therapieplanaktion.
succ | Gibt an, ob die Ausführung der Aktion erfolgreich war.
Rückgabe:
Isom.Base.Boolean
Rückgabewert wird nicht ausgewertet.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1999 - 2007]
Isom.Base.Boolean Isom.Global.Processes.OnAsyncActionStarting ( Isom.Plan.TherapyPlanAction action )

Wird aufgerufen, wenn der Status der Abarbeitung einer asynchronen Aktion auf den Zustand 'in Ausführung' gesetzt wird.

Diese Rückruffunktion wird aufgerufen, wenn die Bearbeitung einer asynchronen Aktion begonnen wird, d.h. wenn die Aktion durch ein externes Ausführungssystem gesteuert wird.

  Isom.Base.Boolean OnAsyncActionStarting (Isom.Plan.TherapyPlanAction action)
  {
      return true;
  }
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Basisbaureihe
Parameter:
action Therapieplanaktion.
Rückgabe:
Isom.Base.Boolean
Rückgabewert wird nicht ausgewertet.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1952 - 1960]
Isom.Base.Boolean Isom.Global.Processes.OnAsyncPhaseHalted | ( | Isom.Plan.TherapyPlanActionList | actions,
 |  | Isom.Sys.ErrorList | errors
 | ) |  |

Wird aufgerufen, wenn bei der Abarbeitung eines asynchronen Plans Fehler aufgetreten sind und eine Maßnahmensteigerung möglich ist.

Diese Rückruffunktion wird aufgerufen, wenn bei der Abarbeitung eines asynchronen Plans Fehler aufgetreten sind und eine Maßnahmensteigerung möglich ist. über den Rückgabewert dieser Rückruffunktion wird festgelegt, ob eine Maßnahmensteigerung durchgeführt werden soll.

Zu beachten:
Der Umfang der Maßnahmensteigerung kann nicht beeinflusst werden. Es werden immer alle Aktionen ausgeführt, die noch nicht erfolgreich waren.
  Isom.Base.Boolean OnAsyncPhaseHalted (Isom.Plan.TherapyPlanActionList actions, Isom.Sys.ErrorList errors)
  {
      // nie eine Maßnahmensteigerung durchführen
      return false;
  }
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Basisbaureihe
Parameter:
actions | ausgeführte Aktionen
errors | Ausführungsfehler
Rückgabe:
Isom.Base.Boolean
gibt an, ob eine Maßnahmensteigerung auszuführen ist.
Seit:
Diese Rückruffunktion wurde zu Argonaut 1.15 eingeführt.
[Isom\Global\Processes.is: 2049 - 2057]
Isom.Base.Boolean Isom.Global.Processes.OnClientListChanged | ( | Isom.Sys.ClientDataList | added,
 |  | Isom.Sys.ClientDataList | removed
 | ) |  |

Wird aufgerufen, wenn sich die Liste der Clients ändert, die mit der Sitzung verbunden sind.

  Isom.Base.Boolean OnClientListChanged (Isom.Sys.ClientDataList added, Isom.Sys.ClientDataList removed)
  {
      return true;
  }
Sinnvolle Spezialisierungsebenen
OEM
Parameter:
added | neu hinzugekommene Clients
removed | Clients, die die Verbindung getrennt haben
Rückgabe:
Isom.Base.Boolean
Rückgabewert wird nicht ausgewertet.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 2104 - 2113]
Isom.Base.Boolean Isom.Global.Processes.OnIsomStarting ( )

Wird aufgerufen, sobald die statische Prüfung der Skripte abgeschlossen ist.

In dieser Rückruffunktion können vom Serviceautor Arbeiten angewiesen werden, die nur einmal zu Beginn einer Fahrzeugsitzung auszuführen sind, z.B. das Starten von Umgebungswächtern.

Diese Rückruffunktion gehört nicht zum Phasenmodell.

  Isom.Base.Boolean OnIsomStarting( )
  {
      // Zeitgeber für Umgebungsüberwachung erzeugen
      Isom.Sys.Events.PeriodicTimer environmentUpdateTimer = Isom.Sys.Events.PeriodicTimer.CreatePeriodicTimer(
          "EnvironmentUpdateTimer", 5000, "OnEnvironmentUpdate");
      environmentUpdateTimer.Enable();

      return true;
  }

  // Periodisch aufgerufene Rückruffunktion des Zeitgebers
  Boolean OnEnvironmentUpdate(Isom.Sys.Events.TimerInfo info)
  {
      // Prüfung der Umgebungswerte, z.B. Spannungen
  }
Sinnvolle Spezialisierungsebenen
OEM
Zu beachten:
Die Funktion wird aufgerufen, während ISOM sich im Processzustand "StateConfigUnknown" befindet
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1592 - 1600]
Isom.Base.Boolean Isom.Global.Processes.OnIsomStopping | ( | Isom.Base.Boolean | isForced,
 |  | Isom.Base.String | message
 | ) |  |

Wird vor dem eigentlichem Beenden von ISOM aufgerufen.

Diese Rückruffunktion wird vor dem eigentlichem Beenden von ISOM aufgerufen. Der Serviceautor kann hier Arbeiten anweisen, die zur korrekten Beendigung einer Fahrzeugsitzung nötig sind.

Diese Rückruffunktion gehört nicht zum Phasenmodell.

  Isom.Base.Boolean OnIsomStopping(Isom.Base.Boolean isForced, Isom.Base.String message)
  {
      return true;
  }
Achtung:
Die Abarbeitungszeit dieser Funktion ist auf 3 Sekunden beschränkt.
Parameter:
isForced | Zeigt an, ob die Beendigung erzwungen ist.
message | Beschreibt die Ursache für das Beenden.
Sinnvolle Spezialisierungsebenen
OEM
Rückgabe:
Isom.Base.Boolean
Rückgabewert wird nicht ausgewertet.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1642 - 1650]
Isom.Base.Boolean Isom.Global.Processes.OnLogicalVehicleChanged | ( | Isom.Base.String | previousLV,
 |  | Isom.Base.String | nextLV,
 |  | Isom.Base.String | requestedPChannel
 | ) |  |

Benachrichtigung über einen Wechsel des aktiven logischen Fahrzeugs

Für jedes logische Fahrzeug kann in der ISOM-Fahrzeugbeschreibung ein eigener Fachdienstesatz vorgegeben werden.
Jedesmal wenn Fachdienste für ein anderes logisches Fahrzeug als bisher angefordert werden, wird diese Rückruffunktion aufgerufen.

  Isom.Base.Boolean OnLogicalVehicleChanged (
    Isom.Base.String previousLV,
    Isom.Base.String nextLV,
    Isom.Base.String requestedPChannel)
  {
      // Wechsel protokollieren

      return true;
  }
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Parameter:
previousLV | Name des bisher verwendeten logischen Fahrzeugs
nextLV | Name des ab jetzt verwendeten logischen Fahrzeugs
requestedPChannel | Angefragter P-Kanal entsprechend Kanalmodell aus der ISOM-Fahrzeugbeschreibung
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall;
Der Rückgabewert wird von ISOM nicht ausgewertet.
Seit:
Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 23. 08 .2011
[Isom\Global\Processes.is: 1521 - 1526]
Isom.Base.Boolean Isom.Global.Processes.OnRestartTherapySession ( )

Wird beim Wiedereinstieg in eine Sitzung aufgerufen.

Diese Rückruffunktion wird von ISOM beim Wiedereinstieg in eine Sitzung aufgerufen. In der Funktion können vom Serviceautor Arbeiten angewiesen werden, die zum Wiedereinstieg nötig sind - z.B. globale Flaggen löschen.

  Isom.Base.Boolean OnRestartTherapySession()
  {
      return true;
  }
Sinnvolle Spezialisierungsebenen
OEM
Rückgabe:
Isom.Base.Boolean
Rückgabewert wird nicht ausgewertet.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1323 - 1331]
Isom.Base.Boolean Isom.Global.Processes.OnSessionListChanged | ( | Isom.Base.StringList | started,
 |  | Isom.Base.StringList | stopped
 | ) |  |

Wird aufgerufen, wenn sich die Liste der Sitzungen ändert, die momentan aktiv sind.

  Isom.Base.Boolean OnSessionListChanged (Isom.Base.StringList started, Isom.Base.StringList stopped)
  {
      return true;
  }
Sinnvolle Spezialisierungsebenen
OEM
Parameter:
started | neu gestartete Sitzungen
stopped | Sitzungen, die beendet wurden
Rückgabe:
Isom.Base.Boolean
Rückgabewert wird nicht ausgewertet.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 2146 - 2155]
Isom.Base.Boolean Isom.Global.Processes.OnUserProfileChanged ( Isom.Context.UserProfile userProfileChanges )

Wird aufgerufen, wenn das Benutzerprofil über die Client-Schnittstelle verändert wurde.

Der Serviceautor wird mit dieser Rückruffunktion über Änderungen am Benutzerprofil informiert und kann diese Ereignisse beispielsweise protokollieren.

  Isom.Base.Boolean OnUserProfileChanged (Isom.Context.UserProfile userProfileChanges)
  {
      // Änderungen protokollieren

      return true;
  }
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Parameter:
userProfileChanges Geänderte Benutzerprofil-Werte.
Rückgabe:
Isom.Base.Boolean
Rückgabewert wird nicht ausgewertet.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1429 - 1437]
Isom.Base.Boolean Isom.Global.Processes.PreparePlan ( )

Wird zu Beginn des Aktionsplans aufgerufen.

Wird zu Beginn der Ausführung des Aktionsplans aufgerufen.

Dieser Einsprungspunkt wird in Phase 10 des Phasenmodells aufgerufen.

  Isom.Base.Boolean PreparePlan()
  {
      return true;
  }
Zu beachten:
Die Funktion wird im Phasenmodell aufgerufen, um ISOM vom Zustand "StateTherapyPlanCompleted" in den Zustand "StateActionPlanCreated" zu überführen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1089 - 1097]
Isom.Base.Boolean Isom.Global.Processes.ReevaluateDataAvailability ( )

Neubewertung der Datenverfügbarkeit für alle Aktionen.

Startet die Neubewertung der Datenverfügbarkeit für alle Aktionen im Therapieplan.

Dieser Einsprungspunkt kann in den Phasen 7 bis 9 des Phasenmodells aufgerufen werden.

  Isom.Base.Boolean ReevaluateDataAvailability()
  {
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance ();

      Isom.Base.Boolean success = tp.ReevaluateDataAvailability();
      return success;
  }
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1281 - 1289]
Isom.Base.Boolean Isom.Global.Processes.RemoveActionManually ( Isom.Plan.TherapyPlanAction action )

Enfernt eine Aktion aus dem Therapieplan.

Entfernt die übergebene Aktion action aus dem Therapieplan.

Dieser Einsprungspunkt wird in Phase 7 des Phasenmodells aufgerufen.

  Isom.Base.Boolean RemoveActionManually( Isom.Plan.TherapyPlanAction action )
  {
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();

      // Aktion entfernen
      Isom.Base.Boolean success = tp.Remove( action );
      return success;
  }
Nachbedingung:
Wenn diese Funktion true zurückgibt, wurde die übergebene Aktion action aus dem Therapieplan entfernt.
Zu beachten:
Die Funktion wird im Phasenmodell im Zustand "StateTherapyPlanCreated" aufgerufen, um eine Aktion aus dem Therapieplan zu entfernen.
Sinnvolle Spezialisierungsebenen
alle
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 668 - 676]
Isom.Base.Boolean Isom.Global.Processes.RunAction ( Isom.Plan.TherapyPlanAction action )

Sofortausführung einer einzelnen Aktion

Die übergebene Aktion action wird sofort ausgeführt. Eventuell vorhandene Vor- und Nachbereiter werden nicht ausgeführt.

Dieser Einsprungspunkt kann in den Phasen 2 bis 7 des Phasenmodells aufgerufen werden.

Achtung:
Damit eine Aktion (z.B. "SelfTest") sofort ausgeführt werden kann, wird eine ISOM/L-Funktion namens "Run<Aktionsname>" (z.B. "RunSelfTest") benötigt, in der der Serviceautor die Ausführung programmiert.
  Isom.Base.Boolean RunAction( Isom.Plan.TherapyPlanAction action )
  {
      Isom.Base.Boolean success = action.Run();
      return success;
  }

  Isom.Base.Boolean RunSelfTest( Isom.Context.Ecu ecu )
  {
      // Selbsttest ausführen
      // Isom.Services.AsamResponseList results = Isom.Services.Asam.ExecuteOnEcu(ecu, ...);

      return true;
  }
Nachbedingung:
Wenn diese Funktion true zurückgibt, wurde die übergebene Aktion action ausgeführt.
Zu beachten:
Die Funktion kann im Phasenmodell in folgenden Zuständen aufgerufen werden:
  • StateConfigKnown
  • StateVehicleDataKnown
  • StateCurrContextKnown
  • StateFutureContextKnown
  • StateTherapyPlanCreated
Sinnvolle Spezialisierungsebenen
alle
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 739 - 747]
Isom.Base.Boolean Isom.Global.Processes.SetExecutionOrder ( )

Festlegung der Ausführungsreihenfolge.

In diesem Einsprungspunkt legt der Serviceautor die Ausführungsreihenfolge von Aktionen fest. Diese Reihenfolge wird für die folgende Aktionsplanberechnung benötigt.

Dieser Einsprungspunkt wird in Phase 9 des Phasenmodells aufgerufen, unmittelbar vor DoTp2Ap().

  Isom.Base.Boolean SetExecutionOrder()
  {
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance ();
      Isom.Plan.ActionPlan ap = Isom.Plan.ActionPlan.GetInstance (tp);

      // Reihenfolge der Aktionen:
      // "Umbau" vor "Programmierung" vor "Codierung"

      // "Umbau" umfasst Ausbau, Einbau und Tausch
      ap.SetExecutionOrders ("Unmount");
      ap.SetExecutionOrders ("Mount");
      ap.SetExecutionOrders ("Replace");

      // "Programmierung"
      ap.SetExecutionOrders ("Flash");

      // "Codierung"
      ap.SetExecutionOrders ("Code");

      // immer @c true zurückgeben
      return true;
  }
Zu beachten:
Die Funktion wird im Prozesszustand "StateTherapyPlanCompleted" aufgerufen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 938 - 946]
Isom.Base.Boolean Isom.Global.Processes.StartPlanPhase ( Isom.Plan.ActionPlanPhase phase )

Wird zu Beginn einer Aktionsplanphase aufgerufen.

Wird vor der Ausführung einer Aktionsplanphase aufgerufen. Hier können vom Serviceautor Arbeiten angewiesen werden, die zu Beginn einer Aktionsplanphase auszuführen sind - z.B. Deaktivieren des MOST-GW bei paralleler Programmierung.

Dieser Einsprungspunkt wird in Phase 10 des Phasenmodells aufgerufen.

  Isom.Base.Boolean StartPlanPhase(Isom.Plan.ActionPlanPhase phase)
  {
      return true;
  }
Zu beachten:
Die Funktion wird im Prozesszustand "StateActionPlanPerforming" aufgerufen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 1137 - 1145]
Isom.Base.Boolean Isom.Global.Processes.UpdateCurrentContextEcus ( )

Ermittlung und Setzen der Ist-Steuergeräteliste im Modell.

In diesem Einsprungspunkt ermittelt der Serviceautor die Listen der Steuergeräte, die im Fahrzeug verbaut sind bzw. erwartet werden, und ergänzt den Ist-Kontext entsprechend.

Dieser Einsprungspunkt wird zu Beginn der Phase 4 des Phasenmodells aufgerufen.

  Isom.Base.Boolean UpdateCurrentContextEcus( )
  {
      Isom.Context.CurrentVehicleContext currentContext = Isom.Context.CurrentVehicleContext.GetInstance ();
      Isom.Context.EcuList expectedEcus = currentContext.GetExpectedEcus();
      Isom.Context.EcuList identifiedEcus = currentContext.IdentifyAllEcus();

      // Behandlung für nicht antwortende oder unerwartet verbaute SG

      Isom.Base.Boolean success = currentContext.SetEcus(identifiedEcus);
      return success;
  }
Nachbedingung:
Wenn diese Funktion true zurückgibt, muss der Ist-Kontext vollständig sein.
Zu beachten:
Die Funktion wird im Phasenmodell aufgerufen, um ISOM vom Zustand "StateVehicleDataKnown" in den Zustand "StateCurrContextKnown" zu überführen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München)
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 444 - 452]
Isom.Base.Boolean Isom.Global.Processes.UpdateCurrentContextVehicleData ( )

Ermittlung des Ist-Kontexts außer der Steuergeräteliste.

In diesem Einsprungspunkt kann der Serviceautor fehlende Daten des Ist-Kontexts ergänzen.

Dieser Einsprungspunkt wird zu Beginn der Phase 3 des Phasenmodells aufgerufen.

Verwendungsbeispiel:
Der folgende Quelltext zeigt eine einfache Implementierung des Einsprungspunkts UpdateCurrentContextVehicleData:
  Isom.Base.Boolean UpdateCurrentContextVehicleData() // Einsprungspunkt zur Ermittlung von Fahrzeuginformationen (Phase 3)
  {
     // Abfrage der Zugriffsinstanz
     Isom.Context.CurrentVehicleContext cctx = Isom.Context.CurrentVehicleContext.GetInstance();

     // Ermittlung der Fahrzeugmerkmale durch den Fachdienst zur Fahrzeugkommunikation
     if (cctx.ReadVehicleOrder().Failed())
     {
        // Fahrzeugmerkmale konnten nicht ausgelesen werden
        return false;
     }

     // Ermittlung der Integrationsstände durch den Fachdienst zur Fahrzeugkommunikation
     if (cctx.ReadVersions().Failed())
     {
        // Integrationsstände konnten nicht ausgelesen werden
        return false;
     }

     // Ermittlung des Benutzerprofils durch den Fachdienst zur Fahrzeugkommunikation
     if (cctx.ReadUserProfile().Failed())
     {
        // Benutzerprofil konnte nicht ausgelesen werden
        return false;
     }

     // Abfrage einer Kopie der ermittelten Fahrzeugmerkmale
     Isom.Context.VehicleOrder vo = cctx.GetVehicleOrderClone();

     // Auswertung der ermittelten Fahrzeugmerkmale
     // ..

      return true;
  }
Nachbedingung:
Wenn diese Funktion true zurückgibt, muss der Ist-Kontext bis auf die Liste der Steuergeräte vollständig sein.
Zu beachten:
Die Funktion wird im Phasenmodell aufgerufen, um ISOM vom Zustand "StateConfigKnown" in den Zustand "StateVehicleDataKnown" zu überführen.
Sinnvolle Spezialisierungsebenen
OEM, Fahrzeuggeneration, Baureihe
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall,
false im Fehlerfall.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Global\Processes.is: 383 - 391]


für Serviceautoren

Isom.Plan

Namensraum Isom.Plan

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Plan.ActionPlan | Fachobjekt für den Aktionsplan
Isom.Plan.ActionPlanPhase | Aktionsplanphasen
Isom.Plan.ActivationCode | Freischaltcodes (Software-Freischaltung, Airbag etc.)
Isom.Plan.ActivationCodeList | Listen von Freischaltcodes
Isom.Plan.OrderingInfo | Bestellinformationen
Isom.Plan.OrderingInfoList | Listen von Bestellinformationen
Isom.Plan.TherapyPlan | Fachobjekt des Therapieplans
Isom.Plan.TherapyPlanAction | Fachobjekt für eine Therapieplanaktion
Isom.Plan.TherapyPlanActionList | Liste von Therapieplanaktionen.


für Serviceautoren

Isom.Plan.ActionPlan

Namensraum Isom.Plan.ActionPlan

Fachobjekt für den Aktionsplan Mehr...

Funktionen
Isom.Base.Boolean | SignalUserInteractionsDone()

Die Funktion SignalUserInteractionsDone gibt für die Aktion, aus der SignalUserInteractionsDone aufgerufen wird, an, dass in der weiteren Ausführung keine Benutzerinteraktionen mehr angezeigt werden und aktualisiert die Zeitprognose bis zur nächsten Benutzerinteraktion dementsprechend.

Instanz-Zugriff

Zugriff auf das Singleton 'ActionPlan'.

Isom.Plan.ActionPlan | GetInstance(Isom.Plan.TherapyPlan tPlan)

Ermittelt den für diese ISOM-Sitzung gültigen Aktionsplan.

Zugriff auf die Phasen

Zugriff auf die Phasen eines Aktionsplans

Isom.Plan.ActionPlanPhase | GetPhase(Isom.Base.String phaseIdent)

Ermittelt für den angegebenen Phasenbezeichner die zugehörige Aktionsplanphase.

Isom.Base.StringList | GetPhases()

Ermittelt Liste von Phasenbezeichnern.

Ermittlung von Zeitwerten

Ermittlung von Zeitprognosen und Laufzeiten

Isom.Base.Number | GetEstimatedRuntime()

Ermittelt die prognostizierte Gesamtausführungszeit.

Isom.Base.Number | GetProcessedRuntime()

Ermittelt die Gesamtausführungszeit des Aktionsplans.

Steuerung der Ausführungsreihenfolge

Abfragen / Setzen der starken ISOM-Ausführungsreihenfolge.

Isom.Base.Boolean | ContainsAsyncBlock()

Ermittelt ob der Aktionsplans asynchrone Aktionen enthält.

Isom.Base.Boolean | SetExecutionOrderGroup(Isom.Base.String actionplangroupRegex)

Legt die Ausführungsreihenfolge aller asynchronen Aktionen innerhalb einer Ausführungsgruppe fest.

Isom.Base.Boolean | SetExecutionOrders(Isom.Base.String actionname)

Legt die Ausführungsreihenfolge der Aktionen fest.

Steuerung der Therapiedurchführung und Neustart

Steuerung der Therapiedurchführung

Isom.Base.Boolean | DoTp2Ap()

Ermittelt zum aktuellen Therapieplan den zugehörigen Aktionsplan und setz diesen als aktuellen Aktionsplan.

Isom.Base.Boolean | ExecuteActionPlan()

Startet die Ausführung des Aktionsplans.

Isom.Base.Boolean | IsActionPlanRestarting()

Prüft, ob der Aktionsplan neu gestartet (vs.

Isom.Base.Boolean | RestartActionPlan()

Initiiert die Neuausführung des Aktionsplans.

Konservierung, Pause, Wiederaufwachen

Steuerung von Konservierung, Pause und Wiederaufwachen

Isom.Base.Boolean | DeletePreservedSession()

Löscht eine persistierte Sitzung.

Isom.Base.String | GetPreservedSessionVersion()

Gibt die Versionskennung einer existierenden konservierten Sitzung zurück.

Isom.Base.Boolean | PreservedSessionExists()

Überprüft, ob eine konservierte Sitzung gefunden werden kann.

Isom.Base.Boolean | PreserveSession()

Löst die Konservierung der aktuellen ISOM-Sitzung aus.

Isom.Base.Boolean | ResumePreservedSession()

Setzt eine evtl.

Debugging-Unterstützung

Debugging-Unterstützung

Isom.Base.String | GetCurrentActionChannel()

Liefert den N-Kanal, über den die aufrufende Aktion durchgeführt wird.

Isom.Base.Boolean | ShowAsMessageBox()

Zeigt eine Repräsentation des Aktionsplanes als Popup-Messagebox.

Planabbruch / Unterbrechung

Steuerung von Planabbruch / Unterbrechung

Isom.Base.Boolean | Cancel(Isom.Base.Number timeout)

Bricht eine Aktionsplanausführung ab.

Isom.Base.Boolean | Pause()

Die Funktion Pause hält die Ausführung des Aktionsplans zum nächst möglichen Zeitpunkt an.

Isom.Base.Boolean | Resume()

Die Funktion Resume setzt die Aktionsplanausführung fort, nachdem sie durch Pause() angehalten wurde.

Bestellinformation

Zusammenstellung von Bestellinformationen für Steuergeräte / Daten.

Isom.Base.Boolean | SetOrderList(Isom.Base.StringList actions, Isom.Base.StringList ecus, Isom.Base.StringList orderNos)

Die Funktion SetOrderList setzt die anzuzeigenden Bestellinformationen.

Eigenschaften

Steuende Eigenschaften für den Aktionsplan.

Isom.Base.StringList | GetAllPropertyNames()

Liefert die Namen aller Eigenschaften des Aktionsplans.

Isom.Base.String | GetProp(Isom.Base.String propName)

Ermittelt den Wert der vorgegebenen Eigenschaft (property) des Aktionsplans.

Isom.Base.StringList | GetPropNames()

Liefert die Namen aller technischen Eigenschaften für den AktionsPlan.

Isom.Base.Boolean | SetProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt den Wert der vorgegebenen Eigenschaft (property) des Aktionsplans.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Plan.ActionPlan | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Plan.ActionPlan | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Der Ausführungsplan ist gewissermaßen die Ausführungs-Ansicht der im Therapieplan geplanten konkreten Therapieplanaktionen.

Während jedoch der Therapieplan die fachlichen Zusammenhänge zwischen Aktionen beschreibt (Aktionen und deren resultierende Aktionen), umfasst der daraus berechnete Aktionsplan (=Ausführungsplan) die Ausführungsreihenfolge, die Parallelität und den aktuellen Ausführungszustand der Aktionen während der Therapiesitzung.

Der Aktionsplan ist maschenartig strukturiert und gliedert sich hierarchisch in

  • Phasen (sequentiell abzuarbeiten),
  • Pfade (je N-Kanal, innerhalb einer Phase parallel abzuarbeiten) und
  • Aktionsplanelemente (innerhalb eines Pfades sequentiell)

Zusammenhängendes Beispiel für die Autorengesteuerte Maßnahmensteigerung

Verwendungsbeispiel:
Die Beispiele zeigen die Implementierung einer autorengesteuerten Maßnahmensteigerung der Programmierung (Flash) durch wiederholte Ausführung des Aktionsplans.

Unter Maßnahmensteigerung wird allgemein die Behandlung von erkannten fachlichen Ausführungsfehlern durch irgendeine Art der Wiederholung oder Uminterpretation verstanden.

ISOM / Taurus unterstützen verschiedene Möglichkeiten der Maßnahmensteigerung durch den Autor:

  1. innere Maßnahmensteigerung in der Do...()-Funktion
    • für Servicetechniker i.d.R. transparent
    • kein Aktionsplan-Neustart notwendig
    • geeignet wenn keine Planungsinformationen (z.B. Logistik) neu ermittelt werden müssen
  2. äußere Maßnahmensteigerung durch Wiederholen der Do...()-Funktion via Aktionsplanneustart
    • für Servicetechniker i.d.R. transparent
    • Aktionsplan-Neustart notwendig
    • keine separate Maßnanahmensteigerungsaktion beteiligt
    • geeignet wenn keine Planungsinformationen (z.B. Logistik) neu ermittelt werden müssen
  3. äußere Maßnahmensteigerung durch Neuplanung der Aktion und anschließenden Aktionsplanneustart
    • für Servicetechniker i.d.R. ersichtlich
    • mindestens eine separate Maßnahmensteigerungsaktion beteiligt
    • geeignet wenn Planungsinformationen (z.B. Logistik) neu ermittelt werden müssen

Die vorliegenden zwei Beispiele widmen sich den letztgenannten zwei Varianten.

Äußere Maßnahmensteigerung durch Neuplanung und Aktionsplanneustart

Das folgende Codebeispiel zeigt alle Elemente zur Implementierung einer äußeren Maßnahmensteigerung durch Neuplanung der Aktion und anschließenden Aktionsplanneustart. Dieses Beispiel enthält folgende Elemente:

  1. In Global.Processes.ExecuteActionPlan() wird solange ActionPlan.ExecuteActionPlan() aufgerufen, bis ActionPlan.IsRestarting() nicht mehr erfüllt ist.
  2. In DoFlash() findet die Maßnahmensteigerung statt, indem bei Fehlschlag von Ecu.FlashComfort()
    • eine Maßnahmensteigerungsaktion namens "EscalationFlashLevelOne" neu geplant wird,
    • der Aktionsplan neu berechnet und zum Restart angewiesen wird,
    • die Ursprungsaktion als fehlgeschlagen markiert wird.
  3. In DoEscalationFlashLevelOne() erfolgt die Implementierung der ersten Maßnahmensteigerungsstufe für die Programmierung, der z.B. aus der Wiederholung der Programmierung mit vorherigem Steuergeräte-Reset bestehen kann (hier nur angedeutet).

  // @file Vendor.is

  Isom.Base.Boolean ExecuteActionPlan ()
  {
      // ...
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
      Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );

      while ( true ) // Autoren-gesteuerte äußere Maßnahmensteigerung
      {
          Isom.Base.Boolean ret = ap.ExecuteActionPlan ();

          if (ret)
          {
              Isom.Sys.Log.Success (Errors.ERRORNUM_ISOML_SUCCESS_EXECUTE_ACTION_PLAN, "Ausführung von ExecuteActionPlan erfolgreich");
          }
          else
          {
              Isom.Sys.Log.Error (Errors.ERRORNUM_ISOML_ERROR_EXECUTE_ACTION_PLAN, "Ausführung von ExecuteActionPlan fehlgeschlagen");
          }

          if( ap.IsActionPlanRestarting() )
          {
              Isom.Sys.Log.Success (Errors.ERRORNUM_ISOML_SUCCESS_EXECUTE_ACTION_PLAN, "Neustart von ExecuteActionPlan angefordert.");
          }
          else
          {
              Isom.Sys.Log.Success (Errors.ERRORNUM_ISOML_SUCCESS_EXECUTE_ACTION_PLAN, "Kein Neustart von ExecuteActionPlan angefordert.");
              break;
          }

      } // while ( true ) // Autoren-gesteuerte äußere Maßnahmensteigerung

      // ...

      return ret;
  }

  // ...

  Isom.Base.Boolean DoFlash( Isom.Plan.TherapyPlanAction action )
  {
      // ...

      Isom.Base.Boolean ret = ecu.FlashComfort();

      // Fehlerdifferenzierung

      if (ret.Failed())
      {
          // Nachfragen, ob für die 2. Maßnahmensteigerungsstufe
          // die Datenbereitstellung aufgerufen werden soll"
          if (Helpers.ShowYesNoHintMsg (Texts.TITLE_ESCALATIONFLASHLEVELONE,
                                        Texts.MSG_ESCALATIONFLASHLEVELONE,
                                        Texts.HINT_ESCALATIONFLASHLEVELONE))
          { // ... wenn ja :

              Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
              if( tp.IsVoid() )
              {
                  Isom.Sys.Log.Log.Error ("", "TherapyPlan.GetInstance() für die Maßnahmensteigerungsaktion fehlgeschlagen.");
              }

              // Maßnahmensteigerungsaktion hinzufügen
              Isom.Plan.TherapiePlanAction escalationAction = tp.CreateEcuAction("EscalationFlashLevelOne");
              if( tp.Add(escalationAction).Failed() )
              {
                  Isom.Sys.Log.Log.Error ("", "TherapyPlan.Add(escalationAction) fehlgeschlagen.");
              }

              // Neustart der Aktionsplanausführung veranlassen
              Isom.Plan.ActionPlan ap = Isom.Plan.ActionPlan.GetInstance( tp );
              if( ap.RestartActionPlan () )
              {
                  Isom.Sys.Log.Error ("", "Neustart des Aktionsplans fehlgeschlagen.");
              }
              return false;        // da ecu.FlashComfort() fehlgeschlagen ist

          } //if (ShowYesNoHintMsg(...))

      } //if (ret.Failed())

      return true;           // da ecu.FlashComfort() erfolgreich war
  }

  // Maßnahmensteigerungsaktion "EscalationFlashLevelOne" für "Flash"

  Isom.Base.Boolean DoEscalationFlashLevelOne ( Isom.Plan.TherapyPlanAction action )
  {
      // z.B. INIT
      // ...

      // z.B. FLASH
      // ...

      Isom.Sys.Log.Success (Errors.ERRORNUM_ISOML_SUCCESS_EXECUTE_ACTION_PLAN, Helpers.ActionLogTextDoSuccess (action, ""));

      return true;

  }

  // @file Text/Texts.is

  namespace OEM.Text.Texts
  {
      // ...

      deftext TITLE TITLE_ESCALATIONFLASHLEVELONE "Maßnahmensteigerung planen"
      deftext MESSAGE MSG_ESCALATIONFLASHLEVELONE "Soll für die fehlgeschlagene Programmierung"\
                                                  " eine Maßnahmensteigerung geplant werden?"
      deftext HINT HINT_ESCALATIONFLASHLEVELONE   "Diese Maßnahmensteigerung besteht aus einer"\
                                                  " Initialisierung und einer"\
                                                  " anschließenden Neuprogrammierung."
      // ...
  }

Äußere Maßnahmensteigerung durch Wiederholen und Aktionsplanneustart

Das folgende Codebeispiel zeigt im Vergleich die anzupassenden Elemente, wenn stattdessen eine äußere Maßnahmensteigerung durch Wiederholen der Do...()-Funktion via Aktionsplanneustart gewünscht ist.

Während Global.Processes.ExecuteActionPlan() unverändert bleibt, wird nun in der Do...()-Funktion keine Aktion explizit neu angewiesen, sondern die aktuell ausgeführte Aktion wird in den Zustand "Isom.Execution.ToReschedule" gesetzt. Der folgende Aufruf von ActionPlan.RestartActionPlan() sorgt dafür, dass diese Aktion neu zur Auführung eingeplant wird.

  // @file Vendor.is

  Isom.Base.Boolean ExecuteActionPlan ()
  {
      // ... wie im o.g. Beispiel
  }

  Isom.Base.Boolean DoFlash( Isom.Plan.TherapyPlanAction action )
  {
      // ...

      Isom.Base.Boolean ret = ecu.FlashComfort();

      // Fehlerdifferenzierung

      if (ret.Failed())
      {
          // Aktion "Flash" wiederverwenden
          action.SetState( "Isom.Execution.ToReschedule" );

          // Neustart der Aktionsplanausführung veranlassen
          Isom.Plan.ActionPlan ap =  Isom.Plan.ActionPlan.GetInstance(Isom.Plan.TherapyPlan.GetInstance());
          if( ap.RestartActionPlan ().Failed() )
          {
              action.SetState( "Isom.Execution.Failed" );
              return false;   // Aktion bleibt auf Failed
          }
          else
          {
              return false;   // Aktion bleibt auf 'ToReschedule'
          }

      } //if (ret.Failed())

      return true;           // da ecu.FlashComfort() erfolgreich war
  }

  // DoEscalationFlashLevelOne() entfällt.
Siehe auch:
Seite ISOM-Phasenmodell für die möglichen Zustandsübergänge.
Isom.Plan.ActionPlan.RestartActionPlan() für die Referenzdokumentation zur dort verwendeten Fachfunktion.

Zusammenhängendes Beispiel für den Planneustart nach Umbauten

Verwendungsbeispiel:
Das Beispiel zeigt die Implementierung eines autorengesteuerten Planneustart nach Umbauten.
  // @file Vendor.is

  Isom.Base.Boolean ExecuteActionPlan ()
  {
      // ...

      // Aktionsplan ausführen
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
      Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );
      Isom.Base.Boolean ret = ap.ExecuteActionPlan ();

      // ...
  }

  // ...

  [ContinueOnError (false)]
  [ContainsUserInteraction ()]
  Isom.Base.Boolean DoRecalcPlanAfterReassembly (Isom.Plan.TherapyPlanAction action)
  {
      // ...

      // Soll-Kontext holen
      Isom.Context.FutureVehicleContext futureContext = Isom.Context.FutureVehicleContext.GetInstance ();

      // ...

      // Plan neu berechnen nach Umbau
      // (ruft auch 'DoTp2Ap' auf (einschließlich eigener Fortschrittsmeldung))
      if (futureContext.RecalcPlanAfterReassembly (vin7).Not())
      {
          Isom.Sys.Log.Error ("", "RecalcPlanAfterReassembly fehlgeschlagen.");
          return false;
      }

      // ...

      // Funktion erfolgreich
      Isom.Sys.Log.Success ("", "DoRecalcPlanAfterReassembly erfolgreich.");

      return true;
  } // function: DoRecalcPlanAfterReassembly ()
Siehe auch:
Isom.Context.FutureVehicleContext.RecalcPlanAfterReassembly() für die Referenzdokumentation zur dort verwendeten Fachfunktion.

Quelldateien:

  • Isom\Plan\ActionPlan.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.Cancel ( Isom.Base.Number timeout )

Bricht eine Aktionsplanausführung ab.

Diese Funktion bewirkt, dass eine Aktionsplanausführung vorzeitig abgebrochen wird. Dabei wird versucht, alle Ausführungsfäden des Aktionsplans geordnet zu beenden. Die für dieses geordnete Beenden zur Verfügung stehende Zeitspanne wird als Parameter angegeben. Können die Ausführungsfäden in dieser Zeit angehalten werden, kehrt die Funktion mit 'true' zurück. In diesem Fall kann nach Rückkehr der Funktion die Sitzung fortgeführt werden. Können die Ausführungsfäden in dieser Zeit nicht angehalten werden, kann die Konsistenz des ISOM-Datenmodells nicht mehr gewährleistet werden. Daher geht ISOM dann in den Zustand über, der auch mit Aufruf von Isom.Context.ContextConfiguration.FinalizeSession() erreicht wird. Danach lässt sich die Sitzung nur noch beenden.

Bemerkungen:
Wird diese Funktion als Teil einer Aktionsplanausführung aufgerufen, kehrt der Aufruf nicht zurück, da das aufrufende Programm nach Ausführung der Funktion beendet wird.
Wird diese Funktion aufgerufen, während kein Aktionsplan ausgeführt wird, kehrt der Aufruf mit 'false' zurück.
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
      Isom.Plan.ActionPlan ap = Isom.Plan.ActionPlan.GetInstance(tp);
      ap.Cancel(10000);
Parameter:
timeout Zeitspanne, in der der Aktionsplan abgebrochen werden soll
Rückgabe:
Isom.Base.Boolean
'true', falls die Aktionsplanausführung geordnet abgebrochen wurde. 'false' sonst.
Datum:
letzte Änderung am 21.09.2010
[Isom\Plan\ActionPlan.is: 929]
objectbound Isom.Plan.ActionPlan Isom.Plan.ActionPlan.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Plan\ActionPlan.is: 1158]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.ContainsAsyncBlock ( )

Ermittelt ob der Aktionsplans asynchrone Aktionen enthält.

Es wird geprüft, ob der Aktionsplans asynchrone Aktionen enthält. Der Ausführungszustand der Aktionen wird nicht berücksichtigt.

Rückgabe:
'true', wenn der Aktionsplan mindestens eine asynchrone Aktion enthält, sonst 'false'.
[Isom\Plan\ActionPlan.is: 605]
Isom.Base.Boolean Isom.Plan.ActionPlan.DeletePreservedSession ( )

Löscht eine persistierte Sitzung.

Vorbedingung:
Es existiert eine konservierte Sitzung (d.h. PreservedSessionExists() liefert 'true')
Rückgabe:
'true' wenn die konservierte Sitzung gelöscht werden konnte.
[Isom\Plan\ActionPlan.is: 842]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.DoTp2Ap ( )

Ermittelt zum aktuellen Therapieplan den zugehörigen Aktionsplan und setz diesen als aktuellen Aktionsplan.

Für Top-Level-Aufrufe sollte stattdessen die verschattete Funktion Isom.Global.Processes.DoTp2Ap() verwendet werden.

  Boolean main()
  {
      // ...
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
      Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );

      ap.DoTp2Ap();
      ap.ExecuteActionPlan();
      // ...
  }
Rückgabe:
'true', falls ein ausführbarer Aktionsplan erfolgreich ermittelt wurde, 'false' sonst.
Siehe auch:
Isom.Global.Processes.DoTp2Ap() für den Einsprungspunkt, der diese Funktion typischerweise verwendet.
[Isom\Plan\ActionPlan.is: 645]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.ExecuteActionPlan ( )

Startet die Ausführung des Aktionsplans.

Für Top-Level-Aufrufe sollte stattdessen die verschattete Funktion Isom.Global.Processes.ExecuteActionPlan() verwendet werden.

Rückgabe:
'true', falls alle Aktionen im Aktionsplan erfolgreich ausgeführt wurden, 'false' sonst.
Siehe auch:
Isom.Global.Processes.ExecuteActionPlan() für den Einsprungspunkt, der diese Funktion typischerweise verwendet.
[Isom\Plan\ActionPlan.is: 662]
objectbound Isom.Base.StringList Isom.Plan.ActionPlan.GetAllPropertyNames ( )

Liefert die Namen aller Eigenschaften des Aktionsplans.

Veraltet:
Wird seit Version 6.5.0.0 nur noch aus Kompatibilitätsgründen unterstützt. Der Abruf der Eigenschaftsnamen wird seitdem durch die Funktion Isom.Context.Ecu.GetPropertyNames() bereitgestellt.
  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );
  Isom.Base.StringList allPropNames = ap.GetAllPropertyNames();
  allPropNames.Reset();
  while( allPropNames.HasNext() )
  {
      Isom.Base.String propName = allPropNames.Next();
      Isom.Base.String propVal  = ap.GetProp(propName);
      // ...
  }
Rückgabe:
Liste aller Eigenschaftsnamen des Aktionsplans.
[Isom\Plan\ActionPlan.is: 1049]
Isom.Base.String Isom.Plan.ActionPlan.GetCurrentActionChannel ( )

Liefert den N-Kanal, über den die aufrufende Aktion durchgeführt wird.

  Isom.Base.String channel = Isom.Plan.ActionPlan.GetCurrentActionChannel();
Rückgabe:
N-Kanal, über den die aufrufende Aktion durchgeführt wird Statische Funktion.
[Isom\Plan\ActionPlan.is: 879]
objectbound Isom.Base.Number Isom.Plan.ActionPlan.GetEstimatedRuntime ( )

Ermittelt die prognostizierte Gesamtausführungszeit.

Rückgabe:
Die prognostizierte Gesamtausführungszeit in Sekunden.
[Isom\Plan\ActionPlan.is: 477]
Isom.Plan.ActionPlan Isom.Plan.ActionPlan.GetInstance ( Isom.Plan.TherapyPlan tPlan )

Ermittelt den für diese ISOM-Sitzung gültigen Aktionsplan.

  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );
Rückgabe:
Der für diese ISOM-Sitzung singuläre Aktionsplan.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Funktion in einer Phase des Phasenmodells aufgerufen wird, in der noch kein Aktionsplan existiert.
[Isom\Plan\ActionPlan.is: 409]
objectbound Isom.Plan.ActionPlanPhase Isom.Plan.ActionPlan.GetPhase ( Isom.Base.String phaseIdent )

Ermittelt für den angegebenen Phasenbezeichner die zugehörige Aktionsplanphase.

  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );
  Isom.Plan.ActionPlanPhase ap1 = ap.GetPhase( "1" );
Rückgabe:
Aktionsplanphase oder Void-Objekt, falls es für diesen Phasenbezeichner keine Aktionsplanphase gibt.
[Isom\Plan\ActionPlan.is: 460]
objectbound Isom.Base.StringList Isom.Plan.ActionPlan.GetPhases ( )

Ermittelt Liste von Phasenbezeichnern.

Mit Hilfe dieser Phasenbezeichner kann über die Funktion 'GetPhase' auf die entsprechende Phase zugegriffen werden. Der Bezeichner ist der Index der Phase und damit eine Ganzzahl von 1 bis einschließlich Phases.Count (Anzahl der vorhandenen Phasen)

Zu beachten:
Phasen, die ausschließlich Aktionen im Zustand 'Rescheduled' beinhalten, werden im Normalfall ausgeblendet. Dies kann Autoren-seitig durch folgenden Konfigurationscode vermieden werden: Isom.Context.ContextConfiguration.SetProp("ActionPlan.Iterators.SuppressRescheduledActions","false")
  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );
  Isom.Base.StringList phaseIDs = ap.GetPhases();
Rückgabe:
Liste von Phasenbezeichnern.
[Isom\Plan\ActionPlan.is: 444]
Isom.Base.String Isom.Plan.ActionPlan.GetPreservedSessionVersion ( )

Gibt die Versionskennung einer existierenden konservierten Sitzung zurück.

Vorbedingung:
Es existiert eine konservierte Sitzung (d.h. PreservedSessionExists() liefert 'true')
Rückgabe:
Die Versionskennung der konservierten Sitzung, bzw. das Void-Objekt, falls keine konservierte Sitzung existiert.
[Isom\Plan\ActionPlan.is: 831]
objectbound Isom.Base.Number Isom.Plan.ActionPlan.GetProcessedRuntime ( )

Ermittelt die Gesamtausführungszeit des Aktionsplans.

Rückgabe:
Die tatsächliche Gesamtausführungszeit in Sekunden.
[Isom\Plan\ActionPlan.is: 486]
objectbound Isom.Base.String Isom.Plan.ActionPlan.GetProp ( Isom.Base.String propName )

Ermittelt den Wert der vorgegebenen Eigenschaft (property) des Aktionsplans.

Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );
  Isom.Base.String val = ap.GetProp( "SomeOemSpecificName" );
Rückgabe:
Wert der Eigenschaft.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Wert ungesetzt oder gleich "" ist.
[Isom\Plan\ActionPlan.is: 1070]
objectbound Isom.Base.StringList Isom.Plan.ActionPlan.GetPropNames ( )

Liefert die Namen aller technischen Eigenschaften für den AktionsPlan.

Es werden die Eigenschaftsnamen für die technischen Eigenschaften (siehe Isom.Plan.ActionPlan.GetProp()) zurückgeliefert. Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance(tp);
   Isom.Base.StringList propertyNames = ap.GetPropNames();
   propertyNames.Reset();
   while(propertyNames.HasNext())
   {
     //Abfrage des Werts für den gelieferten Eigenschaftsnamen und z. B. Aufzeichnung ins Protokoll
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller technischen Eigenschaften für den AktionsPlan.
Siehe auch:
Isom.Plan.ActionPlan.GetProp()
Datum:
letzte Änderung am 09.09.2010
[Isom\Plan\ActionPlan.is: 1128]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.IsActionPlanRestarting ( )

Prüft, ob der Aktionsplan neu gestartet (vs.

vollständig abgearbeitet) wurde.

Zu beachten:
Die Funktion ist primär für die Autorengesteuerte Maßnahmensteigerungsbehandlung sinnvoll.
Die Funktion sollte primär für die Schleife um ActionPlan.ExecuteActionPlan() in Global.Processes.ExecuteActionPlan() eingesetzt werden (s. Zusammenhängendes Beispiel für die Autorengesteuerte Maßnahmensteigerung).
  Boolean ExecuteActionPlan ()
  {
      // ...
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
      Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );

      while ( true ) // Autoren-gesteuerte äußere Maßnahmensteigerung
      {
          ap.ExecuteActionPlan ();

          if( ap.IsActionPlanRestarting().Failed() )
          {
              break;
          }

      } // while ( true ) // Autoren-gesteuerte äußere Maßnahmensteigerung

      // ...
 }
Rückgabe:
'true' g.d.w. Aktionsplan neu startbar ist, d.h. ActionPlan.ExecuteActionPlan() neu aufrufbar ist; 'false' sonst.
Siehe auch:
Zusammenhängendes Beispiel für die Autorengesteuerte Maßnahmensteigerung für ein zusammenhängendes Beispiel.
Isom.Plan.ActionPlan.RestartActionPlan() für die Funktion zum Auslösen eines Neustarts.
[Isom\Plan\ActionPlan.is: 764]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Plan\ActionPlan.is: 1149]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.Pause ( )

Die Funktion Pause hält die Ausführung des Aktionsplans zum nächst möglichen Zeitpunkt an.

Bereits laufende Aktionen werden zu Ende ausgeführt, aber es wird nicht mit der Ausführung weiterer Aktionen begonnen. Die Funktion kehrt erst zurück, wenn die Ausführung angehalten wurde oder der Versuch, die Ausführung anzuhalten, fehlgeschlagen ist.

Rückgabe:
'true' wenn die Aktionsplanausführung erfolgreich angehalten wurde und mit Resume() fortgesetzt werden kann.
'false' wenn die Aktionsplanausführung bereits angehalten war.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Aktionsplanausführung nicht angehalten werden konnte, da die Funktionalität nicht zur Verfügung steht oder weil ein Fachdienstaufruf gescheitert ist. Dies ist auch der Fall, wenn der verwendete Fachdienst das Funktionsmerkmal nicht unterstützt.
Siehe auch:
Isom.Plan.ActionPlan.Resume() zum Fortsetzen einer unterbrochenen Sitzung.
[Isom\Plan\ActionPlan.is: 951]
Isom.Base.Boolean Isom.Plan.ActionPlan.PreservedSessionExists ( )

Überprüft, ob eine konservierte Sitzung gefunden werden kann.

Rückgabe:
'true' wenn eine Sitzung gefunden wurde, 'false' sonst
[Isom\Plan\ActionPlan.is: 807]
Isom.Base.Boolean Isom.Plan.ActionPlan.PreserveSession ( )

Löst die Konservierung der aktuellen ISOM-Sitzung aus.

Dadurch wechselt ISOM in den Processing-State "Pause", in dem die ISOM-Sitzung beendet oder aus dem heraus die Sitzung fortgesetzt werden kann. Begonnene Aktionen werden noch zu Ende geführt.

  Boolean DoShowReassemblyMsgs (Isom.Plan.TherapyPlanAction action)
  {
      // ...
      if (persist)    // "Konservieren" wurde gewählt
      {
           Isom.Plan.ActionPlan.PreserveSession();
      }
  }
Rückgabe:
immer 'true'
[Isom\Plan\ActionPlan.is: 797]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.RestartActionPlan ( )

Initiiert die Neuausführung des Aktionsplans.

Achtung:
Die Funktion setzt im Wesentlichen nur ein Flag, welches die kontrollierte Beendigung von ExecuteActionPlan() zum nächstmöglichen Zeitpunkt veranlasst/signalisiert und kehrt dann sofort zurück. Auf diese Weise kann z.B. Maßnahmensteigerung durch wiederholte Ausführung des Aktionsplans umgesetzt werden. Die eigenliche Maßnahmensteigerung ist nach Beendigung von ActionPlan.ExecuteActionPlan() in Processes.ExecuteActionPlan() vorzusehen (s. Zusammenhängendes Beispiel für die Autorengesteuerte Maßnahmensteigerung).
Vor- und Nachbereiter für den Aktionsplan (PreparePlan(), FinishPlan()) werden auch im Restart-Fall-ausgeführt.
Zu beachten:
Die Funktion ist primär für die Autorengesteuerte Maßnahmensteigerungsbehandlung sinnvoll.
Im Sinne einer für den Autoren möglichst transparenten Maßnahmensteigerungsbehandlung führt RestartActionPlan() folgende Schritte selbständig aus:
  1. Deaktivieren des Therapieplan-orientierten Abbruchmodells für die aktuell ausgeführte Aktion (entspricht Autorenaufruf TherapyPlanAction.SetContinueOnError(true) und kann demzufolge mittels TherapyPlanAction.SetContinueOnError(false) nach RestartActionPlan() rückgängig gemacht werden).
  2. Deaktivieren des Steuergeräte-orientierten Abbruchmodells für die aktuell ausgeführte Aktion (entspricht Autorenaufruf TherapyPlanAction.SetContinueWithEcuOnError(true) und kann demzufolge mittels TherapyPlanAction.SetContinueWithEcuOnError(false) nach RestartActionPlan() rückgängig gemacht werden).
  3. Aktualisieren des Aktionsplans (entspricht Autorenaufruf ActionPlan.DoTp2Ap())
  Boolean DoFlash( Isom.Plan.TherapyPlanAction action )
  {
      // if ( ....Failed() )
      {
          Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
          Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );

          // Neustart der Aktionsplanausführung veranlassen
          if( ap.RestartActionPlan().Failed() )
          {
              Log.Error ("", "Neustart des Aktionsplans fehlgeschlagen.");
          }
      }
  }
Rückgabe:
'true' im Erfolgsfall, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls sich ISOM nicht im Aktionsplan-Ausführungszustand befindet.
Siehe auch:
Zusammenhängendes Beispiel für die Autorengesteuerte Maßnahmensteigerung für ein zusammenhängendes Beispiel.
Isom.Plan.ActionPlan.IsActionPlanRestarting() für die Funktion zur Prüfung, ob ein Neustart stattgefunden hat.
[Isom\Plan\ActionPlan.is: 722]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.Resume ( )

Die Funktion Resume setzt die Aktionsplanausführung fort, nachdem sie durch Pause() angehalten wurde.

Rückgabe:
'true' wenn die Aktionsplanausführung erfolgreich fortgesetzt werden konnte.
'false' wenn die Aktionsplanausführung nicht fortgesetzt werden konnte, weil sie zuvor nicht erfolgreich angehalten wurde.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Aktionsplanausführung nicht wieder aufgenommen werden konnte, da die Funktionalität nicht zur Verfügung steht oder weil ein Fachdienstaufruf gescheitert ist. Dies ist auch der Fall, wenn der verwendete Fachdienst das Funktionsmerkmal nicht unterstützt.
Siehe auch:
Isom.Plan.ActionPlan.Pause() zum Unterbrechen einer Sitzung mit Möglichkeit zum Fortsetzen.
[Isom\Plan\ActionPlan.is: 971]
Isom.Base.Boolean Isom.Plan.ActionPlan.ResumePreservedSession ( )

Setzt eine evtl.

existierende konservierte Sitzung fort.

Für Top-Level-Aufrufe sollte stattdessen die verschattete Funktion Isom.Global.Processes.CheckForPreservedSession() verwendet werden.

Rückgabe:
'true' wenn eine Sitzung wiederaufgeweckt wurde, 'false' sonst
[Isom\Plan\ActionPlan.is: 819]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.SetExecutionOrderGroup ( Isom.Base.String actionplangroupRegex )

Legt die Ausführungsreihenfolge aller asynchronen Aktionen innerhalb einer Ausführungsgruppe fest.

  Boolean SetExecutionOrder()
  {
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
      Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );

      ap.SetExecutionOrders     ( "IsomPreFlash"   ); // von ISOM ausgef.
      ap.SetExecutionOrderGroup ( "TAL_Reassembly" ); // extern ausgeführt
      ap.SetExecutionOrders     ( "IsomPstFlash"   ); // von ISOM ausgef.
      // ...
      return true; // success
  }
Parameter:
actionplangroupRegex (Isom.Base.String)
Regulärer Ausdruck, der auf eine oder mehrere Ausführungsgruppen passt.
Rückgabe:
Isom.Base.Boolean
true, falls Fachfunktionsaufruf erfolgreich
false sonst.
Zu beachten:
Die Ausführungsgruppen werden über die Annotation [ActionPlanGroup] festgelegt.
Diese Funktion darf ausschließlich innerhalb der Rückruffunktion SetExecutionOrder verwendet werden.
Diese Funktion hat nur Relevanz, wenn die Planausführung über ein ISOM-externes Ausführungssystem partiell oder ganz gesteuert wird.
Die Reihenfolge der Aufrufe dieser Funktion und der Funktion SetExecutionOrders bestimmt die erzwungene Ausführungsreihenfolge.
Wird für eine Aktion keine Aktionsreihenfolge explizit festgelegt, bleibt die Einfügereihenfolge im Therapieplan bzw. die von der Logistik vorgegebene Reihenfolge erhalten.
Siehe auch:
Isom.Plan.ActionPlan.SetExecutionOrders
Annotation [ActionPlanGroup]
[Isom\Plan\ActionPlan.is: 590]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.SetExecutionOrders ( Isom.Base.String actionname )

Legt die Ausführungsreihenfolge der Aktionen fest.

Die Reihenfolge der Aufrufe dieser Funktion und der Funktion SetExecutionOrdersAsyncBlock() bestimmt die erzwungene Ausführungsreihenfolge.

Als 'actionname' werden sowohl virtuelle Aktionen (z.B. 'RetofitCCC') als auch konkrete Aktionen (z.B. 'Code') zugelassen. Neben vollständigen Aktionsnamen werden auch reguläre Ausdrücke in C#-Syntax als 'actionname' akzeptiert (z.B. 'Init.*').

Wird für eine Aktion keine Aktionsreihenfolge explizit festgelegt, bleibt die Einfügereihenfolge im Therapieplan bzw. die von der Logistik vorgegebene Reihenfolge erhalten.

Diese Funktion sollte ausschließlich innerhalb der ISOM/L-Funktion SetExecutionOrder() verwendet werden.

  Boolean SetExecutionOrder()
  {
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
      Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );

      ap.SetExecutionOrders( "Flash"  );
      ap.SetExecutionOrders( "Code"   );
      ap.SetExecutionOrders( "Init.*" );
      // Alle Flash Aktionen werden vor allen Code Aktionen ausgeführt
      // Alle Aktionen, die mit "Init" beginnen werden danach ausgeführt.
      // ...
      return true; // success
  }
Rückgabe:
'true' wenn die Ausführungsreihenfolge erfolgreich festgelegt werden konnte, 'false' sonst.
[Isom\Plan\ActionPlan.is: 540]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.SetOrderList | ( | Isom.Base.StringList | actions,
 |  | Isom.Base.StringList | ecus,
 |  | Isom.Base.StringList | orderNos
 | ) |  |

Die Funktion SetOrderList setzt die anzuzeigenden Bestellinformationen.

Die Übergabeparameter sind drei Einzellisten, die jeweils Zeichenketten für

  • Aktion
  • Steuergerät
  • Bestellnummer bzw. einen Ersatz für selbige enthalten.

Rückgabe:
'true'
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben bei Aufruf mit einem Void-Objekt oder wenn die Listen unterschiedlich viele Elemente besitzen.
[Isom\Plan\ActionPlan.is: 996]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.SetProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt den Wert der vorgegebenen Eigenschaft (property) des Aktionsplans.

Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.ActionPlan  ap = Isom.Plan.ActionPlan.GetInstance( tp );
  Isom.Base.String propName = "SomeOemSpecificName";
  if( ap.GetProp(propName).IsVoid() )
  {
      ap.SetProp( propName, "true" );
  }
Rückgabe:
liefert immer 'true'
[Isom\Plan\ActionPlan.is: 1093]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlan.ShowAsMessageBox ( )

Zeigt eine Repräsentation des Aktionsplanes als Popup-Messagebox.

Rückgabe:
immer 'true'
[Isom\Plan\ActionPlan.is: 861]
Isom.Base.Boolean Isom.Plan.ActionPlan.SignalUserInteractionsDone ( )

Die Funktion SignalUserInteractionsDone gibt für die Aktion, aus der SignalUserInteractionsDone aufgerufen wird, an, dass in der weiteren Ausführung keine Benutzerinteraktionen mehr angezeigt werden und aktualisiert die Zeitprognose bis zur nächsten Benutzerinteraktion dementsprechend.

Rückgabe:
'true'
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben bei Aufruf mit einem Void-Objekt oder wenn die Funktion nicht aus einer ausgeführten Aktion heraus aufgerufen wird.
[Isom\Plan\ActionPlan.is: 1012]
Isom.Plan.ActionPlan Isom.Plan.ActionPlan.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Plan\ActionPlan.is: 1170]


für Serviceautoren

Isom.Plan.ActionPlanPhase

Namensraum Isom.Plan.ActionPlanPhase

Aktionsplanphasen Mehr...

Funktionen
Liste der Fachfunktionen

Funktionen zum Erhalten der Kanäle, Aktionliste und Aktionsplangruppe.

Isom.Plan.TherapyPlanActionList | GetActionList(Isom.Base.String channel)

Liefert eine Liste von Therapieplanaktionen, die für den übergebenen Kanal in dieser Aktionsplanphase existieren.

Isom.Base.String | GetActionPlanGroup()

Liefert die Ausführungsgrupe, zu der alle Aktionen der Aktionsplanphase gehören.

Isom.Base.StringList | GetChannels()

Liefert die Liste der N-Kanäle, die in dieser Phase verwendet werden.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Plan.ActionPlanPhase | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Plan.ActionPlanPhase | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Aktionsplanphasen bilden die erste Gliederungsebene des Aktionsplans. Aktionsplanphasen werden stets nacheinander ausgeführt, sie enthalten Aktionsplanpfade.

Quelldateien:

  • Isom\Plan\ActionPlanPhase.is

Dokumentation der Funktionen

objectbound Isom.Plan.ActionPlanPhase Isom.Plan.ActionPlanPhase.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Plan\ActionPlanPhase.is: 147]
objectbound Isom.Plan.TherapyPlanActionList Isom.Plan.ActionPlanPhase.GetActionList ( Isom.Base.String channel )

Liefert eine Liste von Therapieplanaktionen, die für den übergebenen Kanal in dieser Aktionsplanphase existieren.

Zu beachten:
Für wiedereingeplante Aktionen (insbes. Zustand 'Rescheduled) werden eigenständige Objektinstanzen geliefert, die z.B. mit TherepyPlan.GetInstance().GetActions().Contains(...) nicht gefunden werden können.
Rückgabe:
Therapieplanaktionsliste oder Void-Objekt.
[Isom\Plan\ActionPlanPhase.is: 100]
objectbound Isom.Base.String Isom.Plan.ActionPlanPhase.GetActionPlanGroup ( )

Liefert die Ausführungsgrupe, zu der alle Aktionen der Aktionsplanphase gehören.

Rückgabe:
Isom.Base.StringList
Ausführungsgrupe
Ausnahmebehandlung:
Es wird Isom.Base.String.Void zurückgegeben, falls die Ausführungsgrupe für mindestens eine Aktion nicht gesetzt ist.
Es wird Isom.Base.String.Void zurückgegeben, falls die Ausführungsgrupe nicht eindeutig ermittelbar ist.
Siehe auch:
Isom.Plan.ActionPlan.SetExecutionOrderGroup
Annotation ActionPlanGroup
[Isom\Plan\ActionPlanPhase.is: 117]
objectbound Isom.Base.StringList Isom.Plan.ActionPlanPhase.GetChannels ( )

Liefert die Liste der N-Kanäle, die in dieser Phase verwendet werden.

Zu beachten:
Kanäle, die ausschließlich Aktionen im Zustand 'Rescheduled' beinhalten, werden im Normalfall ausgeblendet. Dies kann Autoren-seitig durch folgenden Konfigurationscode vermieden werden: Isom.Context.ContextConfiguration.SetProp("SuppressRescheduledActions","false")
Rückgabe:
Isom.Base.StringList
Liste der N-Kanäle.
[Isom\Plan\ActionPlanPhase.is: 86]
objectbound Isom.Base.Boolean Isom.Plan.ActionPlanPhase.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
Isom.Base.Boolean
true, falls dies das Void-Objekt ist,
false sonst.
[Isom\Plan\ActionPlanPhase.is: 138]
Isom.Plan.ActionPlanPhase Isom.Plan.ActionPlanPhase.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Plan\ActionPlanPhase.is: 159]


für Serviceautoren

Isom.Plan.ActivationCode

Namensraum Isom.Plan.ActivationCode

Freischaltcodes (Software-Freischaltung, Airbag etc.) Mehr...

Funktionen
Funktionen zur Erzeugung eines Fachobjekts

Isom.Plan.ActivationCode | CreateFromData(Isom.Base.Data fsc)

Erzeugt ein neues Objekt für einen Freischaltcode zur Software-Freischaltung.

Isom.Plan.ActivationCode | CreateSwtActivationCode(Isom.Base.Number AN, Isom.Base.Number UI)

Erzeugt ein neues Objekt für einen Freischaltcode zur Software-Freischaltung.

Getters

Funktionen zum Erhalten von bestimmten Werten.

Isom.Base.Number | GetApplicationNumber()

Ermittelt die Applikationsnummer des Freischaltcodes.

Isom.Base.String | GetCertificate()

Ermittelt das Zertifikat des Freischaltcodes.

Isom.Base.String | GetCodeData()

Ermittelt den Freischaltcode.

Isom.Base.String | GetState()

Ermittelt den Status des Freischaltcodes.

Isom.Base.Number | GetUpgradeIndex()

Ermittelt den Aktualisierungs-Index des Freischaltcodes

Verfügbarkeit

Funktionen, die die Verfügbarkeit von Freischaltcodes betreffen

Isom.Base.Boolean | IsAvailable()

Prüft, ob der Freischaltcode im Transferverzeichnis verfügbar ist.

Isom.Base.Boolean | ReevaluateDataAvailability()

Bewertet die Datenverfügbarkeit aller mit der Aktion assoziierten Dateneinheiten neu.

Setters

Funktionen zum Setzen bestimmter Werte.

Isom.Base.Boolean | SetApplicationNumber(Isom.Base.Number an)

Setzt die Applikationsnummer des Freischaltcodes.

Isom.Base.Boolean | SetCertificate(Isom.Base.String certificate)

Setzt das Zertifikat des Freischaltcodes.

Isom.Base.Boolean | SetCodeData(Isom.Base.String data)

Setzt den Freischaltcode.

Isom.Base.Boolean | SetUpgradeIndex(Isom.Base.Number ui)

Setzt den Aktualisierungs-Index des Freischaltcodes

Eigenschaften

Typischerweise herstellerabhängige Datenwerte, die den Freischaltcode charakterisieren.

Isom.Base.String | GetProp(Isom.Base.String propName)

Ermittelt den Wert der vorgegebenen Eigenschaft (Property) für den Freischaltcode.

Isom.Base.StringList | GetPropNames()

Liefert die Namen aller Eigenschaften des Freischaltcodes.

Isom.Base.Boolean | InvalidateProp(Isom.Base.String propName)

Löscht den Wert der vorgegebenen Eigenschaft (Property).

Isom.Base.Boolean | SetProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt den Wert der generischen Eigenschaft (Property) für den Freischaltcode.

Standardfunktionen

Funktionen, die von (fast) allen ISOM/L-Fachklassen unterstützt werden.

Isom.Plan.ActivationCode | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Plan.ActivationCode | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Freischaltcodes sind Datenobjekte mit Mandanten-spezifischem Inhalt, über die z.B. kostenpflichtige Zusatzfunktionen eines Fahrzeugs aktiviert werden können.

Quelldateien:

  • Isom\Plan\ActivationCode.is

Dokumentation der Funktionen

objectbound Isom.Plan.ActivationCode Isom.Plan.ActivationCode.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Plan\ActivationCode.is: 376]
Isom.Plan.ActivationCode Isom.Plan.ActivationCode.CreateFromData ( Isom.Base.Data fsc )

Erzeugt ein neues Objekt für einen Freischaltcode zur Software-Freischaltung.

Die Datenstruktur wird von den Mandanten-spezifischen Fachdienst-Stellvertreter in ein ActivationCode-Objekt umgewandelt.

Zu beachten:
Da die Datenstruktur Mandanten-spezifisch ist, verläuft die Erzeugung des ActivationCode-Objekts nur erfolgreich, wenn auch der korresponierende Mandant ausgewählt wurde.
 Isom.Base.Uri file = Isom.Base.Uri.DefineUri("file:///Pfad_zum_FSC");
 Isom.Base.Data xml = Isom.Base.Data.LoadXml(file);
 Isom.Plan.ActivationCode ac = Isom.Plan.ActivationCode.CreateFromData(xml);
Parameter:
fsc Datenstruktur eines Freischaltcodes
Rückgabe:
Das neu erzeugte ActivationCode-Objekt.
[Isom\Plan\ActivationCode.is: 129]
Isom.Plan.ActivationCode Isom.Plan.ActivationCode.CreateSwtActivationCode | ( | Isom.Base.Number | AN,
 |  | Isom.Base.Number | UI
 | ) |  |

Erzeugt ein neues Objekt für einen Freischaltcode zur Software-Freischaltung.

Parameter:
AN | Software-Freischaltungs-Applikationsnummer
UI | Software-Freischaltungs-Aktualisierungs-Index
Zu beachten:
Für AN und UN ist Hexadezimalschreibweise mit 0x... möglich.
Rückgabe:
Das neu erzeugte ActivationCode-Objekt.
[Isom\Plan\ActivationCode.is: 103]
objectbound Isom.Base.Number Isom.Plan.ActivationCode.GetApplicationNumber ( )

Ermittelt die Applikationsnummer des Freischaltcodes.

Rückgabe:
Die Applikationsnummer
[Isom\Plan\ActivationCode.is: 151]
objectbound Isom.Base.String Isom.Plan.ActivationCode.GetCertificate ( )

Ermittelt das Zertifikat des Freischaltcodes.

Jedes Byte des Zertifikats wird als zweistellige Hexadezimal-Zahl angegeben.

Rückgabe:
Das Zertifikat.
[Isom\Plan\ActivationCode.is: 182]
objectbound Isom.Base.String Isom.Plan.ActivationCode.GetCodeData ( )

Ermittelt den Freischaltcode.

Jedes Byte des Codes wird als zweistellige Hexadezimal-Zahl angegeben.

Rückgabe:
Der Freischaltcode.
[Isom\Plan\ActivationCode.is: 171]
objectbound Isom.Base.String Isom.Plan.ActivationCode.GetProp ( Isom.Base.String propName )

Ermittelt den Wert der vorgegebenen Eigenschaft (Property) für den Freischaltcode.

Parameter:
propName Name der Eigenschaft
Rückgabe:
Isom.Base.String
Wert der Eigenschaft.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Wert ungesetzt oder gleich "" ist.
[Isom\Plan\ActivationCode.is: 306]
objectbound Isom.Base.StringList Isom.Plan.ActivationCode.GetPropNames ( )

Liefert die Namen aller Eigenschaften des Freischaltcodes.

Rückgabe:
Isom.Base.StringList
Liste der Namen aller technischen Eigenschaften des Steuergeräts.
[Isom\Plan\ActivationCode.is: 346]
objectbound Isom.Base.String Isom.Plan.ActivationCode.GetState ( )

Ermittelt den Status des Freischaltcodes.

Folgende Werte sind möglich:

  • Unknown
  • Available
  • Activated
  • NotAvailable
  • Rejected
  • Cancelled

Rückgabe:
Der Status des Freischaltcodes.
[Isom\Plan\ActivationCode.is: 198]
objectbound Isom.Base.Number Isom.Plan.ActivationCode.GetUpgradeIndex ( )

Ermittelt den Aktualisierungs-Index des Freischaltcodes

Rückgabe:
Der Aktualisierungs-Index
[Isom\Plan\ActivationCode.is: 160]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCode.InvalidateProp ( Isom.Base.String propName )

Löscht den Wert der vorgegebenen Eigenschaft (Property).

Parameter:
propName Name der Eigenschaft
Rückgabe:
Isom.Base.Boolean
Immer 'true'
[Isom\Plan\ActivationCode.is: 336]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCode.IsAvailable ( )

Prüft, ob der Freischaltcode im Transferverzeichnis verfügbar ist.

Rückgabe:
'true', falls Freischaltcode im Transferverzeichnis verfügbar, 'false' sonst.
[Isom\Plan\ActivationCode.is: 214]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCode.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Plan\ActivationCode.is: 367]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCode.ReevaluateDataAvailability ( )

Bewertet die Datenverfügbarkeit aller mit der Aktion assoziierten Dateneinheiten neu.

Rückgabe:
'true' wenn erfolgreich, 'false' sonst.
[Isom\Plan\ActivationCode.is: 224]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCode.SetApplicationNumber ( Isom.Base.Number an )

Setzt die Applikationsnummer des Freischaltcodes.

Parameter:
an Die Applikationsnummer
Rückgabe:
true bei Erfolg, sonst false
[Isom\Plan\ActivationCode.is: 244]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCode.SetCertificate ( Isom.Base.String certificate )

Setzt das Zertifikat des Freischaltcodes.

Jedes Byte des Zertifikats wird als zweistellige Hexadezimal-Zahl angegeben.

Parameter:
certificate Das Zertifikat.
Rückgabe:
true bei Erfolg, sonst false
[Isom\Plan\ActivationCode.is: 281]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCode.SetCodeData ( Isom.Base.String data )

Setzt den Freischaltcode.

Jedes Byte des Codes wird als zweistellige Hexadezimal-Zahl angegeben.

Parameter:
data Der Freischaltcode.
Rückgabe:
true bei Erfolg, sonst false
[Isom\Plan\ActivationCode.is: 268]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCode.SetProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt den Wert der generischen Eigenschaft (Property) für den Freischaltcode.

Parameter:
propName | Name der Eigenschaft
propValue | Neuer Wert der Eigenschaft
Rückgabe:
Isom.Base.Boolean
Immer 'true'
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Steuergeräteobjekt Teil der Ist-Sg-Liste ist und die Eigenschaft bereits nicht leer gesetzt ist.
[Isom\Plan\ActivationCode.is: 324]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCode.SetUpgradeIndex ( Isom.Base.Number ui )

Setzt den Aktualisierungs-Index des Freischaltcodes

Parameter:
ui Der Aktualisierungs-Index
Rückgabe:
true bei Erfolg, sonst false
[Isom\Plan\ActivationCode.is: 255]
Isom.Plan.ActivationCode Isom.Plan.ActivationCode.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ein ungültiges Objekt.
[Isom\Plan\ActivationCode.is: 387]


für Serviceautoren

Isom.Plan.ActivationCodeList

Namensraum Isom.Plan.ActivationCodeList

Listen von Freischaltcodes Mehr...

Funktionen
Isom.Plan.ActivationCodeList | CreateActivationCodeList()

Erzeugt ein neues, leeres Objekt für eine Liste von Freischaltcodes.

Listenfunktionen

Isom.Plan.ActivationCode | At(Isom.Base.Number index)

Ruft den Freischaltcode innerhalb der Liste ab, welche durch den Index ausgewählt wurde.

Isom.Base.Boolean | Contains(Isom.Plan.ActivationCode element)

Abfrage, ob ein Element in der Liste vorhanden ist.

Isom.Plan.ActivationCode | Current()

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Isom.Base.Boolean | HasNext()

Liefert einen Wahrheitswert, der angibt, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Isom.Base.Number | Insert(Isom.Plan.ActivationCode element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Liefert einen Wahrheitswert, der angibt, ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Plan.ActivationCode | Next()

Liefert den nächsten Freischaltcode in der Liste.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt das durch den Index gekennzeichnete Element aus der Liste.

Isom.Base.Boolean | Reset()

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Plan.ActivationCodeList | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Plan.ActivationCodeList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Plan.ActivationCodeList sind Listen von Freischaltcodes des Typs Isom.Plan.ActivationCode

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Plan\ActivationCodeList.is

Dokumentation der Funktionen

objectbound Isom.Plan.ActivationCode Isom.Plan.ActivationCodeList.At ( Isom.Base.Number index )

Ruft den Freischaltcode innerhalb der Liste ab, welche durch den Index ausgewählt wurde.

Parameter:
index Index.
Rückgabe:
Ausgewählter Freischaltcode.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 ist oder größer gleich der Anzahl der Listenelemente.
[Isom\Plan\ActivationCodeList.is: 180]
objectbound Isom.Plan.ActivationCodeList Isom.Plan.ActivationCodeList.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Plan\ActivationCodeList.is: 259]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCodeList.Contains ( Isom.Plan.ActivationCode element )

Abfrage, ob ein Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Plan\ActivationCodeList.is: 230]
Isom.Plan.ActivationCodeList Isom.Plan.ActivationCodeList.CreateActivationCodeList ( )

Erzeugt ein neues, leeres Objekt für eine Liste von Freischaltcodes.

Rückgabe:
Das neu erzeugte ActivationCodeList-Objekt.
[Isom\Plan\ActivationCodeList.is: 90]
objectbound Isom.Plan.ActivationCode Isom.Plan.ActivationCodeList.Current ( )

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Rückgabe:
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Iterator zurückgesetzt wurde.
[Isom\Plan\ActivationCodeList.is: 155]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCodeList.HasNext ( )

Liefert einen Wahrheitswert, der angibt, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Rückgabe:
'true', falls noch Werte in der Liste zur Verfügung stehen, 'false' sonst.
[Isom\Plan\ActivationCodeList.is: 130]
objectbound Isom.Base.Number Isom.Plan.ActivationCodeList.Insert ( Isom.Plan.ActivationCode element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Iterator, wird durch diese Operation zurückgesetzt.

Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügender Freischaltcode.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
[Isom\Plan\ActivationCodeList.is: 204]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCodeList.IsEmpty ( )

Liefert einen Wahrheitswert, der angibt, ob diese Liste leer ist oder nicht.

Rückgabe:
'true', falls die Liste leer ist, 'false' sonst.
[Isom\Plan\ActivationCodeList.is: 119]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCodeList.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Plan\ActivationCodeList.is: 250]
objectbound Isom.Base.Number Isom.Plan.ActivationCodeList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

Rückgabe:
Anzahl der Elemente.
[Isom\Plan\ActivationCodeList.is: 109]
objectbound Isom.Plan.ActivationCode Isom.Plan.ActivationCodeList.Next ( )

Liefert den nächsten Freischaltcode in der Liste.

Diese Funktion sollte zum Iterieren über die Liste verwendet werden.

Rückgabe:
Nächstes Element der Liste..
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Plan\ActivationCodeList.is: 143]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCodeList.Remove ( Isom.Base.Number index )

Entfernt das durch den Index gekennzeichnete Element aus der Liste.

Ein eventuell aktiver Iterator wird durch diese Operation zurückgesetzt.

Parameter:
index Index.
Rückgabe:
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt).
[Isom\Plan\ActivationCodeList.is: 219]
objectbound Isom.Base.Boolean Isom.Plan.ActivationCodeList.Reset ( )

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Rückgabe:
Immer 'true'.
[Isom\Plan\ActivationCodeList.is: 165]
Isom.Plan.ActivationCodeList Isom.Plan.ActivationCodeList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Plan\ActivationCodeList.is: 271]


für Serviceautoren

Isom.Plan.OrderingInfo

Namensraum Isom.Plan.OrderingInfo

Bestellinformationen Mehr...

Funktionen
Isom.Plan.OrderingInfo | CreateNew()

Erzeugt ein neues, leeres Objekt für eine Bestellalternative.

Getters

Lesezugriff

Isom.Base.String | GetHint()

Liefert eine Textreferenz, die den Typ des zu bestellenden Teils beschreibt, z.B.

Isom.Base.String | GetMedium()

Liefert den Typ des Liefermediums.

Isom.Base.String | GetMediumDescription()

Liefert die Beschreibung des konkreten Bestellmediums (z.B.

Isom.Base.String | GetOrderNumber()

Liefert die hersteller- und dienstspezifische Bestellnummer.

Setters

Schreibzugriff

Isom.Base.Boolean | SetHint(Isom.Base.String Hint)

Setzt eine Textreferenz, die den Typ des zu bestellenden Teils beschreibt, z.B.

Isom.Base.Boolean | SetMedium(Isom.Base.String Medium)

Setzt den Typ des Liefermediums.

Isom.Base.Boolean | SetMediumDescription(Isom.Base.String MediumDescription)

Setzt die Beschreibung des konkreten Bestellmediums (z.B. CD-/DVD-Version)

Isom.Base.Boolean | SetOrderNumber(Isom.Base.String OrderNumber)

Setzt die hersteller- und dienstspezifische Bestellnummer.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Plan.OrderingInfo | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Plan.OrderingInfo | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Plan.OrderingInfo enthält die Bestellinformationen

Quelldateien:

  • Isom\Plan\OrderingInfo.is

Dokumentation der Funktionen

objectbound Isom.Plan.OrderingInfo Isom.Plan.OrderingInfo.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Plan\OrderingInfo.is: 245]
Isom.Plan.OrderingInfo Isom.Plan.OrderingInfo.CreateNew ( )

Erzeugt ein neues, leeres Objekt für eine Bestellalternative.

Rückgabe:
Das neu erzeugte OrderingInfo-Objekt.
[Isom\Plan\OrderingInfo.is: 91]
objectbound Isom.Base.String Isom.Plan.OrderingInfo.GetHint ( )

Liefert eine Textreferenz, die den Typ des zu bestellenden Teils beschreibt, z.B.

"Steuergerät" oder "Freischaltcode":

Rückgabe:
Textreferenz
[Isom\Plan\OrderingInfo.is: 155]
objectbound Isom.Base.String Isom.Plan.OrderingInfo.GetMedium ( )

Liefert den Typ des Liefermediums.

Rückgabe:
Typ des Liefermediums

Folgende Liefermedientypen sind definiert:

  • "Unknown"
  • "CDROM"
  • "ASAP"
  • "ONLINE"
  • "TETIS_OR_ASAP",
  • "FAX"
  • "PHONE"
  • "EMAIL"
  • "Brief_OR_Urkunde"
  • "SMS"
  • "Web"

[Isom\Plan\OrderingInfo.is: 125]
objectbound Isom.Base.String Isom.Plan.OrderingInfo.GetMediumDescription ( )

Liefert die Beschreibung des konkreten Bestellmediums (z.B.

CD-/DVD-Version)

Rückgabe:
Beschreibung des konkreten Bestellmediums
[Isom\Plan\OrderingInfo.is: 135]
objectbound Isom.Base.String Isom.Plan.OrderingInfo.GetOrderNumber ( )

Liefert die hersteller- und dienstspezifische Bestellnummer.

Rückgabe:
hersteller- und dienstspezifische Bestellnummer
[Isom\Plan\OrderingInfo.is: 145]
objectbound Isom.Base.Boolean Isom.Plan.OrderingInfo.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Plan\OrderingInfo.is: 236]
objectbound Isom.Base.Boolean Isom.Plan.OrderingInfo.SetHint ( Isom.Base.String Hint )

Setzt eine Textreferenz, die den Typ des zu bestellenden Teils beschreibt, z.B.

"Steuergerät" oder "Freischaltcode":

Rückgabe:
immer 'true'
[Isom\Plan\OrderingInfo.is: 214]
objectbound Isom.Base.Boolean Isom.Plan.OrderingInfo.SetMedium ( Isom.Base.String Medium )

Setzt den Typ des Liefermediums.

Folgende Liefermedientypen sind definiert:

  • "Unknown"
  • "CDROM"
  • "ASAP"
  • "ONLINE"
  • "TETIS_OR_ASAP",
  • "FAX"
  • "PHONE"
  • "EMAIL"
  • "Brief_OR_Urkunde"
  • "SMS"
  • "Web"

Rückgabe:
Textreferenz
[Isom\Plan\OrderingInfo.is: 186]
objectbound Isom.Base.Boolean Isom.Plan.OrderingInfo.SetMediumDescription ( Isom.Base.String MediumDescription )

Setzt die Beschreibung des konkreten Bestellmediums (z.B. CD-/DVD-Version)

Rückgabe:
immer 'true'
[Isom\Plan\OrderingInfo.is: 195]
objectbound Isom.Base.Boolean Isom.Plan.OrderingInfo.SetOrderNumber ( Isom.Base.String OrderNumber )

Setzt die hersteller- und dienstspezifische Bestellnummer.

Rückgabe:
immer 'true'
[Isom\Plan\OrderingInfo.is: 204]
Isom.Plan.OrderingInfo Isom.Plan.OrderingInfo.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Plan\OrderingInfo.is: 257]


für Serviceautoren

Isom.Plan.OrderingInfoList

Namensraum Isom.Plan.OrderingInfoList

Listen von Bestellinformationen Mehr...

Funktionen
Isom.Plan.OrderingInfoList | CreateOrderingInfoList()

Erzeugt ein neues, leeres Objekt für eine Liste von Bestellalternativen.

Listenfunktionen

Isom.Plan.OrderingInfo | At(Isom.Base.Number index)

Ruft die Zeichenkette innerhalb der Liste ab, welche durch den Index ausgewählt wurde.

Isom.Base.Boolean | Contains(Isom.Plan.OrderingInfo element)

Abfrage, ob ein Element in der Liste vorhanden ist.

Isom.Plan.OrderingInfo | Current()

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Isom.Base.Boolean | HasNext()

Liefert einen Wahrheitswert, der angibt, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Isom.Base.Number | Insert(Isom.Plan.OrderingInfo element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Liefert einen Wahrheitswert, der angibt ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Plan.OrderingInfo | Next()

Liefert die nächste Zeichenkette in der Liste.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt das durch den Index gekennzeichnete Element aus der Liste.

Isom.Base.Boolean | Reset()

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Plan.OrderingInfoList | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Plan.OrderingInfoList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Plan.OrderingInfoList sind Listen von Bestellinformationen des Typs Isom.Plan.OrderingInfo

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Plan\OrderingInfoList.is

Dokumentation der Funktionen

objectbound Isom.Plan.OrderingInfo Isom.Plan.OrderingInfoList.At ( Isom.Base.Number index )

Ruft die Zeichenkette innerhalb der Liste ab, welche durch den Index ausgewählt wurde.

Parameter:
index Index.
Rückgabe:
Ausgewählte Zeichenkette.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 ist oder größer gleich der Anzahl der Listenelemente.
[Isom\Plan\OrderingInfoList.is: 179]
objectbound Isom.Plan.OrderingInfoList Isom.Plan.OrderingInfoList.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Plan\OrderingInfoList.is: 258]
objectbound Isom.Base.Boolean Isom.Plan.OrderingInfoList.Contains ( Isom.Plan.OrderingInfo element )

Abfrage, ob ein Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Plan\OrderingInfoList.is: 229]
Isom.Plan.OrderingInfoList Isom.Plan.OrderingInfoList.CreateOrderingInfoList ( )

Erzeugt ein neues, leeres Objekt für eine Liste von Bestellalternativen.

Rückgabe:
Das neu erzeugte OrderingInfoList-Objekt.
[Isom\Plan\OrderingInfoList.is: 90]
objectbound Isom.Plan.OrderingInfo Isom.Plan.OrderingInfoList.Current ( )

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Rückgabe:
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Iterator zurückgesetzt wurde.
[Isom\Plan\OrderingInfoList.is: 154]
objectbound Isom.Base.Boolean Isom.Plan.OrderingInfoList.HasNext ( )

Liefert einen Wahrheitswert, der angibt, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Rückgabe:
'true', falls noch Werte in der Liste zur Verfügung stehen, 'false' sonst.
[Isom\Plan\OrderingInfoList.is: 129]
objectbound Isom.Base.Number Isom.Plan.OrderingInfoList.Insert ( Isom.Plan.OrderingInfo element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Iterator, wird durch diese Operation zurückgesetzt.

Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügende Zeichenkette.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
[Isom\Plan\OrderingInfoList.is: 203]
objectbound Isom.Base.Boolean Isom.Plan.OrderingInfoList.IsEmpty ( )

Liefert einen Wahrheitswert, der angibt ob diese Liste leer ist oder nicht.

Rückgabe:
'true', falls die Liste leer ist, 'false' sonst.
[Isom\Plan\OrderingInfoList.is: 118]
objectbound Isom.Base.Boolean Isom.Plan.OrderingInfoList.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Plan\OrderingInfoList.is: 249]
objectbound Isom.Base.Number Isom.Plan.OrderingInfoList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

Rückgabe:
Anzahl der Elemente.
[Isom\Plan\OrderingInfoList.is: 108]
objectbound Isom.Plan.OrderingInfo Isom.Plan.OrderingInfoList.Next ( )

Liefert die nächste Zeichenkette in der Liste.

Diese Funktion sollte zum Iterieren über die Liste verwendet werden.

Rückgabe:
Nächstes Element der Liste..
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Plan\OrderingInfoList.is: 142]
objectbound Isom.Base.Boolean Isom.Plan.OrderingInfoList.Remove ( Isom.Base.Number index )

Entfernt das durch den Index gekennzeichnete Element aus der Liste.

Ein eventuell aktiver Iterator wird durch diese Operation zurückgesetzt.

Parameter:
index Index.
Rückgabe:
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt.
[Isom\Plan\OrderingInfoList.is: 218]
objectbound Isom.Base.Boolean Isom.Plan.OrderingInfoList.Reset ( )

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Rückgabe:
Immer 'true'.
[Isom\Plan\OrderingInfoList.is: 164]
Isom.Plan.OrderingInfoList Isom.Plan.OrderingInfoList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Plan\OrderingInfoList.is: 270]


für Serviceautoren

Isom.Plan.TherapyPlan

Namensraum Isom.Plan.TherapyPlan

Fachobjekt des Therapieplans Mehr...

Funktionen
Isom.Plan.TherapyPlan | GetInstance()

Ermittelt den singulären, für diese ISOM-Sitzung gültigen Therapieplan.

Erzeugen von Aktionen

Erzeugen von speziellen Aktionen.

Isom.Plan.TherapyPlanAction | CreateAction(Isom.Base.String actionName)

Erzeugt eine nicht Steuergeräte-bezogene Aktion.

Isom.Plan.TherapyPlanAction | CreateEcuAction(Isom.Base.String actionName, Isom.Context.Ecu ecu)

Erzeugt eine Steuergeräte-bezogene Aktion.

Isom.Plan.TherapyPlanAction | CreateEcuGroupAction(Isom.Base.String actionName, Isom.Base.String diagGroup)

Erzeugt eine Steuergeräte-bezogene Aktion.

Isom.Plan.TherapyPlanAction | CreateOrderingAction(Isom.Base.String actionName, Isom.Context.Ecu ecu, Isom.Plan.OrderingInfoList orderingAlternatives)

Erzeugt eine Steuergeräte-bezogene Aktion mit Bestellinformation.

Modifikationen des Therapieplans

Verschiedene Modifikationen, die auf den Therapieplan angewendet werden können.

Isom.Base.Boolean | Add(Isom.Plan.TherapyPlanAction action)

Fügt eine Aktion am Ende des Therapieplan ein.

Isom.Base.Boolean | Remove(Isom.Plan.TherapyPlanAction action)

Enfernt eine Aktion aus dem Therapieplan.

Isom.Base.Boolean | RestoreNativePlan()

Ersetzt den aktuellen Therapieplan durch den nativen Therapieplan.

Lesender Zugriff auf die Aktionsliste(n)

Gewährt lesenden Zugriff auf die Aktionsliste(n).

Isom.Base.Boolean | ContainsAction(Isom.Plan.TherapyPlanAction actionTemplate)

Prüft, ob eine bestimmte Aktion im Therapieplan enthalten ist.

Isom.Plan.TherapyPlanActionList | GetActions()

Ermittelt alle Aktionen des Therapieplans.

Isom.Plan.TherapyPlanActionList | GetEditableActions()

Ermittelt alle nicht Steuergeräte-bezogenen Aktionen, die vom Autor als [EditableAction(...)] markiert wurden.

Isom.Plan.TherapyPlanActionList | GetFilterChainActions()

Ermittelt die Filter-Folge der aktuellen Einfügeoperation vom First-Level-Element bis zum aktuell einzufügenden Element.

Neubewertung der Datenverfügbarkeit

Führt eine Neubewertung der Datenverfügbarkeit aus.

Isom.Base.Boolean | ReevaluateDataAvailability()

Neubewertung der Datenverfügbarkeit aller Aktionen.

Logistikkonsistenz und externe Ausführung

Prüfung der Logistikkonsistenz und externe Ausführung

Isom.Plan.TherapyPlanActionList | GetDeclinedActions()

Ermittelt Aktionen, die von der Logistik abgelehnt wurden.

Isom.Base.Boolean | IsLogisticsConsistent()

Prüft, ob alle benötigten Logistikdaten vorhanden sind.

Therapie-begleitende Nachrichten

Verwaltung der Nachrichten während einer Therapie

Isom.Base.Boolean | AddMessage(Isom.Base.String id, Isom.Base.String message)

Fügt eine Therapie-begleitende Nachricht hinzu.

Isom.Base.StringDictionary | GetAllMessages()

Ermittelt die Liste aller Therapie-begleitenden Nachrichten (z.B.

Isom.Base.Boolean | RemoveMessage(Isom.Base.String id)

Entfernt eine Therapie-begleitende Nachricht von der Anzeige im Abschlussbericht.

Überprüfen des Vorhandenseins der erforderlichen Steuergerätedaten

Überprüft, ob alle erforderlichen Steuergerätedaten vorhanden sind.

Isom.Base.Boolean | GetMissingFiles()

Überprüft, ob zu allen Aktionen des Therapieplans die erforderlichen Steuergerätedaten vorhanden sind.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Plan.TherapyPlan | Clone()

Erzeugt einen neuen Verweis auf das einzige Objekt des Therapieplans.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Plan.TherapyPlan | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Der Therapieplan beschreibt die Software-Reparatur eines Fahrzeugs. Er ist aus den Aktionen zusammengesetzt, die erforderlich sind, um das Fahrzeug aus dem Ist-Zustand in den Soll-Zustand zu überführen. Der Therapieplan gibt dabei keine fachliche Ausführungsreihenfolge vor. Die Ausführungsreihenfolge wird bei der Berechnung des Aktionsplans bestimmt.

Die einzige Instanz des Therapieplans enthält zu jedem Zeitpunkt den aktuell vorliegenden Therapieplan. Die Aktionen werden hinzugefügt durch

  • die Logistik
  • den Serviceautor
  • den Servicetechniker (Werkstatt-Personal)

Der Therapieplan entsteht in den Phasen 6 bis 8 des ISOM-Phasenmodell. In Phase 6 wird der native Therapieplan berechnet. Dazu wird der Einsprungspunkt GeneratePlan aufgerufen. In Phase 7 kann der Therapieplan manuell bearbeitet werden. Dabei werden die Einsprungspunkte AddActionManually und RemoveActionManually aufgerufen. In Phase 8 wird der finale Therapieplan berechnet. Dazu wird der Einsprungspunkt CalculateFinalPlan aufgerufen.

Filterfunktionen von Aktionen

Jedesmal wenn in den oben aufgeführten Einsprungspunkten eine Aktion zum Therapieplan hinzugefügt wird, wird die entsprechende Filterfunktion aufgerufen. Auch durch das Entfernen von Aktionen kann eine Filterung ausgelöst werden. Immer wenn eine Aktion entfernt wird, die nicht die letzte Aktion (in chronologischer Folge) ist, werden die Filterfunktionen der nachfolgenden Aktionen erneut ausgeführt.

Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 26.04.2010

Quelldateien:

  • Isom\Plan\TherapyPlan.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Plan.TherapyPlan.Add ( Isom.Plan.TherapyPlanAction action )

Fügt eine Aktion am Ende des Therapieplan ein.

Das erfolgreiche Hinzufügen bewirkt, dass der Therapieplan danach einen zusätzlichen Knoten mit der Aktion enthält. Bei erfolglosen Einfügeversuchen (return false) bleibt der Therapieplan unverändert.

Die für den Aktionsnamen definierte Filterfunktion wird angewendet. In dieser Filterfunktion kann wiederum TherapyPlan.Add(TherapyPlanAction) aufgerufen werden, d.h. es wird hierarchisch gefiltert.

ISOM erkennt beim hierarchischen Filtern Rekursionen (eine Filterfunktion fügt direkt oder indirekt über mehrere Filteraufruf- Stufen die als Argument übergebene Aktion ein). In diesem Fall wird diese Einfügeoperation ohne rekursiven Filteraufruf durchgeführt (Rekursionsabbruch). Das direkte Einfügen ist dabei ein Normalfall. Bei indirekten Rekursionen wird über die Ereignisaufzeichnung eine Warnung generiert aber normal weitergearbeitet.

Zu beachten:
Diese Funktion sollte ausschließlich in ISOM/L-Programmen - insbesondere Filterfunktionen - aufgerufen werden. Für Aktionen, die als manuell hinzugefügt gelten sollen, ist stattdessen der Einsprungspunkt AddActionManually zu verwenden.
  // Schreiben des Fahrzeugsauftrags hinzufügen
  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.TherapyPlanAction tpa = tp.CreateAction( "DeployVehicleOrder" );
  if(tp.Add( tpa ).Failed())
  {
      // Fehlerbehandlung: Aktion konnte nicht hinzugefügt werden
  }
Achtung:
Eine Aktion ist erst dann im Therapieplan enthalten, nachdem ihre Filterfunktion erfolgreich ausgeführt wurde.
Benachrichtigungen
Wenn die Aktion zum Plan hinzugefügt wurde, sendet ISOM eine Benachrichtigung an die steuernde Anwendung. Die Benachrichtigung kann z.B. eine Aktualisierung der Darstellungen des Steuergerätebaums und der Aktionsliste auslösen.
Parameter:
action die hinzuzufügende Aktion
Rückgabe:
Isom.Base.Boolean
true nach erfolgreichem Einfügen, false sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 427]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlan.AddMessage | ( | Isom.Base.String | id,
 |  | Isom.Base.String | message
 | ) |  |

Fügt eine Therapie-begleitende Nachricht hinzu.

Die Nachrichten können z.B. der Anzeige im Abschlussbericht dienen.

Achtung:
Der Aufruf kann _nicht_ durch TherapyPlan.GetInstance ().GetAllMessages().Add(...) ersetzt werden, weil hier zusätzlich eine Client-Interaktion notwendig ist und GetAllMessages() jedesmal ein neu erzeugtes Objekt liefert.
Zu beachten:
Die Einordnung und Interpretation der IDs obliegt der steuernden Anwendung.
Siehe auch:
Isom.Plan.TherapyPlan.RemoveMessage()
Isom.Plan.TherapyPlan.GetAllMessages()
  Isom.Base.Boolean AssembleDepositedMsgs (Isom.Base.String id)
  {
      Isom.Base.StringList msgs = Isom.Base.StringList.GetGlobal (id);
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance ();

      // Alle Hinweise hinzufügen
      Isom.Base.Number index = 1;
      msgs.Reset();
      while (msgs.HasNext())
      {
          // Aktionsnamen mit Zähler-Variablen initialisieren
          Isom.Base.String actionName = "Nacharbeiter";
          actionName.Append(index.ToIntString());

          // Nachricht hinzufügen
          Isom.Base.String msg = msgs.Next();
          tp.AddMessage(actionName, msg);

          // Index erhöhen
          index.Add(1);
      }
      // ...
  } // function: AssembleDepositedMsgs ()
Benachrichtigungen
Wenn Nachrichten zum Plan hinzugefügt wurden, sendet ISOM eine Benachrichtigung an die steuernde Anwendung.
Parameter:
id | technische ID für die Nachricht (nicht übersetzbar)
message | Text der Nachricht (übersetzbar)
Rückgabe:
Isom.Base.Boolean
false derzeit nie, true wenn erfolgreich hinzugefügt (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die ID oder die Nachricht Void oder die ID leer ist.
Es wird das Void-Objekt zurückgegeben, falls die ID bereits existiert.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 1021]
objectbound Isom.Plan.TherapyPlan Isom.Plan.TherapyPlan.Clone ( )

Erzeugt einen neuen Verweis auf das einzige Objekt des Therapieplans.

Achtung:
Da es vom Therapieplan nur eine Instanz gibt, erhält man hier nur einen zweiten Verweis auf das gleiche darunterliegende Objekt.
Rückgabe:
Isom.Plan.TherapyPlan
Das geklonte Objekt.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 1191]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlan.ContainsAction ( Isom.Plan.TherapyPlanAction actionTemplate )

Prüft, ob eine bestimmte Aktion im Therapieplan enthalten ist.

Es wird geprüft, ob mindestens ein Element im Therapieplan mit der angegebenen Aktion in allen gesetzten Eigenschaften übereinstimmt. D.h. es werden nur die Eigenschaften geprüft, die im Parameter actionTemplate auch gesetzt sind.

Es werden sowohl reale Aktionen als auch virtuelle Aktionen (vgl. TherapyPlan.GetActions()) berücksichtigt.

  // Prüft ob der Plan eine Programmierung für das Steuergerät an der Adresse 64 enthält
  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Context.EcuList list = Isom.Context.FutureVehicleContext.GetInstance().GetEcus();
  Isom.Context.Ecu ecu = list.FindByEcuAddress("64");
  Isom.Plan.TherapyPlanAction tpa = tp.CreateEcuAction( "Flash", ecu );
  if(tp.ContainsAction( tpa ))
  {
      // ...
  }
Parameter:
actionTemplate die zu suchende Aktion
Rückgabe:
Isom.Base.Boolean
Die erzeugte Aktion
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls actionTemplate.IsVoid() gilt.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 717]
objectbound Isom.Plan.TherapyPlanAction Isom.Plan.TherapyPlan.CreateAction ( Isom.Base.String actionName )

Erzeugt eine nicht Steuergeräte-bezogene Aktion.

Eine nicht Steuergeräte-bezogene Aktion wirkt entweder auf mehrere Steuergeräte oder auf kein Steuergerät oder auf das Gesamtfahrzeug.

Zu beachten:
Die Aktion wird nicht automatisch zum Therapieplan hinzugefügt, dafür ist TherapyPlan.Add(TherapyPlanAction) explizit aufzurufen.
  // Schreiben des Fahrzeugsauftrags hinzufügen
  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.TherapyPlanAction tpa = tp.CreateAction( "DeployVehicleOrder" );
  if(tp.Add( tpa ).Failed())
  {
      // Fehlerbehandlung
  }
Parameter:
actionName Aktionsname
Rückgabe:
Isom.Plan.TherapyPlanAction
Die erzeugte Aktion
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Aktionsname leer oder Void ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 208]
objectbound Isom.Plan.TherapyPlanAction Isom.Plan.TherapyPlan.CreateEcuAction | ( | Isom.Base.String | actionName,
 |  | Isom.Context.Ecu | ecu
 | ) |  |

Erzeugt eine Steuergeräte-bezogene Aktion.

Eine Steuergeräte-bezogene Aktion wirkt ausschließlich auf ein Steuergerät. Hier wird das Steuergerät über ein (partiell) befülltes Ecu-Fachobjekt vorgegeben.

Zu beachten:
Die Aktion wird nicht automatisch zum Therapieplan hinzugefügt, dafür ist TherapyPlan.Add(TherapyPlanAction) explizit aufzurufen.
  // Steuergerät mit Diagnoseadresse 16 ermitteln
  Isom.Context.FutureVehicleContext fvc = Isom.Context.FutureVehicleContext.GetInstance();
  Isom.Context.EcuList fvcEcus = fvc.GetEcus();
  Isom.Context.Ecu ecu = fvcEcus.FindByEcuAddress( "16" );

  if(ecu.IsVoid().Not())
  {
      // Programmierung hinzufügen
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
      Isom.Plan.TherapyPlanAction tpa = tp.CreateEcuAction( "Flash", ecu );
      if(tp.Add( tpa ).Failed())
      {
          // Fehlerbehandlung
      }
  }
Parameter:
actionName | Aktionsname
ecu | Das Steuergerät, auf das sich die Aktion bezieht.
Rückgabe:
Isom.Plan.TherapyPlanAction
Die erzeugte Aktion
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Aktionsname leer oder Void ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 256]
objectbound Isom.Plan.TherapyPlanAction Isom.Plan.TherapyPlan.CreateEcuGroupAction | ( | Isom.Base.String | actionName,
 |  | Isom.Base.String | diagGroup
 | ) |  |

Erzeugt eine Steuergeräte-bezogene Aktion.

Eine Steuergeräte-bezogene Aktion wirkt ausschließlich auf ein Steuergerät. Hier wird das Steuergerät über einen Diagnosegruppennamen vorgegeben.

Wenn ein passendes Ecu-Objekt bereits in der Steuergeräteliste des Ist-Zustands existiert, wird dieses verwendet. Ansonsten wird ein neues Ecu-Objekt erzeugt, das lediglich die gruppenbezogenen Informationen aus der ISOM-Fahrzeugbeschreibung enthält und nicht automatisch zum Ist-Zustand hinzugefügt wird.

Zu beachten:
Die Aktion wird nicht automatisch zum Therapieplan hinzugefügt, dafür ist TherapyPlan.Add(TherapyPlanAction) explizit aufzurufen.
  // Programmieren des Steuergeräts mit dem Diagnosegruppennamen D_KLIMA
  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.TherapyPlanAction tpa = tp.CreateEcuGroupAction( "Flash", "D_KLIMA" );
  if(tp.Add( tpa ).Failed())
  {
      // Fehlerbehandlung
  }
Parameter:
actionName | Aktionsname
diagGroup | Aktionsname
Rückgabe:
Isom.Plan.TherapyPlanAction
Die erzeugte Aktion
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Aktionsname leer oder Void ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 302]
objectbound Isom.Plan.TherapyPlanAction Isom.Plan.TherapyPlan.CreateOrderingAction | ( | Isom.Base.String | actionName,
 |  | Isom.Context.Ecu | ecu,
 |  | Isom.Plan.OrderingInfoList | orderingAlternatives
 | ) |  |

Erzeugt eine Steuergeräte-bezogene Aktion mit Bestellinformation.

Eine Steuergeräte-bezogene Aktion wirkt ausschließlich auf ein Steuergerät. Hier wird das Steuergerät wie in der Funktion CreateEcuAction() über ein (partiell) befülltes Ecu-Fachobjekt vorgegeben.

Die Aktion wird mit

Zu beachten:
Die Aktion wird nicht automatisch zum Therapieplan hinzugefügt, dafür ist TherapyPlan.Add(TherapyPlanAction) explizit aufzurufen.
  OrderingInfoList orderingInfoList = OrderingInfoList.CreateOrderingInfoList();
  // ... Liste mit Bestellinformation befüllen

  // Steuergerät mit Diagnoseadresse 16 ermitteln
  Isom.Context.FutureVehicleContext fvc = Isom.Context.FutureVehicleContext.GetInstance();
  Isom.Context.EcuList fvcEcus = fvc.GetEcus();
  Isom.Context.Ecu ecu = fvcEcus.FindByEcuAddress( "16" );

  if(ecu.IsVoid().Not())
  {
      // Tausch hinzufügen
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
      Isom.Plan.TherapyPlanAction tpa = tp.CreateOrderingAction( "Replace", ecu, orderingInfoList );
      if(tp.Add( tpa ).Failed())
      {
          // Fehlerbehandlung
      }
  }
Parameter:
actionName | Aktionsname
ecu | Das Steuergerät, auf das sich die zu bestellende Einheit bezieht.
orderingAlternatives | Bestellinformationen
Rückgabe:
Isom.Plan.TherapyPlanAction
Die erzeugte Aktion
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 355]
objectbound Isom.Plan.TherapyPlanActionList Isom.Plan.TherapyPlan.GetActions ( )

Ermittelt alle Aktionen des Therapieplans.

Die Liste enthält alle Aktionen (inkl. virtueller Aktionen) im Therapieplan. Virtuelle Aktionen sind nicht-Blatt-Knoten im Therapieplan, z.B. Aktionen, die an Filterfunktionen übergeben wurden.

Aktionen, die von anderen Aktionen verdeckt werden, sind hingegen nicht in der Liste enthalten.

Ebenso nicht zurückgegeben werden

  • Aktionen, die an anderer Stelle neu geplant (Rescheduled) wurden,
  • Aktionen, die explizit entfert (Purged) wurden sowie
  • Teilpläne, die nur permanent ausgeblendete (Purged) Aktionen enthalten.

Die Reihenfolge entspricht der Einfügereihenfolge in den Therapieplan.

Zu beachten:
Die zurückgegebene Liste umfasst neben Aktionen, welche schon endgültig im Therapieplan enthalten sind, auch die Aktionen, die im Rahmen der aktuell aktiven Filteraufruf-Hierarchie gerade eingefügt werden (z.B. die nativen Aktionen während des Aufrufs von FilterNativePlan()).
Siehe auch:
Isom.Plan.TherapyPlan.GetDeclinedActions() für abgelehnte Aktionen
  // Alle geplanten Aktionen protokollieren
  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.TherapyPlanActionList plannedActions = tp.GetActions();
  plannedActions.Reset();
  while( plannedActions.HasNext() )
  {
      Isom.Plan.TherapyPlanAction tpa = plannedActions.Next();
      if( tpa.IsVirtual().Not() )
      {
          System.Stdout( tpa.GetActionText() );
      }
  }
Rückgabe:
Isom.Plan.TherapyPlanActionList
Liste aller enthaltenen Aktionen (inkl. virtueller)
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 642]
objectbound Isom.Base.StringDictionary Isom.Plan.TherapyPlan.GetAllMessages ( )

Ermittelt die Liste aller Therapie-begleitenden Nachrichten (z.B.

zur Anzeige im Abschlussbericht).

Zu beachten:
Die Einordnung und Interpretation obliegt dem Client.
Siehe auch:
Isom.Plan.TherapyPlan.AddMessage()
Isom.Plan.TherapyPlan.RemoveMessage()
  Isom.Base.StringDictionary msgDict = Isom.Plan.TherapyPlan.GetInstance().GetAllMessages();
  Isom.Base.StringList keys = msgDict.GetKeys ();
  keys.Reset();
  while(keys.HasNext())
  {
      Isom.Base.String msg = "";
      Isom.Base.String key=keys.Next();
      msg.Append( key );
      msg.Append( ": " );
      msg.Append( msgDict.Get(key) );

      Isom.Sys.System.Stdout( msg );
  }
Rückgabe:
Isom.Base.StringDictionary
ID-Werte-Paare der hinzugefügten Nachrichten.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 1102]
objectbound Isom.Plan.TherapyPlanActionList Isom.Plan.TherapyPlan.GetDeclinedActions ( )

Ermittelt Aktionen, die von der Logistik abgelehnt wurden.

Es werden alle Aktionen zurückgegeben, die von der Logistik abgelehnt und somit nicht in den Therapieplan übernommen wurden.

Zu beachten:
Die Funktionalität wird nur von einigen externen Ausführungssystemen unterstützt. Auf anderen Systemen wird eine leere Liste oder Void zurückgegeben.
Siehe auch:
Isom.Plan.TherapyPlan.GetActions() für effektiv geplante Aktionen
  Boolean CalculateFinalPlan()
  {
      // Neuen Soll-Kontext mit manuellen Erweiterungen an die Logistik übergeben:
      Isom.Context.FutureVehicleContext futureContext = Isom.Context.FutureVehicleContext.GetInstance();
      if (futureContext.CalcFinalFutureContext().Failed())
      {
          return false;
      }

      // Therapieplan für den neuen Soll-Kontext von Einsprungspunkt erzeugen lassen:
      if (futureContext.GeneratePlan().Failed())
      {
          return false;
      }

      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance ();
      Isom.Plan.TherapyPlanActionList declined = tp.GetDeclinedActions();
      if(declined.IsEmpty().Not())
      {
          String message = "Abgelehnte Aktionen:";
          declined.Reset();
          while(declined.HasNext())
          {
              Isom.Plan.TherapyPlanAction act = declined.Next();
              message.Append(" ");
              message.Append(act.GetActionText());
          }

          // Warnung anzeigen und weitermachen (restliche Aktionen ausführen)
          Helpers.ShowOkMsg ("Warnung", message);
      }

      return true;
  }
Rückgabe:
Isom.Plan.TherapyPlanActionList
Abgelehnte Aktionen
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Therapieplan noch keinen Logistikplan enthält (d.h. wenn noch kein Logistikplan berechnet ist).
Es wird das Void-Objekt zurückgegeben, falls der Fachdienst keine Liste abgelehnter Aktionen geliefert hat.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 946]
objectbound Isom.Plan.TherapyPlanActionList Isom.Plan.TherapyPlan.GetEditableActions ( )

Ermittelt alle nicht Steuergeräte-bezogenen Aktionen, die vom Autor als [EditableAction(...)] markiert wurden.

Zu beachten:
Die Steuergeräte-bezogenen Aktionen lassen sich über Ecu.GetEditableActions() ermitteln.
Die Sichtbarkeit kann über TherapyPlanAction.IsVisibleAsEditableAction() ermittelt werden.
  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.TherapyPlanActionList editableActions = tp.GetEditableActions();
  editableActions.Reset();
  while( editableActions.HasNext() )
  {
      Isom.Plan.TherapyPlanAction tpa = editableActions.Next();
      System.Stdout( tpa.GetActionText() );
  }
Rückgabe:
Isom.Plan.TherapyPlanActionList
Liste aller nicht Steuergeräte-bezogenen hinzufügbaren Aktionen.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 677]
objectbound Isom.Plan.TherapyPlanActionList Isom.Plan.TherapyPlan.GetFilterChainActions ( )

Ermittelt die Filter-Folge der aktuellen Einfügeoperation vom First-Level-Element bis zum aktuell einzufügenden Element.

Die Filter-Folge entspricht der Folge von der "oberen" virtuellen Aktionen entlang des aktuell bearbeiteten Teilbaums gemäß der Einfügereihenfolge in den Therapieplan.

Das Wurzel-Element des Therapieplan namens "TherapyPlan" ist in der Filter-Folge nicht enthalten.

Zu beachten:
Die Funktion ist nur innerhalb einer Aufrufhierarchie von FilterFunktionen sinnvoll.
Siehe auch:
Isom.Plan.TherapyPlan.GetActions()
  Boolean Filter...( Isom.Plan.TherapyPlanAction action )
  {
      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();

      Isom.Plan.TherapyPlanActionList fcas = tp.GetFilterChainActions();
      Isom.Plan.TherapyPlanAction pattern = tp.CreateAction( "RetrofitCCC" );

      // prüfen, ob diese Aktion als Teil der Umrüstung "RetrofitCCC" eingefügt wird
      if( fcas.Contains( pattern ) )
      {
          // ...
      }
  }
Rückgabe:
Isom.Plan.TherapyPlanActionList
Filterkette
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls im Ausführungsfaden keine Filterhierarchie ermittelbar ist.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 767]
Isom.Plan.TherapyPlan Isom.Plan.TherapyPlan.GetInstance ( )

Ermittelt den singulären, für diese ISOM-Sitzung gültigen Therapieplan.

  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
Rückgabe:
Isom.Plan.TherapyPlan
Der für diese ISOM-Sitzung singuläre Therapieplan.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 26.04.2010
[Isom\Plan\TherapyPlan.is: 163]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlan.GetMissingFiles ( )

Überprüft, ob zu allen Aktionen des Therapieplans die erforderlichen Steuergerätedaten vorhanden sind.

Verwendungsbeispiel:
 using Isom.Plan.*;
 ...
       TherapyPlan tp = TherapyPlan.GetInstance();
       tp.GetMissingFiles();
       TherapyPlanActionList actions = tp.GetActions();
       actions.Reset();
       while (actions.HasNext())
       {
           TherapyPlanAction tpa = actions.Next();
           String missingSwu = tpa.GetProp("Swu:Missing");
           if (missingSwu.Equals("").Not())  // Zeichenkette ist nicht leer oder Void
           {
               //Fehler
           }
       }
 ...
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall, false sonst.
[Isom\Plan\TherapyPlan.is: 1142]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlan.IsLogisticsConsistent ( )

Prüft, ob alle benötigten Logistikdaten vorhanden sind.

Für alle Aktionen im Therapieplan wird geprüft

  • ob Logistikdaten benötigt werden
  • und wenn ja, ob die Logistikdaten bereits ermittelt wurden.

Zu beachten:
Der Aufruf ist logisch äquivalent zu TherapyPlan.GetInstance().At(0).IsLogisticsConsistent()
Siehe auch:
Isom.Plan.TherapyPlanAction.IsLogisticsConsistent()
  Boolean CalculateFinalPlan ()
  {
      // Neuen Soll-Kontext mit manuellen Erweiterungen an die Logistik übergeben:
      Isom.Context.FutureVehicleContext futureContext = Isom.Context.FutureVehicleContext.GetInstance();
      if (futureContext.CalcFinalFutureContext().Failed())
      {
          return false;
      }

      // Therapieplan für den neuen Soll-Kontext von Einsprungspunkt erzeugen lassen:
      if (futureContext.GeneratePlan().Failed())
      {
          return false;
      }

      Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance ();
      if( tp.IsLogisticsConsistent().Failed() )
      {
          // Fehler protokollieren und Ausführung abbrechen
          return false;
      }

      // ...

      return true;
  }
Rückgabe:
Isom.Base.Boolean
false für mind. eine Logistik-relevante Aktion liegen die benötigten Logistikdaten nicht vor, true für alle Logistik-relevanten Aktionen sind die Logistikdaten vorhanden oder es existieren keine logistikrelevanten Aktionen.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls während der Ermittlung der Logistikrelevanz technische Fehler auftreten.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 872]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlan.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
Isom.Base.Boolean
true, falls dies das Void-Objekt ist, false sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 1170]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlan.ReevaluateDataAvailability ( )

Neubewertung der Datenverfügbarkeit aller Aktionen.

Bewertet die Datenverfügbarkeit aller mit den Aktionen im Therapieplan assoziierten Dateneinheiten neu.

  Isom.Plan. TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  if( tp.ReevaluateDataAvailability().Failed() )
  {
      // Planausführung verhindern und mit Fehlermeldung abbrechen
  }
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall, false sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 803]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlan.Remove ( Isom.Plan.TherapyPlanAction action )

Enfernt eine Aktion aus dem Therapieplan.

Es werden alle unabhängigen Vorkommen der angegebenen Aktion entfernt, d.h. alle Vorkommen, die direkt in den Therapieplan eingefügt wurden. Ist die angegebene Aktion dagegen von einer weiteren Aktion (durch deren Filterfunktion) als Abhängigkeit hinzugefügt worden, dann wird sie nicht entfernt. Bei erfolglosen Entfernversuchen (return false) bleibt der Therapieplan unverändert.

Zu beachten:
Diese Funktion sollte ausschließlich in ISOM/L-Programmen verwendet werden, z.B. in Einsprungspunkten. Für Aktionen, die als manuell hinzugefügt wurden, ist stattdessen der Einsprungspunkt RemoveActionManually zu verwenden.
  // Schreiben des Fahrzeugsauftrags aus dem Plan entfernen
  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Plan.TherapyPlanAction tpa = tp.CreateAction( "DeployVehicleOrder" );
  if(tp.Remove( tpa ).Failed())
  {
      // Fehlerbehandlung: Aktion konnte nicht entfernt werden
  }
Achtung:
Eine Aktion ist erst dann im Therapieplan enthalten, nachdem ihre Filterfunktion erfolgreich ausgeführt wurde. Es ist daher nicht möglich, eine Aktion innerhalb der eigenen Filterfunktion mit Remove wieder zu entfernen. Stattdessen sollte die Filterfunktion in diesem Fall false zurückgeben.
Benachrichtigungen
Wenn die Aktion aus Plan entfernt wurde, sendet ISOM eine Benachrichtigung an die steuernde Anwendung. Die Benachrichtigung kann z.B. eine Aktualisierung der Darstellungen des Steuergerätebaums und der Aktionsliste auslösen.
Parameter:
action die zu entfernende Aktion
Rückgabe:
Isom.Base.Boolean
true nach erfolgreichem Entfernen, false sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 485]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlan.RemoveMessage ( Isom.Base.String id )

Entfernt eine Therapie-begleitende Nachricht von der Anzeige im Abschlussbericht.

Siehe auch:
Isom.Plan.TherapyPlan.AddMessage()
Isom.Plan.TherapyPlan.GetAllMessages()
  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  Isom.Base.StringDictionary msgDict = tp.GetAllMessages();
  Isom.Base.StringList keys = msgDict.GetKeys();
  keys.Reset();
  if(keys.HasNext())
  {
      // entfernt die erste Nachricht
      tp.RemoveMessage(keys.Next());
  }
Benachrichtigungen
Wenn Nachrichten vom Plan entfernt wurden, sendet ISOM eine Benachrichtigung an die steuernde Anwendung.
Parameter:
id technische ID für die Nachricht (nicht übersetzbar)
Rückgabe:
Isom.Base.Boolean
false derzeit nie, true wenn erfolgreich entfernt (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die ID Void ist.
Es wird das Void-Objekt zurückgegeben, falls die ID noch nicht existiert.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 1063]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlan.RestoreNativePlan ( )

Ersetzt den aktuellen Therapieplan durch den nativen Therapieplan.

Diese Funktion entfernt (ersatzlos) alles aus dem Therapieplan außer dem Knoten des nativen Therapieplans. Von den Aktionen des nativen Therapieplans werden alle "Purged"- Markierungen durch Zustandswechsel auf den Initialzustand 'Isom.Execution.ToDo' entfernt.

Bei erfolglosen Entfernversuchen (return 'Void') bleibt der Therapiebaum unverändert.

  // ContextTerme werden in Sichtbarkeitstermen von Aktionen verwendet
  [ContextTerm ("PlanNotPurged", "NOT Global:GLOBALKEY_PLANPURGED")]

  // Sofort ausführbare Aktion: "PurgePlan"
  [EditableAction ("PurgePlan", "PlanNotPurged AND Planned:*", true)]
  [ActionText ("PurgePlan", "Alle Aktionen entfernen")]

  // Sofort ausführbare Aktion: "RestoreNativePlan"
  [EditableAction ("RestoreNativePlan", "NOT PlanNotPurged", true)]
  [ActionText ("RestoreNativePlan", "Plan wiederherstellen")]

  namespace Vendor
  {
      // Implementierung der sofort ausführbaren Aktion "PurgePlan"
      // Alle Aktionen des Plans ausblenden (per "Purge")
      Isom.Base.Boolean RunPurgePlan (Isom.Plan.TherapyPlanAction action)
      {
          // Therapieplan holen
          Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance ();

          // Alle Aktionen ausblenden
          if (tp.GetActions().At(0).Purge().Failed())
          {
              return false;
          }

          // Flagge setzen: "RestoreNativePlan" wird erlaubt
          Isom.Base.Number.AddGlobal ("GLOBALKEY_PLANPURGED", 1);

          return true;
      }

      // Implementierung der sofort ausführbaren Aktion "RestoreNativePlan"
      // Nativen Plan wiederherstellen ("PurgePlan" aufheben)
      Isom.Base.Boolean RunRestoreNativePlan (Isom.Plan.TherapyPlanAction action)
      {
          // Therapieplan holen
          Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance ();

          Isom.Base.Boolean changed = tp.RestoreNativePlan();

          if( changed.IsVoid() )
          {
              return false;
          }

          // Flagge zurücksetzen: "PurgePlan" wird erlaubt
          Isom.Base.Number.RemoveGlobal ("GLOBALKEY_PLANPURGED");

          return true;
      }
  } // namespace Vendor
Benachrichtigungen
Wenn Aktionen aus Plan entfernt oder zum Plan hinzugefügt wurden, sendet ISOM Benachrichtigungen an die steuernde Anwendung. Auch wenn Aktionen ihren Zustand ändern, werden Benachrichtigungen gesendet. Die Benachrichtigungen können z.B. eine Aktualisierung der Darstellungen des Steuergerätebaums und der Aktionsliste auslösen.
Rückgabe:
Isom.Base.Boolean
true wenn mindestens ein Element geändert (entfernt oder Zustandswechsel), false sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls kein nativer Therapieplan existiert. Der Therapieplan dann bleibt unverändert.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 578]
Isom.Plan.TherapyPlan Isom.Plan.TherapyPlan.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Isom.Plan.TherapyPlan
Ungültiges Objekt.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 04.05.2010
[Isom\Plan\TherapyPlan.is: 1211]


für Serviceautoren

Isom.Plan.TherapyPlanAction

Namensraum Isom.Plan.TherapyPlanAction

Fachobjekt für eine Therapieplanaktion Mehr...

Funktionen
Getters / Setters

Zugriff auf native Merkmale der Aktion.

Isom.Base.String | GetActionText()

Liefert den vom Autor per [Editable[Ecu]Action(…, TextID, …)] vorgegebenen übersetzbaren Text.

Isom.Base.String | GetComment()

Ermittelt den autorendefinierten Kommentar zur Ausführung der Aktion.

Isom.Context.Ecu | GetEcu()

Liefert das assoziierte Steuergeräte-Fachobjekt oder Void.

Isom.Context.LogicalUnitList | GetLogicalUnits()

Liefert die Liste der logischen Einheiten, die von der Aktion betroffen sind.

Isom.Base.String | GetName()

Liefert den vom Autor definierten Namen der Aktion.

Isom.Base.Boolean | IsVirtual()

Ermittelt, ob die Aktion eine virtuelle Aktion, das heißt ein nicht-Blatt-Knoten im Therapiebaum, ist.

Isom.Base.Boolean | SetComment(Isom.Base.String comment)

Legt den autorendefinierten Kommentar zur Ausführung der Aktion fest.

Isom.Base.Boolean | SetEcu(Isom.Context.Ecu newEcu)

Ändert das betroffene Steuergerät unter Erhaltung der restlichen Aktionsinformationen.

Isom.Base.Boolean | SetLogicalUnits(Isom.Context.LogicalUnitList logicalUnits)

Setzt die Liste der logischen Einheiten, die von der Aktion betroffen sind.

Sichtbarkeitssteuerung

Ermittlung / Steuerung der Nutzbarkeit als Editierbare Aktion.

Isom.Base.Boolean | CanRunOnly()

Prüft, ob Aktion an einer beliebigen Stelle im Prozessablauf über Processes.RunAction() ausgeführt werden kann (beispielsweise Diagnose-Aktionen).

Isom.Base.Boolean | IsInsertable()

Ermittelt, ob die Aktion aus ISOM-Sicht zum Therapieplan hinzufügbar ist.

Isom.Base.Boolean | IsPlanned()

Prüft, ob die Editierbare Aktion als geplant markiert ist.

Isom.Base.Boolean | IsRemoveable()

Ermittelt, ob die Aktion aus ISOM-Sicht aus dem Therapieplan entfernbar ist.

Isom.Base.Boolean | SetCanRunOnly(Isom.Base.Boolean CanRunOnly)

Setzt fest, ob die Aktion bereits während der Planungsphase ausgeführt werden kann.

Isom.Base.Boolean | SetManuallyPlanned(Isom.Base.Boolean manuallyPlanned)

Legt fest, ob eine Aktion manuell angewiesen wurde.

Isom.Base.Boolean | SetRemoveable(Isom.Base.Boolean isRemoveable)

Markiert die Aktion als aus dem Therapieplan entfernbar.

Kanalmodell

Ermittlung / Steuerung der für die Aktion möglichen Therapiekanäle.

Isom.Base.StringList | GetPossibleLChannels()

Ermittelt die für die Aktionsausführung alternativ zueinander zulässigen L-Kanäle.

Isom.Base.Boolean | SetPossibleLChannels(Isom.Base.StringList list)

Setzt die für die Aktionsausführung alternativ zueinander zulässigen L-Kanäle.

Freischaltung und Bestellung

Freischalt- und Bestellinformationen für die Aktion.

Isom.Plan.ActivationCode | GetActivationCode()

Liefert den Freischaltcode, auf den sich die Aktion bezieht oder Void.

Isom.Plan.OrderingInfoList | GetOrderingInfoList()

Liefert Bestellinformationen für das Steuergerät.

Isom.Base.Boolean | SetActivationCode(Isom.Plan.ActivationCode ac)

Setzt den Freischaltcode, auf den sich die Aktion bezieht.

Isom.Base.Boolean | SetOrderingInfoList(Isom.Plan.OrderingInfoList infoList)

Setzt die Bestellinformationen für das Steuergerät.

Therapiezeitprognose und Ausführungszeiten

Setzen / Ermitteln der voraussichtlichen Ausführungszeit für die Aktion.

Isom.Base.Number | GetEstimatedRuntime()

Fragt die prognostizierte Laufzeit für die Aktion ab.

Isom.Base.Date | GetFinishTime()

Fragt den Zeitpunkt ab, zu dem die Aktion beendet wurde.

Isom.Base.Number | GetProcessedRuntime()

Liefert die tatsächliche Zeitdauer der Aktion.

Isom.Base.Date | GetStartTime()

Fragt den Zeitpunkt ab, zu dem die Aktion gestartet wurde.

Isom.Base.Boolean | SetEstimatedRuntime(Isom.Base.Number seconds)

Setzt die prognostizierte Laufzeit für die Aktion in Sekunden.

Zustandsmodell

Ermitteln / Setzen von Aktionszuständen.

Isom.Base.String | GetDisplayState()

Ruft den Anzeigezustand der Aktion ab.

Isom.Base.StringList | GetStates()

Liefert eine Liste von Zuständen, die den Ausführungszustand der Aktion beschreiben.

Isom.Base.Boolean | SetDisplayState(Isom.Base.String displayState)

Legt den Anzeigezustand der Aktion fest.

Isom.Base.Boolean | SetState(Isom.Base.String execState)

Legt den Ausführungszustand der Aktion fest.

Aktionseigenschaften

Erweiterungsmodell: Vom Autor frei definierbare Merkmalswerte der Aktion.

Isom.Base.String | GetDisplayProp(Isom.Base.String propName)

Setzt den Wert der vorgegebenen Anzeigeeigenschaft für die Aktion.

Isom.Base.StringList | GetDisplayPropNames()

Liefert die Namen aller Anzeige-Eigenschaften der Aktion.

Isom.Base.String | GetProp(Isom.Base.String propName)

Ermittelt den Wert der vorgegebenen Eigenschaft (property) für die Aktion.

Isom.Base.StringList | GetPropNames()

Liefert die Namen aller technischen Eigenschaften der Aktion.

Isom.Base.Boolean | SetDisplayProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt den Wert der vorgegebenen Anzeigeeigenschaft für für die Aktion.

Isom.Base.Boolean | SetProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt den Wert der generischen Eigenschaft (property) für die Aktion.

Steuerung der Ausführungsreihenfolge

Beeinflussung der Ausführungsreihenfolge, wenn vom Fachdienst unterstützt.

Isom.Base.String | GetActionPlanGroup()

Liefert die Ausführungsgrupe, zu der die Aktion gehört.

Isom.Plan.TherapyPlanActionList | GetDependentActions()

Liefert die abhängigen Aktionen der Therapieplanaktion.

Isom.Base.Number | GetFlashFlags()

Ruft die Flags für den Flashvorgang ab.

Isom.Base.Number | GetPhase()

Fragt den Sortierindex für die Aktionsplanphase ab, in der die Aktion ausgeführt wird.

Isom.Base.Number | GetPriority()

Fragt einen Sortierindex für die Aktionsausführung ab, der innerhalb der Aktionsplanphase durch Kanalauswahl oder durch Trennung der Aktionsplanphasen (Phasenbruch) erzwungen wird.

Isom.Plan.TherapyPlanActionList | GetReasonForFailedDependency()

Liefert die Kette der fehlgeschlagenen Aktionen, die der Grund für das abhängige Fehlschlagen dieser Aktion waren.

Isom.Base.Number | GetSequence()

Fragt den Sortierindex innerhalb des Aktionsplanpfades ab, in der die Aktion ausgeführt wird.

Isom.Base.Boolean | SetFlashFlags(Isom.Base.Number Flags)

Legt die Flags für den Flashvorgang fest.

Isom.Base.Boolean | SetPhase(Isom.Base.Number phase)

Legt ein Sortierkriterium für die Aktionsplanphase fest, das stets über getrennte Aktionsplanphasen (Phasenbruch) erzwungen wird.

Isom.Base.Boolean | SetPriority(Isom.Base.Number priority)

Legt den Sortierindex für die Aktionsausführung ab, der innerhalb der Aktionsplanphase durch Kanalauswahl oder durch Trennung der Aktionsplanphasen (Phasenbruch) erzwungen wird.

Isom.Base.Boolean | SetSequence(Isom.Base.Number sequence)

Legt den Sortierindex für die Aktionsausführung ab, der innerhalb desselben Aktionsplanpfades erzwungen wird.

Editieren des Therapieplans

Löschen / Deaktivieren von Aktionen.

Isom.Base.Boolean | Purge()

Markiert die Aktion oder alle Aktionen im Teilbaum als "nicht einzuplanen" / "nicht auszuführen".

Isom.Base.Boolean | RemoveFromPlan()

Entfernt eine Aktion technisch von der Stelle, an der sie momentan eingefügt ist (beispielsweise aus dem Therapieplan).

Abhängiges Editieren des Therapieplans

Steuerung der Abhängigkeiten zwischen Therapieplanaktionen beim Editieren des Therapieplans.

Isom.Plan.TherapyPlanActionList | GetDependantActionsToRefilter()

Liefert Aktionen, die neu gefiltert werden müssen, wenn die aktuelle Aktion entfernt wird.

Isom.Plan.TherapyPlanActionList | GetDependantActionsToRemove(Isom.Base.Boolean transitive)

Liefert Aktionen, die mit entfernt werden müssen, wenn die aktuelle Aktion entfernt wird.

Isom.Base.Boolean | SetDependantActionsToRefilter(Isom.Plan.TherapyPlanActionList dependantActions)

Setzt Aktionen, die neu gefiltert werden müssen, wenn die aktuelle Aktion entfernt wird.

Isom.Base.Boolean | SetDependantActionsToRemove(Isom.Plan.TherapyPlanActionList dependantActions)

Setzt Aktionen, die mit entfernt werden müssen, wenn die aktuelle Aktion entfernt wird.

Prüfen der Logistikkonsistenz

Ermitteln von Logistikbezügen der Aktion.

Isom.Base.Boolean | IsLogisticsConsistent()

Liefert den Zustand bzgl Logistikinformationen

Steuerung der Aktionsausführung

Sofortausführung von Aktionen.

Isom.Base.Boolean | ExecuteImmediate()

Führt eine Sofort-Aktion aus.

Isom.Base.Boolean | GetExecutedByIsom()

Ruft ab, ob die Aktion durch eine Ausführungsfunktion ausgeführt wird.

Isom.Base.Boolean | Run()

Führt eine einzelne Aktion aus.

Isom.Base.Boolean | SetExecutedByIsom(Isom.Base.Boolean byIsom)

Legt fest, ob die Aktion durch eine Ausführungsfunktion ausgeführt wird.

Abbruchmodell

Dynamische Beeinflussung des Abbruchverhaltens einer Aktion.

Isom.Base.Boolean | GetContinueOnError()

Fragt das Verhalten des Therapieplan-orientierten Abbruchmodells für diese Aktion ab.

Isom.Base.Boolean | GetContinueWithEcuOnError()

Fragt das Verhalten des Steuergeräte-orientierten Abbruchmodells für diese Aktion ab.

Isom.Base.Boolean | SetContinueOnError(Isom.Base.Boolean value)

Setzt das Verhalten des Therapieplan-orientierten Abbruchmodells für diese Aktion.

Isom.Base.Boolean | SetContinueWithEcuOnError(Isom.Base.Boolean value)

Setzt das Verhalten des Steuergeräte-orientierten Abbruchmodells für diese Aktion.

Logische Fahrzeuge und Überarbeitungsstände

Informationen zu logischen Fahrzeugen als Aufteilung des Fahrzeugkontexts, über die Teilbordnetze des Fahreugs separat angesprochen werden können sowie zu Überarbeitungsständen, die den Verbau des Fahrzeugs charakterisieren.
(Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).)

Isom.Context.LogicalVehicleList | GetLogicalVehicles()

Ermittelt die Liste verwendbarer logischer Fahrzeuge.

Isom.Base.Boolean | SetLogicalVehicles(Isom.Context.LogicalVehicleList lvList)

Setzt die Liste verwendbarer logischer Fahrzeuge.

Überprüfen des Vorhandenseins der erforderlichen Steuergerätedaten

Überprüft, ob zu allen Aktionen des Therapieplans die erforderlichen Steuergerätedaten vorhanden sind.

Isom.Base.Boolean | GetMissingFiles()

Überprüft, ob zu allen Aktionen des Therapieplans die erforderlichen Steuergerätedaten vorhanden sind.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Plan.TherapyPlanAction | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Isom.Plan.TherapyPlanAction | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Therapieplanaktionen sind die konstituierenden aktiven Elemente, aus denen sich eine Therapiesitzung zusammensetzt. Sämtliche Fahrzeug-verändernden Tätigkeiten sollten als Aktionen implementiert werden.

Ihr Wirkungsgefüge wird im Therapieplan (Typ Isom.Plan.TherapyPlan) gespeichert, ihre Ausführungsreihenfolge im Aktionsplan Isom.Plan.ActionPlan

Die Klassifizierung von Therapieplanaktionen umfasst folgende Unterscheidungen:

  • virtuelle Aktionen = nicht-Blatt-Knoten im Therapiebaum, entsprechen den Aktionen, die an die Filter...()- Funktion übergeben wurden
  • ausführbare Aktionen = konkrete Aktionen = Aktionen, für die kein Filter angewendet oder die aufrund eines Rekursionsabbruches direkt eingefügt wurden. Für diese muss eine Ausführungsfunktion Do<Name>() in ISOM/L definiert sein.
  • nicht Steuergeräte-bezogene Aktion = Aktion, die entweder auf mehrere Steuergeräte oder auf kein Steuergerät oder auf das Gesamtfahrzeug wirkt.
  • Steuergeräte-bezogene Aktion = Aktion, die ausschließlich auf ein Steuergerät wirkt.

Quelldateien:

  • Isom\Plan\TherapyPlanAction.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.CanRunOnly ( )

Prüft, ob Aktion an einer beliebigen Stelle im Prozessablauf über Processes.RunAction() ausgeführt werden kann (beispielsweise Diagnose-Aktionen).

Zu beachten:
Der Ergebniswert ist 'true', wenn (1a) die Aktion in [EditibleAction] bzw. (1b) [EditibleEcuAction] als sofort ausführbar gekennzeichnet (1c) (bzw. über SetCanRunOnly() gesetzt wurde ) und gleichzeitig (2) der zugeordnete Sichtbarkeitsterm dynamisch erfüllt ist.
vs. CanExecuteImmediate()
Ein Wert 'true' für dieses Flag schließt sämtliche anderen InsertableAction-Flags aus.
Rückgabe:
'true' wenn in jeder Situation sofort ausführbar, 'false' sonst.
[Isom\Plan\TherapyPlanAction.is: 515]
objectbound Isom.Plan.TherapyPlanAction Isom.Plan.TherapyPlanAction.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Isom.Plan.TherapyPlanAction
Das geklonte Objekt.
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2572]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.ExecuteImmediate ( )

Führt eine Sofort-Aktion aus.

Die Aktion kann mit dieser Funktion während der Planungsphase ausgeführt werden (beispielsweise für Bestellaktionen für Freischaltcodes).

   Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
   Isom.Plan.TherapyPlanAction action = tp.CreateAction("ImmediateAction42");

   //..

   if (action.ExecuteImmediate().Failed())
   {
     //Fehlerbehandlung
   }
Rückgabe:
Isom.Base.Boolean
'true', wenn erfolgreich, 'false', sonst
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2131]
objectbound Isom.Base.String Isom.Plan.TherapyPlanAction.GetActionPlanGroup ( )

Liefert die Ausführungsgrupe, zu der die Aktion gehört.

Rückgabe:
Ausführungsgrupe
Ausnahmebehandlung:
Es wird Isom.Base.String.Void zurückgegeben, falls die Ausführungsgrupe für die Aktion nicht gesetzt ist.
Siehe auch:
Isom.Plan.ActionPlan.SetExecutionOrderGroup
Annotation [ActionPlanGroup]
[Isom\Plan\TherapyPlanAction.is: 1682]
objectbound Isom.Base.String Isom.Plan.TherapyPlanAction.GetActionText ( )

Liefert den vom Autor per [Editable[Ecu]Action(…, TextID, …)] vorgegebenen übersetzbaren Text.

Verwendungsbeispiel:
   TherapyPlanActionList list = tPlan.GetEditableActions();
   while(list.HasNext() )
   {
       System.Stdout( list.Next().GetActionText());
   }
   CurrentVehicleContext currentContext = CurrentVehicleContext.GetInstance();
   EcuList ecuList = currentContext.GetEcus();
   while( ecuList.HasNext() )
   {
       Ecu ecu = ecuList.Next();
       list = ecu.GetEditableActions();
       while(list.HasNext() )
       {
           System.Stdout( list.Next().GetActionText());
       }
   }
Rückgabe:
Name der Aktion (case-sensitiv).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls für die Aktion kein übersetzbarer Text bekannt ist.
[Isom\Plan\TherapyPlanAction.is: 221]
objectbound Isom.Plan.ActivationCode Isom.Plan.TherapyPlanAction.GetActivationCode ( )

Liefert den Freischaltcode, auf den sich die Aktion bezieht oder Void.

Verwendungsbeispiel:
 using Isom.Base.*;
 using Isom.Context.*;
 using Isom.Global.Config;
 ...
 ActivationCode ac = action.GetActivationCode();
Rückgabe:
Freischaltcode oder Void.
[Isom\Plan\TherapyPlanAction.is: 734]
objectbound Isom.Base.String Isom.Plan.TherapyPlanAction.GetComment ( )

Ermittelt den autorendefinierten Kommentar zur Ausführung der Aktion.

Rückgabe:
Der für diese Aktion durch SetComment() festgelegte Kommentar zur Ausführung.
[Isom\Plan\TherapyPlanAction.is: 302]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.GetContinueOnError ( )

Fragt das Verhalten des Therapieplan-orientierten Abbruchmodells für diese Aktion ab.

Mit dieser Funktion lässt sich abfragen, ob nach einem Fehler bei Ausführung der Aktion weitere Aktionen für das Steuergerät ausgeführt werden dürfen.

   Isom.Base.Boolean DoFlash (Isom.Plan.TherapyPlanAction action)
   {
     //Aktionsausführung mit Fehlschlag

     if (action.GetContinueOnError())
     {
       //Andere Aktionen dürfen ausgeführt werden
     }
     else
     {
       //Andere noch nicht ausgeführte Aktionen werden <code>FailedDependency</code>
     }

     return true;
   }
Rückgabe:
Isom.Base.Boolean
'true', wenn bei Fehlschlag der Aktion mit anderen Aktionen im Therapiebaum fortgefahren wird
'false', wenn bei Fehlschlag der Aktion nicht mit anderen Aktionen im Therapiebaum fortgefahren wird
Siehe auch:
Isom.Plan.TherapyPlanAction.SetContinueOnError() für die zugehörige Setter-Funktion.
Annotation [ContinueOnError]
Isom.Plan.TherapyPlanAction.GetContinueWithEcuOnError() für Steuergeräte-bezogenes Abbruchmodell.
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2296]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.GetContinueWithEcuOnError ( )

Fragt das Verhalten des Steuergeräte-orientierten Abbruchmodells für diese Aktion ab.

Mit dieser Funktion lässt sich abfragen, ob nach einem Fehler bei Ausführung der Aktion weitere Aktionen für das Steuergerät ausgeführt werden dürfen.

   Isom.Base.Boolean DoFlash (Isom.Plan.TherapyPlanAction action)
   {
     //Aktionsausführung mit Fehlschlag

     if (action.GetContinueWithEcuOnError())
     {
       //Andere Aktionen für dieses SG dürfen ausgeführt werden
     }
     else
     {
       //Andere noch nicht ausgeführte Aktionen für dieses SG werden <code>FailedDependency</code>
     }

     return true;
   }
Rückgabe:
Isom.Base.Boolean
'true', wenn bei Fehlschlag der Aktion mit anderen Aktionen für dieses Steuergerät fortgefahren wird
'false', wenn bei Fehlschlag der Aktion nicht mit anderen Aktionen für dieses Steuergerät fortgefahren wird
Siehe auch:
Isom.Plan.TherapyPlanAction.SetContinueWithEcuOnError() für die zugehörige Setter-Funktion.
Annotation [ContinueWithEcuOnError]
Isom.Plan.TherapyPlanAction.GetContinueOnError() für Therapieplan-bezogenes Abbruchmodell.
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2383]
objectbound Isom.Plan.TherapyPlanActionList Isom.Plan.TherapyPlanAction.GetDependantActionsToRefilter ( )

Liefert Aktionen, die neu gefiltert werden müssen, wenn die aktuelle Aktion entfernt wird.

Die Liste wird vom ISOM-Kern aktualisiert, wenn Aktionen zum Therapieplan hinzugefügt oder aus dem Therapieplan entfernt werden. Der Aufruf kann auf einer bereits im Therapieplan befindlichen Aktion oder auf einer als Suchmuster fungierenden, "freistehenden" Aktion (beispielsweise InsertableAction) erfolgen. Im letzteren Fall wird über Isom.Plan.TherapyPlan.GetActions() die letzte semantisch gleiche Aktion gesucht und verwendet.

   Isom.Base.Boolean RemoveActionManually (Isom.Plan.TherapyPlanAction action)
   {
     Isom.Plan.TherapyPlanActionList dependantActions = action.GetDependantActionsToRefilter();

     //..

     return true;
   }
Rückgabe:
Isom.Plan.TherapyPlanActionList
Abhängige Aktionen, die nach einem Entfernen dieser Aktion neu gefiltert werden müssen.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Liste noch nicht existiert.
Es wird das Void-Objekt zurückgegeben, falls die Liste explizit auf Void gesetzt wurde.
Es wird das Void-Objekt zurückgegeben, falls die oben beschriebene Suche kein passendes Element ergibt.
Siehe auch:
Isom.Plan.TherapyPlanAction.SetDependantActionsToRefilter()
Isom.Plan.TherapyPlanAction.GetDependantActionsToRemove()
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 1892]
objectbound Isom.Plan.TherapyPlanActionList Isom.Plan.TherapyPlanAction.GetDependantActionsToRemove ( Isom.Base.Boolean transitive )

Liefert Aktionen, die mit entfernt werden müssen, wenn die aktuelle Aktion entfernt wird.

Die Liste wird vom ISOM-Kern aktualisiert, wenn Aktionen zum Therapieplan hinzugefügt oder aus dem Therapieplan entfernt werden. Der Aufruf kann auf einer bereits im Therapieplan befindlichen Aktion oder auf einer als Suchmuster fungierenden, "freistehenden" Aktion (beispielsweise InsertableAction) erfolgen. Im letzteren Fall wird über Isom.Plan.TherapyPlan.GetActions() die letzte semantisch gleiche Aktion gesucht und verwendet.

   Isom.Base.Boolean RemoveActionManually (Isom.Plan.TherapyPlanAction action)
   {
     Isom.Plan.TherapyPlanActionList dependantActions = action.GetDependantActionsToRemove();

     //..

     return true;
   }
Parameter:
transitive wenn 'true', werden auch alle Aktionen geliefert, die von Aktionen abhängig sind, die von dieser Aktion abhängig sind ("Transitive Hülle"). wenn 'false', werden nur Aktionen geliefert, die von dieser Aktion direkt abhängig sind.
Rückgabe:
Isom.Plan.TherapyPlanActionList
Abhängige Aktionen, die mit entfernt werden müssen.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Liste noch nicht existiert.
Es wird das Void-Objekt zurückgegeben, falls die Liste explizit auf Void gesetzt wurde.
Es wird das Void-Objekt zurückgegeben, falls die oben beschriebene Suche kein passendes Element ergibt.
Siehe auch:
Isom.Plan.TherapyPlanAction.SetDependantActionsToRemove()
Isom.Plan.TherapyPlanAction.GetDependantActionsToRefilter()
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 1986]
objectbound Isom.Plan.TherapyPlanActionList Isom.Plan.TherapyPlanAction.GetDependentActions ( )

Liefert die abhängigen Aktionen der Therapieplanaktion.

Verwendungsbeispiel:
 using Isom.Plan.*;
 ...
       TherapyPlanAction action;
       // ...
       TherapyPlanActionList dependentActions = action.GetDependentActions();
Rückgabe:
Liste der abhängigen Aktionen
[Isom\Plan\TherapyPlanAction.is: 1700]
objectbound Isom.Base.String Isom.Plan.TherapyPlanAction.GetDisplayProp ( Isom.Base.String propName )

Setzt den Wert der vorgegebenen Anzeigeeigenschaft für die Aktion.

Zu beachten:
Die unterstützten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.
Es gilt die Initialisierungsreihenfolge: ContextConfiguration -> CurrentVehicleContext -> FutureVehicleContext
Verwendungsbeispiel:
   // Consts.is:
   deftext INTERNAL FLASH_ACTION "Programmieren"

   // *.is:
   using Isom.Base.*
   ...
      Ecu ecu = ...
      String val = ecu.GetDisplayProp( Consts.FLASH_ACTION );
Rückgabe:
Wert der Eigenschaft.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Wert ungesetzt oder gleich "" ist.
Siehe auch:
Isom.Plan.TherapyPlanAction.SetDisplayProp()
[Isom\Plan\TherapyPlanAction.is: 1207]
objectbound Isom.Base.StringList Isom.Plan.TherapyPlanAction.GetDisplayPropNames ( )

Liefert die Namen aller Anzeige-Eigenschaften der Aktion.

Es werden die Eigenschaftsnamen für die Anzeige-Eigenschaften (siehe Isom.Plan.TherapyPlanAction.GetDisplayProp()) zurückgeliefert. Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

   Isom.Base.Boolean DoFlash (Isom.Plan.TherapyPlanAction action)
   {
     Isom.Base.StringList displayPropertyNames = action.GetDisplayPropNames();
     displayPropertyNames.Reset();
     while(displayPropertyNames.HasNext())
     {
       //Abfrage des Werts für den gelieferten Eigenschaftsnamen und z. B. Aufzeichnung ins Protokoll
     }

     //Aktionsausführung

     return true;
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller Anzeige-Eigenschaften der Aktion.
Siehe auch:
Isom.Plan.TherapyPlanAction.GetDisplayProp()
Datum:
letzte Änderung am 09.09.2010
[Isom\Plan\TherapyPlanAction.is: 1278]
objectbound Isom.Base.String Isom.Plan.TherapyPlanAction.GetDisplayState ( )

Ruft den Anzeigezustand der Aktion ab.

Rückgabe:
Anzeigezustand der Aktion.
[Isom\Plan\TherapyPlanAction.is: 1044]
objectbound Isom.Context.Ecu Isom.Plan.TherapyPlanAction.GetEcu ( )

Liefert das assoziierte Steuergeräte-Fachobjekt oder Void.

Verwendungsbeispiel:
   using Isom.Base.*
   using Isom.Plan.TherapyPlanAction;
   using Isom.Context.Ecu;
   ...
      Boolean Filter...( TherapyPlanAction action )
      {
          Ecu ecu = action.GetEcu();
          if( ecu.IsVoid().Not() )
              ecu.Store...();     // ecu-wise
          else
              Deploy....();       // vehicle-wise
          ...
      }
Rückgabe:
Assoziiertes Ecu-Objekt für steuergerätebezogene Aktionen oder Void-Objekt, wenn kein Steuergerät assoziiert wurde.
[Isom\Plan\TherapyPlanAction.is: 248]
objectbound Isom.Base.Number Isom.Plan.TherapyPlanAction.GetEstimatedRuntime ( )

Fragt die prognostizierte Laufzeit für die Aktion ab.

Verwendungsbeispiel:
 Number time = tpa.GetEstimatedRuntime ();
Rückgabe:
Prognostizierte Laufzeit in Sekunden.
[Isom\Plan\TherapyPlanAction.is: 821]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.GetExecutedByIsom ( )

Ruft ab, ob die Aktion durch eine Ausführungsfunktion ausgeführt wird.

Eine Ausführungsfunktion wird in ISOM/L implementiert. Ihr Name besteht aus Do und dem Namen der Aktion. Für Aktionen, die im Rahmen einer asynchronen Phase ausgeführt werden, wird z. B. keine Ausführungsfunktion aufgerufen.

   Isom.Base.Boolean FilterActivate (Isom.Plan.TherapyPlanAction action)
   {
     //Ausführung durch Ausführungsfunktion
     action.SetExecutedByIsom(true);

     //Filtern

     return true;
   }
Rückgabe:
Isom.Base.Boolean
'true', wenn ISOM bei der Aktionsausführung die entsprechende Ausführungsfunktion aufruft
'false', sonst
Siehe auch:
Isom.Plan.TherapyPlanAction.SetExecutedByIsom() für die zugehörige Setter-Funktion.
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2200]
objectbound Isom.Base.Date Isom.Plan.TherapyPlanAction.GetFinishTime ( )

Fragt den Zeitpunkt ab, zu dem die Aktion beendet wurde.

Der Rückgabewert kann das Void-Objekt sein, falls die Aktion noch nicht beendet wurde.

Zu beachten:
Zusammen mit der Funktion 'GetStartTime()' lässt sich somit die gesamte Zeitdauer der Aktion berechnen. Im Unterschied zu 'GetProcessedTime()' enthält die somit berechnete Zeitspanne auch die Zeit, in der Benutzeranfragen angezeigt werden.
Verwendungsbeispiel:
 // TherapyPlanAction tpa
 Date startTime = tpa.GetStartTime();
 Date finishTime = tpa.GetFinishTime();
 Number actualDurationInSeconds = finishTime.ElapsedTime(startTime);
Rückgabe:
Zeitpunkt, zu dem die Aktion beendet wurde.
[Isom\Plan\TherapyPlanAction.is: 895]
objectbound Isom.Base.Number Isom.Plan.TherapyPlanAction.GetFlashFlags ( )

Ruft die Flags für den Flashvorgang ab.

Die Flags werden durch eine ganze Zahl repräsentiert.

Verwendungsbeispiel:
 using Isom.Plan.*;
 ...
       TherapyPlanAction action;
       // ...
       Number flashFlags = action.GetFlashFlags();
Rückgabe:
Die Flags für den Flashvorgang als ganze Zahl.
[Isom\Plan\TherapyPlanAction.is: 1647]
objectbound Isom.Context.LogicalUnitList Isom.Plan.TherapyPlanAction.GetLogicalUnits ( )

Liefert die Liste der logischen Einheiten, die von der Aktion betroffen sind.

Verwendungsbeispiel:
Rückgabe:
Liste der logischen Einheiten, die von der Aktion betroffen sind Die Liste kann leer sein, aber nicht das Void-Objekt
[Isom\Plan\TherapyPlanAction.is: 351]
objectbound Isom.Context.LogicalVehicleList Isom.Plan.TherapyPlanAction.GetLogicalVehicles ( )

Ermittelt die Liste verwendbarer logischer Fahrzeuge.

Zu beachten:
Über diese logischen Fahrzeuge wird bei Fahrzeugzugriffen während der Aktionsausführung iteriert.
Die Reihenfolge der logischen Fahrzeuge in der Liste bestimmt über die Zugriffsreihenfolge.
Für steuergerätebezogene und zusammengesetzte Aktionen ermittelt ISOM die Liste automatisch.
   Isom.Plan.TherapyPlanAction tpa = ...;
   Isom.Context.LogicalVehicleList vl = tpa.GetLogicalVehicles();
Rückgabe:
Isom.Context.LogicalVehicleList
Liste verwendbarer logischer Fahrzeuge
Siehe auch:
Isom.Plan.TherapyPlanAction.SetLogicalVehicles
Seit:
Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).
Datum:
letzte Änderung am 29.06.2011
[Isom\Plan\TherapyPlanAction.is: 2466]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.GetMissingFiles ( )

Überprüft, ob zu allen Aktionen des Therapieplans die erforderlichen Steuergerätedaten vorhanden sind.

Verwendungsbeispiel:
 using Isom.Plan.*;
 ...
        TherapyPlanAction action;
        // ...
        action.GetMissingFiles();
        String missingSwu = action.GetProp("Swu:Missing");
        if (missingSwu.Equals("").Not())  // Zeichenkette ist nicht leer oder Void
        {
            //Fehler
        }
 ...
Rückgabe:
Isom.Base.Boolean
true im Erfolgsfall, false sonst.
[Isom\Plan\TherapyPlanAction.is: 2535]
objectbound Isom.Base.String Isom.Plan.TherapyPlanAction.GetName ( )

Liefert den vom Autor definierten Namen der Aktion.

Rückgabe:
Name der Aktion (case-sensitiv).
[Isom\Plan\TherapyPlanAction.is: 189]
objectbound Isom.Plan.OrderingInfoList Isom.Plan.TherapyPlanAction.GetOrderingInfoList ( )

Liefert Bestellinformationen für das Steuergerät.

Verwendungsbeispiel:
 using Isom.Base.*;
 using Isom.Context.*;
 ...
 // Liste der Bestellinformationen holen
 OrderingInfoList oiList = action.GetOrderingInfoList();
 ...
Rückgabe:
Liste von Bestellalternativen.
[Isom\Plan\TherapyPlanAction.is: 775]
objectbound Isom.Base.Number Isom.Plan.TherapyPlanAction.GetPhase ( )

Fragt den Sortierindex für die Aktionsplanphase ab, in der die Aktion ausgeführt wird.

Der vorgegebene Sortierindex ist eine ganze Zahl. Es wird normalerweise von der Logistik festgelegt, kann aber vom Autor angegeben werden. Ein kleinerer Sortierindex bewirkt eine frühere Ausführung der Aktion.

Die Abbildungen für die systemseitig ermittelten Sortierkriterien sind in den herstellerspezifischen Begleitdokumenten zu finden.

Es gelten folgende Zusicherungen bzgl. der Parallelausführung:

(1) Zwei beliebige Aktionen mit verschiedenen Phasenindizes werden in der jeweils zugeordneten Phase und daher stets sequentiell ausgeführt. Phasenindizes werden dabei aufsteigend sortiert.

(2) Zwei beliebige Aktionen mit gleichem Phasenindex, aber verschiedenen Sequenzindizes werden innerhalb der gleichen Phase ausgeführt. Werden beide Aktionen über denselben nebenläufigen Kanal ausgeführt, erfolgt ihre Ausführung sequentiell innerhalb jedes Ausführungspfades nach aufsteigendem Sequenzindex. Werden sie über verschiedene nebenläufige Kanäle ausgeführt, können sie parallel ausgeführt werden.

Technische Details zur Aktionsplanung und -ausführung sind im Fach-IV-Konzept ISOM, Teil III beschrieben.

Verwendungsbeispiel:
 using Isom.Plan.*;
 ...
       TherapyPlanAction action;
       // ...
       Number flashPhase = action.GetPhase();
Rückgabe:
Sortierindex für die Aktionsplanphase (ganze Zahl).
[Isom\Plan\TherapyPlanAction.is: 1334]
objectbound Isom.Base.StringList Isom.Plan.TherapyPlanAction.GetPossibleLChannels ( )

Ermittelt die für die Aktionsausführung alternativ zueinander zulässigen L-Kanäle.

Verwendungsbeispiel:
 using Isom.Base.*;
 using Isom.Context.*;
 ...
 StringList possibleChannels = action.GetPossibleLChannels();

   // Der Algorithmus geht davon aus, dass nur der von der Logistik angewiesene
   // Kanal zurückkommt. Dieser muss eindeutig sein.

   String msg = "Für die Aktion ";
   msg.Append(action.GetName());
   msg.Append(" wurden mögliche Kanäle ");
   msg.Append(possibleChannels.Concat(";"));
   msg.Append(" gefunden.");
   Log.Error ("", msg);
   ...
Rückgabe:
Liste der L-Kanäle.
[Isom\Plan\TherapyPlanAction.is: 690]
objectbound Isom.Base.Number Isom.Plan.TherapyPlanAction.GetPriority ( )

Fragt einen Sortierindex für die Aktionsausführung ab, der innerhalb der Aktionsplanphase durch Kanalauswahl oder durch Trennung der Aktionsplanphasen (Phasenbruch) erzwungen wird.

Der Sortierindex ist eine ganze Zahl. Er wird von einigen Logistiken festgelegt, kann aber vom Autor überschrieben werden.

Die Abbildungen für die systemseitig ermittelten Sortierindizes sind in den herstellerspezifischen Begleitdokumenten zu finden.

Es gelten folgende Zusicherungen bzgl. der Parallelausführung:
(1) Zwei beliebige Aktionen mit verschiedenen Phasenindizes werden in der getrennten Phasen und daher stets sequentiell zueinander ausgeführt. Phasenindizes werden dabei aufsteigend sortiert.
(2) Zwei beliebige Aktionen mit gleichem Phasenindex,aber verschiedenen Prioritäten werden innerhalb derselben Phase und im selben Aktionsplanpfad und damit stets sequentiell ausgeführt, soweit dies mit den Kanalvorgaben der Aktionen vereinbar ist. Lassen die Kanalvorgaben dies nicht zu, wird die Sequentialität erzwungen, indem die Aktionen in verschiedenen Aktionsplanphasen eingeplant werden (Phasenbruch). Prioritätsindizes werden dabei aufsteigend sortiert.
(3) Zwei beliebige Aktionen mit gleichem Phasenindex, gleicher Priorität aber verschiedenen Sequenzindizes werden innerhalb der gleichen Phase ausgeführt. Werden beide Aktionen über denselben nebenläufigen Kanal ausgeführt, erfolgt ihre Ausführung sequentiell innerhalb jedes Ausführungspfades nach aufsteigendem Sequenzindex. Werden sie über verschiedene nebenläufige Kanäle ausgeführt, können sie parallel ausgeführt werden. Sequenzindizes werden dabei aufsteigend sortiert.

Technische Details zur Aktionsplanung und -ausführung sind im Fach-IV-Konzept ISOM, Teil III beschrieben.

Verwendungsbeispiel:
 using Isom.Plan.*;
 ...
       TherapyPlanAction action;
       // ...
       Number flashSequence = action.GetPriority();
Rückgabe:
Aktionsplanpfad-übergreifender Sortierindex (ganze Zahl).
[Isom\Plan\TherapyPlanAction.is: 1450]
objectbound Isom.Base.Number Isom.Plan.TherapyPlanAction.GetProcessedRuntime ( )

Liefert die tatsächliche Zeitdauer der Aktion.

Zu beachten:
Der Rückgabewert kann das Void-Objekt sein, falls die Aktion noch nicht gestartet oder beendet wurde.
Diese Zeitdauer schließt nicht die Anzeige von Benutzeranfragen ein.
Verwendungsbeispiel:
 Data planEntry = Data.Create(Consts.PROTOCOLTAG_ACTION_PLAN);
 Number n = ap.GetProcessedRuntime ();
 planEntry.AddAttribute (Consts.PROTOCOLATTR_PHASE_TOTAL_TIME, n.ToIntString ());
Rückgabe:
Tatsächliche Zeitdauer der Aktion in Sekunden.
[Isom\Plan\TherapyPlanAction.is: 915]
objectbound Isom.Base.String Isom.Plan.TherapyPlanAction.GetProp ( Isom.Base.String propName )

Ermittelt den Wert der vorgegebenen Eigenschaft (property) für die Aktion.

Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Verwendungsbeispiel:
   using Isom.Base.*
   ...
      String val = action.GetProp( "ErrorX" );
Rückgabe:
Diagnoseadresse.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Wert ungesetzt oder gleich "" ist.
[Isom\Plan\TherapyPlanAction.is: 1114]
objectbound Isom.Base.StringList Isom.Plan.TherapyPlanAction.GetPropNames ( )

Liefert die Namen aller technischen Eigenschaften der Aktion.

Es werden die Eigenschaftsnamen für die technischen Eigenschaften (siehe Isom.Plan.TherapyPlanAction.GetProp()) zurückgeliefert. Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

   Isom.Base.Boolean DoFlash (Isom.Plan.TherapyPlanAction action)
   {
     Isom.Base.StringList propertyNames = action.GetPropNames();
     propertyNames.Reset();
     while(propertyNames.HasNext())
     {
       //Abfrage des Werts für den gelieferten Eigenschaftsnamen und z. B. Aufzeichnung ins Protokoll
     }

     //Aktionsausführung

     return true;
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller technischen Eigenschaften der Aktion.
Siehe auch:
Isom.Plan.TherapyPlanAction.GetProp()
Datum:
letzte Änderung am 09.09.2010
[Isom\Plan\TherapyPlanAction.is: 1176]
objectbound Isom.Plan.TherapyPlanActionList Isom.Plan.TherapyPlanAction.GetReasonForFailedDependency ( )

Liefert die Kette der fehlgeschlagenen Aktionen, die der Grund für das abhängige Fehlschlagen dieser Aktion waren.

Verwendungsbeispiel:
 using Isom.Plan.*;
 ...
       TherapyPlanAction action;
       // ...
       TherapyPlanActionList actions = action.GetReasonForFailedDependency();
Rückgabe:
Referenz auf die fehlgeschlagenen Aktionen: Den Anfang der Liste (Index 0) bildet die Aktion, deren Ausführung gescheitert ist. Die weiteren Einträge können andere abhängig fehlgeschlagene Aktionen sein, wenn eine Abhängigkeitskette existiert.
[Isom\Plan\TherapyPlanAction.is: 1722]
objectbound Isom.Base.Number Isom.Plan.TherapyPlanAction.GetSequence ( )

Fragt den Sortierindex innerhalb des Aktionsplanpfades ab, in der die Aktion ausgeführt wird.

Der Sortierindex ist eine ganze Zahl. Er wird normalerweise von der Logistik festgelegt, kann aber vom Autor überschrieben werden.

Die Abbildungen für die systemseitig ermittelten Sortierindizes sind in den herstellerspezifischen Begleitdokumenten zu finden.

Es gelten folgende Zusicherungen bzgl. der Parallelausführung:
(1) Zwei beliebige Aktionen mit verschiedenen Phasenindizes werden in der getrennten Phasen und daher stets sequentiell zueinander ausgeführt. Phasenindizes werden dabei aufsteigend sortiert.
(2) Zwei beliebige Aktionen mit gleichem Phasenindex,aber verschiedenen Prioritäten werden innerhalb derselben Phase und im selben Aktionsplanpfad und damit stets sequentiell ausgeführt, soweit dies mit den Kanalvorgaben der Aktionen vereinbar ist. Lassen die Kanalvorgaben dies nicht zu, wird die Sequentialität erzwungen, indem die Aktionen in verschiedenen Aktionsplanphasen eingeplant werden (Phasenbruch). Prioritätsindizes werden dabei aufsteigend sortiert.
(3) Zwei beliebige Aktionen mit gleichem Phasenindex, gleicher Priorität aber verschiedenen Sequenzindizes werden innerhalb der gleichen Phase ausgeführt. Werden beide Aktionen über denselben nebenläufigen Kanal ausgeführt, erfolgt ihre Ausführung sequentiell innerhalb jedes Ausführungspfades nach aufsteigendem Sequenzindex. Werden sie über verschiedene nebenläufige Kanäle ausgeführt, können sie parallel ausgeführt werden. Sequenzindizes werden dabei aufsteigend sortiert.

Technische Details zur Aktionsplanung und -ausführung sind im Fach-IV-Konzept ISOM, Teil III beschrieben.

Verwendungsbeispiel:
 using Isom.Plan.*;
 ...
       TherapyPlanAction action;
       // ...
       Number flashSequence = action.GetSequence();
Rückgabe:
Sortierindex innerhalb des Aktionsplanpfades (ganze Zahl).
[Isom\Plan\TherapyPlanAction.is: 1563]
objectbound Isom.Base.Date Isom.Plan.TherapyPlanAction.GetStartTime ( )

Fragt den Zeitpunkt ab, zu dem die Aktion gestartet wurde.

Der Rückgabewert kann das Void-Objekt sein, falls die Aktion noch nicht gestartet wurde.

Verwendungsbeispiel:
 // TherapyPlanAction tpa
 Date startTime = tpa.GetStartTime();
 Date finishTime = tpa.GetFinishTime();
 Number actualDurationInSeconds = finishTime.ElapsedTime(startTime);
Rückgabe:
Zeitpunkt, zu dem die Aktion gestartet wurde.
[Isom\Plan\TherapyPlanAction.is: 870]
objectbound Isom.Base.StringList Isom.Plan.TherapyPlanAction.GetStates ( )

Liefert eine Liste von Zuständen, die den Ausführungszustand der Aktion beschreiben.

Bemerkungen:
Die Liste kann folgende Zustandsangaben enthalten:
Präfix | Wert | Beschreibung
Isom.Execution | Virtual | virtuell
Isom.Execution | Shadowed | verschattet
Isom.Execution | Plannable | planbar
Isom.Execution | ToDo | eingeplant (synchron) und noch nicht ausgeführt
Isom.Execution | ToDoAsync | eingeplant (asynchron) und noch nicht ausgeführt
Isom.Execution | Executing | in Ausführung
Isom.Execution | Aborting | wird abgebrochen
Isom.Execution | ToReschedule | wird neu in den Plan eingeordnet
Isom.Execution | Rescheduled | wurde neu in den Plan eingeordnet
Isom.Execution | Purged | inaktiv
Isom.Execution | FailedDependency | abhängig gescheitert
Isom.Execution | Successful | erfolgreich
Isom.Execution | Failed | gescheitert
Isom.Display | Default | Anzeige mit Ausführungsstatus
Isom.Display | Successful | Anzeige als erfolgreich
Isom.Display | Failed | Anzeige als gescheitert
Isom.Display | FailedDependency | Anzeige als abhängig gescheitert
Isom.Display | Suppress | Anzeige ohne Zustandsangabe
Isom.Display | Attention | Anzeige als 'zu beachten'
Isom.Display | ToDo | Anzeige als geplant
Isom.Display | PostSession | Anzeige als Element zur Nachbearbeitung
Isom.Display | PostSession | Anzeige als Element zur Nachbearbeitung
Isom.Logistics.AutoRetainLogisticsConsistency | true | Aufruf der Logistik beim Einplanen
Isom.Logistics.AutoRetainLogisticsConsistency | false | kein Aufruf der Logistik beim Einplanen
Verwendungsbeispiel:
   using Isom.Base.*
   using Isom.Plan.TherapyPlanAction;
   using Isom.Context.Ecu;
   ...
   Boolean CompleteTherapyPlan ()
   {
       TherapyPlan tp = TherapyPlan.GetInstance ();
       TherapyPlanActionList tpal = tp.GetActions ();

       while( tpal.HasNext() )
       {
           TherapyPlanAction tpa = tpal.Next();
           System.Stdout( tpa.GetName().Append(" - ").Append( tpa.GetStates().Concat(",") ) );
           ...
       }
       ...
   }
Rückgabe:
Liste von Zuständen.
[Isom\Plan\TherapyPlanAction.is: 985]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.IsInsertable ( )

Ermittelt, ob die Aktion aus ISOM-Sicht zum Therapieplan hinzufügbar ist.

Dafür wird insbesondere der vom Autor per [Editable[Ecu]Action(..., ..., Term)] vorgegebene Sichtbarkeitsterm ausgewertet.

Diese Flags sind im Therapieplan und den editierbaren Aktionen gesetzt.

Verwendungsbeispiel:
   using Isom.Base.*
   using Isom.Plan.TherapyPlan;
   using Isom.Plan.TherapyPlanAction;
   using Isom.Plan.TherapyPlanActionList;
   ...
      CurrentVehicleContext currentContext = CurrentVehicleContext.GetInstance();
      EcuList ecuList = currentContext.GetEcus();
      while( ecuList.HasNext() )
      {
          Ecu ecu = ecuList.Next();
          list = ecu.GetEditableActions();
          while(list.HasNext() )
          {
              TherapyPlanAction action = list.Next();
              System.Stdout( action.GetActionText() );
              if( action.IsInsertable() )
                  System.Stdout("INSERTABLE");
              else
                  System.Stdout("HIDDEN");
          }
      }
Rückgabe:
'true' wenn die Aktion sichtbar und einfügbar sein soll, 'false' sonst.
[Isom\Plan\TherapyPlanAction.is: 416]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.IsLogisticsConsistent ( )

Liefert den Zustand bzgl Logistikinformationen

Die Funktion bestimmt, ob für die Aktion und ihre eventuellen Kinderknoten Logistikdaten abgefragt werden müssen und falls ja, ob bereits Logistikdaten abgefragt wurden.

   Isom.Base.Boolean FilterAction42 (Isom.Plan.TherapyPlanAction action)
   {
     if( action.IsLogisticsConsistent().Not() )
     {
       //Logistikdaten nicht vorhanden, aber relevant
     }
     else
     {
       //Logistikdaten bereits vorhanden oder nicht relevant
     }

     //..

     return true;
   }
Rückgabe:
Isom.Base.Boolean
'true' Die Aktion ist Logistik-relevant und ihre Logistikdaten wurden abgefragt (das heißt es existiert eine zugehörige Logistikaktion oder ein zugehöriger Logistikplan).
'false' Die Aktion ist Logistik-relevant, ihre Logistikdaten wurden aber noch nicht abgefragt. (Sollte in der Regel während des ersten Filteraufrufs einer Logistik-relevanten Aktion der Fall sein)
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die Aktion nicht logistikrelevant ist.
Es wird das Void-Objekt zurückgegeben, falls während der Ermittlung der Logistikrelevanz technische Fehler auftreten.
Siehe auch:
Isom.Plan.TherapyPlan.IsLogisticsConsistent()
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2088]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.IsPlanned ( )

Prüft, ob die Editierbare Aktion als geplant markiert ist.

Zu beachten:
Die Markierung einer Editierbaren Aktion als geplant bewirkt normalerweise eine entsprechende Anzeige in den Dialogen zum Editieren des Therapieplans.
Die Funktion dient primär Test- und Protokollierungszwecken.
Rückgabe:
'true' wenn als geplant markiert, 'false' sonst.
Siehe auch:
Isom.Context.Ecu.GetEditableActions(), Isom.Plan.TherapyPlan.GetEditableActions() für die Ermittlung Editierbarer Aktionen.
Verwendungsbeispiel:
   TherapyPlanActionList list = tPlan.GetEditableActions();
   System.Stdout( "Folgende Aktionen sollten mit [x] angezeigt werden: " );
   list.Reset();
   while(list.HasNext() )
   {
       TherapyPlanAction tpa = list.Next();
       if( tpa.IsPlanned() )
          System.Stdout( tpa.GetActionText());
   }
[Isom\Plan\TherapyPlanAction.is: 556]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.IsRemoveable ( )

Ermittelt, ob die Aktion aus ISOM-Sicht aus dem Therapieplan entfernbar ist.

Diese Flags sind im Therapieplan und den editierbaren Aktionen gesetzt.

Verwendungsbeispiel:
   using Isom.Base.*
   using Isom.Plan.TherapyPlan;
   using Isom.Plan.TherapyPlanAction;
   using Isom.Plan.TherapyPlanActionList;
   ...
      CurrentVehicleContext currentContext = CurrentVehicleContext.GetInstance();
      EcuList ecuList = currentContext.GetEcus();
      while( ecuList.HasNext() )
      {
          Ecu ecu = ecuList.Next();
          list = ecu.GetEditableActions();
          while(list.HasNext() )
          {
              TherapyPlanAction action = list.Next();
              System.Stdout( action.GetActionText() );
              if( action.IsRemoveable() )
                  System.Stdout("REMOVEABLE");
              else
                  System.Stdout("HIDDEN");
          }
      }
Rückgabe:
'true' wenn die Aktion sichtbar und entfernbar sein soll, 'false' sonst.
[Isom\Plan\TherapyPlanAction.is: 453]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.IsVirtual ( )

Ermittelt, ob die Aktion eine virtuelle Aktion, das heißt ein nicht-Blatt-Knoten im Therapiebaum, ist.

Siehe auch:
Erläuterungen zu Isom.Plan.TherapyPlanAction oben
Verwendungsbeispiel:
   using Isom.Base.*
   using Isom.Plan.TherapyPlan;
   using Isom.Plan.TherapyPlanAction;
   using Isom.Plan.TherapyPlanActionList;
   ...
      TherapyPlan tp = TherapyPlan.GetInstance();
      TherapyPlanActionList tpal = tp.GetActions();
      while( tpal.HasNext() )
      {
          TherapyPlanAction tpa = tpal.Next();
          if( tpa.IsVirtual().Not() )
              tpa. ... ();
      }
Rückgabe:
'true' wenn die Aktion virtuell ist, 'false' wenn die Aktion konkret ist.
[Isom\Plan\TherapyPlanAction.is: 293]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.IsVoid ( )

Bestimmt, ob die Aufrufinstanz das Void-Objekt ist.

Das Void-Objekt kann z. B. bei Funktionsaufrufen geliefert werden, um einen Fehler anzuzeigen.

Rückgabe:
Isom.Base.Boolean
'true', falls dies das Void-Objekt ist, 'false' sonst
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2560]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.Purge ( )

Markiert die Aktion oder alle Aktionen im Teilbaum als "nicht einzuplanen" / "nicht auszuführen".

Veraltet:
Veraltet seit Argonaut 1.10. TherapyPlanAction.Purge() soll in künftigen Versionen durch Mechanismen ersetzt werden, die auf TherapyPlanAction.RemoveFromPlan() basieren.
Achtung:
Die Änderung des Ausführungsstatuses von Aktionen im Therapieplan kann die Logistikkonsistenz zerstören!
Das Ausblenden mittels Purge()-Aufrufen bewirkt auch eine Unterdrückung der Aktion in künftigen Logistikplänen (sogenannte Persistente Wirkung der Purge()s). Dies kann rückgängig gemacht werden, indem die Aktionen mittels RemoveFromPlan() endgültig aus dem Plan gelöscht werden oder indem eine gleiche Aktion neu zu Therapieplan hinzugefügt wird.
Siehe auch:
Isom.Plan.TherapyPlanAction.RemoveFromPlan()
Verwendungsbeispiel:
   using Isom.Base.*
   using Isom.Plan.ActionPlan;
   ...
      TherapyPlanAction tpa = ...;
      Ecu               ecu   = tpa.GetEcu();
      StringList        hardwareDAs = ...;

      if( hardwareDAs.Contains( ecu.GetEcuAddress().ToIntString() ) )
      {
          // Aktion jetzt und künftig unterdrücken
          if( tpa.Purge().Failed() )
          {
              ...
          }

          // Logistik-Neuberechnung
          if (FutureVehicleContext.GetInstance().RecalcPlanAfterReassembly ("").Failed ())
          {
              ...
          }
      }
Rückgabe:
'true' wenn Aktion erfolgreich entfernt, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls für die Aktion kein Einfüge-Zusammenhang vorhanden ist.
[Isom\Plan\TherapyPlanAction.is: 1784]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.RemoveFromPlan ( )

Entfernt eine Aktion technisch von der Stelle, an der sie momentan eingefügt ist (beispielsweise aus dem Therapieplan).

Achtung:
Eventuelle Änderungen am Soll-Kontext (Fahrzeugauftrag, SG-Liste), die mit der ürsprünglichen Aktionsplanung verbunden waren, werden nicht automatisch rückgängig gemacht, sondern es wird rein technisch der Knoten aus der Datenstruktur entfernt.
Entfernen von Aktionen aus dem Therapieplan kann die Logistikkonsistenz zerstören!
Bei Entfernen von Teilbäumen aus Logistikplänen können die entfernten Aktionen in künftigen Logistikplänen erneut geplant werden.
Zu beachten:
Der gesamte Therapieplan kann durch Löschen des Root-Elements, beispielsweise mittels TherapyPlan.GetInstance().GetActions().At(0).RemoveFromPlan() geleert werden.
Verwendungsbeispiel:
   using Isom.Base.*
   using Isom.Plan.ActionPlan;
   ...
      TherapyPlanAction tpa = ...;
      Ecu               ecu   = tpa.GetEcu();
      StringList        hardwareDAs = ...;

      if( hardwareDAs.Contains( ecu.GetEcuAddress().ToIntString() ) )
      {
          // Aktion entfernen
          if( tpa.RemoveFromPlan().Failed() )
          {
              ...
          }

          // Logistik-Neuberechnung
          if (FutureVehicleContext.GetInstance().RecalcPlanAfterReassembly ("").Failed ())
          {
              ...
          }
      }
Rückgabe:
'true' wenn Aktion erfolgreich entfernt werden konnte, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls für die Aktion kein Einfüge-Zusammenhang vorhanden ist.
Siehe auch:
Isom.Plan.TherapyPlanAction.Purge() für persistent wirksames Ausblenden.
Isom.Plan.TherapyPlan.Remove() für Entfernen ganzer Teilbäume mit neuberechnung der Soll-Kontexte.
[Isom\Plan\TherapyPlanAction.is: 1839]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.Run ( )

Führt eine einzelne Aktion aus.

Die Aktion kann mit dieser Funktion außerhalb eines Aktionsplans ausgeführt werden (beispielsweise für Diagnose-Aktionen).

   Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
   Isom.Plan.TherapyPlanAction action = tp.CreateAction("ImmediateAction42");

   //..

   if (action.Run().Failed())
   {
     //Fehlerbehandlung
   }
Rückgabe:
Isom.Base.Boolean
'true', wenn erfolgreich, 'false', sonst
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2163]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetActivationCode ( Isom.Plan.ActivationCode ac )

Setzt den Freischaltcode, auf den sich die Aktion bezieht.

Verwendungsbeispiel:
 using Isom.Base.*;
 using Isom.Context.*;
 ...
 // Freischaltcode auf Activate-Aktion übertragen
 ActivationCode ac = ActivationCode.CreateSwtActivationCode (appNumber, upgradeIndex);
 activateAction.SetActivationCode (ac);
 ...
Rückgabe:
'true' wenn erfolgreich, 'false' sonst.
[Isom\Plan\TherapyPlanAction.is: 755]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetCanRunOnly ( Isom.Base.Boolean CanRunOnly )

Setzt fest, ob die Aktion bereits während der Planungsphase ausgeführt werden kann.

Rückgabe:
'true' wenn erfolgreich, 'false' sonst.
[Isom\Plan\TherapyPlanAction.is: 525]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetComment ( Isom.Base.String comment )

Legt den autorendefinierten Kommentar zur Ausführung der Aktion fest.

Parameter:
comment Ein Kommentar zum Ablauf der Ausführung dieser Aktion.
Verwendungsbeispiel:
   using Isom.Base.*;
   using Isom.Plan.*;
   ...

   Boolean DoFlash ( TherapyPlanAction action )
   {
       // Defaultimplementierung aufrufen
       if (ProcBasic.BasicDoFlash (action).Failed ())
       {
           action.SetComment("Keine weiteren Maßnahmensteigerungsstufen definiert");

           Log.Error ("", "Ausführung von BasicDoFlash fehlgeschlagen.");
           // Funktion fehlgeschlagen
           return false;
       }
       //Funktion erfolgreich
       return true;
   } // function: DoFlash ()
Rückgabe:
Immer 'true'.
[Isom\Plan\TherapyPlanAction.is: 336]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetContinueOnError ( Isom.Base.Boolean value )

Setzt das Verhalten des Therapieplan-orientierten Abbruchmodells für diese Aktion.

Mit dieser Funktion lässt sich steuern, ob nach einem Fehler bei Ausführung der Aktion weitere Aktionen des Therapieplans ausgeführt werden dürfen.

   Isom.Base.Boolean DoFlash (Isom.Plan.TherapyPlanAction action)
   {
     action.SetContinueOnError(true);

     //Aktionsausführung

     return true;
   }
Parameter:
value wenn 'true' wird bei Fehlschlag der Aktion mit anderen Aktionen im Therapiebaum fortgefahren; wenn 'false' wird bei Fehlschlag der Aktion nicht mit anderen Aktionen im Therapiebaum fortgefahren.
Rückgabe:
Isom.Base.Boolean
Immer 'true'
Siehe auch:
Isom.Plan.TherapyPlanAction.GetContinueOnError() für die zugehörige Getter-Funktion.
Annotation [ContinueOnError]
Isom.Plan.TherapyPlanAction.SetContinueWithEcuOnError() für Steuergeräte-bezogenes Abbruchmodell.
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2338]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetContinueWithEcuOnError ( Isom.Base.Boolean value )

Setzt das Verhalten des Steuergeräte-orientierten Abbruchmodells für diese Aktion.

Mit dieser Funktion lässt sich steuern, ob nach einem Fehler bei Ausführung der Aktion weitere Aktionen für das Steuergerät ausgeführt werden dürfen.

   Isom.Base.Boolean DoFlash (Isom.Plan.TherapyPlanAction action)
   {
     action.SetContinueWithEcuOnError(true);

     //Aktionsausführung

     return true;
   }
Parameter:
value wenn 'true', wird bei Fehlschlag der Aktion mit anderen Aktionen für dieses Steuergerät fortgefahren; wenn 'false', wird bei Fehlschlag der Aktion nicht mit anderen Aktionen für dieses Steuergerät fortgefahren.
Rückgabe:
Isom.Base.Boolean
Immer 'true'
Siehe auch:
Isom.Plan.TherapyPlanAction.GetContinueWithEcuOnError() für die zugehörige Getter-Funktion.
Annotation [ContinueWithEcuOnError]
Isom.Plan.TherapyPlanAction.SetContinueOnError() für Therapieplan-bezogenes Abbruchmodell.
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2425]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetDependantActionsToRefilter ( Isom.Plan.TherapyPlanActionList dependantActions )

Setzt Aktionen, die neu gefiltert werden müssen, wenn die aktuelle Aktion entfernt wird.

Die Liste wird vom ISOM-Kern aktualisiert, wenn Aktionen zum Therapieplan hinzugefügt oder aus dem Therapieplan entfernt werden. Die Liste muss deshalb nach jedem manuellen Editieren des Therapieplans neu gesetzt/aktualisiert werden, wenn die ISOM-Vorinitialisierung überschrieben werden soll.

   Isom.Base.Boolean FilterAction42 (Isom.Plan.TherapyPlanAction action)
   {
     Isom.Plan.TherapyPlanActionList dependantActions = Isom.Plan.TherapyPlanActionList.CreateNew();

     //..

     if(action.SetDependantActionsToRefilter(dependantActions).Failed())
     {
       //Fehlerbehandlung
     }

     //..

     return true;
   }
Parameter:
dependantActions Abhängige Aktionen, die nach einem Entfernen dieser Aktion neu gefiltert werden müssen oder Isom.Plan.TherapyPlanActionList.Void()
Rückgabe:
Isom.Base.Boolean
'true', wenn die Liste erfolgreich übernommen werden konnte
'false'sonst
Siehe auch:
Isom.Plan.TherapyPlanAction.GetDependantActionsToRefilter()
Isom.Plan.TherapyPlanAction.SetDependantActionsToRemove()
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 1939]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetDependantActionsToRemove ( Isom.Plan.TherapyPlanActionList dependantActions )

Setzt Aktionen, die mit entfernt werden müssen, wenn die aktuelle Aktion entfernt wird.

Die Liste wird vom ISOM-Kern aktualisiert, wenn Aktionen zum Therapieplan hinzugefügt oder aus dem Therapieplan entfernt werden. Die Liste muss deshalb nach jedem manuellen Editieren des Therapieplans neu gesetzt/aktualisiert werden, wenn die ISOM-Vorinitialisierung überschrieben werden soll.

   Isom.Base.Boolean FilterAction42 (Isom.Plan.TherapyPlanAction action)
   {
     Isom.Plan.TherapyPlanActionList dependantActions = Isom.Plan.TherapyPlanActionList.CreateNew();

     //..

     if(action.SetDependantActionsToRemove(dependantActions).Failed())
     {
       //Fehlerbehandlung
     }

     //..

     return true;
   }
Parameter:
dependantActions Abhängige Aktionen, die mit entfernt werden müssen oder Isom.Plan.TherapyPlanActionList.Void()
Rückgabe:
Isom.Base.Boolean
'true', wenn die Liste erfolgreich übernommen werden konnte
'false'sonst
Siehe auch:
Isom.Plan.TherapyPlanAction.GetDependantActionsToRemove()
Isom.Plan.TherapyPlanAction.SetDependantActionsToRefilter()
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2032]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetDisplayProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt den Wert der vorgegebenen Anzeigeeigenschaft für für die Aktion.

Zu beachten:
Die unterstützten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.
Es gilt die Initialisierungsreihenfolge: ContextConfiguration -> CurrentVehicleContext -> FutureVehicleContext
Verwendungsbeispiel:
   // Consts.is:
   deftext INTERNAL FLASH_ACTION "Programmieren"

   // *.is:
   using Isom.Base.*
   ...
      Ecu ecu = ...
      if( ecu.GetDisplayProp( "ACTION_TYPE" ).IsVoid() )
        ecu.SetDisplayProp( "ACTION_TYPE", FLASH_ACTION );
Rückgabe:
'true' nach erfolgreichem Setzen. 'false' niemals.
Siehe auch:
Isom.Plan.TherapyPlanAction.GetDisplayProp()
[Isom\Plan\TherapyPlanAction.is: 1238]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetDisplayState ( Isom.Base.String displayState )

Legt den Anzeigezustand der Aktion fest.

Folgende Zustände sind zulässig:

  • "Isom.Display.ToDo"
  • "Isom.Display.FailedDependency"
  • "Isom.Display.Successful"
  • "Isom.Display.Failed"
  • "Isom.Display.Attention"
  • "Isom.Display.Suppress"
  • "Isom.Display.Default"

Verwendungsbeispiel:
 using Isom.Base.*;
 using Isom.Context.*;
 using Isom.Global.Config;
 ...
 // Anzeigezustand setzen
           TherapyPlan tp = TherapyPlan.GetInstance ();
           TherapyPlanActionList tpal = tp.GetActions ();
           tpal.Reset ();
           while (tpal.HasNext ())
           {
               TherapyPlanAction tpa = tpal.Next ();
               if (tpa.GetName ().Equals ("Replace"))
               {
                   tpa.SetDisplayState (Consts.ACTIONSTATE_ISOM_DISPLAY_ATTENTION);
               }
           } ...
Rückgabe:
'true' wenn der Anzeigezustand gesetzt werden konnte, 'false' wenn displayState einen unzulässigen Anzeigezustand bezeichnet.
[Isom\Plan\TherapyPlanAction.is: 1082]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetEcu ( Isom.Context.Ecu newEcu )

Ändert das betroffene Steuergerät unter Erhaltung der restlichen Aktionsinformationen.

Rückgabe:
'true' wenn erfolgreich, 'false' sonst.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Parameter Void ist.
Es wird das Void-Objekt zurückgegeben, falls die Aktion nicht steuergerätebezogen ist.
[Isom\Plan\TherapyPlanAction.is: 263]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetEstimatedRuntime ( Isom.Base.Number seconds )

Setzt die prognostizierte Laufzeit für die Aktion in Sekunden.

Verwendungsbeispiel:
   using Isom.Base.*
   using Isom.Plan.TherapyPlanAction;
   using Isom.Context.Ecu;
   ...
   Boolean BasicReplace( TherapyPlanAction action )
   {
       TherapyPlan tp = TherapyPlan.GetInstance();

       // Der Tausch des ACC dauert erfahrungsgemäß 10min.
       action.SetEstimatedRuntime( 600 );
       return BasicFilterReplace( action );
   }
Parameter:
seconds Zu setzende Ausführungszeitprognose
  • wenn >=0 wird die Ausführungszeitprognose auf den Wert gesetzt
  • wenn <0 wird eine vorher gesetzte Ausführungszeitprognose gelöscht.
Rückgabe:
Prognostizierte Laufzeit in Sekunden.
[Isom\Plan\TherapyPlanAction.is: 850]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetExecutedByIsom ( Isom.Base.Boolean byIsom )

Legt fest, ob die Aktion durch eine Ausführungsfunktion ausgeführt wird.

Eine Ausführungsfunktion wird in ISOM/L implementiert. Ihr Name besteht aus Do und dem Namen der Aktion. Für Aktionen, die im Rahmen einer asynchronen Phase ausgeführt werden, wird z. B. keine Ausführungsfunktion aufgerufen.

   Isom.Base.Boolean FilterActivate (Isom.Plan.TherapyPlanAction action)
   {
     //Ausführung durch Ausführungsfunktion
     action.SetExecutedByIsom(true);

     //Filtern

     return true;
   }
Parameter:
byIsom 'true': Die Aktion wird ausgeführt, indem ISOM die entsprechende Ausführungsfunktion aufruft. Die Funktion scheitert, wenn diese Funktion nicht existiert. 'false': ISOM ruft keine Ausführungsfunktion auf.
Rückgabe:
Isom.Base.Boolean
'true', wenn die Einstellung erfolgreich verändert wurde oder keine Veränderung erforderlich war
'false', wenn die Einstellung nicht übernommen wurde
Siehe auch:
Isom.Plan.TherapyPlanAction.GetExecutedByIsom() für die zugehörige Getter-Funktion.
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2242]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetFlashFlags ( Isom.Base.Number Flags )

Legt die Flags für den Flashvorgang fest.

Die Flags werden durch eine ganze Zahl repräsentiert.

Verwendungsbeispiel:
 using Isom.Plan.*;
 ...
       TherapyPlanAction action;
       // ...
       action.SetFlashFlags(42);
Rückgabe:
Immer 'true'.
[Isom\Plan\TherapyPlanAction.is: 1668]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetLogicalUnits ( Isom.Context.LogicalUnitList logicalUnits )

Setzt die Liste der logischen Einheiten, die von der Aktion betroffen sind.

Verwendungsbeispiel:
Rückgabe:
Liste der logischen Einheiten, die von der Aktion betroffen sind Die Liste kann leer sein, aber nicht das Void-Objekt
[Isom\Plan\TherapyPlanAction.is: 366]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetLogicalVehicles ( Isom.Context.LogicalVehicleList lvList )

Setzt die Liste verwendbarer logischer Fahrzeuge.

Zu beachten:
Über diese logischen Fahrzeuge wird bei Fahrzeugzugriffen während der Aktionsausführung iteriert.
Die Reihenfolge der logischen Fahrzeuge in der Liste bestimmt über die Zugriffsreihenfolge.
   Isom.Plan.TherapyPlanAction tpa = ...;
   Isom.Context.LogicalVehicleList lvList = ...;
   Isom.Base.Boolean result = tpa.SetLogicalVehicles(lvList);
Parameter:
lvList (Isom.Context.LogicalVehicleList)
Liste verwendbarer logischer Fahrzeuge
Rückgabe:
Isom.Base.Boolean
true, falls Setzen erfolgreich
false nie.
Siehe auch:
Isom.Plan.TherapyPlanAction.GetLogicalVehicles
Seit:
Eingeführt mit BZ-12385/BZ-12497/WA-588-5637 (Mischbordnetze).
Datum:
letzte Änderung am 29.06.2011
[Isom\Plan\TherapyPlanAction.is: 2498]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetManuallyPlanned ( Isom.Base.Boolean manuallyPlanned )

Legt fest, ob eine Aktion manuell angewiesen wurde.

Diese mit dieser Funktion vorgenommene Einstellung hat Vorrang vor dem Kriterium, ob eine Aktion direkt eingefügt wurde.

Parameter:
manuallyPlanned Gibt an, ob die Aktion als manuell eingeplant oder als nicht manuell eingeplant gelten soll
Rückgabe:
true, wenn der Wert von manuallyPlanned erfolgreich übernommen wurde, sonst false
Datum:
letzte Änderung am 12.10.2010
   Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
   Isom.Plan.TherapyPlanAction sampleAction = tp.CreateEcuAction("SampleAction", ecu);

   // Festlegen, dass diese Aktion nicht manuell angewiesen wurde
   sampleAction.SetManuallyAdded(false);
[Isom\Plan\TherapyPlanAction.is: 626]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetOrderingInfoList ( Isom.Plan.OrderingInfoList infoList )

Setzt die Bestellinformationen für das Steuergerät.

Verwendungsbeispiel:
 using Isom.Base.*;
 using Isom.Context.*;
 ...
 // Liste der Bestellinformationen an eine Aktion weiterreichen
 if (Action.SetOrderingInfoList (oiList).Failed ())
 {
     Log.Warning ("", "Liste der Bestellinformationen konnte nicht an die " \
                      "Aktion weitergereicht werden.");
 } ...
Rückgabe:
'true' oder Void.
[Isom\Plan\TherapyPlanAction.is: 797]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetPhase ( Isom.Base.Number phase )

Legt ein Sortierkriterium für die Aktionsplanphase fest, das stets über getrennte Aktionsplanphasen (Phasenbruch) erzwungen wird.

Der vorgegebene Sortierindex ist eine ganze Zahl. Es wird normalerweise von der Logistik festgelegt, kann aber vom Autor angegeben werden. Ein kleinerer Sortierindex bewirkt eine frühere Ausführung der Aktion.

Achtung:
Vom Autor gesetzte Werte können von der Logistik wieder überschrieben werden. Es liegt in der Verantwortung des Autors dies ggf. durch eine geeignete Aufrufreihenfolge zu berücksichtigen.

Die Abbildungen für die systemseitig ermittelten Sortierkriterien sind in den herstellerspezifischen Begleitdokumenten zu finden.

Es gelten folgende Zusicherungen bzgl. der Parallelausführung:
(1) Zwei beliebige Aktionen mit verschiedenen Phasenindizes werden in der getrennten Phasen und daher stets sequentiell zueinander ausgeführt. Phasenindizes werden dabei aufsteigend sortiert.
(2) Zwei beliebige Aktionen mit gleichem Phasenindex,aber verschiedenen Prioritäten werden innerhalb derselben Phase und im selben Aktionsplanpfad und damit stets sequentiell ausgeführt, soweit dies mit den Kanalvorgaben der Aktionen vereinbar ist. Lassen die Kanalvorgaben dies nicht zu, wird die Sequentialität erzwungen, indem die Aktionen in verschiedenen Aktionsplanphasen eingeplant werden (Phasenbruch). Prioritätsindizes werden dabei aufsteigend sortiert.
(3) Zwei beliebige Aktionen mit gleichem Phasenindex, gleicher Priorität aber verschiedenen Sequenzindizes werden innerhalb der gleichen Phase ausgeführt. Werden beide Aktionen über denselben nebenläufigen Kanal ausgeführt, erfolgt ihre Ausführung sequentiell innerhalb jedes Ausführungspfades nach aufsteigendem Sequenzindex. Werden sie über verschiedene nebenläufige Kanäle ausgeführt, können sie parallel ausgeführt werden. Sequenzindizes werden dabei aufsteigend sortiert.

Technische Details zur Aktionsplanung und -ausführung sind im Fach-IV-Konzept ISOM, Teil III beschrieben.

Parameter:
phase Sortierindex für die Aktionsplanphase (aufsteigend sortiert).
Verwendungsbeispiel:
 using Isom.Plan.*;
 ...
       TherapyPlanAction action;
       // ...
       action.SetPhase(42);
Siehe auch:
Isom.Plan.TherapyPlanAction.SetPriority.
Isom.Plan.TherapyPlanAction.SetSequence.
Rückgabe:
Immer 'true'.
[Isom\Plan\TherapyPlanAction.is: 1397]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetPossibleLChannels ( Isom.Base.StringList list )

Setzt die für die Aktionsausführung alternativ zueinander zulässigen L-Kanäle.

Verwendungsbeispiel:
 possibleLChannels = ...
 action.SetPossibleLChannels(possibleLChannels);
Rückgabe:
Liste der zulässigen L-Kanäle.
[Isom\Plan\TherapyPlanAction.is: 706]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetPriority ( Isom.Base.Number priority )

Legt den Sortierindex für die Aktionsausführung ab, der innerhalb der Aktionsplanphase durch Kanalauswahl oder durch Trennung der Aktionsplanphasen (Phasenbruch) erzwungen wird.

Der Sortierindex ist eine ganze Zahl. Er wird von einigen Logistiken festgelegt, kann aber vom Autor angegeben werden.

Achtung:
Vom Autor gesetzte Werte können von der Logistik wieder überschrieben werden. Es liegt in der Verantwortung des Autors dies ggf. durch eine geeignete Aufrufreihenfolge zu berücksichtigen.

Die Abbildungen für die systemseitig ermittelten Sortierindizes sind in den herstellerspezifischen Begleitdokumenten zu finden.

Es gelten folgende Zusicherungen bzgl. der Parallelausführung:
(1) Zwei beliebige Aktionen mit verschiedenen Phasenindizes werden in der getrennten Phasen und daher stets sequentiell zueinander ausgeführt. Phasenindizes werden dabei aufsteigend sortiert.
(2) Zwei beliebige Aktionen mit gleichem Phasenindex,aber verschiedenen Prioritäten werden innerhalb derselben Phase und im selben Aktionsplanpfad und damit stets sequentiell ausgeführt, soweit dies mit den Kanalvorgaben der Aktionen vereinbar ist. Lassen die Kanalvorgaben dies nicht zu, wird die Sequentialität erzwungen, indem die Aktionen in verschiedenen Aktionsplanphasen eingeplant werden (Phasenbruch). Prioritätsindizes werden dabei aufsteigend sortiert.
(3) Zwei beliebige Aktionen mit gleichem Phasenindex, gleicher Priorität aber verschiedenen Sequenzindizes werden innerhalb der gleichen Phase ausgeführt. Werden beide Aktionen über denselben nebenläufigen Kanal ausgeführt, erfolgt ihre Ausführung sequentiell innerhalb jedes Ausführungspfades nach aufsteigendem Sequenzindex. Werden sie über verschiedene nebenläufige Kanäle ausgeführt, können sie parallel ausgeführt werden. Sequenzindizes werden dabei aufsteigend sortiert.

Technische Details zur Aktionsplanung und -ausführung sind im Fach-IV-Konzept ISOM, Teil III beschrieben.

Parameter:
priority Aktionsplanpfad-übergreifender Sortierindex (aufsteigend sortiert).
Verwendungsbeispiel:
 using Isom.Plan.*;
 ...
       TherapyPlanAction action;
       // ...
       action.SetPriority(42);
Siehe auch:
Isom.Plan.TherapyPlanAction.SetPhase.
Isom.Plan.TherapyPlanAction.SetSequence.
Rückgabe:
Immer 'true'.
[Isom\Plan\TherapyPlanAction.is: 1513]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt den Wert der generischen Eigenschaft (property) für die Aktion.

Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

Verwendungsbeispiel:
   using Isom.Base.*;
   ...
      String propName = "ErrorX";
      if( action.GetProp(propName).IsVoid() )
        action.SetProp( propName, "5" );
Rückgabe:
immer 'true'
[Isom\Plan\TherapyPlanAction.is: 1136]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetRemoveable ( Isom.Base.Boolean isRemoveable )

Markiert die Aktion als aus dem Therapieplan entfernbar.

Diese Flags werden im Therapieplan und den editierbaren Aktionen gesetzt.

Zu beachten:
ISOM entfernt immer den kompletten TOP-Level-Subbaum. Als identifizierende Aktion kann jedoch angegeben werden
  • der Top-Level-Baumknoten
  • ein beliebiger als IsRemoveable gekennzeichneter Subknoten.
Verwendungsbeispiel:
   using Isom.Base.*
   using Isom.Plan.TherapyPlan;
   using Isom.Plan.TherapyPlanAction;
   using Isom.Plan.TherapyPlanActionList;
   ...
      Boolean BasicFilterFlash( TherapyPlanAction action )
      {
          TherapyPlan tp = TherapyPlan.GetInstance();
          Ecu ecu = action.GetEcu();

          // Programmieraktionen auf Steuergeräten ohne freie AIF-Felder werden
          // in Tauschaktionen ("Replace") umgewandelt.
          if( ecu.GetUifFree().Lt( 1 ) )
          {
              TherapyPlanAction replaceAction = tp.CreateEcuAction( "Replace", ecu );
              replaceAction.SetRemoveable( action.IsRemoveable() );
              return tp.Add( replaceAction );
          }
      }
Rückgabe:
'true' im Erfolgsfall (derzeit immer), 'false' sonst.
[Isom\Plan\TherapyPlanAction.is: 493]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetSequence ( Isom.Base.Number sequence )

Legt den Sortierindex für die Aktionsausführung ab, der innerhalb desselben Aktionsplanpfades erzwungen wird.

Der Sortierindex ist eine ganze Zahl. Er wird normalerweise von der Logistik festgelegt, kann aber vom Autor angegeben werden.

Achtung:
Vom Autor gesetzte Werte können von der Logistik wieder überschrieben werden. Es liegt in der Verantwortung des Autors dies ggf. durch eine geeignete Aufrufreihenfolge zu berücksichtigen.

Die Abbildungen für die systemseitig ermittelten Sortierindizes sind in den herstellerspezifischen Begleitdokumenten zu finden.

Es gelten folgende Zusicherungen bzgl. der Parallelausführung:
(1) Zwei beliebige Aktionen mit verschiedenen Phasenindizes werden in der getrennten Phasen und daher stets sequentiell zueinander ausgeführt. Phasenindizes werden dabei aufsteigend sortiert.
(2) Zwei beliebige Aktionen mit gleichem Phasenindex,aber verschiedenen Prioritäten werden innerhalb derselben Phase und im selben Aktionsplanpfad und damit stets sequentiell ausgeführt, soweit dies mit den Kanalvorgaben der Aktionen vereinbar ist. Lassen die Kanalvorgaben dies nicht zu, wird die Sequentialität erzwungen, indem die Aktionen in verschiedenen Aktionsplanphasen eingeplant werden (Phasenbruch). Prioritätsindizes werden dabei aufsteigend sortiert.
(3) Zwei beliebige Aktionen mit gleichem Phasenindex, gleicher Priorität aber verschiedenen Sequenzindizes werden innerhalb der gleichen Phase ausgeführt. Werden beide Aktionen über denselben nebenläufigen Kanal ausgeführt, erfolgt ihre Ausführung sequentiell innerhalb jedes Ausführungspfades nach aufsteigendem Sequenzindex. Werden sie über verschiedene nebenläufige Kanäle ausgeführt, können sie parallel ausgeführt werden. Sequenzindizes werden dabei aufsteigend sortiert.

Technische Details zur Aktionsplanung und -ausführung sind im Fach-IV-Konzept ISOM, Teil III beschrieben.

Parameter:
sequence Sortierindex innerhalb des Aktionsplanpfades (aufsteigend sortiert).
Verwendungsbeispiel:
 using Isom.Plan.*;
 ...
       TherapyPlanAction action;
       // ...
       action.SetSequence(42);
Siehe auch:
Isom.Plan.TherapyPlanAction.SetPhase.
Isom.Plan.TherapyPlanAction.SetPriority.
Rückgabe:
Immer 'true'.
[Isom\Plan\TherapyPlanAction.is: 1625]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanAction.SetState ( Isom.Base.String execState )

Legt den Ausführungszustand der Aktion fest.

Folgende Zustände sind zulässig:

  • Ausgangszustände:
    1. "Isom.Execution.ToDo" (zur Ausführung durch ISOM vorgesehen)
  • Finalzustände:
    1. "Isom.Execution.Purged" (als inaktiv markiert)
    2. "Isom.Execution.FailedDependency" (Vorbedingung nicht erfüllt)
    3. "Isom.Execution.Successful" (ohne Fehler beendet)
    4. "Isom.Execution.Failed" (mit Fehler(n) beendet)

Achtung:
Die Änderung von Aktionszuständen verändert u.U. tiefgehend den Therapieablauf!
Zu beachten:
TherapyPlanAction.SetState() ist primär für die Reaktivierung bereits ausgeführter Aktionen vorgesehen.
Die Änderungen werden nicht automatisch im Aktionsplan berücksichtigt, das heißt es ist ggf. ein Aufruf von ActionPlan.DoTp2Ap() notwendig.
Verwendungsbeispiel:
   TherapyPlan tp = TherapyPlan.GetInstance ();
   TherapyPlanActionList tpal = tp.GetActions ();
   tpal.Reset ();
   while (tpal.HasNext ())
   {
       TherapyPlanAction tpa = tpal.Next ();
       if( tpa. ... )
       {
            tpa.SetState( "Isom.Execution.ToDo" );
            ap.DoTp2Ap (); // ggf. Aktion in neue AP.Phase planen
            break;
       }
   }
Rückgabe:
'true' wenn der Ausführungszustand gesetzt werden konnte, 'false' wenn execState einen unzulässigen Ausführungszustand bezeichnet.
[Isom\Plan\TherapyPlanAction.is: 1034]
Isom.Plan.TherapyPlanAction Isom.Plan.TherapyPlanAction.Void ( )

Erzeugt ein Void-Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um beispielsweise einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Isom.Plan.TherapyPlanAction
Die Funktion liefert immer ein Void-Objekt.
Ausnahmebehandlung:
Void wird von dieser Funktion immer geliefert.
Datum:
letzte Änderung am 10.09.2010
[Isom\Plan\TherapyPlanAction.is: 2588]


für Serviceautoren

Isom.Plan.TherapyPlanActionList

Namensraum Isom.Plan.TherapyPlanActionList

Liste von Therapieplanaktionen. Mehr...

Funktionen
Isom.Plan.TherapyPlanActionList | CreateNew()

Erzeugt eine neue, leere Liste von Therapieplanaktionen.

Listenfunktionen

Isom.Plan.TherapyPlanAction | At(Isom.Base.Number index)

Gibt ein Listenelement zurück.

Isom.Base.Boolean | Contains(Isom.Plan.TherapyPlanAction element)

Prüft, ob ein Element in der Liste vorhanden ist.

Isom.Plan.TherapyPlanAction | Current()

Liefert das Listenelement an der aktuellen Position des Iterators.

Isom.Base.Boolean | HasNext()

Gibt an, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Isom.Base.Number | Insert(Isom.Plan.TherapyPlanAction element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Gibt an, ob diese Liste leer ist.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Plan.TherapyPlanAction | Next()

Liefert die nächste Therapieplanaktion in der Liste.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt ein Element aus der Liste.

Isom.Base.Boolean | Reset()

Setzt den Iterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Plan.TherapyPlanActionList | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Plan.TherapyPlanActionList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Eine Liste von Aktionen.

Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:

  • der indizierte Zugriff mit der Funktion At()
  • das Durchlaufen der Liste mit den Funktionen HasNext() und Next(). Vor dem Durchlaufen sollte Reset() aufgerufen werden.

  // Liste erstellen
  Isom.Plan.TherapyPlanActionList actions = Isom.Plan.TherapyPlanActionList.CreateNew();

  Isom.Base.Boolean empty = actions.IsEmpty();    // gibt 'true' zurück

  // Liste befüllen (mit drei nicht Steuergeräte-bezogenen Aktionen)
  Isom.Plan.TherapyPlan tp = Isom.Plan.TherapyPlan.GetInstance();
  actions.Insert( tp.CreateAction("DeployVehicleOrder") );
  actions.Insert( tp.CreateAction("RetrieveUserProfile") );
  actions.Insert( tp.CreateAction("ClearErrorMemory") );

  empty = actions.IsEmpty();                      // gibt 'false' zurück
  Isom.Base.Number size = actions.Length();       // gibt '3' zurück

  // indizierter Zugriff
  Isom.Plan.TherapyPlanAction action = actions.At(1); // gibt die Aktion 'RetrieveUserProfile' zurück
  action = actions.At(3);                             // gibt 'Void' zurück, da der Index zu groß ist

  // Durchlaufen der Liste
  actions.Reset();                // Iterator zurücksetzen
  while(actions.HasNext())
  {
      action = actions.Next();    // Zugriff auf das nächste Listenelement
      Isom.Sys.System.Stdout(action.GetName());               // Name des aktuellen Listenelements (über lokale Variable) ausgeben
      Isom.Sys.System.Stdout(actions.Current().GetName());    // Name des aktuellen Listenelements (über aktuellen Index) ausgeben
  }

  if( actions.Contains( tp.CreateAction("RetrieveUserProfile") ) )    // 'true'
  {
      // ...
  }

  actions.Remove(0);             // entfernt erstes Element
  size = actions.Length();       // gibt '2' zurück
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010

Quelldateien:

  • Isom\Plan\TherapyPlanActionList.is

Dokumentation der Funktionen

objectbound Isom.Plan.TherapyPlanAction Isom.Plan.TherapyPlanActionList.At ( Isom.Base.Number index )

Gibt ein Listenelement zurück.

Ruft das Element aus der Liste ab, das durch den (Null-basierten) Index ausgewählt wird.

Parameter:
index Index.
Rückgabe:
Isom.Plan.TherapyPlanAction
Ausgewählte Therapieplanaktion.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 ist oder größer gleich der Anzahl der Listenelemente.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 312]
objectbound Isom.Plan.TherapyPlanActionList Isom.Plan.TherapyPlanActionList.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Isom.Plan.TherapyPlanActionList
Das geklonte Objekt.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 433]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanActionList.Contains ( Isom.Plan.TherapyPlanAction element )

Prüft, ob ein Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element.
Rückgabe:
Isom.Base.Boolean
'true', falls das Element gefunden werden konnte, 'false' sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 388]
Isom.Plan.TherapyPlanActionList Isom.Plan.TherapyPlanActionList.CreateNew ( )

Erzeugt eine neue, leere Liste von Therapieplanaktionen.

Rückgabe:
Isom.Plan.TherapyPlanActionList
neue, leere Liste.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 146]
objectbound Isom.Plan.TherapyPlanAction Isom.Plan.TherapyPlanActionList.Current ( )

Liefert das Listenelement an der aktuellen Position des Iterators.

Zu beachten:
Diese Funktion sollte nur beim Iterieren über die Liste verwendet werden.
Rückgabe:
Isom.Plan.TherapyPlanAction
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Iterator zurückgesetzt wurde.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 264]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanActionList.HasNext ( )

Gibt an, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Rückgabe:
Isom.Base.Boolean
'true', falls noch Werte in der Liste zur Verfügung stehen, 'false' sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 209]
objectbound Isom.Base.Number Isom.Plan.TherapyPlanActionList.Insert ( Isom.Plan.TherapyPlanAction element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Iterator, wird durch diese Operation zurückgesetzt.

Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügende Therapieplanaktion.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 343]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanActionList.IsEmpty ( )

Gibt an, ob diese Liste leer ist.

Rückgabe:
Isom.Base.Boolean
'true', falls die Liste leer ist, 'false' sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 190]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanActionList.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
Isom.Base.Boolean
'true', falls dies das Void-Objekt ist, 'false' sonst.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 416]
objectbound Isom.Base.Number Isom.Plan.TherapyPlanActionList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

Rückgabe:
Isom.Base.Number
Anzahl der Elemente.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 173]
objectbound Isom.Plan.TherapyPlanAction Isom.Plan.TherapyPlanActionList.Next ( )

Liefert die nächste Therapieplanaktion in der Liste.

Diese Funktion setzt den Iterator der Liste auf das nächste Element und gibt dieses Element zurück.

Zu beachten:
Diese Funktion sollte zum Iterieren über die Liste verwendet werden.
Vor dem Iterieren sollte der Iterator mit Reset() zurückgesetzt werden.
Rückgabe:
Isom.Plan.TherapyPlanAction
Nächstes Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 240]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanActionList.Remove ( Isom.Base.Number index )

Entfernt ein Element aus der Liste.

Entfernt das durch den Index gekennzeichnete Element aus der Liste. Ein eventuell aktiver Iterator wird durch diese Operation zurückgesetzt.

Parameter:
index Index.
Rückgabe:
Isom.Base.Boolean
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt).
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 369]
objectbound Isom.Base.Boolean Isom.Plan.TherapyPlanActionList.Reset ( )

Setzt den Iterator zurück.

Setzt den Iterator auf die Position vor dem ersten Element der Liste.

Rückgabe:
Isom.Base.Boolean
Immer 'true'.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 285]
Isom.Plan.TherapyPlanActionList Isom.Plan.TherapyPlanActionList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Isom.Plan.TherapyPlanActionList
Ungültiges Objekt.
Autor:
IFS Informationstechnik München
Datum:
letzte Änderung am 05.05.2010
[Isom\Plan\TherapyPlanActionList.is: 453]


für Serviceautoren

Isom.Reporting

Namensraum Isom.Reporting

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Reporting.Report | Berichtsdaten für ein formatiert druckbares Dokument.
Isom.Reporting.ReportSection | Berichts-Absatz (logisches Gliederungs-Element/Struktureller Abschnitt von Berichtsdaten).
Isom.Reporting.ReportSectionList | Liste von Report-Abschnitten des Typs Isom.Reporting.ReportSection


für Serviceautoren

Isom.Reporting.Report

Namensraum Isom.Reporting.Report

Berichtsdaten für ein formatiert druckbares Dokument. Mehr...

Funktionen
Instanz-Zugriff / Instanz-Erzeugung

Ermittlung oder Erzeugung eines Bericht-Fachobjekts.

Isom.Reporting.Report | CreateReport(Isom.Base.String id)

Erzeugt eine neue, leere Objekt-Instanz mit der vorgegebenen ID.

Isom.Base.StringList | GetExistingReports()

Ruft eine Liste der IDs aller bereits erzeugten Report-Objekte ab

Isom.Reporting.Report | GetReport(Isom.Base.String id)

Greift auf eine Objekt-Instanz über die vorgegebene ID zu.

Logische Berichts-Struktur

Gliederungs-Baum eines Berichts.

Isom.Base.Boolean | AddSection(Isom.Reporting.ReportSection sect)

Fügt einen Absatz zum Bericht hinzu.

Isom.Reporting.ReportSection | CreateReportSection(Isom.Base.String id)

Erzeugt eine neue, leere Objektinstanz eines Bericht-Absatzes.

Isom.Reporting.ReportSection | GetReportSection(Isom.Base.String id)

Greift auf den über Id benannten, existierenden Berichtsabschnitt zu.

Isom.Reporting.ReportSectionList | GetReportSectionList()

Listen-Zugriff auf die Objekt-Absätze.

Isom.Base.Boolean | RemoveSection(Isom.Reporting.ReportSection sect)

Entfernt einen Absatz aus dem Bericht.

Kopf- und Formatierungsdaten

Setzen von Kopf- und Formatierungsdaten des Berichts.

Isom.Base.Boolean | SetTemplate(Isom.Base.String templateID)

Setzt die ID/den Namen des Templates, der zur Formatierung des Berichts dient und lädt das zugehörige Template.

Isom.Base.Boolean | SetTitle(Isom.Base.String title)

Setzt die die Überschrift für den Bericht.

Veröffentlichung / Aktivschaltung von Berichten

Anzeigbarmachen / Statusabfrage eines Berichts.

Isom.Base.Boolean | IsPublished()

Prüft, ob für den Bericht bereits Report.Publish() für dieses Objekt mindestens einmal aufgerufen wurde.

Isom.Base.Boolean | Publish()

Registriert die Report-Instanz unter dem angegebenen technischen Namen und macht den Report damit offiziell/anzeigbar.

Vollständigkeits-Prüfung

Prüfen der Befüllung durch den Autor / Ermittlung fehlender Daten.

Isom.Base.StringList | GetMissingIdPaths()

Ermittelt die ID-Pfade aller Sektionen / Elemente, die noch nicht hinreichend befüllt sind, um ihrem Template zu genügen.

Debugging-Unterstützung

Unterstützende Hilfsfunktionen fürs Tracing / Logging / Debugging.

Isom.Base.String | GetAsciiArt()

Ermittelt die Dokumentstruktur als ASCII (für das Debugging / Tracing).

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Reporting.Report | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Reporting.Report | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Ein Bericht ist ein ISOM-Datenhalter für Informationen, die strukturiert und ggf. formatiert dargestellt werden sollen. Die Formatierung selbst ist jedoch nicht Gegenstand des ISOM-Berichtsobjekts, sondern wird durch den jeweiligen Client bestimmt. Ein Bericht ist in Berichts-Kapitel gegliedert (s. Isom.Reporting.ReportSection). Darüberhinaus dienen ReportSection's der strukturellen Zusammenfassung zusammengehöriger Informationen.

Zusammenhängendes Beispiel für die Benutzung von 'Isom.Reporting'

Verwendungsbeispiel:
Das Beispiel zeigt den Aufbau eines Aktionsplans mit folgenden Charakteristiken:
  • mit Titel
  • erste Sektion: allgemeiner Text mit benannten Ecu-Bezügen
  • zweite Sektion: Aktionsliste
    • Nebeneinanderdarstellung nach Kanälen
    • beliebiger Elementzahl Kanal-Spalte
    • je Aktionslisten-Eintrag Aktion und Image assoziieren
  • dritte Sektion:
    • 2 fixe abschließende Hinweise (Client-generiert)
    • ISOM-generierte Hinweisliste mit beliebiger Elementzahl

Das folgende Beispiel zeigt die Template-Definition:

   <!-- @file ?OEMScripsDir?\ReportTemplates\IsomReportTemplate_COMPLETEPLAN_PARALLEL.xml -->
   <IsomReport Id="CompletePlan" StyleTemplate="COMPLETEPLAN_PARALLEL">
     <Title/>
     <SubSections>

       <Section IsTemplate="false" Id="Header">
         <Title />
         <SubSections />
         <Elements>
           <Element IsTemplate="false" DataObject="[Isom.DataModel.IsomStringDO : [TextId=$Client_String_MP]]" />
           <Element IsTemplate="false" DataObject="[Isom.DataModel.IsomStringDO : [TextId=$Client_String_MainGatewayIs]]" />
           <Element IsTemplate="true" Id="TopLevelGw" MinRepeat="1" MaxRepeat="1" DataObject="[Isom.DataModel.IsomEcuDO2]" />
         </Elements>
       </Section>

       <Section IsTemplate="false" Id="Actions">
         <Title />
         <Elements />
         <SubSections>
           <Section IsTemplate="true" MinRepeat="0" MaxRepeat="3">
             <Elements>
               <Element IsTemplate="true" MinRepeat="0" MaxRepeat="999" DataObject="[Isom.DataModel.IsomTherapyPlanActionDO2]" />
               <Element IsTemplate="true" MinRepeat="0" MaxRepeat="999" DataObject="[Isom.Interface.IsomMediaElement]" />
             </Elements>
             <SubSections />
           </Section>
         </SubSections>
       </Section>

       <Section IsTemplate="false" Id="Footer">
         <SubSections />
         <Elements>
           <Element IsTemplate="false" DataObject="[Isom.DataModel.IsomStringDO : [TextId=$Client_String_NochZuTun]]" />
           <Element IsTemplate="false" DataObject="[Isom.DataModel.IsomStringDO : [TextId=$Client_String_Hint]]" />
           <Element IsTemplate="true" MinRepeat="0" MaxRepeat="999" DataObject="[Isom.DataModel.IsomStringDO]" />
         </Elements>
       </Section>

     </SubSections>
     <Elements>
       <Element Id="xxx" IsTemplate="false" DataObject="[Isom.DataModel.IsomStringDO : [TextId=$Client_String_NochZuTun]]" />
     </Elements>
   </IsomReport>

Das folgende Beispiel zeigt die Template-Befüllung in ISOM/L:

   /// @file Vendor.is
   using Isom.Base.*
   using Isom.Reporting.*;

  namespace Vendor
  {
   ...
    /// @brief Berechnet den endgültigen Therapieplan.
    Boolean CalculateFinalPlan ()
    {
      // ...

      / Report instanzieren + grundbefüllen
      String rptID = "CompletePlan"; // -- ein Aktionsplan --
      Report rpt = Report.GetReport( rptID );
      if( rpt.IsVoid() )
      {
        rpt = Report.CreateReport( rptID );
      }
      rpt.SetTemplate( "COMPLETEPLAN_PARALLEL" ); // initiiert Baum-Init.
      rpt.SetTitle( Texts.TITLE_REPORT_COMPLETEPLAN_PARALLEL ); // -- mit Titel

      // -- erste Sektion: allgemeiner Text mit benannten Ecu-Bezügen. --
      String sectID = "Header";
      ReportSection sec = rpt.GetReportSection( sectID );
      if( sec.IsVoid().Not() ) // nur wenn Client-vorgegeben // Titel,Style,Text vom Client
      {
        sec.SetEcu( "TopLevelGw", Helpers.GetTopLevelGateway() );
      }

      // -- zweite Sektion: Aktionsliste --
      sectID = "Actions";
      sec = rpt.GetReportSection( sectID );
      if( sec.IsVoid().Not() ) // nur wenn Client-vorgegeben // Titel,Style,Text vom Client
      {
        StringList phaseIdList = ap.GetPhases (); // Aktionsplan iterieren
        phaseIdList.Reset ();
        while (phaseIdList.HasNext ())   // ... Phasen
        {
          ActionPlanPhase app = ap.GetPhase (phaseIdList.Next ());
          StringList channels = app.GetChannels();
          while( channels.HasNext() )   // ... Kanäle=Pfade
          {
            String channel = channels.Next();

            // Abschnitt instanzieren + grundbefüllen
            ReportSection sub = sec.GetSubSection( channel );
            if( sub.IsVoid() )
            {
              // ReportSection instannzieren + grundbefüllen
              sub = rpt.CreateReportSection( channel );
              sub.SetTitle( channel );
              sec.AddSection( sub );
              // ...Der Client muss wissen, dass
              //  * Abschnitte dieses Templates nebeneinander horizontal verteilt UND
              //  * assoziierte Aktionen innerhalb der Spalten unterenander
              //  darzustellen sind.
            }

            // Abschnitt mit Fachobjekten/Darstellungselementen befüllen
            // ... Aktionen
            TherapyPlanActionList actions= app.GetActionList(channel);
            actions.Reset();
            while ( actions.HasNext() )
            {
            // -- je Aktionslisten-Eintrag Aktion und Image assoziieren --
              TherapyPlanAction action = actions.Next();
              String path = "media/"; path.Append(action.GetName()); path.Append(".png");
              MediaElement img = MediaElement.CreateMediaElement( path, path );

              // -- beliebiger Elementzahl je Pfad --
              sub.SetTherapyPlanAction( "", action ); // ID numerisch, aufsteigend
              sub.SetMediaElement   ( "", img  ); // gleiche numerische ID
              // Wenn der gesetzte Typ nicht zum Template passt, wird Void zurückgegeben.
            // Die Zuordnung Aktion<-->Mediaelement erfolgt über Reihenfolge oder ID-#.
            }
          }
        }
      }

      // -- dritte Sektion: --
      // -- 2 fixe abschließende Hinweise (Client-generiert) --
      // -- ISOM-generierte Hinweisliste mit beliebiger Elementzahl --
      sectID = "Footer";
      sec = rpt.GetReportSection( sectID );
      if( sec.IsVoid().Not() ) // nur wenn Client-vorgegeben // Titel, Style, Text vom Client
      {
        StringDictionary msgDict = TherapyPlan.GetInstance ().GetAllMessages();
        StringList keys = msgDict.GetKeys ();
        keys.Reset();
        while(keys.HasNext())
        {
          sec.SetText( "", msgDict.Get(keys.Next()) ); // ID numerisch, aufsteigend
        }
      }

      // Setzen/Notifizieren
      rpt.Publish();
    }
Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Reporting\Report.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Reporting.Report.AddSection ( Isom.Reporting.ReportSection sect )

Fügt einen Absatz zum Bericht hinzu.

   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.CreateReportSection( "Actions" );
      report.AddSection( section );

      // section.Set...()
Parameter:
sect hinzuzufügender Absatz.
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
[Isom\Reporting\Report.is: 449]
objectbound Isom.Reporting.Report Isom.Reporting.Report.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Reporting\Report.is: 680]
Isom.Reporting.Report Isom.Reporting.Report.CreateReport ( Isom.Base.String id )

Erzeugt eine neue, leere Objekt-Instanz mit der vorgegebenen ID.

Zu beachten:
Für ein zusammenhängendes Beispiel siehe Report.
   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      // Neuen, leeren AB erzeugen
      Report report = Report.CreateReport("FinalReport");

      // report. ...
Rückgabe:
Objektinstanz oder 'Void'.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die ID Void oder die ID leer ist.
Es wird das Void-Objekt zurückgegeben, falls für die ID bereits ein Bericht existiert.
[Isom\Reporting\Report.is: 326]
objectbound Isom.Reporting.ReportSection Isom.Reporting.Report.CreateReportSection ( Isom.Base.String id )

Erzeugt eine neue, leere Objektinstanz eines Bericht-Absatzes.

Achtung:
Die Funktion Report.CreateReportSection() ist nur zu verwenden, wenn das zugehörige Template auf der obersten Ebene des Baums definiert ist, d.h. wenn ein First-Level-Zweig erzeugt werden soll. Für tieferliegende Ebenen ist stattdessen ReportSection.CreateReportSection() zu verwenden.
Zu beachten:
Für ein zusammenhängendes Beispiel siehe Report.
   using Isom.Base.*;
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.CreateReportSection( "Messages" );
      report.AddSection( section );

      // section.Set...()
Rückgabe:
Objektinstanz.
[Isom\Reporting\Report.is: 382]
objectbound Isom.Base.String Isom.Reporting.Report.GetAsciiArt ( )

Ermittelt die Dokumentstruktur als ASCII (für das Debugging / Tracing).

   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      Report report  = Report.CreateReport("FinalReport");
      // ... fill 'report'
      System.Stdout( report.GetAsciiArt() );
Rückgabe:
Dokumentstruktur als ASCII (mit Zeilenumbrüchen).
[Isom\Reporting\Report.is: 649]
Isom.Base.StringList Isom.Reporting.Report.GetExistingReports ( )

Ruft eine Liste der IDs aller bereits erzeugten Report-Objekte ab

   StringList existingReports = Report.GetExistingReports();
Rückgabe:
Eine Liste der Bezeichnungen aller bereits erzeugter Report-Objekte
[Isom\Reporting\Report.is: 339]
objectbound Isom.Base.StringList Isom.Reporting.Report.GetMissingIdPaths ( )

Ermittelt die ID-Pfade aller Sektionen / Elemente, die noch nicht hinreichend befüllt sind, um ihrem Template zu genügen.

Rückgabe:
ID-Pfade mit fehlenden informationen.
[Isom\Reporting\Report.is: 619]
Isom.Reporting.Report Isom.Reporting.Report.GetReport ( Isom.Base.String id )

Greift auf eine Objekt-Instanz über die vorgegebene ID zu.

Zu beachten:
Das Objekt wird dabei nicht bedarfs-erzeugt.
Für ein zusammenhängendes Beispiel siehe Report.
   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      Report report  = Report.GetReport("FinalReport");
      if( report.IsVoid() )
      {
          report = Report.CreateReport("FinalReport");
      }

      // report. ...
Rückgabe:
Objektinstanz oder 'Void'.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die ID Void oder leer ist.
Es wird das Void-Objekt zurückgegeben, falls für die ID bereits ein Bericht existier.
[Isom\Reporting\Report.is: 301]
objectbound Isom.Reporting.ReportSection Isom.Reporting.Report.GetReportSection ( Isom.Base.String id )

Greift auf den über Id benannten, existierenden Berichtsabschnitt zu.

Zu beachten:
Für ein zusammenhängendes Beispiel siehe Report.
Siehe auch:
Isom.Reporting.Report.SetTemplate() für das Zurücksetzen des Objekts auf Leerzustand mit Templates.
   using Isom.Base.*;
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetReportSection( "Messages" );

      // section.Set...()
Rückgabe:
Objektinstanz oder 'Void'.
[Isom\Reporting\Report.is: 405]
objectbound Isom.Reporting.ReportSectionList Isom.Reporting.Report.GetReportSectionList ( )

Listen-Zugriff auf die Objekt-Absätze.

   using Isom.Base.*;
   using Isom.Reporting.*;
   ...
      Report report = ...;
      ReportSectionList sections = report.GetReportSectionList();
      sections.Reset();
      while( sections.HasNext() )
      {
          ReportSection section = sections.Next();
          // ...
      }
Rückgabe:
Liste (ggf. leer).
[Isom\Reporting\Report.is: 428]
objectbound Isom.Base.Boolean Isom.Reporting.Report.IsPublished ( )

Prüft, ob für den Bericht bereits Report.Publish() für dieses Objekt mindestens einmal aufgerufen wurde.

Rückgabe:
'true' wenn bereits publiziert, 'false' sonst.
[Isom\Reporting\Report.is: 596]
objectbound Isom.Base.Boolean Isom.Reporting.Report.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Reporting\Report.is: 671]
objectbound Isom.Base.Boolean Isom.Reporting.Report.Publish ( )

Registriert die Report-Instanz unter dem angegebenen technischen Namen und macht den Report damit offiziell/anzeigbar.

Zu beachten:
Mehrfachregistrierung des gleichen Reports unter verschiendenen Namen ist nicht möglich.
Es wird eine Warnung 'Der publizierte Bericht '...' enthält unvollständige Elemente' geloggt, wenn das Report-Objekt nicht vollständig befüllt ist.
   // @file Consts.is
    deftext INTERNAL NAMECONST_REPORT_COMPLETEPLAN "CompletePlan"
    deftext INTERNAL NAMECONST_REPORT_FINALPLAN    "FinalPlan"

   // @file Vendor.is
   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      Report report  = Report.CreateReport("FinalReport");
      // ... fill 'report'
      report.Publish( Consts.NAMECONST_REPORT_COMPLETEPLAN );
      report.Publish( Consts.NAMECONST_REPORT_FINALPLAN );
Rückgabe:
'true' im Erfolgsfall.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls 'Void' als ID übergeben wurde.
Es wird das Void-Objekt zurückgegeben, falls ein Leerstring als ID übergeben wurde.
[Isom\Reporting\Report.is: 585]
objectbound Isom.Base.Boolean Isom.Reporting.Report.RemoveSection ( Isom.Reporting.ReportSection sect )

Entfernt einen Absatz aus dem Bericht.

   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      report.RemoveSection( section );
Parameter:
sect zu entfernender Absatz.
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
[Isom\Reporting\Report.is: 468]
objectbound Isom.Base.Boolean Isom.Reporting.Report.SetTemplate ( Isom.Base.String templateID )

Setzt die ID/den Namen des Templates, der zur Formatierung des Berichts dient und lädt das zugehörige Template.

Achtung:
Da die Template-ID die Schablone bestimmt, muss der Aufruf von Report.SetTemplate(...) vor allen Zuweisungen erfolgen.
Ein späterer Neuaufruf von Report.SetTemplate(...) mit abweichender templateID löscht vorherige Zuweisungen und Templates.
Zu beachten:
Welche IDs zulässig sind, obliegt einem Kontrakt zwischen ISOM/L-Programmen und Anzeigeapplikation ("Client").
Es sollten nur IDs verwendet werden, für die ein Template in den Servicedaten existiert.
   // @file Consts.is
    deftext INTERNAL STYLECONST_REPORT_COMPLETEPLAN_PARALLEL "COMPLETEPLAN_PARALLEL"

   // @file Vendor.is
   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      Report report  = Report.CreateReport("FinalReport");
      report.SetTemplate( Consts.STYLECONST_REPORT_COMPLETEPLAN_PARALLEL );
Parameter:
templateID technische ID (beliebige Zeichenkette).
Rückgabe:
eindeutiger ID/den Namen des Templates (technisch; nicht-übersetzbar).
[Isom\Reporting\Report.is: 513]
objectbound Isom.Base.Boolean Isom.Reporting.Report.SetTitle ( Isom.Base.String title )

Setzt die die Überschrift für den Bericht.

Die Übergabe von 'Void' setzt die Überschrift zurück.

   // @file Texts.is
    deftext TITLE TITLE_REPORT_COMPLETEPLAN_PARALLEL "Aktionsplan (Parallel-Darstellung)"

   // @file Vendor.is
   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      Report report  = Report.CreateReport("FinalReport");
      report.SetTitle( Texts.TITLE_REPORT_COMPLETEPLAN_PARALLEL );
Parameter:
title Absatz-[Unter]Überschrift (übersetzbar).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls dem Report noch kein Template zugewiesen wurde (vgl. Report.SetTemplate(...)).
[Isom\Reporting\Report.is: 538]
Isom.Reporting.Report Isom.Reporting.Report.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Reporting\Report.is: 692]


für Serviceautoren

Isom.Reporting.ReportSection

Namensraum Isom.Reporting.ReportSection

Berichts-Absatz (logisches Gliederungs-Element/Struktureller Abschnitt von Berichtsdaten). Mehr...

Funktionen
Logische Berichts-Struktur

Gliederungs-Baum eines Berichts oder Berichtabschnitts.

Isom.Base.Boolean | AddSubsection(Isom.Reporting.ReportSection sect)

Fügt einen Absatz zum Bericht hinzu.

Isom.Base.Boolean | RemoveSubsection(Isom.Reporting.ReportSection sect)

Entfernt einen Absatz aus dem Bericht.

Instanz-Zugriff / Instanz-Erzeugung

Ermittlung oder Erzeugung eines Berichtsabsatz-Fachobjekts.

Isom.Reporting.ReportSection | CreateSubsection(Isom.Base.String id)

Erzeugt eine neue, leere Objektinstanz eines Bericht-Absatzes.

Isom.Reporting.ReportSectionList | GetReportSectionList()

Greift auf alle Unterabschnitte des aktuellen Abschnitts zu.

Isom.Reporting.ReportSection | GetSubsection(Isom.Base.String id)

Greift auf einen benannten Unterabschnitt des aktuellen Abschnitts zu.

Kopf- und Formatierungsdaten

Kopf- und Formatierungsdaten des Berichtsabschnitts. (Die Einfügereihenfolge bestimmt üblicherweise auch die Darstellungsreihenfolge.)

Isom.Base.Boolean | SetTemplate(Isom.Base.String templateID)

Setzt die ID/den Namen des Templates, der zur Strukturdefinition/Formatierung des Bericht-Absatzes dient.

Isom.Base.Boolean | SetTitle(Isom.Base.String title)

Setzt die die Überschrift für den Bericht-Absatz.

Assoziierte Darstellungselemente

Nichtfachliche Darstellungselemente, die im Bericht dargestellt werden sollen. (Die Einfügereihenfolge bestimmt üblicherweise auch die Darstellungsreihenfolge.)

Isom.Request.MediaElement | GetMediaElement(Isom.Base.String key)

Ermittelt ein Darstellungselement vom Typ "MediaElement" innerhalb des Bericht-Absatzes.

Isom.Base.String | GetText(Isom.Base.String key)

Ermittelt ein Darstellungselement vom Typ "Text" innerhalb des Bericht-Absatzes.

Isom.Base.Boolean | SetMediaElement(Isom.Base.String key, Isom.Request.MediaElement medium)

Setzt ein Darstellungselement vom Typ "Medienobjekt" (Grafiken/Videos/etc) innerhalb des Bericht-Absatzes.

Isom.Base.Boolean | SetSeparator(Isom.Base.String key, Isom.Base.String sepType)

Setzt ein Trennzeichen-Darstellungselement welches der Client für Formatierungszwecke verwenden kann.

Isom.Base.Boolean | SetText(Isom.Base.String key, Isom.Base.String msg)

Setzt ein Darstellungselement vom Typ "Text" innerhalb des Bericht-Absatzes.

Assoziierte Fachobjekte

Fachobjekte, die im Bericht dargestellt werden sollen. (Die Einfügereihenfolge bestimmt üblicherweise auch die Darstellungsreihenfolge.)

Isom.Base.Date | GetDate(Isom.Base.String key)

Ermittelt ein Kontextelement vom Typ "Date"/Zeitpunkt innerhalb des Bericht-Absatzes.

Isom.Context.Ecu | GetEcu(Isom.Base.String key)

Ermittelt ein Kontextelement vom Typ "Ecu"/Steuergerät innerhalb des Bericht-Absatzes.

Isom.Sys.Error | GetError(Isom.Base.String key)

Ermittelt ein Kontextelement vom Typ "Error" innerhalb des Bericht-Absatzes.

Isom.Plan.TherapyPlanAction | GetTherapyPlanAction(Isom.Base.String key)

Ermittelt ein Kontextelement vom Typ "TherapyPlanAction" innerhalb des Bericht-Absatzes.

Isom.Context.UserProfileSetting | GetUserProfileSetting(Isom.Base.String key)

Ermittelt ein Kontextelement vom Typ "UserProfileSetting"/Einstellung innerhalb des Bericht-Absatzes.

Isom.Base.Boolean | SetDate(Isom.Base.String key, Isom.Base.Date date)

Setzt ein Kontextelement vom Typ "Date"/Zeitpunkt innerhalb des Bericht-Absatzes.

Isom.Base.Boolean | SetEcu(Isom.Base.String key, Isom.Context.Ecu ecu)

Setzt ein Kontextelement vom Typ "Ecu"/Steuergerät innerhalb des Bericht-Absatzes.

Isom.Base.Boolean | SetError(Isom.Base.String key, Isom.Sys.Error err)

Setzt ein Kontextelement vom Typ "Error"/registrierter Fehler innerhalb des Bericht-Absatzes.

Isom.Base.Boolean | SetTherapyPlanAction(Isom.Base.String key, Isom.Plan.TherapyPlanAction action)

Setzt ein Kontextelement vom Typ "TherapyPlanAction"/Aktion innerhalb des Bericht-Absatzes.

Isom.Base.Boolean | SetUserProfileSetting(Isom.Base.String key, Isom.Context.UserProfileSetting setting)

Setzt ein Kontextelement vom Typ "UserProfileSetting"/Einstellung innerhalb des Bericht-Absatzes.

Erweiterungsmechanismus Eigenschaften

Übermittlung zusätzlicher Parametrisierungs- und/oder Anzeigedaten.

Isom.Base.String | GetDisplayProp(Isom.Base.String propName)

Ermittelt einen [potentiell übersetzbaren] Property-Wert.

Isom.Base.StringList | GetDisplayPropNames()

Liefert die Namen aller Anzeige-Eigenschaften des Bericht-Absatzes.

Isom.Base.Boolean | SetDisplayProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt einen [potentiell übersetzbaren] Eigenschafts-Wert.

Technische Identifizierung und Suche

Isom.Base.String | GetKey()

Ermittelt die technische ID des Abschnitts.

Vollständigkeits-Prüfung

Prüfen der Befüllung durch den Autor / Ermittlung fehlender Daten.

Isom.Base.StringList | GetElementKeysByType(Isom.Base.String typeSpec)

Ermittelt die technischen ID's aller im Abschnitt unmittelbar enthaltenen Elemente eines vorgegebenen Typs.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Reporting.ReportSection | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Reporting.ReportSection | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Ein Berichts-Absatz entspricht einem ISOM-Datenhalter für ein Kapitel innerhalb eines Berichts (s. Isom.Reporting.Report). Er kann eine Überschrift haben und ihm kann eine Formatierungsvorschrift zugewiesen werden. Die Formatierung selbst ist jedoch nicht Gegenstand des ISOM-Berichtsobjekts. Für einen Berichts-Absatz kann vom Client ein Template zugewiesen sein, welches festlegt welche Elementetypen mit welcher ID oder mit welcher Multiziplität dem Berichtsabschnittzugewiesen werden können.

Zu beachten:
Für ein zusammenhängendes Beispiel siehe Report.

Quelldateien:

  • Isom\Reporting\ReportSection.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.AddSubsection ( Isom.Reporting.ReportSection sect )

Fügt einen Absatz zum Bericht hinzu.

   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      ReportSection sub = section.GetSubsection( "Messages" );
      section.AddSubSection( sub );
Parameter:
sect hinzuzufügender Absatz.
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls 'Void' als Parameter übergeben wurde.
Es wird das Void-Objekt zurückgegeben, falls dem Report noch kein Template zugewiesen wurde (vgl\. Report.SetTemplate(...)).
Es wird das Void-Objekt zurückgegeben, falls durch das Hinzufügen eine Rekursion ausgelöst würde.
Es wird das Void-Objekt zurückgegeben, falls für die ID des übergebenen Absatzes kein Template gefunden wurde.
Es wird das Void-Objekt zurückgegeben, durch das Hinzufügen der Zähler 'MaxRepeat" des Templates überschritten würde.
[Isom\Reporting\ReportSection.is: 157]
objectbound Isom.Reporting.ReportSection Isom.Reporting.ReportSection.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Reporting\ReportSection.is: 975]
objectbound Isom.Reporting.ReportSection Isom.Reporting.ReportSection.CreateSubsection ( Isom.Base.String id )

Erzeugt eine neue, leere Objektinstanz eines Bericht-Absatzes.

Achtung:
Die Funktion Report.CreateSubsection() ist nur zu verwenden, wenn das zugehörige Template auf der Obersten Ebene des Baums definiert ist, d.h. wenn ein First-Level-Zweig erzeugt werden soll\. Nur für tieferliegende Ebenen ist ReportSection.CreateSubsection() zu verwenden.
Zu beachten:
Für ein zusammenhängendes Beispiel siehe Report.
   using Isom.Base.*;
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      ReportSection sub = section.CreateSubsection( "Messages" );
      section.AddSubSection( sub );
Rückgabe:
Objektinstanz.
[Isom\Reporting\ReportSection.is: 225]
objectbound Isom.Base.Date Isom.Reporting.ReportSection.GetDate ( Isom.Base.String key )

Ermittelt ein Kontextelement vom Typ "Date"/Zeitpunkt innerhalb des Bericht-Absatzes.

Parameter:
key Identifizierende Zeichenkette (techn. ID).
Rückgabe:
Kontextelement oder 'Void'.
[Isom\Reporting\ReportSection.is: 679]
objectbound Isom.Base.String Isom.Reporting.ReportSection.GetDisplayProp ( Isom.Base.String propName )

Ermittelt einen [potentiell übersetzbaren] Property-Wert.

Zu beachten:
Für ein zusammenhängendes Beispiel siehe Report.
   // @file Consts.is
    deftext INTERNAL REPORTPROPNAME_FORMATTINGHINT "FormattingHint"
    deftext INTERNAL REPORTPROPVALUE_BLUE          "Color:Blue" // Client-interpretiert

   // @file Vendor.is
   using Isom.Base.*;
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      String propName = Consts.REPORTPROPNAME_FORMATTINGHINT;
      if( section.GetDisplayProp( propName ).IsVoid() )
      {
        String propVal = Consts.REPORTPROPVALUE_BLUE;
        section.SetDisplayProp( propName, propVal ); // Client-interpretiert
      }
Parameter:
propName Name der Eigenschaft (Groß-Kleinschreibung signifikant).
Rückgabe:
Property-Wert.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Wert ungesetzt ist.
[Isom\Reporting\ReportSection.is: 797]
objectbound Isom.Base.StringList Isom.Reporting.ReportSection.GetDisplayPropNames ( )

Liefert die Namen aller Anzeige-Eigenschaften des Bericht-Absatzes.

Es werden die Eigenschaftsnamen für die Anzeige-Eigenschaften (siehe Isom.Reporting.ReportSection.GetDisplayProp()) zurückgeliefert.

   Report        report  = Report.CreateReport("FinalReport");
   ReportSection section = report.GetSubsection( "Actions" );
   StringList displayPropertyNames = section.GetDisplayPropNames();
   displayPropertyNames.Reset();
   while(displayPropertyNames.HasNext())
   {
     //Abfrage des Werts für den gelieferten Eigenschaftsnamen und z. B. Aufzeichnung ins Protokoll
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller Anzeige-Eigenschaften des Bericht-Absatzes.
Siehe auch:
Isom.Reporting.ReportSection.GetDisplayProp()
Datum:
letzte Änderung am 09.09.2010
[Isom\Reporting\ReportSection.is: 865]
objectbound Isom.Context.Ecu Isom.Reporting.ReportSection.GetEcu ( Isom.Base.String key )

Ermittelt ein Kontextelement vom Typ "Ecu"/Steuergerät innerhalb des Bericht-Absatzes.

Parameter:
key Identifizierende Zeichenkette (techn. ID).
Rückgabe:
Kontextelement oder 'Void'.
[Isom\Reporting\ReportSection.is: 584]
objectbound Isom.Base.StringList Isom.Reporting.ReportSection.GetElementKeysByType ( Isom.Base.String typeSpec )

Ermittelt die technischen ID's aller im Abschnitt unmittelbar enthaltenen Elemente eines vorgegebenen Typs.

   using Isom.Base.*;
   using Isom.Reporting.*;
   ...
      ReportSection section = ...;
      String typeSpec = "[Isom.DataModel.IsomStringDO]";
      StringList idList = section.GetElementKeysByType( typeSpec );
      idList.Reset();
      while( idList.HasNext() )
      {
        String idStr = idList.Next();
        String valueStr = section.GetText(idStr);
        ...
      }
Parameter:
typeSpec Typ-Spezifikation entsprechend den DataObject- Attributen in der Berichtsvorlage. Die eckigen Klammern können wahlweise weggelassen werden.
Rückgabe:
Liste der technischen ID's der Elemente des Abschnitts.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls die übergebene Typspezifikation Void ist.
Zu beachten:
Es werden nur die Schlüssel derjenigen Elemente geliefert, die sich unmittelbar in dem aufrufenden Berichtsabschnitt befinden und die eine ID haben. Unterabschnitte werden nicht berücksichtigt.
[Isom\Reporting\ReportSection.is: 944]
objectbound Isom.Sys.Error Isom.Reporting.ReportSection.GetError ( Isom.Base.String key )

Ermittelt ein Kontextelement vom Typ "Error" innerhalb des Bericht-Absatzes.

Parameter:
key Identifizierende Zeichenkette (techn. ID).
Rückgabe:
Kontextelement oder 'Void'.
[Isom\Reporting\ReportSection.is: 631]
objectbound Isom.Base.String Isom.Reporting.ReportSection.GetKey ( )

Ermittelt die technische ID des Abschnitts.

   using Isom.Base.*;
   using Isom.Reporting.*;
   ...
      ReportSection section = ...;
      String id = section.GetKey();
Rückgabe:
technische ID des Abschnitts.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Wert ungesetzt ist.
[Isom\Reporting\ReportSection.is: 897]
objectbound Isom.Request.MediaElement Isom.Reporting.ReportSection.GetMediaElement ( Isom.Base.String key )

Ermittelt ein Darstellungselement vom Typ "MediaElement" innerhalb des Bericht-Absatzes.

Parameter:
key Identifizierende Zeichenkette (techn. ID).
Rückgabe:
Kontextelement oder 'Void'.
[Isom\Reporting\ReportSection.is: 438]
objectbound Isom.Reporting.ReportSectionList Isom.Reporting.ReportSection.GetReportSectionList ( )

Greift auf alle Unterabschnitte des aktuellen Abschnitts zu.

   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      //ReportSection section = ...;
      ReportSectionList list = section.GetReportSectionList();
      while ( list.HasNext() )
         DoSomething( list.Next() );
Rückgabe:
Gefundene Unterabschnitte in Einfügereihenfolge.
[Isom\Reporting\ReportSection.is: 268]
objectbound Isom.Reporting.ReportSection Isom.Reporting.ReportSection.GetSubsection ( Isom.Base.String id )

Greift auf einen benannten Unterabschnitt des aktuellen Abschnitts zu.

   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      ReportSection sub = section.GetSubsection( "Messages" );
      section.AddSubSection( sub );
Parameter:
id des zu suchenden Unterabschnitts.
Rückgabe:
Gefundener Unterabschnitt oder 'Void'.
[Isom\Reporting\ReportSection.is: 247]
objectbound Isom.Base.String Isom.Reporting.ReportSection.GetText ( Isom.Base.String key )

Ermittelt ein Darstellungselement vom Typ "Text" innerhalb des Bericht-Absatzes.

Parameter:
key Identifizierende Zeichenkette (techn. ID).
Rückgabe:
Kontextelement oder 'Void'.
[Isom\Reporting\ReportSection.is: 391]
objectbound Isom.Plan.TherapyPlanAction Isom.Reporting.ReportSection.GetTherapyPlanAction ( Isom.Base.String key )

Ermittelt ein Kontextelement vom Typ "TherapyPlanAction" innerhalb des Bericht-Absatzes.

Parameter:
key Identifizierende Zeichenkette (techn. ID).
Rückgabe:
Kontextelement oder 'Void'.
[Isom\Reporting\ReportSection.is: 537]
objectbound Isom.Context.UserProfileSetting Isom.Reporting.ReportSection.GetUserProfileSetting ( Isom.Base.String key )

Ermittelt ein Kontextelement vom Typ "UserProfileSetting"/Einstellung innerhalb des Bericht-Absatzes.

Parameter:
key Identifizierende Zeichenkette (techn. ID).
Rückgabe:
Kontextelement oder 'Void'.
[Isom\Reporting\ReportSection.is: 749]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Reporting\ReportSection.is: 966]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.RemoveSubsection ( Isom.Reporting.ReportSection sect )

Entfernt einen Absatz aus dem Bericht.

   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      ReportSection sub = section.CreateSubsection( "Messages" );
      section.RemoveSubsection( sub );
Parameter:
sect zu entfernender Absatz.
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls 'Void' als Parameter übergeben wurde.
Es wird das Void-Objekt zurückgegeben, falls der vorgegebene Abschnitt nicht im Aufrufobjekt enthalten ist.
Es wird das Void-Objekt zurückgegeben, falls durch das Entfernen der Zähler 'MinRepeat' unterschritten würde.
[Isom\Reporting\ReportSection.is: 183]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.SetDate | ( | Isom.Base.String | key,
 |  | Isom.Base.Date | date
 | ) |  |

Setzt ein Kontextelement vom Typ "Date"/Zeitpunkt innerhalb des Bericht-Absatzes.

Zu beachten:
Die Darstellung obliegt einem Kontrakt zwischen ISOM/L-Programmen und Anzeigeapplikation (Client).
   // @file Vendor.is
   using Isom.Base.*;
   using Isom.Sys.Error;
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      // Date date = Date.Now();
      section.SetDate( "StartTime", date );
Parameter:
key | Identifizierende Zeichenkette (techn. ID) oder Leerstring ("") für "ID automatisch vergeben" bzw. "letztes Element des Typs".
date | Datums-Objekt (Darstellung Client-abhängig).
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls dem Report noch kein Template zugewiesen wurde (vgl\. Report.SetTemplate(...)).
Es wird das Void-Objekt zurückgegeben, falls eine ID vorgegeben wurde und kein entsprechendes Element im Abschnitt/Template existiert.
Es wird das Void-Objekt zurückgegeben, falls ein Element/Template mit gleicher ID existiert, aber einen anderen Assoziationstyp hat (z\.B\. Client-Template oder vorher andere Set...()-Funktion benutzt).
[Isom\Reporting\ReportSection.is: 669]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.SetDisplayProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt einen [potentiell übersetzbaren] Eigenschafts-Wert.

Zu beachten:
Für ein zusammenhängendes Beispiel siehe Report.
   // @file Consts.is
    deftext INTERNAL REPORTPROPNAME_FORMATTINGHINT "FormattingHint"
    deftext INTERNAL REPORTPROPVALUE_BLUE          "Color:Blue" // Client-interpretiert

   // @file Vendor.is
   using Isom.Base.*;
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      String propName = Consts.REPORTPROPNAME_FORMATTINGHINT;
      if( section.GetDisplayProp( propName ).IsVoid() )
      {
        String propVal = Consts.REPORTPROPVALUE_BLUE;
        section.SetDisplayProp( propName, propVal ); // Client-interpretiert
      }
Parameter:
propName | Name der Eigenschaft (Groß-Kleinschreibung signifikant).
propValue | zu setzender Wert der Eigenschaft oder 'Void', um die Property zurückzusetzen.
Rückgabe:
'true', falls der Property-Wert erfolgreich eingetragen bzw. entfernt wurde, 'false' sonst.
[Isom\Reporting\ReportSection.is: 832]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.SetEcu | ( | Isom.Base.String | key,
 |  | Isom.Context.Ecu | ecu
 | ) |  |

Setzt ein Kontextelement vom Typ "Ecu"/Steuergerät innerhalb des Bericht-Absatzes.

Zu beachten:
Die Darstellung obliegt einem Kontrakt zwischen ISOM/L-Programmen und Anzeigeapplikation (Client).
   using Isom.Base.*;
   using Isom.Context.Ecu;
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      // Ecu ecu = ...;
      section.SetEcu( "MainGateway", ecu );
Parameter:
key | Identifizierende Zeichenkette (techn. ID) oder Leerstring ("") für "ID automatisch vergeben" bzw. "letztes Element des Typs".
ecu | Steuergeräte-Fachobjekt (Darstellung Client-abhängig).
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls dem Report noch kein Template zugewiesen wurde (vgl\. Report.SetTemplate(...)).
Es wird das Void-Objekt zurückgegeben, falls eine ID vorgegeben wurde und kein entsprechendes Element im Abschnitt/Template existiert.
Es wird das Void-Objekt zurückgegeben, falls ein Element/Template mit gleicher ID existiert, aber einen anderen Assoziationstyp hat (z\.B\. Client-Template oder vorher andere Set...()-Funktion benutzt).
[Isom\Reporting\ReportSection.is: 574]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.SetError | ( | Isom.Base.String | key,
 |  | Isom.Sys.Error | err
 | ) |  |

Setzt ein Kontextelement vom Typ "Error"/registrierter Fehler innerhalb des Bericht-Absatzes.

Zu beachten:
Die Darstellung obliegt einem Kontrakt zwischen ISOM/L-Programmen und Anzeigeapplikation (Client).
   using Isom.Base.*;
   using Isom.Sys.Error;
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      // Error error = GetLastErrors(...).Get(...);
      section.SetError( "", error );
Parameter:
key | Identifizierende Zeichenkette (techn. ID) oder Leerstring ("") für "ID automatisch vergeben" bzw. "letztes Element des Typs".
err | Fehler-Objekt (Darstellung Client-abhängig).
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls dem Report noch kein Template zugewiesen wurde (vgl\. Report.SetTemplate(...)).
Es wird das Void-Objekt zurückgegeben, falls eine ID vorgegeben wurde und kein entsprechendes Element im Abschnitt/Template existiert.
Es wird das Void-Objekt zurückgegeben, falls ein Element/Template mit gleicher ID existiert, aber einen anderen Assoziationstyp hat (z\.B\. Client-Template oder vorher andere Set...()-Funktion benutzt).
[Isom\Reporting\ReportSection.is: 621]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.SetMediaElement | ( | Isom.Base.String | key,
 |  | Isom.Request.MediaElement | medium
 | ) |  |

Setzt ein Darstellungselement vom Typ "Medienobjekt" (Grafiken/Videos/etc) innerhalb des Bericht-Absatzes.

Zu beachten:
Die Darstellung obliegt einem Kontrakt zwischen ISOM/L-Programmen und Anzeigeapplikation (Client).
Für ein zusammenhängendes Beispiel siehe Report.
   using Isom.Base.*;
   using Isom.Reporting.*;
   ...
      MediaElement medium = MediaElement.CreateMediaElement( "IK_IMG", "images/OK.png" );
      section.SetMediaElement( "", medium );
Parameter:
key | Identifizierende Zeichenkette (techn. ID) oder Leerstring ("") für "ID automatisch vergeben" bzw. "letztes Element des Typs".
medium | Medienobjekt-Element (Darstellung Client-abhängig).
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls dem Report noch kein Template zugewiesen wurde (vgl\. Report.SetTemplate(...)).
Es wird das Void-Objekt zurückgegeben, falls eine ID vorgegeben wurde und kein entsprechendes Element im Abschnitt/Template existiert.
Es wird das Void-Objekt zurückgegeben, falls ein Element/Template mit gleicher ID existiert, aber einen anderen Assoziationstyp hat (z\.B\. Client-Template oder vorher andere Set...()-Funktion benutzt).
[Isom\Reporting\ReportSection.is: 428]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.SetSeparator | ( | Isom.Base.String | key,
 |  | Isom.Base.String | sepType
 | ) |  |

Setzt ein Trennzeichen-Darstellungselement welches der Client für Formatierungszwecke verwenden kann.

Zu beachten:
Die Darstellung obliegt einem Kontrakt zwischen ISOM/L-Programmen und Anzeigeapplikation (Client).
Für ein zusammenhängendes Beispiel siehe Report.
   using Isom.Base.*;
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      section.SetSeparator( "", "COMPLETEPLAN_PARALLEL" );
Parameter:
key | Identifizierende Zeichenkette (techn. ID) oder Leerstring ("") für "ID automatisch vergeben" bzw. "letztes Element des Typs".
sepType | Separator-Typ oder Void.
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls dem Report noch kein Template zugewiesen wurde (vgl\. Report.SetTemplate(...)).
Es wird das Void-Objekt zurückgegeben, falls eine ID vorgegeben wurde und kein entsprechendes Element im Abschnitt/Template existiert.
Es wird das Void-Objekt zurückgegeben, falls ein Element/Template mit gleicher ID existiert, aber einen anderen Assoziationstyp hat (z\.B\. Client-Template oder vorher andere Set...()-Funktion benutzt).
[Isom\Reporting\ReportSection.is: 475]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.SetTemplate ( Isom.Base.String templateID )

Setzt die ID/den Namen des Templates, der zur Strukturdefinition/Formatierung des Bericht-Absatzes dient.

Zu beachten:
Welche IDs zulässig sind, obliegt einem Kontrakt zwischen ISOM/L-Programmen und Anzeigeapplikation (Client).
Für ein zusammenhängendes Beispiel siehe Report.
   using Isom.Base.*;
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      section.SetTemplate( "COMPLETEPLAN_PARALLEL" );
Parameter:
templateID technische ID (beliebige Zeichenkette).
Rückgabe:
eindeutige(r) ID/Namen des Templates (technischen; nicht übersetzbar).
[Isom\Reporting\ReportSection.is: 304]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.SetText | ( | Isom.Base.String | key,
 |  | Isom.Base.String | msg
 | ) |  |

Setzt ein Darstellungselement vom Typ "Text" innerhalb des Bericht-Absatzes.

Zu beachten:
Die Darstellung obliegt einem Kontrakt zwischen ISOM/L-Programmen und Anzeigeapplikation (Client).
Für ein zusammenhängendes Beispiel siehe Report.
   using Isom.Base.*;
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      section.SetText( "", "Aktion ausgeführt" );
Parameter:
key | Identifizierende Zeichenkette (techn. ID) oder Leerstring ("") für "ID automatisch vergeben" bzw. "letztes Element des Typs".
msg | Text-Element (übersetzbare ISOM-Zeichenkette).
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls dem Report noch kein Template zugewiesen wurde (vgl\. Report.SetTemplate(...)).
Es wird das Void-Objekt zurückgegeben, falls 'Void' als Key übergeben wurde.
Es wird das Void-Objekt zurückgegeben, falls eine ID vorgegeben wurde und kein entsprechendes Element im Abschnitt/Template existiert.
Es wird das Void-Objekt zurückgegeben, falls ein Element/Template mit gleicher ID existiert, aber einen anderen Assoziationstyp hat (z\.B\. Client-Template oder vorher andere Set...()-Funktion benutzt).
[Isom\Reporting\ReportSection.is: 381]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.SetTherapyPlanAction | ( | Isom.Base.String | key,
 |  | Isom.Plan.TherapyPlanAction | action
 | ) |  |

Setzt ein Kontextelement vom Typ "TherapyPlanAction"/Aktion innerhalb des Bericht-Absatzes.

Zu beachten:
Die Darstellung obliegt einem Kontrakt zwischen ISOM/L-Programmen und Anzeigeapplikation (Client).
Für ein zusammenhängendes Beispiel siehe Report.
   using Isom.Base.*;
   using Isom.Plan.*;
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      // TherapyPlanAction action = ...;
      section.SetTherapyPlanAction( "", action );
Parameter:
key | Identifizierende Zeichenkette (techn. ID) oder Leerstring ("") für "ID automatisch vergeben" bzw. "letztes Element des Typs".
action | Therapieplan-Aktion (Darstellung Client-abhängig).
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls dem Report noch kein Template zugewiesen wurde (vgl\. Report.SetTemplate(...)).
Es wird das Void-Objekt zurückgegeben, falls eine ID vorgegeben wurde und kein entsprechendes Element im Abschnitt/Template existiert.
Es wird das Void-Objekt zurückgegeben, falls ein Element/Template mit gleicher ID existiert, aber einen anderen Assoziationstyp hat (z\.B\. Client-Template oder vorher andere Set...()-Funktion benutzt).
[Isom\Reporting\ReportSection.is: 527]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.SetTitle ( Isom.Base.String title )

Setzt die die Überschrift für den Bericht-Absatz.

Die Übergabe von 'Void' setzt die Überschrift zurück.

Zu beachten:
Für ein zusammenhängendes Beispiel siehe Report.
   using Isom.Base.*
   using Isom.Reporting.*;
   ...
      Report        report  = Report.CreateReport("FinalReport");
      ReportSection section = report.GetSubsection( "Actions" );
      section.SetTitle( "Aktionsplan (Parallel-Darstellung)" );
Parameter:
title Absatz-[Unter]Überschrift (übersetzbare ISOM-Zeichenkette).
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls dem Report noch kein Template zugewiesen wurde (vgl\. Report.SetTemplate(...)).
[Isom\Reporting\ReportSection.is: 329]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSection.SetUserProfileSetting | ( | Isom.Base.String | key,
 |  | Isom.Context.UserProfileSetting | setting
 | ) |  |

Setzt ein Kontextelement vom Typ "UserProfileSetting"/Einstellung innerhalb des Bericht-Absatzes.

Zu beachten:
Die Darstellung obliegt einem Kontrakt zwischen ISOM/L-Programmen und Anzeigeapplikation (Client).
   // @file Vendor.is
   using Isom.Base.*;
   using Isom.Sys.Error;
   using Isom.Reporting.*;
   ...
      Boolean AddUserProfileDataToReport (UserProfile up)
      {
        // String assignment = "CAR";
        UserProfileSettingList upsList = up.GetSettingsByAssignment( assignment );

        // Iteration über alle Settings
        upsList.Reset();
        while( upsList.HasNext() )
        {
          UserProfileSetting ups = upsList.Next();

          UserProfileOptionList upoList = ups.GetOptions();
          while( upoList.HasNext())
          {
            UserProfileOption upo = upoList.Next();
            if( upo.IsCurrent() )
            {
              // ...

              userProfileSection.SetUserProfileSetting(ups.GetName(), ups);
            }
          }
        }
        //...
        return true;
      }
Parameter:
key | Identifizierende Zeichenkette (techn. ID) oder Leerstring ("") für "ID automatisch vergeben" bzw. "letztes Element des Typs".
setting | UserProfileSetting-Objekt (Darstellung Client-abhängig).
Rückgabe:
'true' im Erfolgsfall (derzeit immer).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls dem Report noch kein Template zugewiesen wurde (vgl\. Report.SetTemplate(...)).
Es wird das Void-Objekt zurückgegeben, falls eine ID vorgegeben wurde und kein entsprechendes Element im Abschnitt/Template existiert.
Es wird das Void-Objekt zurückgegeben, falls ein Element/Template mit gleicher ID existiert, aber einen anderen Assoziationstyp hat (z\.B\. Client-Template oder vorher andere Set...()-Funktion benutzt).
[Isom\Reporting\ReportSection.is: 739]
Isom.Reporting.ReportSection Isom.Reporting.ReportSection.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Reporting\ReportSection.is: 987]


für Serviceautoren

Isom.Reporting.ReportSectionList

Namensraum Isom.Reporting.ReportSectionList

Liste von Report-Abschnitten des Typs Isom.Reporting.ReportSection Mehr...

Funktionen
Funktionen zur Erzeugung und Verwendung von Report-Abschnittslisten

Funktionen, die das Erzeugen und Verwenden von Report-Abschnittslisten ermöglicht.

Isom.Reporting.ReportSectionList | CreateReportSectionList()

Erzeugt eine neue Liste.

Isom.Reporting.ReportSection | FindByKey(Isom.Base.String key)

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Isom.Base.Number | Insert(Isom.Reporting.ReportSection med)

Fügt der Liste ein Element hinzu.

Listenfunktionen

Isom.Base.Boolean | Contains(Isom.Reporting.ReportSection element)

Abfrage, ob ein Element in der Liste vorhanden ist.

Isom.Reporting.ReportSection | Current()

Liefert das aktuelle Medienobjekt.

Isom.Base.Boolean | HasNext()

Bestimmt, ob noch weitere Report-Abschnitten in der Liste vorhanden sind.

Isom.Base.Boolean | IsEmpty()

Prüft, ob die Liste Elemente enthält.

Isom.Base.Number | Length()

Liefert die Anzahl der Report-Abschnitten in der Liste.

Isom.Reporting.ReportSection | Next()

Liefert die nächste Auswahlgruppe.

Isom.Base.Boolean | Reset()

Setzt den Listeniterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Reporting.ReportSectionList | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Reporting.ReportSectionList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Reporting.ReportSectionList sind Listen von Report-Abschnitten des Typs Isom.Reporting.ReportSection

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Reporting\ReportSectionList.is

Dokumentation der Funktionen

objectbound Isom.Reporting.ReportSectionList Isom.Reporting.ReportSectionList.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue "ReportSectionList" mit demselben Inhalt.
[Isom\Reporting\ReportSectionList.is: 216]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSectionList.Contains ( Isom.Reporting.ReportSection element )

Abfrage, ob ein Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Reporting\ReportSectionList.is: 193]
Isom.Reporting.ReportSectionList Isom.Reporting.ReportSectionList.CreateReportSectionList ( )

Erzeugt eine neue Liste.

Rückgabe:
Neue Listeninstanz.
[Isom\Reporting\ReportSectionList.is: 87]
objectbound Isom.Reporting.ReportSection Isom.Reporting.ReportSectionList.Current ( )

Liefert das aktuelle Medienobjekt.

Rückgabe:
Aktuelles Medienobjekt oder ein Void-Objekt, falls der Iterator am Anfang der Liste steht.
[Isom\Reporting\ReportSectionList.is: 174]
objectbound Isom.Reporting.ReportSection Isom.Reporting.ReportSectionList.FindByKey ( Isom.Base.String key )

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Parameter:
key Identifikator des zu suchenden Objekts
Rückgabe:
Das Medienobjekt oder das Void-Objekt, falls die Liste kein Medienobjekt mit diesem Identifikator enthält.
[Isom\Reporting\ReportSectionList.is: 122]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSectionList.HasNext ( )

Bestimmt, ob noch weitere Report-Abschnitten in der Liste vorhanden sind.

Rückgabe:
'true', falls weitere Report-Abschnitten vorhanden sind, 'false' sonst.
[Isom\Reporting\ReportSectionList.is: 165]
objectbound Isom.Base.Number Isom.Reporting.ReportSectionList.Insert ( Isom.Reporting.ReportSection med )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Iterator, wird durch diese Operation zurückgesetzt.

Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
med Hinzuzufügendes Medienobjekt.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
[Isom\Reporting\ReportSectionList.is: 111]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSectionList.IsEmpty ( )

Prüft, ob die Liste Elemente enthält.

Rückgabe:
'true', falls keine Report-Abschnitten vorhanden sind, 'false' sonst.
[Isom\Reporting\ReportSectionList.is: 146]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSectionList.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true' wenn es das Void-Objekt ist, 'false' sonst.
[Isom\Reporting\ReportSectionList.is: 208]
objectbound Isom.Base.Number Isom.Reporting.ReportSectionList.Length ( )

Liefert die Anzahl der Report-Abschnitten in der Liste.

Rückgabe:
Anzahl der Report-Abschnitten
[Isom\Reporting\ReportSectionList.is: 137]
objectbound Isom.Reporting.ReportSection Isom.Reporting.ReportSectionList.Next ( )

Liefert die nächste Auswahlgruppe.

Rückgabe:
Nächste Auswahlgruppe in der Liste oder ein Void-Objekt, falls der Iterator auf dem letzten Objekt der Liste steht.
[Isom\Reporting\ReportSectionList.is: 155]
objectbound Isom.Base.Boolean Isom.Reporting.ReportSectionList.Reset ( )

Setzt den Listeniterator zurück.

Rückgabe:
Immer 'true'.
[Isom\Reporting\ReportSectionList.is: 182]
Isom.Reporting.ReportSectionList Isom.Reporting.ReportSectionList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
ungültiges Objekt
[Isom\Reporting\ReportSectionList.is: 228]


für Serviceautoren

Isom.Request

Namensraum Isom.Request

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Request.Button | Schaltflächenelemente bei Eingabeaufforderungen
Isom.Request.ButtonList | Listen von BO-Schaltflächen des Typs Isom.Request.Button
Isom.Request.MeasuredValue | Messwerte
Isom.Request.Measurement | Fachfunktionen für Liste von Messwerten des Typs Isom.Request.MeasuredValue
Isom.Request.MeasurementList | Listen von Messwerten des Typs Isom.Request.Measurement
Isom.Request.MediaElement | Medienobjekt
Isom.Request.MediaList | Listen von Medienobjekten des Typs Isom.Request.MediaElement
Isom.Request.MessageElement | Dialogelement bei Eingabeaufforderungen
Isom.Request.MessageList | Listen von Dialogelementen des Typs Isom.Request.MessageElement
Isom.Request.Option | Auswahldialoge in Benutzerinteraktionen
Isom.Request.RadioButton | Fachobjekt für Radiobuttons in Assistenten
Isom.Request.SelectionGroup | Auswahlgruppenelemente in Benutzerinteraktionen
Isom.Request.SelectionGroupList | Listen von Auswahlgruppen in Benutzerinteraktionen des Typs Isom.Request.SelectionGroup
Isom.Request.UserRequest | Dialogfenster in Benutzerinteraktionen
Isom.Request.Wizard | Fachobjekt für Assistenten


für Serviceautoren

Isom.Request.Button

Namensraum Isom.Request.Button

Schaltflächenelemente bei Eingabeaufforderungen Mehr...

Funktionen
Isom.Request.Button | CreateButton(Isom.Base.String key, Isom.Base.String text)

Erzeugt eine neue Schaltfläche.

Funktionen zum Auslesen von Werten der Schaltfläche

Funktionen, die es ermöglichen den Identifikator und den Anzeigetext auszulesen.

Isom.Base.String | GetKey()

Ruft den Identifikator der aktuellen Schaltfläche ab.

Isom.Base.String | GetText()

Ruft den Anzeigetext der aktuellen Schaltfläche ab.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.Button | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.Button | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Request.Button sind Schaltflächenelemente bei Eingabeaufforderungen

Quelldateien:

  • Isom\Request\Button.is

Dokumentation der Funktionen

objectbound Isom.Request.Button Isom.Request.Button.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue ButtonList mit demselben Inhalt.
[Isom\Request\Button.is: 116]
Isom.Request.Button Isom.Request.Button.CreateButton | ( | Isom.Base.String | key,
 |  | Isom.Base.String | text
 | ) |  |

Erzeugt eine neue Schaltfläche.

Parameter:
key | Eindeutiger Identifikator der Schaltfläche.
text | Anzeigetext der Schaltfläche.
Rückgabe:
Neue Schaltflächeninstanz.
[Isom\Request\Button.is: 72]
objectbound Isom.Base.String Isom.Request.Button.GetKey ( )

Ruft den Identifikator der aktuellen Schaltfläche ab.

Rückgabe:
Identifikator dieser Schaltfläche.
[Isom\Request\Button.is: 85]
objectbound Isom.Base.String Isom.Request.Button.GetText ( )

Ruft den Anzeigetext der aktuellen Schaltfläche ab.

Rückgabe:
Anzeigetext dieser Schaltfläche.
[Isom\Request\Button.is: 93]
objectbound Isom.Base.Boolean Isom.Request.Button.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Request\Button.is: 108]
Isom.Request.Button Isom.Request.Button.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Request\Button.is: 128]


für Serviceautoren

Isom.Request.ButtonList

Namensraum Isom.Request.ButtonList

Listen von BO-Schaltflächen des Typs Isom.Request.Button Mehr...

Funktionen
Isom.Base.Boolean | AddButton(Isom.Request.Button but)

Fügt eine Schaltfläche der Liste hinzu.

Isom.Request.ButtonList | CreateButtonList()

Erzeugt eine neue Liste.

Isom.Request.Button | FindByKey(Isom.Base.String key)

Sucht das über den Identifikator eindeutig gekennzeichente Element aus der Liste.

Listenfunktionen

Isom.Base.Boolean | Contains(Isom.Request.Button element)

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Isom.Request.Button | Current()

Liefert die aktuelle Schaltfläche.

Isom.Base.Boolean | HasNext()

Bestimmt, ob noch weitere Schaltflächen in der Liste vorhanden sind.

Isom.Base.Boolean | IsEmpty()

Prüft, ob die Liste Elemente enthält.

Isom.Base.Number | Length()

Liefert die Anzahl der Schaltflächen in der Liste.

Isom.Request.Button | Next()

Liefert die nächste Schaltfläche.

Isom.Base.Boolean | Reset()

Setzt den Listeniterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.ButtonList | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.ButtonList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Request.ButtonList sind Listen von BO-Schaltflächen des Typs Isom.Request.Button

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Request\ButtonList.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Request.ButtonList.AddButton ( Isom.Request.Button but )

Fügt eine Schaltfläche der Liste hinzu.

Rückgabe:
Immer 'true'.
[Isom\Request\ButtonList.is: 90]
objectbound Isom.Request.ButtonList Isom.Request.ButtonList.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue ButtonList mit demselben Inhalt.
[Isom\Request\ButtonList.is: 192]
objectbound Isom.Base.Boolean Isom.Request.ButtonList.Contains ( Isom.Request.Button element )

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Request\ButtonList.is: 170]
Isom.Request.ButtonList Isom.Request.ButtonList.CreateButtonList ( )

Erzeugt eine neue Liste.

Rückgabe:
Neue Listeninstanz.
[Isom\Request\ButtonList.is: 82]
objectbound Isom.Request.Button Isom.Request.ButtonList.Current ( )

Liefert die aktuelle Schaltfläche.

Rückgabe:
Aktuelle Schaltfläche oder ein Void-Objekt, falls der Iterator am Anfang der Liste steht.
[Isom\Request\ButtonList.is: 151]
objectbound Isom.Request.Button Isom.Request.ButtonList.FindByKey ( Isom.Base.String key )

Sucht das über den Identifikator eindeutig gekennzeichente Element aus der Liste.

Parameter:
key Identifikator des zu suchenden Objekts.
Rückgabe:
Das Schaltflächenobjekt oder das Void-Objekt, falls die Liste keine Schaltfläche mit diesem Identifikator enthät.
[Isom\Request\ButtonList.is: 101]
objectbound Isom.Base.Boolean Isom.Request.ButtonList.HasNext ( )

Bestimmt, ob noch weitere Schaltflächen in der Liste vorhanden sind.

Rückgabe:
'true', falls weitere Schaltflächen vorhanden sind, 'false' sonst.
[Isom\Request\ButtonList.is: 142]
objectbound Isom.Base.Boolean Isom.Request.ButtonList.IsEmpty ( )

Prüft, ob die Liste Elemente enthält.

Rückgabe:
'true', falls keine Schaltfläche vorhanden sind 'false' sonst.
[Isom\Request\ButtonList.is: 123]
objectbound Isom.Base.Boolean Isom.Request.ButtonList.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Request\ButtonList.is: 184]
objectbound Isom.Base.Number Isom.Request.ButtonList.Length ( )

Liefert die Anzahl der Schaltflächen in der Liste.

Rückgabe:
Anzahl der Schaltflächen.
[Isom\Request\ButtonList.is: 115]
objectbound Isom.Request.Button Isom.Request.ButtonList.Next ( )

Liefert die nächste Schaltfläche.

Rückgabe:
Nächste Schaltfläche in der Liste oder ein Void-Objekt, falls der Iterator auf dem letzten Objekt der Liste steht.
[Isom\Request\ButtonList.is: 132]
objectbound Isom.Base.Boolean Isom.Request.ButtonList.Reset ( )

Setzt den Listeniterator zurück.

Rückgabe:
Immer 'true'.
[Isom\Request\ButtonList.is: 159]
Isom.Request.ButtonList Isom.Request.ButtonList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Request\ButtonList.is: 204]


für Serviceautoren

Isom.Request.MeasuredValue

Namensraum Isom.Request.MeasuredValue

Messwerte Mehr...

Funktionen
Isom.Request.MeasuredValue | CreateMeasuredValue(Isom.Base.String key, Isom.Base.String value, Isom.Base.String unit, Isom.Base.String min, Isom.Base.String max)

Erzeugt eine neue "MeasuredValue".

Funktionen zum Auslesen und Setzen von Werten

Funktionen, die das Auslesen und Setzen bestimmter Werte ermöglicht.

Isom.Base.String | GetKey()

Ruft den Identifikator der aktuellen "MeasuredValue" ab.

Isom.Base.String | GetMax()

Ruft den größtmöglichen Wert ab.

Isom.Base.String | GetMin()

Ruft den kleinstmöglichen Wert ab.

Isom.Base.String | GetUnit()

Ruft die Einheit der aktuellen "MeasuredValue" ab.

Isom.Base.String | GetValue()

Ruft den Anzeigetext der aktuellen "MeasuredValue" ab.

Isom.Base.Boolean | SetMax(Isom.Base.String max)

Legt den größtmöglichen Wert fest.

Isom.Base.Boolean | SetMin(Isom.Base.String min)

Legt den kleinstmöglichen Wert fest.

Isom.Base.Boolean | SetUnit(Isom.Base.String unit)

Legt die Einheit der aktuellen MeasuredValue fest.

Isom.Base.Boolean | SetValue(Isom.Base.String value)

Legt den Anzeigetext der aktuellen "MeasuredValue" fest.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.MeasuredValue | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.MeasuredValue | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Request.MeasuredValue sind Messwerte, die eingestellt und ausgelesen werden können.

Quelldateien:

  • Isom\Request\MeasuredValue.is

Dokumentation der Funktionen

objectbound Isom.Request.MeasuredValue Isom.Request.MeasuredValue.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
neue "MeasuredValue" mit demselben Inhalt.
[Isom\Request\MeasuredValue.is: 183]
Isom.Request.MeasuredValue Isom.Request.MeasuredValue.CreateMeasuredValue | ( | Isom.Base.String | key,
 |  | Isom.Base.String | value,
 |  | Isom.Base.String | unit,
 |  | Isom.Base.String | min,
 |  | Isom.Base.String | max
 | ) |  |

Erzeugt eine neue "MeasuredValue".

Parameter:
key | eindeutiger Identifikator der "MeasuredValue"
value | Initialer Wert der "MeasuredValue"
unit | Einheit der "MeasuredValue"
min | Minimaler Wert der "MeasuredValue"
max | Maximaler Wert der "MeasuredValue"
Rückgabe:
Neue Instanz von "MeasuredValue".
[Isom\Request\MeasuredValue.is: 83]
objectbound Isom.Base.String Isom.Request.MeasuredValue.GetKey ( )

Ruft den Identifikator der aktuellen "MeasuredValue" ab.

Rückgabe:
Identifikator dieser "MeasuredValue".
[Isom\Request\MeasuredValue.is: 96]
objectbound Isom.Base.String Isom.Request.MeasuredValue.GetMax ( )

Ruft den größtmöglichen Wert ab.

Rückgabe:
Der größtmögliche Wert.
[Isom\Request\MeasuredValue.is: 152]
objectbound Isom.Base.String Isom.Request.MeasuredValue.GetMin ( )

Ruft den kleinstmöglichen Wert ab.

Rückgabe:
Der kleinstmögliche Wert.
[Isom\Request\MeasuredValue.is: 136]
objectbound Isom.Base.String Isom.Request.MeasuredValue.GetUnit ( )

Ruft die Einheit der aktuellen "MeasuredValue" ab.

Rückgabe:
Einheit dieser "MeasuredValue".
[Isom\Request\MeasuredValue.is: 120]
objectbound Isom.Base.String Isom.Request.MeasuredValue.GetValue ( )

Ruft den Anzeigetext der aktuellen "MeasuredValue" ab.

Rückgabe:
Anzeigetext dieser "MeasuredValue".
[Isom\Request\MeasuredValue.is: 104]
objectbound Isom.Base.Boolean Isom.Request.MeasuredValue.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, andernfalls 'false'.
[Isom\Request\MeasuredValue.is: 175]
objectbound Isom.Base.Boolean Isom.Request.MeasuredValue.SetMax ( Isom.Base.String max )

Legt den größtmöglichen Wert fest.

Rückgabe:
Immer 'true'.
[Isom\Request\MeasuredValue.is: 160]
objectbound Isom.Base.Boolean Isom.Request.MeasuredValue.SetMin ( Isom.Base.String min )

Legt den kleinstmöglichen Wert fest.

Rückgabe:
Immer 'true'.
[Isom\Request\MeasuredValue.is: 144]
objectbound Isom.Base.Boolean Isom.Request.MeasuredValue.SetUnit ( Isom.Base.String unit )

Legt die Einheit der aktuellen MeasuredValue fest.

Rückgabe:
Immer 'true'.
[Isom\Request\MeasuredValue.is: 128]
objectbound Isom.Base.Boolean Isom.Request.MeasuredValue.SetValue ( Isom.Base.String value )

Legt den Anzeigetext der aktuellen "MeasuredValue" fest.

Rückgabe:
Immer 'true'.
[Isom\Request\MeasuredValue.is: 112]
Isom.Request.MeasuredValue Isom.Request.MeasuredValue.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
ungültiges Objekt
[Isom\Request\MeasuredValue.is: 195]


für Serviceautoren

Isom.Request.Measurement

Namensraum Isom.Request.Measurement

Fachfunktionen für Liste von Messwerten des Typs Isom.Request.MeasuredValue Mehr...

Funktionen
Funktionen zum Bearbeiten und Verwenden von Messwerten

Funktionen, die es ermöglichen Messwerte zu Bearbeiten und Verwenden.

Isom.Base.Boolean | AddMeasuredValue(Isom.Request.MeasuredValue measure)

Fügt einen Messwert der Liste hinzu.

Isom.Request.Measurement | CreateMeasurement(Isom.Base.String key)

Erzeugt eine neue Liste.

Isom.Request.MeasuredValue | FindByKey(Isom.Base.String key)

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Isom.Base.String | GetDisplayType()

Liefert die aktuell gewünschte Darstellungsart.

Isom.Base.String | GetHeading()

Gibt die optionale Überschrift für die Messwerte zurück.

Isom.Base.String | GetKey()

Ruft den Identifikator der aktuellen Messwertgruppe ab.

Isom.Base.Boolean | SetDisplayType(Isom.Base.String displayType)

Legt die gewünschte Darstellungsart fest.

Isom.Base.Boolean | SetHeading(Isom.Base.String heading)

Setzt die optionale Überschrift für die Messwerte.

Listenfunktionen

Isom.Base.Boolean | Contains(Isom.Request.MeasuredValue element)

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Isom.Request.MeasuredValue | Current()

Liefert den aktuelle Messwert.

Isom.Base.Boolean | HasNext()

Bestimmt, ob noch weitere Messwerte in der Liste vorhanden sind.

Isom.Base.Boolean | IsEmpty()

Prüft, ob die Liste Elemente enthält.

Isom.Base.Number | Length()

Liefert die Anzahl der Messwerte in der Liste.

Isom.Request.MeasuredValue | Next()

Liefert den nächsten Messwerte.

Isom.Base.Boolean | Reset()

Setzt den Listeniterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.Measurement | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.Measurement | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Das folgende Quelltext-Beispiel zeigt die Verwendung am Beispiel einer Messwertanzeige in einem Assistentenschritt.

 Isom.Base.Boolean UpdatedMeasurementStep(Isom.Request.Wizard wizard)
 {
    wizard.AddMessage("Message", "   ");

    Isom.Base.String msg2 = "UpdateFunktion: ";
    msg2.Append(wizard.GetUpdateFunction());

    wizard.AddMessage("MessageNeuLine", "   ");

    // Messgröße erzeugen
    Isom.Request.Measurement measureXAngle = Isom.Request.Measurement.CreateMeasurement("XAngle");
    Isom.Request.Measurement measureYAngle = Isom.Request.Measurement.CreateMeasurement("YAngle");
    // Anzeigetyp festlegen (muss dem Client bekannt sein)
    measureXAngle.SetDisplayType("BARITEM horizontal filled");
    measureYAngle.SetDisplayType("VOLTAGE");

    measureXAngle.SetHeading("X");
    measureYAngle.SetHeading("Y");

    // Messwert "XAngleValue" und "YAngleValue" erzeugen
    // (Identifikator, Startwert, Einheit, untere und obere Grenze des Wertebereichs)
    Isom.Request.MeasuredValue xAngle =
        Isom.Request.MeasuredValue.CreateMeasuredValue("XAngleValue", "0.0", "°", "-15.0", "15.0");
    Isom.Request.MeasuredValue yAngle =
        Isom.Request.MeasuredValue.CreateMeasuredValue("YAngleValue", "0.0", "°", "-15.0", "15.0");

    // Zu Messgröße "XAngle" bzw. "YAngle" hinzufügen
    measureXAngle.AddMeasuredValue(xAngle);
    measureYAngle.AddMeasuredValue(yAngle);

    // Liste von Messgrößen erzeugen
    wizard.AddMeasurement("MesX", measureXAngle);
    wizard.AddMeasurement("MesY", measureYAngle);

    return true;
 }

Quelldateien:

  • Isom\Request\Measurement.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Request.Measurement.AddMeasuredValue ( Isom.Request.MeasuredValue measure )

Fügt einen Messwert der Liste hinzu.

Rückgabe:
Immer 'true'.
[Isom\Request\Measurement.is: 137]
objectbound Isom.Request.Measurement Isom.Request.Measurement.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
neue "Measurement" mit demselben Inhalt.
[Isom\Request\Measurement.is: 295]
objectbound Isom.Base.Boolean Isom.Request.Measurement.Contains ( Isom.Request.MeasuredValue element )

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Parameter:
element gesuchtes Element
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Request\Measurement.is: 272]
Isom.Request.Measurement Isom.Request.Measurement.CreateMeasurement ( Isom.Base.String key )

Erzeugt eine neue Liste.

Rückgabe:
Neue Listeninstanz.
[Isom\Request\Measurement.is: 129]
objectbound Isom.Request.MeasuredValue Isom.Request.Measurement.Current ( )

Liefert den aktuelle Messwert.

Rückgabe:
Aktueller Messwert oder ein Void-Objekt, falls der Iterator am Anfang der Liste steht.
[Isom\Request\Measurement.is: 253]
objectbound Isom.Request.MeasuredValue Isom.Request.Measurement.FindByKey ( Isom.Base.String key )

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Parameter:
key Identifikator des zu suchenden Objekts.
Rückgabe:
Das Objekt oder das Void-Objekt, falls die Liste kein Messwert mit diesem Identifikator enthält.
[Isom\Request\Measurement.is: 148]
objectbound Isom.Base.String Isom.Request.Measurement.GetDisplayType ( )

Liefert die aktuell gewünschte Darstellungsart.

Rückgabe:
Gewünschte Darstellungsart.
[Isom\Request\Measurement.is: 164]
objectbound Isom.Base.String Isom.Request.Measurement.GetHeading ( )

Gibt die optionale Überschrift für die Messwerte zurück.

Rückgabe:
Die optionale Überschrift, falls sie gesetzt ist, sonst "Void".
[Isom\Request\Measurement.is: 201]
objectbound Isom.Base.String Isom.Request.Measurement.GetKey ( )

Ruft den Identifikator der aktuellen Messwertgruppe ab.

Rückgabe:
Identifikator dieser Messwertgruppe.
[Isom\Request\Measurement.is: 156]
objectbound Isom.Base.Boolean Isom.Request.Measurement.HasNext ( )

Bestimmt, ob noch weitere Messwerte in der Liste vorhanden sind.

Rückgabe:
'true', falls weitere Messwerte vorhanden sind, 'false' sonst.
[Isom\Request\Measurement.is: 244]
objectbound Isom.Base.Boolean Isom.Request.Measurement.IsEmpty ( )

Prüft, ob die Liste Elemente enthält.

Rückgabe:
'true', falls keine Messwerte vorhanden sind, 'false' sonst.
[Isom\Request\Measurement.is: 225]
objectbound Isom.Base.Boolean Isom.Request.Measurement.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true' wenn es das Void-Objekt ist, 'false' sonst.
[Isom\Request\Measurement.is: 287]
objectbound Isom.Base.Number Isom.Request.Measurement.Length ( )

Liefert die Anzahl der Messwerte in der Liste.

Rückgabe:
Anzahl der Messwerte.
[Isom\Request\Measurement.is: 216]
objectbound Isom.Request.MeasuredValue Isom.Request.Measurement.Next ( )

Liefert den nächsten Messwerte.

Rückgabe:
Nächster Messwert in der Liste oder ein Void-Objekt, falls der Iterator auf dem letzten Objekt der Liste steht.
[Isom\Request\Measurement.is: 234]
objectbound Isom.Base.Boolean Isom.Request.Measurement.Reset ( )

Setzt den Listeniterator zurück.

Rückgabe:
Immer 'true'.
[Isom\Request\Measurement.is: 261]
objectbound Isom.Base.Boolean Isom.Request.Measurement.SetDisplayType ( Isom.Base.String displayType )

Legt die gewünschte Darstellungsart fest.

Die Darstellungsart muss dem Client bekannt sein. Momentan sind für den Taurus Client folgende Werte zulässig (ohne Berücksichtung der Groß-/Kleinschreibung):

  • baritem für eine lineare Anzeige
  • voltage für eine Skalenanzeige, ähnlich einem analogen Messgerät

Für den Wert baritem können zusätzliche Parameter angegeben werden:

  • horizontal oder vertical legt die Ausrichtung fest (Vorgabewert ist horizontal)
  • filled gibt an, dass ein ausgefüllter Balken statt einer Markierung angezeigt werden soll Mehrere Parameter werden durch Leerzeichen getrennt angegeben.

Rückgabe:
Immer 'true'.
[Isom\Request\Measurement.is: 185]
objectbound Isom.Base.Boolean Isom.Request.Measurement.SetHeading ( Isom.Base.String heading )

Setzt die optionale Überschrift für die Messwerte.

Rückgabe:
Immer 'true'
[Isom\Request\Measurement.is: 193]
Isom.Request.Measurement Isom.Request.Measurement.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
ungültiges Objekt
[Isom\Request\Measurement.is: 307]


für Serviceautoren

Isom.Request.MeasurementList

Namensraum Isom.Request.MeasurementList

Listen von Messwerten des Typs Isom.Request.Measurement Mehr...

Funktionen
Isom.Base.Boolean | AddMeasurement(Isom.Request.Measurement measure)

Fügt der Liste ein Element hinzu.

Isom.Request.MeasurementList | CreateMeasurementList()

Erzeugt eine neue Liste.

Isom.Request.Measurement | FindByKey(Isom.Base.String key)

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Listenfunktionen

Isom.Base.Boolean | Contains(Isom.Request.Measurement element)

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Isom.Request.Measurement | Current()

Liefert das aktuelle Elemente.

Isom.Base.Boolean | HasNext()

Bestimmt, ob noch weitere Elemente in der Liste vorhanden sind.

Isom.Base.Boolean | IsEmpty()

Prüft, ob die Liste Elemente enthält.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Request.Measurement | Next()

Liefert das nächste Element.

Isom.Base.Boolean | Reset()

Setzt den Listeniterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.MeasurementList | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.MeasurementList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Request.MeasurementList sind Listen von Messwerten des Typs Isom.Request.Measurement

Quelldateien:

  • Isom\Request\MeasurementList.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Request.MeasurementList.AddMeasurement ( Isom.Request.Measurement measure )

Fügt der Liste ein Element hinzu.

Rückgabe:
Immer 'true'.
[Isom\Request\MeasurementList.is: 85]
objectbound Isom.Request.MeasurementList Isom.Request.MeasurementList.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue "MeasurementList" mit demselben Inhalt.
[Isom\Request\MeasurementList.is: 189]
objectbound Isom.Base.Boolean Isom.Request.MeasurementList.Contains ( Isom.Request.Measurement element )

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Request\MeasurementList.is: 166]
Isom.Request.MeasurementList Isom.Request.MeasurementList.CreateMeasurementList ( )

Erzeugt eine neue Liste.

Rückgabe:
neue Listeninstanz
[Isom\Request\MeasurementList.is: 77]
objectbound Isom.Request.Measurement Isom.Request.MeasurementList.Current ( )

Liefert das aktuelle Elemente.

Rückgabe:
Aktuelles Elemente oder ein Void-Objekt, falls der Iterator am Anfang der Liste steht.
[Isom\Request\MeasurementList.is: 147]
objectbound Isom.Request.Measurement Isom.Request.MeasurementList.FindByKey ( Isom.Base.String key )

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Parameter:
key Identifikator des zu suchenden Objekts.
Rückgabe:
Das Element oder das Void-Objekt, falls die Liste kein Element mit diesem Identifikator enthält.
[Isom\Request\MeasurementList.is: 96]
objectbound Isom.Base.Boolean Isom.Request.MeasurementList.HasNext ( )

Bestimmt, ob noch weitere Elemente in der Liste vorhanden sind.

Rückgabe:
'true', falls weitere Elemente vorhanden sind, 'false' sonst.
[Isom\Request\MeasurementList.is: 138]
objectbound Isom.Base.Boolean Isom.Request.MeasurementList.IsEmpty ( )

Prüft, ob die Liste Elemente enthält.

Rückgabe:
'true', falls keine Elemente vorhanden sind, 'false' sonst.
[Isom\Request\MeasurementList.is: 119]
objectbound Isom.Base.Boolean Isom.Request.MeasurementList.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Request\MeasurementList.is: 181]
objectbound Isom.Base.Number Isom.Request.MeasurementList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

Rückgabe:
Anzahl der Elemente.
[Isom\Request\MeasurementList.is: 110]
objectbound Isom.Request.Measurement Isom.Request.MeasurementList.Next ( )

Liefert das nächste Element.

Rückgabe:
Nächstes Element in der Liste oder ein Void-Objekt, falls der Iterator auf dem letzten Objekt der Liste steht.
[Isom\Request\MeasurementList.is: 128]
objectbound Isom.Base.Boolean Isom.Request.MeasurementList.Reset ( )

Setzt den Listeniterator zurück.

Rückgabe:
Immer 'true'.
[Isom\Request\MeasurementList.is: 155]
Isom.Request.MeasurementList Isom.Request.MeasurementList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt
[Isom\Request\MeasurementList.is: 201]


für Serviceautoren

Isom.Request.MediaElement

Namensraum Isom.Request.MediaElement

Medienobjekt Mehr...

Funktionen
Funktion zur Erzeugung eines Medienobjektes

Isom.Request.MediaElement | CreateMediaElement(Isom.Base.String key, Isom.Base.String path)

Erzeugt ein neues Medienobjekt.

Instanzmethoden

Funktionen zum Lesen des Identifikators und des Pfades und zum Setzen des Pfades.

Isom.Base.String | GetKey()

Ruft den Identifikator des aktuellen Mediums ab.

Isom.Base.String | GetPath()

Ruft den relativen Pfad zur Mediendatei ab.

Isom.Base.Boolean | SetPath(Isom.Base.String text)

Legt den relativen Pfad der aktuellen Mediendatei fest.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.MediaElement | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.MediaElement | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Request.MediaElement ist ein Medienobjekt, das beispielsweise einen Verweis auf eine Grafik oder ein Video enthalten kann.

Quelldateien:

  • Isom\Request\MediaElement.is

Dokumentation der Funktionen

objectbound Isom.Request.MediaElement Isom.Request.MediaElement.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue "MediaElement" mit demselben Inhalt.
[Isom\Request\MediaElement.is: 134]
Isom.Request.MediaElement Isom.Request.MediaElement.CreateMediaElement | ( | Isom.Base.String | key,
 |  | Isom.Base.String | path
 | ) |  |

Erzeugt ein neues Medienobjekt.

Parameter:
key | Eindeutiger Identifikator des Medienobjekts
path | Relativer Pfad zum Medienobjekt
Rückgabe:
Neue Medienobjektinstanz.
[Isom\Request\MediaElement.is: 81]
objectbound Isom.Base.String Isom.Request.MediaElement.GetKey ( )

Ruft den Identifikator des aktuellen Mediums ab.

Rückgabe:
Identifikator dieses Mediums.
[Isom\Request\MediaElement.is: 95]
objectbound Isom.Base.String Isom.Request.MediaElement.GetPath ( )

Ruft den relativen Pfad zur Mediendatei ab.

Rückgabe:
Anzeigetext dieses Mediums.
[Isom\Request\MediaElement.is: 103]
objectbound Isom.Base.Boolean Isom.Request.MediaElement.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true' wenn es das Void-Objekt ist, 'false' sonst.
[Isom\Request\MediaElement.is: 126]
objectbound Isom.Base.Boolean Isom.Request.MediaElement.SetPath ( Isom.Base.String text )

Legt den relativen Pfad der aktuellen Mediendatei fest.

Rückgabe:
Immer 'true'.
[Isom\Request\MediaElement.is: 111]
Isom.Request.MediaElement Isom.Request.MediaElement.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
ungültiges Objekt
[Isom\Request\MediaElement.is: 146]


für Serviceautoren

Isom.Request.MediaList

Namensraum Isom.Request.MediaList

Listen von Medienobjekten des Typs Isom.Request.MediaElement Mehr...

Funktionen
Isom.Request.MediaList | CreateMediaList()

Erzeugt eine neue Liste.

Fachliche Funktionen

Funktionen, die das Erzeugen und Verwenden von Medienlisten ermöglichen.

Isom.Base.Boolean | AddMedia(Isom.Request.MediaElement med)

Fügt ein Medienobjekt der Liste hinzu.

Isom.Request.MediaElement | FindByKey(Isom.Base.String key)

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Listenfunktionen

Isom.Base.Boolean | Contains(Isom.Request.MediaElement element)

Abfrage, ob ein Element in der Liste vorhanden ist.

Isom.Request.MediaElement | Current()

Liefert das aktuelle Medienobjekt.

Isom.Base.Boolean | HasNext()

Bestimmt, ob noch weitere Medienobjekte in der Liste vorhanden sind.

Isom.Base.Boolean | IsEmpty()

Prüft, ob die Liste Elemente enthält.

Isom.Base.Number | Length()

Liefert die Anzahl der Medienobjekte in der Liste.

Isom.Request.MediaElement | Next()

Liefert die nächste Auswahlgruppe.

Isom.Base.Boolean | Reset()

Setzt den Listeniterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.MediaList | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.MediaList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Request.MediaList sind Listen von Medienobjekten des Typs Isom.Request.MediaElement

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Request\MediaList.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Request.MediaList.AddMedia ( Isom.Request.MediaElement med )

Fügt ein Medienobjekt der Liste hinzu.

Rückgabe:
Immer 'true'.
[Isom\Request\MediaList.is: 96]
objectbound Isom.Request.MediaList Isom.Request.MediaList.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue "MediaList" mit demselben Inhalt.
[Isom\Request\MediaList.is: 201]
objectbound Isom.Base.Boolean Isom.Request.MediaList.Contains ( Isom.Request.MediaElement element )

Abfrage, ob ein Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Request\MediaList.is: 178]
Isom.Request.MediaList Isom.Request.MediaList.CreateMediaList ( )

Erzeugt eine neue Liste.

Rückgabe:
Neue Listeninstanz.
[Isom\Request\MediaList.is: 82]
objectbound Isom.Request.MediaElement Isom.Request.MediaList.Current ( )

Liefert das aktuelle Medienobjekt.

Rückgabe:
Aktuelles Medienobjekt oder ein Void-Objekt, falls der Iterator am Anfang der Liste steht.
[Isom\Request\MediaList.is: 159]
objectbound Isom.Request.MediaElement Isom.Request.MediaList.FindByKey ( Isom.Base.String key )

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Parameter:
key Identifikator des zu suchenden Objekts
Rückgabe:
Das Medienobjekt oder das Void-Objekt, falls die Liste kein Medienobjekt mit diesem Identifikator enthält.
[Isom\Request\MediaList.is: 107]
objectbound Isom.Base.Boolean Isom.Request.MediaList.HasNext ( )

Bestimmt, ob noch weitere Medienobjekte in der Liste vorhanden sind.

Rückgabe:
'true', falls weitere Medienobjekte vorhanden sind, 'false' sonst.
[Isom\Request\MediaList.is: 150]
objectbound Isom.Base.Boolean Isom.Request.MediaList.IsEmpty ( )

Prüft, ob die Liste Elemente enthält.

Rückgabe:
'true', falls keine Medienobjekte vorhanden sind, 'false' sonst.
[Isom\Request\MediaList.is: 131]
objectbound Isom.Base.Boolean Isom.Request.MediaList.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true' wenn es das Void-Objekt ist, 'false' sonst.
[Isom\Request\MediaList.is: 193]
objectbound Isom.Base.Number Isom.Request.MediaList.Length ( )

Liefert die Anzahl der Medienobjekte in der Liste.

Rückgabe:
Anzahl der Medienobjekte
[Isom\Request\MediaList.is: 122]
objectbound Isom.Request.MediaElement Isom.Request.MediaList.Next ( )

Liefert die nächste Auswahlgruppe.

Rückgabe:
Nächste Auswahlgruppe in der Liste oder ein Void-Objekt, falls der Iterator auf dem letzten Objekt der Liste steht.
[Isom\Request\MediaList.is: 140]
objectbound Isom.Base.Boolean Isom.Request.MediaList.Reset ( )

Setzt den Listeniterator zurück.

Rückgabe:
Immer 'true'.
[Isom\Request\MediaList.is: 167]
Isom.Request.MediaList Isom.Request.MediaList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
ungültiges Objekt
[Isom\Request\MediaList.is: 213]


für Serviceautoren

Isom.Request.MessageElement

Namensraum Isom.Request.MessageElement

Dialogelement bei Eingabeaufforderungen Mehr...

Funktionen
Statische Funktionen

Funktionen, die für das Erzeugen von Anzeige- und Eigabeelemente zuständig sind.

Isom.Request.MessageElement | CreateMessage(Isom.Base.String key, Isom.Base.String text)

Erzeugt eine neues Anzeigelement.

Isom.Request.MessageElement | CreateNumberInput(Isom.Base.String key, Isom.Base.String text, Isom.Base.Number defVal)

Erzeugt ein neues Eingabeelement für Zahlen.

Isom.Request.MessageElement | CreateTextInput(Isom.Base.String key, Isom.Base.String text, Isom.Base.String defVal)

Erzeugt ein neues Eingabeelement für Texte.

Instanzfunktionen

Funktionen zum Auslesen des Identifikators, des Wertes und des Textes.

Isom.Base.String | GetKey()

Ruft den Identifikator des aktuellen Dialogelements ab.

Isom.Base.String | GetText()

Ruft den Anzeigetext eines Feldes ab.

Isom.Base.String | GetValue()

Ruft den Wert eines Eingabefeldes ab.

Funktionen für Datenimporte

Funktionen, die neue Eingabeelemente erzeugen. Zum Setzen und Lesen verschiedener Werte.

Isom.Request.MessageElement | CreateDataImportActivationCode(Isom.Base.String key, Isom.Base.String text, Isom.Plan.ActivationCode ac)

Erzeugt ein neues Eingabeelement für extern bereit zu stellende Daten für einen Freischaltcode.

Isom.Request.MessageElement | CreateDataImportInput(Isom.Base.String key, Isom.Base.String text, Isom.Base.String type)

Erzeugt ein neues Eingabeelement für extern bereit zu stellende Daten.

Isom.Request.MessageElement | CreateDataImportVehicleOrder(Isom.Base.String key, Isom.Base.String text)

Erzeugt ein neues Eingabeelement für extern bereit zu stellende Daten für einen Fahrzeugauftrag.

Isom.Base.String | GetDataImportIndex(Isom.Base.String key)

Liefert den Wert eines gesetzten Schlüssels.

Isom.Base.StringList | GetDataImportIndicesKeys()

Liefert alle Schlüssel von Indizes, die gesetzt sind.

Isom.Base.StringList | GetSuggestions()

Liefert für Eingabeelemente die vorgeschlagenen Werte.

Isom.Base.Boolean | SetDataImportIndex(Isom.Base.String key, Isom.Base.String value)

Setzt einen Index für den Datenimport.

Isom.Base.Boolean | SetSuggestions(Isom.Base.StringList suggestions)

Setzt für Eingabeelemente die vorgeschlagenen Werte.

Isom.Base.Boolean | SetUri(Isom.Base.String targetUri)

Setzt die Uri.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.MessageElement | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.MessageElement | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Request.MessageElement ist ein Dialogelement bei Eingabeaufforderungen

Quelldateien:

  • Isom\Request\MessageElement.is

Dokumentation der Funktionen

objectbound Isom.Request.MessageElement Isom.Request.MessageElement.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue ButtonList mit demselben Inhalt.
[Isom\Request\MessageElement.is: 288]
Isom.Request.MessageElement Isom.Request.MessageElement.CreateDataImportActivationCode | ( | Isom.Base.String | key,
 |  | Isom.Base.String | text,
 |  | Isom.Plan.ActivationCode | ac
 | ) |  |

Erzeugt ein neues Eingabeelement für extern bereit zu stellende Daten für einen Freischaltcode.

Parameter:
key | Eindeutiger Identifikator des Eingabeelements.
text | Anzeigetext mit Aufforderung zur Eingabe.
ac | Freischaltcode
Rückgabe:
Neue Dialogelementinstanz.
[Isom\Request\MessageElement.is: 190]
Isom.Request.MessageElement Isom.Request.MessageElement.CreateDataImportInput | ( | Isom.Base.String | key,
 |  | Isom.Base.String | text,
 |  | Isom.Base.String | type
 | ) |  |

Erzeugt ein neues Eingabeelement für extern bereit zu stellende Daten.

Parameter:
key | Eindeutiger Identifikator des Eingabeelements.
text | Anzeigetext mit Aufforderung zur Eingabe.
type | Den Typ der Eingabe und evtl. Parameter.
Rückgabe:
Neue Dialogelementinstanz.
[Isom\Request\MessageElement.is: 178]
Isom.Request.MessageElement Isom.Request.MessageElement.CreateDataImportVehicleOrder | ( | Isom.Base.String | key,
 |  | Isom.Base.String | text
 | ) |  |

Erzeugt ein neues Eingabeelement für extern bereit zu stellende Daten für einen Fahrzeugauftrag.

Die Fahrgestellnummer muss erfolgreich ermittelt worden sein.

Parameter:
key | Eindeutiger Identifikator des Eingabeelements.
text | Anzeigetext mit Aufforderung zur Eingabe.
Rückgabe:
Neue Dialogelementinstanz.
[Isom\Request\MessageElement.is: 202]
Isom.Request.MessageElement Isom.Request.MessageElement.CreateMessage | ( | Isom.Base.String | key,
 |  | Isom.Base.String | text
 | ) |  |

Erzeugt eine neues Anzeigelement.

Parameter:
key | Eindeutiger Identifikator des Anzeigeelements.
text | Anzeigetext.
Rückgabe:
Neue Dialogelementinstanz.
[Isom\Request\MessageElement.is: 102]
Isom.Request.MessageElement Isom.Request.MessageElement.CreateNumberInput | ( | Isom.Base.String | key,
 |  | Isom.Base.String | text,
 |  | Isom.Base.Number | defVal
 | ) |  |

Erzeugt ein neues Eingabeelement für Zahlen.

Parameter:
key | Eindeutiger Identifikator des Eingabeelements.
text | Anzeigetext.
defVal | Defaultwert für das Eingabefeld.
Rückgabe:
Neue Dialogelementinstanz.
[Isom\Request\MessageElement.is: 124]
Isom.Request.MessageElement Isom.Request.MessageElement.CreateTextInput | ( | Isom.Base.String | key,
 |  | Isom.Base.String | text,
 |  | Isom.Base.String | defVal
 | ) |  |

Erzeugt ein neues Eingabeelement für Texte.

Parameter:
key | Eindeutiger Identifikator des Eingabeelements.
text | Anzeigetext.
defVal | Defaultwert für das Eingabefeld.
Rückgabe:
Neue Dialogelementinstanz.
[Isom\Request\MessageElement.is: 113]
objectbound Isom.Base.String Isom.Request.MessageElement.GetDataImportIndex ( Isom.Base.String key )

Liefert den Wert eines gesetzten Schlüssels.

Zu beachten:
Diese Funktion kann nur für solche MessageElemente erfolgreich aufgerufen werden, die mit einer der CreateDataImport*-Funktionen erzeugt wurden.
Parameter:
key Schlüssel des Indexes
Rückgabe:
Wert des Schlüssels, falls erfolgreich.
[Isom\Request\MessageElement.is: 246]
objectbound Isom.Base.StringList Isom.Request.MessageElement.GetDataImportIndicesKeys ( )

Liefert alle Schlüssel von Indizes, die gesetzt sind.

Zu beachten:
Diese Funktion kann nur für solche MessageElemente erfolgreich aufgerufen werden, die mit einer der CreateDataImport*-Funktionen erzeugt wurden.
Rückgabe:
Liste von Schlüsseln, falls erfolgreich.
[Isom\Request\MessageElement.is: 235]
objectbound Isom.Base.String Isom.Request.MessageElement.GetKey ( )

Ruft den Identifikator des aktuellen Dialogelements ab.

Rückgabe:
Identifikator dieses Dialogelements.
[Isom\Request\MessageElement.is: 141]
objectbound Isom.Base.StringList Isom.Request.MessageElement.GetSuggestions ( )

Liefert für Eingabeelemente die vorgeschlagenen Werte.

Rückgabe:
Die für das Eingabeelement vorgeschlagenen Werte.
[Isom\Request\MessageElement.is: 263]
objectbound Isom.Base.String Isom.Request.MessageElement.GetText ( )

Ruft den Anzeigetext eines Feldes ab.

Rückgabe:
Anzeigetext.
[Isom\Request\MessageElement.is: 157]
objectbound Isom.Base.String Isom.Request.MessageElement.GetValue ( )

Ruft den Wert eines Eingabefeldes ab.

Rückgabe:
Wert des Eingabefeldes.
[Isom\Request\MessageElement.is: 149]
objectbound Isom.Base.Boolean Isom.Request.MessageElement.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Request\MessageElement.is: 280]
objectbound Isom.Base.Boolean Isom.Request.MessageElement.SetDataImportIndex | ( | Isom.Base.String | key,
 |  | Isom.Base.String | value
 | ) |  |

Setzt einen Index für den Datenimport.

Zu beachten:
Diese Funktion kann nur für solche MessageElemente erfolgreich aufgerufen werden, die mit einer der CreateDataImport*-Funktionen erzeugt wurden.
Parameter:
key | Schlüssel des Indexes
value | Wert des Indexes
Rückgabe:
'true' falls erfolgreich.
[Isom\Request\MessageElement.is: 225]
objectbound Isom.Base.Boolean Isom.Request.MessageElement.SetSuggestions ( Isom.Base.StringList suggestions )

Setzt für Eingabeelemente die vorgeschlagenen Werte.

Parameter:
suggestions vorgeschlagene Werte
Rückgabe:
immer 'true'
[Isom\Request\MessageElement.is: 255]
objectbound Isom.Base.Boolean Isom.Request.MessageElement.SetUri ( Isom.Base.String targetUri )

Setzt die Uri.

Zu beachten:
Diese Funktion kann nur für solche MessageElemente erfolgreich aufgerufen werden, die mit einer der CreateDataImport*-Funktionen erzeugt wurden.
Parameter:
targetUri Zu setzende Uri.
Rückgabe:
'true' falls erfolgreich.
[Isom\Request\MessageElement.is: 213]
Isom.Request.MessageElement Isom.Request.MessageElement.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Request\MessageElement.is: 300]


für Serviceautoren

Isom.Request.MessageList

Namensraum Isom.Request.MessageList

Listen von Dialogelementen des Typs Isom.Request.MessageElement Mehr...

Funktionen
Funktionen zur Erstellung und Verwendung von Dialogelementlisten

Funktionen, die das Erstellen und Verwenden von Dialogelementlisten ermöglichen.

Isom.Base.Boolean | AddMessage(Isom.Request.MessageElement but)

Fügt ein Element der Liste hinzu.

Isom.Request.MessageList | CreateMessageList()

Erzeugt eine neue Liste.

Isom.Request.MessageElement | FindByKey(Isom.Base.String key)

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Listenfunktionen

Isom.Base.Boolean | Contains(Isom.Request.MessageElement element)

Abfrage, ob ein Element in der Liste vorhanden ist.

Isom.Request.MessageElement | Current()

Liefert das aktuelle Dialogelement.

Isom.Base.Boolean | HasNext()

Bestimmt, ob noch weitere Dialogelemente in der Liste vorhanden sind.

Isom.Base.Boolean | IsEmpty()

Prüft, ob die Liste Elemente enthält.

Isom.Base.Number | Length()

Liefert die Anzahl der Dialogelemente in der Liste.

Isom.Request.MessageElement | Next()

Liefert das nächste Dialogelement.

Isom.Base.Boolean | Reset()

Setzt den Listeniterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.MessageList | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.MessageList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Request.MessageList sind Listen von Dialogelementen des Typs Isom.Request.MessageElement

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Request\MessageList.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Request.MessageList.AddMessage ( Isom.Request.MessageElement but )

Fügt ein Element der Liste hinzu.

Rückgabe:
Immer 'true'.
[Isom\Request\MessageList.is: 95]
objectbound Isom.Request.MessageList Isom.Request.MessageList.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue MessageList mit demselben Inhalt.
[Isom\Request\MessageList.is: 198]
objectbound Isom.Base.Boolean Isom.Request.MessageList.Contains ( Isom.Request.MessageElement element )

Abfrage, ob ein Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Request\MessageList.is: 175]
Isom.Request.MessageList Isom.Request.MessageList.CreateMessageList ( )

Erzeugt eine neue Liste.

Rückgabe:
Neue Listeninstanz.
[Isom\Request\MessageList.is: 87]
objectbound Isom.Request.MessageElement Isom.Request.MessageList.Current ( )

Liefert das aktuelle Dialogelement.

Rückgabe:
Aktuelles Dialogelement oder ein Void-Objekt, falls der Iterator am Anfang der Liste steht.
[Isom\Request\MessageList.is: 156]
objectbound Isom.Request.MessageElement Isom.Request.MessageList.FindByKey ( Isom.Base.String key )

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Parameter:
key Identifikator des zu suchenden Objekts.
Rückgabe:
Das Dialogelement oder das Void-Objekt, falls die Liste kein Element mit diesem Identifikator enthät.
[Isom\Request\MessageList.is: 106]
objectbound Isom.Base.Boolean Isom.Request.MessageList.HasNext ( )

Bestimmt, ob noch weitere Dialogelemente in der Liste vorhanden sind.

Rückgabe:
'true', falls weitere Dialogelemente vorhanden sind, 'false' sonst.
[Isom\Request\MessageList.is: 147]
objectbound Isom.Base.Boolean Isom.Request.MessageList.IsEmpty ( )

Prüft, ob die Liste Elemente enthält.

Rückgabe:
'true', falls keine Dialogelemente vorhanden sind, 'false' sonst.
[Isom\Request\MessageList.is: 128]
objectbound Isom.Base.Boolean Isom.Request.MessageList.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Request\MessageList.is: 190]
objectbound Isom.Base.Number Isom.Request.MessageList.Length ( )

Liefert die Anzahl der Dialogelemente in der Liste.

Rückgabe:
Anzahl der Dialogelemente.
[Isom\Request\MessageList.is: 120]
objectbound Isom.Request.MessageElement Isom.Request.MessageList.Next ( )

Liefert das nächste Dialogelement.

Rückgabe:
Nächstes Dialogelemente in der Liste oder ein Void-Objekt, falls der Iterator auf dem letzten Objekt der Liste steht.
[Isom\Request\MessageList.is: 137]
objectbound Isom.Base.Boolean Isom.Request.MessageList.Reset ( )

Setzt den Listeniterator zurück.

Rückgabe:
Immer 'true'.
[Isom\Request\MessageList.is: 164]
Isom.Request.MessageList Isom.Request.MessageList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Request\MessageList.is: 210]


für Serviceautoren

Isom.Request.Option

Namensraum Isom.Request.Option

Auswahldialoge in Benutzerinteraktionen Mehr...

Funktionen
Statische Methoden

Funktionen, die das Erzeugen von Optionen und Identifikator von Optionen ermöglichen.

Isom.Request.Option | CreateMultiColumnOption(Isom.Base.String key, Isom.Base.StringList values)

Erzeugt eine neue Option.

Isom.Request.Option | CreateOption(Isom.Base.String key, Isom.Base.String text)

Erzeugt eine neue Option.

Instanzmethoden

Funktionen, die das Auslesen des Identifikators und das Auslesen und Setzen des Textes ermöglichen.

Isom.Base.String | GetKey()

Ruft den Identifikator der aktuellen Option ab.

Isom.Base.String | GetText()

Ruft den Anzeigetext der aktuellen Option ab.

Isom.Base.Boolean | SetText(Isom.Base.String text)

Legt den Anzeigetext der aktuellen Option fest.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.Option | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.Option | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Request.Option sind Auswahldialoge in der Benutzerinteraktion. Optionen werden in Auswahlgruppen zusammengefasst.

Quelldateien:

  • Isom\Request\Option.is

Dokumentation der Funktionen

objectbound Isom.Request.Option Isom.Request.Option.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue Option mit demselben Inhalt.
[Isom\Request\Option.is: 152]
Isom.Request.Option Isom.Request.Option.CreateMultiColumnOption | ( | Isom.Base.String | key,
 |  | Isom.Base.StringList | values
 | ) |  |

Erzeugt eine neue Option.
Parameter:
key | Eindeutiger Identifikator der Option.
values | Mehrspaltiger Anzeigetext der Option.
Rückgabe:
Neue Optionsinstanz.
[Isom\Request\Option.is: 98]
Isom.Request.Option Isom.Request.Option.CreateOption | ( | Isom.Base.String | key,
 |  | Isom.Base.String | text
 | ) |  |

Erzeugt eine neue Option.

    Option a = Option.CreateOption ("1", Texts.OPTION_1);
Parameter:
key | Eindeutiger Identifikator der Option.
text | Anzeigetext der Option.
Rückgabe:
Neue Optionsinstanz.
[Isom\Request\Option.is: 85]
objectbound Isom.Base.String Isom.Request.Option.GetKey ( )

Ruft den Identifikator der aktuellen Option ab.

Rückgabe:
Identifikator dieser Option.
[Isom\Request\Option.is: 113]
objectbound Isom.Base.String Isom.Request.Option.GetText ( )

Ruft den Anzeigetext der aktuellen Option ab.

Rückgabe:
Anzeigetext dieser Option.
[Isom\Request\Option.is: 121]
objectbound Isom.Base.Boolean Isom.Request.Option.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Request\Option.is: 144]
objectbound Isom.Base.Boolean Isom.Request.Option.SetText ( Isom.Base.String text )

Legt den Anzeigetext der aktuellen Option fest.

Rückgabe:
Immer 'true'.
[Isom\Request\Option.is: 129]
Isom.Request.Option Isom.Request.Option.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Request\Option.is: 164]


für Serviceautoren

Isom.Request.RadioButton

Namensraum Isom.Request.RadioButton

Fachobjekt für Radiobuttons in Assistenten Mehr...

Funktionen
Namensraumfunktionen

Funktionen, die zum Auslesen, Setzen, Auswählen und Aktivieren benötigt werden.

Isom.Base.Boolean | EnableWizardNext()

Wenn dieser RadioButton ausgewählt ist, wird die Schaltfläche "Next" automatisch bedienbar.

Isom.Base.String | GetHint()

Ruft den Hinweistext des RadioButton ab

Isom.Base.String | GetKey()

Ruft den Schlüssel des RadioButton ab

Isom.Base.String | GetMessage()

Ruft den Nachrichtentext des RadioButton ab

Isom.Base.String | GetWizardNext()

Ruft den Namen der mit dem RadioButton verknüpften Funktion ab

Isom.Base.Boolean | Select()

Setzt diesen RadioButton als ausgewählt

Isom.Base.Boolean | SetHint(Isom.Base.String hint)

Setzt den Hinweistext des RadioButton

Isom.Base.Boolean | SetMessage(Isom.Base.String message)

Setzt den Nachrichtentext des RadioButton

Isom.Base.Boolean | SetWizardNext(Isom.Base.String nextFunction)

Verknüpft den RadioButton mit einer Funktion, die bei Betätigen der Weiter-Schaltfläche ausgeführt wird, falls dieser RadioButton selektiert ist.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.RadioButton | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob das aktuelle Element das Void-Objekt ist.

Isom.Request.RadioButton | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Isom.Request.RadioButton ist das Fachobjekt für Radiobuttons in Assistenten.

Quelldateien:

  • Isom\Request\RadioButton.is

Dokumentation der Funktionen

objectbound Isom.Request.RadioButton Isom.Request.RadioButton.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Rückgabe:
Kopie
[Isom\Request\RadioButton.is: 285]
objectbound Isom.Base.Boolean Isom.Request.RadioButton.EnableWizardNext ( )

Wenn dieser RadioButton ausgewählt ist, wird die Schaltfläche "Next" automatisch bedienbar.

 RadioButton rb = ..
 rb.EnableWizardNext();
Bemerkungen:
Bei Steuerung der Schrittkontrolle durch den Assistenten wird die Schaltfläche "Next" mit der Auswahl des RadioButtons verbunden, wenn dem RadioButton über Isom.Request.RadioButton.SetWizardNext eine Folgefunktion zugewiesen ist.
Ausnahmebehandlung:
Die Funktion kann nur während der manuellen Steuerung der Schrittkontrolle des zugehörigen Assistenten durch den Autor verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Rückgabe:
'true'
[Isom\Request\RadioButton.is: 257]
objectbound Isom.Base.String Isom.Request.RadioButton.GetHint ( )

Ruft den Hinweistext des RadioButton ab

 RadioButton rb = ..
 String hint = rb.GetHint();
Ausnahmebehandlung:
Wurde kein Hinweistext für den RadioButton festgelegt, wird das Void-Objekt zurückgegeben
Rückgabe:
Hinweistext des RadioButton
[Isom\Request\RadioButton.is: 148]
objectbound Isom.Base.String Isom.Request.RadioButton.GetKey ( )

Ruft den Schlüssel des RadioButton ab

 RadioButton rb = ..
 String key = rb.GetKey();
Rückgabe:
Schlüssel des RadioButton
[Isom\Request\RadioButton.is: 84]
objectbound Isom.Base.String Isom.Request.RadioButton.GetMessage ( )

Ruft den Nachrichtentext des RadioButton ab

 RadioButton rb = ..
 String text = rb.GetText();
Ausnahmebehandlung:
Wurde kein Nachrichtentext für den RadioButton festgelegt, wird das Void-Objekt zurückgegeben
Rückgabe:
Nachrichtentext des RadioButton
[Isom\Request\RadioButton.is: 116]
objectbound Isom.Base.String Isom.Request.RadioButton.GetWizardNext ( )

Ruft den Namen der mit dem RadioButton verknüpften Funktion ab

 RadioButton rb = ..
 String function = rb.GetWizardNext();
Ausnahmebehandlung:
Die Funktion kann nur während der Ausführung des zugehörigen Assistenten durch 'Run' mit Steuerung der Schrittkontrolle durch den Assistenten verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Wurde keine Funktion mit dem RadioButton verknüpft, wird das Void-Objekt zurückgegeben Void-Objekt zurückgegeben.
Rückgabe:
Name der mit dem RadioButton verknüpften Funktion
[Isom\Request\RadioButton.is: 219]
objectbound Isom.Base.Boolean Isom.Request.RadioButton.IsVoid ( )

Bestimmt, ob das aktuelle Element das Void-Objekt ist.

Rückgabe:
'true', falls das aktuelle Element das Void-Objekt ist, 'false' sonst.
[Isom\Request\RadioButton.is: 276]
objectbound Isom.Base.Boolean Isom.Request.RadioButton.Select ( )

Setzt diesen RadioButton als ausgewählt

 RadioButton rb = ..
 rb.Select();
Rückgabe:
'true'
[Isom\Request\RadioButton.is: 233]
objectbound Isom.Base.Boolean Isom.Request.RadioButton.SetHint ( Isom.Base.String hint )

Setzt den Hinweistext des RadioButton

 RadioButton rb = ..
 rb.SetHint("Dies führt zur Ausführung geeigneter Aktionen mit 'Weiter'");
Parameter:
hint Hinweistext des RadioButton
Rückgabe:
'true'
[Isom\Request\RadioButton.is: 132]
objectbound Isom.Base.Boolean Isom.Request.RadioButton.SetMessage ( Isom.Base.String message )

Setzt den Nachrichtentext des RadioButton

 RadioButton rb = ..
 rb.SetText("Ja");
Parameter:
message Nachrichtentext des RadioButton
Rückgabe:
'true'
[Isom\Request\RadioButton.is: 100]
objectbound Isom.Base.Boolean Isom.Request.RadioButton.SetWizardNext ( Isom.Base.String nextFunction )

Verknüpft den RadioButton mit einer Funktion, die bei Betätigen der Weiter-Schaltfläche ausgeführt wird, falls dieser RadioButton selektiert ist.

 Boolean Step1(IsomWizard wizard)
 {
   RadioButton rb = wizard.AddRadioButton("Ja");
   rb.SetWizardNext("Step2_Yes");
   RadioButton rb = wizard.AddRadioButton("Nein");
   rb.SetWizardNext("Step2_No");
   return true;
 }

 Boolean Step2_Yes(IsomWizard wizard)
 {
   ..
 }

 Boolean Step2_No(IsomWizard wizard)
 {
   ..
 }
Parameter:
nextFunction Funktion, die den Assistenten mit dem Inhalt des nächsten Dialogs befüllt.
Bemerkungen:
Für die Angabe des Parameters 'nextFunction' gelten die gleichen Regeln wie beim direkten Aufruf der Funktion. Hier kann wie im Codebeispiel der Funktionsname ohne Namensraumqualifizierung angegeben werden, falls die Funktion im gleichen Namenraum liegt, wie die Funktion, in der 'SetFunction' aufgerufen wird. Alternativ kann die Funktion mit einem vorangestellten Namensraum angegeben werden, z. B. mit 'OEM.Wizard1.Step2'. Es können nur Funktionen verwendet werden, die genau einen Parameter besitzen, der vom Typ 'IsomWizard' ist und ein 'Boolean' als Rückgabewert liefern. Kann der Parameter 'nextFunction' keiner ISOM/L-Funktion zugeordnet werden, die den Anforderungen entspricht, liefert der Aufruf von 'SetFunction' die Rückgabe 'Void'.
Ausnahmebehandlung:
Die Funktion kann nur während der Ausführung des zugehörigen Assistenten durch 'Run' mit Steuerung der Schrittkontrolle durch den Assistenten verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Erfüllt eine angegebene Funktion die Anforderungen nicht, wird das Void-Objekt zurückgegeben.
Rückgabe:
'true'
[Isom\Request\RadioButton.is: 198]
Isom.Request.RadioButton Isom.Request.RadioButton.Void ( )

Erzeugt ein Void-Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

Rückgabe:
Void-Objekt
[Isom\Request\RadioButton.is: 297]


für Serviceautoren

Isom.Request.SelectionGroup

Namensraum Isom.Request.SelectionGroup

Auswahlgruppenelemente in Benutzerinteraktionen Mehr...

Funktionen
Statische Funktionen

Funktionen zum Erzeugen und Auswählen bestimmter Elemente.

Isom.Request.SelectionGroup | CreateCheckBoxes(Isom.Base.String key)

Erzeugt eine neue Gruppe von Checkboxen.

Isom.Request.SelectionGroup | CreateDropDownList(Isom.Base.String key)

Erzeugt eine neue Drop-Down-Liste.

Isom.Request.SelectionGroup | CreateListBox(Isom.Base.String key)

Erzeugt ein neues Listenfeld.

Isom.Request.SelectionGroup | CreateMultiColumnList(Isom.Base.String key, Isom.Base.StringList colums)

Erzeugt ein neues Listenfeld.

Isom.Request.SelectionGroup | CreateRadioButtons(Isom.Base.String key)

Erzeugt eine neue Gruppe von Radiobuttons.

Instanzfunktionen

Funktionen zur Verwendung von Auswahlgruppenelementen.

Isom.Base.Boolean | AddOption(Isom.Request.Option option)

Fügt eine neue Option zur Auswahlgruppe hinzu.

Isom.Base.Boolean | Deselect(Isom.Base.String key)

Wählt die Option mit dem angegebenen Identifikator ab.

Isom.Base.String | GetHeading()

Gibt die optionale Überschrift für die Auswahlgruppe zurück.

Isom.Base.String | GetKey()

Ruft den Identifikator des aktuellen Dialogelements ab.

Isom.Base.StringList | GetSelectedKeys()

Liefert die Liste der Identifikatoren der gewählten Optionen.

Isom.Base.StringList | GetSelectedTexts()

Liefert die Liste der Anzeigetexte der gewählten Optionen.

Isom.Base.Boolean | IsExclusive()

Gibt an, ob die Auswahlgruppe exklusiv ist oder nicht.

Isom.Base.Boolean | Select(Isom.Base.String key)

Wählt die Option mit dem angegebenen Identifikator aus.

Isom.Base.Boolean | SetHeading(Isom.Base.String displayText)

Setzt die optionale Überschrift für die Auswahlgruppe.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.SelectionGroup | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.SelectionGroup | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Request.SelectionGroup sind Auswahlgruppenelemente in Benutzerinteraktionen.

Quelldateien:

  • Isom\Request\SelectionGroup.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Request.SelectionGroup.AddOption ( Isom.Request.Option option )

Fügt eine neue Option zur Auswahlgruppe hinzu.

Rückgabe:
'true' genau dann, wenn noch keine Option mit demselben Identifikator in der Auswahlgruppe enthalten ist.
[Isom\Request\SelectionGroup.is: 140]
objectbound Isom.Request.SelectionGroup Isom.Request.SelectionGroup.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue SelectionGroupList mit demselben Inhalt.
[Isom\Request\SelectionGroup.is: 234]
Isom.Request.SelectionGroup Isom.Request.SelectionGroup.CreateCheckBoxes ( Isom.Base.String key )

Erzeugt eine neue Gruppe von Checkboxen.

Parameter:
key Eindeutiger Identifikator des Anzeigeelements.
Rückgabe:
Neue Dialogelementinstanz.
[Isom\Request\SelectionGroup.is: 97]
Isom.Request.SelectionGroup Isom.Request.SelectionGroup.CreateDropDownList ( Isom.Base.String key )

Erzeugt eine neue Drop-Down-Liste.

Parameter:
key Eindeutiger Identifikator des Anzeigeelements.
Rückgabe:
Neue Dialogelementinstanz.
[Isom\Request\SelectionGroup.is: 106]
Isom.Request.SelectionGroup Isom.Request.SelectionGroup.CreateListBox ( Isom.Base.String key )

Erzeugt ein neues Listenfeld.

Parameter:
key Eindeutiger Identifikator des Anzeigeelements.
Rückgabe:
Neue Dialogelementinstanz.
[Isom\Request\SelectionGroup.is: 115]
Isom.Request.SelectionGroup Isom.Request.SelectionGroup.CreateMultiColumnList | ( | Isom.Base.String | key,
 |  | Isom.Base.StringList | colums
 | ) |  |

Erzeugt ein neues Listenfeld.

Parameter:
key | Eindeutiger Identifikator des Anzeigeelements.
colums | Liste mit den eindeutigen Namen der Spalte
Rückgabe:
Neue Dialogelementinstanz.
[Isom\Request\SelectionGroup.is: 125]
Isom.Request.SelectionGroup Isom.Request.SelectionGroup.CreateRadioButtons ( Isom.Base.String key )

Erzeugt eine neue Gruppe von Radiobuttons.

Parameter:
key Eindeutiger Identifikator des Anzeigeelements.
Rückgabe:
Neue Dialogelementinstanz.
[Isom\Request\SelectionGroup.is: 88]
objectbound Isom.Base.Boolean Isom.Request.SelectionGroup.Deselect ( Isom.Base.String key )

Wählt die Option mit dem angegebenen Identifikator ab.

Rückgabe:
Der neue Auswahlzustand der Option oder Void, falls die Option nicht in der Auswahlgruppe enthalten ist.
[Isom\Request\SelectionGroup.is: 194]
objectbound Isom.Base.String Isom.Request.SelectionGroup.GetHeading ( )

Gibt die optionale Überschrift für die Auswahlgruppe zurück.

Rückgabe:
Die optionale Überschrift, falls sie gesetzt ist, sonst "Void".
[Isom\Request\SelectionGroup.is: 211]
objectbound Isom.Base.String Isom.Request.SelectionGroup.GetKey ( )

Ruft den Identifikator des aktuellen Dialogelements ab.

Rückgabe:
Identifikator dieses Dialogelements.
[Isom\Request\SelectionGroup.is: 164]
objectbound Isom.Base.StringList Isom.Request.SelectionGroup.GetSelectedKeys ( )

Liefert die Liste der Identifikatoren der gewählten Optionen.

Rückgabe:
Die Liste der Identifikatoren der gewählten Optionen.
[Isom\Request\SelectionGroup.is: 148]
objectbound Isom.Base.StringList Isom.Request.SelectionGroup.GetSelectedTexts ( )

Liefert die Liste der Anzeigetexte der gewählten Optionen.

Rückgabe:
Die Liste der Anzeigetexte der gewählten Optionen.
[Isom\Request\SelectionGroup.is: 156]
objectbound Isom.Base.Boolean Isom.Request.SelectionGroup.IsExclusive ( )

Gibt an, ob die Auswahlgruppe exklusiv ist oder nicht.

In einer exklusiven Auswahlgruppe kann immer nur eine Option gleichzeitig ausgewählt sein, bei nichtexklusiven beliebig viele. Radiobuttons und Drop-Down-Listen sind exklusiv, Checkboxen und Listenfelder nicht.

Rückgabe:
Identifikator dieses Dialogelements.
[Isom\Request\SelectionGroup.is: 176]
objectbound Isom.Base.Boolean Isom.Request.SelectionGroup.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Request\SelectionGroup.is: 226]
objectbound Isom.Base.Boolean Isom.Request.SelectionGroup.Select ( Isom.Base.String key )

Wählt die Option mit dem angegebenen Identifikator aus.

Rückgabe:
Der neue Auswahlzustand der Option oder Void, falls die Option nicht in der Auswahlgruppe enthalten ist.
[Isom\Request\SelectionGroup.is: 185]
objectbound Isom.Base.Boolean Isom.Request.SelectionGroup.SetHeading ( Isom.Base.String displayText )

Setzt die optionale Überschrift für die Auswahlgruppe.

Rückgabe:
Immer 'true'.
[Isom\Request\SelectionGroup.is: 203]
Isom.Request.SelectionGroup Isom.Request.SelectionGroup.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Request\SelectionGroup.is: 246]


für Serviceautoren

Isom.Request.SelectionGroupList

Namensraum Isom.Request.SelectionGroupList

Listen von Auswahlgruppen in Benutzerinteraktionen des Typs Isom.Request.SelectionGroup Mehr...

Funktionen
Fachliche Funktionen

Funktionen, die die Erzeugung und Verwendung von Auswahlgruppenlisten ermöglichen.

Isom.Base.Boolean | AddSelectionGroup(Isom.Request.SelectionGroup sel)

Fügt eine Auswahlgruppe der Liste hinzu.

Isom.Request.SelectionGroupList | CreateSelectionGroupList()

Erzeugt eine neue Liste.

Isom.Request.SelectionGroup | FindByKey(Isom.Base.String key)

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Listenfunktionen

Isom.Base.Boolean | Contains(Isom.Request.SelectionGroup element)

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Isom.Request.SelectionGroup | Current()

Liefert die aktuelle Auswahlgruppe.

Isom.Base.Boolean | HasNext()

Bestimmt, ob noch weitere Auswahlgruppen in der Liste vorhanden sind.

Isom.Base.Boolean | IsEmpty()

Prüft, ob die Liste Auswahlgruppen enthält.

Isom.Base.Number | Length()

Liefert die Anzahl der Auswahlgruppen in der Liste.

Isom.Request.SelectionGroup | Next()

Liefert die nächste Auswahlgruppe.

Isom.Base.Boolean | Reset()

Setzt den Listeniterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.SelectionGroupList | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.SelectionGroupList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Request.SelectionGroupList sind Listen von Auswahlgruppen in Benutzerinteraktionen des Typs Isom.Request.SelectionGroup

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Request\SelectionGroupList.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Request.SelectionGroupList.AddSelectionGroup ( Isom.Request.SelectionGroup sel )

Fügt eine Auswahlgruppe der Liste hinzu.

Rückgabe:
Immer 'true'.
[Isom\Request\SelectionGroupList.is: 96]
objectbound Isom.Request.SelectionGroupList Isom.Request.SelectionGroupList.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue SelectionGroupList mit demselben Inhalt.
[Isom\Request\SelectionGroupList.is: 201]
objectbound Isom.Base.Boolean Isom.Request.SelectionGroupList.Contains ( Isom.Request.SelectionGroup element )

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Request\SelectionGroupList.is: 178]
Isom.Request.SelectionGroupList Isom.Request.SelectionGroupList.CreateSelectionGroupList ( )

Erzeugt eine neue Liste.

Rückgabe:
Neue Listeninstanz.
[Isom\Request\SelectionGroupList.is: 88]
objectbound Isom.Request.SelectionGroup Isom.Request.SelectionGroupList.Current ( )

Liefert die aktuelle Auswahlgruppe.

Rückgabe:
Aktuelle Auswahlgruppe oder ein Void-Objekt, falls der Iterator am Anfang der Liste steht.
[Isom\Request\SelectionGroupList.is: 159]
objectbound Isom.Request.SelectionGroup Isom.Request.SelectionGroupList.FindByKey ( Isom.Base.String key )

Sucht das über den Identifikator eindeutig gekennzeichnete Element aus der Liste.

Parameter:
key Identifikator des zu suchenden Objekts.
Rückgabe:
Das Auswahlgruppenobjekt oder das Void-Objekt, falls die Liste keine Auswahlgruppe mit diesem Identifikator enthält.
[Isom\Request\SelectionGroupList.is: 107]
objectbound Isom.Base.Boolean Isom.Request.SelectionGroupList.HasNext ( )

Bestimmt, ob noch weitere Auswahlgruppen in der Liste vorhanden sind.

Rückgabe:
'true', falls weitere Auswahlgruppen vorhanden sind, 'false' sonst.
[Isom\Request\SelectionGroupList.is: 150]
objectbound Isom.Base.Boolean Isom.Request.SelectionGroupList.IsEmpty ( )

Prüft, ob die Liste Auswahlgruppen enthält.

Rückgabe:
'true', falls keine Auswahlgruppen vorhanden sind, 'false' sonst.
[Isom\Request\SelectionGroupList.is: 131]
objectbound Isom.Base.Boolean Isom.Request.SelectionGroupList.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Request\SelectionGroupList.is: 193]
objectbound Isom.Base.Number Isom.Request.SelectionGroupList.Length ( )

Liefert die Anzahl der Auswahlgruppen in der Liste.

Rückgabe:
Anzahl der Auswahlgruppen.
[Isom\Request\SelectionGroupList.is: 122]
objectbound Isom.Request.SelectionGroup Isom.Request.SelectionGroupList.Next ( )

Liefert die nächste Auswahlgruppe.

Rückgabe:
Nächste Auswahlgruppe in der Liste oder ein Void-Objekt, falls der Iterator auf dem letzten Objekt der Liste steht.
[Isom\Request\SelectionGroupList.is: 140]
objectbound Isom.Base.Boolean Isom.Request.SelectionGroupList.Reset ( )

Setzt den Listeniterator zurück.

Rückgabe:
Immer 'true'.
[Isom\Request\SelectionGroupList.is: 167]
Isom.Request.SelectionGroupList Isom.Request.SelectionGroupList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Request\SelectionGroupList.is: 213]


für Serviceautoren

Isom.Request.UserRequest

Namensraum Isom.Request.UserRequest

Dialogfenster in Benutzerinteraktionen Mehr...

Funktionen
Statische Funktionen

Funktionen, die zur Erzeugung, Beendigung und zum Auslesen des Benutzerinteraktionobjektes benötigt werden.

Isom.Request.UserRequest | Create(Isom.Base.String title)

Erzeugt ein neues, leeres Benutzerinteraktionsobjekt.

Isom.Request.UserRequest | CreateRequest(Isom.Base.String title, Isom.Request.MessageList messages, Isom.Request.ButtonList buttons)

Erzeugt ein neues Benutzerinteraktionsobjekt mit Anzeige-/Eingabeelementen und Schaltflächen.

Isom.Base.Boolean | DisposeAll()

Ruft für alle aktiven Anfragen ein "Dispose" auf.

Isom.Request.UserRequest | GetRequest(Isom.Base.Number id)

Holt anhand der übergebenen ID ein bestehendes Benutzerinteraktionsobjekt.

Instanzfunktionen

Funktionen, die die Verwendung ermöglichen.

Isom.Base.Boolean | Close()

Schließt eine Benutzerinteraktion im Client.

Isom.Base.Boolean | Dispose()

Gibt alle Ressourcen dieser Benutzerinteraktion wieder frei.

Isom.Plan.TherapyPlanAction | GetAction()

Liefert das assoziierte Therapieplanaktions-Objekt der Anfrage.

Isom.Request.ButtonList | GetButtons()

Zugriff auf die Liste der Schaltflächen der Benutzeranfrage.

Isom.Context.Ecu | GetEcu()

Liefert das assoziierte ECU-Objekt der Anfrage.

Isom.Base.Number | GetId()

Liefert den Identifikator der Anfrage.

Isom.Base.String | GetLayoutType()

Zugriff auf die gewünschte Darstellungsart der Benutzeranfrage.

Isom.Diagnostics.MeasurementList | GetMeasurements()

Zugriff auf die Liste der Messwerte der Benutzeranfrage.

Isom.Request.MediaList | GetMedia()

Zugriff auf die Liste der Medienobjekte der Benutzeranfrage.

Isom.Request.MessageList | GetMessages()

Zugriff auf die Liste der Nachrichten der Benutzeranfrage.

Isom.Request.MessageList | GetRequestResults()

Liefert die Liste der Dialogelemente, wobei die Werte bei Eingabeelementen mit den Resultaten gefüllt wurden.

Isom.Request.Button | GetSelectedButton()

Liefert die vom Benutzer gewählte Schaltfläche zur Bestätigung der Interaktion.

Isom.Request.SelectionGroupList | GetSelectionGroups()

Zugriff auf die Liste der Auswahlgruppen der Benutzeranfrage.

Isom.Base.Number | GetTimer()

Liefert den gesetzten Wert für den Timer.

Isom.Base.String | GetTitle()

Zugriff auf den Titel der Benutzeranfrage.

Isom.Base.Boolean | IsElapsed()

Prüft, ob eine Benutzeranfrage mit zeitlich begrenzter Gültigkeitsdauer abgelaufen ist.

Isom.Base.Boolean | SetAction(Isom.Plan.TherapyPlanAction tpa)

Setzt eine Therapieplanaktion für die Anfrage.

Isom.Request.ButtonList | SetButtons(Isom.Request.ButtonList buttons)

Setzt die Liste der Schaltflächen der Benutzeranfrage.

Isom.Base.Boolean | SetEcu(Isom.Context.Ecu newEcu)

Setzt ein ECU-Objekt für die Anfrage.

Isom.Base.String | SetLayoutType(Isom.Base.String layoutType)

Setzt die gewünschte Darstellungsart der Benutzeranfrage.

Isom.Diagnostics.MeasurementList | SetMeasurements(Isom.Diagnostics.MeasurementList mlist)

Setzt die Liste der Messwerte der Benutzeranfrage.

Isom.Request.MediaList | SetMedia(Isom.Request.MediaList mediaElements)

Setzt die Liste der Medienobjekte der Benutzeranfrage.

Isom.Request.MessageList | SetMessages(Isom.Request.MessageList messages)

Setzt die Liste der Nachrichten der Benutzeranfrage.

Isom.Request.SelectionGroupList | SetSelectionGroups(Isom.Request.SelectionGroupList selectionGroups)

Setzt die Liste der Auswahlgruppen der Benutzeranfrage.

Isom.Base.Boolean | SetTimer(Isom.Base.Number time)

Setzt einen Timer für die Anfrage.

Isom.Base.String | SetTitle(Isom.Base.String title)

Setzt den Titel der Benutzeranfrage.

Isom.Base.Boolean | ShowRequest()

Erzeugt die Ereignisse zur Anzeige einer Benutzerinteraktion.

Isom.Base.Boolean | UpdateMeasurement(Isom.Base.String key)

Aktualisiert die Darstellung des Messwerts mit dem übergebenen Schlüssel.

Isom.Base.Boolean | UpdateMessage(Isom.Request.MessageElement message)

Erzeugt ein Ereignis zur Aktualisierung einer Benutzerinteraktion.

Isom.Base.Boolean | UpdateRequest(Isom.Request.MessageElement message)

Erzeugt ein Ereignis zur Aktualisierung einer Benutzerinteraktion.

Isom.Request.Button | WaitUserRequest()

Bringt eine Benutzerinteraktion zur Anzeige.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Request.UserRequest | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Request.UserRequest | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Request.UserRequest sind Dialogfenster in Benutzerinteraktionen

Quelldateien:

  • Isom\Request\UserRequest.is

Dokumentation der Funktionen

objectbound Isom.Request.UserRequest Isom.Request.UserRequest.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
neue Liste der Schaltflächen mit demselben Inhalt
[Isom\Request\UserRequest.is: 499]
objectbound Isom.Base.Boolean Isom.Request.UserRequest.Close ( )

Schließt eine Benutzerinteraktion im Client.

Rückgabe:
Immer 'true'.
[Isom\Request\UserRequest.is: 476]
Isom.Request.UserRequest Isom.Request.UserRequest.Create ( Isom.Base.String title )

Erzeugt ein neues, leeres Benutzerinteraktionsobjekt.

Parameter:
title Überschrift für ein Dialogfenster
Rückgabe:
Neues Benutzerinteraktionsobjekt.
[Isom\Request\UserRequest.is: 121]
Isom.Request.UserRequest Isom.Request.UserRequest.CreateRequest | ( | Isom.Base.String | title,
 |  | Isom.Request.MessageList | messages,
 |  | Isom.Request.ButtonList | buttons
 | ) |  |

Erzeugt ein neues Benutzerinteraktionsobjekt mit Anzeige-/Eingabeelementen und Schaltflächen.

Parameter:
title | Überschrift für ein Dialogfenster.
messages | Anzeige- und Eingabeelemente, die dem Benutzer angezeigt werden sollen.
buttons | Schaltflächen, die dem Benutzer angezeigt werden sollen.
Rückgabe:
neues Benutzerinteraktionsobjekt
[Isom\Request\UserRequest.is: 135 - 137]
objectbound Isom.Base.Boolean Isom.Request.UserRequest.Dispose ( )

Gibt alle Ressourcen dieser Benutzerinteraktion wieder frei.

Rückgabe:
Immer 'true'.
[Isom\Request\UserRequest.is: 236]
Isom.Base.Boolean Isom.Request.UserRequest.DisposeAll ( )

Ruft für alle aktiven Anfragen ein "Dispose" auf.

Rückgabe:
'true' im Erfolgsfall.
[Isom\Request\UserRequest.is: 156]
objectbound Isom.Plan.TherapyPlanAction Isom.Request.UserRequest.GetAction ( )

Liefert das assoziierte Therapieplanaktions-Objekt der Anfrage.

Rückgabe:
Assoziiertes Therapieplanaktions-Objekt; kann das Void-Objekt sein, wenn z.B. kein Therapieplanaktions-Objekt gesetzt wurde.
[Isom\Request\UserRequest.is: 278]
objectbound Isom.Request.ButtonList Isom.Request.UserRequest.GetButtons ( )

Zugriff auf die Liste der Schaltflächen der Benutzeranfrage.

Rückgabe:
Liste der Schaltflächen.
[Isom\Request\UserRequest.is: 366]
objectbound Isom.Context.Ecu Isom.Request.UserRequest.GetEcu ( )

Liefert das assoziierte ECU-Objekt der Anfrage.

Rückgabe:
Assoziiertes ECU-Objekt; kann das Void-Objekt sein, wenn z.B. kein ECU- Objekt gesetzt wurde.
[Isom\Request\UserRequest.is: 261]
objectbound Isom.Base.Number Isom.Request.UserRequest.GetId ( )

Liefert den Identifikator der Anfrage.

Rückgabe:
Eindeutiger Identifikator
[Isom\Request\UserRequest.is: 244]
objectbound Isom.Base.String Isom.Request.UserRequest.GetLayoutType ( )

Zugriff auf die gewünschte Darstellungsart der Benutzeranfrage.

Die Darstellungsart muss dem Client bekannt sein.

Rückgabe:
Die gewünschte Darstellungsart.
[Isom\Request\UserRequest.is: 458]
objectbound Isom.Diagnostics.MeasurementList Isom.Request.UserRequest.GetMeasurements ( )

Zugriff auf die Liste der Messwerte der Benutzeranfrage.

Rückgabe:
Liste der Messwerte.
[Isom\Request\UserRequest.is: 425]
objectbound Isom.Request.MediaList Isom.Request.UserRequest.GetMedia ( )

Zugriff auf die Liste der Medienobjekte der Benutzeranfrage.

Rückgabe:
Liste der Medienobjekte.
[Isom\Request\UserRequest.is: 406]
objectbound Isom.Request.MessageList Isom.Request.UserRequest.GetMessages ( )

Zugriff auf die Liste der Nachrichten der Benutzeranfrage.

Rückgabe:
Die Nachrichten-Liste.
[Isom\Request\UserRequest.is: 346]
Isom.Request.UserRequest Isom.Request.UserRequest.GetRequest ( Isom.Base.Number id )

Holt anhand der übergebenen ID ein bestehendes Benutzerinteraktionsobjekt.

Die Funktion liefert ein Void-Objekt, falls für diese ID kein Benutzerinteraktionselement erzeugt wurde, oder dieses nicht mehr besteht.

Parameter:
id Identifikator der Benutzerinteraktion
Rückgabe:
Bestehendes Benutzerinteraktionsobjekt oder Void-Objekt.
[Isom\Request\UserRequest.is: 148]
objectbound Isom.Request.MessageList Isom.Request.UserRequest.GetRequestResults ( )

Liefert die Liste der Dialogelemente, wobei die Werte bei Eingabeelementen mit den Resultaten gefüllt wurden.

Rückgabe:
Liste der Dialogelemente
[Isom\Request\UserRequest.is: 201]
objectbound Isom.Request.Button Isom.Request.UserRequest.GetSelectedButton ( )

Liefert die vom Benutzer gewählte Schaltfläche zur Bestätigung der Interaktion.

Rückgabe:
Gewählte Schaltfläche
[Isom\Request\UserRequest.is: 211]
objectbound Isom.Request.SelectionGroupList Isom.Request.UserRequest.GetSelectionGroups ( )

Zugriff auf die Liste der Auswahlgruppen der Benutzeranfrage.

Rückgabe:
Liste der Auswahlgruppen.
[Isom\Request\UserRequest.is: 386]
objectbound Isom.Base.Number Isom.Request.UserRequest.GetTimer ( )

Liefert den gesetzten Wert für den Timer.

Es wird die Gesamtdauer des Timers in Sekunden zurückgegeben. Falls kein Timer mittels 'SetTimer' gesetzt wurde, wird der Standard- wert '0' geliefert.

Rückgabe:
Zahl, die den Wert des Timers angibt.
[Isom\Request\UserRequest.is: 309]
objectbound Isom.Base.String Isom.Request.UserRequest.GetTitle ( )

Zugriff auf den Titel der Benutzeranfrage.

Rückgabe:
Der Titel.
[Isom\Request\UserRequest.is: 327]
objectbound Isom.Base.Boolean Isom.Request.UserRequest.IsElapsed ( )

Prüft, ob eine Benutzeranfrage mit zeitlich begrenzter Gültigkeitsdauer abgelaufen ist.

Rückgabe:
'true' wenn die Gültigkeitsdauer abgelaufen ist, 'false' sonst.
[Isom\Request\UserRequest.is: 318]
objectbound Isom.Base.Boolean Isom.Request.UserRequest.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Request\UserRequest.is: 491]
objectbound Isom.Base.Boolean Isom.Request.UserRequest.SetAction ( Isom.Plan.TherapyPlanAction tpa )

Setzt eine Therapieplanaktion für die Anfrage.

Rückgabe:
'true' im Erfolgsfall, 'false' wenn das übergebene Therapieplanaktions-Objekt Void war.
[Isom\Request\UserRequest.is: 269]
objectbound Isom.Request.ButtonList Isom.Request.UserRequest.SetButtons ( Isom.Request.ButtonList buttons )

Setzt die Liste der Schaltflächen der Benutzeranfrage.

Rückgabe:
Liste der Schaltflächen.
[Isom\Request\UserRequest.is: 376]
objectbound Isom.Base.Boolean Isom.Request.UserRequest.SetEcu ( Isom.Context.Ecu newEcu )

Setzt ein ECU-Objekt für die Anfrage.

Rückgabe:
'true' im Erfolgsfall, 'false' wenn das übergebene ECU-Objekt Void war.
[Isom\Request\UserRequest.is: 252]
objectbound Isom.Base.String Isom.Request.UserRequest.SetLayoutType ( Isom.Base.String layoutType )

Setzt die gewünschte Darstellungsart der Benutzeranfrage.

Die Darstellungsart muss dem Client bekannt sein.

Rückgabe:
Die gewünschte Darstellungsart.
[Isom\Request\UserRequest.is: 468]
objectbound Isom.Diagnostics.MeasurementList Isom.Request.UserRequest.SetMeasurements ( Isom.Diagnostics.MeasurementList mlist )

Setzt die Liste der Messwerte der Benutzeranfrage.

Rückgabe:
Liste der Messwerte.
[Isom\Request\UserRequest.is: 435]
objectbound Isom.Request.MediaList Isom.Request.UserRequest.SetMedia ( Isom.Request.MediaList mediaElements )

Setzt die Liste der Medienobjekte der Benutzeranfrage.

Rückgabe:
Liste der Medienobjekte.
[Isom\Request\UserRequest.is: 416]
objectbound Isom.Request.MessageList Isom.Request.UserRequest.SetMessages ( Isom.Request.MessageList messages )

Setzt die Liste der Nachrichten der Benutzeranfrage.

Rückgabe:
Die Nachrichten-Liste.
[Isom\Request\UserRequest.is: 356]
objectbound Isom.Request.SelectionGroupList Isom.Request.UserRequest.SetSelectionGroups ( Isom.Request.SelectionGroupList selectionGroups )

Setzt die Liste der Auswahlgruppen der Benutzeranfrage.

Rückgabe:
Liste der Auswahlgruppen.
[Isom\Request\UserRequest.is: 396]
objectbound Isom.Base.Boolean Isom.Request.UserRequest.SetTimer ( Isom.Base.Number time )

Setzt einen Timer für die Anfrage.

Die Angabe der Zeit erfolgt in Sekunden. Wird die Anfrage mittels "ShowRequest" angezeigt, beginnt der Timer zu zählen und sendet dem Client kontinuierlich eine Fortschrittsinformation, bis die gesetzte Zeit abgelaufen ist. Nach Ablauf des Timers wird intern kein 'Dispose' aufgerufen und keine explizite Nachricht zum Schließen des Dialogs an die Clients geschickt. Dies kann der Autor, falls gewünscht, mit dem Aufruf von "Dispose()" erreichen. Der Timer kann nur vor dem Aufruf von "ShowRequest" gesetzt werden. Ein späteres Setzen, während die Benutzeranfrage angezeigt wird, ist nicht möglich und liefert als Rückgabewert 'false'. Der gesetzt Timer hat keinen Einfluss, wenn der Dialog mittels "WaitUserRequest" angezeigt wird.

Parameter:
time Wird für 'time' ein Wert kleiner oder gleich 0 gesetzt, so wird der Timeout-Mechanismus nicht verwendet. Der Wert wird intern auf 0 gesetzt. Der übergebene Wert wird immer auf eine Ganzzahl abgerundet.
Rückgabe:
'true' im Erfolgsfall, 'false' sonst.
[Isom\Request\UserRequest.is: 299]
objectbound Isom.Base.String Isom.Request.UserRequest.SetTitle ( Isom.Base.String title )

Setzt den Titel der Benutzeranfrage.

Rückgabe:
Der Titel.
[Isom\Request\UserRequest.is: 336]
objectbound Isom.Base.Boolean Isom.Request.UserRequest.ShowRequest ( )

Erzeugt die Ereignisse zur Anzeige einer Benutzerinteraktion.

Es wird jedoch mit der Ausführung des Skripts fortgefahren.

Rückgabe:
Immer 'true'
[Isom\Request\UserRequest.is: 172]
objectbound Isom.Base.Boolean Isom.Request.UserRequest.UpdateMeasurement ( Isom.Base.String key )

Aktualisiert die Darstellung des Messwerts mit dem übergebenen Schlüssel.

Rückgabe:
'true' genau dann, wenn der Messwert mit dem übergebenen Schlüssel in der aktuellen Benutzeranfrage enthalten ist.
[Isom\Request\UserRequest.is: 447]
objectbound Isom.Base.Boolean Isom.Request.UserRequest.UpdateMessage ( Isom.Request.MessageElement message )

Erzeugt ein Ereignis zur Aktualisierung einer Benutzerinteraktion.

Rückgabe:
Immer 'true'.
[Isom\Request\UserRequest.is: 220]
objectbound Isom.Base.Boolean Isom.Request.UserRequest.UpdateRequest ( Isom.Request.MessageElement message )

Erzeugt ein Ereignis zur Aktualisierung einer Benutzerinteraktion.

Veraltet:
Veraltet seit Argonaut 1.9. Stattdessen UpdateMessage() verwenden.
Rückgabe:
Immer 'true'.
[Isom\Request\UserRequest.is: 228]
Isom.Request.UserRequest Isom.Request.UserRequest.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
ungültiges Objekt
[Isom\Request\UserRequest.is: 511]
objectbound Isom.Request.Button Isom.Request.UserRequest.WaitUserRequest ( )

Bringt eine Benutzerinteraktion zur Anzeige.

Das Skript wird solange angehalten, bis die Ergebnisse vorliegen.

   ButtonList buttons = ButtonList.CreateButtonList ();
   buttons.AddButton (Button.CreateButton("1", "Steuergerätespezifische Aktionen"));
   buttons.AddButton (Button.CreateButton("2", "Ende"));
   String mainTitle = "Editierung des Therapieplans";
   UserRequest mainReq = UserRequest.Create(mainTitle);
   String selectedKey = mainReq.WaitUserRequest().GetKey ();
Rückgabe:
Die Schaltfläche, die vom Benutzer gewählt wurde.
[Isom\Request\UserRequest.is: 192]


für Serviceautoren

Isom.Request.Wizard

Namensraum Isom.Request.Wizard

Fachobjekt für Assistenten Mehr...

Funktionen
Funktionen zur Erzeugung, Start und Verwaltung von Assistenten

Isom.Request.Wizard | Create()

Erzeugt einen neuen Assistenten

Isom.Base.Boolean | Dispose()

Schließt und löscht den Assistenten

Isom.Base.String | GetKey()

Fragt den identifizierenden Schlüssel ab.

Isom.Base.String | GetUpdateFunction()

Fragt die Aktualisierungsfunktion ab.

Isom.Request.Wizard | GetWizard(Isom.Base.String key)

Fragt einen bereits erzeugten Assistenten anhand seines identifizierenden Schlüssels ab

Isom.Base.Boolean | Run(Isom.Base.String function, Isom.Base.Boolean wizardControlledWorkflow)

Startet die Ausführung des Assistenten.

Isom.Base.Boolean | SetUpdateFunction(Isom.Base.String updateFunction)

Setzt die Aktualisierungsfunktion.

Schaltflächenbezogene Funktionen

Isom.Base.Boolean | DisableBack()

Deaktiviert die Zurück-Schaltfläche, so dass sie nicht verwendet werden kann

Isom.Base.Boolean | DisableNext()

Deaktiviert die Weiter-Schaltfläche, so dass sie nicht verwendet werden kann

Isom.Base.String | GetLabelButtonBack()

Fragt die Beschriftung der Schaltfläche 'Zurück' ab.

Isom.Base.String | GetLabelButtonDone()

Fragt die Beschriftung der Schaltfläche 'Beenden' ab.

Isom.Base.String | GetLabelButtonNext()

Fragt die Beschriftung der Schaltfläche 'Weiter' ab.

Isom.Base.String | GetLabelButtonQuit()

Fragt die Beschriftung der Schaltfläche 'X' ab.

Isom.Base.String | GetNext()

Fragt ab, welche Funktion mit der Weiter-Schaltfläche verknüpft ist

Isom.Request.Wizard | GetPreviousStep()

Ermittelt den Assistenten aus dem vorhergehenden Schritt

Isom.Base.String | GetQuit()

Fragt ab, welche Funktion beim Beenden des Assistenten ausgeführt wird

Isom.Base.Boolean | SetLabelButtonBack(Isom.Base.String label)

Setzt die Beschriftung für die Schaltfläche 'Zurück'.

Isom.Base.Boolean | SetLabelButtonDone(Isom.Base.String label)

Setzt die Beschriftung für die Schaltfläche 'Beenden'.

Isom.Base.Boolean | SetLabelButtonNext(Isom.Base.String label)

Setzt die Beschriftung für die Schaltfläche 'Weiter'.

Isom.Base.Boolean | SetLabelButtonQuit(Isom.Base.String label)

Setzt die Beschriftung für die Schaltfläche 'X'.

Isom.Base.Boolean | SetNext(Isom.Base.String nextFunction, Isom.Base.Boolean lastStep)

Bietet zwei Möglichkeiten an, die Weiter-Schaltfläche anzupassen: 1.

Isom.Base.Boolean | SetQuit(Isom.Base.String quitFunction)

Setzt eine Funktion, die beim Beenden des Assistenten aufgerufen wird

Funktionen zum angezeigten Inhalt des Assistenten

Isom.Base.Boolean | AddMeasurement(Isom.Base.String key, Isom.Diagnostics.Measurement measurement)

Fügt dem beschriebenen Dialogschritt eine Gruppe von Messwerten im Nachrichtenfenster des Assistenten hinzu

Isom.Base.Boolean | AddMessage(Isom.Base.String key, Isom.Base.String message)

Fügt einen Text zum beschriebenen Dialogschritt hinzu

Isom.Request.UserRequest | GetContentDialog()

Ruft das Fachobjekt ab, das den Inhalt des Nachrichtenfenster beschreibt

Isom.Base.String | GetContentTitle()

Ruft den Titel des Inhaltelements des Assistenten ab

Isom.Base.String | GetDescription()

Ruft den Dokumentenverweis zur Beschreibung des Assistenten ab

Isom.Base.String | GetDescriptionTitle()

Ruft den Titel des Elements zur Beschreibung des Assistenten ab

Isom.Base.String | GetHelp()

Ruft den Dokumentenverweis zur Hilfe für die Benutzung des Assistenten ab

Isom.Base.String | GetHelpTitle()

Ruft den Titel der Hilfe für die Benutzung des Assistenten ab

Isom.Base.String | GetLayoutType()

Liefert den eingestellten Darstellungstypen des Assistenten

Isom.Diagnostics.Measurement | GetMeasurement(Isom.Base.String key)

Ruft eine Gruppe von Messwerten im Nachrichtenfenster des beschriebenen Dialogschritts ab

Isom.Base.String | GetMedia()

Ruft den Verweis auf das Medienelement des Assistenten ab

Isom.Base.String | GetMediaTitle()

Ruft den Titel des Medienelements des Assistenten ab

Isom.Base.String | GetMessage(Isom.Base.String key)

Ruft einen für den beschriebenen Dialogschritt festgelegten Text ab

Isom.Base.String | GetTitle()

Ruft den Titel des Assistenten ab

Isom.Base.Boolean | SetContentTitle(Isom.Base.String title)

Legt den Titel des Inhaltelements des Assistenten fest

Isom.Base.Boolean | SetDescription(Isom.Base.String descriptionFile)

Legt das Dokument fest, das zur Beschreibung des Assistenten angezeigt wird.

Isom.Base.Boolean | SetDescriptionTitle(Isom.Base.String title)

Legt den Titel des Elements zur Beschreibung des Assistenten fest

Isom.Base.Boolean | SetHelp(Isom.Base.String helpFile)

Legt das Dokument fest, das zur Hilfe für die Benutzung des Assistenten angezeigt wird

Isom.Base.Boolean | SetHelpTitle(Isom.Base.String title)

Legt den Titel der Hilfe für die Benutzung des Assistenten fest

Isom.Base.Boolean | SetLayoutType(Isom.Base.String layout)

Setzt den Darstellungstypen des Assistenten

Isom.Base.Boolean | SetMeasurement(Isom.Base.String key, Isom.Diagnostics.Measurement measurement)

Aktualisiert eine Gruppe von Messwerten im Nachrichtenfenster des beschriebenen Dialogschritts

Isom.Base.Boolean | SetMedia(Isom.Base.String mediaFile)

Legt das Medienelement fest, das im Assistenten angezeigt werden soll

Isom.Base.Boolean | SetMediaTitle(Isom.Base.String title)

Legt den Titel des Medienelements des Assistenten fest

Isom.Base.Boolean | SetMessage(Isom.Base.String key, Isom.Base.String message)

Aktualisiert einen Text im Dialogschritt, während er angezeigt wird.

Isom.Base.Boolean | SetTitle(Isom.Base.String title)

Setzt den anzuzeigenden Titel des Assistenten

Funktionen für Benutzerinteraktionen

Isom.Request.RadioButton | AddRadioButton(Isom.Base.String key, Isom.Base.String rbText)

Erzeugt einen RadioButton, der dem Nachrichtenfenster des beschriebenen Dialogschritts hinzugefügt wird

Isom.Base.Boolean | AddTextInput(Isom.Base.String key, Isom.Base.String inputDescription, Isom.Base.String defaultValue)

Fügt ein Texteingabefeld im Nachrichtenfenster des beschriebenen Dialogschritts hinzu

Isom.Request.RadioButton | GetRadioButton(Isom.Base.String key)

Fragt einen RadioButton ab

Isom.Base.String | GetSelectedButton()

Fragt die betätigte Schaltfläche ab.

Isom.Request.RadioButton | GetSelectedRadioButton()

Fragt den ausgewählten RadioButton ab

Isom.Base.String | GetTextInput(Isom.Base.String key)

Ruft den Wert eines Texteingabefelds ab

Funktionen zur Historie

Isom.Base.Boolean | IsVisited()

Ruft ab, ob der Dialogschritt schon einmal ausgeführt wurde

Funktionen zur Speicherung von Daten im Assistenten

Isom.Base.Boolean | AddBoolean(Isom.Base.String key, Isom.Base.Boolean value)

Speichert einen Wahrheitswert im Assistenten.

Isom.Base.Boolean | AddNumber(Isom.Base.String key, Isom.Base.Number value)

Speichert eine Zahl im Assistenten.

Isom.Base.Boolean | AddString(Isom.Base.String key, Isom.Base.String value)

Speichert eine Zeichenkette im Assistenten.

Isom.Base.Boolean | GetBoolean(Isom.Base.String key)

Fragt einen vorher zur Datenhaltung an den Assistenten übergebenen Wahrheitswert ab

Isom.Base.Number | GetNumber(Isom.Base.String key)

Fragt einen vorher zur Datenhaltung an den Assistenten übergebenen Zahlenwert ab

Isom.Base.String | GetString(Isom.Base.String key)

Fragt eine vorher zur Datenhaltung an den Assistenten übergebene Zeichenkette ab

Funktionen für Assistenten mit autorengesteuerter Schrittkontrolle

Isom.Base.Boolean | ClearWizard()

Setzt den Assistenten zurück auf die Einstellungen, die vor der Ausführung des Assistenten mit 'Run' gemacht wurden

Isom.Base.Boolean | ShowWizard()

Zeigt einen Dialog an und kehrt zurück, ohne auf eine Schaltflächenbetätigung zu warten

Isom.Base.String | WaitWizard()

Zeigt einen Dialog an und wartet auf eine Schaltflächenbetätigung

Allgemeine Funktionen

Isom.Request.Wizard | Clone()

Liefert das aktuelle Objekt.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob das aktuelle Element das Void-Objekt ist.

Isom.Request.Wizard | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Dieses Fachobjekt unterstützt die Erstellung von Assistenten. Es bietet dazu z. B. Funktionen an, mit denen sich der textuelle Inhalt und die Funktionalität von Schaltflächen jedes Schritts in der Dialogfolge angeben lassen.

Gestartet wird die Anzeige des Assistenten mit der Funktion 'Run'. Als erster Parameter 'function' wird der Name einer Funktion übergeben, die aufgerufen wird, um das Aussehen des Assistenten und die möglichen nächsten Dialogschritte festzulegen. Der zweite Parameter 'wizardControlledWorkflow' ist ein Wahrheitswert und legt fest, wie die Abarbeitung der Dialogschrittschritte gesteuert wird. Ist der Parameter 'true', übernimmt der Assistent einige Aufgaben selbst, wie z. B. den Aufruf zur Anzeige des nächsten Dialogschritts. Ist er 'false', übernimmt der ISOM/L-Autor diese Aufgaben, was ihm eine größere Flexibilität ermöglicht. Durch diese Unterscheidung ergeben sich zwei Arten, wie ein Assistent definiert werden kann:

1. Mit Schrittsteuerung durch den Assistenten

Die in 'Run' übergebene Funktion beschreibt, wie der erste Dialogschritt aussieht. Nach Auswertung der Funktion wird der Schritt automatisch angezeigt. Der durch die Schaltfläche 'Weiter' erreichbare, nächste Dialogschritt wird mit der Funktion 'SetNext' angegeben. Als Parameter wird wiederum der Name der Funktion mit den Festlegungen des nächsten Dialogschritts übergeben. Eine Abfolge von Dialogen wird so durch die Verwendung von 'SetNext' in der beschreibenden Funktion jedes Einzelschritts definiert.

 Isom.Base.Boolean StartWizard()
 {
   Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
   wizard.SetContentTitle("Hinweise"); //Titel des Reiters für Inhalte mit Benutzerinteraktionen
   wizard.Run("Step1", true); //Der Assistent beginnt mit dem Dialogschritt,
                              //der durch die Funktion 'Step1' definiert wird.
 }

 Isom.Base.Boolean Step1(Isom.Request.Wizard wizard)
 {
   //...
   wizard.SetNext("Step2", false); //Verknüpt die Weiter-Schaltfläche mit 'Step2'
   //...
 }

 Isom.Base.Boolean Step2(Isom.Request.Wizard wizard)
 {
   //...
   wizard.SetNext("Exit", true);   //Verknüpt die Weiter-Schaltfläche mit 'Exit'
   //...
 }

 Isom.Base.Boolean Exit(Isom.Request.Wizard wizard)
 {
   wizard.Dispose();        //Löscht den Assistenten
 }
Bemerkungen:
Mit 'SetUpdateFunction' lässt sich für die automatische Schrittverwaltung bei der Festlegung eines Dialogschritts auch eine Funktion angeben, die während der Anzeige des Schritts ausgeführt wird. Sie erlaubt es, durch Aufruf von Funktionen, die den Inhalt verändern, die Anzeige zu aktualisieren.
Bei der automatischen Schrittverwaltung baut die Definition eines Schritts auf einem leeren Schritt auf, so dass keine Elemente des vorhergehenden Dialogschritts übernommen werden. Eine Ausnahme bilden dabei die Festlegungen, die vor dem Aufruf von 'Run' getroffen wurden. Sie gelten für jeden Dialogschritt, ohne dass sie explizit angegeben werden müssen.
Bei der automatischen Schrittverwaltung wird bei Betätigung der 'Zurück'-Schaltfläche die Funktion des vorhergehenden Dialogschritts ausgeführt. Diese Funktionalität läßt sich mit 'DisableBack' deaktivieren.

2. Mit manueller Schrittsteuerung durch den Autor

Die in 'Run' übergebene Funktion enthält in diesem Modus den gesamten Dialogablauf. Der Autor steuert in der Funktion selbst, wann ein Schritt angezeigt wird. Dazu stehen ihm die zwei Funktionen 'ShowWizard' und 'WaitWizard' zur Verfügung. Ein Aufruf von 'ShowWizard' aktualisiert die Anzeige des Assistenten und kehrt zurück, ohne auf die Betätigung einer Schaltfläche zu warten. 'WaitWizard' aktualisiert die Anzeige und wartet auf die Betätigung einer Schaltfläche. Als Rückgabeergebnis eines Aufrufs von 'WaitWizard' wird der Schlüssel der betätigten Schaltfläche geliefert. Dabei sind die Werte "Next", "Back" und "Quit" möglich.

 Isom.Base.Boolean StartWizard()
 {
   Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
   wizard.Run("Dispatcher", false); //Der Assistent ruft die Funktion 'Dispatcher' auf,
                                    //die eine autorengesteuerten Dialogabfolge enthält.
 }

 Isom.Base.Boolean Dispatcher(Isom.Request.Wizard wizard)
 {
   wizard.AddMessage("FirstMessage", "Erster Schritt: Warte auf Betätigung einer Schaltfläche..");
   Isom.Base.String button = wizard.WaitWizard();
   switch (button)
   {
     case "Next": //Benutzer hat auf 'Weiter' geklickt
     {
        //...
     }
     case "Back": //Benutzer hat auf 'Zurück' geklickt
     {
        //...
     }
     case "Quit": //Benutzer hat den Assistenten beendet
     {
        //...
     }
     default:
     {
        //...
     }

   }
 }

Hinweise

Bemerkungen:
Alle Funktionen dieses Fachobjekts liefern ein Void-Objekt als Rückgabe, falls einer ihrer Aufrufparameter das Void-Objekt ist.

Quelldateien:

  • Isom\Request\Wizard.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Request.Wizard.AddBoolean | ( | Isom.Base.String | key,
 |  | Isom.Base.Boolean | value
 | ) |  |

Speichert einen Wahrheitswert im Assistenten.

Der Wert wird zusammen mit einem Schlüssel übergeben, der das Abrufen des Wahrheitswerts mit 'GetBoolean' erlaubt

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.AddBoolean("Key1", true);
Parameter:
key | Schlüssel des Wahrheitswerts
value | Zu speichernder Wahrheitswert
Ausnahmebehandlung:
Falls einer der Parameter 'key' und 'value' ein Void-Objekt ist, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1612]
objectbound Isom.Base.Boolean Isom.Request.Wizard.AddMeasurement | ( | Isom.Base.String | key,
 |  | Isom.Diagnostics.Measurement | measurement
 | ) |  |

Fügt dem beschriebenen Dialogschritt eine Gruppe von Messwerten im Nachrichtenfenster des Assistenten hinzu

 Isom.Diagnostics.Measurement measurement = Isom.Diagnostics.Measurement.CreateMeasurement("XAngle");
 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.AddMeasurement("Measurement_01", measurement);
Parameter:
key | Schlüssel
measurement | Messwerte
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Bemerkungen:
Gibt es bereits eine Messwertgruppe mit dem Schlüssel, wird sie durch die übergebene Gruppe ersetzt
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1217]
objectbound Isom.Base.Boolean Isom.Request.Wizard.AddMessage | ( | Isom.Base.String | key,
 |  | Isom.Base.String | message
 | ) |  |

Fügt einen Text zum beschriebenen Dialogschritt hinzu

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.AddMessage("MSG1", Texts.MESSAGE_WIZARD01);
Parameter:
key | Schlüssel
message | Nachricht
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Bemerkungen:
Gibt es bereits einen Text mit dem Schlüssel, wird er durch den übergebenen Text ersetzt
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1123]
objectbound Isom.Base.Boolean Isom.Request.Wizard.AddNumber | ( | Isom.Base.String | key,
 |  | Isom.Base.Number | value
 | ) |  |

Speichert eine Zahl im Assistenten.

Der Wert wird zusammen mit einem Schlüssel übergeben, der das Abrufen der Zahl mit 'GetNumber' erlaubt

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.AddNumber("Key1", 5);
Parameter:
key | Schlüssel des Zahlenwerts
value | Zu speichernder Zahlenwert
Ausnahmebehandlung:
Falls einer der Parameter 'key' und 'value' ein Void-Objekt ist, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1568]
objectbound Isom.Request.RadioButton Isom.Request.Wizard.AddRadioButton | ( | Isom.Base.String | key,
 |  | Isom.Base.String | rbText
 | ) |  |

Erzeugt einen RadioButton, der dem Nachrichtenfenster des beschriebenen Dialogschritts hinzugefügt wird

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 RadioButton rb = wizard.AddRadioButton("SelectYes", "Ja");
 RadioButton rb = wizard.AddRadioButton("SelectNo", "Nein");
Parameter:
key | Schlüssel des RadioButton
rbText | Nachrichtentext des RadioButton
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Bemerkungen:
Gibt es bereits einen RadioButton mit dem Schlüssel, wird er ersetzt
Rückgabe:
Erzeugter RadioButton
[Isom\Request\Wizard.is: 1392]
objectbound Isom.Base.Boolean Isom.Request.Wizard.AddString | ( | Isom.Base.String | key,
 |  | Isom.Base.String | value
 | ) |  |

Speichert eine Zeichenkette im Assistenten.

Der Wert wird zusammen mit einem Schlüssel übergeben, der das Abrufen der Zeichenkette mit 'GetString' erlaubt

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.AddString("Key1", "Value1");
Parameter:
key | Schlüssel des Zeichenkettenwerts
value | Zu speichernder Zeichenkettenwert
Ausnahmebehandlung:
Falls einer der Parameter 'key' und 'value' ein Void-Objekt ist, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1524]
objectbound Isom.Base.Boolean Isom.Request.Wizard.AddTextInput | ( | Isom.Base.String | key,
 |  | Isom.Base.String | inputDescription,
 |  | Isom.Base.String | defaultValue
 | ) |  |

Fügt ein Texteingabefeld im Nachrichtenfenster des beschriebenen Dialogschritts hinzu

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.AddTextInput("FgNr", "Fahrgestellnummer", "");
Parameter:
key | Schlüssel des Texteingabefelds
inputDescription | Texthinweis zum Eingabefeld
defaultValue | Voreingestellter Wert im Eingabefeld
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Bemerkungen:
Gibt es bereits ein Texteingabefeld mit dem Schlüssel, wird es mit den übergebenen Werten ersetzt
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1348]
objectbound Isom.Base.Boolean Isom.Request.Wizard.ClearWizard ( )

Setzt den Assistenten zurück auf die Einstellungen, die vor der Ausführung des Assistenten mit 'Run' gemacht wurden

 Isom.Base.Boolean StartWizard()
 {
   Isom.Request.Wizard wizard = Wizard.Create();
   wizard.SetTitle("MyTitle");
   wizard.Run("Dispatcher", false); //Der Assistent ruft die Funktion 'Dispatcher' auf,
                                    //die eine autorengesteuerten Dialogabfolge enthält.
 }

 Isom.Base.Boolean Dispatcher(Isom.Request.Wizard wizard)
 {
   wizard.AddMessage("FirstMessage", "Erster Schritt");
   Isom.Base.String button = wizard.WaitWizard();  //Zeigt den Dialog mit Text "FirstMessage" an und
                                                   //wartet auf eine Schaltflächenbetätigung
   wizard.ClearWizard();                 //Setzt den Dialog zurück (danach ist nur noch der Titel als
                                         //"MyTitle" gesetzt)
   switch (button)
   {
      //...
   }
 }
Ausnahmebehandlung:
Die Funktion kann nur während der Ausführung von 'Run' mit autorengesteuerter Schrittkontrolle durch den Assistenten verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1677]
objectbound Isom.Request.Wizard Isom.Request.Wizard.Clone ( )

Liefert das aktuelle Objekt.

 Isom.Request.Wizard a = Isom.Request.Wizard.Create();
 Isom.Request.Wizard b = a.Clone();
Rückgabe:
das aktuelle Objekt
[Isom\Request\Wizard.is: 1781]
Isom.Request.Wizard Isom.Request.Wizard.Create ( )

Erzeugt einen neuen Assistenten

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
Rückgabe:
Assistent
[Isom\Request\Wizard.is: 267]
objectbound Isom.Base.Boolean Isom.Request.Wizard.DisableBack ( )

Deaktiviert die Zurück-Schaltfläche, so dass sie nicht verwendet werden kann

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.DisableBack();
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 650]
objectbound Isom.Base.Boolean Isom.Request.Wizard.DisableNext ( )

Deaktiviert die Weiter-Schaltfläche, so dass sie nicht verwendet werden kann

Bemerkungen:
Um die Schaltfläche wieder aktivierbar zu machen, muss sie bei Steuerung der Schrittkontrolle durch den Assistenten mit 'SetNext' mit einer Funktion verknüpft werden. Bei autorengesteuerter Schrittkontrolle lässt sich der Zustand der Schaltfläche wieder durch 'ClearWizard' zurücksetzen.
 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.Disable();
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 634]
objectbound Isom.Base.Boolean Isom.Request.Wizard.Dispose ( )

Schließt und löscht den Assistenten

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.Dispose();
Ausnahmebehandlung:
Wurde der Wizard bereits mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 365]
objectbound Isom.Base.Boolean Isom.Request.Wizard.GetBoolean ( Isom.Base.String key )

Fragt einen vorher zur Datenhaltung an den Assistenten übergebenen Wahrheitswert ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.Boolean value = wizard.GetBoolean("Key1");
Parameter:
key Schlüssel des Wahrheitswerts
Ausnahmebehandlung:
Kann dem Schlüssel kein Wahrheitswert zugeordnet werden, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Gespeicherter Wahrheitswert
[Isom\Request\Wizard.is: 1632]
objectbound Isom.Request.UserRequest Isom.Request.Wizard.GetContentDialog ( )

Ruft das Fachobjekt ab, das den Inhalt des Nachrichtenfenster beschreibt

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Request.UserRequest request = wizard.GetContentDialog();
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Das Fachobjekt mit dem Inhalt des Nachrichtenfensters
[Isom\Request\Wizard.is: 839]
objectbound Isom.Base.String Isom.Request.Wizard.GetContentTitle ( )

Ruft den Titel des Inhaltelements des Assistenten ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String contentTitle = wizard.GetContentTitle();
Ausnahmebehandlung:
Wurde kein Titel festgelegt, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Titel des Inhaltelements des Assistenten
[Isom\Request\Wizard.is: 1101]
objectbound Isom.Base.String Isom.Request.Wizard.GetDescription ( )

Ruft den Dokumentenverweis zur Beschreibung des Assistenten ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String description = wizard.GetDescription();
Ausnahmebehandlung:
Wurde kein Dokumentenverweis zur Beschreibung des Assistenten festgelegt, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Dokumentenverweis zur Beschreibung des Assistenten
[Isom\Request\Wizard.is: 954]
objectbound Isom.Base.String Isom.Request.Wizard.GetDescriptionTitle ( )

Ruft den Titel des Elements zur Beschreibung des Assistenten ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String descriptionTitle = wizard.GetDescriptionTitle();
Ausnahmebehandlung:
Wurde kein Titel festgelegt, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Titel des Elements zur Beschreibung des Assistenten
[Isom\Request\Wizard.is: 990]
objectbound Isom.Base.String Isom.Request.Wizard.GetHelp ( )

Ruft den Dokumentenverweis zur Hilfe für die Benutzung des Assistenten ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String help = wizard.GetHelp();
Ausnahmebehandlung:
Wurde kein Hilfedokument festgelegt, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Dokumentenverweis zur Hilfe für die Benutzung des Assistenten
[Isom\Request\Wizard.is: 878]
objectbound Isom.Base.String Isom.Request.Wizard.GetHelpTitle ( )

Ruft den Titel der Hilfe für die Benutzung des Assistenten ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String helpTitle = wizard.GetHelpTitle();
Ausnahmebehandlung:
Wurde kein Titel festgelegt, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Hilfe für die Benutzung des Assistenten
[Isom\Request\Wizard.is: 914]
objectbound Isom.Base.String Isom.Request.Wizard.GetKey ( )

Fragt den identifizierenden Schlüssel ab.

Mit dem Schlüssel kann der Assistent über die Funktion 'GetWizard' abgerufen werden

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String key = wizard.GetKey();
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Schlüssel des Assistenten
[Isom\Request\Wizard.is: 284]
objectbound Isom.Base.String Isom.Request.Wizard.GetLabelButtonBack ( )

Fragt die Beschriftung der Schaltfläche 'Zurück' ab.

Mit der Schaltfläche 'Zurück' wechselt man zu der vorangegangenen Ansicht.

Rückgabe:
Isom.Base.String
Die aktuelle Beschriftung der Schaltfläche.
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
[Isom\Request\Wizard.is: 681]
objectbound Isom.Base.String Isom.Request.Wizard.GetLabelButtonDone ( )

Fragt die Beschriftung der Schaltfläche 'Beenden' ab.

Die Schaltfläche 'Beenden' wird im letzten Schritt statt der Schaltfläche 'Weiter' angezeigt. Mit ihr wird der Assistent geschlossen.

Rückgabe:
Isom.Base.String
Die aktuelle Beschriftung der Schaltfläche.
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
[Isom\Request\Wizard.is: 745]
objectbound Isom.Base.String Isom.Request.Wizard.GetLabelButtonNext ( )

Fragt die Beschriftung der Schaltfläche 'Weiter' ab.

Mit der Schaltfläche 'Weiter' wechselt man zu der nächsten Ansicht.

Rückgabe:
Isom.Base.String
Die aktuelle Beschriftung der Schaltfläche.
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
[Isom\Request\Wizard.is: 712]
objectbound Isom.Base.String Isom.Request.Wizard.GetLabelButtonQuit ( )

Fragt die Beschriftung der Schaltfläche 'X' ab.

Mit der Schaltfläche 'X' schließt man den Assistenten sofort.

Rückgabe:
Isom.Base.String
Die aktuelle Beschriftung der Schaltfläche.
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
[Isom\Request\Wizard.is: 780]
objectbound Isom.Base.String Isom.Request.Wizard.GetLayoutType ( )

Liefert den eingestellten Darstellungstypen des Assistenten

 Isom.Base.Boolean IsLayoutSet(Isom.Request.Wizard wizard)
 {
   Isom.Base.String layout = wizard.GetLayout();    //Liefert den eingestellten Darstellungstypen
   return layout.IsVoid();                          //Prüft auf das Void-Objekt
 }
Ausnahmebehandlung:
Ist der Darstellungstyp nicht eingestellt, wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Bemerkungen:
Der Darstellungstyp legt die für den Assistenten in der Bedienoberfläche verwendete Anzeigemaske fest
Rückgabe:
Darstellungstyp
[Isom\Request\Wizard.is: 1318]
objectbound Isom.Diagnostics.Measurement Isom.Request.Wizard.GetMeasurement ( Isom.Base.String key )

Ruft eine Gruppe von Messwerten im Nachrichtenfenster des beschriebenen Dialogschritts ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String key = wizard.WaitWizard();
 Isom.Diagnostics.Measurement measurement = wizard.GetMeasurement(key);
Parameter:
key Schlüssel
Ausnahmebehandlung:
Wurde keine Gruppe von Messwerten für den Schlüssel festgelegt, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Gruppe von Messwerten
[Isom\Request\Wizard.is: 1238]
objectbound Isom.Base.String Isom.Request.Wizard.GetMedia ( )

Ruft den Verweis auf das Medienelement des Assistenten ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String media = wizard.GetMedia();
Ausnahmebehandlung:
Wurde kein Verweis festgelegt, wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Verweis auf das Medienelement des Assistenten
[Isom\Request\Wizard.is: 1029]
objectbound Isom.Base.String Isom.Request.Wizard.GetMediaTitle ( )

Ruft den Titel des Medienelements des Assistenten ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String mediaTitle = wizard.GetMediaTitle();
Ausnahmebehandlung:
Wurde kein Titel festgelegt, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Titel des Medienelements des Assistenten
[Isom\Request\Wizard.is: 1065]
objectbound Isom.Base.String Isom.Request.Wizard.GetMessage ( Isom.Base.String key )

Ruft einen für den beschriebenen Dialogschritt festgelegten Text ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String key = wizard.WaitWizard();
 Isom.Base.String message = wizard.GetMessage(key);
Parameter:
key Schlüssel
Ausnahmebehandlung:
Wurde kein Text für den Schlüssel festgelegt, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Nachricht
[Isom\Request\Wizard.is: 1144]
objectbound Isom.Base.String Isom.Request.Wizard.GetNext ( )

Fragt ab, welche Funktion mit der Weiter-Schaltfläche verknüpft ist

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String nextFunction = wizard.GetNext();
Ausnahmebehandlung:
Ist keine Funktion mit der Weiter-Schaltfläche verknüpft, wird das Void-Objekt zurückgegeben
Die Funktion kann nicht während Ausführung von 'Run' mit autorengesteuerter Schrittkontrolle verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Mit der Weiter-Schaltfläche verknüpfte Funktion
[Isom\Request\Wizard.is: 546]
objectbound Isom.Base.Number Isom.Request.Wizard.GetNumber ( Isom.Base.String key )

Fragt einen vorher zur Datenhaltung an den Assistenten übergebenen Zahlenwert ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Number value = wizard.GetNumber("Key1");
Parameter:
key Schlüssel des Zahlenwerts
Ausnahmebehandlung:
Kann dem Schlüssel kein Zahlenwert zugeordnet werden, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Gespeicherter Zahlenwert
[Isom\Request\Wizard.is: 1588]
objectbound Isom.Request.Wizard Isom.Request.Wizard.GetPreviousStep ( )

Ermittelt den Assistenten aus dem vorhergehenden Schritt

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Request.Wizard previousStep = wizard.GetPreviousStep();
Ausnahmebehandlung:
Wurde noch kein Schritt des Assistenten durchgeführt, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Assistent mit den Daten aus dem vorhergehenden Schritt. Dieses Fachobjekt kann nicht verändert oder ausgeführt werden, jede Funktion, die dies versucht gibt das Void-Objekt zurück
[Isom\Request\Wizard.is: 525]
objectbound Isom.Base.String Isom.Request.Wizard.GetQuit ( )

Fragt ab, welche Funktion beim Beenden des Assistenten ausgeführt wird

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String nextFunction = wizard.GetNext();
Ausnahmebehandlung:
Ist keine Funktion Zur Ausführung beim Beenden gesetzt, wird das Void-Objekt zurückgegeben
Die Funktion kann nicht während Ausführung von 'Run' mit autorengesteuerter Schrittkontrolle verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Funktion , die beim Beenden des Assistenten ausgeführt wird
[Isom\Request\Wizard.is: 613]
objectbound Isom.Request.RadioButton Isom.Request.Wizard.GetRadioButton ( Isom.Base.String key )

Fragt einen RadioButton ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 RadioButton rb = wizard.GetRadioButton("SelectYes");
Parameter:
key Schlüssel des RadioButton
Ausnahmebehandlung:
Gibt es keinen RadioButton mit dem Schlüssel, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
RadioButton
[Isom\Request\Wizard.is: 1412]
objectbound Isom.Base.String Isom.Request.Wizard.GetSelectedButton ( )

Fragt die betätigte Schaltfläche ab.

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String result = wizard.GetSelectedButton();
Ausnahmebehandlung:
Ist keine Schaltfläche betätigt oder der Assistent bei autorengesteuerter Schrittkontrolle mit 'ClearWizard' zurückgesetzt worden, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Bemerkungen:
Die Rückgabe ist einer folgenden Werte: 1. "Next" für die 'Weiter'-Schaltfläche 1. "Back" für die 'Zurück'-Schaltfläche 1. "Quit", falls der Benutzer den Assistenten beendet hat
Rückgabe:
Betätigte Schaltfläche
[Isom\Request\Wizard.is: 1455]
objectbound Isom.Request.RadioButton Isom.Request.Wizard.GetSelectedRadioButton ( )

Fragt den ausgewählten RadioButton ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 RadioButton rb = wizard.GetSelectedButton();
Ausnahmebehandlung:
Ist kein RadioButton ausgewählt oder der Assistent bei autorengesteuerter Schrittkontrolle mit 'ClearWizard' zurückgesetzt worden, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Ausgewählter RadioButton
[Isom\Request\Wizard.is: 1431]
objectbound Isom.Base.String Isom.Request.Wizard.GetString ( Isom.Base.String key )

Fragt eine vorher zur Datenhaltung an den Assistenten übergebene Zeichenkette ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String value = wizard.GetString("Key1");
Parameter:
key Schlüssel des Zeichenkettenwerts
Ausnahmebehandlung:
Kann dem Schlüssel keine Zeichenkette zugeordnet werden, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Gespeicherter Zeichenkettenwert
[Isom\Request\Wizard.is: 1544]
objectbound Isom.Base.String Isom.Request.Wizard.GetTextInput ( Isom.Base.String key )

Ruft den Wert eines Texteingabefelds ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String input = wizard.GetTextInput();
Parameter:
key Schlüssel des Texteingabefelds
Ausnahmebehandlung:
Wurde kein Texteingabefeld für das Nachrichtenfenster festgelegt, wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Aktueller Wert des Texteingabefelds
[Isom\Request\Wizard.is: 1369]
objectbound Isom.Base.String Isom.Request.Wizard.GetTitle ( )

Ruft den Titel des Assistenten ab

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String title = wizard.GetTitle();
Ausnahmebehandlung:
Wurde kein Titel festgelegt, wird das Void-Objekt zurückgegeben
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Titel des Assistenten
[Isom\Request\Wizard.is: 822]
objectbound Isom.Base.String Isom.Request.Wizard.GetUpdateFunction ( )

Fragt die Aktualisierungsfunktion ab.

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Base.String updateFunction = wizard.GetUpdateFunction();
Ausnahmebehandlung:
Ist keine Aktualisierungsfunktion gesetzt, wird das Void-Objekt zurückgegeben
Die Funktion kann nicht während Ausführung von 'Run' mit autorengesteuerter Schrittkontrolle verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
Funktion, die den Dialogschritt aktualisiert
[Isom\Request\Wizard.is: 444]
Isom.Request.Wizard Isom.Request.Wizard.GetWizard ( Isom.Base.String key )

Fragt einen bereits erzeugten Assistenten anhand seines identifizierenden Schlüssels ab

 Isom.Request.Wizard wizard1 = wizard1.Create();
 Isom.Base.String key = wizard1.GetKey();
 Isom.Request.Wizard wizard2 = wizard1.GetWizard(key);
Parameter:
key Schlüssel des abgefragten Assistenten
Ausnahmebehandlung:
Existiert kein Assistent mit dem Schlüssel, wird das Void-Objekt zurückgegeben
Rückgabe:
Assistent
[Isom\Request\Wizard.is: 303]
objectbound Isom.Base.Boolean Isom.Request.Wizard.IsVisited ( )

Ruft ab, ob der Dialogschritt schon einmal ausgeführt wurde

 Isom.Base.Boolean Step1(Isom.Request.Wizard wizard)
 {
   if (wizard.IsVisited())
   {
     //Schritt wurde bereits ausgeführt
   }
   else
   {
     //Schritt wird das erste Mal ausgeführt
   }
   return true;
 }
Ausnahmebehandlung:
Wird die Funktion außerhalb der Festlegung eines Dialogschritts aufgerufen, wird das Void-Objekt zurückgegeben
Die Funktion kann nur während der Ausführung von 'Run' mit Steuerung der Schrittkontrolle durch den Assistenten verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true', falls der Dialogschritt schon einmal ausgeführt wurde, 'false' sonst
[Isom\Request\Wizard.is: 1494]
objectbound Isom.Base.Boolean Isom.Request.Wizard.IsVoid ( )

Bestimmt, ob das aktuelle Element das Void-Objekt ist.

 Isom.Request.Wizard a = Isom.Request.Wizard.Create();
 if (a.IsVoid())
 {
    return false;
 }
Rückgabe:
'true', falls das aktuelle Element das Void-Objekt ist, 'false' sonst.
[Isom\Request\Wizard.is: 1769]
objectbound Isom.Base.Boolean Isom.Request.Wizard.Run | ( | Isom.Base.String | function,
 |  | Isom.Base.Boolean | wizardControlledWorkflow
 | ) |  |

Startet die Ausführung des Assistenten.

 Isom.Base.Boolean StartWizard()
 {
   Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
   wizard.Run("Step1", true);     //Startet Assistent mit automatischer Schrittverwaltung
                                  //und 'Step1' als ersten Schritt.
 }

 Isom.Base.Boolean Step1(Isom.Request.Wizard wizard)
 {
   //...
 }
Parameter:
function | Funktion, die den Assistenten mit Inhalt befüllt.
wizardControlledWorkflow | Angabe, ob die Schrittverwaltung automatisch vom Assistenten erledigt wird.
Bemerkungen:
Für die Angabe des Parameters 'function' gelten die gleichen Regeln wie beim direkten Aufruf der Funktion. Hier kann wie im Codebeispiel der Funktionsname ohne Namensraumqualifizierung angegeben werden, falls die Funktion im gleichen Namensraum liegt, wie die Funktion, in der 'Run' aufgerufen wird. Alternativ kann die Funktion mit einem vorangestellten Namensraum angegeben werden, z. B. mit 'OEM.Wizard1.Step1'. Es können nur Funktionen verwendet werden, die genau einen Parameter besitzen, der vom Typ 'Wizard' ist und ein 'Isom.Base.Boolean' als Rückgabewert liefern. Kann der Parameter 'function' keiner ISOM/L-Funktion zugeordnet werden, die den Anforderungen entspricht, liefert der Aufruf von 'Run' die Rückgabe 'Void'.
Ausnahmebehandlung:
Existiert die angegebene Funktion nicht oder erfüllt sie die Anforderungen nicht, wird das Void-Objekt zurückgegeben.
Wird der Assistent bereits mit einem Aufruf von Run() ausgeführt, wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 349]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetContentTitle ( Isom.Base.String title )

Legt den Titel des Inhaltelements des Assistenten fest

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.SetContentTitle("Ablauf");
Parameter:
title Titel des Inhaltelements des Assistenten
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1083]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetDescription ( Isom.Base.String descriptionFile )

Legt das Dokument fest, das zur Beschreibung des Assistenten angezeigt wird.

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.SetDescription("DescriptionDir\Description_Wizard01.pdf");
Parameter:
descriptionFile Dokumentenverweis zur Anzeige der Beschreibung des Assistenten
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Bemerkungen:
Der Parameter 'descriptionFile' unterstützt die von der Klasse 'MediaElement' angebotenen Medienelemente.
Rückgabe:
'true'
[Isom\Request\Wizard.is: 935]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetDescriptionTitle ( Isom.Base.String title )

Legt den Titel des Elements zur Beschreibung des Assistenten fest

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.SetDescriptionTitle("Beschreibung");
Parameter:
title Titel des Elements zur Beschreibung des Assistenten
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 972]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetHelp ( Isom.Base.String helpFile )

Legt das Dokument fest, das zur Hilfe für die Benutzung des Assistenten angezeigt wird

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.SetHelp("HelpDir\HowTo_Wizard01.html");
Parameter:
helpFile Dokumentenverweis zur Anzeige der Hilfe des Assistenten
Bemerkungen:
Der Parameter 'helpFile' unterstützt die von der Klasse 'MediaElement' angebotenen Medienelemente.
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 860]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetHelpTitle ( Isom.Base.String title )

Legt den Titel der Hilfe für die Benutzung des Assistenten fest

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.SetHelpTitle("Hilfe");
Parameter:
title Titel der Hilfe für die Benutzung des Assistenten
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 896]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetLabelButtonBack ( Isom.Base.String label )

Setzt die Beschriftung für die Schaltfläche 'Zurück'.

Mit der Schaltfläche 'Zurück' wechselt man zu der vorangegangenen Ansicht.

Parameter:
label Beschriftung für die Schaltfläche
Rückgabe:
'true'
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht oder wird als Parameter eine leere Zeichenkette oder ein Void-Objekt übergeben, wird das Void-Objekt zurückgegeben
[Isom\Request\Wizard.is: 667]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetLabelButtonDone ( Isom.Base.String label )

Setzt die Beschriftung für die Schaltfläche 'Beenden'.

Die Schaltfläche 'Beenden' wird im letzten Schritt statt der Schaltfläche 'Weiter' angezeigt. Mit ihr wird der Assistent geschlossen.

Parameter:
label Beschriftung für die Schaltfläche
Rückgabe:
'true'
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht oder wird als Parameter eine leere Zeichenkette oder ein Void-Objekt übergeben, wird das Void-Objekt zurückgegeben
[Isom\Request\Wizard.is: 730]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetLabelButtonNext ( Isom.Base.String label )

Setzt die Beschriftung für die Schaltfläche 'Weiter'.

Mit der Schaltfläche 'Weiter' wechselt man zu der nächsten Ansicht.

Parameter:
label Beschriftung für die Schaltfläche
Rückgabe:
'true'
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht oder wird als Parameter eine leere Zeichenkette oder ein Void-Objekt übergeben, wird das Void-Objekt zurückgegeben
[Isom\Request\Wizard.is: 698]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetLabelButtonQuit ( Isom.Base.String label )

Setzt die Beschriftung für die Schaltfläche 'X'.

Mit der Schaltfläche 'X' schließt man den Assistenten sofort.

Zu beachten:
Im Taurus® Client wird für diese Schaltfläche eine Grafik verwendet und die Beschriftung nicht angezeigt.
Parameter:
label Beschriftung für die Schaltfläche
Rückgabe:
'true'
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht oder wird als Parameter eine leere Zeichenkette oder ein Void-Objekt übergeben, wird das Void-Objekt zurückgegeben
[Isom\Request\Wizard.is: 766]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetLayoutType ( Isom.Base.String layout )

Setzt den Darstellungstypen des Assistenten

 Isom.Base.Boolean StepWithLayoutX(Isom.Request.Wizard wizard)
 {
   wizard.SetLayout("LayoutX");    //Setzt den Darstellungstypen 'LayoutX'
   wizard.SetNext("Step2", false); //Verknüpt die Weiter-Schaltfläche mit 'Step2'
   return true;
 }
Parameter:
layout Darstellungstyp, der gesetzt wird
Ausnahmebehandlung:
Ist der Darstellungstyp das Void-Objekt oder die leere Zeichenkette, wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Bemerkungen:
Der Darstellungstyp legt die für den Assistenten in der Bedienoberfläche verwendete Anzeigemaske fest
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1295]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetMeasurement | ( | Isom.Base.String | key,
 |  | Isom.Diagnostics.Measurement | measurement
 | ) |  |

Aktualisiert eine Gruppe von Messwerten im Nachrichtenfenster des beschriebenen Dialogschritts

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 Isom.Diagnostics.Measurement update = Isom.Diagnostics.Measurement.CreateMeasurement("XAngle");
 wizard.SetMeasurement("Measurement_01", update);
Parameter:
key | Schlüssel
measurement | Aktualisierte Messwerte
Ausnahmebehandlung:
Wurde keine Gruppe von Messwerten für den Schlüssel festgelegt, wird das Void-Objekt zurückgegeben
Die Funktion kann nur während der Ausführung von 'Run' mit Steuerung der Schrittkontrolle durch den Assistenten verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Bemerkungen:
Die Funktion kann in der Aktualisierungsfunktion des Dialogschritts verwendet werden, um eine vorher eingeführte Messwertgruppe zu aktualisieren.
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1268]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetMedia ( Isom.Base.String mediaFile )

Legt das Medienelement fest, das im Assistenten angezeigt werden soll

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.SetMedia("MediaDir\Diagrams\Wizard01.jpg");
Parameter:
mediaFile Verweis auf ein Medienelement
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Bemerkungen:
Der Parameter 'mediaFile' unterstützt die von der Klasse 'MediaElement' angebotenen Medienelemente.
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1011]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetMediaTitle ( Isom.Base.String title )

Legt den Titel des Medienelements des Assistenten fest

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.SetMediaTitle("Bild");
Parameter:
title Titel des Medienelements des Assistenten
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1047]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetMessage | ( | Isom.Base.String | key,
 |  | Isom.Base.String | message
 | ) |  |

Aktualisiert einen Text im Dialogschritt, während er angezeigt wird.

 Isom.Base.Boolean StartWizard()
 {
   Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
   wizard.Run("Step1", true);
 }

 Isom.Base.Boolean Step1(Isom.Request.Wizard wizard)
 {
   //...
   wizard.AddMessage("MSG1", Texts.MESSAGE_WIZARD01);
   //...
   wizard.SetUpdateFunction("UpdateStep1");
   //...
 }

 Isom.Base.Boolean UpdateStep1(Isom.Request.Wizard wizard)
 {
   //...
   Isom.Base.String updatedText = Texts.MESSAGE_WIZARD02;
   wizard.SetMessage("MSG1", updatedText);
   //...
 }
Parameter:
key | Schlüssel der aktualisierten Nachricht
message | Nachricht
Ausnahmebehandlung:
Wurde kein Text für den Schlüssel festgelegt, wird das Void-Objekt zurückgegeben
Die Funktion kann nur während der Ausführung von 'Run' mit Steuerung der Schrittkontrolle durch den Assistenten verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Bemerkungen:
Die Funktion kann in der Aktualisierungsfunktion des Dialogschritts verwendet werden, um eine vorher eingeführte Textnachricht zu aktualisieren.
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1194]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetNext | ( | Isom.Base.String | nextFunction,
 |  | Isom.Base.Boolean | lastStep
 | ) |  |

Bietet zwei Möglichkeiten an, die Weiter-Schaltfläche anzupassen: 1.

Die Weiter-Schaltfläche kann für die aktivierte Schrittkontrolle durch den Assistenten mit einer Funktion, die den Dialog für den nächsten Schritt anpasst, verknüpft werden. 2. Die Weiter-Schaltfläche kann zu einer Beenden-Schaltfläche umgewandelt werden

 Isom.Base.Boolean Step1(Isom.Request.Wizard wizard)
 {
   wizard.SetNext("Step2", false);
   return true;
 }

 Isom.Base.Boolean Step2(Isom.Request.Wizard wizard)
 {
   //...
 }
Parameter:
nextFunction | Funktion, die den Assistenten mit dem Inhalt des nächsten Dialogs befüllt.
lastStep | Angabe, ob im nächsten Dialog die Weiter-Schaltfläche durch eine Beenden-Schaltfläche ersetzt wird
Bemerkungen:
Für die Angabe des Parameters 'nextFunction' gelten ansonsten die gleichen Regeln wie beim direkten Aufruf der Funktion. Hier kann wie im Codebeispiel der Funktionsname ohne Namensraumqualifizierung angegeben werden, falls die Funktion im gleichen Namensraum liegt, wie die Funktion, in der 'SetNext' aufgerufen wird. Alternativ kann die Funktion mit einem vorangestellten Namensraum angegeben werden, z. B. mit 'OEM.Wizard1.Step2'. Es können nur Funktionen verwendet werden, die genau einen Parameter besitzen, der vom Typ 'Wizard' ist und ein 'Isom.Base.Boolean' als Rückgabewert liefern.
Falls der Parameter 'lastStep' den Wert 'true' besitzt, kann als Parameter 'nextFunction' auch eine leere Zeichenkette angegeben werden. Wird die Beenden-Schaltfläche dann während der Ausführung von 'Run' mit Steuerung der Schrittkontrolle durch den Assistenten betätigt, wird falls vorhanden, die mit 'SetQuit' vorgegebene Funktion ausgeführt. Wurde keine Funktion mit 'SetQuit' vorgegeben, wird der Assistent geschlossen, ohne eine Funktion auszuführen.
Bei autorengesteuerter Schrittkontrolle kann die Funktion nur mit leerer Zeichenkette als Parameter 'nextFunction' und 'lastStep' mit Wert 'true' verwendet werden. Dadurch wandelt sich die Weiter- Schaltfläche in eine Beenden-Schaltfläche um. Bei dieser Art der Schrittkontrolle wird bei anderen Parametern das Void-Objekt zurückgegeben.
Ausnahmebehandlung:
Existiert die angegebene Funktion nicht oder erfüllt sie die Anforderungen nicht, wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 506]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetQuit ( Isom.Base.String quitFunction )

Setzt eine Funktion, die beim Beenden des Assistenten aufgerufen wird

 Isom.Base.Boolean StartWizard()
 {
   Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
   wizard.SetQuit("OnQuit");
 }

 Isom.Base.Boolean OnQuit(Isom.Request.Wizard wizard)
 {
   wizard.Dispose();
 }
Parameter:
quitFunction Funktion, die beim Beenden des Assistenten aufgerufen wird
Bemerkungen:
Für die Angabe des Parameters 'quitFunction' gelten die gleichen Regeln wie beim direkten Aufruf der Funktion. Hier kann wie im Codebeispiel der Funktionsname ohne Namensraumqualifizierung angegeben werden, falls die Funktion im gleichen Namensraum liegt, wie die Funktion, in der 'SetQuit' aufgerufen wird. Alternativ kann die Funktion mit einem vorangestellten Namensraum angegeben werden, z. B. mit 'OEM.Wizard1.OnQuit'. Es können nur Funktionen verwendet werden, die genau einen Parameter besitzen, der vom Typ 'Wizard' ist und ein 'Isom.Base.Boolean' als Rückgabewert liefern.
Der Rückgabewert der 'quitFunction' legt fest, ob der Assistent tatsächlich beendet wird. Gibt die 'quitFunction' den Wert 'false' zurück, so wird die Ausführung des Assistenten fortgesetzt.
Ausnahmebehandlung:
Existiert die angegebene Funktion nicht oder erfüllt sie die Anforderungen nicht, wird das Void-Objekt zurückgegeben.
Die Funktion kann nicht während Ausführung von 'Run' mit autorengesteuerter Schrittkontrolle verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 592]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetTitle ( Isom.Base.String title )

Setzt den anzuzeigenden Titel des Assistenten

 Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
 wizard.SetTitle("ISOM-Assistent");
Ausnahmebehandlung:
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Parameter:
title Titel des Assistenten
Rückgabe:
'true'
[Isom\Request\Wizard.is: 804]
objectbound Isom.Base.Boolean Isom.Request.Wizard.SetUpdateFunction ( Isom.Base.String updateFunction )

Setzt die Aktualisierungsfunktion.

Diese Funktion wird vor der Anzeige des Dialogschritts gestartet und erlaubt es, die Anzeige zu aktualisieren.

 Isom.Base.Boolean StartWizard()
 {
   Isom.Request.Wizard wizard = Isom.Request.Wizard.Create();
   wizard.Run("Step1", true);
 }

 Isom.Base.Boolean Step1(Isom.Request.Wizard wizard)
 {
   //...
   wizard.AddMessage("MSG1", Texts.MESSAGE_WIZARD01);
   //...
   wizard.SetUpdateFunction("UpdateStep1");
   //...
 }

 Isom.Base.Boolean UpdateStep1(Isom.Request.Wizard wizard)
 {
   //...
   Isom.Base.String updatedText = Texts.MESSAGE_WIZARD02;
   wizard.SetMessage("MSG1", updatedText);
   //...
 }
Parameter:
updateFunction Funktion, die bei Anzeige des Dialogschritts gestartet wird
Bemerkungen:
Für die Angabe des Parameters 'updateFunction' gelten die gleichen Regeln wie beim direkten Aufruf der Funktion. Hier kann wie im Codebeispiel der Funktionsname ohne Namensraumqualifizierung angegeben werden, falls die Funktion im gleichen Namensraum liegt, wie die Funktion, in der 'UpdateStep1' aufgerufen wird. Alternativ kann die Funktion mit einem vorangestellten Namensraum angegeben werden, z. B. mit 'OEM.Wizard1.UpdateStep1'. Es können nur Funktionen verwendet werden, die genau einen Parameter besitzen, der vom Typ 'Wizard' ist und ein 'Isom.Base.Boolean' als Rückgabewert liefern.
Um die Anzeige des Dialogschritts zu ändern, kann man in der Aktualisierungsfunktion die Funktionen aufrufen, mit denen die Inhalte des Assistenten geändert werden.
Ausnahmebehandlung:
Existiert die angegebene Funktion nicht oder erfüllt sie die Anforderungen nicht, wird das Void-Objekt zurückgegeben.
Die Funktion kann nicht während Ausführung von 'Run' mit autorengesteuerter Schrittkontrolle verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 423]
objectbound Isom.Base.Boolean Isom.Request.Wizard.ShowWizard ( )

Zeigt einen Dialog an und kehrt zurück, ohne auf eine Schaltflächenbetätigung zu warten

 Isom.Base.Boolean StartWizard()
 {
   Isom.Request.Wizard wizard = Wizard.Create();
   wizard.SetTitle("MyTitle");
   wizard.Run("Dispatcher", false); //Der Assistent ruft die Funktion 'Dispatcher' auf,
                                    //die eine autorengesteuerten Dialogabfolge enthält.
 }

 Isom.Base.Boolean Dispatcher(Isom.Request.Wizard wizard)
 {
   wizard.AddMessage("FirstMessage", "Erster Schritt");
   wizard.ShowWizard();  //Zeigt den Dialog mit Text "FirstMessage" an
   //...
 }
Ausnahmebehandlung:
Die Funktion kann nur während der Ausführung von 'Run' mit autorengesteuerter Schrittkontrolle durch den Assistenten verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1709]
Isom.Request.Wizard Isom.Request.Wizard.Void ( )

Erzeugt ein Void-Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

 Isom.Request.Wizard f()
 {
  //...
  if (error)
    return Wizard.Void();
  //...
 }
Rückgabe:
Void-Objekt
[Isom\Request\Wizard.is: 1800]
objectbound Isom.Base.String Isom.Request.Wizard.WaitWizard ( )

Zeigt einen Dialog an und wartet auf eine Schaltflächenbetätigung

 Isom.Base.Boolean StartWizard()
 {
   Isom.Request.Wizard wizard = Wizard.Create();
   wizard.SetTitle("MyTitle");
   wizard.Run("Dispatcher", false); //Der Assistent ruft die Funktion 'Dispatcher' auf,
                                    //die eine autorengesteuerten Dialogabfolge enthält.
 }

 Isom.Base.Boolean Dispatcher(Isom.Request.Wizard wizard)
 {
   wizard.AddMessage("FirstMessage", "Erster Schritt");
   Isom.Base.String button = wizard.WaitWizard();  //Zeigt den Dialog mit Text "FirstMessage" an und
                                                   //wartet auf eine Schaltflächenbetätigung
   wizard.ClearWizard();                 //Setzt den Dialog zurück (danach ist nur noch der Titel als
                                         //"MyTitle" gesetzt)
   switch (button)
   {
      //...
   }
 }
Ausnahmebehandlung:
Die Funktion kann nur während der Ausführung von 'Run' mit autorengesteuerter Schrittkontrolle durch den Assistenten verwendet werden, sonst wird das Void-Objekt zurückgegeben.
Wurde der Wizard mit 'Dispose()' gelöscht, wird das Void-Objekt zurückgegeben
Rückgabe:
'true'
[Isom\Request\Wizard.is: 1747]


für Serviceautoren

Isom.Security

Namensraum Isom.Security

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Security.SecurityProvider

Sicherheitsaufgaben wie zum Beispiel Freischaltung bzw.


für Serviceautoren

Isom.Security.SecurityProvider

Namensraum Isom.Security.SecurityProvider

Sicherheitsaufgaben wie zum Beispiel Freischaltung bzw. Mehr...

Funktionen
Funktion zum Erzeugen eines Security-Provider-Objekts

Isom.Security.SecurityProvider | Create(Isom.Base.String name)

Erzeugt ein neues Security-Provider-Objekt anhand des vorgegebenen Namens.

Funktionen zum Abrufen der Instanz

Funktionen, die das Abrufen der Instanz ermöglichen.

Isom.Base.Number | GetId()

Ruft die ID dieser Objekt-Instanz ab.

Isom.Security.SecurityProvider | GetProvider(Isom.Base.Number id)

Ruft das Security-Provider-Objekt mit der übergebenen ID ab.

Fach-Operationen auf Objektinstanzen

Funktionen zum Erzeugen und Verwenden Sicherheitsschlüssels.

Isom.Base.Boolean | Authenticate()

Führt eine Authentifizierung durch.

Isom.Base.Boolean | CheckKeyStore()

Prüft, ob ein vorher angeforderter Schlüssel erhalten wurde.

Isom.Base.Boolean | GenerateKey()

Generiert einen Schlüssel.

Isom.Base.Boolean | ProvideKeyStoreData()

Bringt einen mit 'RequestKeyStore' angeforderdeten und erhaltenen Schlüssel ein.

Isom.Base.Boolean | ReleaseKeyStore()

Gibt reservierte Ressourcen wieder frei.

Isom.Base.Boolean | RequestKeyStore()

Löst eine Anforderung nach einem Schlüssel aus.

Eigenschaften

Funktionen zum Lesen und Setzen von Eigenschaften.

Isom.Base.String | GetProp(Isom.Base.String propName)

Ermittelt den Wert der vorgegebenen Eigenschaft (property) für den Security-Provider.

Isom.Base.StringList | GetPropNames()

Liefert die Namen aller technischen Eigenschaften für den Security-Provider.

Isom.Base.Boolean | SetProp(Isom.Base.String propName, Isom.Base.String propValue)

Setzt den Wert der vorgegebenen Eigenschaft (property) für den Security-Provider.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Security.SecurityProvider | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Security.SecurityProvider | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Sperrung von Sonderfunktionen

Dieses Fachobjekt bietet Zugang zu kryptographischen Funktionen. Damit unterstützt es die Erfüllung von Sicherheitsaufgaben.

Hinweis: Dieses Fachobjekt funktioniert nicht mit ISOM Didact. Die meisten Funktionsaufrufe kehren mit dem Ergebnis 'Void' zurück.

Quelldateien:

  • Isom\Security\SecurityProvider.is

Dokumentation der Funktionen

objectbound Isom.Base.Boolean Isom.Security.SecurityProvider.Authenticate ( )

Führt eine Authentifizierung durch.

   using Isom.Base.*
   ...
      SecurityProvider provider = ...;
      Boolean succ = provider.Authenticate();
Rückgabe:
'true' wenn die Authentifizierung erfolgreich war, 'false' sonst.
[Isom\Security\SecurityProvider.is: 175]
objectbound Isom.Base.Boolean Isom.Security.SecurityProvider.CheckKeyStore ( )

Prüft, ob ein vorher angeforderter Schlüssel erhalten wurde.

   using Isom.Base.*
   ...
      SecurityProvider provider = ...;
      StringDictionary results = provider.CheckKeyStore();
Rückgabe:
Ergebnis der Anforderung
[Isom\Security\SecurityProvider.is: 223]
objectbound Isom.Security.SecurityProvider Isom.Security.SecurityProvider.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Security\SecurityProvider.is: 375]
Isom.Security.SecurityProvider Isom.Security.SecurityProvider.Create ( Isom.Base.String name )

Erzeugt ein neues Security-Provider-Objekt anhand des vorgegebenen Namens.

   using Isom.Base.*
   ...
      SecurityProvider provider = SecurityProvider.Create( "Name" );
   ...
Rückgabe:
Das neu erzeugte Security-Provider-Objekt.
[Isom\Security\SecurityProvider.is: 106]
objectbound Isom.Base.Boolean Isom.Security.SecurityProvider.GenerateKey ( )

Generiert einen Schlüssel.

   using Isom.Base.*
   ...
      SecurityProvider provider = ...;
      String key = provider.GenerateKey();
Rückgabe:
Der erzeugte Schlüssel.
[Isom\Security\SecurityProvider.is: 191]
objectbound Isom.Base.Number Isom.Security.SecurityProvider.GetId ( )

Ruft die ID dieser Objekt-Instanz ab.

   using Isom.Base.*
   ...
      Number id = SecurityProvider.GetId();
   ...
Rückgabe:
Security-Provider-Objekt.
[Isom\Security\SecurityProvider.is: 149]
objectbound Isom.Base.String Isom.Security.SecurityProvider.GetProp ( Isom.Base.String propName )

Ermittelt den Wert der vorgegebenen Eigenschaft (property) für den Security-Provider.

Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

   using Isom.Base.*
   ...
      SecurityProvider provider = ...;
      String val = provider.GetProp( "PropertyName" );
Rückgabe:
Wert der Eigenschaft.
Ausnahmebehandlung:
Es wird Void zurückgegeben, wenn die Eigenschaft nicht gesetzt oder auf den Leerstring gesetzt ist.
[Isom\Security\SecurityProvider.is: 286]
objectbound Isom.Base.StringList Isom.Security.SecurityProvider.GetPropNames ( )

Liefert die Namen aller technischen Eigenschaften für den Security-Provider.

Es werden die Eigenschaftsnamen für die technischen Eigenschaften (siehe Isom.Security.SecurityProvider.GetProp()) zurückgeliefert. Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

   Isom.Security.SecurityProvider secProvider = Isom.Security.SecurityProvider.GetInstance("Security42");
   Isom.Base.StringList propertyNames = secProvider.GetPropNames();
   propertyNames.Reset();
   while(propertyNames.HasNext())
   {
     //Abfrage des Werts für den gelieferten Eigenschaftsnamen und z. B. Aufzeichnung ins Protokoll
   }
Rückgabe:
Isom.Base.StringList
Liste der Namen aller technischen Eigenschaften für den Security-Provider.
Siehe auch:
Isom.Security.SecurityProvider.GetProp()
Datum:
letzte Änderung am 09.09.2010
[Isom\Security\SecurityProvider.is: 346]
Isom.Security.SecurityProvider Isom.Security.SecurityProvider.GetProvider ( Isom.Base.Number id )

Ruft das Security-Provider-Objekt mit der übergebenen ID ab.

   using Isom.Base.*
   ...
      SecurityProvider provider = SecurityProvider.GetProvider(1);
   ...
Rückgabe:
Security-Provider-Objekt.
[Isom\Security\SecurityProvider.is: 132]
objectbound Isom.Base.Boolean Isom.Security.SecurityProvider.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Security\SecurityProvider.is: 366]
objectbound Isom.Base.Boolean Isom.Security.SecurityProvider.ProvideKeyStoreData ( )

Bringt einen mit 'RequestKeyStore' angeforderdeten und erhaltenen Schlüssel ein.

   using Isom.Base.*
   ...
      SecurityProvider provider = ...;
      StringDictionary results = provider.ProvideKeyStoreData();
Rückgabe:
Ergebnis der Anforderung
[Isom\Security\SecurityProvider.is: 240]
objectbound Isom.Base.Boolean Isom.Security.SecurityProvider.ReleaseKeyStore ( )

Gibt reservierte Ressourcen wieder frei.

   using Isom.Base.*
   ...
      SecurityProvider provider = ...;
      StringDictionary results = provider.ReleaseKeyStore();
Rückgabe:
Ergebnis der Anforderung
[Isom\Security\SecurityProvider.is: 256]
objectbound Isom.Base.Boolean Isom.Security.SecurityProvider.RequestKeyStore ( )

Löst eine Anforderung nach einem Schlüssel aus.

   using Isom.Base.*
   ...
      SecurityProvider provider = ...;
      StringDictionary results = provider.RequestKeyStore();
Rückgabe:
Ergebnis der Anforderung
[Isom\Security\SecurityProvider.is: 207]
objectbound Isom.Base.Boolean Isom.Security.SecurityProvider.SetProp | ( | Isom.Base.String | propName,
 |  | Isom.Base.String | propValue
 | ) |  |

Setzt den Wert der vorgegebenen Eigenschaft (property) für den Security-Provider.

Die systemseitig ermittelten Eigenschaftsnamen sind in den herstellerspezifischen Begleitdokumenten zu finden.

   using Isom.Base.*
   ...
      SecurityProvider provider = ...;
      String propName = "PropertyName";
      if( provider.GetProp(propName).IsVoid() )
        provider.SetProp( propName, "PropertyValue" );
Rückgabe:
'true' nach erfolgreichem Setzen, 'false' niemals.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Steuergeräteobjekt Teil der Ist-Sg-Liste ist und die Eigenschaft bereits nicht leer gesetzt ist.
[Isom\Security\SecurityProvider.is: 312]
Isom.Security.SecurityProvider Isom.Security.SecurityProvider.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Security\SecurityProvider.is: 387]


für Serviceautoren

Isom.Services

Namensraum Isom.Services

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Services.Asam | ASAM-Job-Aufrufe
Isom.Services.AsamParameter | Parameter eines ASAM-Jobs oder -Diensts.
Isom.Services.AsamParameterList | Liste von ASAM-Parametern.
Isom.Services.AsamResponseList | Liste von ASAM-Antworten.
Isom.Services.DataProcurement | Zugriff auf allgemeine Informationen der Datenbeschaffung
Isom.Services.Ediabas | EDIABAS-Job-Aufrufe
Isom.Services.EdiabasResultSet | Ergebnisse bei EDIABAS-Job-Aufrufen als Tabelle
Isom.Services.EdiabasResultSetList | Listen von EDIABAS-Ergebnismengen des Typs Isom.Services.EdiabasResultSet
Isom.Services.ServiceManager | Fachobjekt für Informationen zum Fachdienstzugriff


für Serviceautoren

Isom.Services.Asam

Namensraum Isom.Services.Asam

ASAM-Job-Aufrufe Mehr...

Funktionen
Statische Funktionen

Funktionen zum Aufruf eines ASAM-Jobs oder -Diensts auf einer logischen Verbindung.

Isom.Services.AsamResponseList | Execute(Isom.Base.String logicalLink, Isom.Base.String jobName, Isom.Services.AsamParameterList parameters)

Statischer Aufruf eines ASAM-Jobs oder -Diensts auf einer logischen Verbindung.

Isom.Services.AsamResponseList | ExecuteOnEcu(Isom.Context.Ecu ecu, Isom.Base.String jobName, Isom.Services.AsamParameterList parameters)

Statischer Aufruf eines ASAM-Jobs oder -Diensts auf einem Steuergerät.

Ausführliche Beschreibung

Isom.Services.Asam ist für den ASAM-Job-Aufruf zuständig.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Services\Asam.is

Dokumentation der Funktionen

Isom.Services.AsamResponseList Isom.Services.Asam.Execute | ( | Isom.Base.String | logicalLink,
 |  | Isom.Base.String | jobName,
 |  | Isom.Services.AsamParameterList | parameters
 | ) |  |

Statischer Aufruf eines ASAM-Jobs oder -Diensts auf einer logischen Verbindung.

   using Isom.Base.*
   using Isom.Services.*;
   ...
      String logicalLink = "LOGICAL_LINK_NAME";
      String jobName = "ASAM_JOB_NAME";
      AsamParameterList parameters = AsamParameterList.CreateAsamParameterList();
      AsamParameter paramUInt32 =
                        AsamParameter.CreateSimple("PARAMETER_NAME", "UINT32", "42");
   ...
      params.Insert(paramLogLevel);
      AsamResponseList responseList = Asam.Execute(logicalLink, jobName, parameters);
      AsamParameterList firstResponse = responseList.At(0);
      AsamParameter someResponseParam = firstResponse.Get("RESP_PARAMETER_NAME");
   ...
Parameter:
logicalLink | Name der logischen Verbindung
jobName | Name des ASAM-Jobs oder -Diensts
parameters | Parameterliste für diesen Job
Achtung:
Diese Funktion wird nicht für alle D-Server-Implementierungen angeboten. Alternativ kann die Funktion "ExecuteOnEcu" benutzt werden.
Rückgabe:
Liste von ASAM-Antworten oder Void, falls der Aufruf nicht unterstützt wird.
[Isom\Services\Asam.is: 99]
Isom.Services.AsamResponseList Isom.Services.Asam.ExecuteOnEcu | ( | Isom.Context.Ecu | ecu,
 |  | Isom.Base.String | jobName,
 |  | Isom.Services.AsamParameterList | parameters
 | ) |  |

Statischer Aufruf eines ASAM-Jobs oder -Diensts auf einem Steuergerät.

   using Isom.Base.*
   using Isom.Context.Ecu;
   using Isom.Services.*;
   ...
      Ecu ecu = ...
      String jobName = "ASAM_JOB_NAME";
      AsamParameterList parameters = AsamParameterList.CreateAsamParameterList();
      AsamParameter paramUInt32 =
                        AsamParameter.CreateSimple("PARAMETER_NAME", "UINT32", "42");
      params.Insert(paramLogLevel);
   ...
      AsamResponseList responseList = Asam.ExecuteOnEcu(ecu, jobName, parameters);
      AsamParameterList firstResponse = responseList.At(0);
      AsamParameter someResponseParam = firstResponse.Get("RESP_PARAMETER_NAME");
   ...
Parameter:
ecu | Steuergerät, für das der Aufruf erfolgen soll
jobName | Name des ASAM-Jobs oder -Diensts
parameters | Parameterliste für diesen Job
Rückgabe:
Liste von ASAM-Antworten
[Isom\Services\Asam.is: 132]


für Serviceautoren

Isom.Services.AsamParameter

Namensraum Isom.Services.AsamParameter

Parameter eines ASAM-Jobs oder -Diensts. Mehr...

Funktionen
Generatorfunktionen

Funktionen zur Erzeugung von ASAM-Parameter.

Isom.Services.AsamParameter | Create(Isom.Base.String name)

Erzeugt einen benannten ASAM-Parameter ohne Typinformation oder Wert.

Isom.Services.AsamParameter | CreateComplex(Isom.Base.String name, Isom.Base.String dataType)

Erzeugt einen komplexen ASAM-Parameter.

Isom.Services.AsamParameter | CreateSimple(Isom.Base.String name, Isom.Base.String dataType, Isom.Base.String value)

Erzeugt einen einfachen ASAM-Parameter.

Zugriffsfunktionen

Funktionen, die es erlauben auf ASAM-Parameter zuzugreifen.

Isom.Base.String | GetDataType()

Ruft den aktuellen ASAM-Datentyp des Parameters ab.

Isom.Base.String | GetName()

Ruft den Namen des Parameters ab.

Isom.Base.String | GetValue()

Ruft den Wert des Parameters ab.

Isom.Base.Boolean | IsComplex()

Bestimmt, ob es sich um einen komplexen Parameter handelt.

Isom.Base.Boolean | SetDataType(Isom.Base.String dataType)

Setzt den aktuellen ASAM-Datentyp des Parameters.

Isom.Base.String | SetName(Isom.Base.String name)

Setzt den Namen des Parameters.

Isom.Base.Boolean | SetValue(Isom.Base.String val)

Setzt den Wert eines einfachen Parameters.

Listenfunktionen

Isom.Services.AsamParameter | At(Isom.Base.Number index)

Liefert den Unterparameter am angegebenen nullbasierten Index aus der Liste zurück.

Isom.Base.Boolean | Contains(Isom.Base.String name)

Prüft, ob ein Unterparameter mit dem angegebenen Namen in der Liste enthalten ist.

Isom.Services.AsamParameter | Current()

Liefert während des Durchlaufens der Liste den aktuellen Unterparameter

Isom.Services.AsamParameter | Get(Isom.Base.String name)

Ruft einen benannten Unterparameter des Parameters ab.

Isom.Base.Boolean | HasNext()

Prüft, ob es beim Durchlaufen der Liste mit .Next() Unterparameter gibt, die noch nicht abgerufen wurden.

Isom.Base.Number | Insert(Isom.Services.AsamParameter element)

Fügt einem Parameter einen Unterparameter hinzu.

Isom.Base.Boolean | IsEmpty()

Prüft, ob dieser Parameter Unterparameter enthält oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Unterparameter.

Isom.Services.AsamParameter | Next()

Liefert beim Durchlaufen der Liste den nächsten Unterparameter.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt den Unterparameter mit dem angegebenen Index aus der Liste eines Parameters.

Isom.Base.Boolean | RemoveByName(Isom.Base.String name)

Entfernt den Unterparameter mit dem angegebenen Namen aus der Liste eines Parameters.

Isom.Base.Boolean | Reset()

Setzt den Durchlauf-Iterator vor das erste Element der Liste von Unterparameters, so ein neuer Durchlauf der Liste begonnen werden kann.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Services.AsamParameter | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Services.AsamParameter | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Ein Parameter kann selbst weitere (Unter-)Parameter enthalten. Er bietet daher die Funktionalität einer Liste, deren Elemente per Index oder per Name abgerufen werden können.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Services\AsamParameter.is

Dokumentation der Funktionen

objectbound Isom.Services.AsamParameter Isom.Services.AsamParameter.At ( Isom.Base.Number index )

Liefert den Unterparameter am angegebenen nullbasierten Index aus der Liste zurück.

 AsamParameter param = AsamParameter.CreateComplex("MUX_NAME", "MULTIPLEXER");
 AsamParameter subParam = AsamParameter.CreateSimple("TEST", "UINT32", "5");
 param.Insert(subParam);
 AsamParameter firstSubParam = param.At(0);            // firstSubParam ist subParam
 AsamParameter secondSubParam = param.At(1);           // secondSubParam ist Void
Parameter:
index Index des abgerufenen Elements in der Liste, beginnend bei 0 für das erste Element.
Rückgabe:
Parameter mit dem übergebenen Index.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 oder größer gleich der Anzahl der Listenelemente (=Anzahl der Unterparameter) ist, oder der Parameter ein einfacher Parameter ist.
[Isom\Services\AsamParameter.is: 475]
objectbound Isom.Services.AsamParameter Isom.Services.AsamParameter.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue AsamParameter mit demselben Inhalt.
[Isom\Services\AsamParameter.is: 625]
objectbound Isom.Base.Boolean Isom.Services.AsamParameter.Contains ( Isom.Base.String name )

Prüft, ob ein Unterparameter mit dem angegebenen Namen in der Liste enthalten ist.

 AsamParameter param = ...
 AsamParameter subParam0 = AsamParameter.CreateSimple("TEST0", "UINT32", "5");
 param.Insert(subParam0);
 Boolean contained = param.Contains("TEST0"); // contained ist true
Parameter:
name Name des Unterparameters.
Rückgabe:
'true', falls das Element enthalten ist, 'false' sonst (z.B. wenn der Name das Void-Objekt ist oder kein Parameter dieses Namens bekannt ist).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Aufruf auf einem einfachen Parameter erfolgt.
[Isom\Services\AsamParameter.is: 599]
Isom.Services.AsamParameter Isom.Services.AsamParameter.Create ( Isom.Base.String name )

Erzeugt einen benannten ASAM-Parameter ohne Typinformation oder Wert.

 AsamParameter param = AsamParameter.Create("PARAMETER_NAME");
Rückgabe:
Der neu erzeugte ASAM-Parameter.
[Isom\Services\AsamParameter.is: 108]
Isom.Services.AsamParameter Isom.Services.AsamParameter.CreateComplex | ( | Isom.Base.String | name,
 |  | Isom.Base.String | dataType
 | ) |  |

Erzeugt einen komplexen ASAM-Parameter.

 AsamParameter param = AsamParameter.CreateSimple("COMPLEX_PARAMETER_NAME", "MULTIPLEXER");
Parameter:
name Name des ASAM-Parameters
dataType ASAM-Datentyp des Parameters; erlaubte Werte für diese Zeichenkette sind:
  • "DTC"
  • "END_OF_PDU"
  • "ENVDATA"
  • "ENVDATADESC"
  • "FIELD"
  • "MULTIPLEXER"
  • "STRUCTURE"
  • "TABLE"
  • "TEXTTABLE"
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der angegebene Datentyp ungültig ist oder sich der angebene Wert nicht in den Datentyp konvertiert werden kann.
Rückgabe:
Der neu erzeugte ASAM-Parameter
[Isom\Services\AsamParameter.is: 176]
Isom.Services.AsamParameter Isom.Services.AsamParameter.CreateSimple | ( | Isom.Base.String | name,
 |  | Isom.Base.String | dataType,
 |  | Isom.Base.String | value
 | ) |  |

Erzeugt einen einfachen ASAM-Parameter.

 AsamParameter param = AsamParameter.CreateSimple("SIMPLE_PARAMETER_NAME", "UINT32", "42");
Parameter:
name | Name des ASAM-Parameters
dataType ASAM-Datentyp des Parameters; erlaubte Werte für diese Zeichenkette sind:
  • "ASCIISTRING"
  • "BITFIELD"
  • "BOOLEAN"
  • "BYTEFIELD"
  • "FLOAT32"
  • "FLOAT64"
  • "INT16"
  • "INT32"
  • "INT64"
  • "INT8"
  • "KEY"
  • "LENGTHKEY"
  • "UINT16"
  • "UINT32"
  • "UINT64"
  • "UINT8"
  • "UNICODE2STRING"
value | Wert des Parameters
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der angegebene Datentyp ungültig ist oder sich der angebene Wert nicht in den Datentyp konvertiert werden kann.
Rückgabe:
Der neu erzeugte ASAM-Parameter
[Isom\Services\AsamParameter.is: 146]
objectbound Isom.Services.AsamParameter Isom.Services.AsamParameter.Current ( )

Liefert während des Durchlaufens der Liste den aktuellen Unterparameter

 AsamParameter param = ...
 param.Reset();                        //Listendurchlauf vorbereiten
 while (param.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    param.Next();
    AsamParameter currentSubParam = param.Current();     //Element abrufen
    ...
 }
Rückgabe:
Aktueller Unterparameter aus der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Durchlauf-Iterator vor das erste Element der Liste zeigt.
[Isom\Services\AsamParameter.is: 433]
objectbound Isom.Services.AsamParameter Isom.Services.AsamParameter.Get ( Isom.Base.String name )

Ruft einen benannten Unterparameter des Parameters ab.

 AsamParameter param = ...
 AsamParameter subParam = param.Get("SUB_PARAM_NAME");
Parameter:
name Name des abzurufenden Unterparameters.
Rückgabe:
Parameter mit dem übergebenen Namen.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls kein Unterparameter mit diesem Namen enthalten ist oder der Parameter ein einfacher Parameter ist.
[Isom\Services\AsamParameter.is: 550]
objectbound Isom.Base.String Isom.Services.AsamParameter.GetDataType ( )

Ruft den aktuellen ASAM-Datentyp des Parameters ab.

 AsamParameter param = ...
 String dataType = param.GetDataType();
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Typ des Parameters unbekannt ist.
Achtung:
Nicht alle D-Server-Implementierungen können diese Information anbieten, falls es sich um einen Rückgabeparameter eines ASAM-Aufrufs handelt. In diesem Fall wird das Void-Objekt zurückgegeben.
Rückgabe:
Der aktuelle ASAM-Datentyp des Parameters als Zeichenkette.
[Isom\Services\AsamParameter.is: 269]
objectbound Isom.Base.String Isom.Services.AsamParameter.GetName ( )

Ruft den Namen des Parameters ab.

 AsamParameter param = ...
 String paramName = param.GetName();
Rückgabe:
Der Name des Parameters
[Isom\Services\AsamParameter.is: 198]
objectbound Isom.Base.String Isom.Services.AsamParameter.GetValue ( )

Ruft den Wert des Parameters ab.

Achtung:
Der Wert eines komplexen Parameters ist die Anzahl seiner Unterparameter.
 AsamParameter param = ...
 String val = param.GetValue();
Rückgabe:
Der Wert des Parameters
[Isom\Services\AsamParameter.is: 228]
objectbound Isom.Base.Boolean Isom.Services.AsamParameter.HasNext ( )

Prüft, ob es beim Durchlaufen der Liste mit .Next() Unterparameter gibt, die noch nicht abgerufen wurden.

 AsamParameter param = ...
 param.Reset();                        //Listendurchlauf vorbereiten
 while (param.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    AsamParameter currentSubParam = param.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
'true', falls noch weitere Parameter in der Liste mit .Next() abgerufen werden können, 'false' sonst.
[Isom\Services\AsamParameter.is: 389]
objectbound Isom.Base.Number Isom.Services.AsamParameter.Insert ( Isom.Services.AsamParameter element )

Fügt einem Parameter einen Unterparameter hinzu.

Das Element wird an der letzten Position eingefügt. Ein eventuell aktiver Iterator, wird durch diese Operation zurückgesetzt.

 AsamParameter param = AsamParameter.CreateComplex("MUX_NAME", "MULTIPLEXER");
 AsamParameter subParam = AsamParameter.CreateSimple("TEST", "UINT32", "5");
 param.Insert(subParam);
Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügender Unterparameter.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
Es wird das Void-Objekt zurückgegeben, falls der Aufruf auf einem einfachen Parameter erfolgt.
[Isom\Services\AsamParameter.is: 506]
objectbound Isom.Base.Boolean Isom.Services.AsamParameter.IsComplex ( )

Bestimmt, ob es sich um einen komplexen Parameter handelt.

 AsamParameter param = ...
 Boolean isComplex = param.IsComplex();
Rückgabe:
"True" genau dann, wenn es sich um einen komplexen Parameter handelt.
[Isom\Services\AsamParameter.is: 326]
objectbound Isom.Base.Boolean Isom.Services.AsamParameter.IsEmpty ( )

Prüft, ob dieser Parameter Unterparameter enthält oder nicht.

 AsamParameter param = AsamParameter.CreateComplex("MUX_NAME", "MULTIPLEXER");
 Boolean isEmpty = param.IsEmpty();    // isEmpty ist true
 AsamParameter subParam = AsamParameter.CreateSimple("TEST", "UINT32", "5");
 param.Insert(subParam);
 isEmpty = param.IsEmpty();            // isEmpty ist false
Rückgabe:
'true', falls dieser Parameter Unterparameter enthält, 'false' sonst.
[Isom\Services\AsamParameter.is: 369]
objectbound Isom.Base.Boolean Isom.Services.AsamParameter.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Services\AsamParameter.is: 617]
objectbound Isom.Base.Number Isom.Services.AsamParameter.Length ( )

Liefert die Anzahl der Unterparameter.

 AsamParameter param = AsamParameter.CreateComplex("MUX_NAME", "MULTIPLEXER");
 AsamParameter subParam0 = AsamParameter.CreateSimple("TEST0", "UINT32", "5");
 AsamParameter subParam1 = AsamParameter.CreateSimple("TEST1", "INT32", "7653");
 param.Insert(subParam0);
 param.Insert(subParam1);
 Number length = param.Length(); // length ist 2
Rückgabe:
Anzahl der Elemente.
[Isom\Services\AsamParameter.is: 353]
objectbound Isom.Services.AsamParameter Isom.Services.AsamParameter.Next ( )

Liefert beim Durchlaufen der Liste den nächsten Unterparameter.

Ein Listendurchlauf wird mit .Reset() zurückgesetzt, um mit .Next() vom Listenanfang an durchlaufen zu können.

 AsamParameter param = ...
 param.Reset();                        //Listendurchlauf vorbereiten
 while (param.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    AsamParameter currentSubParam = param.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Nächster Unterparameter aus der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Services\AsamParameter.is: 411]
objectbound Isom.Base.Boolean Isom.Services.AsamParameter.Remove ( Isom.Base.Number index )

Entfernt den Unterparameter mit dem angegebenen Index aus der Liste eines Parameters.

Ein eventuell aktiver Durchlauf-Iterator wird durch diese Operation zurückgesetzt.

 AsamParameter param = ...
 AsamParameter subParam0 = AsamParameter.CreateSimple("TEST0", "UINT32", "5");
 AsamParameter subParam1 = AsamParameter.CreateSimple("TEST1", "INT32", "7653");
 param.Insert(subParam0); // Liste enthält subParam0
 param.Insert(subParam1); // Liste enthält subParam0, subParam 1
 param.Remove(0); // Liste enthält subParam1
Rückgabe:
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Aufruf auf einem einfachen Parameter erfolgt.
[Isom\Services\AsamParameter.is: 531]
objectbound Isom.Base.Boolean Isom.Services.AsamParameter.RemoveByName ( Isom.Base.String name )

Entfernt den Unterparameter mit dem angegebenen Namen aus der Liste eines Parameters.

Ein eventuell aktiver Durchlauf-Iterator wird durch diese Operation zurückgesetzt.

 AsamParameter param = ...
 AsamParameter subParam0 = AsamParameter.CreateSimple("TEST0", "UINT32", "5");
 AsamParameter subParam1 = AsamParameter.CreateSimple("TEST1", "INT32", "7653");
 param.Insert(subParam0); // Liste enthält subParam0
 param.Insert(subParam1); // Liste enthält subParam0, subParam 1
 param.Remove("TEST0"); // Liste enthält subParam1
Parameter:
name Name des zu entfernenden Unterparameters.
Rückgabe:
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Name das Void-Objekt ist oder kein Parameter dieses Namens bekannt ist).
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Aufruf auf einem einfachen Parameter erfolgt.
[Isom\Services\AsamParameter.is: 577]
objectbound Isom.Base.Boolean Isom.Services.AsamParameter.Reset ( )

Setzt den Durchlauf-Iterator vor das erste Element der Liste von Unterparameters, so ein neuer Durchlauf der Liste begonnen werden kann.

 AsamParameter param = ...
 param.Reset();                        //Listendurchlauf vorbereiten
 while (param.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    AsamParameter currentSubParam = param.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Immer 'true'.
[Isom\Services\AsamParameter.is: 452]
objectbound Isom.Base.Boolean Isom.Services.AsamParameter.SetDataType ( Isom.Base.String dataType )

Setzt den aktuellen ASAM-Datentyp des Parameters.

 AsamParameter param = ...
 Boolean success = param.SetDataType("ASCIISTRING");
  • "ASCIISTRING"
  • "BITFIELD"
  • "BOOLEAN"
  • "BYTEFIELD"
  • "DTC"
  • "END_OF_PDU"
  • "ENVDATA"
  • "ENVDATADESC"
  • "FIELD"
  • "FLOAT32"
  • "FLOAT64"
  • "INT16"
  • "INT32"
  • "INT64"
  • "INT8"
  • "KEY"
  • "LENGTHKEY"
  • "MULTIPLEXER"
  • "STRUCTURE"
  • "TABLE"
  • "TEXTTABLE"
  • "UINT16"
  • "UINT32"
  • "UINT64"
  • "UINT8"
  • "UNICODE2STRING"
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Typ des Parameters unbekannt ist.
Rückgabe:
"True" genau dann, wenn das Setzen des Typs erfolgreich war.
[Isom\Services\AsamParameter.is: 312]
objectbound Isom.Base.String Isom.Services.AsamParameter.SetName ( Isom.Base.String name )

Setzt den Namen des Parameters.

 AsamParameter param = ...
 String newName = param.SetName("NEW_PARAM_NAME");
Parameter:
name Der zu setzende Name des Parameters
Rückgabe:
Der aktuell gesetzte Name des Parameters
[Isom\Services\AsamParameter.is: 213]
objectbound Isom.Base.Boolean Isom.Services.AsamParameter.SetValue ( Isom.Base.String val )

Setzt den Wert eines einfachen Parameters.

Achtung:
Der Wert eines komplexen Parameters kann nicht gesetzt werden.
 AsamParameter param = ...
 Boolean success = param.SetValue("42");
Parameter:
val Der zu setzende Wert des Parameters
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls es sich um einen komplexen Parameter handelt oder der angebene Wert nicht in den aktuellen Datentyp des Parameters konvertiert werden kann.
Rückgabe:
"True" genau dann, wenn das Setzen des Werts erfolgreich war.
[Isom\Services\AsamParameter.is: 249]
Isom.Services.AsamParameter Isom.Services.AsamParameter.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Services\AsamParameter.is: 637]


für Serviceautoren

Isom.Services.AsamParameterList

Namensraum Isom.Services.AsamParameterList

Liste von ASAM-Parametern. Mehr...

Funktionen
Generatorfunktionen

Isom.Services.AsamParameterList | CreateAsamParameterList()

Erzeugt eine neue Listeninstanz.

Listenfunktionen

Isom.Services.AsamParameter | At(Isom.Base.Number index)

Liefert den Parameter am angegebenen nullbasierten Index aus der Liste zurück.

Isom.Base.Boolean | Contains(Isom.Base.String name)

Prüft, ob ein Parameter mit dem angegebenen Namen in der Liste enthalten ist.

Isom.Services.AsamParameter | Current()

Liefert während des Durchlaufens der Liste den aktuellen Parameter

Isom.Services.AsamParameter | Get(Isom.Base.String name)

Ruft einen benannten Parameter aus der Liste ab.

Isom.Base.Boolean | HasNext()

Prüft, ob es beim Durchlaufen der Liste mit .Next() Elemente gibt, die noch nicht abgerufen wurden.

Isom.Base.Number | Insert(Isom.Services.AsamParameter element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Prüft, ob die Liste Elemente enthält

Isom.Base.Number | Length()

Liefert die Anzahl der Parameter.

Isom.Services.AsamParameter | Next()

Liefert beim Durchlaufen der Liste den nächsten Parameter.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt den Parameter mit dem angegebenen Index aus der Liste Ein eventuell aktiver Durchlauf-Iterator wird durch diese Operation zurückgesetzt.

Isom.Base.Boolean | RemoveByName(Isom.Base.String name)

Entfernt den Parameter mit dem angegebenen Namen aus der Liste eines Parameters.

Isom.Base.Boolean | Reset()

Setzt den Durchlauf-Iterator vor das erste Element der Liste von Parametern, so dass ein neuer Durchlauf der Liste begonnen werden kann.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Services.AsamParameterList | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Services.AsamParameterList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Ein Parameter kann selbst weitere (Unter-)Parameter enthalten. Er bietet daher die Funktionalität einer Liste, deren Elemente per Index oder per Name abgerufen werden können.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Services\AsamParameterList.is

Dokumentation der Funktionen

objectbound Isom.Services.AsamParameter Isom.Services.AsamParameterList.At ( Isom.Base.Number index )

Liefert den Parameter am angegebenen nullbasierten Index aus der Liste zurück.

 AsamParameterList paramList = AsamParameterList.CreateAsamParameterList();
 AsamParameter param0 = AsamParameter.CreateSimple("TEST0", "UINT32", "5");
 AsamParameter param1 = AsamParameter.CreateSimple("TEST1", "INT32", "-42");
 paramList.Insert(subParam0);
 paramList.Insert(subParam1);
 AsamParameter secondParam = paramList.At(1); // secondParam ist subParam1
Parameter:
index Index des abgerufenen Elements in der Liste, beginnend bei 0 für das erste Element.
Rückgabe:
Parameter mit dem übergebenen Index.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 oder größer gleich der Anzahl der Listenelemente (=Anzahl der Parameter) ist.
[Isom\Services\AsamParameterList.is: 254]
objectbound Isom.Services.AsamParameterList Isom.Services.AsamParameterList.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue AsamParameterList mit demselben Inhalt.
[Isom\Services\AsamParameterList.is: 397]
objectbound Isom.Base.Boolean Isom.Services.AsamParameterList.Contains ( Isom.Base.String name )

Prüft, ob ein Parameter mit dem angegebenen Namen in der Liste enthalten ist.

 AsamParameterList paramList = AsamParameterList.CreateAsamParameterList();
 AsamParameter subParam0 = AsamParameter.CreateSimple("TEST0", "UINT32", "5");
 AsamParameter subParam1 = AsamParameter.CreateSimple("TEST1", "INT32", "7653");
 paramList.Insert(subParam0); // Liste enthält subParam0
 paramList.Insert(subParam1); // Liste enthält subParam0, subParam 1
 Boolean isContained = paramList.Contains("TEST0"); // isContained ist "true"
Parameter:
name Name des Parameters.
Rückgabe:
'true', falls das Element enthalten ist, 'false' sonst (z.B. wenn der Name das Void-Objekt ist oder kein Parameter dieses Namens bekannt ist).
[Isom\Services\AsamParameterList.is: 371]
Isom.Services.AsamParameterList Isom.Services.AsamParameterList.CreateAsamParameterList ( )

Erzeugt eine neue Listeninstanz.

 AsamParameterListList paramList = AsamParameterList.CreateAsamParameterList();
Rückgabe:
Die neu erzeugte ASAM-Parameterliste.
[Isom\Services\AsamParameterList.is: 105]
objectbound Isom.Services.AsamParameter Isom.Services.AsamParameterList.Current ( )

Liefert während des Durchlaufens der Liste den aktuellen Parameter

 AsamParameterList paramList = ...
 paramList.Reset();                        //Listendurchlauf vorbereiten
 while (paramList.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    paramList.Next();
    AsamParameter param = paramList.Current();     //Element abrufen
    ...
 }
Rückgabe:
Aktueller Parameter aus der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Durchlauf-Iterator vor das erste Element der Liste zeigt.
[Isom\Services\AsamParameterList.is: 212]
objectbound Isom.Services.AsamParameter Isom.Services.AsamParameterList.Get ( Isom.Base.String name )

Ruft einen benannten Parameter aus der Liste ab.

 AsamParameterList paramList = AsamParameterList.CreateAsamParameterList();
 AsamParameter param = AsamParameter.CreateSimple("TEST0", "UINT32", "5");
 paramList.Insert(param);
 AsamParameter namedParam = paramList.Get("TEST0");
Parameter:
name Name des abzurufenden Parameters.
Rückgabe:
Parameter mit dem übergebenen Namen.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls kein Parameter mit diesem Namen enthalten ist.
[Isom\Services\AsamParameterList.is: 325]
objectbound Isom.Base.Boolean Isom.Services.AsamParameterList.HasNext ( )

Prüft, ob es beim Durchlaufen der Liste mit .Next() Elemente gibt, die noch nicht abgerufen wurden.

 AsamParameterList paramList = ...
 paramList.Reset();                        //Listendurchlauf vorbereiten
 while (paramList.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    AsamParameter param = paramList.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
'true', falls noch weitere Parameter in der Liste mit .Next() abgerufen werden können, 'false' sonst.
[Isom\Services\AsamParameterList.is: 168]
objectbound Isom.Base.Number Isom.Services.AsamParameterList.Insert ( Isom.Services.AsamParameter element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Iterator, wird durch diese Operation zurückgesetzt.

 AsamParameterList paramList = AsamParameterList.CreateAsamParameterList();
 AsamParameter param = AsamParameter.CreateSimple("TEST0", "UINT32", "5");
 paramList.Insert(param);
Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügender Parameter.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
[Isom\Services\AsamParameterList.is: 283]
objectbound Isom.Base.Boolean Isom.Services.AsamParameterList.IsEmpty ( )

Prüft, ob die Liste Elemente enthält

 AsamParameterList paramList = AsamParameterList.CreateAsamParameterList();
 AsamParameter param0 = AsamParameter.CreateSimple("TEST0", "UINT32", "5");
 Boolean isEmpty = paramList.IsEmpty(); // isEmpty ist "true"
 paramList.Insert(subParam0);
 Boolean isEmpty = paramList.IsEmpty(); // isEmpty ist "false"
Rückgabe:
'true', falls die Liste Elemente enthält, 'false' sonst.
[Isom\Services\AsamParameterList.is: 148]
objectbound Isom.Base.Boolean Isom.Services.AsamParameterList.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Services\AsamParameterList.is: 389]
objectbound Isom.Base.Number Isom.Services.AsamParameterList.Length ( )

Liefert die Anzahl der Parameter.

 AsamParameterList paramList = AsamParameterList.CreateAsamParameterList();
 AsamParameter param0 = AsamParameter.CreateSimple("TEST0", "UINT32", "5");
 AsamParameter param1 = AsamParameter.CreateSimple("TEST1", "INT32", "-42");
 paramList.Insert(subParam0);
 paramList.Insert(subParam1);
 Number length = paramList.Length(); // length ist 2
Rückgabe:
Anzahl der Elemente.
[Isom\Services\AsamParameterList.is: 132]
objectbound Isom.Services.AsamParameter Isom.Services.AsamParameterList.Next ( )

Liefert beim Durchlaufen der Liste den nächsten Parameter.

Ein Listendurchlauf wird mit .Reset() zurückgesetzt, um mit .Next() vom Listenanfang an durchlaufen zu können.

 AsamParameterList paramList = ...
 paramList.Reset();                        //Listendurchlauf vorbereiten
 while (paramList.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    AsamParameter param = paramList.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Nächster Parameter aus der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Services\AsamParameterList.is: 190]
objectbound Isom.Base.Boolean Isom.Services.AsamParameterList.Remove ( Isom.Base.Number index )

Entfernt den Parameter mit dem angegebenen Index aus der Liste Ein eventuell aktiver Durchlauf-Iterator wird durch diese Operation zurückgesetzt.

 AsamParameterList paramList = AsamParameterList.CreateAsamParameterList();
 AsamParameter subParam0 = AsamParameter.CreateSimple("TEST0", "UINT32", "5");
 AsamParameter subParam1 = AsamParameter.CreateSimple("TEST1", "INT32", "7653");
 paramList.Insert(subParam0); // Liste enthält subParam0
 paramList.Insert(subParam1); // Liste enthält subParam0, subParam 1
 paramList.Remove(0); // Liste enthält subParam1
Rückgabe:
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt).
[Isom\Services\AsamParameterList.is: 304]
objectbound Isom.Base.Boolean Isom.Services.AsamParameterList.RemoveByName ( Isom.Base.String name )

Entfernt den Parameter mit dem angegebenen Namen aus der Liste eines Parameters.

Ein eventuell aktiver Durchlauf-Iterator wird durch diese Operation zurückgesetzt.

 AsamParameterList paramList = AsamParameterList.CreateAsamParameterList();
 AsamParameter subParam0 = AsamParameter.CreateSimple("TEST0", "UINT32", "5");
 AsamParameter subParam1 = AsamParameter.CreateSimple("TEST1", "INT32", "7653");
 paramList.Insert(subParam0); // Liste enthält subParam0
 paramList.Insert(subParam1); // Liste enthält subParam0, subParam 1
 paramList.RemoveByName("TEST0"); // Liste enthält subParam1
Parameter:
name Name des zu entfernenden Parameters.
Rückgabe:
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Name das Void-Objekt ist oder kein Parameter dieses Namens bekannt ist).
[Isom\Services\AsamParameterList.is: 350]
objectbound Isom.Base.Boolean Isom.Services.AsamParameterList.Reset ( )

Setzt den Durchlauf-Iterator vor das erste Element der Liste von Parametern, so dass ein neuer Durchlauf der Liste begonnen werden kann.

 AsamParameterList paramList = ...
 paramList.Reset();                        //Listendurchlauf vorbereiten
 while (paramList.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    AsamParameter param = paramList.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Immer 'true'.
[Isom\Services\AsamParameterList.is: 231]
Isom.Services.AsamParameterList Isom.Services.AsamParameterList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Services\AsamParameterList.is: 409]


für Serviceautoren

Isom.Services.AsamResponseList

Namensraum Isom.Services.AsamResponseList

Liste von ASAM-Antworten. Mehr...

Funktionen
Listenfunktionen

Isom.Services.AsamParameterList | At(Isom.Base.Number index)

Liefert Die Antwort am angegebenen nullbasierten Index aus der Liste zurück.

Isom.Services.AsamParameterList | Current()

Liefert während des Durchlaufens der Liste die aktuelle Antwort

Isom.Base.Boolean | HasNext()

Prüft, ob es beim Durchlaufen der Liste mit .Next() Elemente gibt, die noch nicht abgerufen wurden.

Isom.Base.Boolean | IsEmpty()

Prüft, ob die Liste Elemente enthält

Isom.Base.Number | Length()

Liefert die Anzahl der Parameter.

Isom.Services.AsamParameterList | Next()

Liefert beim Durchlaufen der Liste die nächste Antwort.

Isom.Base.Boolean | Reset()

Setzt den Durchlauf-Iterator vor das erste Element der Liste, so dass ein neuer Durchlauf der Liste begonnen werden kann.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Services.AsamResponseList | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Services.AsamResponseList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Eine Antwort besteht wiederum aus einer Liste von ASAM-Parametern.

Siehe auch:
Isom.Services.AsamParameterList

Der Autor kann selbst keine Instanzen dieses Fachobjekts erzeugen; er kann sie nur als Rückgabe eines ASAM-Aufrufs erhalten.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Services\AsamResponseList.is

Dokumentation der Funktionen

objectbound Isom.Services.AsamParameterList Isom.Services.AsamResponseList.At ( Isom.Base.Number index )

Liefert Die Antwort am angegebenen nullbasierten Index aus der Liste zurück.

 AsamResponseList responseList = Asam.Execute(...);
 AsamParameterList firstResponse = responseList.At(0);
Parameter:
index Index des abgerufenen Elements in der Liste, beginnend bei 0 für das erste Element.
Rückgabe:
Antwort mit dem übergebenen Index.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 oder größer gleich der Anzahl der Listenelemente (=Anzahl der Antworten) ist.
[Isom\Services\AsamResponseList.is: 207]
objectbound Isom.Services.AsamResponseList Isom.Services.AsamResponseList.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue AsamResponseList mit demselben Inhalt.
[Isom\Services\AsamResponseList.is: 233]
objectbound Isom.Services.AsamParameterList Isom.Services.AsamResponseList.Current ( )

Liefert während des Durchlaufens der Liste die aktuelle Antwort

 AsamResponseList responseList = Asam.Execute(...);
 responseList.Reset();                        //Listendurchlauf vorbereiten
 while (responseList.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    AsamParameterList response = responseList.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Aktuelle Antwort aus der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Durchlauf-Iterator vor das erste Element der Liste zeigt.
[Isom\Services\AsamResponseList.is: 168]
objectbound Isom.Base.Boolean Isom.Services.AsamResponseList.HasNext ( )

Prüft, ob es beim Durchlaufen der Liste mit .Next() Elemente gibt, die noch nicht abgerufen wurden.

 AsamResponseList responseList = Asam.Execute(...);
 responseList.Reset();                        //Listendurchlauf vorbereiten
 while (responseList.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    AsamParameterList response = responseList.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
'true', falls noch weitere Antworten in der Liste mit .Next() abgerufen werden können, 'false' sonst.
[Isom\Services\AsamResponseList.is: 125]
objectbound Isom.Base.Boolean Isom.Services.AsamResponseList.IsEmpty ( )

Prüft, ob die Liste Elemente enthält

 AsamResponseList responseList = Asam.Execute(...);
 Boolean isEmpty = responseList.IsEmpty();
Rückgabe:
'true', falls die Liste Elemente enthält, 'false' sonst.
[Isom\Services\AsamResponseList.is: 105]
objectbound Isom.Base.Boolean Isom.Services.AsamResponseList.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Services\AsamResponseList.is: 225]
objectbound Isom.Base.Number Isom.Services.AsamResponseList.Length ( )

Liefert die Anzahl der Parameter.

 AsamResponseList responseList = Asam.Execute(...);
 Number length = responseList.Length();
Rückgabe:
Anzahl der Elemente.
[Isom\Services\AsamResponseList.is: 92]
objectbound Isom.Services.AsamParameterList Isom.Services.AsamResponseList.Next ( )

Liefert beim Durchlaufen der Liste die nächste Antwort.

Ein Listendurchlauf wird mit .Reset() zurückgesetzt, um mit .Next() vom Listenanfang an durchlaufen zu können.

 AsamResponseList responseList = Asam.Execute(...);
 responseList.Reset();                        //Listendurchlauf vorbereiten
 while (responseList.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    AsamParameterList response = responseList.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Nächste Antwort aus der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Services\AsamResponseList.is: 147]
objectbound Isom.Base.Boolean Isom.Services.AsamResponseList.Reset ( )

Setzt den Durchlauf-Iterator vor das erste Element der Liste, so dass ein neuer Durchlauf der Liste begonnen werden kann.

 AsamResponseList responseList = Asam.Execute(...);
 responseList.Reset();                        //Listendurchlauf vorbereiten
 while (responseList.HasNext ())              //Prüfen, ob es ein nächstes Element gibt
 {
    AsamParameterList response = responseList.Next();     //Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Immer 'true'.
[Isom\Services\AsamResponseList.is: 187]
Isom.Services.AsamResponseList Isom.Services.AsamResponseList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Services\AsamResponseList.is: 245]


für Serviceautoren

Isom.Services.DataProcurement

Namensraum Isom.Services.DataProcurement

Zugriff auf allgemeine Informationen der Datenbeschaffung Mehr...

Funktionen
Namensraufunktionen

Funktionen für Zugriff auf allgemeine Informationen der Datenbeschaffung.

Isom.Base.StringList | GetDataSources(Isom.Base.String category, Isom.Base.StringDictionary attributes)

Ermittelt die Liste aller Datenquellen, die vom DataProcurement Anbieter der eingegebenen Kategorie verwaltet werden

Isom.Base.StringDictionary | GetProperties(Isom.Base.String dataSource)

Die Funktion ermittelt die Eigenschaft der Datenquelle dataSource und gibt diese in einem Wörterbuch zurück.

Isom.Base.Data | Query(Isom.Base.String dataSource, Isom.Base.StringDictionary filter)

Die Funktion sucht in der Datenquelle nach Daten die die Bedingungen im Wörterbuch filter erfüllen.

Isom.Base.Boolean | Verify(Isom.Base.String category, Isom.Base.StringDictionary attributes)

Diese Funktion überprüft beim Datenanbieter Kategorie die Gültigkeit der definierten Merkmale aus dem Parameter attributes und gibt das Ergebnis der Prüfung wieder zurück

Ausführliche Beschreibung

Isom.Services.DataProcurement dient dem Zugriff auf allgemeine Informationen der Datenbeschaffung

Quelldateien:

  • Isom\Services\DataProcurement.is

Dokumentation der Funktionen

Isom.Base.StringList Isom.Services.DataProcurement.GetDataSources | ( | Isom.Base.String | category,
 |  | Isom.Base.StringDictionary | attributes
 | ) |  |

Ermittelt die Liste aller Datenquellen, die vom DataProcurement Anbieter der eingegebenen Kategorie verwaltet werden

Parameter:
category | : Kategorie des DataProcurement-Anbieters
attributes | : Attribute (key,value) der gesuchten Datenquellen
Rückgabe:
Bei Erfolg wird die Liste mit den IDs der gefundenen Datenquellen zurückgegeben
[Isom\Services\DataProcurement.is: 70]
Isom.Base.StringDictionary Isom.Services.DataProcurement.GetProperties ( Isom.Base.String dataSource )

Die Funktion ermittelt die Eigenschaft der Datenquelle dataSource und gibt diese in einem Wörterbuch zurück.

Das Wörterbuch wird vom DataProcurement-Anbieter erzeugt und enthält OEM-spezifische Werte.

Parameter:
dataSource : ID der Datenquelle
Rückgabe:
Bei erfolgreicher Ausführung wird das Wörterbuch mit den Eigenschaften der Datenquelle zurückgegeben
[Isom\Services\DataProcurement.is: 93]
Isom.Base.Data Isom.Services.DataProcurement.Query | ( | Isom.Base.String | dataSource,
 |  | Isom.Base.StringDictionary | filter
 | ) |  |

Die Funktion sucht in der Datenquelle nach Daten die die Bedingungen im Wörterbuch filter erfüllen.

Die Bedingungen sind OEM-spezifisch. Sie werden vom zugeordneten DataProcurement-Anbieter ausgewertet und auf die Suche angewendet.

Parameter:
dataSource | : ID der Datenquelle
filter | : Wörterbuch der Suchbedingungen
Rückgabe:
Bei erfolgreicher Ausführung wird das Ergebnis der Anfrage in einer OEM-spezifischen XML-Struktur zurückgegeben.
[Isom\Services\DataProcurement.is: 106]
Isom.Base.Boolean Isom.Services.DataProcurement.Verify | ( | Isom.Base.String | category,
 |  | Isom.Base.StringDictionary | attributes
 | ) |  |

Diese Funktion überprüft beim Datenanbieter Kategorie die Gültigkeit der definierten Merkmale aus dem Parameter attributes und gibt das Ergebnis der Prüfung wieder zurück

Parameter:
category | : Kategorie des DataProcurement Anbieters
attributes | : Wörterbuch mit der Definition der zu prüfenden Merkmale
Rückgabe:
Bei erfolgreicher Ausführung wird das Ergebnis der Prüfung zurückgegeben
[Isom\Services\DataProcurement.is: 82]


für Serviceautoren

Isom.Services.Ediabas

Namensraum Isom.Services.Ediabas

EDIABAS-Job-Aufrufe Mehr...

Funktionen
Statische Funktionen

Funktionen zur Verwendung von EDIABAS.

Isom.Services.EdiabasResultSetList | CallEdiabas(Isom.Base.String sgbd, Isom.Base.String jobName, Isom.Base.String jobParams)

Statischer Aufruf eines EDIABAS-Jobs mit textbasierten Argumenten.

Isom.Services.EdiabasResultSetList | CallEdiabasBin(Isom.Base.String sgbd, Isom.Base.String jobName, Isom.Base.String jobParams)

Statischer Aufruf eines EDIABAS-Jobs mit binären Argumenten (hex-codiert).

Isom.Base.Boolean | ResetTimeout()

Setzt den Timeout-Wert zurück.

Isom.Base.Boolean | RetainSession(Isom.Base.Boolean permanent)

Die Funktion 'RetainSession' bewirkt, dass die EDIABAS-Instanz nicht geschlossen wird, wenn permanent auf 'true' gesetzt wird.

Isom.Base.Boolean | SetTimeout(Isom.Base.Number timeoutValue)

Setzt einen Timeout-Wert für die Ausführung des EDIABAS-Jobs.

Ausführliche Beschreibung

Dieses Fachobjekt ermöglicht es, EDIABAS-Jobs auszuführen. Es orientiert sich dabei mit seiner Schnittstelle an der tatsächlichen Schnittstelle von EDIABAS.

Dieses Fachobjekt funktioniert nicht mit ISOM Didact. Die Funktionen zeigen keine Wirkung und/oder kehren mit dem Ergebnis 'Void' zurück.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Services\Ediabas.is

Dokumentation der Funktionen

Isom.Services.EdiabasResultSetList Isom.Services.Ediabas.CallEdiabas | ( | Isom.Base.String | sgbd,
 |  | Isom.Base.String | jobName,
 |  | Isom.Base.String | jobParams
 | ) |  |

Statischer Aufruf eines EDIABAS-Jobs mit textbasierten Argumenten.

Zu beachten:
Es wird immer der Default-N-Kanal verwendet.
Parameter:
sgbd | Name der zu verwendenden Steuergerätebeschreibungsdatei.
jobName | Name des EDIABAS-Jobs.
jobParams | Eventuelle Parameter für diesen Job. Werden keine Parameter benötigt, ist eine leere Zeichenkette zu übergeben.
Rückgabe:
Liste der EDIABAS-ResultSets.
[Isom\Services\Ediabas.is: 81]
Isom.Services.EdiabasResultSetList Isom.Services.Ediabas.CallEdiabasBin | ( | Isom.Base.String | sgbd,
 |  | Isom.Base.String | jobName,
 |  | Isom.Base.String | jobParams
 | ) |  |

Statischer Aufruf eines EDIABAS-Jobs mit binären Argumenten (hex-codiert).

Zu beachten:
Es wird immer der Default-N-Kanal verwendet.
Parameter:
sgbd | Name der zu verwendenden Steuergerätebeschreibungsdatei.
jobName | Name des EDIABAS-Jobs.
jobParams | Eventuelle Parameter für diesen Job. Werden keine Parameter benötigt, sollte CallEdiabas() verwendet werden.
   using Isom.Base.*
   using Isom.Services.*;
   ...
      String sgbd   = "TMODE";
      String job    = "SETZE_SG_PARAMETER_ALLG";
      String params = "06 00 80 25 00 00 00 00 00 00 A0 0F C8 00 14 00 00 00 03 00";
      EdiabasResultSetList resultSetList = Ediabas.CallEdiabasBin (sgbd, job, params);
Rückgabe:
Liste der EDIABAS-ResultSets.
[Isom\Services\Ediabas.is: 108]
Isom.Base.Boolean Isom.Services.Ediabas.ResetTimeout ( )

Setzt den Timeout-Wert zurück.

Alle folgenden Aufrufe von CallEdiabas und CallEdiabasBin werden ohne Timeout durchgeführt.

   using Isom.Base.*
   using Isom.Services.*;
   ...
      Ediabas.SetTimeout( 10000 );
      EdiabasResultSetList resultSetList = Ediabas.CallEdiabas ("D_CAS", "IDENT", "");
      Ediabas.ResetTimeout();
Rückgabe:
Immer 'true'.
[Isom\Services\Ediabas.is: 158]
Isom.Base.Boolean Isom.Services.Ediabas.RetainSession ( Isom.Base.Boolean permanent )

Die Funktion 'RetainSession' bewirkt, dass die EDIABAS-Instanz nicht geschlossen wird, wenn permanent auf 'true' gesetzt wird.

Alle zukünftigen Ediabas-Jobs werden mit derselben Ediabas-Instanz durchgeführt. Dabei ist es unerheblich ob diese direkt (durch 'CallEdiabas' bzw. 'CallEdiabasBin') oder indirekt (also z.B. innerhalb 'CurrentVehicleContext.ReadOdometer()') aufgerufen werden.

Zu beachten:
Hinweis: Es ist nicht garantiert dass die EDIABAS-Instanz über die gesamte Sitzung geöffnet bleibt. So wird z.B. bei einem Baureihenwechsel (z.B. von 'Base' auf 'E60') ein neuer Fachdienst und damit auch eine neue EDIABAS-Instanz gestartet.
Parameter:
permanent Gibt an, ob die EDIABAS-Instanz permanent geöffnet bleiben soll oder ob EDIABAS jedes Mal neu initialisiert und beendet wird.
   using Isom.Base.*
   using Isom.Services.*;
   ...
      Ediabas.RetainSession( true );
      Ediabas.CallEdiabas ("mrkmsk16","seed_key","2");
      Ediabas.CallEdiabas ("mrkmsk16","steuern_fahrgestellnummer","WBAA0000001234567");
      Ediabas.CallEdiabas ("mrkmsk16","seed_key","1");
      Ediabas.RetainSession( false );
Rückgabe:
'true' im Erfolgsfall
[Isom\Services\Ediabas.is: 189]
Isom.Base.Boolean Isom.Services.Ediabas.SetTimeout ( Isom.Base.Number timeoutValue )

Setzt einen Timeout-Wert für die Ausführung des EDIABAS-Jobs.

Nach Ablauf dieser, in Millisekunden angegebenen, Zeitspanne wird versucht, den EDIABAS-Job abzubrechen. Der Wert darf nicht kleiner oder gleich '0' sein.

Zu beachten:
Der gesetzte Timeout gilt für alle folgenden Aufrufe von CallEdiabs und CallEdiabasBin. Daher muss anschließend der Timeout-Mechanismus mittels der Funktion 'ResetTimeout()' wieder deaktiviert werden.
Parameter:
timeoutValue Zeitdauer in Millisekunden
   using Isom.Base.*
   using Isom.Services.*;
   ...
   using Isom.Base.*
   using Isom.Services.*;
   ...
      // Setze den Timeout für EDIABAS-Aufrufe auf 10 Sekunden
      Ediabas.SetTimeout( 10000 );
      // Führe den EDIABAS-Aufruf aus
      EdiabasResultSetList resultSetList = Ediabas.CallEdiabas ("D_CAS", "IDENT", "");
      // Deaktiviere den Timeout-Mechanismus
      Ediabas.ResetTimeout();
Rückgabe:
'true' falls erfolgreich.
[Isom\Services\Ediabas.is: 139]


für Serviceautoren

Isom.Services.EdiabasResultSet

Namensraum Isom.Services.EdiabasResultSet

Ergebnisse bei EDIABAS-Job-Aufrufen als Tabelle Mehr...

Funktionen
Funktionen zum Zugriff auf die Tabellen

Funktionen zum Auslesen von Ergebnissen.

Isom.Base.String | Get(Isom.Base.String name)

Liefert das Ergebnis mit dem angegebenen Namen.

Isom.Base.StringDictionary | GetResults(Isom.Base.String filterRegex)

Liefert alle EDIABAS-Ergebnisse, deren Namen auf das angegebene Suchmuster passen.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Services.EdiabasResultSet | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Services.EdiabasResultSet | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Services.EdiabasResultSet legt die Ergebnisse von EDIABAS-Job-Aufrufen als Tabelle ab.

Quelldateien:

  • Isom\Services\EdiabasResultSet.is

Dokumentation der Funktionen

objectbound Isom.Services.EdiabasResultSet Isom.Services.EdiabasResultSet.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue EdiabasResultSet mit dem selben Inhalt.
[Isom\Services\EdiabasResultSet.is: 127]
objectbound Isom.Base.String Isom.Services.EdiabasResultSet.Get ( Isom.Base.String name )

Liefert das Ergebnis mit dem angegebenen Namen.

Parameter:
name Name des zu holenden Ergebnisses.
Rückgabe:
Wert des Ergebnisses.
[Isom\Services\EdiabasResultSet.is: 104]
objectbound Isom.Base.StringDictionary Isom.Services.EdiabasResultSet.GetResults ( Isom.Base.String filterRegex )

Liefert alle EDIABAS-Ergebnisse, deren Namen auf das angegebene Suchmuster passen.

Parameter:
filterRegex Regulärer Ausdruck der zu holenden Ergebnisse.
Rückgabe:
Die ausgewählten (Name,Wert)-Paare Werte des Ergebnisssatzes.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der übergebene reguläre Ausdruck Void oder ungültig ist.
   using Isom.Base.*
   ...
      EdiabasResultSet resultSet = ...;
      StringDictionary subResults = resultSet.GetResults("ID_.*");
      StringList keys = subResults.GetKeys();
      keys.Reset();
      while( keys.HasNext() )
      {
          String key = keys.Next();

          String msg = "EdiabasCallGetStatus[ '$key' ] = '$value'";
          msg.Replace( "$key", key );
          msg.Replace( "$value", subResults.Get( key ) );
          System.Stdout( msg );
      }
[Isom\Services\EdiabasResultSet.is: 95]
objectbound Isom.Base.Boolean Isom.Services.EdiabasResultSet.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Services\EdiabasResultSet.is: 119]
Isom.Services.EdiabasResultSet Isom.Services.EdiabasResultSet.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Services\EdiabasResultSet.is: 139]


für Serviceautoren

Isom.Services.EdiabasResultSetList

Namensraum Isom.Services.EdiabasResultSetList

Listen von EDIABAS-Ergebnismengen des Typs Isom.Services.EdiabasResultSet Mehr...

Funktionen
Funktionen zum Finden und Erhalten von Ergebnissen

Funktionen, die das Finden und Erhalten von Ergebnissen ermöglichen.

Isom.Base.String | FindResult(Isom.Base.String name)

Sucht in allen ResultSets nach dem angegebenen Ergebnis.

Isom.Services.EdiabasResultSet | GetResultSet(Isom.Base.Number index)

Hole einen bestimmten ResultSet.

Listenfunktionen

Isom.Base.Boolean | Contains(Isom.Services.EdiabasResultSet element)

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

Isom.Services.EdiabasResultSet | Current()

Liefert das aktuelle ResultSet.

Isom.Base.Boolean | HasNext()

Prüft, ob es beim Durchlaufen der Liste mit .Next() ResultSets gibt, die noch nicht abgerufen wurden.

Isom.Base.Boolean | IsEmpty()

Prüft, ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Services.EdiabasResultSet | Next()

Liefert beim Durchlaufen der Liste das nächste ResultSet.

Isom.Base.Boolean | Reset()

Setzt den Listeniterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Services.EdiabasResultSetList | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Services.EdiabasResultSetList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Services.EdiabasResultSetList sind Listen von EDIABAS-Ergebnismengen des Typs Isom.Services.EdiabasResultSet

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Services\EdiabasResultSetList.is

Dokumentation der Funktionen

objectbound Isom.Services.EdiabasResultSetList Isom.Services.EdiabasResultSetList.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue EDIABAS-ResultSetList mit demselben Inhalt.
[Isom\Services\EdiabasResultSetList.is: 262]
objectbound Isom.Base.Boolean Isom.Services.EdiabasResultSetList.Contains ( Isom.Services.EdiabasResultSet element )

Abfrage, ob ein bestimmtes Element in der Liste vorhanden ist.

      EdiabasResultSetList list = ...
      EdiabasResultSet set = ...
      Boolean result = list.Contains(set);
Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Services\EdiabasResultSetList.is: 240]
objectbound Isom.Services.EdiabasResultSet Isom.Services.EdiabasResultSetList.Current ( )

Liefert das aktuelle ResultSet.

      EdiabasResultSetList list = ...
      list.Reset();                                   // Listendurchlauf vorbereiten
      while (list.HasNext ())                         // Prüfen, ob es ein nächstes Element gibt
      {
        list.Next();                                  // Durchlauf weiterführen
        EdiabasResultSet current = list.Current();    // Element abrufen
        ...
      }
Rückgabe:
Aktuelles ResultSet oder ein Void-Objekt, falls der Iterator am Anfang der Liste steht.
[Isom\Services\EdiabasResultSetList.is: 204]
objectbound Isom.Base.String Isom.Services.EdiabasResultSetList.FindResult ( Isom.Base.String name )

Sucht in allen ResultSets nach dem angegebenen Ergebnis.

Wird kein Ergebnis gefunden, so wird ein Void-String Objekt zurückgeliefert. Es wird immer das erste Vorkommen des Ergebnisses geliefert. Ist das Ergebnis in mehreren ResultSets vorhanden und soll es aus einem späteren ResultSet geholt werden, so ist dies nur über die spezifische ResultSetTable möglich.

Parameter:
name Name des Ergebnisses
Rückgabe:
String mit dem Ergebnis. Alle Ergebnisse werden in den Typ String umgewandelt.
[Isom\Services\EdiabasResultSetList.is: 104]
objectbound Isom.Services.EdiabasResultSet Isom.Services.EdiabasResultSetList.GetResultSet ( Isom.Base.Number index )

Hole einen bestimmten ResultSet.

Parameter:
index Index des zu holenden ResultSets.
Rückgabe:
Ein EDIABAS-ResultSet, welches den Zugriff auf die einzelnen Ergebnisse ermöglicht.
[Isom\Services\EdiabasResultSetList.is: 88]
objectbound Isom.Base.Boolean Isom.Services.EdiabasResultSetList.HasNext ( )

Prüft, ob es beim Durchlaufen der Liste mit .Next() ResultSets gibt, die noch nicht abgerufen wurden.

      EdiabasResultSetList list = ...
      list.Reset();                               // Listendurchlauf vorbereiten
      while (list.HasNext ())                     // Prüfen, ob es ein nächstes Element gibt
      {
        EdiabasResultSet current = list.Next();   // Element abrufen und Durchlauf weiterführen
        ...
      }
Rückgabe:
'true', falls noch ResultSets in der Liste mit .Next() abgerufen werden können, 'false' sonst.
[Isom\Services\EdiabasResultSetList.is: 183]
objectbound Isom.Base.Boolean Isom.Services.EdiabasResultSetList.IsEmpty ( )

Prüft, ob diese Liste leer ist oder nicht.

      EdiabasResultSetList list = ...
      Boolean isEmpty = list.IsEmpty();
Rückgabe:
'true', falls die Liste leer ist, 'false' sonst.
[Isom\Services\EdiabasResultSetList.is: 139]
objectbound Isom.Base.Boolean Isom.Services.EdiabasResultSetList.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Services\EdiabasResultSetList.is: 254]
objectbound Isom.Base.Number Isom.Services.EdiabasResultSetList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

      EdiabasResultSetList list = ...
      Number length = list.Length();
Rückgabe:
Anzahl der Elemente.
[Isom\Services\EdiabasResultSetList.is: 125]
objectbound Isom.Services.EdiabasResultSet Isom.Services.EdiabasResultSetList.Next ( )

Liefert beim Durchlaufen der Liste das nächste ResultSet.

Ein Listendurchlauf wird mit .Reset() zurückgesetzt, um die Liste mit .Next() vom Listenanfang an durchlaufen zu können.

      EdiabasResultSetList list = ...
      list.Reset();                               // Listendurchlauf vorbereiten
      while (list.HasNext ())                     // Prüfen, ob es ein nächstes Element gibt
      {
        EdiabasResultSet current = list.Next();   // Element abrufen und Durchlauf weiterführen
        ...
      }
Rückgabe:
Nächstes Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Services\EdiabasResultSetList.is: 162]
objectbound Isom.Base.Boolean Isom.Services.EdiabasResultSetList.Reset ( )

Setzt den Listeniterator zurück.

      EdiabasResultSetList list = ...
      list.Reset();                               // Listendurchlauf vorbereiten
      while (list.HasNext ())                     // Prüfen, ob es ein nächstes Element gibt
      {
        EdiabasResultSet current = list.Next();   // Element abrufen und Durchlauf weiterführen
        ...
      }
Rückgabe:
Immer 'true'.
[Isom\Services\EdiabasResultSetList.is: 223]
Isom.Services.EdiabasResultSetList Isom.Services.EdiabasResultSetList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Services\EdiabasResultSetList.is: 274]


für Serviceautoren

Isom.Services.ServiceManager

Namensraum Isom.Services.ServiceManager

Fachobjekt für Informationen zum Fachdienstzugriff Mehr...

Funktionen
Isom.Services.ServiceManager | GetInstance()

Liefert die statische Instanz des Fachobjekts für den Fachdienstzugriff.

Isom.Base.Boolean | ResetServiceType()

Entfernt die letzte Fachdienstvorgabe.

Isom.Base.Boolean | SetPreferredService(Isom.Base.String service)

Setzen des für die Aktion bevorzugt zu verwendenden Fachdiensts.

Isom.Base.Boolean | SetServiceType(Isom.Base.String service)

Gibt einen Fachdienst vor, der verwendet werden soll.

Ausführliche Beschreibung

Isom.Services.ServiceManager ist das Fachobjekt für Informationen zum Fachdienstzugriff

Quelldateien:

  • Isom\Services\ServiceManager.is

Dokumentation der Funktionen

Isom.Services.ServiceManager Isom.Services.ServiceManager.GetInstance ( )

Liefert die statische Instanz des Fachobjekts für den Fachdienstzugriff.

   Isom.Services.ServiceManager sw = Isom.Services.ServiceManager.GetInstance();
Rückgabe:
statische Instanz für den Fachdienstzugriff
[Isom\Services\ServiceManager.is: 66]
objectbound Isom.Base.Boolean Isom.Services.ServiceManager.ResetServiceType ( )

Entfernt die letzte Fachdienstvorgabe.

Es wird die letzte Fachdienstvorgabe entfernt, die mit Isom.Services.ServiceManager.SetServiceType eingefügt wurde.

Zu beachten:
Jeder Aufruf von SetServiceType() speichert den zu verwendenden Fachdienst auf einem Stapel. Für jeden Aufruf von SetServiceType() muss ein Aufruf von ResetServiceType() erfolgen, um den aktuell verwendeten Fachdienst vom Stapel zu entfernen.
   Isom.Services.EdiabasResultSetList TreatmentForPrepareAndCallEdiabas(
      Isom.Base.String sgbd, Isom.Base.String job, Isom.Base.String params)
   {
      ...
      // Fachdienst Pollux per ServiceManager vorgeben
      Isom.Services.ServiceManager.GetInstance().SetServiceType("Pollux");

      // Eigentlicher EDIABAS-Aufruf
      Isom.Services.EdiabasResultSetList results = Isom.Services.Ediabas.CallEdiabas(sgbd, job, params);

      // Fachdienst zurücksetzen
      Isom.Services.ServiceManager.GetInstance().ResetServiceType();
      ...
      // Ergebnisse des Aufrufs zurückliefern
      return results;
   }
Rückgabe:
Immer 'true'
Siehe auch:
Isom.Services.ServiceManager.SetServiceType
[Isom\Services\ServiceManager.is: 138]
objectbound Isom.Base.Boolean Isom.Services.ServiceManager.SetPreferredService ( Isom.Base.String service )

Setzen des für die Aktion bevorzugt zu verwendenden Fachdiensts.

Falls der bevorzugte Fachdienst eine Fachdienstfunktion implementiert, wird der Fachdienst verwendet, auch wenn in der Fahrzeugbeschreibung ein Fachdienst mit höherer Priorität angegeben wurde.

   Isom.Services.ServiceManager mgr = Isom.Services.ServiceManager.GetInstance();
   mgr.SetPreferredService("FasttrackDirect");
   Isom.Context.CurrentVehicleContext cvc = Isom.Context.CurrentVehicleContext.GetInstance();
   Isom.Context.EcuList ecus = cvc.GetEcus();
   ecus.Reset();
   while( ecus.HasNext() )
   {
     Isom.Context.Ecu ecu = ecus.Next();
     if(ecu.ReadDtc().Failed())
     {
       //Fehlerbehandlung
     }
   }
   mgr.ResetServiceType();
Rückgabe:
Isom.Base.Boolean
Immer 'true'.
Datum:
letzte Änderung am 01.09.2010
[Isom\Services\ServiceManager.is: 176]
objectbound Isom.Base.Boolean Isom.Services.ServiceManager.SetServiceType ( Isom.Base.String service )

Gibt einen Fachdienst vor, der verwendet werden soll.

Der gesetzte Fachdienst wird verwendet bis diese Vorgabe mit Isom.Services.ServiceManager.ResetServiceType wieder entfernt wird.

Zu beachten:
Jeder Aufruf von SetServiceType() speichert den zu verwendenden Fachdienst auf einem Stapel. Für jeden Aufruf von SetServiceType() muss ein Aufruf von ResetServiceType() erfolgen, um den aktuell verwendeten Fachdienst vom Stapel zu entfernen.
   Isom.Services.EdiabasResultSetList TreatmentForPrepareAndCallEdiabas(
      Isom.Base.String sgbd, Isom.Base.String job, Isom.Base.String params)
   {
      ...
      // Fachdienst Pollux per ServiceManager vorgeben
      Isom.Services.ServiceManager.GetInstance().SetServiceType("Pollux");

      // Eigentlicher EDIABAS-Aufruf
      Isom.Services.EdiabasResultSetList results = Isom.Services.Ediabas.CallEdiabas(sgbd, job, params);

      // Fachdienst zurücksetzen
      Isom.Services.ServiceManager.GetInstance().ResetServiceType();
      ...
      // Ergebnisse des Aufrufs zurückliefern
      return results;
   }
Parameter:
service zu verwendender Fachdienst
Rückgabe:
Immer 'true'
Siehe auch:
Isom.Services.ServiceManager.ResetServiceType
[Isom\Services\ServiceManager.is: 103]


für Serviceautoren

Isom.Sys

Namensraum Isom.Sys

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Sys.CallProfile | Zugriff auf gemessene Zeiten ausgeführter Funktionen
Isom.Sys.ClientData | Informationen über einen beobachtenden oder steuernden Client.
Isom.Sys.ClientDataList | Listen aus Client-Informationen des Typs Isom.Sys.ClientData
Isom.Sys.Contract | Zugriff auf Vertragsinformationen innerhalb abgefragter Händlerdaten
Isom.Sys.ContractList | Liste von Vertragsinformationen des Typs Isom.Sys.Contract
Isom.Sys.Dealer | Zugriff auf Händlerinformationen
Isom.Sys.Error | Fehlerbeschreibungen
Isom.Sys.ErrorHistory | Zugriff auf die Fehlergeschichte.
Isom.Sys.ErrorList | Listen von Fehlerbeschreibungen des Typs Isom.Sys.Error
Isom.Sys.Events |
Isom.Sys.FunctionInfo | Zugriff auf die gemessene Zeiten aller Ausführungen einer Funktion
Isom.Sys.Log | Zugriff auf die Ereignisaufzeichung
Isom.Sys.Protocol | Erzeugung eines Sitzungsprotokoll der Therapiesitzung und Zugriff auf Protokollarchive.
Isom.Sys.RuntimeInfo | Zugriff auf gemessene Zeiten ausgeführter Funktionen
Isom.Sys.SessionContext | Fachobjekt für den Sitzungskontext
Isom.Sys.System | Zugriff auf allgemeine Systemressourcen
Isom.Sys.SystemInfo | Zugriff auf allgemeine Informationen über den Rechner und die Systemumgebung
Isom.Sys.VersionInfo | Informationen über die Versionskennung der Programmierapplikation


für Serviceautoren

Isom.Sys.CallProfile

Namensraum Isom.Sys.CallProfile

Zugriff auf gemessene Zeiten ausgeführter Funktionen Mehr...

Funktionen
Listenfunktionen

Isom.Sys.FunctionInfo | At(Isom.Base.Number index)

Ruft eine durch einen Index gekennzeichnete Element aus der Liste ab.

Isom.Base.Boolean | Contains(Isom.Sys.FunctionInfo element)

Abfrage, ob ein Element in der Liste vorhanden ist.

Isom.Sys.FunctionInfo | Current()

Liefert während des Durchlaufens der Liste das aktuelle Element.

Isom.Base.Boolean | HasNext()

Prüft, ob es beim Durchlaufen der Liste mit .Next() Elemente gibt, die noch nicht abgerufen wurden.

Isom.Base.Number | Insert(Isom.Sys.FunctionInfo element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Prüft, ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Sys.FunctionInfo | Next()

Liefert beim Durchlaufen der Liste das nächste Element.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt ein durch einen Index gekennzeichnetes Element aus der Liste.

Isom.Base.Boolean | Reset()

Setzt den Durchlauf-Iterator vor das erste Element der Liste, so ein neuer Durchlauf der Liste begonnen werden kann.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Sys.CallProfile | Clone()

Erzeugt eine identische Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.CallProfile | Void()

Erzeugt ein Void-Objekt.

Ausführliche Beschreibung

Isom.Sys.CallProfile ist der Zugriff auf gemessene Zeiten ausgeführter Funktionen als Liste von 'FunctionInfo'-Objekten

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Sys\CallProfile.is

Dokumentation der Funktionen

objectbound Isom.Sys.FunctionInfo Isom.Sys.CallProfile.At ( Isom.Base.Number index )

Ruft eine durch einen Index gekennzeichnete Element aus der Liste ab.

 CallProfile list = ...
 FunctionInfo a = list.At(0);
 FunctionInfo b = list.At(1);
Parameter:
index Index des abgerufenen Elements in der Liste, beginnend bei 0 für das erste Element.
Rückgabe:
Element an dem übergebenen Index.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 ist oder größer gleich der Anzahl der Listenelemente.
[Isom\Sys\CallProfile.is: 211]
objectbound Isom.Sys.CallProfile Isom.Sys.CallProfile.Clone ( )

Erzeugt eine identische Kopie dieses Objekts.

Dabei werden für alle enthaltenen Zeichenkettenobjekte ebenso Kopien erzeugt.

 StringList a = ...
 StringList b = a.Clone();
Rückgabe:
Kopie dieses Objekts.
[Isom\Sys\CallProfile.is: 319]
objectbound Isom.Base.Boolean Isom.Sys.CallProfile.Contains ( Isom.Sys.FunctionInfo element )

Abfrage, ob ein Element in der Liste vorhanden ist.

 FunctionInfo scp = ...
 CallProfile list = ...
 Boolean contains = list.Contains(scp);
Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Sys\CallProfile.is: 278]
objectbound Isom.Sys.FunctionInfo Isom.Sys.CallProfile.Current ( )

Liefert während des Durchlaufens der Liste das aktuelle Element.

 CallProfile list = ...
 list.Reset();                        // Listendurchlauf vorbereiten
 while (list.HasNext ())              // Prüfen, ob es ein nächstes Element gibt
 {
    list.Next();                      // Durchlauf weiterführen
    FunctionInfo current = list.Current();  // Element abrufen
    ...
 }
Rückgabe:
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Durchlauf-Iterator vor das erste Element der Liste zeigt.
[Isom\Sys\CallProfile.is: 172]
objectbound Isom.Base.Boolean Isom.Sys.CallProfile.HasNext ( )

Prüft, ob es beim Durchlaufen der Liste mit .Next() Elemente gibt, die noch nicht abgerufen wurden.

 CallProfile list = ...
 list.Reset();                        // Listendurchlauf vorbereiten
 while (list.HasNext ())              // Prüfen, ob es ein nächstes Element gibt
 {
    FunctionInfo current = list.Next();     // Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
'true', falls noch Elemente in der Liste mit .Next() abgerufen werden können, 'false' sonst.
[Isom\Sys\CallProfile.is: 128]
objectbound Isom.Base.Number Isom.Sys.CallProfile.Insert ( Isom.Sys.FunctionInfo element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Iterator, wird durch diese Operation zurückgesetzt.

 FunctionInfo scp = ...
 CallProfile list = ...
 list.Insert(scp);
Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügendes Element.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
[Isom\Sys\CallProfile.is: 240]
objectbound Isom.Base.Boolean Isom.Sys.CallProfile.IsEmpty ( )

Prüft, ob diese Liste leer ist oder nicht.

 CallProfile list = ...
 Boolean isEmpty = list.IsEmpty();
Rückgabe:
'true', falls die Liste leer ist, 'false' sonst.
[Isom\Sys\CallProfile.is: 108]
objectbound Isom.Base.Boolean Isom.Sys.CallProfile.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

 StringList a = ...
 if (a.IsVoid())
 {
    return false;
 }
Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\CallProfile.is: 305]
objectbound Isom.Base.Number Isom.Sys.CallProfile.Length ( )

Liefert die Anzahl der Elemente in der Liste.

 CallProfile list = ...
 Number length = list.Length();
Rückgabe:
Anzahl der Elemente.
[Isom\Sys\CallProfile.is: 95]
objectbound Isom.Sys.FunctionInfo Isom.Sys.CallProfile.Next ( )

Liefert beim Durchlaufen der Liste das nächste Element.

Ein Listendurchlauf wird mit .Reset() zurückgesetzt, um sie mit .Next() vom Listenanfang an durchlaufen zu können.

 CallProfile list = ...
 list.Reset();                        // Listendurchlauf vorbereiten
 while (list.HasNext ())              // Prüfen, ob es ein nächstes Element gibt
 {
    FunctionInfo current = list.Next();     // Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Nächstes Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Sys\CallProfile.is: 150]
objectbound Isom.Base.Boolean Isom.Sys.CallProfile.Remove ( Isom.Base.Number index )

Entfernt ein durch einen Index gekennzeichnetes Element aus der Liste.

Ein eventuell aktiver Durchlauf-Iterator, wird durch diese Operation zurückgesetzt.

Parameter:
index Index des zu entfernenden Elements in der Liste, beginnend bei 0 für das erste Element.
 FunctionInfo scp = ...
 CallProfile list = ...
 Boolean result = list.Remove(scp);
Rückgabe:
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt).
[Isom\Sys\CallProfile.is: 261]
objectbound Isom.Base.Boolean Isom.Sys.CallProfile.Reset ( )

Setzt den Durchlauf-Iterator vor das erste Element der Liste, so ein neuer Durchlauf der Liste begonnen werden kann.

 CallProfile list = ...
 list.Reset();                        // Listendurchlauf vorbereiten
 while (list.HasNext ())              // Prüfen, ob es ein nächstes Element gibt
 {
    FunctionInfo current = list.Next();     // Element abrufen und Durchlauf weiterführen
    ...
 }
Rückgabe:
Immer 'true'.
[Isom\Sys\CallProfile.is: 191]
Isom.Sys.CallProfile Isom.Sys.CallProfile.Void ( )

Erzeugt ein Void-Objekt.

Das erzeugte Void-Objekt kann z. B. in Funktionen zurückgegeben werden, um einen Fehler anzuzeigen.

 StringList f()
 {
    ...
    if (error)
      return StringList.Void();
    ...
 }
Rückgabe:
Void-Objekt
[Isom\Sys\CallProfile.is: 339]


für Serviceautoren

Isom.Sys.ClientData

Namensraum Isom.Sys.ClientData

Informationen über einen beobachtenden oder steuernden Client. Mehr...

Funktionen
Isom.Sys.ClientData | Create()

Erzeugt ein Objekt des Typs ClientData.

Fachoperationen

Funktionen zum Auslesen von Informationen.

Isom.Base.Boolean | GetIsControlling()

Gibt zurück, ob dieser Client die Sitzung steuert.

Isom.Base.String | GetName()

Gibt den Namen des Clients zurück.

Isom.Base.String | GetRole()

Gibt die Rolle des Client zurück.

Isom.Base.StringDictionary | GetSettings()

Gibt die Konfiguration des Clients zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Sys.ClientData | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.ClientData | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.ClientData enthält Informationen über einen beobachtenden oder steuernden Client.

Quelldateien:

  • Isom\Sys\ClientData.is

Dokumentation der Funktionen

objectbound Isom.Sys.ClientData Isom.Sys.ClientData.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Sys\ClientData.is: 151]
Isom.Sys.ClientData Isom.Sys.ClientData.Create ( )

Erzeugt ein Objekt des Typs ClientData.

Rückgabe:
Das Objekt.
[Isom\Sys\ClientData.is: 76]
objectbound Isom.Base.Boolean Isom.Sys.ClientData.GetIsControlling ( )

Gibt zurück, ob dieser Client die Sitzung steuert.

Rückgabe:
'true', falls der Client die Sitzung steuert, 'false' sonst.
[Isom\Sys\ClientData.is: 124]
objectbound Isom.Base.String Isom.Sys.ClientData.GetName ( )

Gibt den Namen des Clients zurück.

Rückgabe:
Der Name.
[Isom\Sys\ClientData.is: 92]
objectbound Isom.Base.String Isom.Sys.ClientData.GetRole ( )

Gibt die Rolle des Client zurück.

Rückgabe:
Die Rolle (Controller, SessionObserver, ClientObserver).
[Isom\Sys\ClientData.is: 100]
objectbound Isom.Base.StringDictionary Isom.Sys.ClientData.GetSettings ( )

Gibt die Konfiguration des Clients zurück.

Die Konfiguration besteht aus einem Wörterbuch, das eine Reihe von Einstellungen des Clients dokumentiert. Das vollständige Wörterbuch (Schlüssel und Werte) wird vom Client erzeugt und von ISOM unverändert weitergegeben. Die Konfiguration ist dafür vorgesehen, die Einstellungen des Clients im Sitzungsprotokoll zu dokumentieren.

Rückgabe:
Die Konfiguration.
[Isom\Sys\ClientData.is: 115]
objectbound Isom.Base.Boolean Isom.Sys.ClientData.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\ClientData.is: 143]
Isom.Sys.ClientData Isom.Sys.ClientData.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\ClientData.is: 162]


für Serviceautoren

Isom.Sys.ClientDataList

Namensraum Isom.Sys.ClientDataList

Listen aus Client-Informationen des Typs Isom.Sys.ClientData Mehr...

Funktionen
Isom.Sys.ClientDataList | CreateClientDataList()

Erzeugt ein Objekt vom Typ ClientDataList.

Listenfunktionen

Isom.Sys.ClientData | At(Isom.Base.Number index)

Ruft das Element innerhalb der Liste ab, das durch den Index ausgewählt wurde.

Isom.Base.Boolean | Contains(Isom.Sys.ClientData target)

Fragt ab, ob ein bestimmtes Element in der Liste vorhanden ist.

Isom.Sys.ClientData | Current()

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Isom.Base.Boolean | HasNext()

Liefert einen Wahrheitswert, der angibt, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Isom.Base.Number | Insert(Isom.Sys.ClientData element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Liefert einen Wahrheitswert, der angibt ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Sys.ClientData | Next()

Liefert den nächsten Eintrag in der Liste.

Isom.Base.Boolean | Remove(Isom.Base.Number index)

Entfernt das durch den Index gekennzeichnete Element aus der Liste.

Isom.Base.Boolean | Reset()

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Sys.ClientDataList | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.ClientDataList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.ClientDataList sind Listen aus Client-Informationen des Typs Isom.Sys.ClientData

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Sys\ClientDataList.is

Dokumentation der Funktionen

objectbound Isom.Sys.ClientData Isom.Sys.ClientDataList.At ( Isom.Base.Number index )

Ruft das Element innerhalb der Liste ab, das durch den Index ausgewählt wurde.

Parameter:
index Index.
Rückgabe:
Ausgewähltes Element.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 ist oder größer gleich der Anzahl der Listenelemente.
[Isom\Sys\ClientDataList.is: 169]
objectbound Isom.Sys.ClientDataList Isom.Sys.ClientDataList.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
[Isom\Sys\ClientDataList.is: 244]
objectbound Isom.Base.Boolean Isom.Sys.ClientDataList.Contains ( Isom.Sys.ClientData target )

Fragt ab, ob ein bestimmtes Element in der Liste vorhanden ist.

Parameter:
target Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Sys\ClientDataList.is: 217]
Isom.Sys.ClientDataList Isom.Sys.ClientDataList.CreateClientDataList ( )

Erzeugt ein Objekt vom Typ ClientDataList.

Rückgabe:
Das Objekt.
[Isom\Sys\ClientDataList.is: 87]
objectbound Isom.Sys.ClientData Isom.Sys.ClientDataList.Current ( )

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Rückgabe:
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Iterator zurückgesetzt wurde.
[Isom\Sys\ClientDataList.is: 146]
objectbound Isom.Base.Boolean Isom.Sys.ClientDataList.HasNext ( )

Liefert einen Wahrheitswert, der angibt, ob beim Iterieren über die Liste noch Werte abgerufen werden können.

Rückgabe:
'true', falls noch Werte in der Liste zur Verfügung stehen, 'false' sonst.
[Isom\Sys\ClientDataList.is: 135]
objectbound Isom.Base.Number Isom.Sys.ClientDataList.Insert ( Isom.Sys.ClientData element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Iterator, wird durch diese Operation zurückgesetzt.

Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügendes Element.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
[Isom\Sys\ClientDataList.is: 192]
objectbound Isom.Base.Boolean Isom.Sys.ClientDataList.IsEmpty ( )

Liefert einen Wahrheitswert, der angibt ob diese Liste leer ist oder nicht.

Rückgabe:
'true', falls die Liste leer ist, 'false' sonst.
[Isom\Sys\ClientDataList.is: 113]
objectbound Isom.Base.Boolean Isom.Sys.ClientDataList.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\ClientDataList.is: 236]
objectbound Isom.Base.Number Isom.Sys.ClientDataList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

Rückgabe:
Anzahl der Elemente.
[Isom\Sys\ClientDataList.is: 104]
objectbound Isom.Sys.ClientData Isom.Sys.ClientDataList.Next ( )

Liefert den nächsten Eintrag in der Liste.

Diese Funktion sollte zum Iterieren über die Liste verwendet werden.

Rückgabe:
Nächstes Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Sys\ClientDataList.is: 125]
objectbound Isom.Base.Boolean Isom.Sys.ClientDataList.Remove ( Isom.Base.Number index )

Entfernt das durch den Index gekennzeichnete Element aus der Liste.

Ein eventuell aktiver Iterator wird durch diese Operation zurückgesetzt.

Parameter:
index Index.
Rückgabe:
'true', falls das Element entfernt werden konnte, 'false' sonst (z.B. wenn der Index das Void-Objekt ist oder außerhalb des zulässigen Bereichs liegt).
[Isom\Sys\ClientDataList.is: 206]
objectbound Isom.Base.Boolean Isom.Sys.ClientDataList.Reset ( )

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Rückgabe:
Immer 'true'.
[Isom\Sys\ClientDataList.is: 155]
Isom.Sys.ClientDataList Isom.Sys.ClientDataList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\ClientDataList.is: 255]


für Serviceautoren

Isom.Sys.Contract

Namensraum Isom.Sys.Contract

Zugriff auf Vertragsinformationen innerhalb abgefragter Händlerdaten Mehr...

Funktionen
Getter

Funktionen, die das Auslesen von Informationen ermöglichen.

Isom.Base.String | GetBrand()

Abfrage der Marke

Isom.Base.String | GetContractType()

Abfrage des Vertragtyps

Isom.Base.Date | GetEndContractDate()

Abfrage des Vertragsendes

Isom.Base.Number | GetInternationalDealerNumber()

Abfrage der vertragsbezogenen Händlernummer

Isom.Base.String | GetProduct()

Abfrage des Produkts

Isom.Base.Date | GetStartDate()

Abfrage des Vertragsbeginns

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Sys.Contract | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Sys.Contract | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.Contract gewährt Zugriff auf Vertragsinformationen innerhalb abgefragter Händlerdaten.

Quelldateien:

  • Isom\Sys\Contract.is

Dokumentation der Funktionen

objectbound Isom.Sys.Contract Isom.Sys.Contract.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue Contract mit demselben Inhalt.
[Isom\Sys\Contract.is: 146]
objectbound Isom.Base.String Isom.Sys.Contract.GetBrand ( )

Abfrage der Marke

Rückgabe:
Marke
[Isom\Sys\Contract.is: 76]
objectbound Isom.Base.String Isom.Sys.Contract.GetContractType ( )

Abfrage des Vertragtyps

Rückgabe:
Vertragstyp falls vorhanden, nichts sonst
[Isom\Sys\Contract.is: 121]
objectbound Isom.Base.Date Isom.Sys.Contract.GetEndContractDate ( )

Abfrage des Vertragsendes

Rückgabe:
Vertragsende
[Isom\Sys\Contract.is: 112]
objectbound Isom.Base.Number Isom.Sys.Contract.GetInternationalDealerNumber ( )

Abfrage der vertragsbezogenen Händlernummer

Rückgabe:
vertragsbezogene Händlernummer
[Isom\Sys\Contract.is: 94]
objectbound Isom.Base.String Isom.Sys.Contract.GetProduct ( )

Abfrage des Produkts

Rückgabe:
Produkt
[Isom\Sys\Contract.is: 85]
objectbound Isom.Base.Date Isom.Sys.Contract.GetStartDate ( )

Abfrage des Vertragsbeginns

Rückgabe:
Vertragsbeginn
[Isom\Sys\Contract.is: 103]
objectbound Isom.Base.Boolean Isom.Sys.Contract.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Sys\Contract.is: 137]
Isom.Sys.Contract Isom.Sys.Contract.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\Contract.is: 158]


für Serviceautoren

Isom.Sys.ContractList

Namensraum Isom.Sys.ContractList

Liste von Vertragsinformationen des Typs Isom.Sys.Contract Mehr...

Funktionen
Funktion zur Erzeugung einer neuen, leeren Vertragsliste

Erzeugt eine neue, leere Vertragsliste.

Isom.Sys.ContractList | CreateContractList()

Erzeugt eine neue, leere Liste.

Listenfunktionen

Isom.Base.Boolean | Contains(Isom.Sys.Contract element)

Abfrage, ob ein Vertragselement in der Liste vorhanden ist.

Isom.Sys.Contract | Current()

Liefert das aktuelle Vertragselement.

Isom.Base.Boolean | HasNext()

Bestimmt, ob noch weitere Vertragselemente in der Liste vorhanden sind.

Isom.Base.Number | Insert(Isom.Sys.Contract element)

Fügt der Liste ein Element hinzu.

Isom.Base.Boolean | IsEmpty()

Prüft, ob die Liste Elemente enthält.

Isom.Base.Number | Length()

Liefert die Anzahl der Vertragselemente in der Liste.

Isom.Sys.Contract | Next()

Liefert das nächste Vertragselement.

Isom.Base.Boolean | Reset()

Setzt den Listeniterator zurück.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Sys.ContractList | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Sys.ContractList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.ContractList repräsentiert Listen von Verträgen (Isom.Sys.Contract)

Zu beachten:
Bei dieser Listeart gibt es nur eine Möglichkeit, um auf die Elemente in der Liste zuzugreifen:
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.

Quelldateien:

  • Isom\Sys\ContractList.is

Dokumentation der Funktionen

objectbound Isom.Sys.ContractList Isom.Sys.ContractList.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue ContractList mit demselben Inhalt.
[Isom\Sys\ContractList.is: 218]
objectbound Isom.Base.Boolean Isom.Sys.ContractList.Contains ( Isom.Sys.Contract element )

Abfrage, ob ein Vertragselement in der Liste vorhanden ist.

Parameter:
element Gesuchtes Element.
Rückgabe:
'true', falls das Element gefunden werden konnte, 'false' sonst.
[Isom\Sys\ContractList.is: 163]
Isom.Sys.ContractList Isom.Sys.ContractList.CreateContractList ( )

Erzeugt eine neue, leere Liste.

 ContractList list = ContractList.CreateContractList();
Rückgabe:
Leere Liste.
[Isom\Sys\ContractList.is: 93]
objectbound Isom.Sys.Contract Isom.Sys.ContractList.Current ( )

Liefert das aktuelle Vertragselement.

Rückgabe:
Aktuelles Vertragselement oder ein Void-Objekt, falls der Iterator am Anfang der Liste steht.
[Isom\Sys\ContractList.is: 144]
objectbound Isom.Base.Boolean Isom.Sys.ContractList.HasNext ( )

Bestimmt, ob noch weitere Vertragselemente in der Liste vorhanden sind.

Rückgabe:
'true', falls weitere Vertragselemente vorhanden sind, 'false' sonst.
[Isom\Sys\ContractList.is: 135]
objectbound Isom.Base.Number Isom.Sys.ContractList.Insert ( Isom.Sys.Contract element )

Fügt der Liste ein Element hinzu.

Das Element wird an der letzten Position der Liste eingefügt. Ein eventuell aktiver Iterator, wird durch diese Operation zurückgesetzt.

 Contract contract = ...
 ContractList list = ContractList.CreateNumberList();
 list.Insert(contract);
Zu beachten:
Der zurückgegebene Index des eingefügten Elements ist nur gültig, solange kein Element an einer Position mit einem kleineren Index aus der Liste entfernt wird.
Parameter:
element Hinzuzufügender Vertrag.
Rückgabe:
Isom.Base.Number
Aktueller Index des eingefügten Elements in der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls das Element nicht hinzugefügt werden konnte.
[Isom\Sys\ContractList.is: 192]
objectbound Isom.Base.Boolean Isom.Sys.ContractList.IsEmpty ( )

Prüft, ob die Liste Elemente enthält.

Rückgabe:
'true', falls keine Vertragselemente vorhanden sind, 'false' sonst.
[Isom\Sys\ContractList.is: 116]
objectbound Isom.Base.Boolean Isom.Sys.ContractList.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Sys\ContractList.is: 210]
objectbound Isom.Base.Number Isom.Sys.ContractList.Length ( )

Liefert die Anzahl der Vertragselemente in der Liste.

Rückgabe:
Anzahl der Vertragselemente.
[Isom\Sys\ContractList.is: 108]
objectbound Isom.Sys.Contract Isom.Sys.ContractList.Next ( )

Liefert das nächste Vertragselement.

Rückgabe:
Nächstes Vertragselement in der Liste oder ein Void-Objekt, falls der Iterator auf dem letzten Objekt der Liste steht.
[Isom\Sys\ContractList.is: 125]
objectbound Isom.Base.Boolean Isom.Sys.ContractList.Reset ( )

Setzt den Listeniterator zurück.

Rückgabe:
Immer 'true'.
[Isom\Sys\ContractList.is: 152]
Isom.Sys.ContractList Isom.Sys.ContractList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\ContractList.is: 230]


für Serviceautoren

Isom.Sys.Dealer

Namensraum Isom.Sys.Dealer

Zugriff auf Händlerinformationen Mehr...

Funktionen
Elementoperationen

Funktionen zum Auslesen von Informationen.

Isom.Base.String | GetBusinessRelationship()

Abfrage des Vertragsverhältnisses

Isom.Sys.ContractList | GetContractList()

Abfrage einer Liste mit allen Vertragsinformationen

Isom.Base.Number | GetDistributionPartnerNumber()

Abfrage der Händlernummer

Isom.Base.Boolean | IsAdmissible(Isom.Base.String brand, Isom.Base.String product)

Abfrage, ob für ein Fahrzeug (spezifiziert durch Marke ("brand") und Produkt ("product")) ein Vertrag vorhanden ist und das Fahrzeug behandelt werden darf.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Sys.Dealer | Clone()

Erzeugt eine Kopie dieses Objekts.

Isom.Base.Boolean | IsVoid()

Prüft, ob es sich um das Void-Objekt handelt.

Isom.Sys.Dealer | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.Dealer gewährt Zugriff auf Händlerinformationen

Quelldateien:

  • Isom\Sys\Dealer.is

Dokumentation der Funktionen

objectbound Isom.Sys.Dealer Isom.Sys.Dealer.Clone ( )

Erzeugt eine Kopie dieses Objekts.

Rückgabe:
Neue Dealer mit demselben Inhalt.
[Isom\Sys\Dealer.is: 125]
objectbound Isom.Base.String Isom.Sys.Dealer.GetBusinessRelationship ( )

Abfrage des Vertragsverhältnisses

Rückgabe:
Vertragsverhältnis
[Isom\Sys\Dealer.is: 80]
objectbound Isom.Sys.ContractList Isom.Sys.Dealer.GetContractList ( )

Abfrage einer Liste mit allen Vertragsinformationen

Rückgabe:
Liste mit Vertragsinformationen
[Isom\Sys\Dealer.is: 89]
objectbound Isom.Base.Number Isom.Sys.Dealer.GetDistributionPartnerNumber ( )

Abfrage der Händlernummer

Rückgabe:
Händlernummer
[Isom\Sys\Dealer.is: 71]
objectbound Isom.Base.Boolean Isom.Sys.Dealer.IsAdmissible | ( | Isom.Base.String | brand,
 |  | Isom.Base.String | product
 | ) |  |

Abfrage, ob für ein Fahrzeug (spezifiziert durch Marke ("brand") und Produkt ("product")) ein Vertrag vorhanden ist und das Fahrzeug behandelt werden darf.

Rückgabe:
true, falls das Fahrzeug behandelt werden darf, false sonst
[Isom\Sys\Dealer.is: 99]
objectbound Isom.Base.Boolean Isom.Sys.Dealer.IsVoid ( )

Prüft, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls das Objekt Void ist, 'false' sonst.
[Isom\Sys\Dealer.is: 115]
Isom.Sys.Dealer Isom.Sys.Dealer.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\Dealer.is: 137]


für Serviceautoren

Isom.Sys.Error

Namensraum Isom.Sys.Error

Fehlerbeschreibungen Mehr...

Funktionen
Elementoperationen

Funktionen zum Festellen und Auslesen von Fehlern

Isom.Base.Boolean | Add(Isom.Base.String errorName, Isom.Base.String errorMessage)

Signalisiert dem ausführenden Faden einen fachlichen Fehler, der durch seine textuelle Bezeichnung identifiziert wird.

Isom.Plan.TherapyPlanAction | GetAction()

Ruft die Therapieplanaktion ab, in dessen Zusammenhang der Fehler aufgetreten ist.

Isom.Base.String | GetDescription()

Liefert die Beschreibung des Fehlers.

Isom.Context.Ecu | GetEcu()

Ruft das Steuergerät ab, in dessen Zusammenhang der Fehler aufgetreten ist.

Isom.Base.String | GetErrorText()

Ruft eine textuelle Beschreibung des Fehlers ab.

Isom.Base.Number | GetErrorValue()

Ruft den numerischen Wert des Fehlers ab.

Isom.Base.String | GetFullName()

Ruft den vollqualifizierten Bezeichner des Fehlers ab.

Isom.Base.Boolean | Notify(Isom.Base.String errorName, Isom.Base.String errorMessage)

Signalisiert dem Ablaufsystem einen fachlichen Fehler, der durch seine textuelle Bezeichnung identifiziert wird.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.Error | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.Error dient der Fehlerbeschreibung.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Sys\Error.is

Dokumentation der Funktionen

Isom.Base.Boolean Isom.Sys.Error.Add | ( | Isom.Base.String | errorName,
 |  | Isom.Base.String | errorMessage
 | ) |  |

Signalisiert dem ausführenden Faden einen fachlichen Fehler, der durch seine textuelle Bezeichnung identifiziert wird.

   using Isom.Sys.Error;
   ...
   // Innerhalb der Auswertung von aktualisierten Umgebungsinformationen
   // ...
   Error.Add("Voltage.Low", "Spannungsunterlauf");
Parameter:
errorName | Bezeichnung des Fehlers. Diese kann nach den gleichen Kriterien angegeben werden wie in ErrorList.Find(), d.h. vollqualifiziert, teilqualifiziert oder auch ohne Qualifikation. Die Bezeichnung muss den Fehler systemweit eindeutig identifizieren.
errorMessage | : Hinweistext zum Fehler
Rückgabe:
'true' wenn der Fehler signalisiert wurde, 'false' wenn der Fehler nicht signalisiert wurde, da die Identifikation nicht existierte oder nicht eindeutig war.
[Isom\Sys\Error.is: 140]
objectbound Isom.Plan.TherapyPlanAction Isom.Sys.Error.GetAction ( )

Ruft die Therapieplanaktion ab, in dessen Zusammenhang der Fehler aufgetreten ist.

Rückgabe:
Therapieplanaktion
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Fehler nicht in Zusammenhang mit einer Therapieplanaktion steht
[Isom\Sys\Error.is: 107]
objectbound Isom.Base.String Isom.Sys.Error.GetDescription ( )

Liefert die Beschreibung des Fehlers.

Rückgabe:
Die Beschreibung des Fehlers.
[Isom\Sys\Error.is: 172]
objectbound Isom.Context.Ecu Isom.Sys.Error.GetEcu ( )

Ruft das Steuergerät ab, in dessen Zusammenhang der Fehler aufgetreten ist.

Rückgabe:
Steuergerät
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Fehler nicht in Zusammenhang mit einem Steuergerät steht
[Isom\Sys\Error.is: 96]
objectbound Isom.Base.String Isom.Sys.Error.GetErrorText ( )

Ruft eine textuelle Beschreibung des Fehlers ab.

Rückgabe:
Eine textuelle Beschreibung des Fehlers oder der leere String, wenn keine textuelle Beschreibung vorliegt.
[Isom\Sys\Error.is: 85]
objectbound Isom.Base.Number Isom.Sys.Error.GetErrorValue ( )

Ruft den numerischen Wert des Fehlers ab.

Rückgabe:
Den numerischen Wert des Fehlers.
[Isom\Sys\Error.is: 77]
objectbound Isom.Base.String Isom.Sys.Error.GetFullName ( )

Ruft den vollqualifizierten Bezeichner des Fehlers ab.

Rückgabe:
vollqualifizierter Bezeichner des Fehlers
[Isom\Sys\Error.is: 115]
objectbound Isom.Base.Boolean Isom.Sys.Error.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\Error.is: 188]
Isom.Base.Boolean Isom.Sys.Error.Notify | ( | Isom.Base.String | errorName,
 |  | Isom.Base.String | errorMessage
 | ) |  |

Signalisiert dem Ablaufsystem einen fachlichen Fehler, der durch seine textuelle Bezeichnung identifiziert wird.

   using Isom.Sys.Error;
   ...
   // Innerhalb der Auswertung von aktualisierten Umgebungsinformationen
   // ...
   Error.Notify("Voltage.Low", "Spannungsunterlauf");
Parameter:
errorName | Bezeichnung des Fehlers. Diese kann nach den gleichen Kriterien angegeben werden wie in ErrorList.Find(), d.h. vollqualifiziert, teilqualifiziert oder auch ohne Qualifikation. Die Bezeichnung muss den Fehler systemweit eindeutig identifizieren.
errorMessage | : Hinweistext zum Fehler
Rückgabe:
'true' wenn der Fehler signalisiert wurde, 'false' wenn der Fehler nicht signalisiert wurde, da die Identifikation nicht existierte oder nicht eindeutig war.
[Isom\Sys\Error.is: 164]
Isom.Sys.Error Isom.Sys.Error.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\Error.is: 199]


für Serviceautoren

Isom.Sys.ErrorHistory

Namensraum Isom.Sys.ErrorHistory

Zugriff auf die Fehlergeschichte. Mehr...

Funktionen
Elementoperationen

Funktionen zum Auslesen und Löschen der Fehlergeschichte.

Isom.Sys.ErrorList | CatchLastErrors()

Ruft die Liste von Fehlern ab, die während der Ausführung der vorherigen Anweisung oder des vorherigen Blocks aufgetreten sind.

Isom.Base.Boolean | Clear()

Löscht die gesamte Fehlergeschichte.

Isom.Sys.ErrorList | GetAllErrors()

Ruft die Liste von Fehlern ab, die seit dem letzten Aufruf von Clear() registriert wurden.

Isom.Sys.ErrorList | GetLastErrors()

Ruft die Liste von Fehlern ab, die während der Ausführung der vorherigen Anweisung oder des vorherigen Blocks aufgetreten sind.

Ausführliche Beschreibung

Isom.Sys.ErrorHistory liefert Zugriff auf die Fehlergeschichte

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Sys\ErrorHistory.is

Dokumentation der Funktionen

Isom.Sys.ErrorList Isom.Sys.ErrorHistory.CatchLastErrors ( )

Ruft die Liste von Fehlern ab, die während der Ausführung der vorherigen Anweisung oder des vorherigen Blocks aufgetreten sind.

Die abgerufenen Fehler werden gelöscht, d.h. die abgerufenen Fehler können kein zweites Mal mit GetLastErrors() oder CatchLastErrors() abgerufen werden. Falls die abgerufenen Fehler nicht gelöscht werden sollen, muss die Funktion GetLastErrors() benutzt werden.

CatchLastErrors() löscht keine Einträge aus der Liste jemals aufgetretener Fehler, die mit GetAllErrors() abgerufen werden kann.

Die vorherige Anweisung, ebenso wie jede Anweisung in einem Block, kann dabei sowohl eine Funktion der ISOM-Fachbibliothek als auch eine Hilfsfunktionen, die in ISOM/L definiert ist, sein.

Reine Variablendeklarationen werden ignoriert. Ist der Aufruf von CatchLastErrors() der erste innerhalb eines Blocks, so bezieht sich die Abfrage auf

  • die Bedingung innerhalb der übergeordneten if-Anweisung
  • die Bedingung innerhalb der übergeordneten while-Anweisung
  • das Muster innerhalb der übergeordneten switch-Anweisung

   using Isom.Context.*;
   using Isom.Sys.*;
   ...

   Boolean ShowCatchLastErrorsUsage()
   {
     // Abfragen und Löschen aller Fehler, die bei der Ausführung von
     // anEcu.Identify().Failed() auftreten
     if (anEcu.Identify().Failed())
     {
       ErrorList errors = ErrorHistory.CatchLastErrors();
       ...
     }
     ...
     ...
     // stattdessen kann auch die unten definierte ISOM/L-Hilfsfunktion aufgerufen werden
     if (HelperIdentifyEcu(enEcu).Failed())
     {
       // enthält alle Fehler, die während der Ausführung von HelperIdentifyEcu(ecu).Failed()
       // aufgetreten sind und die noch nicht mittels CatchLastErrors() bereits innerhalb
       // von HelperIdentifyEcu(enEcu) abgefragt wurden
       ErrorList errors = ErrorHistory.CatchLastErrors();
     }

     // auch syntakisch möglich:
     if (anEcu.Identify().Failed().Not())
     {
       ...
     }
     else
     {
       ErrorList errors = ErrorHistory.CatchLastErrors();
       ...
     }
   }

   Boolean HelperIdentifyEcu(Ecu ecu)
   {
     if (ecu.Identify().Failed())
     {
       // enthält alle Fehler, die bei der Ausführung von ecu.Identify().Failed()
       // aufgetreten sind
       ErrorList errors = ErrorHistory.CatchLastErrors();

       // Versuche erneut, z.B. mit EDIABAS-Jobs
       {
         // Stattdessen könnten auch weitere ISOM/L-Hilfsfunktionen benutzt werden
         EdiabasResultSetList results1 = Ediabas.CallEdiabas(...);
         EdiabasResultSetList results2 = Ediabas.CallEdiabas(...);
       }

       // Abfrage aller Fehler, die während der Ausführung des vorherigen Blocks
       // von Ediabas-Aufrufen aufgetreten sind
       ErrorList ediabasErrors = ErrorHistory.CatchLastErrors();

       // Bewerte zweiten Versuch
       ...
       return secondAttemptSuccessul;
     }

     return true;
   }
Rückgabe:
Liste der aufgetretenen Fehler.
[Isom\Sys\ErrorHistory.is: 243]
Isom.Base.Boolean Isom.Sys.ErrorHistory.Clear ( )

Löscht die gesamte Fehlergeschichte.

Rückgabe:
Immer 'true'.
[Isom\Sys\ErrorHistory.is: 259]
Isom.Sys.ErrorList Isom.Sys.ErrorHistory.GetAllErrors ( )

Ruft die Liste von Fehlern ab, die seit dem letzten Aufruf von Clear() registriert wurden.

Rückgabe:
die gesamte Fehlergeschichte.
[Isom\Sys\ErrorHistory.is: 251]
Isom.Sys.ErrorList Isom.Sys.ErrorHistory.GetLastErrors ( )

Ruft die Liste von Fehlern ab, die während der Ausführung der vorherigen Anweisung oder des vorherigen Blocks aufgetreten sind.

Die abgerufenen Fehler werden nicht gelöscht. Weitere Aufrufe von GetLastErrors() oder CatchLastErrors() können die abgerufenen Fehler erneut liefern. Wenn die Fehler gelöscht werden sollen, muss CatchLastErrors() benutzt werden.

Die vorherige Anweisung, ebenso wie jede Anweisung in einem Block, kann dabei sowohl eine Funktion der ISOM-Fachbibliothek als auch eine Hilfsfunktionen, die in ISOM/L definiert ist, sein.

Reine Variablendeklarationen werden ignoriert. Ist der Aufruf von GetLastErrors() der erste innerhalb eines Blocks, so bezieht sich die Abfrage auf

  • die Bedingung innerhalb der übergeordneten if-Anweisung
  • die Bedingung innerhalb der übergeordneten while-Anweisung
  • das Muster innerhalb der übergeordneten switch-Anweisung

   using Isom.Context.*;
   using Isom.Sys.*;
   ...

   Boolean ShowGetLastErrorsUsage()
   {
     // Abfrage aller Fehler, die bei der Ausführung von anEcu.Identify().Failed() auftreten
     if (anEcu.Identify().Failed())
     {
       ErrorList errors = ErrorHistory.GetLastErrors();
       ...
     }
     ...
     // stattdessen kann auch die unten definierte ISOM/L-Hilfsfunktion aufgerufen werden
     if (HelperIdentifyEcu(enEcu).Failed())
     {
       // enthält alle Fehler, die während der Ausführung von HelperIdentifyEcu(ecu).Failed()
       // aufgetreten sind
       ErrorList errors = ErrorHistory.GetLastErrors();
     }

     // auch syntakisch möglich:
     if (anEcu.Identify().Failed().Not())
     {
       ...
     }
     else
     {
       ErrorList errors = ErrorHistory.GetLastErrors();
       ...
     }
   }

   Boolean HelperIdentifyEcu(Ecu ecu)
   {
     if (ecu.Identify().Failed())
     {
       // enthält alle Fehler, die bei der Ausführung von ecu.Identify().Failed()
       // aufgetreten sind
       ErrorList errors = ErrorHistory.GetLastErrors();

       // Versuche erneut, z.B. mit EDIABAS-Jobs
       {
         // Stattdessen könnten auch weitere ISOM/L-Hilfsfunktionen benutzt werden
         EdiabasResultSetList results1 = Ediabas.CallEdiabas(...);
         EdiabasResultSetList results2 = Ediabas.CallEdiabas(...);
       }

       // Abfrage aller Fehler, die während der Ausführung des vorherigen Blocks
       // von Ediabas-Aufrufen aufgetreten sind
       ErrorList ediabasErrors = ErrorHistory.GetLastErrors();

       // Bewerte zweiten Versuch
       ...
       return secondAttemptSuccessul;
     }

     return true;
   }
Rückgabe:
Liste der aufgetretenen Fehler.
[Isom\Sys\ErrorHistory.is: 149]


für Serviceautoren

Isom.Sys.ErrorList

Namensraum Isom.Sys.ErrorList

Listen von Fehlerbeschreibungen des Typs Isom.Sys.Error Mehr...

Funktionen
Isom.Sys.ErrorList | CreateErrorList()

Erzeugt eine neue Instanz von ErrorList

Listenfunktionen

Isom.Sys.Error | At(Isom.Base.Number index)

Ruft das Element innerhalb der Liste ab, das durch den Index ausgewählt wurde.

Isom.Base.Boolean | Contains(Isom.Base.String filter)

Fragt ab, ob ein Element in der Liste vorhanden ist, das einen gegebenen Filter erfüllt.

Isom.Sys.Error | Current()

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Isom.Sys.ErrorList | Find(Isom.Base.String filter)

Sucht alle Elemente der Liste, die einen gegebenen Filter erfüllen.

Isom.Base.Boolean | HasNext()

Liefert einen Wahrheitswert, der angibt, ob beim Iterieren über die Liste noch Elemente abgerufen werden können.

Isom.Base.Boolean | IsEmpty()

Liefert einen Wahrheitswert, der angibt, ob diese Liste leer ist oder nicht.

Isom.Base.Number | Length()

Liefert die Anzahl der Elemente in der Liste.

Isom.Sys.Error | Next()

Liefert das nächste Element in der Liste.

Isom.Base.Boolean | Reset()

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.ErrorList | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.ErrorList sind Listen von Fehlerbeschreibungen des Typs Isom.Sys.Error.

Zu beachten:
Es gibt zwei Möglichkeiten, um auf die Elemente in der Liste zuzugreifen:
  • durch einen indizierten Zugriff mit der Funktion .At()
  • durch Durchlaufen der Liste mit den Funktionen .HasNext() und .Next(). Vor einem Durchlaufen sollte .Reset() aufgerufen werden.
Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Sys\ErrorList.is

Dokumentation der Funktionen

objectbound Isom.Sys.Error Isom.Sys.ErrorList.At ( Isom.Base.Number index )

Ruft das Element innerhalb der Liste ab, das durch den Index ausgewählt wurde.

Parameter:
index Index.
Rückgabe:
Ausgewähltes Element.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Index kleiner als 0 ist oder größer gleich der Anzahl der Listenelemente.
[Isom\Sys\ErrorList.is: 160]
objectbound Isom.Base.Boolean Isom.Sys.ErrorList.Contains ( Isom.Base.String filter )

Fragt ab, ob ein Element in der Liste vorhanden ist, das einen gegebenen Filter erfüllt.

Parameter:
filter Filterkriterium.
Rückgabe:
'true', falls ein Element gefunden wurde, das das Filterkriterium erfüllt. 'false' sonst.
[Isom\Sys\ErrorList.is: 172]
Isom.Sys.ErrorList Isom.Sys.ErrorList.CreateErrorList ( )

Erzeugt eine neue Instanz von ErrorList

Rückgabe:
Eine leere Fehlerliste.
[Isom\Sys\ErrorList.is: 81]
objectbound Isom.Sys.Error Isom.Sys.ErrorList.Current ( )

Liefert das aktuelle Listenelement während der Iteration über die Liste.

Rückgabe:
Aktuelles Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls der Iterator zurückgesetzt wurde.
[Isom\Sys\ErrorList.is: 137]
objectbound Isom.Sys.ErrorList Isom.Sys.ErrorList.Find ( Isom.Base.String filter )

Sucht alle Elemente der Liste, die einen gegebenen Filter erfüllen.

Parameter:
filter Filterkriterium
Rückgabe:
Alle Elemente der Liste, die das angegebene Filterkriterium erfüllen.
[Isom\Sys\ErrorList.is: 183]
objectbound Isom.Base.Boolean Isom.Sys.ErrorList.HasNext ( )

Liefert einen Wahrheitswert, der angibt, ob beim Iterieren über die Liste noch Elemente abgerufen werden können.

Rückgabe:
'true', falls noch Elemente in der Liste zur Verfügung stehen, 'false' sonst.
[Isom\Sys\ErrorList.is: 114]
objectbound Isom.Base.Boolean Isom.Sys.ErrorList.IsEmpty ( )

Liefert einen Wahrheitswert, der angibt, ob diese Liste leer ist oder nicht.

Rückgabe:
'true', falls die Liste leer ist, 'false' sonst.
[Isom\Sys\ErrorList.is: 104]
objectbound Isom.Base.Boolean Isom.Sys.ErrorList.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\ErrorList.is: 199]
objectbound Isom.Base.Number Isom.Sys.ErrorList.Length ( )

Liefert die Anzahl der Elemente in der Liste.

Rückgabe:
Anzahl der Elemente.
[Isom\Sys\ErrorList.is: 95]
objectbound Isom.Sys.Error Isom.Sys.ErrorList.Next ( )

Liefert das nächste Element in der Liste.

Diese Funktion sollte zum Iterieren über die Liste verwendet werden.

Rückgabe:
Nächstes Element der Liste.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls keine weiteren Elemente in der Liste sind.
[Isom\Sys\ErrorList.is: 126]
objectbound Isom.Base.Boolean Isom.Sys.ErrorList.Reset ( )

Setzt den Iterator zurück, sodass er vor dem ersten Element der Liste steht.

Rückgabe:
Immer 'true'.
[Isom\Sys\ErrorList.is: 146]
Isom.Sys.ErrorList Isom.Sys.ErrorList.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\ErrorList.is: 210]


für Serviceautoren

Isom.Sys.Events

Namensraum Isom.Sys.Events

Hier folgen die Namensräume mit einer Kurzbeschreibung (wenn verfügbar):
Isom.Sys.Events.Event | Auslösen von Ereignissen durch den Autor
Isom.Sys.Events.EventInfo | Beschreibung eines Ereignisses
Isom.Sys.Events.EventListener | Fachobjekt für Beobachter von Events
Isom.Sys.Events.Guard | Zugriff auf Wächterfunktionen
Isom.Sys.Events.GuardInfo | Stellt eine Beschreibung eines Wächter-Rückrufs bereit
Isom.Sys.Events.PeriodicTimer | Fachobjekt für periodisch auslösende Zeitgeber
Isom.Sys.Events.Timer | Fachobjekt für einmal auslösende Zeitgeber ("Wecker")
Isom.Sys.Events.TimerInfo | Stellt eine Beschreibung eines Zeitgeber-Rückrufs bereit


für Serviceautoren

Isom.Sys.Events.Event

Namensraum Isom.Sys.Events.Event

Auslösen von Ereignissen durch den Autor Mehr...

Funktionen
Isom.Base.Boolean RaiseEvent(Isom.Base.String eventName, Isom.Base.StringDictionary eventData)

Löst ein Ereignis aus

Ausführliche Beschreibung

Mittels des Fachobjekts Event können Ereignisse ausgelöst werden, die dann durch einen Rückruf asynchron bearbeitet werden.

Quelldateien:

  • Isom\Sys\Events\Event.is

Dokumentation der Funktionen

Isom.Base.Boolean Isom.Sys.Events.Event.RaiseEvent | ( | Isom.Base.String | eventName,
 |  | Isom.Base.StringDictionary | eventData
 | ) |  |

Löst ein Ereignis aus

Parameter:
eventName | Bezeichnung des ausgelösten Ereignisses. Ein Ereignisempfänger, der dieses Ereignis erhalten soll, muss in seiner Definition die Zeichenkette AUTHOR: voranstellen
eventData | Ereignisspezifische Daten. Der Inhalt dieses Wörterbuchs ist spezifisch für jedes Ereignis und kann beliebig gewählt werden
Rückgabe:
'true', wenn das Ereignis erfolgreich ausgelöst wurde. Achtung: Das Auslösen des Ereignisses ist unabhängig davon, ob auch ein Beobachter definiert ist, der dieses Ereignis empfangen kann.
   using Isom.Base.*;
   using Isom.Sys.Events.*;

   Boolean MyFunction()
   {
     EventListener listener = EventListener.CreateEventListener("vinKnownListener", "AUTHOR:VinKnown", "OnVinKnown");
     listener.Enable();

     StringDictionary eventDataDict = StringDictionary.CreateStringDictionary();
     eventDataDict.Add("VIN", myVin);
     Event.RaiseEvent("VinKnown", eventDataDict"); } Boolean OnVinKnown(EventInfo info) { ... return true; }
[Isom\Sys\Events\Event.is: 98]


für Serviceautoren

Isom.Sys.Events.EventInfo

Namensraum Isom.Sys.Events.EventInfo

Beschreibung eines Ereignisses Mehr...

Funktionen
Elementoperationen

Funktionen zum Auslesen von Informationen.

Isom.Plan.TherapyPlanAction | GetAction()

Ruft die Aktion ab, in deren Kontext das Ereignis aufgetreten ist.

Isom.Base.StringDictionary | GetEventData()

Ruft ein Wörterbuch der Event-spezifischen Informationen ab.

Isom.Base.String | GetEventName()

Ruft die Bezeichnung des aufgetretenen Ereignisses ab.

Isom.Base.String | GetHint()

Ruft eine Textbeschreibung der Ursache für die Auslösung dieses Ereignisses ab.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.Events.EventInfo | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Mittels des EventInfo-Fachobjekts werden Details eines ausgelösten Ereignisses bereitgestellt.

Quelldateien:

  • Isom\Sys\Events\EventInfo.is

Dokumentation der Funktionen

objectbound Isom.Plan.TherapyPlanAction Isom.Sys.Events.EventInfo.GetAction ( )

Ruft die Aktion ab, in deren Kontext das Ereignis aufgetreten ist.

Das ist diejenige Aktion, die ausgeführt wurde, während der Empfänger des Ereignisses definiert wurde.

Wird ein Empfänger definiert, bevor die Planausführung gestartet wurde, tritt das Ereignis nicht im Kontext irgendeiner Aktion auf, auch nicht, wenn zum Zeitpunkt des Eintretens des Ereignisses eine oder mehrere Aktionen ausgeführt werden.

Rückgabe:
Aktion, in deren Kontext das Ereignis eingetreten ist
Ausnahmebehandlung:
wenn keine Aktion abrufbar ist
  using Isom.Base.*;
  using Isom.Context.*;
  using Isom.Sys.Events.*;

  Boolean OnMyEvent(EventInfo info)
  {
    String msg = "$(Hint) im Kontext von '$(Action)'";
    msg.Replace("$(Hint)", info.GetHint());

    TherapyPlanAction eventAction = info.GetAction();
    if (eventAction.IsVoid().Not())
    {
      Ecu ecu = eventAction.GetEcu();
      if (ecu.IsVoid())
      {
        msg.Replace("$(Action)", eventAction.GetName());
      }
      else
      {
        String actionMessage = "$(ActionName) auf $(ActionEcuName)";
        actionMessage.Replace("$(ActionName)", eventAction.GetName());
        actionMessage.Replace("$(ActionEcuName)", ecu.GetBaseVariant());
        msg.Replace("$(Action)", actionMessage);
      }
    }
    else
    {
      msg.Replace("$(Action)", "keiner Aktion");
    }

    System.Stdout(msg);
    return true;
  }
[Isom\Sys\Events\EventInfo.is: 166]
objectbound Isom.Base.StringDictionary Isom.Sys.Events.EventInfo.GetEventData ( )

Ruft ein Wörterbuch der Event-spezifischen Informationen ab.

Der Inhalt des Wörterbuchs ist spezifisch für jeden möglichen Rückruf abhängig vom Auslöser.

Für die Ereignisse ISOM:EntertFunction und ISOM:LeaveFunction sind die Einträge "Function" und "FunctionNamespace" definiert.

Rückgabe:
Wörterbuch Ereignis-spezifischer Informationen
[Isom\Sys\Events\EventInfo.is: 110]
objectbound Isom.Base.String Isom.Sys.Events.EventInfo.GetEventName ( )

Ruft die Bezeichnung des aufgetretenen Ereignisses ab.

Im Falle eines mittels Event.RaiseEvent(String,StringDictionary) ausgelösten Ereignisses wurde der dort angegebenen Bezeichnung "AUTHOR:" vorangestellt.

Rückgabe:
Bezeichnung des aufgetretenen Ereignisses
[Isom\Sys\Events\EventInfo.is: 82]
objectbound Isom.Base.String Isom.Sys.Events.EventInfo.GetHint ( )

Ruft eine Textbeschreibung der Ursache für die Auslösung dieses Ereignisses ab.

Diese Beschreibung wird vom ISOM-Kern erzeugt und ist für die Verwendung im Rahmen der Ereignisaufzeichnung vorgesehen

Rückgabe:
Textbeschreibung des Ereignisses
Ausnahmebehandlung:
wenn keine Textbeschreibung verfügbar ist
[Isom\Sys\Events\EventInfo.is: 95]
objectbound Isom.Base.Boolean Isom.Sys.Events.EventInfo.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\Events\EventInfo.is: 186]
Isom.Sys.Events.EventInfo Isom.Sys.Events.EventInfo.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\Events\EventInfo.is: 198]


für Serviceautoren

Isom.Sys.Events.EventListener

Namensraum Isom.Sys.Events.EventListener

Fachobjekt für Beobachter von Events Mehr...

Funktionen
Elementoperationen

Funktionen zum Verwenden und Bearbeiten von Beobachtern.

Isom.Sys.Events.EventListener | CreateEventListener(Isom.Base.String name, Isom.Base.String eventType, Isom.Base.String callback)

Erzeugt ein neues Ereignis-Beobachterobjekt.

Isom.Base.Boolean | Disable()

Deaktiviert den Empfang von Rückrufen für diesen Beobachter

Isom.Base.Boolean | Dispose()

Gibt das Ereignis-Beobachterobjekt frei.

Isom.Base.Boolean | Enable()

Aktiviert den Empfang von Rückrufen für diesen Beobachter

Isom.Sys.Events.EventListener | FindEventListener(Isom.Base.String name)

Findet ein Ereignis-Beobachterobjekt mit einer angegebenen Bezeichnung

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.Events.EventListener | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.Events.EventListener ist das Fachobjekt für Beobachter von Events

Quelldateien:

  • Isom\Sys\Events\EventListener.is

Dokumentation der Funktionen

Isom.Sys.Events.EventListener Isom.Sys.Events.EventListener.CreateEventListener | ( | Isom.Base.String | name,
 |  | Isom.Base.String | eventType,
 |  | Isom.Base.String | callback
 | ) |  |

Erzeugt ein neues Ereignis-Beobachterobjekt.

Der Beobachter, der mit CreateEventListener(String,String,String) erzeugt wurde, ist inaktiv. Zum Start des Empfangs von Rückrufen muss Enable() aufgerufen werden

Parameter:
name | Eindeutige Bezeichnung des Beobachters. Anhand dieser Bezeichnung kann der Beobachter mit FindEventListener(String) wieder gefunden werden
eventType | Bezeichnung des Ereignisses, das der Beobachter empfangen soll. Sollen Ereignisse empfangen werden, die mittels Event.RaiseEvent(String,StringDictionary) ausgelöst werden, muss dem Bezeichner "AUTHOR:" vorangestellt werden.
callback | Name der Rückruffunktion, die aufgerufen wird, wenn condition zu 'true' ausgewertet wird. Die Funktion muss im aktuellen Namensraum oder im Namensraum des OEM vorhanden sein. Ihre Signatur muss lauten: Boolean (EventInfo)
Rückgabe:
Ereignis-Beobachterobjekt
Ausnahmebehandlung:
wenn bereits ein Ereignis-Beobachterobjekt mit der angegebenen Bezeichnung existiert
Bemerkungen:
Ein Beispiel ist unter EventInfo.GetEventData() zu finden.
[Isom\Sys\Events\EventListener.is: 101]
objectbound Isom.Base.Boolean Isom.Sys.Events.EventListener.Disable ( )

Deaktiviert den Empfang von Rückrufen für diesen Beobachter

Rückgabe:
'true', wenn der Beobachter erfolgreich deaktiviert wurde
Ausnahmebehandlung:
wenn der Beobachter bereits mit Dispose() freigegeben wurde
[Isom\Sys\Events\EventListener.is: 135]
objectbound Isom.Base.Boolean Isom.Sys.Events.EventListener.Dispose ( )

Gibt das Ereignis-Beobachterobjekt frei.

Das Objekt ist nach diesem Aufruf nicht mehr benutzbar und wird mit FindEventListener(String) nicht mehr gefunden.

Rückgabe:
'true', wenn das Objekt erfolgreich freigegeben wurde
Ausnahmebehandlung:
wenn das Objekt bereits mit Dispose() freigegeben wurde
[Isom\Sys\Events\EventListener.is: 148]
objectbound Isom.Base.Boolean Isom.Sys.Events.EventListener.Enable ( )

Aktiviert den Empfang von Rückrufen für diesen Beobachter

Rückgabe:
'true', wenn der Beobachter erfolgreich aktiviert wurde
Ausnahmebehandlung:
wenn der Beobachter bereits mit Dispose() freigegeben wurde
[Isom\Sys\Events\EventListener.is: 124]
Isom.Sys.Events.EventListener Isom.Sys.Events.EventListener.FindEventListener ( Isom.Base.String name )

Findet ein Ereignis-Beobachterobjekt mit einer angegebenen Bezeichnung

Rückgabe:
Das Ereignis-Beobachterobjekt mit der angegeben Bezeichnung
Ausnahmebehandlung:
wenn es kein Ereignis-Beobachterobjekt mit der angegeben Bezeichnung gibt
[Isom\Sys\Events\EventListener.is: 113]
objectbound Isom.Base.Boolean Isom.Sys.Events.EventListener.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\Events\EventListener.is: 168]
Isom.Sys.Events.EventListener Isom.Sys.Events.EventListener.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\Events\EventListener.is: 180]


für Serviceautoren

Isom.Sys.Events.Guard

Namensraum Isom.Sys.Events.Guard

Zugriff auf Wächterfunktionen Mehr...

Funktionen
Elementoperationen

Funktionen zum Verwenden und Bearbeiten von Wächtern.

Isom.Sys.Events.Guard | CreateGuard(Isom.Base.String name, Isom.Base.String observedVariable, Isom.Base.String condition, Isom.Base.String callback)

Erzeugt einen benannten Wächter zur Überwachung einer Umgebungsgröße.

Isom.Base.Boolean | Disable()

Beendet die Überwachung durch einen Wächter.

Isom.Base.Boolean | Dispose()

Gibt ein Wächterobjekt frei.

Isom.Base.Boolean | Enable()

Startet die Überwachung, die für einen Wächter definiert wurde.

Isom.Sys.Events.Guard | FindGuard(Isom.Base.String name)

Sucht einen bereits durch Guard.CreateGuard(String,String,String,String) erzeugten und benannten Wächter.

Isom.Base.String | GetName()

Ruft die Bezeichnung des benannten Wächters ab.

Isom.Base.String | GetObservedVariable()

Ruft die Bezeichnung der von diesem Wächter überwachten Umgebungsvariable ab.

Isom.Base.Number | GetPeriod()

Ruft die Zeitspanne zwischen 2 Überprüfungen der zu überwachenden Umgebungsgröße ab.

Isom.Base.Boolean | SetPeriod(Isom.Base.Number milliSeconds)

Ändert die Zeitspanne zwischen 2 Überprüfungen der zu überwachenden Umgebungsgröße.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.Events.Guard | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Ein Guard-Fachobjekt repräsentiert einen Wächter, der nicht mittels Annotationen, sondern mittels Funktionen konfiguriert, aktiviert und wieder deaktiviert wird.

Quelldateien:

  • Isom\Sys\Events\Guard.is

Dokumentation der Funktionen

Isom.Sys.Events.Guard Isom.Sys.Events.Guard.CreateGuard | ( | Isom.Base.String | name,
 |  | Isom.Base.String | observedVariable,
 |  | Isom.Base.String | condition,
 |  | Isom.Base.String | callback
 | ) |  |

Erzeugt einen benannten Wächter zur Überwachung einer Umgebungsgröße.

Die Größe wird regelmäßig abgefragt. Erfüllt der ermittelte Wert eine angegebene Bedingung, wie eine angegebene Rückruffunktion asynchron aufgerufen.

Ein Wächter, der mittels CreateGuard(String,String,String,String) erzeugt wurde, ist inaktiv. Zum Start der Überwachung muss Enable() aufgerufen werden.

Parameter:
name | Legt eine eindeutige Bezeichnung des Wächters fest. Anhand dieser Bezeichnung kann der Wächter mit der Funktion FindGuard(String) abgerufen werden.
observedVariable | Bezeichnung der Umgebungsvariable, die überwacht werden soll. Zulässige Werte sind: ISOM:BatteryVoltage, ISOM:IgnitionVoltage
condition | Logischer Ausdruck, bei dessen Auswertung zu 'true' für die Umgebungsvariable ein Rückruf ausgelöst wird. Zugelassen sind Vergleichsoperatoren (>=, ==, <=, >, <) sowie logische Verknüpfungen (NOT, AND, OR, XOR). Der linke Operand der Vergleichsoperatoren ist immer die gemessene Größe. Der Operatorvorrang ist: NOT, AND, OR
callback | Name der Rückruffunktion, die aufgerufen wird, wenn condition zu 'true' ausgewertet wird. Die Funktion muss im aktuellen Namensraum oder im Namensraum des OEM vorhanden sein. Ihre Signatur muss lauten: Boolean (GuardInfo)
Rückgabe:
Die Instanz des Wächters.
Ausnahmebehandlung:
Wenn name einen bereits existenten Wächter beschreibt
Wenn observedVariable eine nicht bekannte Umgebungsgröße bezeichnet
Wenn condition nicht interpretierbar ist.
    // Beispielcode zur Demonstration von CreateGuard(String, String, String, String),
    // Enable(), Disable()
    using Isom.Base.*;
    using Isom.Sys.Events.*;
    ...
    Guard aTerminal30Guard = Guard.CreateGuard("terminal30Guard1", "ISOM:BatteryVoltage", "< 12.4 OR > 14.5", "OnTerminal30Guard");
    aTerminal30Guard.Enable();
    ...
    aTerminal30Guard.Disable();
    ...
    aTerminal30Guard.Enable();
    ...
    aTerminal30Guard.Disable();
    aTerminal30Guard.Dispose();
[Isom\Sys\Events\Guard.is: 137]
objectbound Isom.Base.Boolean Isom.Sys.Events.Guard.Disable ( )

Beendet die Überwachung durch einen Wächter.

Rückgabe:
'true', falls die Überwachung erfolgreich deaktiviert wurde.
Ausnahmebehandlung:
wenn der Wächter bereits mit Dispose() freigegeben wurde
[Isom\Sys\Events\Guard.is: 184]
objectbound Isom.Base.Boolean Isom.Sys.Events.Guard.Dispose ( )

Gibt ein Wächterobjekt frei.

Der Wächter ist nach diesem Aufruf nicht mehr nutzbar und wird nicht mehr durch FindGuard(String) gefunden.

Rückgabe:
'true'
Ausnahmebehandlung:
wenn der Wächter bereits mit Dispose() freigegeben wurde
[Isom\Sys\Events\Guard.is: 197]
objectbound Isom.Base.Boolean Isom.Sys.Events.Guard.Enable ( )

Startet die Überwachung, die für einen Wächter definiert wurde.

Rückgabe:
'true', falls die Überwachung erfolgreich gestartet wurde.
Ausnahmebehandlung:
wenn der Wächter bereits mit Dispose() freigegeben wurde
[Isom\Sys\Events\Guard.is: 173]
Isom.Sys.Events.Guard Isom.Sys.Events.Guard.FindGuard ( Isom.Base.String name )

Sucht einen bereits durch Guard.CreateGuard(String,String,String,String) erzeugten und benannten Wächter.

Parameter:
name Bezeichnung des Wächters.
Rückgabe:
Der mit name bezeichneten Wächter.
Ausnahmebehandlung:
Wenn name keinen bereits existierenden benannten Wächter bezeichnet.
    // Beispielcode zur Verwendung von FindGuard(String); siehe dazu auch das
    // Codebeispiel zu CreateGuard(String, String)
    using Isom.Base.*;
    using Isom.Sys.Events.*;
    ...
    Guard aTerminal30Guard = Guard.FindGuard("terminal30Guard1");
[Isom\Sys\Events\Guard.is: 161]
objectbound Isom.Base.String Isom.Sys.Events.Guard.GetName ( )

Ruft die Bezeichnung des benannten Wächters ab.

Rückgabe:
Die Bezeichnung des benannten Wächters.
[Isom\Sys\Events\Guard.is: 206]
objectbound Isom.Base.String Isom.Sys.Events.Guard.GetObservedVariable ( )

Ruft die Bezeichnung der von diesem Wächter überwachten Umgebungsvariable ab.

Rückgabe:
Die Bezeichnung der überwachten Umgebungsvariable
[Isom\Sys\Events\Guard.is: 216]
objectbound Isom.Base.Number Isom.Sys.Events.Guard.GetPeriod ( )

Ruft die Zeitspanne zwischen 2 Überprüfungen der zu überwachenden Umgebungsgröße ab.

Rückgabe:
Zeitspanne zwischen 2 Überprüfungen der zu überwachenden Umgebungsgröße in Millisekunden
[Isom\Sys\Events\Guard.is: 227]
objectbound Isom.Base.Boolean Isom.Sys.Events.Guard.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\Events\Guard.is: 266]
objectbound Isom.Base.Boolean Isom.Sys.Events.Guard.SetPeriod ( Isom.Base.Number milliSeconds )

Ändert die Zeitspanne zwischen 2 Überprüfungen der zu überwachenden Umgebungsgröße.

Die Voreinstellung beträgt 5 Sekunden. Die Zeitspanne kann unabhängig davon geändert werden, ob der Wächter aktiv oder inaktiv ist.

Parameter:
milliSeconds Zeitspanne zwischen 2 Überprüfungen der zu überwachenden Umgebungsgröße
Rückgabe:
'true', wenn die Zeitspanne erfolgreich geändert wurde
Ausnahmebehandlung:
wenn der Wächter bereits mit Dispose() freigegeben wurde
wenn die angegebene Zeitspanne kleiner als 0 ist
[Isom\Sys\Events\Guard.is: 246]
Isom.Sys.Events.Guard Isom.Sys.Events.Guard.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\Events\Guard.is: 278]


für Serviceautoren

Isom.Sys.Events.GuardInfo

Namensraum Isom.Sys.Events.GuardInfo

Stellt eine Beschreibung eines Wächter-Rückrufs bereit Mehr...

Funktionen
Elementoperationen

Funktionen zum Auslesen von Informationen.

Isom.Plan.TherapyPlanAction | GetAction()

Ruft die Aktion ab, in deren Kontext der Rückruf aufgetreten ist.

Isom.Base.StringDictionary | GetEventData()

Ruft ein Wörterbuch der wächterspezifischen Informationen ab.

Isom.Base.String | GetHint()

Ruft eine Textbeschreibung der Ursache für die Auslösung dieses Wächterrückrufs ab.

Isom.Base.String | GetVariableName()

Ruft die Bezeichnung der Umgebungsvariable ab, deren Wert zur Auslösung des Wächterrückrufs führte

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.Events.GuardInfo | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.Events.GuardInfo stellt eine Beschreibung eines Wächter-Rückrufs bereit

Quelldateien:

  • Isom\Sys\Events\GuardInfo.is

Dokumentation der Funktionen

objectbound Isom.Plan.TherapyPlanAction Isom.Sys.Events.GuardInfo.GetAction ( )

Ruft die Aktion ab, in deren Kontext der Rückruf aufgetreten ist.

Das ist diejenige Aktion, die ausgeführt wurde, während der Empfänger des Rückrufs definiert wurde.

Wird ein Empfänger definiert, bevor die Planausführung gestartet wurde, tritt der Rückruf nicht im Kontext irgendeiner Aktion auf, auch nicht, wenn zum Zeitpunkt des Eintretens des Ereignisses eine oder mehrere Aktionen ausgeführt werden.

Rückgabe:
Aktion, in deren Kontext der Rückruf eingetreten ist
Ausnahmebehandlung:
wenn keine Aktion abrufbar ist
Bemerkungen:
Die Verwendung ist analog zu EventInfo.GetAction() im dort gezeigten Beispiel möglich
[Isom\Sys\Events\GuardInfo.is: 115]
objectbound Isom.Base.StringDictionary Isom.Sys.Events.GuardInfo.GetEventData ( )

Ruft ein Wörterbuch der wächterspezifischen Informationen ab.

Rückgabe:
Wörterbuch Ereignis-spezifischer Informationen
[Isom\Sys\Events\GuardInfo.is: 94]
objectbound Isom.Base.String Isom.Sys.Events.GuardInfo.GetHint ( )

Ruft eine Textbeschreibung der Ursache für die Auslösung dieses Wächterrückrufs ab.

Diese Beschreibung wird vom ISOM-Kern erzeugt und ist für die Verwendung im Rahmen der Ereignisaufzeichnung vorgesehen

Rückgabe:
Textbeschreibung des Wächterrückrufs
Ausnahmebehandlung:
wenn keine Textbeschreibung verfügbar ist
[Isom\Sys\Events\GuardInfo.is: 85]
objectbound Isom.Base.String Isom.Sys.Events.GuardInfo.GetVariableName ( )

Ruft die Bezeichnung der Umgebungsvariable ab, deren Wert zur Auslösung des Wächterrückrufs führte

Rückgabe:
Bezeichnung der Umgebungsvariable
[Isom\Sys\Events\GuardInfo.is: 125]
objectbound Isom.Base.Boolean Isom.Sys.Events.GuardInfo.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\Events\GuardInfo.is: 145]
Isom.Sys.Events.GuardInfo Isom.Sys.Events.GuardInfo.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\Events\GuardInfo.is: 157]


für Serviceautoren

Isom.Sys.Events.PeriodicTimer

Namensraum Isom.Sys.Events.PeriodicTimer

Fachobjekt für periodisch auslösende Zeitgeber Mehr...

Funktionen
Elementoperationen

Funktionen zum Verwenden und Bearbeiten von periodisch auslösenden Zeitgebern.

Isom.Sys.Events.PeriodicTimer | CreatePeriodicTimer(Isom.Base.String name, Isom.Base.Number delay, Isom.Base.String callback)

Erzeugt einen benannten Zeitgeber, der periodisch auslöst, wenn eine vorgegebene Zeitspanne verstrichen ist.

Isom.Base.Boolean | Disable()

Deaktiviert Rückrufe infolge des Zeitgebers.

Isom.Base.Boolean | Dispose()

Gibt ein Zeitgeberobjekt frei.

Isom.Base.Boolean | Enable()

Aktiviert den Zeitgeber und den Rückrufempfänger dieses Zeitgebers.

Isom.Sys.Events.PeriodicTimer | FindPeriodicTimer(Isom.Base.String name)

Sucht einen bereits durch PeriodicTimer.CreatePeriodicTimer(String,Number,String) erzeugten und benannten Zeitgeber.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.Events.PeriodicTimer | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.Events.PeriodicTimer ist das Fachobjekt für periodisch auslösende Zeitgeber.

Quelldateien:

  • Isom\Sys\Events\PeriodicTimer.is

Dokumentation der Funktionen

Isom.Sys.Events.PeriodicTimer Isom.Sys.Events.PeriodicTimer.CreatePeriodicTimer | ( | Isom.Base.String | name,
 |  | Isom.Base.Number | delay,
 |  | Isom.Base.String | callback
 | ) |  |

Erzeugt einen benannten Zeitgeber, der periodisch auslöst, wenn eine vorgegebene Zeitspanne verstrichen ist.

Dann wird die angegebene Rückruffunktion asynchron aufgerufen.

Ein Zeitgeber, der mittels CreatePeriodicTimer(String,Number,String) erzeugt wurde, ist inaktiv. Zum Start der Zeitmessung muss Enable() aufgerufen werden.

Parameter:
name | Legt eine eindeutige Bezeichnung des Zeitgebers fest. Anhand dieser Bezeichnung kann der Zeitgeber mit der Funktion FindPeriodicTimer(String) abgerufen werden.
delay | Dauer bis zum Auslösen des Zeitgebers in Millisekunden
callback | Name der Rückruffunktion, die aufgerufen wird, wenn die angegebene Zeitspanne verstrichen ist. Die Funktion muss im aktuellen Namensraum oder im Namensraum des OEM vorhanden sein. Ihre Signatur muss lauten: Boolean (TimerInfo)
Rückgabe:
Die Instanz des Zeitgebers.
Ausnahmebehandlung:
Wenn name einen bereits existenten periodisch auslösenden Zeitgeber beschreibt
Wenn die angegebene Zeitspanne negativ ist
    // Beispielcode zur Demonstration von CreateTimer(String,Number,String),
    // Enable(), Disable()
    using Isom.Base.*;
    using Isom.Sys.Events.*;
    using Isom.Context.*;

    Boolean ContextIdent()
    {
      PeriodicTimer envCheckTimer = PeriodicTimer.CreatePeriodicTimer("environmentCheckTimer", 5000, "OnEnvironmentCheckTimer");
      envCheckTimer.Enable();
      ...
    }

    Boolean OnEnvironmentCheckTimer(TimerInfo info)
    {
      // Prüfung des VCI-Zustandes
    }
[Isom\Sys\Events\PeriodicTimer.is: 123]
objectbound Isom.Base.Boolean Isom.Sys.Events.PeriodicTimer.Disable ( )

Deaktiviert Rückrufe infolge des Zeitgebers.

Rückgabe:
'true', falls der Rückrufempfänger erfolgreich deaktiviert wurde.
Ausnahmebehandlung:
wenn der Zeitgeber bereits mit Dispose() freigegeben wurde
[Isom\Sys\Events\PeriodicTimer.is: 173]
objectbound Isom.Base.Boolean Isom.Sys.Events.PeriodicTimer.Dispose ( )

Gibt ein Zeitgeberobjekt frei.

Der Zeitgeber ist nach diesem Aufruf nicht mehr nutzbar und wird nicht mehr durch FindPeriodicTimer(String) gefunden.

Rückgabe:
'true'
Ausnahmebehandlung:
wenn der Zeitgeber bereits mit Dispose() freigegeben wurde
[Isom\Sys\Events\PeriodicTimer.is: 185]
objectbound Isom.Base.Boolean Isom.Sys.Events.PeriodicTimer.Enable ( )

Aktiviert den Zeitgeber und den Rückrufempfänger dieses Zeitgebers.

Die Zeitmessung beginnt, wenn Enable() aufgerufen wird, während der Zeitgeber deaktiviert ist. Die Zeitmessung kann nicht durch eine Folge von Disable() und Enable() pausiert werden.

Rückgabe:
'true', falls der Zeitgeber und der Rückrufempfänger erfolgreich aktiviert wurden
Ausnahmebehandlung:
wenn der Zeitgeber bereits mit Dispose() freigegeben wurde
[Isom\Sys\Events\PeriodicTimer.is: 162]
Isom.Sys.Events.PeriodicTimer Isom.Sys.Events.PeriodicTimer.FindPeriodicTimer ( Isom.Base.String name )

Sucht einen bereits durch PeriodicTimer.CreatePeriodicTimer(String,Number,String) erzeugten und benannten Zeitgeber.

Parameter:
name Bezeichnung des Zeitgebers.
Rückgabe:
Den mit name bezeichneten Zeitgeber.
Ausnahmebehandlung:
Wenn name keinen bereits existierenden benannten Zeitgeber bezeichnet.
    // Beispielcode zur Verwendung von FindTimer(String); siehe dazu auch das
    // Codebeispiel zu CreatePeriodicTimer(String,Number,String)
    using Isom.Base.*;
    using Isom.Sys.Events.*;
    ...
    Timer envCheckTimer = Timer.FindPerodicTimer("environmentCheckTimer");
[Isom\Sys\Events\PeriodicTimer.is: 147]
objectbound Isom.Base.Boolean Isom.Sys.Events.PeriodicTimer.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\Events\PeriodicTimer.is: 205]
Isom.Sys.Events.PeriodicTimer Isom.Sys.Events.PeriodicTimer.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\Events\PeriodicTimer.is: 217]


für Serviceautoren

Isom.Sys.Events.Timer

Namensraum Isom.Sys.Events.Timer

Fachobjekt für einmal auslösende Zeitgeber ("Wecker") Mehr...

Funktionen
Elementoperationen

Funktionen zum Verwenden und Bearbeiten von einmal auslösenden Zeitgebern ("Wecker") .

Isom.Sys.Events.Timer | CreateTimer(Isom.Base.String name, Isom.Base.Number milliSeconds, Isom.Base.String callback)

Erzeugt einen benannten Zeitgeber, der einmalig auslöst, wenn eine vorgegebene Zeitspanne verstrichen ist.

Isom.Base.Boolean | Disable()

Deaktiviert den Rückrufempfänger des Zeitgebers.

Isom.Base.Boolean | Dispose()

Gibt ein Zeitgeberobjekt frei.

Isom.Base.Boolean | Enable()

Aktiviert den Zeitgeber und den Rückrufempfänger dieses Zeitgebers.

Isom.Sys.Events.Timer | FindTimer(Isom.Base.String name)

Sucht einen bereits durch Timer.CreateTimer(String,Number,String) erzeugten und benannten Zeitgeber.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.Events.Timer | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.Events.Timer ist ein Fachobjekt für einen einmal auslösenden Zeitgeber ("Wecker").

Quelldateien:

  • Isom\Sys\Events\Timer.is

Dokumentation der Funktionen

Isom.Sys.Events.Timer Isom.Sys.Events.Timer.CreateTimer | ( | Isom.Base.String | name,
 |  | Isom.Base.Number | milliSeconds,
 |  | Isom.Base.String | callback
 | ) |  |

Erzeugt einen benannten Zeitgeber, der einmalig auslöst, wenn eine vorgegebene Zeitspanne verstrichen ist.

Dann wird die angegebene Rückruffunktion asynchron aufgerufen.

Ein Zeitgeber, der mittels CreateTimer(String,Number,String) erzeugt wurde, ist inaktiv. Zum Start der Zeitmessung muss Enable() aufgerufen werden.

Parameter:
name | Legt eine eindeutige Bezeichnung des Zeitgebers fest. Anhand dieser Bezeichnung kann der Zeitgeber mit der Funktion FindTimer(String) abgerufen werden.
milliSeconds | Dauer bis zum Auslösen des Zeitgebers in Millisekunden
callback | Name der Rückruffunktion, die aufgerufen wird, wenn die angegebene Zeitspanne verstrichen ist. Die Funktion muss im aktuellen Namensraum oder im Namensraum des OEM vorhanden sein. Ihre Signatur muss lauten: Boolean (TimerInfo)
Rückgabe:
Die Instanz des Zeitgebers.
Ausnahmebehandlung:
Wenn name einen bereits existenten einmal auslösenden Zeitgeber beschreibt
Wenn die angegebene Zeitspanne negativ ist
    // Beispielcode zur Demonstration von CreateTimer(String,Number,String),
    // Enable(), Disable()
    using Isom.Base.*;
    using Isom.Sys.Events.*;
    using Isom.Context.*;

    Boolean FilterMyAction(TherapyPlanAction action)
    {
      Timer myTimer = Timer.CreateTimer("myFilterTimer", 10000, "OnLongFilterFunction");
      myTimer.Enable();
      ...
      myTimer.Disable();
      myTimer.Dispose();
      return true;
    }

    // Wird aufgerufen, wenn FilterMyAction länger als 10 Sekunden dauert
    Boolean OnLongFilterFunction(TimerInfo info)
    {
      // Die Ausführung der Filterfunktion dauert ungewöhnlich lang
    }
[Isom\Sys\Events\Timer.is: 127]
objectbound Isom.Base.Boolean Isom.Sys.Events.Timer.Disable ( )

Deaktiviert den Rückrufempfänger des Zeitgebers.

Rückgabe:
'true', falls der Rückrufempfänger erfolgreich deaktiviert wurde.
Ausnahmebehandlung:
wenn der Zeitgeber bereits mit Dispose() freigegeben wurde
[Isom\Sys\Events\Timer.is: 179]
objectbound Isom.Base.Boolean Isom.Sys.Events.Timer.Dispose ( )

Gibt ein Zeitgeberobjekt frei.

Der Zeitgeber ist nach diesem Aufruf nicht mehr nutzbar und wird nicht mehr durch FindTimer(String) gefunden.

Rückgabe:
'true'
Ausnahmebehandlung:
wenn der Zeitgeber bereits mit Dispose() freigegeben wurde
[Isom\Sys\Events\Timer.is: 191]
objectbound Isom.Base.Boolean Isom.Sys.Events.Timer.Enable ( )

Aktiviert den Zeitgeber und den Rückrufempfänger dieses Zeitgebers.

Die Zeitmessung beginnt, wenn Enable() aufgerufen wird, während der Zeitgeber deaktiviert ist. Die Zeitmessung kann nicht durch eine Folge von Disable() und Enable() pausiert werden. Ein einmal abgelaufener Zeitgeber kann nicht erneut durch Disable() und Enable() benutzt werden.

Rückgabe:
'true', falls der Zeitgeber und der Rückrufempfänger erfolgreich aktiviert wurden
Ausnahmebehandlung:
wenn der Zeitgeber bereits mit Dispose() freigegeben wurde
[Isom\Sys\Events\Timer.is: 168]
Isom.Sys.Events.Timer Isom.Sys.Events.Timer.FindTimer ( Isom.Base.String name )

Sucht einen bereits durch Timer.CreateTimer(String,Number,String) erzeugten und benannten Zeitgeber.

Parameter:
name Bezeichnung des Zeitgebers.
Rückgabe:
Den mit name bezeichneten Zeitgeber.
Ausnahmebehandlung:
Wenn name keinen bereits existierenden benannten Zeitgeber bezeichnet.
    // Beispielcode zur Verwendung von FindTimer(String); siehe dazu auch das
    // Codebeispiel zu CreateTimer(String,Number,String)
    using Isom.Base.*;
    using Isom.Sys.Events.*;
    ...
    Timer filterTimer = Timer.FindTimer("myFilterTimer");
[Isom\Sys\Events\Timer.is: 151]
objectbound Isom.Base.Boolean Isom.Sys.Events.Timer.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\Events\Timer.is: 211]
Isom.Sys.Events.Timer Isom.Sys.Events.Timer.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\Events\Timer.is: 223]


für Serviceautoren

Isom.Sys.Events.TimerInfo

Namensraum Isom.Sys.Events.TimerInfo

Stellt eine Beschreibung eines Zeitgeber-Rückrufs bereit Mehr...

Funktionen
Elementoperationen

Funktionen zum Auslesen von Zeitgebern.

Isom.Plan.TherapyPlanAction | GetAction()

Ruft die Aktion ab, in deren Kontext der Rückruf aufgetreten ist.

Isom.Base.StringDictionary | GetEventData()

Ruft ein Wörterbuch zusätzlicher Informationen ab.

Isom.Base.String | GetHint()

Ruft eine Textbeschreibung der Ursache für die Auslösung dieses Rückrufs ab.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.Events.TimerInfo | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.Events.TimerInfo stellt eine Beschreibung eines Zeitgeber-Rückrufs bereit.

Quelldateien:

  • Isom\Sys\Events\TimerInfo.is

Dokumentation der Funktionen

objectbound Isom.Plan.TherapyPlanAction Isom.Sys.Events.TimerInfo.GetAction ( )

Ruft die Aktion ab, in deren Kontext der Rückruf aufgetreten ist.

Das ist diejenige Aktion, die ausgeführt wurde, während der Empfänger des Rückrufs definiert wurde.

Wird ein Empfänger definiert, bevor die Planausführung gestartet wurde, tritt der Rückruf nicht im Kontext irgendeiner Aktion auf, auch dann nicht, wenn zum Zeitpunkt des Eintretens des Events eine oder mehrere Aktionen ausgeführt werden.

Rückgabe:
Aktion, in deren Kontext der Rückruf eingetreten ist
Ausnahmebehandlung:
wenn keine Aktion abrufbar ist
Bemerkungen:
Die Verwendung ist analog zu EventInfo.GetAction() im dort gezeigten Beispiel möglich
[Isom\Sys\Events\TimerInfo.is: 113]
objectbound Isom.Base.StringDictionary Isom.Sys.Events.TimerInfo.GetEventData ( )

Ruft ein Wörterbuch zusätzlicher Informationen ab.

Rückgabe:
Wörterbuch Event-spezifischer Informationen
[Isom\Sys\Events\TimerInfo.is: 92]
objectbound Isom.Base.String Isom.Sys.Events.TimerInfo.GetHint ( )

Ruft eine Textbeschreibung der Ursache für die Auslösung dieses Rückrufs ab.

Diese Beschreibung wird vom ISOM-Kern erzeugt und ist für die Verwendung im Rahmen der Ereignisaufzeichnung vorgesehen

Rückgabe:
Textbeschreibung des Wächterrückrufs
Ausnahmebehandlung:
wenn keine Textbeschreibung verfügbar ist
[Isom\Sys\Events\TimerInfo.is: 83]
objectbound Isom.Base.Boolean Isom.Sys.Events.TimerInfo.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\Events\TimerInfo.is: 133]
Isom.Sys.Events.TimerInfo Isom.Sys.Events.TimerInfo.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\Events\TimerInfo.is: 145]


für Serviceautoren

Isom.Sys.FunctionInfo

Namensraum Isom.Sys.FunctionInfo

Zugriff auf die gemessene Zeiten aller Ausführungen einer Funktion Mehr...

Funktionen
Elementoperationen

Funktionen zum Auslesen von Informationen.

Isom.Base.String | GetComponentName()

Liefert den Namen der Komponente, die die Funktion ausgeführt hat

Isom.Base.Number | GetCount()

Liefert die Anzahl der Aufrufe der Funktion

Isom.Base.Number | GetExecutionTime()

Liefert die akkumulierte Ausführungszeit der Funktion in Millisekunden.

Isom.Base.String | GetFunctionName()

Liefert den Namen der Funktion

Isom.Base.Number | GetInstructionCounter()

Liefert die Anzahl der in der Funktion insgesamt abgearbeiteten Anweisungen (inklusive wiederholter Ausführungen und inklusive der Anweisungen in Unterfunktionsaufrufen)

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Sys.FunctionInfo | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.FunctionInfo | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.FunctionInfo gewährt Zugriff auf die gemessene Zeiten aller Ausführungen einer Funktion.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Sys\FunctionInfo.is

Dokumentation der Funktionen

objectbound Isom.Sys.FunctionInfo Isom.Sys.FunctionInfo.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\FunctionInfo.is: 252]
objectbound Isom.Base.String Isom.Sys.FunctionInfo.GetComponentName ( )

Liefert den Namen der Komponente, die die Funktion ausgeführt hat

   Isom.Sys.RuntimeInfo ri = SystemInfo.GetLastRuntimeInfo ();
   Isom.Sys.CallProfile cp = ri.GetCallProfile ();
   Isom.Sys.FunctionInfo funcInfo = cp.At (0);

   Isom.Base.String compName = funcInfo.GetComponentName();
Rückgabe:
Name der Komponente
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\FunctionInfo.is: 97]
objectbound Isom.Base.Number Isom.Sys.FunctionInfo.GetCount ( )

Liefert die Anzahl der Aufrufe der Funktion

   Isom.Sys.RuntimeInfo ri = SystemInfo.GetLastRuntimeInfo ();
   Isom.Sys.CallProfile cp = ri.GetCallProfile ();
   Isom.Sys.FunctionInfo funcInfo = cp.At (0);

   Isom.Base.Number count = funcInfo.GetCount();

   Isom.Base.String msg = "Funktion wurde ";
   msg.Append(count.ToIntString());
   msg.Append(" Mal aufgerufen");
Rückgabe:
Anzahl der Aufrufe der Funktion
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\FunctionInfo.is: 178]
objectbound Isom.Base.Number Isom.Sys.FunctionInfo.GetExecutionTime ( )

Liefert die akkumulierte Ausführungszeit der Funktion in Millisekunden.

   Isom.Sys.RuntimeInfo ri = SystemInfo.GetLastRuntimeInfo ();
   Isom.Sys.CallProfile cp = ri.GetCallProfile ();
   Isom.Sys.FunctionInfo funcInfo = cp.At (0);

   Isom.Base.Number execTime = funcInfo.GetExecutionTime();

   Isom.Base.String msg = "Ausführungsdauer: ";
   msg.Append(execTime.ToFloatString());
   msg.Append(" ms");
Rückgabe:
Akkumulierte Ausführungszeit in Millisekunden
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\FunctionInfo.is: 151]
objectbound Isom.Base.String Isom.Sys.FunctionInfo.GetFunctionName ( )

Liefert den Namen der Funktion

   Isom.Sys.RuntimeInfo ri = SystemInfo.GetLastRuntimeInfo ();
   Isom.Sys.CallProfile cp = ri.GetCallProfile ();
   Isom.Sys.FunctionInfo funcInfo = cp.At (0);

   Isom.Base.String funcName = funcInfo.GetFunctionName();

   // prüfe, ob Funktion gemäß Namenskonvention Teil der ISOM-API ist
   Isom.Base.Boolean  isAPIFunction = funcName.Substring(0, 4).Equals("Isom");
Rückgabe:
Name der Funktion
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\FunctionInfo.is: 123]
objectbound Isom.Base.Number Isom.Sys.FunctionInfo.GetInstructionCounter ( )

Liefert die Anzahl der in der Funktion insgesamt abgearbeiteten Anweisungen (inklusive wiederholter Ausführungen und inklusive der Anweisungen in Unterfunktionsaufrufen)

   Isom.Sys.RuntimeInfo ri = SystemInfo.GetLastRuntimeInfo ();
   Isom.Sys.CallProfile cp = ri.GetCallProfile ();
   Isom.Sys.FunctionInfo funcInfo = cp.At (0);

   Isom.Base.Number count = funcInfo.GetInstructionCounter();

   Isom.Base.String msg = "In der Funktion wurden ";
   msg.Append(count.ToIntString());
   msg.Append(" Anweisungen ausgeführt");
Rückgabe:
Isom.Base.Number
Anzahl der ausgeführten Instruktionen.
Siehe auch:
Isom.Sys.SystemInfo.GetInstructionCounter() für Einsprungspunkt-bezogene Anweisungszähler.
Isom.Sys.RuntimeInfo.GetInstructionCounter() für Ausführungsblock-bezogene Anweisungszähler.
Autor:
IFS Informationstechnik Müchen
Datum:
letzte Änderung am 22.12.2010
[Isom\Sys\FunctionInfo.is: 211]
objectbound Isom.Base.Boolean Isom.Sys.FunctionInfo.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\FunctionInfo.is: 237]
Isom.Sys.FunctionInfo Isom.Sys.FunctionInfo.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\FunctionInfo.is: 269]


für Serviceautoren

Isom.Sys.Log

Namensraum Isom.Sys.Log

Zugriff auf die Ereignisaufzeichung Mehr...

Funktionen
Namensraumfunktionen

Funktionen zur Versendung verschiedener Fehlermeldungen.

Isom.Base.Boolean | Error(Isom.Base.String id, Isom.Base.String message)

Versendet eine Zeichenkette als Fehlermeldung an die Ereignisaufzeichnung.

Isom.Base.Boolean | Fatal(Isom.Base.String id, Isom.Base.String message)

Versendet eine Zeichenkette als schwerwiegende Fehlermeldung an die Ereignisaufzeichnung.

Isom.Base.Boolean | Info(Isom.Base.String id, Isom.Base.String message)

Versendet eine Zeichenkette als Hinweis an die Ereignisaufzeichnung.

Isom.Base.Boolean | Success(Isom.Base.String id, Isom.Base.String message)

Versendet eine Zeichenkette als Erfolgsmeldung an die Ereignisaufzeichnung.

Isom.Base.Boolean | Warning(Isom.Base.String id, Isom.Base.String message)

Versendet eine Zeichenkette als Warnhinweis an die Ereignisaufzeichnung.

Ausführliche Beschreibung

Isom.Sys.Log gewährt Zugriff auf die Ereignisaufzeichnung.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Sys\Log.is

Dokumentation der Funktionen

Isom.Base.Boolean Isom.Sys.Log.Error | ( | Isom.Base.String | id,
 |  | Isom.Base.String | message
 | ) |  |

Versendet eine Zeichenkette als Fehlermeldung an die Ereignisaufzeichnung.

Parameter:
id | ganzzahlige Fehlernummer als Bezeichner.
message | Zeichenkette, die aufgezeichnet werden soll.
Rückgabe:
'true', falls die Zeichenkette aufgezeichnet wurde, 'false' sonst (z.B. weil die Zeichenkette das Void-Objekt war).
[Isom\Sys\Log.is: 94]
Isom.Base.Boolean Isom.Sys.Log.Fatal | ( | Isom.Base.String | id,
 |  | Isom.Base.String | message
 | ) |  |

Versendet eine Zeichenkette als schwerwiegende Fehlermeldung an die Ereignisaufzeichnung.

Parameter:
id | ganzzahlige Fehlernummer als Bezeichner.
message | Zeichenkette, die aufgezeichnet werden soll.
Rückgabe:
'true', falls die Zeichenkette aufgezeichnet wurde, 'false' sonst (z.B. weil die Zeichenkette das Void-Objekt war).
[Isom\Sys\Log.is: 80]
Isom.Base.Boolean Isom.Sys.Log.Info | ( | Isom.Base.String | id,
 |  | Isom.Base.String | message
 | ) |  |

Versendet eine Zeichenkette als Hinweis an die Ereignisaufzeichnung.

Parameter:
id | ganzzahlige Fehlernummer als Bezeichner.
message | Zeichenkette, die aufgezeichnet werden soll.
Rückgabe:
'true', falls die Zeichenkette aufgezeichnet wurde, 'false' sonst (z.B. weil die Zeichenkette das Void-Objekt war).
[Isom\Sys\Log.is: 122]
Isom.Base.Boolean Isom.Sys.Log.Success | ( | Isom.Base.String | id,
 |  | Isom.Base.String | message
 | ) |  |

Versendet eine Zeichenkette als Erfolgsmeldung an die Ereignisaufzeichnung.

Parameter:
id | ganzzahlige Fehlernummer als Bezeichner.
message | Zeichenkette, die aufgezeichnet werden soll.
Rückgabe:
'true', falls die Zeichenkette aufgezeichnet wurde, 'false' sonst (z.B. weil die Zeichenkette das Void-Objekt war).
[Isom\Sys\Log.is: 136]
Isom.Base.Boolean Isom.Sys.Log.Warning | ( | Isom.Base.String | id,
 |  | Isom.Base.String | message
 | ) |  |

Versendet eine Zeichenkette als Warnhinweis an die Ereignisaufzeichnung.

Parameter:
id | ganzzahlige Fehlernummer als Bezeichner.
message | Zeichenkette, die aufgezeichnet werden soll.
Rückgabe:
'true', falls die Zeichenkette aufgezeichnet wurde, 'false' sonst (z.B. weil die Zeichenkette das Void-Objekt war).
[Isom\Sys\Log.is: 108]


für Serviceautoren

Isom.Sys.Protocol

Namensraum Isom.Sys.Protocol

Erzeugung eines Sitzungsprotokoll der Therapiesitzung und Zugriff auf Protokollarchive. Mehr...

Funktionen
Isom.Base.Boolean | CreateProtocol(Isom.Base.String name)

Erzeugt die Instanz des Fachobjekts Protocol.

Namensraum-Operationen

Funktionen zum Erzeugen eines Sitzungsprotokoll und Zugriff auf Protokollarchive.

Isom.Base.Boolean | AddAttribute(Isom.Base.String name, Isom.Base.String text)

Fügt dem Dokumentknoten des Sitzungsprotokolls ein Attribut hinzu.

Isom.Base.Boolean | AddEntry(Isom.Base.Data entry)

Fügt dem Sitzungsprotokoll ein Ereignis hinzu.

Isom.Base.Boolean | AddToHeader(Isom.Base.Data entry)

Fügt dem Kopf des Sitzungsprotokolls einen Eintrag hinzu.

Isom.Base.Boolean | CreateHeader(Isom.Base.String name)

Erzeugt den Kopfeintrag des Fachobjekts Protocol.

Isom.Base.String | GetArchiveName(Isom.Base.String archiveId)

Ermittelt den Namen eines Archivs, das Protokolldateien der laufenden Sitzung enthält.

Isom.Base.String | GetFileName()

Ermittelt den Namen der Datei, in der das Sitzungsprotokoll gespeichert wird.

Isom.Base.Data | GetHeader()

Gibt den Kopfeintrag des Sitzungsprotokolls zurück.

Isom.Base.Boolean | SetFileName(Isom.Base.String fileName)

Setzt den Namen (und das Verzeichnis) für die Datei, in der das Sitzungsprotokoll gespeichert wird.

Ausführliche Beschreibung

Mit Hilfe dieses Fachobjekts kann ein XML-basiertes Protokoll der Therapiesitzung erzeugt werden. Die Struktur des XML-Dokuments kann durch den Serviceautor frei definiert werden. Es werden keinerlei Annahmen getroffen.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Sys\Protocol.is

Dokumentation der Funktionen

Isom.Base.Boolean Isom.Sys.Protocol.AddAttribute | ( | Isom.Base.String | name,
 |  | Isom.Base.String | text
 | ) |  |

Fügt dem Dokumentknoten des Sitzungsprotokolls ein Attribut hinzu.

 Isom.Sys.Protocol.AddAttribute("xmlns:xsi", "http://www.w3.org/2001/XMLSchema-instance");
Parameter:
name | Der Name des Attributs.
text | Der Text des Attributs.
Rückgabe:
'true', falls das Attribut hinzugefügt wurde, 'false' sonst.
[Isom\Sys\Protocol.is: 127]
Isom.Base.Boolean Isom.Sys.Protocol.AddEntry ( Isom.Base.Data entry )

Fügt dem Sitzungsprotokoll ein Ereignis hinzu.

    Isom.Base.Data entry = ..
    Isom.Sys.Protocol.AddEntry(entry);
Parameter:
entry Das Ereignis.
Rückgabe:
'true' bei erfolgreicher Ausführung, 'false' sonst.
[Isom\Sys\Protocol.is: 159]
Isom.Base.Boolean Isom.Sys.Protocol.AddToHeader ( Isom.Base.Data entry )

Fügt dem Kopf des Sitzungsprotokolls einen Eintrag hinzu.

    Isom.Base.Data entry = ..
    Isom.Sys.Protocol.AddToHeader(entry);
Parameter:
entry Der Eintrag.
Rückgabe:
'true' bei erfolgreicher Ausführung, 'false' sonst.
[Isom\Sys\Protocol.is: 174]
Isom.Base.Boolean Isom.Sys.Protocol.CreateHeader ( Isom.Base.String name )

Erzeugt den Kopfeintrag des Fachobjekts Protocol.

Zu beachten:
Muss einmal aufgerufen werden, bevor in das Sitzungsprotokoll geschrieben werden kann.
 Isom.Sys.Protocol.CreateHeader("HEADER");
Parameter:
name Der Name des Knotens für den Kopfeintrag.
Rückgabe:
'true', falls der Knoten noch nicht existiert hat, 'false' sonst.
[Isom\Sys\Protocol.is: 112]
Isom.Base.Boolean Isom.Sys.Protocol.CreateProtocol ( Isom.Base.String name )

Erzeugt die Instanz des Fachobjekts Protocol.

Zu beachten:
Muss einmal aufgerufen werden, bevor in das Sitzungsprotokoll geschrieben werden kann.
 Isom.Sys.Protocol.CreateProtocol("PROTOCOL");
Parameter:
name Der Name des Dokumentknotens (Wurzelknotens).
Rückgabe:
'true', falls der Knoten noch nicht existiert hat, 'false' sonst.
[Isom\Sys\Protocol.is: 90]
Isom.Base.String Isom.Sys.Protocol.GetArchiveName ( Isom.Base.String archiveId )

Ermittelt den Namen eines Archivs, das Protokolldateien der laufenden Sitzung enthält.

In den Protokollierungsrichtlinien kann eine beliebige Anzahl von Archiven definiert werden. Jedem Archiv ist eine eindeutige ID zugeordnet über die es referenziert werden kann.

 Isom.Base.String archiveFileName = Isom.Sys.Protocol.GetArchiveName("Log");
Parameter:
archiveID ID des Archivs dessen Name ermittelt werden soll.
Rückgabe:
Der Name des Archivs.
Ausnahmebehandlung:
Es wird das Void-Objekt zurückgegeben, falls kein Archiv mit der angegebenen ID definiert ist.
[Isom\Sys\Protocol.is: 233]
Isom.Base.String Isom.Sys.Protocol.GetFileName ( )

Ermittelt den Namen der Datei, in der das Sitzungsprotokoll gespeichert wird.

Bemerkungen:
Der Name muss vorher mit Hilfe der Fachfunktion 'SetFileName' gesetzt worden sein.
 Isom.Base.String protocolFileName = Isom.Sys.Protocol.GetFileName();
Rückgabe:
Der Dateiname.
Siehe auch:
Isom.Sys.Protocol.SetFileName()
[Isom\Sys\Protocol.is: 214]
Isom.Base.Data Isom.Sys.Protocol.GetHeader ( )

Gibt den Kopfeintrag des Sitzungsprotokolls zurück.

Diese Fachfunktion gibt eine Kopie des Kopfeintrags zurück. Änderungen an der Kopie haben keine Auswirkung auf das Sitzungsprotokoll. Um den Kopfeintrag zu erweitern, muss die Fachfunktion 'AddToHeader' verwendet werden.

    Isom.Base.Data header = Isom.Sys.Protocol.GetHeader();
Rückgabe:
Der Kopfeintrag.
Siehe auch:
Isom.Sys.Protocol.AddToHeader()
[Isom\Sys\Protocol.is: 144]
Isom.Base.Boolean Isom.Sys.Protocol.SetFileName ( Isom.Base.String fileName )

Setzt den Namen (und das Verzeichnis) für die Datei, in der das Sitzungsprotokoll gespeichert wird.

 Isom.Base.String dateTime = Isom.Base.Date.Now().ToUniversalTimeFormatted("yyyyMMdd_HHmmss");

 Isom.Base.String name = "XXXXXXX_DEALER_";
 name.Append(dateTime);
 name.Append(".prot");

 Isom.Base.Boolean success = Isom.Sys.Protocol.SetFileName(name);
Parameter:
fileName Der Name der Protokolldatei.
Rückgabe:
'true' bei erfolgreicher Ausführung, 'false' sonst.
Siehe auch:
Isom.Sys.Protocol.GetFileName()
[Isom\Sys\Protocol.is: 197]


für Serviceautoren

Isom.Sys.RuntimeInfo

Namensraum Isom.Sys.RuntimeInfo

Zugriff auf gemessene Zeiten ausgeführter Funktionen Mehr...

Funktionen
Fachfunktionen

Funktionen zum Auslesen und Messen von Ausführungszeiten von Funktionen.

Isom.Sys.CallProfile | GetCallProfile()

Liefert eine Aufschlüsselung der gemessenen Zeiten nach Funktionen

Isom.Base.Number | GetInstructionCounter()

Liefert die Anzahl abgearbeiteten Anweisungen des Zielbereichs.

Isom.Base.Number | GetIsomExecutionTime()

Liefert die gesamte Ausführungszeit des Zielbereichs in den ISOM-Fachobjekten

Isom.Base.Number | GetServicesExecutionTime()

Liefert die gesamte Ausführungszeit des Zielbereichs in den ISOM-Fachdienststellvertretern

Isom.Base.Number | GetTotalExecutionTime()

Liefert die gesamte Ausführungszeit des Zielbereichs

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Sys.RuntimeInfo | Clone()

Erzeugt eine identische Kopie des Objekts.

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.RuntimeInfo | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Isom.Sys.RuntimeInfo gewährt Zugriff auf gemessene Zeiten ausgeführter Funktionen.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Sys\RuntimeInfo.is

Dokumentation der Funktionen

objectbound Isom.Sys.RuntimeInfo Isom.Sys.RuntimeInfo.Clone ( )

Erzeugt eine identische Kopie des Objekts.

Rückgabe:
Das geklonte Objekt.
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\RuntimeInfo.is: 280]
objectbound Isom.Sys.CallProfile Isom.Sys.RuntimeInfo.GetCallProfile ( )

Liefert eine Aufschlüsselung der gemessenen Zeiten nach Funktionen

 Isom.Base.Boolean Test(Isom.Base.Boolean b)
 {
   {
     // ...
     if (b)
       leave;

     // ...
     return true;
   }
   finally
   {
     //Die Profilerinformationen werden im abschließenden Block immer abgefragt und ausgewertet
     Isom.Sys.RuntimeInfo rtInfo = Isom.Sys.SystemInfo.GetLastRuntimeInfo();
     Isom.Sys.CallProfile profile = rtInfo.GetCallProfile();
     while(profile.HasNext())
     {
       Isom.Sys.FunctionInfo next = profile.Next();
       // ...
     }
   }
   //..
   return false;
 }
Rückgabe:
Aufschlüsselung der gemessenen Zeiten nach Funktionen
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\RuntimeInfo.is: 201]
objectbound Isom.Base.Number Isom.Sys.RuntimeInfo.GetInstructionCounter ( )

Liefert die Anzahl abgearbeiteten Anweisungen des Zielbereichs.

Zu beachten:
Der Zielbereich umfasst die unmittelbar vor Aufruf von Isom.Sys.SystemInfo.GetLastRuntimeInfo() ausgeführte Anweisung bzw. den unmittelbar vor Aufruf ausgeführten Block.
   { // Beginn des Zielbereichs (hier: als Block)
     Isom.Base.Number i = 5;
     i.Add(1);
   } // Ende des Zielbereichs
   Isom.Sys.RuntimeInfo rtInfo = SystemInfo.GetLastRuntimeInfo();
   Isom.Base.Number count = rtInfo.GetInstructionCounter();

   Isom.Base.String msg = "Ausführung des Blocks umfasste $count Anweisungen.";
   msg.Replace(count.ToIntString());
   Isom.Sys.System.Stdout(msg);
Rückgabe:
Isom.Base.Number
Anzahl der ausgeführten Instruktionen.
Siehe auch:
Isom.Sys.SystemInfo.GetInstructionCounter() für Einsprungspunkt-bezogene Anweisungszähler.
Isom.Sys.FunctionInfo.GetInstructionCounter() für Funktions-bezogene Anweisungszähler.
Autor:
IFS Informationstechnik Müchen
Datum:
letzte Änderung am 22.12.2010
[Isom\Sys\RuntimeInfo.is: 239]
objectbound Isom.Base.Number Isom.Sys.RuntimeInfo.GetIsomExecutionTime ( )

Liefert die gesamte Ausführungszeit des Zielbereichs in den ISOM-Fachobjekten

   Isom.Sys.RuntimeInfo rtInfo = SystemInfo.GetLastRuntimeInfo();
   Isom.Base.Number isomExecTime = rtInfo.GetIsomExecutionTime();

   Isom.Base.String msg = "gemessene Ausführungszeit in ISOM-Fachobjekten: ";
   msg.Append(isomExecTime.ToFloatString());
   msg.Append(" ms");
   Isom.Sys.System.Stdout(msg);
Rückgabe:
Zeit in Millisekunden
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\RuntimeInfo.is: 132]
objectbound Isom.Base.Number Isom.Sys.RuntimeInfo.GetServicesExecutionTime ( )

Liefert die gesamte Ausführungszeit des Zielbereichs in den ISOM-Fachdienststellvertretern

   Isom.Sys.RuntimeInfo rtInfo = SystemInfo.GetLastRuntimeInfo();
   Isom.Base.Number servicesExecTime = rtInfo.GetServicesExecutionTime();

   Isom.Base.String msg = "gemessene Ausführungszeit in ISOM-Fachdienstproxys: ";
   msg.Append(servicesExecTime.ToFloatString());
   msg.Append(" ms");
   Isom.Sys.System.Stdout(msg);
Rückgabe:
Zeit in Millisekunden
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\RuntimeInfo.is: 157]
objectbound Isom.Base.Number Isom.Sys.RuntimeInfo.GetTotalExecutionTime ( )

Liefert die gesamte Ausführungszeit des Zielbereichs

Zu beachten:
Der Zielbereich umfasst die unmittelbar vor Aufruf von Isom.Sys.SystemInfo.GetLastRuntimeInfo() ausgeführte Anweisung bzw. den unmittelbar vor Aufruf ausgeführten Block.
   { // Beginn des Zielbereichs (hier: als Block)
     Isom.Base.Number i = 5;
     i.Add(1);
   } // Ende des Zielbereichs
   Isom.Sys.RuntimeInfo rtInfo = SystemInfo.GetLastRuntimeInfo();
   Isom.Base.Number execTime = rtInfo.GetTotalExecutionTime();

   Isom.Base.String msg  = "gemessene Ausführungszeit: ";
   msg.Append(execTime.ToFloatString());
   msg.Append(" ms");
   Isom.Sys.System.Stdout(msg);
Rückgabe:
Zeit in Millisekunden
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\RuntimeInfo.is: 107]
objectbound Isom.Base.Boolean Isom.Sys.RuntimeInfo.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\RuntimeInfo.is: 265]
Isom.Sys.RuntimeInfo Isom.Sys.RuntimeInfo.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\RuntimeInfo.is: 298]


für Serviceautoren

Isom.Sys.SessionContext

Namensraum Isom.Sys.SessionContext

Fachobjekt für den Sitzungskontext Mehr...

Funktionen
Isom.Sys.SessionContext | GetInstance()

Gibt die Instanz des Fachobjekts SessionContext zurück.

Fachoperationen

Funktionen zum Auslesen von Informationen.

Isom.Sys.ClientDataList | GetActiveClients()

Ermittelt die Liste der Clients, die momentan mit dieser Sitzung verbunden sind.

Isom.Sys.ClientDataList | GetAllClients()

Ermittelt die Liste der Clients, die jemals mit dieser Sitzung verbunden waren, unabhängig vom aktuellen Verbindungsstatus.

Isom.Base.String | GetSessionId()

Ermittelt die Sitzungs-ID.

Isom.Base.StringList | GetSessionList()

Ermittelt die Liste der aktiven Sitzungen.

Isom.Base.String | GetSessionName()

Ermittelt den Sitzungsnamen.

Isom.Base.StringDictionary | GetSettings()

Ermittelt die zusätzlichen Angaben zur Sitzung.

Grundfunktionen aller ISOM/L-Namensräume

Funktionen, die in den meisten Namensräumen verfügbar sind

Isom.Base.Boolean | IsVoid()

Bestimmt, ob es sich um das Void-Objekt handelt.

Isom.Sys.SessionContext | Void()

Erzeugt ein ungültiges Objekt.

Ausführliche Beschreibung

Der Sitzungskontext stellt Daten bereit, die von der Sitzungsverwaltung übermittelt wurden.

Hinweis: Dieses Fachobjekt funktioniert nicht mit ISOM Didact. Die meisten Funktionsaufrufe kehren mit dem Ergebnis 'Void' zurück.

Quelldateien:

  • Isom\Sys\SessionContext.is

Dokumentation der Funktionen

objectbound Isom.Sys.ClientDataList Isom.Sys.SessionContext.GetActiveClients ( )

Ermittelt die Liste der Clients, die momentan mit dieser Sitzung verbunden sind.

Rückgabe:
Die Liste der Clients.
[Isom\Sys\SessionContext.is: 139]
objectbound Isom.Sys.ClientDataList Isom.Sys.SessionContext.GetAllClients ( )

Ermittelt die Liste der Clients, die jemals mit dieser Sitzung verbunden waren, unabhängig vom aktuellen Verbindungsstatus.

Rückgabe:
Die Liste der Clients.
[Isom\Sys\SessionContext.is: 148]
Isom.Sys.SessionContext Isom.Sys.SessionContext.GetInstance ( )

Gibt die Instanz des Fachobjekts SessionContext zurück.

Rückgabe:
Die Instanz des Fachobjekts.
[Isom\Sys\SessionContext.is: 81]
objectbound Isom.Base.String Isom.Sys.SessionContext.GetSessionId ( )

Ermittelt die Sitzungs-ID.

Rückgabe:
Die Sitzungs-ID.
[Isom\Sys\SessionContext.is: 97]
objectbound Isom.Base.StringList Isom.Sys.SessionContext.GetSessionList ( )

Ermittelt die Liste der aktiven Sitzungen.

Rückgabe:
Eine Liste mit den IDs der Sitzungen.
[Isom\Sys\SessionContext.is: 130]
objectbound Isom.Base.String Isom.Sys.SessionContext.GetSessionName ( )

Ermittelt den Sitzungsnamen.

Rückgabe:
Der Sitzungsname.
[Isom\Sys\SessionContext.is: 105]
objectbound Isom.Base.StringDictionary Isom.Sys.SessionContext.GetSettings ( )

Ermittelt die zusätzlichen Angaben zur Sitzung.

Diese Angaben werden von der Sitzungsverwaltung festgelegt, um zusätzliche Informationen zur Sitzung zu übermitteln.

     String sessionType = SessionContext.GetInstance().GetSettings().Get(Consts.SESSIONCONTEXT_SESSION_TYPE);
Rückgabe:
Die zusätzlichen Angaben. Das Wörterbuch kann folgende Einträge enthalten:
  • SessionType Typ der Sitzung, z.B. "SERVICE"
[Isom\Sys\SessionContext.is: 122]
objectbound Isom.Base.Boolean Isom.Sys.SessionContext.IsVoid ( )

Bestimmt, ob es sich um das Void-Objekt handelt.

Rückgabe:
'true', falls dies das Void-Objekt ist, 'false' sonst.
[Isom\Sys\SessionContext.is: 167]
Isom.Sys.SessionContext Isom.Sys.SessionContext.Void ( )

Erzeugt ein ungültiges Objekt.

Die Funktion kann in Fehlerfällen verwendet werden, um z.B. einen ungültigen Funktionsrückgabewert zu erzeugen.

Rückgabe:
Ungültiges Objekt.
[Isom\Sys\SessionContext.is: 178]


für Serviceautoren

Isom.Sys.System

Namensraum Isom.Sys.System

Zugriff auf allgemeine Systemressourcen Mehr...

Funktionen
Namensraumfunktionen

Funktionen, die Zugriff auf allgemeine Systemressourcen gewähren.

Isom.Base.Boolean | Stderr(Isom.Base.String message)

Gibt eine Zeile (mit zusätzlichem Zeilentrenner) in den Standardfehlerausgabestrom aus.

Isom.Base.String | Stdin()

Liest eine Zeile aus der Standardeingabe.

Isom.Base.Boolean | Stdout(Isom.Base.String message)

Gibt eine Zeile (mit zusätzlichem Zeilentrenner) in den Standardausgabestrom aus.

Isom.Base.Boolean | Wait(Isom.Base.Number milliseconds)

Verzögert die Ausführung (des Threads) um die vorgegebene Anzahl von Millisekunden.

Ausführliche Beschreibung

Isom.Sys.System gewährt Zugriff auf allgemeine Systemressourcen.

Autor:
IFS Informationstechnik München

Quelldateien:

  • Isom\Sys\System.is

Dokumentation der Funktionen

Isom.Base.Boolean Isom.Sys.System.Stderr ( Isom.Base.String message )

Gibt eine Zeile (mit zusätzlichem Zeilentrenner) in den Standardfehlerausgabestrom aus.

Diese Funktion ist hauptsächlich für den Kommandozeilenbetrieb ISOM/CLI sinnvoll.

Rückgabe:
Immer 'true'.
[Isom\Sys\System.is: 89]
Isom.Base.String Isom.Sys.System.Stdin ( )

Liest eine Zeile aus der Standardeingabe.

Diese Funktion ist hauptsächlich für den Kommandozeilenbetrieb ISOM/CLI sinnvoll.

Rückgabe:
Gelesene Eingabezeile.
[Isom\Sys\System.is: 100]
Isom.Base.Boolean Isom.Sys.System.Stdout ( Isom.Base.String message )

Gibt eine Zeile (mit zusätzlichem Zeilentrenner) in den Standardausgabestrom aus.

Diese Funktion ist hauptsächlich für den Kommandozeilenbetrieb ISOM/CLI sinnvoll.

Rückgabe:
Immer 'true'.
[Isom\Sys\System.is: 78]
Isom.Base.Boolean Isom.Sys.System.Wait ( Isom.Base.Number milliseconds )

Verzögert die Ausführung (des Threads) um die vorgegebene Anzahl von Millisekunden.

Rückgabe:
Immer 'true'.
[Isom\Sys\System.is: 66]


für Serviceautoren

Isom.Sys.SystemInfo

Namensraum Isom.Sys.SystemInfo

Zugriff auf allgemeine Informationen über den Rechner und die Systemumgebung Mehr...

Funktionen
Daten externer Anbieter

Isom.Base.String | GetBusinessHours()

Ermittelt die Geschäftszeiten.

Isom.Sys.Dealer | GetDealer()

Ermittelt die Händlerinformationen.

Isom.Base.String | GetDeviceType()

Ermittelt den Geräte-Typ.

Isom.Base.String | GetLanguage()

Ermittelt die Spracheinstellungen.

Isom.Base.String | GetLocalBrand()

Ermittelt die lokalen Markeneinstellungen.

Isom.Base.StringDictionary | GetNetworkInfo()

Ermittelt Informationen der Netzwerkeinstellungen.

Isom.Base.StringDictionary | GetPerformanceSnapshot()

Ermittelt die momentane Auslastung des Rechners.

Isom.Base.StringDictionary | GetUserInfo()

Ermittelt die Daten des Händlers.

Interne Daten

Systeminformationen, die von ISOM bereitgestellt werden

Isom.Base.Number | GetInstructionCounter()

Liefert die Anzahl der ausgeführten Instruktionen der ausführenden Interpreterinstanz.

Isom.Base.Number | GetIsomlNodeCounter()

Liefert die Anzahl der geladenen ISOM/L-Knoten im Parsebaum.

Isom.Sys.RuntimeInfo | GetLastRuntimeInfo()

Liefert die Ausführungszeiten, die während der Ausführung der vorherigen Anweisung oder des vorherigen Blocks gemessen wurden.

Isom.Base.Number | GetMemoryUsage()

Ermittelt den aktuellen Speicherverbrauch des ISOM-Prozesses

Ausführliche Beschreibung

Die Funktionen dieses Namensraums stellen Informationen über die Systemumgebung bereit. Ein Großteil dieser Informationen wird vom Taurus® DataProcurment über entsprechende Datenanbieter ermittelt.

Quelldateien:

  • Isom\Sys\SystemInfo.is

Dokumentation der Funktionen

Isom.Base.String Isom.Sys.SystemInfo.GetBusinessHours ( )

Ermittelt die Geschäftszeiten.

Für jeden Tag werden Beginn und Ende der Geschäftszeiten angegeben. Die Daten der einzelnen Tage sind durch '|' getrennt, z.B.: 7:00 - 18:00 | 7:00 - 18:00 | 7:00 - 18:00 | 7:00 - 18:00 | 7:30 - 16:00 | 8:00 - 12:00 | - - -

Rückgabe:
Die Geschäftszeiten.
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\SystemInfo.is: 178]
Isom.Sys.Dealer Isom.Sys.SystemInfo.GetDealer ( )

Ermittelt die Händlerinformationen.

Rückgabe:
Die Händlerinformationen.
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\SystemInfo.is: 266]
Isom.Base.String Isom.Sys.SystemInfo.GetDeviceType ( )

Ermittelt den Geräte-Typ.

Rückgabe:
Der Geräte-Typ.
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\SystemInfo.is: 206]
Isom.Base.Number Isom.Sys.SystemInfo.GetInstructionCounter ( )

Liefert die Anzahl der ausgeführten Instruktionen der ausführenden Interpreterinstanz.

Zu beachten:
Da jeder Einsprungspunkt in einer eigenen Interpreterinstanz abgearbeitet wird, entspricht das Ergebnis der Anzahl der ausgeführten Instruktionen seit Beginn des aktuell abgearbeiteten Einsprungspunkts.
Bei der Abarbeitung eines einzelnen ISOM/L-Programms entspricht das Ergebnis der Anzahl der ausgeführten Instruktionen seit Start der main()-Funktion.
   // in OEM\Global\GlobalEntryPoints.isi:
   Isom.Base.Boolean UpdateCurrentContextEcus()
   {
     // ...

     Isom.Base.Number count = Isom.Sys.SystemInfo.GetInstructionCounter();
     Isom.Base.String text = "Für die Ermittlung der Steuergeräteliste wurden $count Anweisungen ausgeführt.";
     text.Replace("$count", count.ToIntString());
     Isom.Sys.System.Stdout(text);

     return true;
   } // UpdateCurrentContextEcus
Rückgabe:
Isom.Base.Number
Anzahl der ausgeführten Instruktionen des ausführenden Interpreters.
Siehe auch:
Isom.Sys.FunctionInfo.GetInstructionCounter() für Funktions-bezogene Anweisungszähler.
Isom.Sys.RuntimeInfo.GetInstructionCounter() für Ausführungsblock-bezogene Anweisungszähler.
Autor:
IFS Informationstechnik Müchen
Datum:
letzte Änderung am 22.12.2010
[Isom\Sys\SystemInfo.is: 385]
Isom.Base.Number Isom.Sys.SystemInfo.GetIsomlNodeCounter ( )

Liefert die Anzahl der geladenen ISOM/L-Knoten im Parsebaum.

   // in OEM\Global\GlobalEntryPoints.isi:
   Isom.Base.Boolean OnIsomStarting( )
   {
     Isom.Base.String text = "Aufruf von OnIsomStarting: ";

     Isom.Base.Number count = Isom.Sys.SystemInfo.GetIsomlNodeCounter();
     text.Append(count.ToIntString());
     text.Append(" Syntaxbaumknoten wurden bisher geladen.");
     Isom.Sys.System.Stdout(text);

     // ...
   } //  OnIsomStarting
Rückgabe:
Isom.Base.Number
Anzahl der ausgeführten Instruktionen des ausführenden Interpreters.
Autor:
IFS Informationstechnik Müchen
Datum:
letzte Änderung am 22.12.2010
[Isom\Sys\SystemInfo.is: 417]
Isom.Base.String Isom.Sys.SystemInfo.GetLanguage ( )

Ermittelt die Spracheinstellungen.

Rückgabe:
Name der eingestellten Sprache.
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\SystemInfo.is: 192]
Isom.Sys.RuntimeInfo Isom.Sys.SystemInfo.GetLastRuntimeInfo ( )

Liefert die Ausführungszeiten, die während der Ausführung der vorherigen Anweisung oder des vorherigen Blocks gemessen wurden.

Reine Variablendeklarationen ohne Zuweisung werden dabei ignoriert. Ist der Aufruf von GetLastRuntimeInfo() der erste innerhalb eines Blocks, so bezieht sich die Abfrage auf

  • die Bedingung innerhalb der übergeordneten if-Anweisung
  • die Bedingung innerhalb der übergeordneten while-Anweisung
  • das Muster innerhalb der übergeordneten switch-Anweisung

Zu beachten:
Zur Messung von Ausführungszeiten muss beim Start von ISOM der Kommandozeilenschalter "Profile" angegeben worden sein, ansonsten liefert diese Funktion 'Void'
   using Isom.Context.*;
   using Isom.Sys.*;
   ...

   // Abfrage der Zeiten, die bei der Ausführung von anEcu.Identify().Failed() auftreten
   if (anEcu.Identify().Failed())
   {
     Isom.Sys.RuntimeInfo rtInfo = SystemInfo.GetLastRuntimeInfo();
     ...
   }
   ...

   // oder auch möglich:
   if (anEcu.Identify().Failed())
   {
     ...
   }
   else
   {
     Isom.Sys.RuntimeInfo rtInfo = SystemInfo.GetLastRuntimeInfo();
     ...
   }
Rückgabe:
Zeitmessungen.
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\SystemInfo.is: 341]
Isom.Base.String Isom.Sys.SystemInfo.GetLocalBrand ( )

Ermittelt die lokalen Markeneinstellungen.

Rückgabe:
Die Markeneinstellungen.
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\SystemInfo.is: 252]
Isom.Base.Number Isom.Sys.SystemInfo.GetMemoryUsage ( )

Ermittelt den aktuellen Speicherverbrauch des ISOM-Prozesses

Rückgabe:
Speicherbedarf in Bytes
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\SystemInfo.is: 291]
Isom.Base.StringDictionary Isom.Sys.SystemInfo.GetNetworkInfo ( )

Ermittelt Informationen der Netzwerkeinstellungen.

Die verfügbaren Daten werden in einem Wörterbuch zurückgegeben.

   Isom.Base.StringDictionary networkInfo = SystemInfo.GetNetworkInfo();
   Isom.Base.String ipAddress = networkInfo.Get(Consts.SYSTEMINFO_NETWORKINFO_IP_ADDRESS);
   Isom.Base.String hostname = networkInfo.Get(Consts.SYSTEMINFO_NETWORKINFO_HOSTNAME);
   Isom.Base.String macAddress = networkInfo.Get(Consts.SYSTEMINFO_NETWORKINFO_MAC_ADDRESS);
   Isom.Base.String gateway = networkInfo.Get(Consts.SYSTEMINFO_NETWORKINFO_GATEWAY);
   Isom.Base.String netmask = networkInfo.Get(Consts.SYSTEMINFO_NETWORKINFO_NETMASK);
   Isom.Base.String linkQuality = networkInfo.Get(Consts.SYSTEMINFO_NETWORKINFO_QUALITY);
   Isom.Base.String linkType = networkInfo.Get(Consts.SYSTEMINFO_NETWORKINFO_LINKTYPE);
Rückgabe:
Die Netzwerkeinstellungen in einem Wörterbuch. Das Wörterbuch enthält folgende Einträge:
  • IpAddress IP-Adresse des Rechners
  • Hostname IP-Adresse des Rechners
  • MacAddress MAC-Adresse des Rechners
  • Gateway Gateway der Rechners
  • Netmask Netmask der Netzwerkkonfiguration
  • LinkQuality Qualität der Netzwerkanbindung
  • LinkType Art der Netzwerkanbindung
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\SystemInfo.is: 112]
Isom.Base.StringDictionary Isom.Sys.SystemInfo.GetPerformanceSnapshot ( )

Ermittelt die momentane Auslastung des Rechners.

Die verfügbaren Daten werden in einem Wörterbuch zurückgegeben.

   Isom.Base.StringDictionary performanceSnapshot = SystemInfo.GetPerformanceSnapshot();
   Isom.Base.String uptime = performanceSnapshot.Get(Consts.SYSTEMINFO_PERFORMANCESNAPSHOT_UPTIME);
   Isom.Base.String memory = performanceSnapshot.Get(Consts.SYSTEMINFO_PERFORMANCESNAPSHOT_MEMORY);
   Isom.Base.String harddisk = performanceSnapshot.Get(Consts.SYSTEMINFO_PERFORMANCESNAPSHOT_HARDDISK);
   Isom.Base.String cpu = performanceSnapshot.Get(Consts.SYSTEMINFO_PERFORMANCESNAPSHOT_CPU);
   Isom.Base.String cpuCount = performanceSnapshot.Get(Consts.SYSTEMINFO_PERFORMANCESNAPSHOT_CPU_NO);
Rückgabe:
Die Daten der Auslastung. Das Wörterbuch enthält folgende Einträge:
  • Uptime Zeit (in [ms]) seit dem letzten Systemstart
  • Memory Verfügbarer (freier) Arbeitsspeicher
  • Harddisk Freier und genutzter Speicherplatz auf Festplatten
  • CPU CPU-Auslastung (als kommaseparierte Liste von Prozentwerten)
  • CpuCount Anzahl der Prozessoren im Rechner
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\SystemInfo.is: 238]
Isom.Base.StringDictionary Isom.Sys.SystemInfo.GetUserInfo ( )

Ermittelt die Daten des Händlers.

Die verfügbaren Daten werden in einem Wörterbuch zurückgegeben.

   Isom.Base.StringDictionary userInfo = SystemInfo.GetUserInfo();
   Isom.Base.String name = userInfo.Get(Consts.SYSTEMINFO_USERINFO_NAME);
   Isom.Base.String id = userInfo.Get(Consts.SYSTEMINFO_USERINFO_ID);
   Isom.Base.String address = userInfo.Get(Consts.SYSTEMINFO_USERINFO_ADDRESS);
   Isom.Base.String phone = userInfo.Get(Consts.SYSTEMINFO_USERINFO_PHONE);
   Isom.Base.String fax = userInfo.Get(Consts.SYSTEMINFO_USERINFO_FAX);
   Isom.Base.String email = userInfo.Get(Consts.SYSTEMINFO_USERINFO_EMAIL);
   Isom.Base.String country = userInfo.Get(Consts.SYSTEMINFO_USERINFO_COUNTRY);
   Isom.Base.String contact = userInfo.Get(Consts.SYSTEMINFO_USERINFO_CONTACT);
   Isom.Base.String brand = userInfo.Get(Consts.SYSTEMINFO_USERINFO_BRAND);
   Isom.Base.String distributorId = userInfo.Get(Consts.SYSTEMINFO_USERINFO_DISTRIBUTOR_ID);
   Isom.Base.String factoryId = userInfo.Get(Consts.SYSTEMINFO_USERINFO_FACTORY_ID);
   Isom.Base.String aux1 = userInfo.Get(Consts.SYSTEMINFO_USERINFO_AUX1);
   Isom.Base.String aux2 = userInfo.Get(Consts.SYSTEMINFO_USERINFO_AUX2);
Rückgabe:
Die Händlerdaten. Das Wörterbuch enthält folgende Einträge:
  • Name Name des Händlers
  • Id Händlers-ID
  • Address Adresse des Händlers
  • Phone Telefonnummer des Händlers
  • Fax Faxnummer des Händlers
  • Email Email-Adresse des Händlers
  • Country Land
  • Contact Kontaktinformation
  • Brand Markenname
  • DistributorId Vertriebspartner-ID
  • FactoryId Betriebs-ID
  • Aux1 zusätzliche Angaben
  • Aux2 zusätzliche Angaben
Autor:
IFS Informationstechnik Müchen
[Isom\Sys\SystemInfo.is: 160]


für Serviceautoren

Isom.Sys.VersionInfo

Namensraum Isom.Sys.VersionInfo

Informationen über die Versionskennung der Programmierapplikation Mehr...

Funktionen
Namensraumfunktionen

Funktionen zum Auslesen von der Produkt- und Oemversion.

Isom.Base.String | GetOemVersion()

Liefert die durch den OEM definierte Versionskennung der Werkstattapplikation.

Isom.Base.String | GetProductVersion()

Liefert die durch die IFS definierte Produkt-Versionskennung der Werkstattapplikation.

Ausführliche Beschreibung

Isom.Sys.VersionInfo kann Informationen über die Versionskennung der Programmierapplikation

auslesen.

Quelldateien:

  • Isom\Sys\VersionInfo.is

Dokumentation der Funktionen

Isom.Base.String Isom.Sys.VersionInfo.GetOemVersion ( )

Liefert die durch den OEM definierte Versionskennung der Werkstattapplikation.

Rückgabe:
Die Versionskennung (Name + Versionsnummer) als Zeichenkette.
   ...
   String oemVersion = Isom.Sys.VersionInfo.GetOemVersion();  // z.B. "1.7.0.0"
[Isom\Sys\VersionInfo.is: 83]
Isom.Base.String Isom.Sys.VersionInfo.GetProductVersion ( )

Liefert die durch die IFS definierte Produkt-Versionskennung der Werkstattapplikation.

Rückgabe:
Die Versionskennung (Name + Versionsnummer) als Zeichenkette.
   ...
   String productVersion = Isom.Sys.VersionInfo.GetProductVersion();  // z.B. "100.564"
[Isom\Sys\VersionInfo.is: 70]


für Serviceautoren

  • A
  • C
  • D
  • E
  • F
  • G
  • H
  • I
  • L
  • M
  • N
  • O
  • P
  • Q
  • R
  • S
  • T
  • U
  • V
  • W
  • X
Hier folgt die Aufzählung aller Funktionen mit Verweisen auf die Namensräume für jede Funktion:

- A -

  • AbortActionPlan() : Isom.Global.Controller , Isom.Global.Processes
  • Add() : Isom.Base.UriDictionary , Isom.Base.StringDictionary , Isom.Base.Number , Isom.Sys.Error , Isom.Plan.TherapyPlan , Isom.Context.Dtc , Isom.Context.VehicleOrder
  • AddActionManually() : Isom.Global.Processes
  • AddAttribute() : Isom.Base.Data , Isom.Sys.Protocol
  • AddBoolean() : Isom.Request.Wizard
  • AddButton() : Isom.Request.ButtonList
  • AddElement() : Isom.Base.Data
  • AddEntry() : Isom.Sys.Protocol
  • AddGlobal() : Isom.Base.StringList , Isom.Base.String , Isom.Base.Number , Isom.Base.Data
  • AddMeasuredValue() : Isom.Request.Measurement , Isom.Diagnostics.Measurement
  • AddMeasurement() : Isom.Request.MeasurementList , Isom.Request.Wizard , Isom.Diagnostics.MeasurementList
  • AddMedia() : Isom.Request.MediaList
  • AddMessage() : Isom.Plan.TherapyPlan , Isom.Request.MessageList , Isom.Request.Wizard
  • AddNumber() : Isom.Request.Wizard
  • AddOption() : Isom.Request.SelectionGroup
  • AddPlanElement() : Isom.Global.Controller
  • AddRadioButton() : Isom.Request.Wizard
  • AddSection() : Isom.Reporting.Report
  • AddSelectionGroup() : Isom.Request.SelectionGroupList
  • AddString() : Isom.Request.Wizard
  • AddStringToGlobalList() : Isom.Base.StringList
  • AddSubsection() : Isom.Reporting.ReportSection
  • AddTextInput() : Isom.Request.Wizard
  • AddToHeader() : Isom.Sys.Protocol
  • And() : Isom.Base.Number , Isom.Base.Boolean
  • Append() : Isom.Base.String
  • At() : Isom.Base.StringList , Isom.Base.NumberList , Isom.Base.DataList , Isom.Sys.ErrorList , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Services.AsamParameter , Isom.Services.AsamResponseList , Isom.Services.AsamParameterList , Isom.Plan.TherapyPlanActionList , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfoList , Isom.Context.UserProfileOptionList , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.UserProfileSettingList , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicleList
  • Authenticate() : Isom.Security.SecurityProvider

- C -

  • CalcFinalFutureContext() : Isom.Context.FutureVehicleContext
  • CalcNewFutureContext() : Isom.Context.FutureVehicleContext
  • CalculateFinalPlan() : Isom.Global.Controller , Isom.Global.Processes
  • CalculatePlan() : Isom.Global.Controller
  • CalculateReversedActionPlan() : Isom.Checkpoint.VehicleRestore
  • CallEdiabas() : Isom.Services.Ediabas
  • CallEdiabasBin() : Isom.Services.Ediabas
  • Cancel() : Isom.Plan.ActionPlan
  • CanRunOnly() : Isom.Plan.TherapyPlanAction
  • CatchLastErrors() : Isom.Sys.ErrorHistory
  • ChangeTherapyDataPath() : Isom.Checkpoint.VehicleRestore
  • ChangeTherapyPlanTargets() : Isom.Checkpoint.VehicleRestore
  • ChangeVehicleOrder() : Isom.Context.FutureVehicleContext
  • CheckAccess() : Isom.Global.Processes
  • CheckCheckpointCompatibilityToCurrentVehicle() : Isom.Checkpoint.CheckpointProcesses
  • CheckForPreservedSession() : Isom.Global.Processes
  • CheckFutureContext() : Isom.Checkpoint.CheckpointProcesses
  • CheckKeyStore() : Isom.Security.SecurityProvider
  • Clear() : Isom.Sys.ErrorHistory , Isom.Context.Dtc
  • ClearDtc() : Isom.Context.Ecu
  • ClearDtcInAllEcus() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • ClearWizard() : Isom.Request.Wizard
  • Clone() : Isom.Base.Version , Isom.Base.UriDictionary , Isom.Base.Uri , Isom.Base.StringList , Isom.Base.StringDictionary , Isom.Base.String , Isom.Base.RegEx , Isom.Base.NumberList , Isom.Base.Number , Isom.Base.Date , Isom.Base.DataList , Isom.Base.Data , Isom.Base.Boolean , Isom.Sys.ClientData , Isom.Sys.Contract , Isom.Sys.ContractList , Isom.Sys.Dealer , Isom.Context.Ecu , Isom.Plan.TherapyPlanAction , Isom.Sys.RuntimeInfo , Isom.Sys.FunctionInfo , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Services.AsamParameter , Isom.Services.EdiabasResultSet , Isom.Services.EdiabasResultSetList , Isom.Services.AsamResponseList , Isom.Services.AsamParameterList , Isom.Security.SecurityProvider , Isom.Request.Button , Isom.Request.ButtonList , Isom.Request.MeasuredValue , Isom.Request.Measurement , Isom.Request.MeasurementList , Isom.Request.MediaElement , Isom.Request.MediaList , Isom.Plan.TherapyPlanActionList , Isom.Plan.TherapyPlan , Isom.Plan.ActionPlanPhase , Isom.Plan.ActionPlan , Isom.Plan.ActivationCode , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfo , Isom.Plan.OrderingInfoList , Isom.Request.MessageElement , Isom.Request.MessageList , Isom.Request.Option , Isom.Request.RadioButton , Isom.Request.SelectionGroup , Isom.Request.SelectionGroupList , Isom.Request.UserRequest , Isom.Request.Wizard , Isom.Reporting.ReportSection , Isom.Reporting.ReportSectionList , Isom.Reporting.Report , Isom.Exchange.DataDescription , Isom.Exchange.DataDescriptionList , Isom.Diagnostics.MeasuredValue , Isom.Diagnostics.Measurement , Isom.Diagnostics.MeasurementList , Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.Dtc , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.VehicleOrder , Isom.Context.FutureVehicleContext , Isom.Context.LogicalUnit , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicle , Isom.Context.LogicalVehicleList , Isom.Checkpoint.VehicleCheckpoint , Isom.Checkpoint.VehicleRestore
  • Close() : Isom.Request.UserRequest
  • CodeWithDefaults() : Isom.Context.Ecu
  • CompareCheckpointEcusToCurrentContextEcus() : Isom.Checkpoint.VehicleRestore
  • Compl() : Isom.Base.Number
  • CompleteTherapyPlan() : Isom.Global.Processes
  • ComputeEcuActionVisibility() : Isom.Context.ContextConfiguration
  • ComputeMenuItemVisibility() : Isom.Context.ContextConfiguration
  • ComputeVehicleActionVisibility() : Isom.Context.ContextConfiguration
  • Concat() : Isom.Base.StringList
  • Contains() : Isom.Base.StringList , Isom.Base.NumberList , Isom.Base.DataList , Isom.Sys.ContractList , Isom.Sys.ErrorList , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Services.AsamParameter , Isom.Services.EdiabasResultSetList , Isom.Services.AsamParameterList , Isom.Request.ButtonList , Isom.Request.Measurement , Isom.Request.MeasurementList , Isom.Request.MediaList , Isom.Plan.TherapyPlanActionList , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfoList , Isom.Request.MessageList , Isom.Request.SelectionGroupList , Isom.Reporting.ReportSectionList , Isom.Exchange.DataDescriptionList , Isom.Diagnostics.Measurement , Isom.Diagnostics.MeasurementList , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.VehicleOrder , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicleList
  • ContainsAction() : Isom.Plan.TherapyPlan
  • ContainsAsyncBlock() : Isom.Plan.ActionPlan
  • ContainsIgnoreCase() : Isom.Base.StringList
  • ContextIdent() : Isom.Global.Processes
  • Count() : Isom.Base.UriDictionary , Isom.Base.StringDictionary , Isom.Context.Dtc
  • Create() : Isom.Base.Data , Isom.Sys.ClientData , Isom.Services.AsamParameter , Isom.Security.SecurityProvider , Isom.Request.UserRequest , Isom.Request.Wizard , Isom.Exchange.DataDescription , Isom.Exchange.DataDescriptionList
  • CreateAction() : Isom.Plan.TherapyPlan
  • CreateActivationCodeList() : Isom.Plan.ActivationCodeList
  • CreateAsamParameter() : Isom.Context.MockupFactory
  • CreateAsamParameterList() : Isom.Services.AsamParameterList , Isom.Context.MockupFactory
  • CreateAsamResponseList() : Isom.Context.MockupFactory
  • CreateButton() : Isom.Request.Button
  • CreateButtonList() : Isom.Request.ButtonList
  • CreateByDtcNumber() : Isom.Context.Dtc
  • CreateCheckBoxes() : Isom.Request.SelectionGroup
  • CreateCheckpoint() : Isom.Checkpoint.CheckpointProcesses
  • CreateClientDataList() : Isom.Sys.ClientDataList
  • CreateComplex() : Isom.Services.AsamParameter
  • CreateContractList() : Isom.Sys.ContractList
  • CreateDataImportActivationCode() : Isom.Request.MessageElement
  • CreateDataImportInput() : Isom.Request.MessageElement
  • CreateDataImportVehicleOrder() : Isom.Request.MessageElement
  • CreateDataList() : Isom.Base.DataList
  • CreateDropDownList() : Isom.Request.SelectionGroup
  • CreateEcu() : Isom.Context.MockupFactory
  • CreateEcuAction() : Isom.Plan.TherapyPlan
  • CreateEcuGroupAction() : Isom.Plan.TherapyPlan
  • CreateEcuList() : Isom.Context.MockupFactory
  • CreateEdiabasResultSetList() : Isom.Context.MockupFactory
  • CreateErrorList() : Isom.Sys.ErrorList
  • CreateEventListener() : Isom.Sys.Events.EventListener
  • CreateFromData() : Isom.Plan.ActivationCode
  • CreateFromXml() : Isom.Base.Data
  • CreateGuard() : Isom.Sys.Events.Guard
  • CreateHeader() : Isom.Sys.Protocol
  • CreateListBox() : Isom.Request.SelectionGroup
  • CreateMeasuredValue() : Isom.Request.MeasuredValue , Isom.Diagnostics.MeasuredValue
  • CreateMeasurement() : Isom.Request.Measurement , Isom.Diagnostics.Measurement
  • CreateMeasurementList() : Isom.Request.MeasurementList , Isom.Diagnostics.MeasurementList
  • CreateMediaElement() : Isom.Request.MediaElement
  • CreateMediaList() : Isom.Request.MediaList
  • CreateMessage() : Isom.Request.MessageElement
  • CreateMessageList() : Isom.Request.MessageList
  • CreateMultiColumnList() : Isom.Request.SelectionGroup
  • CreateMultiColumnOption() : Isom.Request.Option
  • CreateNew() : Isom.Base.Version , Isom.Plan.TherapyPlanActionList , Isom.Plan.OrderingInfo , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.LogicalUnit , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicleList
  • CreateNewByAddress() : Isom.Context.Ecu
  • CreateNewByGroupName() : Isom.Context.Ecu
  • CreateNewForFile() : Isom.Exchange.DataHandle
  • CreateNewForUri() : Isom.Exchange.DataHandle
  • CreateNumberInput() : Isom.Request.MessageElement
  • CreateNumberList() : Isom.Base.NumberList
  • CreateOption() : Isom.Request.Option
  • CreateOrderingAction() : Isom.Plan.TherapyPlan
  • CreateOrderingInfoList() : Isom.Plan.OrderingInfoList
  • CreatePeriodicTimer() : Isom.Sys.Events.PeriodicTimer
  • CreateProtocol() : Isom.Sys.Protocol
  • CreateRadioButtons() : Isom.Request.SelectionGroup
  • CreateReport() : Isom.Reporting.Report
  • CreateReportSection() : Isom.Reporting.Report
  • CreateReportSectionList() : Isom.Reporting.ReportSectionList
  • CreateRequest() : Isom.Request.UserRequest
  • CreateSelectionGroupList() : Isom.Request.SelectionGroupList
  • CreateSimple() : Isom.Services.AsamParameter
  • CreateStringDictionary() : Isom.Base.StringDictionary
  • CreateStringList() : Isom.Base.StringList
  • CreateSubsection() : Isom.Reporting.ReportSection
  • CreateSwtActivationCode() : Isom.Plan.ActivationCode
  • CreateTextInput() : Isom.Request.MessageElement
  • CreateTimer() : Isom.Sys.Events.Timer
  • CreateUriDictionary() : Isom.Base.UriDictionary
  • CreateVehicleOrder() : Isom.Context.MockupFactory
  • CreateWithNamespace() : Isom.Base.Data
  • Current() : Isom.Base.StringList , Isom.Base.NumberList , Isom.Base.DataList , Isom.Sys.ContractList , Isom.Sys.ErrorList , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Services.AsamParameter , Isom.Services.EdiabasResultSetList , Isom.Services.AsamResponseList , Isom.Services.AsamParameterList , Isom.Request.ButtonList , Isom.Request.Measurement , Isom.Request.MeasurementList , Isom.Request.MediaList , Isom.Plan.TherapyPlanActionList , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfoList , Isom.Request.MessageList , Isom.Request.SelectionGroupList , Isom.Context.UserProfileOptionList , Isom.Reporting.ReportSectionList , Isom.Exchange.DataDescriptionList , Isom.Diagnostics.Measurement , Isom.Diagnostics.MeasurementList , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.UserProfileSettingList , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicleList

- D -

  • DefineRegEx() : Isom.Base.RegEx
  • DefineUri() : Isom.Base.Uri
  • DeleteAllDtc() : Isom.Context.Ecu
  • DeleteDtc() : Isom.Context.Ecu
  • DeleteFinalPlan() : Isom.Global.Controller , Isom.Global.Processes
  • DeletePreservedSession() : Isom.Plan.ActionPlan
  • DeployAllVersions() : Isom.Context.Ecu , Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • DeployUserProfile() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • Deselect() : Isom.Request.SelectionGroup
  • Disable() : Isom.Sys.Events.EventListener , Isom.Sys.Events.Guard , Isom.Sys.Events.PeriodicTimer , Isom.Sys.Events.Timer
  • DisableActivationCode() : Isom.Context.Ecu
  • DisableBack() : Isom.Request.Wizard
  • DisableNext() : Isom.Request.Wizard
  • Dispose() : Isom.Sys.Events.EventListener , Isom.Sys.Events.Guard , Isom.Sys.Events.PeriodicTimer , Isom.Sys.Events.Timer , Isom.Request.UserRequest , Isom.Request.Wizard
  • DisposeAll() : Isom.Request.UserRequest
  • Div() : Isom.Base.Number
  • DoCode() : Isom.Global.Processes
  • DoFlash() : Isom.Global.Processes
  • DoMount() : Isom.Global.Processes
  • DoReplace() : Isom.Global.Processes
  • DoTp2Ap() : Isom.Plan.ActionPlan , Isom.Global.Processes
  • DoUnmount() : Isom.Global.Processes

- E -

  • ElapsedTime() : Isom.Base.Date
  • Enable() : Isom.Sys.Events.EventListener , Isom.Sys.Events.Guard , Isom.Sys.Events.PeriodicTimer , Isom.Sys.Events.Timer
  • EnableActivationCode() : Isom.Context.Ecu
  • EnableWizardNext() : Isom.Request.RadioButton
  • EndPlanPhase() : Isom.Global.Processes
  • EnforceExclusive() : Isom.Context.LogicalVehicle
  • Eq() : Isom.Base.Version , Isom.Base.Number
  • Equals() : Isom.Base.String , Isom.Context.VehicleOrder
  • EqualsIgnoreCase() : Isom.Base.String
  • ErasePartial() : Isom.Context.Ecu
  • Error() : Isom.Sys.Log
  • EvaluateCurrentContextEcus() : Isom.Global.Controller
  • EvaluateFutureContext() : Isom.Global.Controller
  • EvaluateModelSeries() : Isom.Global.Controller
  • EvaluateTerm() : Isom.Context.VehicleOrder
  • EvaluateVehicleData() : Isom.Global.Controller
  • Execute() : Isom.Services.Asam
  • ExecuteActionPlan() : Isom.Plan.ActionPlan , Isom.Global.Processes
  • ExecuteImmediate() : Isom.Plan.TherapyPlanAction
  • ExecuteOnEcu() : Isom.Services.Asam
  • ExportTherapyData() : Isom.Checkpoint.VehicleCheckpoint

- F -

  • Failed() : Isom.Base.Boolean
  • Fatal() : Isom.Sys.Log
  • Filter() : Isom.Context.EcuList
  • FilterByBaseVariant() : Isom.Context.EcuList
  • FilterByEcuAddress() : Isom.Context.EcuList
  • FilterByGroupName() : Isom.Context.EcuList
  • FilterByProp() : Isom.Context.DtcList
  • FilterByState() : Isom.Context.EcuList
  • FinalizeSession() : Isom.Context.ContextConfiguration
  • Find() : Isom.Sys.ErrorList
  • FindByBaseVariant() : Isom.Context.EcuList
  • FindByEcuAddress() : Isom.Context.EcuList
  • FindByGroupName() : Isom.Context.EcuList
  • FindByKey() : Isom.Request.ButtonList , Isom.Request.Measurement , Isom.Request.MeasurementList , Isom.Request.MediaList , Isom.Request.MessageList , Isom.Request.SelectionGroupList , Isom.Reporting.ReportSectionList , Isom.Diagnostics.Measurement , Isom.Diagnostics.MeasurementList
  • FindByName() : Isom.Context.LogicalVehicleList
  • FindByType() : Isom.Exchange.DataDescriptionList
  • FindElements() : Isom.Base.Data
  • FindEventListener() : Isom.Sys.Events.EventListener
  • FindFirst() : Isom.Base.String
  • FindGuard() : Isom.Sys.Events.Guard
  • FindModelSeries() : Isom.Context.ContextConfiguration
  • FindPeriodicTimer() : Isom.Sys.Events.PeriodicTimer
  • FindResult() : Isom.Services.EdiabasResultSetList
  • FindTimer() : Isom.Sys.Events.Timer
  • FinishPlan() : Isom.Global.Processes
  • FlashComfort() : Isom.Context.Ecu
  • FlashForced() : Isom.Context.Ecu
  • FlashPartial() : Isom.Context.Ecu
  • Floor() : Isom.Base.Number
  • FromBytes() : Isom.Base.String

- G -

  • Ge() : Isom.Base.Number
  • GenerateKey() : Isom.Security.SecurityProvider
  • GeneratePlan() : Isom.Global.Processes , Isom.Context.FutureVehicleContext
  • Get() : Isom.Base.UriDictionary , Isom.Base.StringDictionary , Isom.Services.AsamParameter , Isom.Services.EdiabasResultSet , Isom.Services.AsamParameterList , Isom.Context.Dtc
  • GetAction() : Isom.Sys.Error , Isom.Sys.Events.EventInfo , Isom.Sys.Events.GuardInfo , Isom.Sys.Events.TimerInfo , Isom.Request.UserRequest
  • GetActionList() : Isom.Plan.ActionPlanPhase
  • GetActionPlanGroup() : Isom.Plan.TherapyPlanAction , Isom.Plan.ActionPlanPhase
  • GetActions() : Isom.Plan.TherapyPlan
  • GetActionText() : Isom.Plan.TherapyPlanAction
  • GetActivationCode() : Isom.Plan.TherapyPlanAction
  • GetActivationCodes() : Isom.Context.Ecu
  • GetActiveClients() : Isom.Sys.SessionContext
  • GetAllClients() : Isom.Sys.SessionContext
  • GetAllEnvironmentVars() : Isom.Context.Environment
  • GetAllErrors() : Isom.Sys.ErrorHistory
  • GetAllMessages() : Isom.Plan.TherapyPlan
  • GetAllPropertyNames() : Isom.Context.Ecu , Isom.Plan.ActionPlan
  • GetAllSettings() : Isom.Context.UserProfile
  • GetApplicationNumber() : Isom.Plan.ActivationCode
  • GetArchiveName() : Isom.Sys.Protocol
  • GetAreaOfVehicleSystemForDtcNumber() : Isom.Context.Dtc
  • GetAsciiArt() : Isom.Reporting.Report
  • GetAssemblingChildren() : Isom.Context.Ecu
  • GetAssemblingParent() : Isom.Context.Ecu
  • GetAssignment() : Isom.Context.UserProfileSetting
  • GetAttribute() : Isom.Base.Data
  • GetAttributes() : Isom.Base.Data
  • GetBaseVariant() : Isom.Context.Ecu
  • GetBatteryVoltage() : Isom.Context.CurrentVehicleContext , Isom.Context.Environment
  • GetBoolean() : Isom.Request.Wizard
  • GetBrand() : Isom.Sys.Contract
  • GetBuild() : Isom.Base.Version
  • GetBuildVersion() : Isom.Context.CurrentVehicleContext
  • GetBusinessHours() : Isom.Sys.SystemInfo
  • GetBusinessRelationship() : Isom.Sys.Dealer
  • GetButtons() : Isom.Request.UserRequest
  • GetCallProfile() : Isom.Sys.RuntimeInfo
  • GetCategory() : Isom.Context.LogicalUnit
  • GetCertificate() : Isom.Plan.ActivationCode
  • GetChannels() : Isom.Plan.ActionPlanPhase
  • GetChecksum() : Isom.Base.Uri
  • GetCodeData() : Isom.Plan.ActivationCode
  • GetCodingNames() : Isom.Context.Ecu
  • GetCodingSequence() : Isom.Context.Ecu
  • GetComment() : Isom.Plan.TherapyPlanAction
  • GetComponentName() : Isom.Sys.FunctionInfo
  • GetConnectedBuses() : Isom.Context.Ecu
  • GetContentDialog() : Isom.Request.Wizard
  • GetContentTitle() : Isom.Request.Wizard
  • GetContinueOnError() : Isom.Plan.TherapyPlanAction
  • GetContinueWithEcuOnError() : Isom.Plan.TherapyPlanAction
  • GetContractList() : Isom.Sys.Dealer
  • GetContractType() : Isom.Sys.Contract
  • GetCount() : Isom.Sys.FunctionInfo
  • GetCurrentActionChannel() : Isom.Plan.ActionPlan
  • GetCurrentUserProfileClone() : Isom.Context.LogicalVehicle
  • GetCurrentVciFirmwareVersion() : Isom.Context.Environment
  • GetCurrentVersion() : Isom.Context.CurrentVehicleContext
  • GetDataHandle() : Isom.Base.Data
  • GetDataImportIndex() : Isom.Request.MessageElement
  • GetDataImportIndicesKeys() : Isom.Request.MessageElement
  • GetDataIntegrationLevel() : Isom.Context.ContextConfiguration
  • GetDataSources() : Isom.Services.DataProcurement
  • GetDataType() : Isom.Services.AsamParameter , Isom.Exchange.DataDescription
  • GetDate() : Isom.Reporting.ReportSection
  • GetDealer() : Isom.Sys.SystemInfo
  • GetDeclinedActions() : Isom.Plan.TherapyPlan
  • GetDefaultLChannels() : Isom.Context.ContextConfiguration
  • GetDependantActionsToRefilter() : Isom.Plan.TherapyPlanAction
  • GetDependantActionsToRemove() : Isom.Plan.TherapyPlanAction
  • GetDependentActions() : Isom.Plan.TherapyPlanAction
  • GetDescription() : Isom.Sys.Error , Isom.Request.Wizard
  • GetDescriptionTitle() : Isom.Request.Wizard
  • GetDeviceType() : Isom.Sys.SystemInfo
  • GetDiagName() : Isom.Context.Ecu
  • GetDisplayName() : Isom.Context.Ecu
  • GetDisplayProp() : Isom.Context.Ecu , Isom.Plan.TherapyPlanAction , Isom.Reporting.ReportSection , Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext , Isom.Context.LogicalVehicle
  • GetDisplayPropNames() : Isom.Context.Ecu , Isom.Plan.TherapyPlanAction , Isom.Reporting.ReportSection , Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext , Isom.Context.LogicalVehicle
  • GetDisplayState() : Isom.Plan.TherapyPlanAction
  • GetDisplayType() : Isom.Request.Measurement , Isom.Diagnostics.Measurement
  • GetDistributionPartnerNumber() : Isom.Sys.Dealer
  • GetDtc() : Isom.Context.Ecu
  • GetDtcIdentifiers() : Isom.Context.Ecu
  • GetDtcNumber() : Isom.Context.Dtc
  • GetEcu() : Isom.Plan.TherapyPlanAction , Isom.Sys.Error , Isom.Request.UserRequest , Isom.Reporting.ReportSection
  • GetEcuAddress() : Isom.Context.Ecu
  • GetEcus() : Isom.Context.CurrentVehicleContext , Isom.Context.Dtc , Isom.Context.DtcList , Isom.Context.FutureVehicleContext , Isom.Context.LogicalVehicle
  • GetEcusByBus() : Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext
  • GetEcuText() : Isom.Context.Ecu
  • GetEditableActions() : Isom.Context.Ecu , Isom.Plan.TherapyPlan
  • GetElementKeysByType() : Isom.Reporting.ReportSection
  • GetElements() : Isom.Base.Data
  • GetEndContractDate() : Isom.Sys.Contract
  • GetEnvironmentVar() : Isom.Context.Environment
  • GetError() : Isom.Reporting.ReportSection
  • GetErrorText() : Isom.Sys.Error
  • GetErrorValue() : Isom.Sys.Error
  • GetEstimatedRuntime() : Isom.Plan.TherapyPlanAction , Isom.Plan.ActionPlan
  • GetEventData() : Isom.Sys.Events.EventInfo , Isom.Sys.Events.GuardInfo , Isom.Sys.Events.TimerInfo
  • GetEventName() : Isom.Sys.Events.EventInfo
  • GetExecutedByIsom() : Isom.Plan.TherapyPlanAction
  • GetExecutionTime() : Isom.Sys.FunctionInfo
  • GetExistingGlobals() : Isom.Base.StringList , Isom.Base.String , Isom.Base.Number , Isom.Base.Data
  • GetExistingReports() : Isom.Reporting.Report
  • GetExpectedEcus() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • GetFileName() : Isom.Sys.Protocol
  • GetFilterChainActions() : Isom.Plan.TherapyPlan
  • GetFinishTime() : Isom.Plan.TherapyPlanAction
  • GetFlashFlags() : Isom.Plan.TherapyPlanAction
  • GetFragment() : Isom.Base.Uri
  • GetFreezeFrameConditions() : Isom.Context.Dtc
  • GetFullName() : Isom.Sys.Error
  • GetFunctionName() : Isom.Sys.FunctionInfo
  • GetFutureContext() : Isom.Global.Processes
  • GetFutureUserProfile() : Isom.Context.LogicalVehicle
  • GetGatewayByBus() : Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext
  • GetGlobal() : Isom.Base.StringList , Isom.Base.String , Isom.Base.Number , Isom.Base.Data
  • GetGroupName() : Isom.Context.Ecu
  • GetHeader() : Isom.Sys.Protocol
  • GetHeading() : Isom.Request.Measurement , Isom.Request.SelectionGroup , Isom.Diagnostics.Measurement
  • GetHelp() : Isom.Request.Wizard
  • GetHelpTitle() : Isom.Request.Wizard
  • GetHint() : Isom.Sys.Events.EventInfo , Isom.Sys.Events.GuardInfo , Isom.Sys.Events.TimerInfo , Isom.Plan.OrderingInfo , Isom.Request.RadioButton
  • GetHistoricalVersion() : Isom.Context.CurrentVehicleContext
  • GetHost() : Isom.Base.Uri
  • GetId() : Isom.Security.SecurityProvider , Isom.Request.UserRequest
  • GetIgnitionVoltage() : Isom.Context.CurrentVehicleContext , Isom.Context.Environment
  • GetImportURI() : Isom.Context.VehicleOrder
  • GetIndices() : Isom.Exchange.DataDescription
  • GetInstance() : Isom.Sys.SessionContext , Isom.Services.ServiceManager , Isom.Plan.TherapyPlan , Isom.Plan.ActionPlan , Isom.Global.Config , Isom.Global.Controller , Isom.Exchange.DataExchange , Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.Environment , Isom.Context.FutureVehicleContext , Isom.Checkpoint.VehicleCheckpoint , Isom.Checkpoint.VehicleRestore
  • GetInstructionCounter() : Isom.Sys.SystemInfo , Isom.Sys.RuntimeInfo , Isom.Sys.FunctionInfo
  • GetInternationalDealerNumber() : Isom.Sys.Contract
  • GetIsControlling() : Isom.Sys.ClientData
  • GetIsomExecutionTime() : Isom.Sys.RuntimeInfo
  • GetIsomlNodeCounter() : Isom.Sys.SystemInfo
  • GetKey() : Isom.Request.Button , Isom.Request.MeasuredValue , Isom.Request.Measurement , Isom.Request.MediaElement , Isom.Request.MessageElement , Isom.Request.Option , Isom.Request.RadioButton , Isom.Request.SelectionGroup , Isom.Request.Wizard , Isom.Reporting.ReportSection , Isom.Diagnostics.MeasuredValue , Isom.Diagnostics.Measurement , Isom.Context.LogicalUnit
  • GetKeys() : Isom.Base.UriDictionary , Isom.Base.StringDictionary , Isom.Context.Dtc
  • GetLabelButtonBack() : Isom.Request.Wizard
  • GetLabelButtonDone() : Isom.Request.Wizard
  • GetLabelButtonNext() : Isom.Request.Wizard
  • GetLabelButtonQuit() : Isom.Request.Wizard
  • GetLanguage() : Isom.Sys.SystemInfo
  • GetLastErrors() : Isom.Sys.ErrorHistory
  • GetLastRuntimeInfo() : Isom.Sys.SystemInfo
  • GetLatestVciFirmwareVersion() : Isom.Context.Environment
  • GetLayoutType() : Isom.Request.UserRequest , Isom.Request.Wizard
  • GetLocalBrand() : Isom.Sys.SystemInfo
  • GetLogicalUnits() : Isom.Context.Ecu , Isom.Plan.TherapyPlanAction
  • GetLogicalVehicle() : Isom.Context.Ecu
  • GetLogicalVehicles() : Isom.Plan.TherapyPlanAction , Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext
  • GetMajor() : Isom.Base.Version
  • GetMax() : Isom.Request.MeasuredValue , Isom.Diagnostics.MeasuredValue
  • GetMeasurement() : Isom.Request.Wizard
  • GetMeasurements() : Isom.Request.UserRequest
  • GetMedia() : Isom.Request.UserRequest , Isom.Request.Wizard
  • GetMediaElement() : Isom.Reporting.ReportSection
  • GetMediaTitle() : Isom.Request.Wizard
  • GetMedium() : Isom.Plan.OrderingInfo
  • GetMediumDescription() : Isom.Plan.OrderingInfo
  • GetMemoryUsage() : Isom.Sys.SystemInfo
  • GetMessage() : Isom.Request.RadioButton , Isom.Request.Wizard
  • GetMessages() : Isom.Request.UserRequest
  • GetMin() : Isom.Request.MeasuredValue , Isom.Diagnostics.MeasuredValue
  • GetMinor() : Isom.Base.Version
  • GetMissingFiles() : Isom.Plan.TherapyPlanAction , Isom.Plan.TherapyPlan
  • GetMissingIdPaths() : Isom.Reporting.Report
  • GetModelSeries() : Isom.Context.ContextConfiguration , Isom.Context.VehicleOrder
  • GetModelSeriesGroup() : Isom.Context.ContextConfiguration
  • GetModelSeriesRevision() : Isom.Context.ContextConfiguration
  • GetName() : Isom.Sys.ClientData , Isom.Plan.TherapyPlanAction , Isom.Sys.Events.Guard , Isom.Services.AsamParameter , Isom.Context.UserProfileOption , Isom.Context.UserProfileSetting , Isom.Context.LogicalVehicle
  • GetNetworkInfo() : Isom.Sys.SystemInfo
  • GetNext() : Isom.Request.Wizard
  • GetNumber() : Isom.Request.Wizard
  • GetObservedVariable() : Isom.Sys.Events.Guard
  • GetOdometerUnit() : Isom.Context.CurrentVehicleContext
  • GetOdometerValue() : Isom.Context.CurrentVehicleContext
  • GetOem() : Isom.Context.ContextConfiguration
  • GetOemFormat() : Isom.Context.VehicleOrder
  • GetOemVersion() : Isom.Sys.VersionInfo
  • GetOperationMode() : Isom.Global.Config , Isom.Context.Environment
  • GetOptions() : Isom.Context.UserProfileSetting
  • GetOrderingInfo() : Isom.Context.LogicalUnit
  • GetOrderingInfoList() : Isom.Plan.TherapyPlanAction
  • GetOrderNumber() : Isom.Plan.OrderingInfo
  • GetOrderType() : Isom.Context.Ecu
  • GetPath() : Isom.Base.Uri , Isom.Request.MediaElement
  • GetPerformanceSnapshot() : Isom.Sys.SystemInfo
  • GetPeriod() : Isom.Sys.Events.Guard
  • GetPhase() : Isom.Plan.TherapyPlanAction , Isom.Plan.ActionPlan
  • GetPhases() : Isom.Plan.ActionPlan
  • GetPort() : Isom.Base.Uri
  • GetPossibleAssemblingChildren() : Isom.Context.Ecu
  • GetPossibleAssemblingParents() : Isom.Context.Ecu
  • GetPossibleDtc() : Isom.Context.Dtc
  • GetPossibleInterfaces() : Isom.Context.ContextConfiguration
  • GetPossibleLChannels() : Isom.Context.Ecu , Isom.Plan.TherapyPlanAction
  • GetPossibleLogicalVehicles() : Isom.Context.LogicalVehicle
  • GetPossibleNChannels() : Isom.Context.ContextConfiguration
  • GetPossibleTargetVersions() : Isom.Context.FutureVehicleContext , Isom.Context.LogicalVehicle
  • GetPossibleVariants() : Isom.Context.Ecu
  • GetPostCodingDelay() : Isom.Context.Ecu
  • GetPreservedSessionVersion() : Isom.Plan.ActionPlan
  • GetPreviousOemVersion() : Isom.Context.CurrentVehicleContext
  • GetPreviousStep() : Isom.Request.Wizard
  • GetPrimaryBus() : Isom.Context.Ecu
  • GetPriority() : Isom.Plan.TherapyPlanAction
  • GetProcessedRuntime() : Isom.Plan.TherapyPlanAction , Isom.Plan.ActionPlan
  • GetProcessState() : Isom.Global.Controller
  • GetProduct() : Isom.Sys.Contract
  • GetProductVersion() : Isom.Sys.VersionInfo
  • GetProp() : Isom.Context.Ecu , Isom.Plan.TherapyPlanAction , Isom.Security.SecurityProvider , Isom.Plan.ActionPlan , Isom.Plan.ActivationCode , Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext , Isom.Context.LogicalUnit , Isom.Context.LogicalVehicle
  • GetProperties() : Isom.Services.DataProcurement , Isom.Context.VehicleOrder
  • GetPropertiesKeys() : Isom.Context.VehicleOrder
  • GetPropNames() : Isom.Context.Ecu , Isom.Plan.TherapyPlanAction , Isom.Security.SecurityProvider , Isom.Plan.ActionPlan , Isom.Plan.ActivationCode , Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext , Isom.Context.LogicalUnit , Isom.Context.LogicalVehicle
  • GetProtocol() : Isom.Context.Ecu
  • GetProvider() : Isom.Security.SecurityProvider
  • GetQuery() : Isom.Base.Uri
  • GetQuit() : Isom.Request.Wizard
  • GetRadioButton() : Isom.Request.Wizard
  • GetReasonForFailedDependency() : Isom.Plan.TherapyPlanAction
  • GetReport() : Isom.Reporting.Report
  • GetReportSection() : Isom.Reporting.Report
  • GetReportSectionList() : Isom.Reporting.ReportSection , Isom.Reporting.Report
  • GetRequest() : Isom.Request.UserRequest
  • GetRequestResults() : Isom.Request.UserRequest
  • GetResults() : Isom.Services.EdiabasResultSet
  • GetResultSet() : Isom.Services.EdiabasResultSetList
  • GetRevision() : Isom.Base.Version
  • GetRole() : Isom.Sys.ClientData
  • GetScheme() : Isom.Base.Uri
  • GetSelectedButton() : Isom.Request.UserRequest , Isom.Request.Wizard
  • GetSelectedKeys() : Isom.Request.SelectionGroup
  • GetSelectedRadioButton() : Isom.Request.Wizard
  • GetSelectedTexts() : Isom.Request.SelectionGroup
  • GetSelectionGroups() : Isom.Request.UserRequest
  • GetSequence() : Isom.Plan.TherapyPlanAction
  • GetServicesExecutionTime() : Isom.Sys.RuntimeInfo
  • GetSessionId() : Isom.Sys.SessionContext
  • GetSessionList() : Isom.Sys.SessionContext
  • GetSessionName() : Isom.Sys.SessionContext , Isom.Context.ContextConfiguration
  • GetSessionRemark() : Isom.Context.ContextConfiguration
  • GetSettings() : Isom.Sys.ClientData , Isom.Sys.SessionContext
  • GetSettingsByAssignment() : Isom.Context.UserProfile
  • GetSoftwareVersionEcus() : Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext , Isom.Context.LogicalVehicle
  • GetSpecialFunctionEcus() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • GetStandardisationForDtcNumber() : Isom.Context.Dtc
  • GetStartDate() : Isom.Sys.Contract
  • GetStartTime() : Isom.Plan.TherapyPlanAction
  • GetState() : Isom.Plan.ActivationCode
  • GetStates() : Isom.Context.Ecu , Isom.Plan.TherapyPlanAction , Isom.Context.LogicalUnit
  • GetString() : Isom.Request.Wizard
  • GetSubsection() : Isom.Reporting.ReportSection
  • GetSuggestions() : Isom.Request.MessageElement
  • GetSupportedDataTypes() : Isom.Exchange.DataExchange
  • GetSystemCategoryForDtcNumber() : Isom.Context.Dtc
  • GetTargetVersion() : Isom.Context.FutureVehicleContext , Isom.Context.LogicalVehicle
  • GetText() : Isom.Base.Data , Isom.Request.Button , Isom.Request.MessageElement , Isom.Request.Option , Isom.Reporting.ReportSection
  • GetTextCategory() : Isom.Base.String
  • GetTextId() : Isom.Base.String
  • GetTextInput() : Isom.Request.Wizard
  • GetTherapyPlanAction() : Isom.Reporting.ReportSection
  • GetTimer() : Isom.Request.UserRequest
  • GetTitle() : Isom.Request.UserRequest , Isom.Request.Wizard
  • GetTotalExecutionTime() : Isom.Sys.RuntimeInfo
  • GetUnit() : Isom.Request.MeasuredValue , Isom.Diagnostics.MeasuredValue
  • GetUpdateFunction() : Isom.Request.Wizard
  • GetUpgradeIndex() : Isom.Plan.ActivationCode
  • GetUrisFromAsamParameter() : Isom.Context.MockupFactory
  • GetUrisFromAsamParameterList() : Isom.Context.MockupFactory
  • GetUrisFromAsamResponseList() : Isom.Context.MockupFactory
  • GetUrisFromEcu() : Isom.Context.MockupFactory
  • GetUrisFromEcuList() : Isom.Context.MockupFactory
  • GetUrisFromEdiabasResultSetList() : Isom.Context.MockupFactory
  • GetUrisFromVehicleOrder() : Isom.Context.MockupFactory
  • GetUserInfo() : Isom.Base.Uri , Isom.Sys.SystemInfo
  • GetUserProfile() : Isom.Context.FutureVehicleContext
  • GetUserProfileClone() : Isom.Context.CurrentVehicleContext
  • GetUserProfileSetting() : Isom.Reporting.ReportSection
  • GetValue() : Isom.Services.AsamParameter , Isom.Request.MeasuredValue , Isom.Request.MessageElement , Isom.Diagnostics.MeasuredValue
  • GetVariableName() : Isom.Sys.Events.GuardInfo
  • GetVciChannelCount() : Isom.Context.Environment
  • GetVciChannelData() : Isom.Context.Environment
  • GetVciConnectionQuality() : Isom.Context.Environment
  • GetVciConnectionType() : Isom.Context.Environment
  • GetVciGateway() : Isom.Context.Environment
  • GetVciIp() : Isom.Context.Environment
  • GetVciMac() : Isom.Context.Environment
  • GetVciName() : Isom.Context.Environment
  • GetVciNetmask() : Isom.Context.Environment
  • GetVciState() : Isom.Context.Environment
  • GetVehicleConfigurationEcus() : Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext , Isom.Context.LogicalVehicle
  • GetVehicleGeneration() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • GetVehicleIdentificationNumber() : Isom.Context.CurrentVehicleContext , Isom.Checkpoint.VehicleRestore
  • GetVehicleInterface() : Isom.Context.ContextConfiguration
  • GetVehicleOrder() : Isom.Checkpoint.VehicleRestore
  • GetVehicleOrderClone() : Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext
  • GetVehiclePreparationState() : Isom.Context.Environment
  • GetVersion() : Isom.Context.LogicalUnit
  • GetVin17() : Isom.Context.ContextConfiguration
  • GetVinEcus() : Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext , Isom.Context.LogicalVehicle
  • GetWizard() : Isom.Request.Wizard
  • GetWizardNext() : Isom.Request.RadioButton
  • Gt() : Isom.Base.Version , Isom.Base.Number

- H -

  • HasNext() : Isom.Base.StringList , Isom.Base.NumberList , Isom.Base.DataList , Isom.Sys.ContractList , Isom.Sys.ErrorList , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Services.AsamParameter , Isom.Services.EdiabasResultSetList , Isom.Services.AsamResponseList , Isom.Services.AsamParameterList , Isom.Request.ButtonList , Isom.Request.Measurement , Isom.Request.MeasurementList , Isom.Request.MediaList , Isom.Plan.TherapyPlanActionList , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfoList , Isom.Request.MessageList , Isom.Request.SelectionGroupList , Isom.Context.UserProfileOptionList , Isom.Reporting.ReportSectionList , Isom.Exchange.DataDescriptionList , Isom.Diagnostics.Measurement , Isom.Diagnostics.MeasurementList , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.UserProfileSettingList , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicleList

- I -

  • Identify() : Isom.Context.Ecu
  • IdentifyAllEcus() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • ImportVehicleOrder() : Isom.Context.CurrentVehicleContext
  • Info() : Isom.Sys.Log
  • Insert() : Isom.Base.StringList , Isom.Base.NumberList , Isom.Base.DataList , Isom.Sys.ContractList , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Services.AsamParameter , Isom.Services.AsamParameterList , Isom.Plan.TherapyPlanActionList , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfoList , Isom.Reporting.ReportSectionList , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicleList
  • InvalidateProp() : Isom.Context.Ecu , Isom.Plan.ActivationCode , Isom.Context.LogicalUnit
  • IsActionPlanRestarting() : Isom.Plan.ActionPlan
  • IsAdmissible() : Isom.Sys.Dealer
  • IsAvailable() : Isom.Plan.ActivationCode
  • IsCodeable() : Isom.Context.Ecu
  • IsComplex() : Isom.Services.AsamParameter
  • IsCurrent() : Isom.Context.UserProfileOption
  • IsDefault() : Isom.Context.UserProfileOption
  • IsDefinedType() : Isom.Exchange.DataDescriptionList
  • IsElapsed() : Isom.Request.UserRequest
  • IsEmpty() : Isom.Base.StringList , Isom.Base.NumberList , Isom.Base.DataList , Isom.Sys.ContractList , Isom.Sys.ErrorList , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Services.AsamParameter , Isom.Services.EdiabasResultSetList , Isom.Services.AsamResponseList , Isom.Services.AsamParameterList , Isom.Request.ButtonList , Isom.Request.Measurement , Isom.Request.MeasurementList , Isom.Request.MediaList , Isom.Plan.TherapyPlanActionList , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfoList , Isom.Request.MessageList , Isom.Request.SelectionGroupList , Isom.Context.UserProfileOptionList , Isom.Reporting.ReportSectionList , Isom.Exchange.DataDescriptionList , Isom.Diagnostics.Measurement , Isom.Diagnostics.MeasurementList , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.UserProfileSettingList , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicleList
  • IsExclusive() : Isom.Request.SelectionGroup
  • IsFlashable() : Isom.Context.Ecu
  • IsInOperationMode() : Isom.Global.Config
  • IsInsertable() : Isom.Plan.TherapyPlanAction
  • IsInState() : Isom.Context.Ecu , Isom.Context.LogicalUnit
  • IsLogisticsConsistent() : Isom.Plan.TherapyPlanAction , Isom.Plan.TherapyPlan
  • IsMatch() : Isom.Base.RegEx
  • IsMockAsamParameterListOf() : Isom.Context.MockupFactory
  • IsMockAsamParameterOf() : Isom.Context.MockupFactory
  • IsMockAsamResponseListOf() : Isom.Context.MockupFactory
  • IsMockEcuListOf() : Isom.Context.MockupFactory
  • IsMockEcuOf() : Isom.Context.MockupFactory
  • IsMockEdiabasResultSetListOf() : Isom.Context.MockupFactory
  • IsMockVehicleOrderOf() : Isom.Context.MockupFactory
  • IsPlanned() : Isom.Plan.TherapyPlanAction
  • IsPublished() : Isom.Reporting.Report
  • IsRemoveable() : Isom.Plan.TherapyPlanAction
  • IsRequired() : Isom.Exchange.DataDescription
  • IsRouter() : Isom.Context.Ecu
  • IsTherapyPlanEmpty() : Isom.Checkpoint.CheckpointProcesses
  • IsValid() : Isom.Base.Data , Isom.Context.VehicleOrder
  • IsVirtual() : Isom.Plan.TherapyPlanAction
  • IsVisited() : Isom.Request.Wizard
  • IsVoid() : Isom.Base.Version , Isom.Base.UriDictionary , Isom.Base.Uri , Isom.Base.StringList , Isom.Base.StringDictionary , Isom.Base.String , Isom.Base.RegEx , Isom.Base.NumberList , Isom.Base.Number , Isom.Base.Date , Isom.Base.DataList , Isom.Base.Data , Isom.Base.Boolean , Isom.Sys.ClientData , Isom.Sys.Contract , Isom.Sys.ContractList , Isom.Sys.Dealer , Isom.Context.Ecu , Isom.Plan.TherapyPlanAction , Isom.Sys.Error , Isom.Sys.ErrorList , Isom.Sys.SessionContext , Isom.Sys.RuntimeInfo , Isom.Sys.FunctionInfo , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Sys.Events.EventInfo , Isom.Sys.Events.EventListener , Isom.Sys.Events.Guard , Isom.Sys.Events.GuardInfo , Isom.Sys.Events.PeriodicTimer , Isom.Sys.Events.Timer , Isom.Sys.Events.TimerInfo , Isom.Services.AsamParameter , Isom.Services.EdiabasResultSet , Isom.Services.EdiabasResultSetList , Isom.Services.AsamResponseList , Isom.Services.AsamParameterList , Isom.Security.SecurityProvider , Isom.Request.Button , Isom.Request.ButtonList , Isom.Request.MeasuredValue , Isom.Request.Measurement , Isom.Request.MeasurementList , Isom.Request.MediaElement , Isom.Request.MediaList , Isom.Plan.TherapyPlanActionList , Isom.Plan.TherapyPlan , Isom.Plan.ActionPlanPhase , Isom.Plan.ActionPlan , Isom.Plan.ActivationCode , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfo , Isom.Plan.OrderingInfoList , Isom.Request.MessageElement , Isom.Request.MessageList , Isom.Request.Option , Isom.Request.RadioButton , Isom.Request.SelectionGroup , Isom.Request.SelectionGroupList , Isom.Request.UserRequest , Isom.Request.Wizard , Isom.Context.UserProfileOption , Isom.Context.UserProfileOptionList , Isom.Context.UserProfileSetting , Isom.Reporting.ReportSection , Isom.Reporting.ReportSectionList , Isom.Reporting.Report , Isom.Global.Controller , Isom.Exchange.DataDescription , Isom.Exchange.DataHandle , Isom.Exchange.DataExchange , Isom.Exchange.DataDescriptionList , Isom.Diagnostics.MeasuredValue , Isom.Diagnostics.Measurement , Isom.Diagnostics.MeasurementList , Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.Dtc , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.Environment , Isom.Context.VehicleOrder , Isom.Context.UserProfileSettingList , Isom.Context.UserProfile , Isom.Context.FutureVehicleContext , Isom.Context.LogicalUnit , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicle , Isom.Context.LogicalVehicleList , Isom.Checkpoint.VehicleCheckpoint , Isom.Checkpoint.VehicleRestore

- L -

  • Le() : Isom.Base.Number
  • Length() : Isom.Base.StringList , Isom.Base.String , Isom.Base.NumberList , Isom.Base.DataList , Isom.Sys.ContractList , Isom.Sys.ErrorList , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Services.AsamParameter , Isom.Services.EdiabasResultSetList , Isom.Services.AsamResponseList , Isom.Services.AsamParameterList , Isom.Request.ButtonList , Isom.Request.Measurement , Isom.Request.MeasurementList , Isom.Request.MediaList , Isom.Plan.TherapyPlanActionList , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfoList , Isom.Request.MessageList , Isom.Request.SelectionGroupList , Isom.Context.UserProfileOptionList , Isom.Reporting.ReportSectionList , Isom.Exchange.DataDescriptionList , Isom.Diagnostics.Measurement , Isom.Diagnostics.MeasurementList , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.UserProfileSettingList , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicleList
  • Load() : Isom.Exchange.DataExchange
  • LoadCheckpoint() : Isom.Checkpoint.VehicleRestore
  • LoadDictionary() : Isom.Exchange.DataExchange
  • LoadText() : Isom.Base.Data
  • LoadXml() : Isom.Base.Data
  • Lookup() : Isom.Exchange.DataExchange
  • Lt() : Isom.Base.Version , Isom.Base.Number

- M -

  • Matches() : Isom.Base.RegEx
  • Mod() : Isom.Base.Number
  • Mul() : Isom.Base.Number

- N -

  • Ne() : Isom.Base.Number
  • Next() : Isom.Base.StringList , Isom.Base.NumberList , Isom.Base.DataList , Isom.Sys.ContractList , Isom.Sys.ErrorList , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Services.AsamParameter , Isom.Services.EdiabasResultSetList , Isom.Services.AsamResponseList , Isom.Services.AsamParameterList , Isom.Request.ButtonList , Isom.Request.Measurement , Isom.Request.MeasurementList , Isom.Request.MediaList , Isom.Plan.TherapyPlanActionList , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfoList , Isom.Request.MessageList , Isom.Request.SelectionGroupList , Isom.Context.UserProfileOptionList , Isom.Reporting.ReportSectionList , Isom.Exchange.DataDescriptionList , Isom.Diagnostics.Measurement , Isom.Diagnostics.MeasurementList , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.UserProfileSettingList , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicleList
  • Normalize() : Isom.Context.VehicleOrder
  • Not() : Isom.Base.Boolean
  • Notify() : Isom.Sys.Error
  • Now() : Isom.Base.Date

- O -

  • OnAsyncActionFinished() : Isom.Global.Processes
  • OnAsyncActionStarting() : Isom.Global.Processes
  • OnAsyncPhaseHalted() : Isom.Global.Processes
  • OnClientListChanged() : Isom.Global.Processes
  • OnIsomStarting() : Isom.Global.Processes
  • OnIsomStopping() : Isom.Global.Processes
  • OnLogicalVehicleChanged() : Isom.Global.Processes
  • OnRestartTherapySession() : Isom.Global.Processes
  • OnSessionListChanged() : Isom.Global.Processes
  • OnUserProfileChanged() : Isom.Global.Processes
  • Or() : Isom.Base.Number , Isom.Base.Boolean

- P -

  • Parse() : Isom.Base.Version , Isom.Base.Date
  • ParseFormatted() : Isom.Base.Date
  • ParseHexNumber() : Isom.Base.String
  • ParseLocalTime() : Isom.Base.Date
  • ParseNumber() : Isom.Base.String
  • Pause() : Isom.Plan.ActionPlan
  • PerformActionPlan() : Isom.Global.Controller
  • PrepareActionPlan() : Isom.Global.Controller
  • PreparePlan() : Isom.Global.Processes
  • PreservedSessionExists() : Isom.Plan.ActionPlan
  • PreserveSession() : Isom.Plan.ActionPlan
  • PrintRet() : Isom.Checkpoint.CheckpointProcesses
  • ProvideKeyStoreData() : Isom.Security.SecurityProvider
  • Publish() : Isom.Reporting.Report
  • Purge() : Isom.Plan.TherapyPlanAction

- Q -

  • Query() : Isom.Base.Data , Isom.Services.DataProcurement
  • QueryLogistics() : Isom.Context.Ecu

- R -

  • RaiseEvent() : Isom.Sys.Events.Event
  • ReadDetails() : Isom.Context.Dtc
  • ReadDtc() : Isom.Context.Ecu
  • ReadDtcFromAllEcus() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • ReadOdometerFromEcus() : Isom.Context.CurrentVehicleContext
  • ReadUserProfile() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • ReadVehicleOrder() : Isom.Context.Ecu , Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • ReadVehicleOrderAdditionals() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • ReadVehicleOrderPure() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • ReadVersions() : Isom.Context.Ecu , Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • ReadVin() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • RecalcPlanAfterReassembly() : Isom.Context.FutureVehicleContext
  • ReevaluateDataAvailability() : Isom.Plan.TherapyPlan , Isom.Plan.ActivationCode , Isom.Global.Controller , Isom.Global.Processes
  • ReleaseExclusive() : Isom.Context.LogicalVehicle
  • ReleaseKeyStore() : Isom.Security.SecurityProvider
  • Remove() : Isom.Base.StringList , Isom.Base.NumberList , Isom.Base.DataList , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Services.AsamParameter , Isom.Services.AsamParameterList , Isom.Plan.TherapyPlanActionList , Isom.Plan.TherapyPlan , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfoList , Isom.Exchange.DataExchange , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.VehicleOrder , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicleList
  • RemoveActionManually() : Isom.Global.Processes
  • RemoveAll() : Isom.Base.StringList , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicleList
  • RemoveAttribute() : Isom.Base.Data
  • RemoveByName() : Isom.Services.AsamParameter , Isom.Services.AsamParameterList
  • RemoveDataByCurrentVin() : Isom.Exchange.DataExchange
  • RemoveDictionary() : Isom.Exchange.DataExchange
  • RemoveElements() : Isom.Base.Data
  • RemoveFromDictionary() : Isom.Exchange.DataExchange
  • RemoveFromPlan() : Isom.Plan.TherapyPlanAction
  • RemoveGlobal() : Isom.Base.StringList , Isom.Base.String , Isom.Base.Number , Isom.Base.Data
  • RemoveMessage() : Isom.Plan.TherapyPlan
  • RemovePlanElement() : Isom.Global.Controller
  • RemoveSection() : Isom.Reporting.Report
  • RemoveSubsection() : Isom.Reporting.ReportSection
  • RemoveText() : Isom.Base.Data
  • Replace() : Isom.Base.String
  • ReplaceFirst() : Isom.Base.String
  • RequestKeyStore() : Isom.Security.SecurityProvider
  • Reset() : Isom.Base.StringList , Isom.Base.NumberList , Isom.Base.DataList , Isom.Sys.ContractList , Isom.Sys.ErrorList , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Services.AsamParameter , Isom.Services.EdiabasResultSetList , Isom.Services.AsamResponseList , Isom.Services.AsamParameterList , Isom.Request.ButtonList , Isom.Request.Measurement , Isom.Request.MeasurementList , Isom.Request.MediaList , Isom.Plan.TherapyPlanActionList , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfoList , Isom.Request.MessageList , Isom.Request.SelectionGroupList , Isom.Context.UserProfileOptionList , Isom.Reporting.ReportSectionList , Isom.Exchange.DataDescriptionList , Isom.Diagnostics.Measurement , Isom.Diagnostics.MeasurementList , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.UserProfileSettingList , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicleList
  • ResetFutureContext() : Isom.Context.FutureVehicleContext
  • ResetSequence() : Isom.Context.LogicalVehicleList
  • ResetServiceType() : Isom.Services.ServiceManager
  • ResetTimeout() : Isom.Services.Ediabas
  • RestartActionPlan() : Isom.Plan.ActionPlan
  • RestartTherapySession() : Isom.Global.Controller
  • RestoreCheckpoint() : Isom.Checkpoint.CheckpointProcesses
  • RestoreNativePlan() : Isom.Plan.TherapyPlan
  • Resume() : Isom.Plan.ActionPlan
  • ResumePreservedSession() : Isom.Plan.ActionPlan
  • RetainSession() : Isom.Services.Ediabas
  • Run() : Isom.Plan.TherapyPlanAction , Isom.Request.Wizard
  • RunAction() : Isom.Global.Controller , Isom.Global.Processes
  • RunProcess() : Isom.Context.Ecu , Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext , Isom.Context.LogicalVehicle

- S -

  • SaveIndividualData() : Isom.Checkpoint.VehicleCheckpoint
  • SaveVehicleInformation() : Isom.Checkpoint.VehicleCheckpoint
  • Search() : Isom.Base.String
  • Select() : Isom.Request.RadioButton , Isom.Request.SelectionGroup , Isom.Context.LogicalUnitList
  • SetAction() : Isom.Request.UserRequest
  • SetActivationCode() : Isom.Plan.TherapyPlanAction
  • SetApplicationNumber() : Isom.Plan.ActivationCode
  • SetAssemblingChildren() : Isom.Context.Ecu
  • SetAssemblingParent() : Isom.Context.Ecu
  • SetBaseVariant() : Isom.Context.Ecu
  • SetBuild() : Isom.Base.Version
  • SetBuildVersion() : Isom.Context.CurrentVehicleContext
  • SetButtons() : Isom.Request.UserRequest
  • SetCanRunOnly() : Isom.Plan.TherapyPlanAction
  • SetCategory() : Isom.Context.LogicalUnit
  • SetCertificate() : Isom.Plan.ActivationCode
  • SetCodeData() : Isom.Plan.ActivationCode
  • SetCodingSequence() : Isom.Context.Ecu
  • SetComment() : Isom.Plan.TherapyPlanAction
  • SetContentTitle() : Isom.Request.Wizard
  • SetContinueOnError() : Isom.Plan.TherapyPlanAction
  • SetContinueWithEcuOnError() : Isom.Plan.TherapyPlanAction
  • SetCurrentContextToSavedContext() : Isom.Checkpoint.VehicleRestore
  • SetCurrentOemVersion() : Isom.Context.FutureVehicleContext
  • SetCurrentVersion() : Isom.Context.CurrentVehicleContext
  • SetDataImportIndex() : Isom.Request.MessageElement
  • SetDataIntegrationLevel() : Isom.Context.ContextConfiguration
  • SetDataType() : Isom.Services.AsamParameter , Isom.Exchange.DataDescription
  • SetDate() : Isom.Reporting.ReportSection
  • SetDefaultLChannels() : Isom.Context.ContextConfiguration
  • SetDependantActionsToRefilter() : Isom.Plan.TherapyPlanAction
  • SetDependantActionsToRemove() : Isom.Plan.TherapyPlanAction
  • SetDescription() : Isom.Request.Wizard
  • SetDescriptionTitle() : Isom.Request.Wizard
  • SetDiagName() : Isom.Context.Ecu
  • SetDisplayProp() : Isom.Context.Ecu , Isom.Plan.TherapyPlanAction , Isom.Reporting.ReportSection , Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext , Isom.Context.LogicalVehicle
  • SetDisplayState() : Isom.Plan.TherapyPlanAction
  • SetDisplayType() : Isom.Request.Measurement , Isom.Diagnostics.Measurement
  • SetDtc() : Isom.Context.Ecu
  • SetDtcNumber() : Isom.Context.Dtc
  • SetEcu() : Isom.Plan.TherapyPlanAction , Isom.Request.UserRequest , Isom.Reporting.ReportSection
  • SetEcus() : Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext , Isom.Context.LogicalVehicle
  • SetError() : Isom.Reporting.ReportSection
  • SetEstimatedRuntime() : Isom.Plan.TherapyPlanAction
  • SetExecutedByIsom() : Isom.Plan.TherapyPlanAction
  • SetExecutionOrder() : Isom.Global.Processes
  • SetExecutionOrderGroup() : Isom.Plan.ActionPlan
  • SetExecutionOrders() : Isom.Plan.ActionPlan
  • SetFileName() : Isom.Sys.Protocol
  • SetFlashFlags() : Isom.Plan.TherapyPlanAction
  • SetGroupName() : Isom.Context.Ecu
  • SetHeading() : Isom.Request.Measurement , Isom.Request.SelectionGroup , Isom.Diagnostics.Measurement
  • SetHelp() : Isom.Request.Wizard
  • SetHelpTitle() : Isom.Request.Wizard
  • SetHint() : Isom.Plan.OrderingInfo , Isom.Request.RadioButton
  • SetHistoricalVersion() : Isom.Context.CurrentVehicleContext
  • SetIndices() : Isom.Exchange.DataDescription
  • SetKey() : Isom.Context.LogicalUnit
  • SetLabelButtonBack() : Isom.Request.Wizard
  • SetLabelButtonDone() : Isom.Request.Wizard
  • SetLabelButtonNext() : Isom.Request.Wizard
  • SetLabelButtonQuit() : Isom.Request.Wizard
  • SetLayoutType() : Isom.Request.UserRequest , Isom.Request.Wizard
  • SetLogicalUnits() : Isom.Context.Ecu , Isom.Plan.TherapyPlanAction
  • SetLogicalVehicles() : Isom.Plan.TherapyPlanAction
  • SetMajor() : Isom.Base.Version
  • SetManuallyPlanned() : Isom.Plan.TherapyPlanAction
  • SetMax() : Isom.Request.MeasuredValue , Isom.Diagnostics.MeasuredValue
  • SetMeasurement() : Isom.Request.Wizard
  • SetMeasurements() : Isom.Request.UserRequest
  • SetMedia() : Isom.Request.UserRequest , Isom.Request.Wizard
  • SetMediaElement() : Isom.Reporting.ReportSection
  • SetMediaTitle() : Isom.Request.Wizard
  • SetMedium() : Isom.Plan.OrderingInfo
  • SetMediumDescription() : Isom.Plan.OrderingInfo
  • SetMessage() : Isom.Request.RadioButton , Isom.Request.Wizard
  • SetMessages() : Isom.Request.UserRequest
  • SetMin() : Isom.Request.MeasuredValue , Isom.Diagnostics.MeasuredValue
  • SetMinor() : Isom.Base.Version
  • SetModelSeries() : Isom.Context.ContextConfiguration , Isom.Context.VehicleOrder
  • SetModelSeriesGroup() : Isom.Context.ContextConfiguration
  • SetModelSeriesRevision() : Isom.Context.ContextConfiguration
  • SetName() : Isom.Services.AsamParameter
  • SetNamespaces() : Isom.Base.Data
  • SetNChannelEnforcedSequential() : Isom.Context.ContextConfiguration
  • SetNewLineOnXmlAttribute() : Isom.Base.Data
  • SetNext() : Isom.Request.Wizard
  • SetOdometer() : Isom.Context.CurrentVehicleContext
  • SetOem() : Isom.Context.ContextConfiguration
  • SetOrderingInfo() : Isom.Context.LogicalUnit
  • SetOrderingInfoList() : Isom.Plan.TherapyPlanAction
  • SetOrderList() : Isom.Plan.ActionPlan
  • SetOrderNumber() : Isom.Plan.OrderingInfo
  • SetPath() : Isom.Request.MediaElement
  • SetPeriod() : Isom.Sys.Events.Guard
  • SetPhase() : Isom.Plan.TherapyPlanAction
  • SetPossibleLChannels() : Isom.Plan.TherapyPlanAction
  • SetPostCodingDelay() : Isom.Context.Ecu
  • SetPreferredService() : Isom.Services.ServiceManager
  • SetPriority() : Isom.Plan.TherapyPlanAction
  • SetProp() : Isom.Context.Ecu , Isom.Plan.TherapyPlanAction , Isom.Security.SecurityProvider , Isom.Plan.ActionPlan , Isom.Plan.ActivationCode , Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.FutureVehicleContext , Isom.Context.LogicalUnit , Isom.Context.LogicalVehicle
  • SetProperties() : Isom.Context.VehicleOrder
  • SetQuit() : Isom.Request.Wizard
  • SetRemoveable() : Isom.Plan.TherapyPlanAction
  • SetRequired() : Isom.Exchange.DataDescription
  • SetRevision() : Isom.Base.Version
  • SetSelectionGroups() : Isom.Request.UserRequest
  • SetSeparator() : Isom.Reporting.ReportSection
  • SetSequence() : Isom.Plan.TherapyPlanAction , Isom.Context.LogicalVehicleList
  • SetServiceType() : Isom.Services.ServiceManager
  • SetState() : Isom.Context.Ecu , Isom.Plan.TherapyPlanAction , Isom.Context.LogicalUnit
  • SetSuggestions() : Isom.Request.MessageElement
  • SetTargetVersion() : Isom.Context.FutureVehicleContext , Isom.Context.LogicalVehicle
  • SetTemplate() : Isom.Reporting.ReportSection , Isom.Reporting.Report
  • SetText() : Isom.Base.Data , Isom.Request.Option , Isom.Reporting.ReportSection
  • SetTextCategory() : Isom.Base.String
  • SetTextId() : Isom.Base.String
  • SetTherapyPlanAction() : Isom.Reporting.ReportSection
  • SetTimeout() : Isom.Services.Ediabas
  • SetTimer() : Isom.Request.UserRequest
  • SetTitle() : Isom.Request.UserRequest , Isom.Request.Wizard , Isom.Reporting.ReportSection , Isom.Reporting.Report
  • SetUnit() : Isom.Request.MeasuredValue , Isom.Diagnostics.MeasuredValue
  • SetUpdateFunction() : Isom.Request.Wizard
  • SetUpgradeIndex() : Isom.Plan.ActivationCode
  • SetUri() : Isom.Request.MessageElement
  • SetUserProfileOptionAsCurrent() : Isom.Context.UserProfileOptionList
  • SetUserProfileSetting() : Isom.Reporting.ReportSection
  • SetValue() : Isom.Services.AsamParameter , Isom.Request.MeasuredValue , Isom.Diagnostics.MeasuredValue
  • SetVehicleGeneration() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle
  • SetVehicleOrder() : Isom.Context.CurrentVehicleContext
  • SetVersion() : Isom.Context.LogicalUnit
  • SetVin17() : Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext
  • SetWizardNext() : Isom.Request.RadioButton
  • ShowAsMessageBox() : Isom.Plan.ActionPlan
  • ShowRequest() : Isom.Request.UserRequest
  • ShowWizard() : Isom.Request.Wizard
  • SignalUserInteractionsDone() : Isom.Plan.ActionPlan
  • Sort() : Isom.Base.StringList
  • Split() : Isom.Base.String
  • StartPlanPhase() : Isom.Global.Processes
  • Stderr() : Isom.Sys.System
  • Stdin() : Isom.Sys.System
  • Stdout() : Isom.Sys.System
  • StopIsom() : Isom.Global.Controller
  • Store() : Isom.Exchange.DataExchange
  • StoreActivationCode() : Isom.Context.Ecu
  • StoreAndEnableActivationCode() : Isom.Context.Ecu
  • StoreDictionary() : Isom.Exchange.DataExchange
  • StoreVehicleOrder() : Isom.Context.Ecu
  • Sub() : Isom.Base.Number
  • Substring() : Isom.Base.String
  • Success() : Isom.Sys.Log

- T -

  • TerminateIsom() : Isom.Global.Controller
  • ToBytes() : Isom.Base.String
  • ToFloatString() : Isom.Base.Number
  • ToHexString() : Isom.Base.Number
  • ToIntString() : Isom.Base.Number
  • ToLocalTime() : Isom.Base.Date
  • ToLocalTimeFormatted() : Isom.Base.Date
  • ToLower() : Isom.Base.String
  • ToString() : Isom.Context.VehicleOrder
  • ToUniversalTime() : Isom.Base.Date
  • ToUniversalTimeFormatted() : Isom.Base.Date
  • ToUpper() : Isom.Base.String
  • ToXml() : Isom.Base.Data

- U -

  • UpdateContext() : Isom.Context.Ecu
  • UpdateCurrentContextEcus() : Isom.Global.Processes
  • UpdateCurrentContextVehicleData() : Isom.Global.Processes
  • UpdateDictionary() : Isom.Exchange.DataExchange
  • UpdateMeasurement() : Isom.Request.UserRequest
  • UpdateMessage() : Isom.Request.UserRequest
  • UpdateRequest() : Isom.Request.UserRequest
  • UserProfileChanged() : Isom.Context.CurrentVehicleContext , Isom.Context.LogicalVehicle

- V -

  • Verify() : Isom.Services.DataProcurement
  • Void() : Isom.Base.Version , Isom.Base.UriDictionary , Isom.Base.Uri , Isom.Base.StringList , Isom.Base.StringDictionary , Isom.Base.String , Isom.Base.RegEx , Isom.Base.NumberList , Isom.Base.Number , Isom.Base.Date , Isom.Base.DataList , Isom.Base.Data , Isom.Base.Boolean , Isom.Sys.ClientData , Isom.Sys.Contract , Isom.Sys.ContractList , Isom.Sys.Dealer , Isom.Context.Ecu , Isom.Plan.TherapyPlanAction , Isom.Sys.Error , Isom.Sys.ErrorList , Isom.Sys.SessionContext , Isom.Sys.RuntimeInfo , Isom.Sys.FunctionInfo , Isom.Sys.ClientDataList , Isom.Sys.CallProfile , Isom.Sys.Events.EventInfo , Isom.Sys.Events.EventListener , Isom.Sys.Events.Guard , Isom.Sys.Events.GuardInfo , Isom.Sys.Events.PeriodicTimer , Isom.Sys.Events.Timer , Isom.Sys.Events.TimerInfo , Isom.Services.AsamParameter , Isom.Services.EdiabasResultSet , Isom.Services.EdiabasResultSetList , Isom.Services.AsamResponseList , Isom.Services.AsamParameterList , Isom.Security.SecurityProvider , Isom.Request.Button , Isom.Request.ButtonList , Isom.Request.MeasuredValue , Isom.Request.Measurement , Isom.Request.MeasurementList , Isom.Request.MediaElement , Isom.Request.MediaList , Isom.Plan.TherapyPlanActionList , Isom.Plan.TherapyPlan , Isom.Plan.ActionPlanPhase , Isom.Plan.ActionPlan , Isom.Plan.ActivationCode , Isom.Plan.ActivationCodeList , Isom.Plan.OrderingInfo , Isom.Plan.OrderingInfoList , Isom.Request.MessageElement , Isom.Request.MessageList , Isom.Request.Option , Isom.Request.RadioButton , Isom.Request.SelectionGroup , Isom.Request.SelectionGroupList , Isom.Request.UserRequest , Isom.Request.Wizard , Isom.Context.UserProfileOption , Isom.Context.UserProfileOptionList , Isom.Context.UserProfileSetting , Isom.Reporting.ReportSection , Isom.Reporting.ReportSectionList , Isom.Reporting.Report , Isom.Global.Controller , Isom.Exchange.DataDescription , Isom.Exchange.DataHandle , Isom.Exchange.DataExchange , Isom.Exchange.DataDescriptionList , Isom.Diagnostics.MeasuredValue , Isom.Diagnostics.Measurement , Isom.Diagnostics.MeasurementList , Isom.Context.ContextConfiguration , Isom.Context.CurrentVehicleContext , Isom.Context.Dtc , Isom.Context.DtcList , Isom.Context.EcuList , Isom.Context.Environment , Isom.Context.VehicleOrder , Isom.Context.UserProfileSettingList , Isom.Context.UserProfile , Isom.Context.FutureVehicleContext , Isom.Context.LogicalUnit , Isom.Context.LogicalUnitList , Isom.Context.LogicalVehicle , Isom.Context.LogicalVehicleList , Isom.Checkpoint.VehicleCheckpoint , Isom.Checkpoint.VehicleRestore

- W -

  • Wait() : Isom.Sys.System
  • WaitUserRequest() : Isom.Request.UserRequest
  • WaitWizard() : Isom.Request.Wizard
  • Warning() : Isom.Sys.Log
  • WriteXml() : Isom.Base.Data

- X -

  • Xor() : Isom.Base.Number , Isom.Base.Boolean


für Serviceautoren

Liste der Annotationen

Hier folgt die Übersicht aller definierten Annotationen.

Annotationen für Namensräume

Annotation | Beschreibung
ActionDependency | Definiert bedingende und abhängige Aktionen
Version | Gibt die Version der ISOM/L-Programme an.
EditableAction | Definiert eine Fahrzeugaktion.
EditableEcuAction | Definiert eine Steuergeräteaktion.
ActionText | Legt den Anzeigenamen einer Aktion fest.
ActionSymbol | Legt das Symbol für eine Aktion fest.
ActionPlanGroup | Legt die Aktionsplangruppe für eine Aktion fest. (Die Aktionsplangruppe wird bei Ermittlung der Ausführungsreihenfolge benötigt.)
ActionLogicalVehicle | Legt das logische Fahrzeug für die Ausführung der Aktion fest.
EcuText | Legt den Anzeigenamen eines Steuergeräts fest.
ContinueOnError | Gibt an, ob der Plan nach einem Fehler in einer Aktion fortgesetzt werden soll.
ContinueWithEcuOnError | Gibt an, ob nach einem Fehler in einer steuergerätebezogenen Aktion weitere Aktionen für dieses Steuergerät ausgeführt werden dürfen.
ContextTerm | Definiert ein Makro, das in Sichtbarkeitstermen verwendet werden kann.
PossibleLChannels | Legt die zulässigen L-Kanäle fest.
AutoCalculateEstimatedRuntime | Gibt an, ob die Ausführungszeitprognose bei jeder Planänderung zu aktualisieren ist.
AutoRetainLogisticsConsistency | Gibt an, ob die Logistikinformation bei jeder Planänderung zu aktualisieren ist.
PreferredService | Gibt den bevorzugt zu verwendenden Fachdienst an.
ServiceType | Legt den zulässigen Fachdienst fest.

Annotationen für Funktionen

Annotation | Beschreibung
HandleServiceInitializationErrors | Gibt an, dass Fehler in der Fachdienstinitialisierung vom Serviceautor behandelt werden.
PossibleLChannels | Legt die zulässigen L-Kanäle fest.
EnforceSequential | Gibt an, ob die Aktion sequentiell ausgeführt werden muss.
ContinueOnError | Gibt an, ob der Plan nach einem Fehler in einer Aktion fortgesetzt werden soll.
ContinueWithEcuOnError | Gibt an, ob nach einem Fehler in einer steuergerätebezogenen Aktion weitere Aktionen für dieses Steuergerät ausgeführt werden dürfen.
ExecuteAfterError | Gibt an, dass die Funktion auch nach einem Fehler in einer vorangegangenen Aktion ausgeführt werden kann.
ExecuteAfterEcuError | Gibt an, dass die Funktion auch nach einem Fehler in einer vorangegangenen steuergerätebezogenen Aktion ausgeführt werden kann.
AutoCalculateEstimatedRuntime | Gibt an, ob die Ausführungszeitprognose bei jeder Planänderung zu aktualisieren ist.
AutoRetainLogisticsConsistency | Gibt an, ob die Logistikinformation bei jeder Planänderung zu aktualisieren ist.
PreferredService | Gibt den bevorzugt zu verwendenden Fachdienst an.
ServiceType | Legt den zulässigen Fachdienst fest.
ContainsUserInteraction | Gibt an, dass die Funktion Benutzerinteraktionen im regulären Ausführungspfad enthält.
Timer | Startet einen Zeitgeber, der für die Ausführungsdauer der Funktion aktiv ist.
PeriodicTimer | Startet einen periodischen Zeitgeber, der für die Ausführungsdauer der Funktion aktiv ist.
Event | Legt ein Ereignis fest, das während der Funktionsausführung auftreten kann.
Guard | Legt einen Wächter für Umgebungswerte fest, der während der Funktionsausführung aktiv ist.
MenuItem | Definiert einen Menüeintrag.
MenuText | Legt den Anzeigenamen eines Menüeintrags fest.
EnforceLogicalVehicle | Erzwingt die Verwendung eines logischen Fahrzeugs für Fachdienstzugriffe und vermeidet Kanalumschaltungen.


für Serviceautoren

Zusätzliche Informationen

Hier folgt eine Liste mit zusammengehörigen Themengebieten:
  • ISOM-Phasenmodell
  • Zeichenkettenkonstanten
  • Veraltete oder entfernte Elemente